FieldWorks data model

FieldWorks is a suite of integrated language research software applications. This help file contains the documentation for the FieldWorks data model. The data model is expressed in the Unified Modeling Language. For more information about UML refer to: http://www.uml.org/

To use this help file, click on the Diagrams link in the top left frame. Select a diagram from the bottom left frame. Start with the ***Legend diagram for some brief explanation.

Classes can be clicked on in class diagrams to get full documentation on the class.

For more information, contact Larry Hayashi at larry_hayashi@sil.org.

Diagrams and documentation produced using MagicDraw ( http://www.magicdraw.com ).
This model is used to generate a SQL database.


Or use button on each attribute for individual documentation display (if any).

num: abbrev: abstract: false module: Cellar(num:0) base:

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


ChkRef

test num:116 | abbrev: chkr | abstract: false | module: Ling(num:5) | base: CmObject
 | This object contains details about an occurrence of a ChkTerm in the original text so the user can see where a rendering of that term is supposed to exist, as well as information about the actual rendering in the vernacular text.The Ref, Location, and KeyWord fields together comprise a unique key that can be used if necessary to associate this object with a node in a similar list which is organized differently.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | KeyWord | 2 | String |
 | In the Biblical Terms list, this will contain the specific Greek or Hebrew word(s) in the original text, though not necessarily the surface (i.e., inflected) form. This may be useful to display for the user. Together with the Ref and Location, this might be useful for associating existing ChkRef objects with ChkTerms in a list that is being restructured according to a new system of organization.
test Basic | Location | 6 | Integer |
 | Information about the location of the ChkTerm in the original source text (for Scripture terms, the 1-based index of the word in the verse in the original language). Leave as 0 if not needed.
test Basic | Ref | 1 | Integer |
 | Index to a target text unit. For Scripture the BCV (book/chapter/verse) reference in the English versification.
test Basic | Status | 4 | Integer |
 | Checking status for this item (as defined by the reference-keyword).

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Rendering | 5 | atomic | WfiWordform
 | The target vernacular rendering of the checking item at this reference.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | ChkTerm:Occurrences | 1 | sequence | ChkRef
 | List of references where this checking item needs to be checked. E.g., a list of scripture references where a specific sense of a key term needs to be checked.


ChkRendering

test num:126 | abbrev: chkg | abstract: false | module: Ling(num:5) | base: CmObject
 | Represents a rendering (i.e. vernacular equivalent) for a term. This class exists to allow a single place where users can identify the specific gloss for each unique rendering of a key term or name and record an explanation about the rendering decision.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Explanation | 3 | MultiUnicode |
 | An optional short explanation of why this rendering was chosen to render the term.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Meaning | 2 | atomic | WfiGloss
 | The literal meaning of the vernacular term or phrase used for rendering the ChkTerm. This will be displayed as the back translation of the vernacular rendering. This is optional, but when supplied (by the user) must be one of the glosses for one of the senses of the SurfaceForm.
test Refer | SurfaceForm | 1 | atomic | WfiWordform
 | A vernacular wordform that occurs in the text and is a valid equivalent for rendering the term that owns this ChkRendering object. This is required to be filled in when a ChkRendering is created.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | ChkTerm:Renderings | 3 | collection | ChkRendering
 | Represents the renderings (i.e. vernacular equivalents) for a term. A ChkRendering is added whenever a rendering is ascribed to a ChkRef for which a ChkRendering does not already exist in this collection.


ChkSense

test num:121 | abbrev: chks | abstract: false | module: Ling(num:5) | base: CmObject
 | Relates a check item to a particular lexical sense of a lexical item. Stores explanatory information about this relationship. From this sense other information about the lexeme can be inferred, such as the lexical stem or the citation form. The lexical item may be inflected but the inflection is not pertinent to the check item. (If a specific inflection with a special sense is needed, add a lexical entry for the specific inflection as a subentry of the more general lexical item and add the special sense to this subentry.) Needed by Key Terms checking and other semantically-based checklists.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Explanation | 1 | MultiUnicode |
 | A short explanation of the relationship of the lexical sense to the check item. For example, in the Key Terms list, may add an additional explanation of why the lexical item is chosen to render the key term, beyond the definition given for the Sense.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Sense | 2 | atomic | LexSense
 | In Scripture, a target lexical sense for a key term. More generically, a lexical sense associated with a checklist item. With the LexSense as a starting point, the stem, citation form, literal meaning, definition, gloss and likely inflectional word forms for the rendering can be determined. Note that we do not determine the lexical stem directly but rather make a semantic connection to it through the particular sense of the stem that is relevant to the ChkItem. We can always determine the stem from the sense but not vice versa.

Back references (sorted by attribute name)

Type Name Num Card Sig


ChkTerm

test num:125 | abbrev: chkt | abstract: false | module: Ling(num:5) | base: CmPossibility
 | List item for a term to be checked for proper rendering to an equivalent term or terms for one or more references in a vernacular text. The CmPossibility.Name field will contain the Lemma form of the term in the original language (i.e., Greek or Hebrew) in the grc or heb alternative. ("grc" and "heb" are the ICU locales.) The primary English gloss would be in the en alternative, and glosses in other localizations would be stored in their respective alternatives. Since terms will often have multiple vernacular equivalents, and we need to be able to store literal back translations for those, the Name will not be used for vernacular equivalents. The CmPossibilty.Description can contain additional information about the term in the analysis language(s). It might also contain a list of other derived forms of the term in the original language.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | SeeAlso | 2 | MultiUnicode |
 | Alternate glosses (in UI/analysis writing systems) that should appear in the list of terms (when sorted/grouped by gloss). Multiple glosses are separated by semi-colons.
test Basic | TermId | 4 | Integer |
 | A fixed identifier that matches the term in one or more external source files (e.g., BiblicalTerms.xml, localizations of that file, and/or files that link terms to semantic domains) to uniquely identify the term so it can be correctly matched (and updated, etc.) from the right entry in the external files. This can also be used to obtain a consistent secondary sort when two key terms have identical Lemma forms and/or glosses.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Occurrences | 1 | sequence | ChkRef
 | List of references where this checking item needs to be checked. E.g., a list of scripture references where a specific sense of a key term needs to be checked.
test Owning | Renderings | 3 | collection | ChkRendering
 | Represents the renderings (i.e. vernacular equivalents) for a term. A ChkRendering is added whenever a rendering is ascribed to a ChkRef for which a ChkRendering does not already exist in this collection.

Back references (sorted by attribute name)

Type Name Num Card Sig


CmAgent

test num:23 | abbrev: laag | abstract: false | module: Cellar(num:0) | base: CmObject
 | A human or computational analysis agent associated with various linguistic analyses. Currently (Jan, 2002) are used only by the morphological parsing system for words. Using agents, the system stores whether or not a particular word parse is validated by the lexicon and the state of the word grammar. The UI will allow the user to also create word parses manually (thus a human agent) or to indicate to the system that he, the user, has verified a computational parse.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Human | 3 | Boolean |
 | T = human, F = computational agent.
test Basic | Name | 1 | MultiUnicode |
 | Arbitrary name of the agent. Examples: Larry, AMPLE, XEROXParser, HermitCrab.
test Basic | StateInformation | 2 | Unicode |
 | Defines what constraint groups are turned off. (Example: in morphological parsing we might turn off a set of rules). It is represented as XML and is empty unless the morphological system is in debug mode. We have not yet determined the nature of the XML representation (Jan 17, 2002).
test Basic | Version | 5 | Unicode |
 | This attribute is not finalized but for now possible values include:Normal - represents the parser using the current state of the grammar and lexicon. Debug - represents the parser using a limited grammar (user has turned off some group of constraints) Milestone - represents the parser using a particular grammar and lexicon at a particular time as recorded on CmObject (date created). Works in conjunction with StateInformation.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Approves | 7 | atomic | CmAgentEvaluation
 | The agent evaluation which objects being evaluated refer to in order to indicate that this agent approves or accepts them.
test Owning | Disproves | 8 | atomic | CmAgentEvaluation
 | The agent evaluation which objects being evaluated refer to in order to indicate that this agent disapproves or does not accept them.
Owning | Notes | 4 | atomic | StText

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | MoMorphData:AnalyzingAgents | 5 | collection | CmAgent
test Owned by | LangProject:AnalyzingAgents | 38 | collection | CmAgent
 | At this point, in time (Jan, 2002) CmAnalyzingAgents are used only by MoMorphological data. Refer to CmAnalyzingAgent for more info.
test Refer'd by | CmAnnotation:Source | 4 | atomic | CmAgent
 | Who made this annotation. If a computer parser, the agent will be that parser.


CmAgentEvaluation

num:32 abbrev: caev abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Evaluations | 14 | collection | WfiAnalysis
 | Refers to either the Approves or Disapproves evaluations of various agents to indicate that the agent does or does not approve this analysis.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | CmAgent:Approves | 7 | atomic | CmAgentEvaluation
 | The agent evaluation which objects being evaluated refer to in order to indicate that this agent approves or accepts them.
test Owned by | CmAgent:Disproves | 8 | atomic | CmAgentEvaluation
 | The agent evaluation which objects being evaluated refer to in order to indicate that this agent disapproves or does not accept them.


CmAnnotation

test num:34 abbrev: anno abstract: true module: Cellar(num:0) base: CmObject
The user can annotate another object in any number of ways. An annotation represents some level of analysis or tagging on a object or fragment of an object (a portion of text, or a media file). Analyses can include a freeform comment, a tag from a tag list, a featureStructure or combination of the above. There are two particular uses of this object that we are thinking of right now: a. tagging texts or media files with various types of annotations (OCM, grammatical, semantic, etc.) and b. tagging objects with system level annotations ... for example, parses with "incomplete analysis". This model is extremely generalized and it may be that we need to add subclasses for specialized behaviours. We may want to subclass the current Annotation class to make lighter annotation classes. For example, EndObject and OtherObjects might go on a "MultiObjectAnnotation". TextWordformInContext (which has been removed from the model ... we may perhaps need a subclass) will definitely not care about the endObject. The majority of annotations won't need an EndObject ... only those that span multiple paragraphs. For now, Annotations are ownerless. Might need to have it owned by LangProject for cache purposes. Question: Can an annotation point to two or more objects from different projects? At this point it cannot cross databases because we would need an attribute for the database itself.

Direct Subclasses

  • CmIndirectAnnotation
  • CmBaseAnnotation
  • CmMediaAnnotation

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Comment | 2 | MultiString-big |
 | Not sure what the signature here should be yet. multiBigString, multiUnicode, StText? <p> Probably, in most cases, only BigString will be needed.
test Basic | CompDetails | 1 | Unicode-big |
 | Data stored and used by specialized computer agents (e.g. computational parsers) in the FieldWorks system. Most likely will be stored in XML format.
test Basic | DateCreated | 9 | Time |
 | Date stamp for when this annotation was created, for display to the user. This may differ from the internally generated timestamp that is used for record locking and conflict detection.
test Basic | DateModified | 10 | Time |
 | Date and time that this annotation was last modified, for display to the user and for use by automated checking tools. Allows explicit tracking of relevent modifications versus the automatic date stamp created by the database engine.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | AnnotationType | 3 | atomic | CmAnnotationDefn
 | An annotation is of a particular type. The AnnotationDefn defines possible behaviors for an annotation.
test Refer | InstanceOf | 6 | atomic | CmObject
 | Annotations, in many cases, are tags from a predefined list of objects. We might want to mark up a text for OCM codes. A particular annotation in context may tag an instance of OCM code 152. WordformsInContext are tagged with Wordforms found in the WordformInventory.
test Refer | Source | 4 | atomic | CmAgent
 | Who made this annotation. If a computer parser, the agent will be that parser.
Owning | Features | 8 | atomic | FsFeatStruc
test Owning | Text | 7 | atomic | StText
 | To handle multiparagraph annotations.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:Annotations | 44 | collection | CmAnnotation
Refer'd by | CmIndirectAnnotation:AppliesTo | 1 | sequence | CmAnnotation


CmAnnotationDefn

test num:35 | abbrev: annd | abstract: false | module: Cellar(num:0) | base: CmPossibility
 | In all likelyhood, a subclass of CmPossibility. Defines a possible type of annotation.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | AllowsComment | 3 | Boolean |
 | True = user can type in a comment associated with the Annotation. False = user cannot type in a comment. Example: a user may tag a section of text with OCM 152 but also want to provide a comment as to why he tagged it in this way.
test Basic | AllowsFeatureStructure | 4 | Boolean |
 | T = Annotation can carry a FsFeatStruc.
test Basic | AllowsInstanceOf | 5 | Boolean |
 | T = Annotation can be selected from a list of instances of a particular CmObject. Example: OCM annotations are contextual instances of the AnthroList items.
test Basic | CanCreateOrphan | 8 | Boolean |
 | When the objects an Annotation refers to are deleted: T = Keep Annotation F = Delete Annotation For some types of annotations we may want the annotation to persist, even though the object it annotates no longer exists. What happens to an annotation when the object it annotates disappears: 1. If the object it points to goes away, get rid of the annotation. 2. If the range becomes empty the Annotation goes away. QUESTIONS: 3. If something gets deleted at the beginning or the end, do you jump right or left? 4. If an object is owned by another object, do you move the annotation to the owner? Refer to http://mpj.cx/twiki/bin/view.pl/Wordworks/Mar2003OutcomesMinutesDiscussions for further discussion.
test Basic | CopyCutPastable | 10 | Boolean |
 | T = annotations of this type are copied and pasted when their annotated object is copied and pasted. F = these types of annotations are NOT copied along with their annotation object.
test Basic | InstanceOfSignature | 6 | Integer |
 | ClassDefn id from metatable. States that this AnnotationDefn allows instances of a particular class.
test Basic | MaxDupOccur | 14 | Integer |
 | The user should be able to set the limit of each type of checking error, as appropriate for each project and stage. MaxDupOccur stores how many "duplicate" errors are allowed for each type of check. Other types of annotations could use this if it's useful. ("Duplicates" would be defined differently for different types of annotations.)
test Basic | Multi | 12 | Boolean |
 | Indicates whether this annotation type needs "multi" capabilities. Also need to indicate which encodings to offer the user. Vernacular, Analysis, etc.
test Basic | PromptUser | 9 | Boolean |
 | Should the user be prompted before annotated object is deleted? T = Prompt user. F = Delete without prompt.
test Basic | Severity | 13 | Integer |
 | For example, we may want to indicate the following with visual cues. Severity: 0 = NA 1 = Critical 2 = Problem 3 = Warning 4 = Suggestion User
test Basic | UserCanCreate | 7 | Boolean |
 | Perhaps the only reason for this attribute is so that we can limit the AnnotationDefns displayed in a GUI that the user selects from. Perhaps it is better to use a boolean: <p> UserCanCreate: T | F
test Basic | ZeroWidth | 11 | Boolean |
 | T = Annotations of this type are have the same Begin and EndOffset and thus zeroWidth. Potential example: footnotes markers.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | CmAnnotation:AnnotationType | 3 | atomic | CmAnnotationDefn
 | An annotation is of a particular type. The AnnotationDefn defines possible behaviors for an annotation.
Refer'd by | ScrMarkerMapping:NoteType | 11 | atomic | CmAnnotationDefn
Refer'd by | ScrImportSource:NoteType | 2 | atomic | CmAnnotationDefn


CmAnthroItem

num:26 abbrev: anit abstract: false module: Cellar(num:0) base: CmPossibility

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | WordFormLookup:AnthroCodes | 5 | collection | CmAnthroItem
Refer'd by | LexSense:AnthroCodes | 2 | collection | CmAnthroItem
test Refer'd by | RnGenericRec:AnthroCodes | 7 | collection | CmAnthroItem
 | OcmCodes - User applies OCM tags to this particular record.April 5, 2001 - The following documentation needs to be updated.This is where the user applies tagging at the scope of the entire record. Tags will be to such lists as the FRAME (the modified Outline of Cultural Materials), a grammar outline, and numerous other outlines that will be included with the system. After doing this tagging, the user will be able to quickly find all records that pertain to a particular topic. (In the user interface, we will provide mechanisms to facilitate fast tagging, including choosing which outline to tag from.)
test Refer'd by | CmSemanticDomain:OcmRefs | 3 | collection | CmAnthroItem
 | For those that do have an OCM list, we will set links to the appropriate items. We anticipate our program establishing these links when the OCM list is added to the database.


CmBaseAnnotation

num:37 abbrev: bann abstract: false module: Cellar(num:0) base: CmAnnotation

Direct Subclasses

  • ScrScriptureNote

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | BeginOffset | 1 | Integer |
 | For Annotations that annotate a text string fragment or a media file fragment, we set the BeginOffset and EndOffset.
test Basic | BeginRef | 10 | Integer |
 | For Scripture use, this will be used to store begin Scripture references. The int actually encodes book, chapter, and verse for Consultant Notes, Translator Notes, Change History Notes, etc. The attribute is available for other uses in other applications.
test Basic | EndOffset | 4 | Integer |
 | See BeginOffset.
test Basic | EndRef | 11 | Integer |
 | For Scripture use, this will be used to store end Scripture references. The int actually encodes book, chapter, and verse for Consultant Notes, Translator Notes, Change History Notes, etc. The attribute is available for other uses in other applications.
test Basic | Flid | 3 | Integer |
 | An annotation knows what it is annotating through the BeginObject reference attribute and the Begin and EndOffsets. For those annotations that are not on objects themselves but data within the object, we we need to identify which attribute holds the data through the field id (abbrev: FLID) found in the FieldWorks RDBMS.
Basic | WritingSystem | 8 | Unicode |
test Basic | WsSelector | 9 | Integer |
 | Refer to documentation on CmPossibilityList_WsSelector.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | BeginObject | 5 | atomic | CmObject
Refer | EndObject | 6 | atomic | CmObject
Refer | OtherObjects | 7 | collection | CmObject

Back references (sorted by attribute name)

Type Name Num Card Sig


CmCell

num:11 abbrev: fcel abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Contents | 1 | String |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | CmRow:Cells | 1 | sequence | CmCell


CmCustomItem

test num:27 | abbrev: cci | abstract: false | module: Cellar(num:0) | base: CmPossibility
 | Purpose is to allow users to add custom fields to custom lists without affecting standard lists.Since these lists are global in a database (since we are modifying the Field$ table) they can't be owned by a language project, so custom lists will be another unowned object.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


CmDomainQ

test num:67 | abbrev: doq | abstract: false | module: Cellar(num:0) | base: CmObject
 | Was CmDomainQuestion

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | ExampleSentences | 3 | MultiString |
 | Example: (Ron Moe's Standard Format): \xe We got up before <dawn>... A list of sample sentences illustrating words elicited from this question. The illustrated word may be bolded. We may have sentences in more than one language. If there are multiple sentences, they are all placed in the same string.
test Basic | ExampleWords | 2 | MultiUnicode |
 | Example: (Ron Moe's Standard Format): \ex air, aerial, airspace, atmosphere A list of sample words in this category. The list may be in English or other languages (e.g., \exf). The words are comma delimited. They are not formatted and they do not have any embedded languages. These words may be used when searching for possible domains for a sense based on the sense gloss. If this process is too slow, we may need to go to separate wordform lists, but we are hoping that complexity will not be necessary.
test Basic | Question | 1 | MultiUnicode |
 | Example: (Ron Moe's Standard Format): \qu (2) What words refer... The question is not formatted and has no embedded languages. It is multi because we may have translations in other languages (e.g., \quf are French translations).

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | CmSemanticDomain:Questions | 5 | sequence | CmDomainQ
 | Each domain has a list of questions used to elicit words. Each question has sample words and sentences, so we group these together into CmDomainQ. The domain then owns a sequence of these. They need to be ordered since important questions come first.


CmFile

num:47 abbrev: cmfl abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Copyright | 5 | MultiString |
 | Publishable information about the copyright that should appear on the copyright page of the publication.
Basic | Description | 2 | MultiString-big |
Basic | InternalPath | 4 | Unicode |
Basic | Name | 1 | MultiUnicode |
Basic | OriginalPath | 3 | Unicode |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | CmFolder:Files | 6 | collection | CmFile
test Owned by | ScrImportSFFiles:Files | 2 | collection | CmFile
 | The files that this source comprises. Currently (Dec 2005) plan to only set the OriginalPath in the CmFile.
test Refer'd by | CmMedia:MediaFile | 2 | atomic | CmFile
 | Multiple CmMedia objects may reference a single media file, so this property is a reference to a file. CmFile. As with pictures, media files will be copied to root\media directory where root is determined by LangProject_ExtLinkRootDir, which defaults to c:\program files\FieldWorks if not set (or some other location?).
Refer'd by | CmPicture:PictureFile | 2 | atomic | CmFile


CmFilter

num:9 abbrev: fil abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | App | 5 | Guid |  |
Basic | ClassId | 2 | Integer |  |
Basic | ColumnInfo | 8 | Unicode |  |
Basic | FieldId | 3 | Integer |  |
Basic | FieldInfo | 4 | Unicode |  |
Basic | Name | 1 | Unicode |  |
Basic | PromptText | 10 | Unicode |  |
Basic | ShowPrompt | 9 | Integer | min: 0 | max:127
Basic | Type | 6 | Integer | min: 0 | max:127

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Rows | 7 | sequence | CmRow

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:Filters | 24 | collection | CmFilter


CmFolder

num:2 abbrev: fold abstract: false module: Cellar(num:0) base:

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Description | 5 | MultiString-big |
Basic | Name | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Files | 6 | collection | CmFile
Owning | SubFolders | 3 | collection | CmFolder

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LangProject:Media | 51 | collection | CmFolder
 | This contains a lit of folders holding media file objects. For now, we will have one CmFolder called "Local Media" that holds all media.
Owned by | LangProject:Pictures | 48 | collection | CmFolder
Owned by | CmFolder:SubFolders | 3 | collection | CmFolder


CmIndirectAnnotation

num:36 abbrev: iann abstract: false module: Cellar(num:0) base: CmAnnotation

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | AppliesTo | 1 | sequence | CmAnnotation

Back references (sorted by attribute name)

Type Name Num Card Sig


CmLocation

num:12 abbrev: loc abstract: false module: Cellar(num:0) base: CmPossibility

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic |  | 1 |  |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | LexPronunciation:Location | 3 | atomic | CmLocation
 | Some pronunciations can be related to specific areas, so this points to the location list.
test Refer'd by | RnGenericRec:Locations | 24 | collection | CmLocation
 | A list of locations in which the event occurred.
Refer'd by | CmPerson:PlaceOfBirth | 6 | atomic | CmLocation
Refer'd by | CmPerson:PlacesOfResidence | 9 | collection | CmLocation


CmMajorObject

num:5 abbrev: mobj abstract: true module: Cellar(num:0) base: CmObject

Direct Subclasses

  • ReversalIndex
  • Text
  • LexDb
  • WordformLookupList
  • Scripture
  • CmPossibilityList
  • RnResearchNbk
  • DsChart

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | DateCreated | 2 | Time |
Basic | DateModified | 3 | Time |
Basic | Description | 4 | MultiString-big |
Basic | Name | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | HeaderFooterSets | 6 | collection | PubHFSet
 | Used to define preset header/footer layouts that can be selected and copied to a publication division. Reason: needed to implement TE-1468
test Owning | Publications | 5 | collection | Publication
 | A collection of all of the publication layouts available for output from the translated scripture database.

Back references (sorted by attribute name)

Type Name Num Card Sig


CmMedia

test num:69 | abbrev: med | abstract: false | module: Cellar(num:0) | base: CmObject
 | This provides a class for linking to a media file which may be a .wav sound clip, .wmv movie clip, etc. It also allows the user to enter a label describing the file contents.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Label | 1 | MultiString |
 | This allows a user to enter a label for each media file in multiple writing systems. It also allows formatting or embedded writing systems.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | MediaFile | 2 | atomic | CmFile
 | Multiple CmMedia objects may reference a single media file, so this property is a reference to a file. CmFile. As with pictures, media files will be copied to root\media directory where root is determined by LangProject_ExtLinkRootDir, which defaults to c:\program files\FieldWorks if not set (or some other location?).

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LexPronunciation:MediaFiles | 4 | sequence | CmMedia
 | A pronunciation may have more than one media file to allow for a man's voice and a woman's voice, slight dialect differences, etc.


CmMediaAnnotation

test num:38 | abbrev: mann | abstract: false | module: Cellar(num:0) | base: CmAnnotation
 | Yet to be defined. Will probably point to a RnMedia item.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


CmObject

num:0 abbrev: obj abstract: false module: Cellar(num:0) base:

Direct Subclasses

  • PhNaturalClass
  • LexAppendix
  • PhPhonData
  • LexExampleSentence
  • CmTranslation
  • MoInflAffixTemplate
  • PhEnvironment
  • MoReferralRule
  • MoCompoundRule
  • LexSense
  • MoStratum
  • PhCode
  • MoDerivTrace
  • MoMorphSynAnalysis
  • MoStemName
  • ReversalIndexEntry
  • MoMorphData
  • LexPronunciation
  • PhContextOrVar
  • PhTerminalUnit
  • WordFormLookup
  • LexEntry
  • WfiWordform
  • WfiGloss
  • MoInflClass
  • WfiWordSet
  • MoRuleMapping
  • PhFeatureConstraint
  • MoAdhocProhib
  • MoForm
  • PhPhonemeSet
  • ChkRef
  • LexReference
  • ChkSense
  • ChkRendering
  • PhSegmentRule
  • PhSegRuleRHS
  • ScrBookAnnotations
  • WfiAnalysis
  • MoDeriv
  • FsFeatureSystem
  • FsAbstractStructure
  • FsFeatStrucType
  • FsSymFeatVal
  • FsFeatureSpecification
  • ScrBook
  • ScrSection
  • ScrBookRef
  • UserViewRec
  • CmMajorObject
  • StStyle
  • CmOverlay
  • UserView
  • CmFilter
  • StText
  • UserViewField
  • CmProject
  • CrossReference
  • CmPossibility
  • CmCell
  • CmAgent
  • CmRow
  • CmAgentEvaluation
  • MoGlossItem
  • MoGlossSystem
  • CmAnnotation
  • ScrDraft
  • ScrDifference
  • WfiMorphBundle
  • PubDivision
  • PubPageLayout
  • Publication
  • PubHFSet
  • PubHeader
  • CmFile
  • CmPicture
  • LexEtymology
  • UserConfigAcct
  • CmResource
  • RnRoledPartic
  • Reminder
  • RnGenericRec
  • CmDomainQ
  • ScrImportSet
  • ScrMarkerMapping
  • CmMedia
  • ScrCheckRun
  • DsDiscourseData
  • LexEntryRef
  • PunctuationForm
  • Note
  • Segment
  • TextTag
  • ConstituentChartCellPart
  • ConstChartRow

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | Segment:Analyses | 6 | sequence | CmObject
test Owned by | StTxtPara:AnalyzedTextObjects | 5 | sequence | CmObject
 | AnalyzedTextObjects is used when there are associated analyses with any objects in the text. It is primarily meant for morphological interlinear analysis of text. Reference pointers to TxtWordformInContext (one for every word, punctuation and reference in the text) are set in a sequence. Note: the name of the class will likely change to TxtObjInContext because it handles more than just words. Refer to the documentation on TxtWordformInContext for more information. This attribute is used only if the application requires it. It does not obviate the need for TextObjects
Refer'd by | CmBaseAnnotation:BeginObject | 5 | atomic | CmObject
test Refer'd by | LexEntryRef:ComponentLexemes | 4 | sequence | CmObject
 | The UI limits this to a sequence of LexEntry or LexSense. For variants, this field points to the main entry or sense. When not hidden, this will produce a minor variant entry that always shows the main entry referenced here. This variant will always be shown in the main entry being referenced. ComponentLexemes is ignored in this case. For complex entries, this property lists the components for this idiom, derivation, compound, etc. All of the listed components will be displayed in the subentry following the headword. For example, emphanizoo (cmpd. of en, pha, -an, -id). Whether they get displayed as subentries is controlled by the PrimaryLexemes property. This allows the user to specify component lexemes for productive lexemes without cluttering the printed dictionary.]
Refer'd by | CmBaseAnnotation:EndObject | 6 | atomic | CmObject
test Refer'd by | CmAnnotation:InstanceOf | 6 | atomic | CmObject
 | Annotations, in many cases, are tags from a predefined list of objects. We might want to mark up a text for OCM codes. A particular annotation in context may tag an instance of OCM code 152. WordformsInContext are tagged with Wordforms found in the WordformInventory.
test Refer'd by | LexEntry:MainEntriesOrSenses | 19 | sequence | CmObject
 | If a user has specified Morphology, then FW should by default set a link to the entry that has a morph type of root. In the case of two or more roots, FW makes an arbitrary decision. Like other parts of the WW system, default choices should be indicated to the user so they can review them. In the majority of cases for subentry-like entries this will be only one entry (establishment points to establish) but with the possibility of more for entries that have more than one root in them (blackboard may point to board and black). For inflected forms, there will ALWAYS be only one entry pointed to (men points to man). (This used to be on LexSubentry and MainEntryOrSense on LexMinorEntry.) Subentries can be "subs" of either a major entry, another subentry, a minor entry (very rare) or a particular sense of any of the above. In this latter case, common in Philippine and Indonesian lexicons, the subentry usually appears under the sense of the entry.
test Refer'd by | StTxtPara:ObjRefs | 6 | collection | CmObject
 | For Scripture, by convention this refers to ScrRef objects (a subclass of CmObject). In other texts we might possibly have a use for referring to other targets--for example, ChoicesListItems like OCM codes, if we decided to go down to the paragraph level but didn't want to go all the way to tagging phrases. This could also foreseeably be used for referencing schemes for vernacular text (apart from a Scripture referencing system). It also avoids the philosophical problem of having a property unique to Scripture on a very general-purpose object.
Refer'd by | CmBaseAnnotation:OtherObjects | 7 | collection | CmObject
test Refer'd by | LexEntryRef:PrimaryLexemes | 3 | sequence | CmObject
 | The UI limits this to a sequence of LexEntry or LexSense. For variants, this field is unused. For complex entries, this field points to a subset of ComponentLexemes. The entries or senses in this property determine the main entries that will have subentries generated for this entry. For example, if ComponentLexemes has kick, the, bucket, and PrimaryLexemes only has kick, then kick is the only entry that will show a ‘kick the bucket’ subentry in a root-based display.
test Refer'd by | MoPhonolRuleApp:Rule | 1 | atomic | CmObject
 | refers to the phonological rule (class to be defined) whose application this trace structure represents
Refer'd by | LexReference:Targets | 2 | sequence | CmObject
test Refer'd by | StTxtPara:TextObjects | 4 | sequence | CmObject
 | The Contents of StTxtPara are parsed into TextObjects. The event that triggers parsing is yet to be determined but will probably be when the StTxtPara loses focus. Parsed objects include Wordforms, Punctuation, and References (including ScrRefs if the contents are translated Scripture). A sequence of references are set to each of these objects as they are found in their respective inventories (Wordform Inventory, Punctuation Inventory, and ReferenceScheme) This attribute exists in order to allow for a concordance by WfiWordform, (currently including punctuation), PunctuationForm and/or ScrRef. This attribute is a "lite" version of AnalyzedTextObjects. This attribute should only be used if a particular application of StTxtPara requires concordances.


CmObject

num: abbrev: abstract: false module: Cellar(num:0) base:

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | Segment:Analyses | 5 | sequence | CmObject
test Refer'd by | PhPhonRuleFeat:Item | 1 | atomic | CmObject
 | This refers to a CmObject, where that CmObject would probably be a MoInflClass (e.g. a conjugation class), an FsSymFeatVal (e.g. feminine gender), or a CmPossibility (for an exception "feature"). Any such MoInflClass would be owned by a PartOfSpeech (or by a nested MoInflClass within a PartOfSpeech); any such FsSymFeatVal would be owned by an FsClosedFeature; and the exception "feature" CmPossibility would be in the possibility list owned by MoMorphData:ProdRestrict.


CmOverlay

test num:21 | abbrev: ovl | abstract: false | module: Cellar(num:0) | base: CmObject
 | An overlay is a collection of CmPossibilities used to mark up text in a StText. The formatting for each item is defined by properties on the CmPossibiliy. In the original model, we had model CmOverlayTag that could carry their own formatting apart from the formatting defined in the CmPossibility. In the current model, we have removed this capability.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Name | 1 | Unicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | PossItems | 4 | collection | CmPossibility
 | An Overlay can have a number of CmPossibilities associated with it for the purposes of tagging text. These CmPossibilities come from a particular CmPossibilityList (defined by PossList). For example, the user might have an overlay for OCM codes having to do with marriage and fishing. He might have another overlay with OCM codes that have to do with cooking.
test Refer | PossList | 2 | atomic | CmPossibilityList
 | The list that a CmOverlay gets its PossItems from.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:Overlays | 37 | collection | CmOverlay


CmPerson

num:13 abbrev: per abstract: false module: Cellar(num:0) base: CmPossibility

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Alias | 1 | MultiUnicode |  |
Basic | DateOfBirth | 4 | GenDate |  |
Basic | DateOfDeath | 11 | GenDate |  |
Basic | Gender | 3 | Integer | min: 0 | max:2
Basic | IsResearcher | 8 | Boolean |  |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Education | 10 | atomic | CmPossibility
Refer | PlaceOfBirth | 6 | atomic | CmLocation
Refer | PlacesOfResidence | 9 | collection | CmLocation
Refer | Positions | 13 | collection | CmPossibility

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | StJournalText:CreatedBy | 3 | atomic | CmPerson
 | From a list of users, the person who created the journal entry.
test Refer'd by | StJournalText:ModifiedBy | 4 | atomic | CmPerson
 | From a list of users, the person who last modified the journal entry.
test Refer'd by | RnRoledPartic:Participants | 1 | collection | CmPerson
 | A list of people (or one person) involved in the event in the role specified below.
test Refer'd by | CmPossibility:Researchers | 13 | collection | CmPerson
 | The person(s) who created/modified this Possibility record or any of its fields.
test Refer'd by | RnGenericRec:Researchers | 4 | collection | CmPerson
 | Tthe persons who obtained, entered, or analyzed the data. If more than one person was involved, then all researchers can be cited here.
test Refer'd by | RnGenericRec:Sources | 25 | collection | CmPerson
 | The person(s) who reported the event to the researcher.


CmPicture

num:48 abbrev: pic abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Caption | 3 | MultiString |
 | The caption in a string/publication/etc.
test Basic | Description | 4 | MultiString-big |
 | Illustration description. This material does not show up on the printed page. This can include special publishing notes, etc.
test Basic | LayoutPos | 5 | Integer |
 | An enumeration: 0 - Center Column (no text wrapping around picture, shrinks picture proportionately if wider than the column, caption can occupy full column width); 1 - Center Page (top or bottom of page only, no text wrapping around picture, shrinks picture proportionately if wider than the column, caption can occupy full page width); 2 - Right-align in Column (text wraps to the left of picture, caption can occupy same width as picture); 3 - Left-align in Column (text wraps to the right of picture, caption can occupy same width as picture); 4 - Fill Column (grows picture if necessary to fill column width, caption can occupy full column width); 5 - Fill Page (top or bottom of page only, grows picture if necessary to fill page width, caption can occupy full page width); 6 Full Page (picture occupies full page, grows/shrinks picture if necessary).
test Basic | LocationMax | 9 | Integer |
 | Depending on the value of LocationRangeType, specifies the maximum Scripture reference or the number of paragraphs after the paragraph containing the ORC reference at which this picture can be laid out.
test Basic | LocationMin | 8 | Integer |
 | Depending on the value of LocationRangeType, specifies the minimum Scripture reference or the number of paragraphs before the paragraph containing the ORC reference at which this picture can be laid out.
test Basic | LocationRangeType | 7 | Integer |
 | LocationRangeType, LocationMin and LocationMax together are used to prevent gaps at the end of a page from trying to lay out a picture at an exact location (i.e., where the ORC is). LocationRangeType is an enumeration indicating the type of data contained in LocationMin and LocationMax: 0 - LocationMin and LocationMax are ignored, and the picture must lay out on the line following the ORC, even if this results in a gap; 1 - LocationMin and LocationMax contain Scripture references having the format BBCCCVVV, which encodes book, chapter, and verse; 2 - LocationMin and LocationMax represent a number of paragraphs before or after the paragraph containing the ORC. In non-Scripture text, LocationRangeType should always be 0 or 2.
test Basic | ScaleFactor | 6 | Integer |
 | Percentage by which picture is grown or shrunk. Not used if the LayoutPos is 4 (Fill Column), 5 (Fill Page), 6 (Full Page).

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | PictureFile | 2 | atomic | CmFile

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LexSense:Pictures | 29 | sequence | CmPicture


CmPossibility

test num:7 | abbrev: pss | abstract: false | module: Cellar(num:0) | base: CmObject CmPossibilityList
 | In regards to how this is implemented in FieldWorks, Ken says ... In SQL code, you could place a CmPerson in a "MoMorphTypeList" and it would be perfectly happy. However, our list editor always uses the ItemClsid to create any new items that are created in the list, so it is enforced in this way. Presumably, any other application that might create possibilities would also check ItemClsid and create the correct type of object for the list. If not, it is a bug.

Direct Subclasses

  • MoMorphType
  • PartOfSpeech
  • ChkTerm
  • PhPhonRuleFeat
  • CmCustomItem
  • CmLocation
  • CmAnnotationDefn
  • CmPerson
  • CmAnthroItem
  • CmSemanticDomain
  • LexEntryType
  • LexRefType

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Abbreviation | 2 | MultiUnicode |  |
test Basic | BackColor | 16 | Integer |  |
 | BackColor for overlay functionality.
Basic | DateCreated | 10 | Time |  |
Basic | DateModified | 11 | Time |  |
Basic | Description | 3 | MultiString-big |  |
test Basic | ForeColor | 15 | Integer |  |
 | ForeColor for overlay functionality.
test Basic | HelpId | 14 | Unicode |  |
 | Used by the help system to launch the appropriate help topic for the Possibility item.
test Basic | Hidden | 19 | Boolean |  |
 | Indicates whether overlay bracketing should be hidden or not. True = Hidden.
test Basic | IsProtected | 20 | Boolean |  |
 | This flag is set for items that are accessed by the software via GUIDs. The software is assuming that this item is always present with the same GUID on all machines. When set, a user can still edit the item, but it cannot be deleted.
Basic | Name | 1 | MultiUnicode |  |
Basic | SortSpec | 6 | Integer |  |
test Basic | UnderColor | 17 | Integer |  |
 | UnderColor for overlay functionality - the color of the "underline" style when used in Overlays.
test Basic | UnderStyle | 18 | Integer | min: 0 | max:127
 | UnderStyle - style of the underline used in overlays functionality.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Confidence | 8 | atomic | CmPossibility
 | Indicates confidence in the data collected for this possibility item. This value comes from a user-defined list that is used by many different FieldWorks objects (Events, Analysis Records, Lexical Entries and their Senses, etc.) These values are user-definable and initially include: Low, Medium and High as possibilities.
test Refer | Researchers | 13 | collection | CmPerson
 | The person(s) who created/modified this Possibility record or any of its fields.
test Refer | Restrictions | 7 | collection | CmPossibility
 | Indicates whether the data for this possibility item has restrictions for presentation to certain audiences. This value comes from a user-defined list that is used by many different FieldWorks objects (Events, Analysis Records, Lexical Entries and their Senses, etc.) These values are user-definable and initially include: No restrictions, Do not publish, Case by case, Unknown
test Refer | Status | 9 | atomic | CmPossibility
 | The status of this Possibility. This is a user-definable list but initial list will include: Confirmed, Disproved, Pending.
test Owning | Discussion | 12 | atomic | StText
 | Any pertinent discussion for this Possibility.
Owning | SubPossibilities | 4 | sequence | CmPossibility

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoInflAffMsa:AffixCategory | 2 | atomic | CmPossibility
In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. This field is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a CmPossibility of "derv" (derivational affix).
test Refer'd by | MoDerivAffMsa:AffixCategory | 8 | atomic | CmPossibility
In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. This field is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a CmPossibility of "derv" (derivational affix).
test Refer'd by | ScrScriptureNote:Categories | 2 | sequence | CmPossibility
Place to indicate zero to many standard categories to which the issue discussed in the note might belong. USB and CONNOT categories will be supplied on a factory installed list. This is an open (user modifiable) list.
test Refer'd by | ConstituentChartCellPart:Column | 1 | atomic | CmPossibility
Specifically a column identifier.
test Refer'd by | CmPossibility:Confidence | 8 | atomic | CmPossibility
Indicates confidence in the data collected for this possibility item. This value comes from a user-defined list that is used by many different FieldWorks objects (Events, Analysis Records, Lexical Entries and their Senses, etc.) These values are user-definable and initially include: Low, Medium and High as possibilities.
test Refer'd by | RnGenericRec:Confidence | 5 | atomic | CmPossibility
An indication of how confident the researcher is about the data in this record. Example values high, medium, low, uncertain.
Refer'd by | LexSense:DomainTypes | 6 | collection | CmPossibility
Refer'd by | CmPerson:Education | 10 | atomic | CmPossibility
test Refer'd by | MoDerivAffMsa:FromProdRestrict | 13 | collection | CmPossibility
FromProductivityRestrictions: refers to a collection of CmPossibility, giving any restriction classes which the stem to which this affix attaches must bear. If this attribute is empty, this affix may attach to a stem regardless of what restriction classes the stem bears (see MoStemMsa.ProductivityRestrictions). If there are two or more restriction classes listed for this affix, then the stem must have at least all of these restriction classes in its MoStemMsa.ProductivityRestrictions attribute in order for this affix to attach to the stem. The stem could have more restriction classes, but not less. Changed from FromProductivityRestrictions.
test Refer'd by | MoInflAffMsa:FromProdRestrict | 8 | collection | CmPossibility
Refers to a collection of CmPossibility, giving any restriction classes which the stem to which this affix attaches must bear. If this attribute is empty, this affix may attach to a stem regardless of what restriction classes the stem bears (see MoStemMsa.ProductivityRestrictions). If there are two or more restriction classes listed for this affix, then the stem must have at least all of these restriction classes in its MoStemMsa.ProductivityRestrictions attribute in order for this affix to attach to the stem. The stem could have more restriction classes, but not less. (Note that unlike the case with MoDerivationalAffixMsa, there is no 'to productivity restrictions' attribute for inflectional affixes: inflectional affixes cannot add restriction classes to a word.) Changed from FromProductivityRestrictions.
test Refer'd by | Text:Genres | 9 | collection | CmPossibility
This associates a text with any number of genres.
test Refer'd by | RnGenericRec:PhraseTags | 8 | collection | CmPossibility
The Tags attribute is used for explicit tagging by the end-user, where he indicates that a given tag applies to the entire record. The PhraseTags attribute by contrast is a behind-the-scenes tag. When the user tags a word or phrase within a description, the editing mechanism will add that tag to this attribute. The purpose is to provide a means for fast searching. The user can do a quick back-reference search to arrive at the appropriate records, and then do a text search to find the actual tagged phrase. In this manner we avoid having to do a sequential search through every record in the notebook.
Refer'd by | CmPerson:Positions | 13 | collection | CmPossibility
Refer'd by | CmPossibilityList:Possibilities | 8 | collection | CmPossibility
test Refer'd by | CmOverlay:PossItems | 4 | collection | CmPossibility
An Overlay can have a number of CmPossibilities associated with it for the purposes of tagging text. These CmPossibilities come from a particular CmPossibilityList (defined by PossList). For example, the user might have an overlay for OCM codes having to do with marriage and fishing. He might have another overlay with OCM codes that have to do with cooking.
test Refer'd by | MoStemMsa:ProdRestrict | 6 | collection | CmPossibility
Refers to a collection of CmPossibility, giving any exceptional properties of the stem that relate to restricting the productivity of affixes. (Other terms for this are 'exception features,' 'rule features' and 'ad hoc features'.) Usually these represent restrictions which are shared among a set of more than two morphemes (unlike AMPLE's 'ad hoc pairs', which concern a pair of morphemes). An example from English is the feature [+Latinate], marking that part of the English vocabulary which is etymologically derived from Latin, and which has certain synchronic properties. For example, the suffix -ity attaches only to [+Latinate] stems (Aronoff 1976: 51): felicity, vivacity, *widity, *strongity The similar suffix -ness, on the other hand, attaches to more or less all adjectives regardless of this feature. Similar restrictions are apparently found in other languages which have undergone substantial borrowing, e.g. Mohawk and Dutch are said to have restrictions which depend on whether or not stems were borrowed from French. Maybe there are other sources of such restrictions as well. These restrictions cannot be handled by inflection classes. The reason is that inflection classes and exception features are likely to be cross-cutting distinctions. Another sort of restriction for which exception features have sometimes been used, is for certain restricted (morpho-)phonological alternations, such as the Velar Softening rule of English (Chomsky and Halle 1968; Aronoff 1976: 51). However, this use is sometimes complicated by restrictions on adjacency, which cannot be easily modeled. An apparent alternative to exception features would be morphosyntactic features. However, exception features are (by definition) invisible to the syntax, and the use of morphosyntactic features for this purpose could incorrectly prevent unification of features in syntax, e.g. if we build an NP consisting of a [+Latinate] noun and an [-Latinate] determiner. See also MoDerivationalAffixMsa.FromProductivityRestrictions. Do exception features percolate? There is some inconclusive discussion of this in Aronoff 1976: 52. Note that the answer to this will not directly affect the domain model, only the parser and generator (unless we decide to leave it up to the user, and put a toggle somewhere). See also note under MoDerivationalAffixMsa. Changed from ProductivityRestrictions.
test Refer'd by | MoDerivStepMsa:ProdRestrict | 6 | collection | CmPossibility
Specifies the restriction classes which the word has at this stage in the derivation. Changed from ProductivityRestrictions
test Refer'd by | CmPossibility:Restrictions | 7 | collection | CmPossibility
Indicates whether the data for this possibility item has restrictions for presentation to certain audiences. This value comes from a user-defined list that is used by many different FieldWorks objects (Events, Analysis Records, Lexical Entries and their Senses, etc.) These values are user-definable and initially include: No restrictions, Do not publish, Case by case, Unknown
test Refer'd by | RnGenericRec:Restrictions | 6 | collection | CmPossibility
Any restrictions that might exist for this data.
test Refer'd by | RnRoledPartic:Role | 2 | atomic | CmPossibility
The role of the above participant(s). The role may be set to "unspecified."
Refer'd by | LexSense:SenseType | 12 | atomic | CmPossibility
Refer'd by | LexSense:Status | 26 | atomic | CmPossibility
test Refer'd by | CmPossibility:Status | 9 | atomic | CmPossibility
The status of this Possibility. This is a user-definable list but initial list will include: Confirmed, Disproved, Pending.
test Refer'd by | RnGenericRec:Status | 18 | atomic | CmPossibility
An indication of the current status of the record. Included default possibilities include: Confirmed, Disproved, Pending
Owned by | CmPossibility:SubPossibilities | 4 | sequence | CmPossibility
Refer'd by | TextTag:Tag | 5 | atomic | CmPossibility
test Refer'd by | ConstChartTag:Tag | 1 | atomic | CmPossibility
The CmPossibilities come from the list of chart tags (discourse chart markers).
test Refer'd by | DsChart:Template | 1 | atomic | CmPossibility
Type of Discourse Chart. Each type of chart can have a different organization and layout of columns. Template must refer to a top-level CmPossibility in (eventually one of?) the template possibility lists of the DsDiscourseData (a Template).
Refer'd by | LexSense:ThesaurusItems | 13 | collection | CmPossibility
Refer'd by | WordFormLookup:ThesaurusItems | 3 | collection | CmPossibility
test Refer'd by | RnGenericRec:TimeOfEvent | 26 | collection | CmPossibility
The time that the event occurred. The types of items in the list here can be vernacular words that capture how the culture captures different times during the day.
test Refer'd by | MoDerivAffMsa:ToProdRestrict | 14 | collection | CmPossibility
Specifies any restriction classes which the MoDerivationalStepMsa resulting from attaching this affix to a stem will bear (in its ProductivityRestrictions attribute). Specifically: if this attribute is non-empty, the stem resulting from the attachment of this affix will have these restriction classes as the value of its ProductivityRestrictions (overriding any restriction classes borne by the stem to which this affix attached). If on the other hand this attribute is empty, the ProductivityRestrictions of the output stem will be the same as those of the input stem. Changed from ToProductivityRestrictions.
test Refer'd by | MoCompoundRule:ToProdRestrict | 8 | collection | CmPossibility
refers to a collection of CmPossibility, giving any restriction classes which the stem resulting from this compound rule will bear. Specifically: if this attribute is non-empty, the stem resulting from this rule will have these restriction classes as the value of its ProductivityRestrictions (overriding any restriction classes borne by the daughter stems). If on the other hand this attribute is empty, the ProductivityRestrictions of the output stem will be the same as those of the head (for MoEndocentricCompounds) or empty (for MoExocentricCompounds). Changed from ToProductivityRestrictions.
test Refer'd by | CmTranslation:Type | 2 | atomic | CmPossibility
The type of translation: free, literal, back, front, etc.
test Refer'd by | RnGenericRec:Type | 27 | atomic | CmPossibility
The type of event. Included possibilities include: Performance, Almanac, Conversation, Observation, Literature Summary.
Refer'd by | LexSense:UsageTypes | 14 | collection | CmPossibility


CmPossibilityList

num:8 abbrev: pssl abstract: false module: Cellar(num:0) base: CmMajorObject

Direct Subclasses

  • CmPossibility

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Abbreviation | 10 | MultiUnicode |  |
Basic | Depth | 2 | Integer | min: 0 | max:127
test Basic | DisplayOption | 13 | Integer | min: 0 | max:2
 | This determines whether we display name (kpntName = 0), name and abbreviation (kpntNameAndAbbrev = 1), or abbreviation (kpntAbbreviation = 2) when we display names.
Basic | HelpFile | 11 | Unicode |  |
Basic | IsClosed | 5 | Boolean |  |
Basic | IsSorted | 4 | Boolean |  |
test Basic | IsVernacular | 15 | Boolean |  |
 | This indicates whether the list will display vernacular (True) or analysis encodings (false) as the default.
test Basic | ItemClsid | 14 | Integer |  |
 | This is the clsid of the items that can be inserted into this list.
test Basic | ListVersion | 21 | Guid |  |
 | Uniquely identifies a particular version of the possiblity llist so that version changes can be detected and update routines run.
Basic | PreventChoiceAboveLevel | 3 | Integer | min: 0 | max:8
Basic | PreventDuplicates | 6 | Boolean |  |
Basic | PreventNodeChoices | 7 | Boolean |  |
Basic | UseExtendedFields | 12 | Boolean |  |
Basic | WritingSystem | 17 | Unicode |  |
test Basic | WsSelector | 18 | Integer |  |
 | // the application to get the appropriate writing system from the application. For example, // a language project has a list of one or more analysis encodings. kwsAnal would // tell the program to use the first writing system in this list. #define kwsAnal 0xffffffff // (-1) The first analysis writing system. #define kwsVern 0xfffffffe // (-2) The first vernacular writing system. #define kwsAnals 0xfffffffd // (-3) All analysis writing system. #define kwsVerns 0xfffffffc // (-4) All vernacular writing system. #define kwsAnalVerns 0xfffffffb // (-5) All analysis then All vernacular writing system. #define kwsVernAnals 0xfffffffa // (-6) All vernacular then All analysis writing system. #define kwsLim 0xfffffff9 // (-7) One beyond the last magic value.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Possibilities | 8 | collection | CmPossibility

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LangProject:AffixCategories | 34 | atomic | CmPossibilityList
In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. The AffixCategoryList is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a MoAffixCategory of "derv" (derivational affix). Refer to MoInflectionalAffixMsa and MoDerivationalAffixMsa for more information.
Owned by | LangProject:AnalysisStatus | 29 | atomic | CmPossibilityList
test Owned by | LangProject:AnnotationDefs | 47 | atomic | CmPossibilityList
Changed from AnnotationDefinitions.
Owned by | LangProject:AnthroList | 12 | atomic | CmPossibilityList
test Owned by | DsDiscourseData:ChartMarkers | 3 | atomic | CmPossibilityList
This list stores markers that can be inserted into the chart to provide additional labelling. The top-level is several different kinds of markers (initially Tense/Aspect/Mood, Pronouns, and Demonstatives), and below those are the (sometimes hierarchical) lists of possible markers for that type. Combining them like this makes it easy to add new categories as well as items.
test Owned by | LangProject:CheckLists | 50 | collection | CmPossibilityList
The CheckLists will be a collection of CmPossibilityList objects, each with a unique identifier. For example, one CmPossibilityList will be called KeyTerms which will represent a hierarchical list of Biblical key terms. The possibility lists can be imported programmatically from external files. Each CmPossibilityList will hold ChkItem objects (derived from CmPossibility).
test Owned by | LexDb:ComplexEntryTypes | 23 | atomic | CmPossibilityList
This Complex Entry Types list is used to classify a LexEntryRef via the ComplexEntryTypes property. ItemClsid should be set to LexEntryType, IsSorted to true, and Depth to 127. The list will typically be flat, but the user is free to introduce a hierarchy if desirable. When entries use this list, they will be displayed as subentries in the dictionary. Entries using this list will be displayed as subentries in the dictionary; usually at the end of the major entry and will typically produce a separate major entry in the dictionary referring to the main entry. The display is dependent on whether a root-based or stem-based view of the dictionary is being printed. The initial list may have: Acronym Compound Contractions Derivation Idiom Phrasal Verb Saying
Owned by | LangProject:ConfidenceLevels | 25 | atomic | CmPossibilityList
test Owned by | DsDiscourseData:ConstChartTempl | 1 | atomic | CmPossibilityList
Templates describing possible chart organizations. Top level Possibilities are Chart Templates. SubPossibilities represent groups of columns or columns. (This is stretching the idea of 'possibilities' somewhat, and it is unusual that the top-level possibilities are really a different kind of thing from the leaves, but it can be thought of as an extension of the idea that non-leaf nodes perform a grouping function.) Changed from ConstChartTemplates for the port.
Owned by | LexDb:DomainTypes | 7 | atomic | CmPossibilityList
Owned by | LangProject:Education | 32 | atomic | CmPossibilityList
test Owned by | LangProject:GenreList | 52 | atomic | CmPossibilityList
This property holds the list of defined genres (instances of CmPossibility) used by texts.
Owned by | LangProject:Locations | 30 | atomic | CmPossibilityList
Owned by | LexDb:MorphTypes | 8 | atomic | CmPossibilityList
test Owned by | Scripture:NoteCategories | 25 | atomic | CmPossibilityList
List of categories that identify the types of issues that a ScrScriptureNote might deal with. Changed from ScriptureNoteCategories.
Owned by | ReversalIndex:PartsOfSpeech | 1 | atomic | CmPossibilityList
Owned by | LangProject:PartsOfSpeech | 5 | atomic | CmPossibilityList
Owned by | LangProject:People | 31 | atomic | CmPossibilityList
test Owned by | PhPhonData:PhonRuleFeats | 6 | atomic | CmPossibilityList
The rule features are a way to limit the application of rules, either by excluding or requiring these "features." The CmPossibilityList contains zero or more PhPhonRuleFeat classes. These refer to a CmObject, where that CmObject would probably be a MoInflClass (e.g. a conjugation class), an FsSymFeatVal (e.g. feminine gender), or a CmPossibility (for an exception "feature").
Owned by | LangProject:Positions | 36 | atomic | CmPossibilityList
Refer'd by | UserViewField:PossList | 12 | atomic | CmPossibilityList
test Refer'd by | CmOverlay:PossList | 2 | atomic | CmPossibilityList
The list that a CmOverlay gets its PossItems from.
test Owned by | MoMorphData:ProdRestrict | 9 | atomic | CmPossibilityList
This reflects what is also referred to as exception features in the literature. It defines class identifiers that can be associated with non-productive derivational or inflectional affixes that only go on stems that belong to the same class. An example from English is the feature [+Latinate], marking that part of the English vocabulary which is etymologically derived from Latin, and which has certain synchronic properties. For example, the suffix -ity attaches only to [+Latinate] stems (Aronoff 1976: 51): felicity, vivacity, *widity, *strongity. The similar suffix -ness, on the other hand, attaches to more or less all adjectives regardless of this feature. Similar restrictions are apparently found in other languages which have undergone substantial borrowing, e.g. Mohawk and Dutch are said to have restrictions which depend on whether or not stems were borrowed from French. Maybe there are other sources of such restrictions as well. These restrictions cannot be handled by inflection classes. The reason is that inflection classes and exception features are likely to be cross-cutting distinctions. Changed from ProductivityRestrictions
test Owned by | RnResearchNbk:RecTypes | 3 | atomic | CmPossibilityList
A list of event types that the user can modify. Types included by default are: Performance, Almanac, Conversation, Observation, LiteratureSummary.
test Owned by | LexDb:References | 19 | atomic | CmPossibilityList
This holds the possibility list that holds LexRefType items which own the actual references.
Owned by | LangProject:Restrictions | 26 | atomic | CmPossibilityList
Owned by | LangProject:Roles | 28 | atomic | CmPossibilityList
Owned by | LangProject:SemanticDomainList | 49 | atomic | CmPossibilityList
Owned by | LexDb:SenseTypes | 5 | atomic | CmPossibilityList
Owned by | LexDb:Status | 15 | atomic | CmPossibilityList
test Owned by | LangProject:TextMarkupTags | 55 | atomic | CmPossibilityList
Top eval Possibilities are major tag categories ( Syntax, Semantics, RRG, etc.) The actual tags are their SubPossibilities [After V1, more hierarchy may be possible.]
Refer'd by | LangProject:Thesaurus | 9 | atomic | CmPossibilityList
Owned by | LangProject:TimeOfDay | 33 | atomic | CmPossibilityList
Owned by | LangProject:TranslationTags | 7 | atomic | CmPossibilityList
Owned by | LexDb:UsageTypes | 6 | atomic | CmPossibilityList
test Owned by | LexDb:VariantEntryTypes | 22 | atomic | CmPossibilityList
This Variant Entry Types list is used to classify a LexEntryRef via VariantEntryTypes. ItemClsid should be set to LexEntryType, IsSorted to true, and Depth to 127. The list is hierarchical with the top level being the type of variant (e.g., dialectal) and subitems being the conditions (e.g., British English, American English) for that type of variant. Normally the user will set this property to a subitem, although a top level item could be used if the user does not want to specify the condition. The user is free to provide additional nesting if useful. All items in the list will be LexEntryType, so the user will need to specify an appropriate Abbreviation and ReverseAbbr for each item in the list. This gives greater control to the user than having the program try to piece together information from a hierarchy of LexEntryTypes. The Abbreviation is used when displaying the main entry from the minor entry (e.g., Brit. dial. of color). The ReverseAbbr is used when displaying the minor entry from the main entry (e.g., Brit. dial. colour). Entries using this list will be displayed as minor entries in the dictionary; usually following the main entry headword and will typically produce a separate minor entry in the dictionary referring to the main entry. The initial list may have: Dialectal Variant British American Free Variant Inflectional Variant Singular Plural First Person Singular (1SG) Third Person Singular Present (3SG.PRES) Location New York Los Angeles Register Formal Informal Sociolect Upper Class Lower Class Spelling Variant


CmProject

num:1 abbrev: proj abstract: true module: Cellar(num:0) base: CmObject

Direct Subclasses

  • LangProject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | DateCreated | 2 | Time |
Basic | DateModified | 4 | Time |
Basic | Description | 5 | MultiString-big |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


CmResource

test num:70 | abbrev: rsrc | abstract: false | module: Cellar(num:0) | base: CmObject
 | Name and version of an external data resource used by FieldWorks

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Name | 1 | Unicode |
 | Internal name for the resource (the application is responsible for defining the resource and the interface to the resource).
test Basic | Version | 2 | Guid |
 | Version number for the external resource, stored in the database to determine when the version number in the external copy no longer matches.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LexDb:Resources | 21 | collection | CmResource
 | The named external resources (e.g. xml files) used by FLEX and their version numbers.
test Owned by | Scripture:Resources | 33 | collection | CmResource
 | The named external resources (e.g. xml files) used by Translation Editor and their version numbers.


CmRow

num:10 abbrev: frow abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Cells | 1 | sequence | CmCell

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | CmFilter:Rows | 7 | sequence | CmRow


CmSemanticDomain

test num:66 | abbrev: dom | abstract: false | module: Cellar(num:0) | base: CmPossibility
 | This class is used to represent around 1,800 of Ron Moe's semantic domains (backslashes refer to his Standard Format markers): \is 2.7.1 -- maps to English Abbreviation of CmPossibility \sd -- maps to English Name of CmPossibility \sdf -- maps to French Name of CmPossibility \dd -- maps to English Description of CmPossibility

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | LouwNidaCodes | 1 | Unicode |
 | Example: (Ron Moe's Standard Format): \ln 23G Live, Die Multiple Louw & Nida references map to one Unicode string with semicolons as delimiters. At this point, due to royalties, we do not plan to provide the complete Louw & Nida list in our database.
test Basic | OcmCodes | 2 | Unicode |
 | Example: (Ron Moe's Standard Format): \hr 761 Life and Death Multiple OCM references map to one Unicode string with semicolons as delimiters. Some users may not have an OCM code in their database due to royalties, so we can't make actual links to a list.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | OcmRefs | 3 | collection | CmAnthroItem
 | For those that do have an OCM list, we will set links to the appropriate items. We anticipate our program establishing these links when the OCM list is added to the database.
test Refer | RelatedDomains | 4 | collection | CmSemanticDomain
 | Example: (Ron Moe's Standard Format):\cf Weather; Cloud; Star We use this property to link related domains. Ideally this should be a bidirectional link, but so far we do not provide this capability in our conceptual model. So for now we'll live with unidirectional links.
test Owning | Questions | 5 | sequence | CmDomainQ
 | Each domain has a list of questions used to elicit words. Each question has sample words and sentences, so we group these together into CmDomainQ. The domain then owns a sequence of these. They need to be ordered since important questions come first.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | CmSemanticDomain:RelatedDomains | 4 | collection | CmSemanticDomain
 | Example: (Ron Moe's Standard Format):\cf Weather; Cloud; Star We use this property to link related domains. Ideally this should be a bidirectional link, but so far we do not provide this capability in our conceptual model. So for now we'll live with unidirectional links.
Refer'd by | LexSense:SemanticDomains | 27 | collection | CmSemanticDomain


CmTranslation

test num:29 | abbrev: tran | abstract: false | module: Cellar(num:0) | base: CmObject
 | Used for handling various types of translations of a paragraph. For Scripture this includes a back translation. For vernacular texts, this includes free and literal translations.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Status | 3 | MultiUnicode |
 | A label to hold any kind of metadata about the Translation, in particular used for its status (as in “fresh” or “stale”, etc.). These labels can be stored and retrieved independently for each writing system and so correspond the parallel string in the Translation for each writing system. Different types of CmTranslations can have different sets of status labels according to the need of the type.
test Basic | Translation | 1 | MultiString-big |
 | The signature is multiBigString allowing us to have translations in multiple languages (e.g. ENG, FRN, SPN).

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Type | 2 | atomic | CmPossibility
 | The type of translation: free, literal, back, front, etc.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LexExampleSentence:Translations | 3 | collection | CmTranslation
test Owned by | StTxtPara:Translations | 8 | collection | CmTranslation
 | Refer to the documentation on LpTranslation.


ConstChartClauseMarker

num:9 abbrev: cccm abstract: false module: Ling(num:5) base: ConstituentChartCellPart

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | DependentClauses | 1 | sequence | ConstChartRow
 | Indicates that the specified rows are dependent clauses (or song or speech).

Back references (sorted by attribute name)

Type Name Num Card Sig


ConstChartMovedTextMarker

num:8 abbrev: ccmtm abstract: false module: Ling(num:5) base: ConstituentChartCellPart

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Preposed | 2 | Boolean |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | WordGroup | 1 | atomic | ConstChartWordGroup
 | The target ConstChartWordGroup is in the column that shows the actual position of the text, while the marker indicates where the ￢ﾀﾜsomething was moved from here￢ﾀﾝ marker should appear. WordGroup is bidirectional on purpose. We need to maintain a back-reference here.

Back references (sorted by attribute name)

Type Name Num Card Sig


ConstChartRow

num:3 abbrev: ccr abstract: false module: Ling(num:5) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | ClauseType | 2 | Integer |
 | This is an enum with these values: Normal, Dependent, Song, and Speech.
Basic | EndDependentClauseGroup | 6 | Boolean |
Basic | EndParagraph | 3 | Boolean |
Basic | EndSentence | 4 | Boolean |
Basic | Label | 8 | String |
Basic | Notes | 1 | String |
Basic | StartDependentClauseGroup | 5 | Boolean |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Cells | 7 | sequence | ConstituentChartCellPart

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | ConstChartClauseMarker:DependentClauses | 1 | sequence | ConstChartRow
 | Indicates that the specified rows are dependent clauses (or song or speech).
test Owned by | DsConstChart:Rows | 2 | sequence | ConstChartRow
 | The main content of the chart. Each ConstChartRow represents a row/clause.


ConstChartTag

num:10 abbrev: cct abstract: false module: Ling(num:5) base: ConstituentChartCellPart

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Tag | 1 | atomic | CmPossibility
 | The CmPossibilities come from the list of chart tags (discourse chart markers).

Back references (sorted by attribute name)

Type Name Num Card Sig


ConstChartWordGroup

test num:7 | abbrev: ccwg | abstract: false | module: Ling(num:5) | base: ConstituentChartCellPart
 | This column shows the actual position of the text. ConstChartWordGroup's Begin/EndAnalysisIndices refer to Segment's Analyses sequence

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | BeginAnalysisIndex | 3 | Integer |
 | Indicate the words that occur in the indicated cell of the chart.
test Basic | EndAnalysisIndex | 4 | Integer |
 | Indicate the words that occur in the indicated cell of the chart.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | BeginSegment | 1 | atomic | Segment
 | If BeginSegment is null, then there are no words in the WordGroup and this represents a User-entered marker indicating the User wants a special "missing" marker to show up in this cell highlighting that fact that nothing occurs in this cell (presumably because normally there would be something in this column). [Presentation note: currently this is displayed as "---".]
Refer | EndSegment | 2 | atomic | Segment

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | ConstChartMovedTextMarker:WordGroup | 1 | atomic | ConstChartWordGroup
 | The target ConstChartWordGroup is in the column that shows the actual position of the text, while the marker indicates where the ￢ﾀﾜsomething was moved from here￢ﾀﾝ marker should appear. WordGroup is bidirectional on purpose. We need to maintain a back-reference here.


ConstituentChartCellPart

num:6 abbrev: cccp abstract: true module: Ling(num:5) base: CmObject

Direct Subclasses

  • ConstChartWordGroup
  • ConstChartMovedTextMarker
  • ConstChartTag
  • ConstChartClauseMarker

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | MergesAfter | 2 | Boolean |
Basic | MergesBefore | 3 | Boolean |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Column | 1 | atomic | CmPossibility
 | Specifically a column identifier.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | ConstChartRow:Cells | 7 | sequence | ConstituentChartCellPart


CrossReference

test num:28 | abbrev: cref | abstract: false | module: Cellar(num:0) | base: CmObject
 | May 23, 2001. This is to be used for cross references between objects. In its current state, it will be used ONLY for bidirectional (cf. unidirectional or cross-reference sets of greater than 2) cross-references. Although there is a comment attribute on this object, it will not be used in version 1 of the Research Notebook.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Comment | 1 | MultiString-big |
 | To be used after version 1 for indicating the reason for a cross-reference. It is quite likely that a pointer to a list of types of cross-references will also be included in the future.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | RnResearchNbk:CrossReferences | 4 | collection | CrossReference
 | CrossReference objects that capture crossReferences between two RnGenericRecords are owned here by the ResearchNotebook.
test Refer'd by | RnGenericRec:CrossReferences | 12 | collection | CrossReference
 | A RnGenericRecord can refer to one or more CrossReference objects. For version 1 of Research Notebook, CrossReference objects will have two backreferences representing a bi-directional cross-reference.


DsChart

test num:122 | abbrev: dsc | abstract: true | module: Ling(num:5) | base: CmMajorObject
 | This is the discourse chart. This will be subclassed into a Longacre/Levinsohn Constituent Chart, and will be the base class for other discourse charts.

Direct Subclasses

  • DsConstChart

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Template | 1 | atomic | CmPossibility
 | Type of Discourse Chart. Each type of chart can have a different organization and layout of columns. Template must refer to a top-level CmPossibility in (eventually one of?) the template possibility lists of the DsDiscourseData (a Template).

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | DsDiscourseData:Charts | 2 | collection | DsChart
 | Actual instances of discourse charts (tentatively of all types, even though we currently only have one type: Constituent Chart).


DsConstChart

test num:123 | abbrev: dscc | abstract: false | module: Ling(num:5) | base: DsChart
 | This class represents a Longacre/Levinsohn type Constituent Chart. Syntactic columns vs TextSegment rows. For a brief summary and an example, see Chapter 8 in Dooley and Levinsohn, "Analyzing Discourse".

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | BasedOn | 1 | atomic | StText
 | The linguistic text that the chart organizes (currently part of a Text, but could also be part of Scripture).
test Owning | Rows | 2 | sequence | ConstChartRow
 | The main content of the chart. Each ConstChartRow represents a row/clause.

Back references (sorted by attribute name)

Type Name Num Card Sig


DsDiscourseData

test num:124 | abbrev: dsdd | abstract: false | module: Ling(num:5) | base: CmObject
 | This gathers all the discourse-related material into one place.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | ChartMarkers | 3 | atomic | CmPossibilityList
 | This list stores markers that can be inserted into the chart to provide additional labelling. The top-level is several different kinds of markers (initially Tense/Aspect/Mood, Pronouns, and Demonstatives), and below those are the (sometimes hierarchical) lists of possible markers for that type. Combining them like this makes it easy to add new categories as well as items.
test Owning | Charts | 2 | collection | DsChart
 | Actual instances of discourse charts (tentatively of all types, even though we currently only have one type: Constituent Chart).
test Owning | ConstChartTempl | 1 | atomic | CmPossibilityList
 | Templates describing possible chart organizations. Top level Possibilities are Chart Templates. SubPossibilities represent groups of columns or columns. (This is stretching the idea of 'possibilities' somewhat, and it is unusual that the top-level possibilities are really a different kind of thing from the leaves, but it can be thought of as an extension of the idea that non-leaf nodes perform a grouping function.) Changed from ConstChartTemplates for the port.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LangProject:DiscourseData | 53 | atomic | DsDiscourseData
 | The place for all our discourse analysis data.


FsAbstractStructure

num:60 abbrev: abst abstract: true module: Cellar(num:0) base: CmObject

Direct Subclasses

  • FsFeatStruc
  • FsFeatStrucDisj

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | FsComplexValue:Value | 1 | atomic | FsAbstractStructure


FsClosedFeature

num:50 abbrev: clof abstract: false module: Cellar(num:0) base: FsFeatDefn

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Values | 1 | collection | FsSymFeatVal

Back references (sorted by attribute name)

Type Name Num Card Sig


FsClosedValue

num:51 abbrev: clov abstract: false module: Cellar(num:0) base: FsFeatureSpecification

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Value | 1 | atomic | FsSymFeatVal

Back references (sorted by attribute name)

Type Name Num Card Sig


FsComplexFeature

num:4 abbrev: comf abstract: false module: Cellar(num:0) base: FsFeatDefn

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Type | 1 | atomic | FsFeatStrucType

Back references (sorted by attribute name)

Type Name Num Card Sig


FsComplexValue

num:53 abbrev: cval abstract: false module: Cellar(num:0) base: FsFeatureSpecification

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Value | 1 | atomic | FsAbstractStructure

Back references (sorted by attribute name)

Type Name Num Card Sig


FsDisjunctiveValue

num:54 abbrev: dval abstract: false module: Cellar(num:0) base: FsFeatureSpecification

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Value | 1 | collection | FsSymFeatVal
 | Every Fs*Value class has an attribute of "Value". The only one that has multiple items is FsDisjunctiveValue (after all, how can you have a disjunction with only one item?). In a sense, even for FsDisjunctiveValue, there is only one "value" associated with a disjunction: it's the first one that "works." For consistency within the entire Fs*Value set, the attribute for FsDisjunctiveValue is in the singular as "Value" rather than "Values" even though it is a collection.

Back references (sorted by attribute name)

Type Name Num Card Sig


FsFeatDefn

test num:55 | abbrev: fdef | abstract: true | module: Cellar(num:0) | base:
 | Changed from FsFeatureDefn

Direct Subclasses

  • FsComplexFeature
  • FsOpenFeature
  • FsClosedFeature

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Abbreviation | 2 | MultiUnicode |
test Basic | CatalogSourceId | 9 | Unicode |
 | Needed to make inflection feature catalog UI work.
Basic | Description | 3 | MultiString |
test Basic | DisplayToRightOfValues | 8 | Boolean |
 | For use in the Gloss Assistant: T = Display the value of GlossAbbreviation to the right of any displayed values in the gloss (only if ShowInGloss = T) F = Display to the left (only if ShowInGloss = T) Example: ANIM:CL cf. CL:ANIM representing [ CLASS [ ANIMATE ] ]
test Basic | GlossAbbreviation | 5 | MultiUnicode |
 | Used by the Gloss Assistant to construct glosses. For gloss components that are not to be shown, leave this attribute empty. The gloss abbreviation is distinguished from the standard abbreviation because the latter is used for constructing feature representations where an empty abbreviation would be highly confusing. MultiUnicode to allow for different Abbreviations for the same concept found in different glossing languages.
Basic | Name | 1 | MultiUnicode |
test Basic | RightGlossSep | 6 | MultiUnicode |
 | Specifies the separator symbol that should appear to the right of a gloss component when the Gloss Assistant system constructs a gloss. MultiUnicode to allow for different glossing separators used in different languages. Renamed from RightGlossSeparator for the Firebird port.
test Basic | ShowInGloss | 7 | Boolean |
 | For use in the Gloss Assistant: T = Display the value of GlossAbbreviation in the gloss. F = Do not display the value

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Default | 4 | atomic | FsFeatureSpecification
 | Feature of number might have a default value of singular.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | PartOfSpeech:BearableFeatures | 8 | collection | FsFeatDefn
 | refers to a collection seq of FsFeatureDefn, each of which is a morphosyntactic feature which a word of this part of speech can bear. This is primarily intended for features which may be important to the derivational morphology, although these features may also be relevant to inflectional morphology. For example, the English suffix -ess is added only to animate nouns: waitress, lioness, actress, but *tabless, *officess; ?ful attaches to abstract nouns: graceful, useful, helpful, but *personful, *buildingful, *actorful.The notion of features that a given part of speech can bear is generally implicit in works on morphology, but see Lieber 1992: 90-91.
test Refer'd by | PhFeatureConstraint:Feature | 1 | atomic | FsFeatDefn
 | refers to an FsFeatureDefnPhFeatureNode, the feature with respect to which the constraint ensures agreement (or disagreement).The use of an atomic attr, rather than a seq attr, emulates to a certain extent the insight of autosegmental phonology and feature geometry that a rule can change (or refer to in the environment) only a single feature node. Note however that the fact that the feature can be a nonterminal feature (an FsComplexFeature), allows agreement with respect to a number of features dominated by a single node (e.g. a place of articulation feature, which might dominate the features labial, coronal, and back).
Refer'd by | FsFeatureSpecification:Feature | 3 | atomic | FsFeatDefn
test Refer'd by | FsFeatStrucType:Features | 4 | sequence | FsFeatDefn
 | The order of features will be used in the Gloss Assistant system to put feature values in the correct glossing order. For example, the user may want the FsFeatStrucType of TAM (tense aspect modality) to be ordered Aspect, Modality and Tense.
Owned by | FsFeatureSystem:Features | 3 | collection | FsFeatDefn
test Refer'd by | PartOfSpeech:InflectableFeats | 9 | collection | FsFeatDefn
 | refers to a collection seq of FsFeatureDefn, each of which is a morphosyntactic feature which a word of this part of speech is inflected for. Note that MoInflectionalAffixMsas may be sensitive to other features as well. Changed from InflectableFeatures


FsFeatStruc

test num:57 | abbrev: fstr | abstract: false | module: Cellar(num:0) | base: FsAbstractStructure
 | Changed FsFeatureStructure to FSFeatStruc

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Type | 3 | atomic | FsFeatStrucType
Owning | FeatureDisjunctions | 1 | collection | FsFeatStrucDisj
Owning | FeatureSpecs | 2 | collection | FsFeatureSpecification

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | FsFeatStrucDisj:Contents | 1 | collection | FsFeatStruc
test Owned by | PartOfSpeech:DefaultFeatures | 11 | atomic | FsFeatStruc
A feature structure which specifies features that should be assumed in the absence of any inflectional affixes for the features defined. Example: In English, nouns are by default singular [num:sg].
test Owned by | PartOfSpeech:EmptyParadigmCells | 2 | collection | FsFeatStruc
owns a collection seq of FsFeatStruc, indicating the cells (feature-value combinations) which are disallowed in the paradigm. This is intended to account for defective paradigms, which are not common (e.g. deponent verbs in Greek, which are verbs that have no active forms). Since defective paradigms are relatively rare, this will probably be a seldom-used attribute. It is not intended to account for syncretism in the paradigm, i.e. the situation where one cell 'uses' the affixes of another cell (for which MoReferralRules are supplied instead, should disjunctive ordering of the affixes in an MoInflAffixSlot not suffice.).Since this attribute is defined at the level of the part of speech, it is not possible to define cells which are empty in only one inflection class. It is not obvious that this is correct, e.g. it is not obvious that deponent verbs in Greek belonged to a separate part of speech from other verbs. Pluralia tantum words like scissors and trousers are another example, since it is not clear that they belong to a separate part of speech from other nouns. Yet another example of a set of words that cannot plausibly be assigned to a separate category comes from Russian. Halle (1973: 7-8) says there are about a hundred verbs, all in a particular conjugation class, which lack first person singular non-past forms. It is unclear what the status of this gap is; it may be semantically or pragmatically based (some of the glosses are 'I conquer', 'I talk rudely', 'I behave foolishly'). According to Halle, "Russian grammar books frequently note that such forms… 'do not exist', or 'are not used', or 'are avoided'." Perhaps this is more of a sociolinguistic issue. Jensen (1990: 117-119) discusses some other defective paradigms, although he admits that his Latin examples are suspect: the defective paradigm is based on the corpus of Latin literature, and it may be that the corpus, not the paradigm, is defective. Jensen also lists as examples a few French verbs which lack certain forms: "cloré ['to close, enclose']… lacks the passé simple and the first and second persons plural of the present. Gésir ['to lie'] lacks all tenses but the present and imperfect indicative, and lacks the first and second persons singular of the present." He notes that synonyms supply the missing forms, so these gaps probably cannot be explained on semantic or pragmatic grounds. Jensen also gives as examples English modal verbs, which lack participle and 'infinitive' (to V) forms. In this case, the customary solution is to create a separate part of speech (modals), as a subclass of the category Verb.There are at least two verbs in English with defective paradigms: sight-see (*sight-sees, *sight-saw, sight-seen-but sight-seeing), and beware (which occurs only in this base form. Another puzzle with respect to defective paradigms, is the fact that while the singular of pluralia tantum words is ungrammatical in isolation, they are found in compounds: scissor-handle and trouser-leg. It is not clear how a defective distribution of certain elements of the paradigm should be handled. Matthews (1972a: 197, fn. 2) suggests that defective paradigms be handled in the syntax, although it is unclear how this would work.
test Owned by | MoGlossItem:FeatStructFrag | 8 | atomic | FsFeatStruc
A gloss item in the language-specific gloss system is formalized by a feature structure fragment. The feature structure for a glossed morpheme is thus the unification of all the feature structure fragments for its component gloss items. When the user selects gloss items from the language-specific gloss system to form a composite gloss, this analysis is stored in the MSA as a gloss bundle (which an attribute on MSA that stores a set of references to all the selected gloss items). The language-specific feature structure for an MSA is automatically generated by computing the unification of all the feature structure fragments in the gloss bundle. Changed from FeatureStructureFragment.
test Owned by | PhNCFeatures:Features | 1 | atomic | FsFeatStruc
owns an FsFeatStruc, specifying the feature values which characterize this natural class. The meaning is that any phoneme which includes (N.B.: not unifies with) the specified feature values matches this natural class.
Owned by | CmAnnotation:Features | 8 | atomic | FsFeatStruc
test Owned by | PhPhoneme:Features | 2 | atomic | FsFeatStruc
The Features attribute is how the user provides the phonological features of a phoneme (phonological segment). This means that the features contained in the FsFeatStruc must be from LangProject:PhFeatureSystem.
test Owned by | MoDerivAffMsa:FromMsFeatures | 1 | atomic | FsFeatStruc
specifies the morphosyntactic features which the stem to which this affix attaches must bear. See also the discussion of the FromPartOfSpeech attribute above.
test Owned by | MoDeriv:InflectionalFeats | 3 | atomic | FsFeatStruc
Owns (but see below) an FsFeatStruc giving the inflectional features (to be) realized in this derivation. It is not clear whether this should be an owning or virtual attr. If derivations are always owned by some higher object that could logically hold such a feature structure (e.g. a test case or a cell in a paradigm), then this attr should just return that feature structure. Changed from InflectionalFeatures.
test Owned by | MoDerivStepMsa:InflFeats | 3 | atomic | FsFeatStruc
Owns an FsFeatStruc, giving the morphosyntactic features which the word is to be inflected for at the end of the derivation. Changed from InflectionFeatures for the database port.
test Owned by | MoInflAffMsa:InflFeats | 1 | atomic | FsFeatStruc
Owns an FsFeatStruc, representing the morphosyntactic features realized by this affix. Most commonly, the feature values of this FsFeatStruc will belong to the PartOfSpeechGrammar.doc - PartOfSpeech.vAllInflectableFeatures of the stem to which the inflectional affix attaches, but may also include any of the features in the vAllInherentFeatureValues or vAllBearableFeatures attrs. For example, in Tzeltal there are two incompletive aspect prefixes, distinguished by whether the stem to which they attach is transitive or intransitive. The aspect feature would be an inflectable feature of verbs, but the transitivity feature would be either an inherent feature of the stem (assuming transitive and intransitive verbs have distinct parts of speech) or a bearable feature (if transitive and intransitive verbs are both treated as having the part of speech verb, and are distinguished by the transitivity feature alone). In determining what feature values can be added to a given FsFeatStruc, it will probably be desirable to disallow conflicting feature values (or even assigning the same feature value twice). However, it is permissible to have two different feature values at different places in an FsComplexValue; for example, [[Subject [Person 1]] [Object [Person 2]]]. In the course of a stealth-to-wealth analysis, a single affix might occupy a set of cells in a paradigm, where the cells do not form a natural class, and where they are not an 'elsewhere' case, or at least the user does not recognize them as such. This situation can be accommodated by the use of FsFeatStruc.FeatDisj. The goal at the 'wealth' end would be to find a natural class for the cells, thereby eliminating the feature disjunction, or to use disjunctive ordering within an MoInflAffixSlot to allow the statement of the features in a non-disjunctive manner. Changed from InflectionFeatures for the database port.
test Owned by | PartOfSpeech:InherFeatVal | 1 | atomic | FsFeatStruc
Owns a FsFeatStruc, representing (some of) the feature values inherently associated with this category (e.g. [+N +V]). Changed from InherentFeatureValues
test Owned by | MoReferralRule:Input | 3 | atomic | FsFeatStruc
owns an FsFeatStruc, constituting the morphosyntactic feature values which must be present in a word in order for this Rule of Referral to apply. Often these features form an 'environment' which is not altered in the Output. However, this is true only if the input features are disjunctive with the output features. For instance, suppose in some language the nominative plural of nouns is syncretic with the nominative singular. Assuming singular and plural are the two possible values of 'number' in this language, this syncretism can be represented by a rule which has as input [case: nominative] and as output [number: singular]. But it is not always possible to make the input and output features disjunctive, particularly (but not only) where features are non-binary. For example, if the above syncretism held in a language which distinguished dual number, and the nominative dual was distinct from the singular (and plural) nominative forms, then it would be necessary to mention the 'number' feature both in the input and in the output, to prevent the rule from overapplying to the dual. It might be possible (and desirable) to have a view of rules of referral in which the input features which are unaffected in the output are distinguished (as a sort of environment) from the input features which are changed in the output. Additional notes: In Stump's (1993a, (11) page 457) format for a Rule of Referral, this corresponds to τ on the left-hand side.
test Owned by | MoAffixAllomorph:MsEnvFeatures | 1 | atomic | FsFeatStruc
owns an FsFeatStruc, defining the morphosyntactic features which the stem to which this affix attaches must bear. See discussion of the MsEnvPartOfSpeech attribute above.
test Owned by | MoDerivStepMsa:MsFeatures | 2 | atomic | FsFeatStruc
owns an FsFeatStruc, giving the morphosyntactic features which result from percolation. N.B.: This does not include inflectional features which are to be realized by inflectional affixes (and which may be incompatible with the current part of speech, or contradict percolated features).
test Owned by | MoStemMsa:MsFeatures | 1 | atomic | FsFeatStruc
gives any morphosyntactic features belonging to the stem in addition to those specified by PartOfSpeech.InherentFeatureValues. In most cases, there will be none, but this attribute may be useful for exceptional words (such as the pluralia tantum words pants and scissors, which are grammatically plural even though the default for English nouns is singular). The features are restricted to those in vAllPossibleFeatures of my PartOfSpeech.
test Owned by | WfiAnalysis:MsFeatures | 4 | atomic | FsFeatStruc
WfiAnalysis parallels MorphoSyntacticItem in the lexical database. Allowing MSFeatures here allows the user to easily convert a wordform to a subentry. This also supports S2W in that a user may know the features that a wordform bears but not its component parts (e.g may know that it's plural without knowing what the plural morpheme is). Additionally, in the case of suppletion, there may not be a morpheme to identify.
test Owned by | MoReferralRule:Output | 4 | atomic | FsFeatStruc
Constitutes the morphosyntactic feature values which the Rule of Referral outputs. Additional notes: In Stump's (1993a, (11) page 457) format for a Rule of Referral, this corresponds to [F1:v1...Fm:Vm]. Note that the input and output fields may refer to the same features, albeit with different values. This is particularly likely for non-binary features (see Stump's rules (20) and (28), for example), but may also be necessary with binary features (e.g. Stump's rule (54b)). Accordingly, it would be possible to split the input features into a set of features whose values will be changed in the output, and a set of features which effectively form the environment for the change. This could even be done in the 'view' of the rule.
test Owned by | MoInflClass:ReferenceForms | 7 | collection | FsFeatStruc
ReferenceForms: owns a collection of FsFeatStruc, each of which defines the cell whose inflection uniquely picks out an inflection class. (Cf. Carstairs-McCarthy 1991, particularly section 8). Usually, the reference forms belonging to a PartOfSpeech will suffice for all the MoInflectionClasses, i.e. a single "Primary Reference Form" (Carstairs-McCarthy's term). In some cases, however, it may prove necessary to provide a secondary reference form to distinguish among "mixed" classes (see again the discussion in Carstairs-McCarthy 1991.) This attr is then where the secondary reference form would be stored. The classes which need to be distinguished by ReferenceForms will presumably constitute the members of the Subclasses attr of some parent inflection class, together with that parent inflection class. The appropriate class to list the ReferenceForms will then be that parent class, and the daughter classes will inherit that property via their vAllReferenceForms (see below). Note that this attribute performs no particular function in any of the algorithms used for computing affixed forms. However, it may be useful in the context of a dictionary, e.g. for providing principal parts.
test Owned by | PartOfSpeech:ReferenceForms | 10 | collection | FsFeatStruc
owns a collection seq of FsFeatStruc, each of which defines the cell whose inflection uniquely picks out an inflection class. (Cf. Carstairs-McCarthy 1991, particularly section 8). Usually, the reference forms belonging to a part of speech will suffice for all the MoInflectionClasses, i.e. a single "Primary Reference Form" (Carstairs-McCarthy's term). In some cases, however, it may prove necessary to provide a secondary reference form to distinguish among "mixed" classes (see again the discussion in Carstairs-McCarthy 1991.) Any secondary reference forms are provided in the attr of the same name of the particular MoInflectionClasses to which they pertain.Note that this attribute performs no particular function in any of the algorithms used for computing affixed forms. However, it may be useful in the context of a dictionary, e.g. for providing principal parts.
test Owned by | MoInflAffixTemplate:Region | 5 | atomic | FsFeatStruc
owns an FsFeatStruc defining the region of the paradigm for which this template is relevant. The idea here is that in some regions of the template (typically, things like participles or imperatives), there may be fewer affix slots than in other regions. While one could use the same template for all regions, with affixes in some of the slots restricted to appearing only with certain features (such as [?participle]), this is probably not the simplest analysis (since it requires all affixes in those slots to be so marked, including what would otherwise be default affixes). If this attr is empty, then this template pertains to the entire paradigm except for any regions covered by templates ordered before this one in the PartOfSpeech.AffixTemplates attr of the owner.
test Owned by | MoStemName:Regions | 4 | collection | FsFeatStruc
owns a collection of FsFeatStrucs. Conceptually, this is analogous to MoInflectionalAffixMsa.InflectionalFeatures, defining the parts of the paradigm that use this stem. However, unlike an inflectional affix, it is possible for a stem to have more than one FsFeatStruc and therefore pertain to more than one contiguous region of a paradigm, i.e. a stem need have no particular (or at least no consistent) semantics over and above the semantics of the lexeme it belongs to. (Again, see Aronoff 1992.) An example is the '1sg/subj' stem which for many Spanish verbs is used for the past subjunctive and the 1sg present indicative, such as teng- 'have'. In addition to being relevant to one or more regions of a paradigm, a stem may be relevant to derivational morphology. This is indicated in the model by referencing the MoStemName from the MoDerivationalAffixMsa.
test Owned by | MoDerivAffMsa:ToMsFeatures | 2 | atomic | FsFeatStruc
ToMsFeatures: owns a FsFeatStruc, giving the morphosyntactic features which the word derived from this affix contains. In brief, the morphosyntactic features of the output word will contain all these feature values plus any nonconflicting feature values of the stem, provided the features are included in PartOfSpeech.BearableFeatures or PartOfSpeech.InflectableFeatures of the output word. (Or putting it differently, the ToMsFeatures override any conflicting features which would otherwise be percolated up from the stem.)


FsFeatStrucDisj

test num:58 | abbrev: fsd | abstract: false | module: Cellar(num:0) | base: FsAbstractStructure
 | Note: the type of an FsFeatStrucDisj should be inherited from that of its disjuncts, and the types of those disjuncts must be the same. (MM: Sep 2001) Changed FsFeatureStructureDisJunction to FsFeatStrucDisj

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Contents | 1 | collection | FsFeatStruc

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | FsFeatStruc:FeatureDisjunctions | 1 | collection | FsFeatStrucDisj


FsFeatStrucType

test num:59 | abbrev: fst | abstract: false | module: Cellar(num:0) | base: CmObject
 | Changed FsFeatureStructureType to FsFeatStrucType

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Abbreviation | 2 | MultiUnicode |
test Basic | CatalogSourceId | 5 | Unicode |
 | Needed to make inflection feature catalog UI work.
Basic | Description | 3 | MultiString |
Basic | Name | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Features | 4 | sequence | FsFeatDefn
 | The order of features will be used in the Gloss Assistant system to put feature values in the correct glossing order. For example, the user may want the FsFeatStrucType of TAM (tense aspect modality) to be ordered Aspect, Modality and Tense.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | FsFeatStruc:Type | 3 | atomic | FsFeatStrucType
Refer'd by | FsComplexFeature:Type | 1 | atomic | FsFeatStrucType
Owned by | FsFeatureSystem:Types | 2 | collection | FsFeatStrucType


FsFeatureSpecification

num:56 abbrev: fspc abstract: true module: Cellar(num:0) base: CmObject

Direct Subclasses

  • FsOpenValue
  • FsComplexValue
  • FsSharedValue
  • FsNegatedValue
  • FsClosedValue
  • FsDisjunctiveValue

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | RefNumber | 1 | Integer | min: 0 | max:268435455
Basic | ValueState | 2 | Integer | min: 0 | max:15

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Feature | 3 | atomic | FsFeatDefn

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | FsFeatDefn:Default | 4 | atomic | FsFeatureSpecification
 | Feature of number might have a default value of singular.
Owned by | FsFeatStruc:FeatureSpecs | 2 | collection | FsFeatureSpecification
Refer'd by | FsSharedValue:Value | 1 | atomic | FsFeatureSpecification


FsFeatureSystem

num:49 abbrev: fsys abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Features | 3 | collection | FsFeatDefn
Owning | Types | 2 | collection | FsFeatStrucType

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:MsFeatureSystem | 21 | atomic | FsFeatureSystem
test Owned by | LangProject:PhFeatureSystem | 154 | atomic | FsFeatureSystem
 | This feature system contains the phonological features used by phonological rules. They are kept separate from the morpho-syntactic features in the MsFeatureSystem attribute.


FsNegatedValue

num:61 abbrev: nval abstract: false module: Cellar(num:0) base: FsFeatureSpecification

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Value | 1 | atomic | FsSymFeatVal

Back references (sorted by attribute name)

Type Name Num Card Sig


FsOpenFeature

num:62 abbrev: opf abstract: false module: Cellar(num:0) base: FsFeatDefn

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | WritingSystem | 2 | Unicode |
test Basic | WsSelector | 3 | Integer |
 | Refer to documentation on CmPossibilityList_WsSelector.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


FsOpenValue

num:63 abbrev: oval abstract: false module: Cellar(num:0) base: FsFeatureSpecification

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Value | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


FsSharedValue

num:64 abbrev: sval abstract: false module: Cellar(num:0) base: FsFeatureSpecification

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Value | 1 | atomic | FsFeatureSpecification

Back references (sorted by attribute name)

Type Name Num Card Sig


FsSymFeatVal

test num:65 | abbrev: fval | abstract: false | module: Cellar(num:0) | base: CmObject
 | Renamed from FsSymbolicFeatureValue for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Abbreviation | 2 | MultiUnicode |
test Basic | CatalogSourceId | 7 | Unicode |
 | Needed to make inflection feature catalog UI work.
Basic | Description | 3 | MultiString |
test Basic | GlossAbbreviation | 4 | MultiUnicode |
 | Used by the Gloss Assistant to construct glosses. For gloss components that are not to be shown, leave this attribute empty. The gloss abbreviation is distinguished from the standard abbreviation because the latter is used for constructing feature representations where an empty abbreviation would be highly confusing.
Basic | Name | 1 | MultiUnicode |
test Basic | RightGlossSep | 5 | MultiUnicode |
 | Specifies the separator symbol that should appear to the right of a gloss component when the Gloss Assistant system constructs a gloss. MultiUnicode to allow for different glossing separators used in different languages. Changed from RightGlossSeparator for the Firebird Port.
test Basic | ShowInGloss | 6 | Boolean |
 | For use in the Gloss Assistant: T = Display the value of GlossAbbreviation in the gloss. F = Do not display the value

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | FsClosedValue:Value | 1 | atomic | FsSymFeatVal
Refer'd by | FsNegatedValue:Value | 1 | atomic | FsSymFeatVal
test Refer'd by | FsDisjunctiveValue:Value | 1 | collection | FsSymFeatVal
 | Every Fs*Value class has an attribute of "Value". The only one that has multiple items is FsDisjunctiveValue (after all, how can you have a disjunction with only one item?). In a sense, even for FsDisjunctiveValue, there is only one "value" associated with a disjunction: it's the first one that "works." For consistency within the entire Fs*Value set, the attribute for FsDisjunctiveValue is in the singular as "Value" rather than "Values" even though it is a collection.
Owned by | FsClosedFeature:Values | 1 | collection | FsSymFeatVal


LangProject

test num:1 | abbrev: lgpr | abstract: false | module: LangProj(num:6) | base: CmProject
 | Renamed from LanguageProject for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | AnalysisWss | 17 | Unicode |
 | Changed from AnalysisWritingSystems This is a space-delimited list of writing system tags.
test Basic | CurAnalysisWss | 19 | Unicode |
 | This is a space-delimited list of writing system tags.
test Basic | CurPronunWss | 20 | Unicode |
 | Changed from CurrentPronunciationWritingSystems This is a space-delimited list of writing system tags.
test Basic | CurVernWss | 18 | Unicode |
 | Changed from CurrentVernacularWritingSystems This is a space-delimited list of writing system tags
Basic | EthnologueCode | 1 | Unicode |
test Basic | ExtLinkRootDir | 42 | Unicode |
 | External Link Root Directory: External links may have a full path name or a relative path name. This property holds the relative path definition when relative path names are used. It could be a physical path name (e.g., c:\FwData) or a network name that could be accessed by other users (e.g., \\ls-daffy\FwData).
Basic | FieldWorkLocation | 4 | MultiUnicode |
Basic | MainCountry | 3 | MultiUnicode |
test Basic | VernWss | 41 | Unicode |
 | Changed from VernacularWritingSystems This is a space-delimited list of writing system tags.
Basic | WorldRegion | 2 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Thesaurus | 9 | atomic | CmPossibilityList
Refer | WordformLookupLists | 11 | collection | WordformLookupList
Owning | ActivatedFeatures | 46 | collection | UserAppFeatAct
test Owning | AffixCategories | 34 | atomic | CmPossibilityList
 | In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. The AffixCategoryList is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a MoAffixCategory of "derv" (derivational affix). Refer to MoInflectionalAffixMsa and MoDerivationalAffixMsa for more information.
Owning | AnalysisStatus | 29 | atomic | CmPossibilityList
test Owning | AnalyzingAgents | 38 | collection | CmAgent
 | At this point, in time (Jan, 2002) CmAnalyzingAgents are used only by MoMorphological data. Refer to CmAnalyzingAgent for more info.
test Owning | AnnotationDefs | 47 | atomic | CmPossibilityList
 | Changed from AnnotationDefinitions.
Owning | Annotations | 44 | collection | CmAnnotation
Owning | AnthroList | 12 | atomic | CmPossibilityList
test Owning | CheckLists | 50 | collection | CmPossibilityList
 | The CheckLists will be a collection of CmPossibilityList objects, each with a unique identifier. For example, one CmPossibilityList will be called KeyTerms which will represent a hierarchical list of Biblical key terms. The possibility lists can be imported programmatically from external files. Each CmPossibilityList will hold ChkItem objects (derived from CmPossibility).
Owning | ConfidenceLevels | 25 | atomic | CmPossibilityList
test Owning | DiscourseData | 53 | atomic | DsDiscourseData
 | The place for all our discourse analysis data.
Owning | Education | 32 | atomic | CmPossibilityList
Owning | Filters | 24 | collection | CmFilter
test Owning | GenreList | 52 | atomic | CmPossibilityList
 | This property holds the list of defined genres (instances of CmPossibility) used by texts.
Owning | LexDb | 14 | atomic | LexDb
Owning | Locations | 30 | atomic | CmPossibilityList
test Owning | Media | 51 | collection | CmFolder
 | This contains a lit of folders holding media file objects. For now, we will have one CmFolder called "Local Media" that holds all media.
Owning | MorphologicalData | 22 | atomic | MoMorphData
Owning | MsFeatureSystem | 21 | atomic | FsFeatureSystem
Owning | Overlays | 37 | collection | CmOverlay
Owning | PartsOfSpeech | 5 | atomic | CmPossibilityList
Owning | People | 31 | atomic | CmPossibilityList
test Owning | PhFeatureSystem | 154 | atomic | FsFeatureSystem
 | This feature system contains the phonological features used by phonological rules. They are kept separate from the morpho-syntactic features in the MsFeatureSystem attribute.
Owning | PhonologicalData | 35 | atomic | PhPhonData
Owning | Pictures | 48 | collection | CmFolder
Owning | Positions | 36 | atomic | CmPossibilityList
Owning | ResearchNotebook | 15 | atomic | RnResearchNbk
Owning | Restrictions | 26 | atomic | CmPossibilityList
Owning | Roles | 28 | atomic | CmPossibilityList
Owning | SemanticDomainList | 49 | atomic | CmPossibilityList
Owning | Styles | 23 | collection | StStyle
test Owning | TextMarkupTags | 55 | atomic | CmPossibilityList
 | Top eval Possibilities are major tag categories ( Syntax, Semantics, RRG, etc.) The actual tags are their SubPossibilities [After V1, more hierarchy may be possible.]
Owning | Texts | 6 | collection | Text
Owning | TimeOfDay | 33 | atomic | CmPossibilityList
Owning | TranslatedScripture | 40 | atomic | Scripture
Owning | TranslationTags | 7 | atomic | CmPossibilityList
Owning | UserAccounts | 45 | collection | UserConfigAcct

Back references (sorted by attribute name)

Type Name Num Card Sig


LexAppendix

num:46 abbrev: apdx abstract: false module: Ling(num:5) base: CmObject

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Contents | 1 | atomic | StText

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LexDb:Appendixes | 2 | collection | LexAppendix
Refer'd by | LexSense:Appendixes | 4 | collection | LexAppendix


LexDb

test num:5 | abbrev: ldb | abstract: false | module: Ling(num:5) | base: CmMajorObject
 | This is the main class for the lexical database. See the LexicalDatabases domain documentation for an overview describing general concepts and external connections. Most of the internal structure is described in subdomains of this same reference. Renamed from LexicalDatabase for the port to Firebird.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | IsBodyInSeparateSubentry | 14 | Boolean |
test Basic | IsHeadwordCitationForm | 13 | Boolean |
 | Used for flags to determine which form to use for headword, etc.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | AllomorphIndex | 11 | collection | MoForm
Refer | LexicalFormIndex | 10 | collection | LexEntry
Owning | Appendixes | 2 | collection | LexAppendix
test Owning | ComplexEntryTypes | 23 | atomic | CmPossibilityList
This Complex Entry Types list is used to classify a LexEntryRef via the ComplexEntryTypes property. ItemClsid should be set to LexEntryType, IsSorted to true, and Depth to 127. The list will typically be flat, but the user is free to introduce a hierarchy if desirable. When entries use this list, they will be displayed as subentries in the dictionary. Entries using this list will be displayed as subentries in the dictionary; usually at the end of the major entry and will typically produce a separate major entry in the dictionary referring to the main entry. The display is dependent on whether a root-based or stem-based view of the dictionary is being printed. The initial list may have: Acronym Compound Contractions Derivation Idiom Phrasal Verb Saying
Owning | DomainTypes | 7 | atomic | CmPossibilityList
test Owning | Entries | 1 | collection | LexEntry
This is a list of all types of entries. It is sorted by citationForm, thus we no longer need the citationForm index.
Owning | Introduction | 12 | atomic | StText
Owning | MorphTypes | 8 | atomic | CmPossibilityList
test Owning | References | 19 | atomic | CmPossibilityList
This holds the possibility list that holds LexRefType items which own the actual references.
test Owning | Resources | 21 | collection | CmResource
The named external resources (e.g. xml files) used by FLEX and their version numbers.
test Owning | ReversalIndexes | 17 | collection | ReversalIndex
Ken Zook: We are pretty well beyond the point where we'll ever allow multiple language projects in a database, so I think it's time we make these indexes owned. Since they are really part of the lexical database, I'm recommending they be owned by the lexical database.
Owning | SenseTypes | 5 | atomic | CmPossibilityList
Owning | Status | 15 | atomic | CmPossibilityList
Owning | UsageTypes | 6 | atomic | CmPossibilityList
test Owning | VariantEntryTypes | 22 | atomic | CmPossibilityList
This Variant Entry Types list is used to classify a LexEntryRef via VariantEntryTypes. ItemClsid should be set to LexEntryType, IsSorted to true, and Depth to 127. The list is hierarchical with the top level being the type of variant (e.g., dialectal) and subitems being the conditions (e.g., British English, American English) for that type of variant. Normally the user will set this property to a subitem, although a top level item could be used if the user does not want to specify the condition. The user is free to provide additional nesting if useful. All items in the list will be LexEntryType, so the user will need to specify an appropriate Abbreviation and ReverseAbbr for each item in the list. This gives greater control to the user than having the program try to piece together information from a hierarchy of LexEntryTypes. The Abbreviation is used when displaying the main entry from the minor entry (e.g., Brit. dial. of color). The ReverseAbbr is used when displaying the minor entry from the main entry (e.g., Brit. dial. colour). Entries using this list will be displayed as minor entries in the dictionary; usually following the main entry headword and will typically produce a separate minor entry in the dictionary referring to the main entry. The initial list may have: Dialectal Variant British American Free Variant Inflectional Variant Singular Plural First Person Singular (1SG) Third Person Singular Present (3SG.PRES) Location New York Los Angeles Register Formal Informal Sociolect Upper Class Lower Class Spelling Variant

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:LexDb | 14 | atomic | LexDb


LexEntry

test num:2 | abbrev: ent | abstract: false | module: Ling(num:5) | base: CmObject
 | This class describes the attributes common to LexMinorEntry, LexMajorEntry and their subclasses.Ken, I added the virtual lexicalForm but I think that we need to add this as an owning attribute.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Bibliography | 12 | MultiString |  |
 | Bibliographic information
test Basic | CitationForm | 3 | MultiUnicode |  |
 | If this is missing, then this defaults to the lexicalForm but the user has the option of specifying a real citation form especially useful for bound roots.
test Basic | Comment | 25 | MultiString |  |
 | Free text field for notes about environment of a variant or any other note. (This used to be on LexVariant and LexMinorEntry.)
Basic | DateCreated | 5 | Time |  |
Basic | DateModified | 6 | Time |  |
test Basic | DoNotUseForParsing | 26 | Boolean |  |
 | The user may initially add entries not knowing if they are highly regular/predictable. Once discovering that an entry is "non-lexical", the user may still want to retain for example sentences, conjugation charts, etc. This boolean specifies that the parser is not to use the morphs or MSA info in its parsing. Default = False.
test Basic | ExcludeAsHeadword | 27 | Boolean |  |
 | By default each entry will show up as a headword. If this flag is set, then dictionary views should not include this item as a headword. (This replaces IsIncludedAsHeadword so that 0 can be the default.)
Basic | HomographNumber | 1 | Integer | min: 0 | max:255
test Basic | ImportResidue | 32 | String-big |  |
 | A place where we can store standard format markers that are not processed in any other way.
test Basic | LiftResidue | 33 | Unicode-big |  |
 | Stores XML data that's not part of our model.
test Basic | LiteralMeaning | 18 | MultiString |  |
 | This field is here for ease of use for the user. However, if the user fills out the components on the MSA of the subentry, the literal meaning can be derived. If Literal Meaning is empty and the components are filled in, the derived literal meaning should be displayed as virtual (in italics perhaps?) (It used to be on LexSubentry.)
test Basic | Restrictions | 14 | MultiUnicode |  |
 | Only certain people can use the entry under certain circumstances
test Basic | SummaryDefinition | 17 | MultiString |  |
 | This is a short definition at an entry level. (It used to be on LexMajorEntry.)

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | MainEntriesOrSenses | 19 | sequence | CmObject
 | If a user has specified Morphology, then FW should by default set a link to the entry that has a morph type of root. In the case of two or more roots, FW makes an arbitrary decision. Like other parts of the WW system, default choices should be indicated to the user so they can review them. In the majority of cases for subentry-like entries this will be only one entry (establishment points to establish) but with the possibility of more for entries that have more than one root in them (blackboard may point to board and black). For inflected forms, there will ALWAYS be only one entry pointed to (men points to man). (This used to be on LexSubentry and MainEntryOrSense on LexMinorEntry.) Subentries can be "subs" of either a major entry, another subentry, a minor entry (very rare) or a particular sense of any of the above. In this latter case, common in Philippine and Indonesian lexicons, the subentry usually appears under the sense of the entry.
test Owning | AlternateForms | 30 | sequence | MoForm
 | This holds alternate forms, or allomorphs, in addition to the lexeme form. The lexeme form is also an allomorph if it is not abstract. These forms along with the lexeme form (when not abstract) are used by the parser.
test Owning | EntryRefs | 34 | sequence | LexEntryRef
 | This property is empty for main entries. For variant and complex entries, one or more LexEntryRef is used to point to the major entries. One variant entry could apply to more than one main entry, so each one could have a separate LexEntryRef. It’s possible for an entry to be a complex entry as well as a variant. This could be represented by one or more LexEntryRefs. Some may want to order multiple entries in a particular way, so we have a sequence instead of a collection.
test Owning | Etymology | 13 | atomic | LexEtymology
 | Each entry can have one etymology specification.
test Owning | LexemeForm | 29 | atomic | MoForm
 | The lexeme form is the form of the entry that is normally used by linguists in interlinear text. The lexeme form is either the default allomorph for this lexEntry (e.g. French 'march' as opposed to citation form 'marcher') or the abstract underlying representation of it. (e.g. -[C][V]^2) When it is an abstract representation, the IsAbstract property is set. The lexeme form is equivalent to the base form in LinguaLinks or the \lx field in MDF files.
Owning | MorphoSyntaxAnalyses | 9 | collection | MoMorphSynAnalysis
test Owning | Pronunciations | 31 | sequence | LexPronunciation
 | We may need more than one pronunciation per entry. For example either/neither have two different pronunciations. Some people may want to order these based on frequency of use, so it is a sequence instead of a collection.
test Owning | Senses | 11 | sequence | LexSense
 | I am not currently sure whether senses belong on minor entries or not but we did allow this in LinguaLinks so I will leave it here for now for compatibility's sake.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LexDb:Entries | 1 | collection | LexEntry
 | This is a list of all types of entries. It is sorted by citationForm, thus we no longer need the citationForm index.
Refer'd by | LexDb:LexicalFormIndex | 10 | collection | LexEntry
test Refer'd by | WfiAnalysis:Stems | 5 | collection | LexEntry
 | In a thorough analysis this attribute will not be used. However, if the linguist wishes to only analyze stems this is an easy way to accomplish this.


LexEntryRef

test num:127 | abbrev: ler | abstract: false | module: Ling(num:5) | base: CmObject
 | A LexEntryRef object is a general purpose link from a variant or complex entry to one or more major entries. It also classifies the link using variant and/or complex entry types that determine how the references are displayed (e.g., minor entry or subentry, and the abbreviations associated with the reference). The UI may restrict what gets used in a particular LexEntryRef. For example, for a variant entry, the UI might limit VariantEntryTypes to a single type and PrimaryLexemes to a single entry while hiding ComplexEntryTypes and ComponentLexemes. For complex entries it might limit ComplexEntryTypes to a single type and hide VariantEntryTypes. On the other hand, the UI could make all of these available so the user could set combinations of variant and complex entries from a single LexEntryRef when they refer to the same major entries.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | HideMinorEntry | 5 | Integer
This field indicates whether the variant or compound entry should be listed as a minor entry referencing the main entry in the lexicon. The lexicographer typically wants to limit minor entries to ones that are not alphabetically close to the main entry. It defaults to 0 which is easiest to implement in the model and is probably the most common situation. The UI for this could say Show Minor Entry, if desired. If there are multiple LexEntryRefs in the same entry, the entry will show as a minor entry unless all of the LexEntryRefs have HideMinorEntry set to 1. The minor entry would only display information for LexEntryRefs that have this property set to 0. For example, we could limit a reference on a minor entry (e.g., Entry: man (pl. men) Entry: people (reg. var. men) Minor Entry: men pl. of man, but not reg. var. of people) I don’t think this is a good example, but I suspect someone might have a productive derivation where they would only want to list a few of the references in the minor entry. By leaving this property on LexEntryRef, this would be possible. If we are certain that everyone will always want to list every occurrence in a minor entry for a variant or a subentry, then we could add this to LexEntry instead of LexEntryRef. We are using an integer instead of a Boolean for the possibility of controlling printing for different dictionary publications. Each bit in the integer could represent a Boolean for a particular dictionary, thus allowing 32 different dictionaries. We are not implementing the support for multiple dictionaries at this point, and the final design may use a different means for controlling minor entries.
Basic | LiftResidue | 7 | Unicode-big
test Basic | RefType | 8 | Integer | max:127
This property is needed in the UI to know whether the current LexEntryRef should show up as a variant or a complex form. We currently use VariantTypes and ComplexFormTypes to determine this, but there are occasions when both of these are missing but we still need to show something in the UI. This integer will be used as an enum with 0 for variants and 1 for complex forms. We may later need to specify inflected forms and perhaps combinations of these.
test Basic | Summary | 6 | MultiString
This field is available for summary information to show with the variant info being displayed from the main entry. It may be in more than one language and might support formatting and embedded languages. Chuck Grimes feels this is important and it is not simply the gloss of the variant entry. This field would contain the MDF \ve, \vn, and \vr information, which may be the name of a dialect and/or any pertinent comment, such as usage restrictions, simple gloss, or inflection. In MDF the contents of \ve is displayed after the variant in parentheses. Since the \ve field is imported from the major entry, and the \ve may differ for the same \va used in different entries, by storing the information with the LexEntryRef we do not lose anything. If we imported it into the SummaryDefinition of the minor entry, we would have to concatenate the various \ve fields and would lose the distinction of which reference they came from. However, my searches so far have not uncovered any place two different main entries refer to the same variant entry, If this does not happen, we could probably ignore this and just use the SummaryDefinition of the minor entry. When displaying the variant entry in a main entry, this summary could be printed following the variant headword. When displaying a subentry in a main entry in the stem-based format, this summary would be displayed following the subentry headword. Would we ever need a different summary for two different LexEntryRefs owned by the same entry? If not, we could do without this property.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | ComplexEntryTypes | 2 | sequence | LexEntryType
This property points to one or more items in the Complex Entry Types list for complex entries. It is unused for variant entries, although the model allows for both to be used if desirable. Normally a complex LexEntryRef will point to more than one main entry or sense via PrimaryLexemes and ComponentLexemes. Entries using ComplexEntryTypes will be displayed as subentries in the dictionary; usually at the end of the major entry and will typically produce a separate major entry in the dictionary referring to the main entry. The display is dependent on whether a root-based or stem-based view of the dictionary is being printed. The referenced LexEntryType is used to control the display of the complex information in the main entry context as well as the minor entry context. See the description of VariantEntryTypes for using the information from the LexEntryRef for display purposes.
test Refer | ComponentLexemes | 4 | sequence | CmObject
The UI limits this to a sequence of LexEntry or LexSense. For variants, this field points to the main entry or sense. When not hidden, this will produce a minor variant entry that always shows the main entry referenced here. This variant will always be shown in the main entry being referenced. ComponentLexemes is ignored in this case. For complex entries, this property lists the components for this idiom, derivation, compound, etc. All of the listed components will be displayed in the subentry following the headword. For example, emphanizoo (cmpd. of en, pha, -an, -id). Whether they get displayed as subentries is controlled by the PrimaryLexemes property. This allows the user to specify component lexemes for productive lexemes without cluttering the printed dictionary.]
test Refer | PrimaryLexemes | 3 | sequence | CmObject
The UI limits this to a sequence of LexEntry or LexSense. For variants, this field is unused. For complex entries, this field points to a subset of ComponentLexemes. The entries or senses in this property determine the main entries that will have subentries generated for this entry. For example, if ComponentLexemes has kick, the, bucket, and PrimaryLexemes only has kick, then kick is the only entry that will show a ‘kick the bucket’ subentry in a root-based display.
test Refer | VariantEntryTypes | 1 | sequence | LexEntryType
This points to one or more LexEntryType items in the Variant Entry Types list for variant entries. It is unused for complex entries, although the model allows for both to be used if desirable. Normally a variant LexEntryRef will only use PrimaryLexemes to point to a single entry or sense. Entries using VariantEntryTypes will be displayed as minor entries in the dictionary; usually following the main entry headword and will typically produce a separate minor entry in the dictionary referring to the main entry. The LexEntryType is used to determine how to display the variant information in the main entry context as well as the minor entry context. The Variant Entry Types list is hierarchical with the top level being the type of variant (e.g., dialectal) and subitems being the conditions (e.g., British English, American English) for that type of variant. Normally the user will set this property to a subitem, although a top level item could be used if the user does not want to specify the condition. Each LexEntryType Abbreviation and ReverseAbbr should contain everything needed for displaying the references for this entry. Flex will not attempt to combine names from different hierarchical levels. The Abbreviation is used when displaying the main entry from the minor entry (e.g., Brit. dial. of color). The ReverseAbbr is used when displaying the minor entry from the main entry (e.g., Brit. dial. colour). This is a sequence because some minor entries can have more than one relationship to the same main entry. For example, colour is a spelling variant and a British dialectal variant. The user could use two LexEntryRefs to represent this, but it would be easier to use a single LexEntryRef with two VariantEntryTypes references.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LexEntry:EntryRefs | 34 | sequence | LexEntryRef
 | This property is empty for main entries. For variant and complex entries, one or more LexEntryRef is used to point to the major entries. One variant entry could apply to more than one main entry, so each one could have a separate LexEntryRef. It’s possible for an entry to be a complex entry as well as a variant. This could be represented by one or more LexEntryRefs. Some may want to order multiple entries in a particular way, so we have a sequence instead of a collection.


LexEntryType

num:118 abbrev: let abstract: false module: Ling(num:5) base: CmPossibility

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | ReverseAbbr | 1 | MultiUnicode |
 | This abbreviation may be used in the minor/subentry when referring to the major entry. For example, CmPossibility_Abbreviation could have "var." and LexEntryType_ReverseAbbr could have "var. of"

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | LexEntryRef:ComplexEntryTypes | 2 | sequence | LexEntryType
This property points to one or more items in the Complex Entry Types list for complex entries. It is unused for variant entries, although the model allows for both to be used if desirable. Normally a complex LexEntryRef will point to more than one main entry or sense via PrimaryLexemes and ComponentLexemes. Entries using ComplexEntryTypes will be displayed as subentries in the dictionary; usually at the end of the major entry and will typically produce a separate major entry in the dictionary referring to the main entry. The display is dependent on whether a root-based or stem-based view of the dictionary is being printed. The referenced LexEntryType is used to control the display of the complex information in the main entry context as well as the minor entry context. See the description of VariantEntryTypes for using the information from the LexEntryRef for display purposes.
test Refer'd by | LexEntryRef:VariantEntryTypes | 1 | sequence | LexEntryType
This points to one or more LexEntryType items in the Variant Entry Types list for variant entries. It is unused for complex entries, although the model allows for both to be used if desirable. Normally a variant LexEntryRef will only use PrimaryLexemes to point to a single entry or sense. Entries using VariantEntryTypes will be displayed as minor entries in the dictionary; usually following the main entry headword and will typically produce a separate minor entry in the dictionary referring to the main entry. The LexEntryType is used to determine how to display the variant information in the main entry context as well as the minor entry context. The Variant Entry Types list is hierarchical with the top level being the type of variant (e.g., dialectal) and subitems being the conditions (e.g., British English, American English) for that type of variant. Normally the user will set this property to a subitem, although a top level item could be used if the user does not want to specify the condition. Each LexEntryType Abbreviation and ReverseAbbr should contain everything needed for displaying the references for this entry. Flex will not attempt to combine names from different hierarchical levels. The Abbreviation is used when displaying the main entry from the minor entry (e.g., Brit. dial. of color). The ReverseAbbr is used when displaying the minor entry from the main entry (e.g., Brit. dial. colour). This is a sequence because some minor entries can have more than one relationship to the same main entry. For example, colour is a spelling variant and a British dialectal variant. The user could use two LexEntryRefs to represent this, but it would be easier to use a single LexEntryRef with two VariantEntryTypes references.


LexEtymology

test num:113 | abbrev: ety | abstract: false | module: Ling(num:5) | base: CmObject
 | History of the entry

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Comment | 1 | MultiString-big |
Basic | Form | 2 | MultiUnicode |
Basic | Gloss | 3 | MultiUnicode |
Basic | LiftResidue | 5 | Unicode-big |
Basic | Source | 4 | Unicode |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LexEntry:Etymology | 13 | atomic | LexEtymology
 | Each entry can have one etymology specification.


LexExampleSentence

test num:4 | abbrev: exsn | abstract: false | module: Ling(num:5) | base: CmObject
 | This provides several additional attributes that are needed for example sentences in a lexical database.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Example | 1 | MultiString |
 | This multilingual attribute holds the vernacular example sentence prior to tokenization. After tokenization it is cleared and the contents are transferred to the contents attribute. It is multilingual to allow multiple encodings in the same language (e.g., Thai, Laotian, and Vietnamese). It is multiString rather than multiUnicode to allow formatting - for example, applying bold to the word associated with the LexEntry.
Basic | LiftResidue | 4 | Unicode-big |
Basic | Reference | 2 | String |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Translations | 3 | collection | CmTranslation

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LexSense:Examples | 7 | sequence | LexExampleSentence


LexPronunciation

num:14 abbrev: pron abstract: false module: Ling(num:5) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | CVPattern | 5 | String |
 | This provides a place to store CV patterns of the pronunciation form. It defaults to the top analysis writing system, but being a string, it can be forced to some other writing system.
test Basic | Form | 1 | MultiUnicode |
 | This is the pronunciation usually in an approximately phonemic encoding for purposes of showing up in the printed dictionary.The pronunciation can be represented with more than one encoding.
Basic | LiftResidue | 7 | Unicode-big |
test Basic | Tone | 6 | String |
 | This provides a place to store tone patterns of the pronunciation form. It defaults to the top analysis writing system, but being a string, it can be forced to some other writing system. Tone may be marked as HL, 12, etc.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Location | 3 | atomic | CmLocation
 | Some pronunciations can be related to specific areas, so this points to the location list.
test Owning | MediaFiles | 4 | sequence | CmMedia
 | A pronunciation may have more than one media file to allow for a man's voice and a woman's voice, slight dialect differences, etc.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LexEntry:Pronunciations | 31 | sequence | LexPronunciation
 | We may need more than one pronunciation per entry. For example either/neither have two different pronunciations. Some people may want to order these based on frequency of use, so it is a sequence instead of a collection.


LexReference

test num:120 | abbrev: lref | abstract: false | module: Ling(num:5) | base: CmObject
 | This class represents a set of lexical relations between senses or references between entries. For lexical relations, it can represent general sets, binary sets, scales, or trees. For entry references it can represent general sets, binary sets, and trees. The type of reference, based on the MappingType of the owner, determines how targets will be interpreted in the UI as well as the class of the targets we want to process for this type.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Comment | 1 | MultiString |
 | This allows the user to add a comment to the set. We don't allow comments on individual links, but generally this comment can refer to individual items, if desired.
Basic | LiftResidue | 4 | Unicode-big |
test Basic | Name | 3 | MultiUnicode |
 | This allows the user to add a name to the set.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Targets | 2 | sequence | CmObject

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LexRefType:Members | 3 | collection | LexReference
 | This holds all of the references of this type.


LexRefType

test num:119 | abbrev: lrt | abstract: false | module: Ling(num:5) | base: CmPossibility
 | This class identifies the type of a relation being stored in all of the LexReference items owned in Members. The MappingType enum determines the type of set we are representing. The type of set determines how the name and abbreviations are used. When the name and abbreviation are the same for both directions of the relation (set, pair, and scale relations), they are stored in CmPossibility_Name and CmPossibility_Abbreviation. When the name and abbreviation are different (tree), CmPossibility_Name and CmPossibility_Abbreviation would specify the specific/part labels while LexReferenceType_ReverseName and LexReferenceType_ReverseAbbreviation would be used for the generic/whole label. Renamed from LexReferenceType for the Firebird port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | MappingType | 2 | Integer | min: 0 | max:127
MappingType (max=127) (used as an enum) with possible values: 0 = sense collection (unordered many to many) 1 = sense pair (one to one) 2 = sense tree (one to unordered many) 3 = sense sequence (ordered many to many) 4 = entry collection (unordered many to many) 5 = entry pair (one to one) 6 = entry tree (one to unordered many) 7 = entry or sense collection (unordered many to many) 8 = entry or sense tree (one to ordered many) This enum determines the type of relation represented by the set. It basically determines how the software treats the items in LexReference_Targets. For 0-3 the button to the right would call up a sense chooser. For 4-6 it would call up an entry chooser. For 7-8 it would call up a chooser that allows either entries or senses. For all but 2, 6, and 8 the field label for all items would come from CmPossibility_Abbreviation. For 2, 6, and 8, the label for the first item would be CmPossibility_Abbreviation, while the label for the other items would be CmLexRefType_ReverseAbbreviation.
test Basic | ReverseAbbreviation | 1 | MultiUnicode
This is used for the generic/whole abbreviation for trees.
test Basic | ReverseName | 4 | MultiUnicode
This is used for the generic/whole name for trees.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Members | 3 | collection | LexReference
 | This holds all of the references of this type.

Back references (sorted by attribute name)

Type Name Num Card Sig


LexSense

num:16 abbrev: sens abstract: false module: Ling(num:5) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | AnthroNote | 15 | MultiString-big |
Basic | Bibliography | 16 | MultiString |
test Basic | Definition | 5 | MultiString |
 | This is multiString to allow for embedding of one encoding within another and also to allow the user to manipulate formatting of different parts of the string.
Basic | DiscourseNote | 17 | MultiString-big |
Basic | EncyclopedicInfo | 18 | MultiString-big |
Basic | GeneralNote | 19 | MultiString-big |
Basic | Gloss | 8 | MultiUnicode |
Basic | GrammarNote | 20 | MultiString-big |
test Basic | ImportResidue | 30 | String-big |
 | A place where we can store standard format markers that are not processed in any other way.
Basic | LiftResidue | 31 | Unicode-big |
Basic | PhonologyNote | 21 | MultiString-big |
Basic | Restrictions | 22 | MultiUnicode |
Basic | ScientificName | 11 | String |
Basic | SemanticsNote | 23 | MultiString-big |
Basic | SocioLinguisticsNote | 24 | MultiString-big |
Basic | Source | 25 | String |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | AnthroCodes | 2 | collection | CmAnthroItem
Refer | Appendixes | 4 | collection | LexAppendix
Refer | DomainTypes | 6 | collection | CmPossibility
Refer | MorphoSyntaxAnalysis | 1 | atomic | MoMorphSynAnalysis
Refer | ReversalEntries | 9 | collection | ReversalIndexEntry
Refer | SemanticDomains | 27 | collection | CmSemanticDomain
Refer | SenseType | 12 | atomic | CmPossibility
Refer | Status | 26 | atomic | CmPossibility
Refer | ThesaurusItems | 13 | collection | CmPossibility
Refer | UsageTypes | 14 | collection | CmPossibility
Owning | Examples | 7 | sequence | LexExampleSentence
Owning | Pictures | 29 | sequence | CmPicture
Owning | Senses | 3 | sequence | LexSense

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | WfiMorphBundle:Sense | 4 | atomic | LexSense
test Refer'd by | ChkSense:Sense | 2 | atomic | LexSense
 | In Scripture, a target lexical sense for a key term. More generically, a lexical sense associated with a checklist item. With the LexSense as a starting point, the stem, citation form, literal meaning, definition, gloss and likely inflectional word forms for the rendering can be determined. Note that we do not determine the lexical stem directly but rather make a semantic connection to it through the particular sense of the stem that is relevant to the ChkItem. We can always determine the stem from the sense but not vice versa.
Owned by | LexSense:Senses | 3 | sequence | LexSense
test Owned by | LexEntry:Senses | 11 | sequence | LexSense
 | I am not currently sure whether senses belong on minor entries or not but we did allow this in LinguaLinks so I will leave it here for now for compatibility's sake.


MoAdhocProhib

test num:26 abbrev: acp abstract: true module: Ling(num:5) base: CmObject
This abstract class is intended to capture co-occurrence restrictions between morphemes or allomorphs which cannot be captured using morphosyntactic or phonological restrictions. Linguistically speaking, this is perhaps as bad a kludge as you can imagine. We allow it here for reasons of stealth-to-wealth work, with the understanding that the program will twist the user's arm into getting rid of these later on (perhaps by flagging each of these constraints with a Warning). The technique is borrowed from AMPLE's ad hoc pairs. Note however that, Aronoff (1976: 53) gives as an example of a negative constraint the fact that the suffix -ness does not attach to adjectives of the form X-ate, X-ant, or X-ent. So maybe this isn't such a kludge after all. On the other hand, Aronoff's examples are largely statistical generalizations, that is, tendencies - as opposed to hard constraints. It may be that we should also have positive cooccurrence constraints. Aronoff (1976: 63) lists a number of "forms of the base" which are compatible with the English prefix un-, among them X-en (where -en is the past participle suffix), X-ing, and X-able, which would be examples of positive constraints. However, un- also attaches to a good many monomorphemic stems (roots, e.g. unhappy), so it may be that this is not a real generalization. In addition to the attributes below, there should probably be an attribute to point to analyses which are ruled out by these constraints. These could be either grammatical words for which the parser would generate an incorrect analysis if it were not for this constraint, or ungrammatical words which the user has supplied, and which would be parsed if not for this constraint. It may even be desirable to allow individual constraints to be turned off in the parsing of such examples, in order to verify that the constraint works, and that it is (still) needed. However, the need for such an attr is probably more general than this class; see my email of 18 Jan 2000. Attributes: (Note also that both subclasses define an attribute to hold a seq of objects that are prohibited from co-occurring. For MoMorphemeAdhocCoProhibition, these objects are MoMorphoSyntaxAnalysis objects, representing morphemes; for MoAllomorphAdhocCoProhibition, these are MoForm objects, representing allomorphs.) Renamed from MoAdhocCoProhibition for the Firebird Port.

Direct Subclasses

  • MoAlloAdhocProhib
  • MoMorphAdhocProhib
  • MoAdhocProhibGr

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Adjacency | 2 | Integer |
 | refers to one of the following possibilities: Anywhere: The morphemes (or allomorphs) in question are constrained from appearing anywhere together in the same word. SomewhereToLeft and SomewhereToRight: The second (and later) morpheme (or allomorph) is constrained from appearing anywhere in the word to the left (right) of the first morpheme (respectively, allomorph). AdjacentToLeft and AdjacentToRight: The second (and later) morpheme (or allomorph) is constrained from appearing immediately to the left (right) of the first morpheme (respectively, allomorph) in the same word.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoMorphData:AdhocCoProhibitions | 3 | collection | MoAdhocProhib
 | Used to hold the list of ad hoc cooccurrence restrictions. (Ideally, this is empty!)
Owned by | MoAdhocProhibGr:Members | 3 | collection | MoAdhocProhib


MoAdhocProhibGr

test num:110 | abbrev: acpg | abstract: false | module: Ling(num:5) | base: MoAdhocProhib
 | Allows the user to group MoAdhocProhib to provide "some rationale" for the adhoc. Renamed from MoAdhocProhibGr for the Firebird port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Description | 2 | MultiString |
Basic | Name | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Members | 3 | collection | MoAdhocProhib

Back references (sorted by attribute name)

Type Name Num Card Sig


MoAffixAllomorph

test num:27 | abbrev: aalo | abstract: false | module: Ling(num:5) | base: MoAffixForm
 | For Item-and-Arrangement allomorphs. Regardless of theoretical propensities, this is the sort of analysis that linguists usually start out with (with the probable exception of reduplicative affixation, at least once the linguist has figured out that the affix is reduplicative). In the current model, each allomorph is owned by a single affix (LexEntry). It has sometimes been argued that the phonological form is shared among distinct morphemes (Robins 1959). For example, in English the third person present tense verbal suffix, the noun plural suffix, and the possessive clitic all arguably have the same form. The LinguaLinks conceptual model supports this viewpoint, but it appears to have caused a great deal of confusion among users (Larry Hayashi, email 13 April 1999), and even programming bugs. The model described here does not support the independence of allomorphs from morphemes; rather, each morpheme owns its own allomorphs.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | MsEnvPartOfSpeech | 4 | atomic | PartOfSpeech
refers to a PartOfSpeech, defining the morphosyntactic features which the stem to which this affix attaches must bear. Together with the MsEnvFeatures attribute (below), this attribute defines the morphosyntactic context in which this allomorph must appear. However, there are linguistic reasons for thinking that allomorphs should not in fact be able to specify morphosyntactic requirements on their environment. That is, there are often (always?) better analyses of allomorphy which do not rely on the morphosyntactic properties of the stem (see e.g. Matthews' 1972b reanalysis of Huave). The attribute is there because AMPLE provides that power (although AMPLE allows the user to test the morphosyntactic properties of arbitrary morphemes to the left or right, while the intention here is that an allomorph can only test the morphosyntactic properties of the stem to which it attaches). Since the parts of speech are contained in an inheritance hierarchy, a question arises: if this attr points to an abstract part of speech (verb, say), does a stem with a more specific part of speech (transitive verb, say) match? In the absence of any reason to think it does not, I would suggest that reference to an abstract part of speech entails that more specific parts of speech are included. Otherwise, it is hard to imagine how one could use this attribute-it would be necessary to allow a seq, or else to have separate but homophonous allomorphs for each specific part of speech. It is not clear what should be done if there are conflicts between the morphosyntactic requirements imposed by this attribute, and those imposed by the affix owning this allomorph. Such conflicts "should" not arise (since allomorphs shouldn't have special morphosyntactic requirements of their own, as argued in the previous paragraph). While it would be fairly simple to ensure that conflicts do not arise between stated morphosyntactic properties, there is the potential for implicit conflicts (e.g. the affix calls for attachment to a noun, while the allomorph requires that the stem have a certain feature value for subject agreement-something which nouns presumably do not mark).
test Refer | PhoneEnv | 2 | collection | PhEnvironment
refers to a collection of PhEnvironment objects, describing what the phonetic environment of this allomorph is. The use of the term 'phonetic' is not intended to distinguish this from a phonological context, merely to say that the context is described in terms of its phonetic properties, not its morphosyntactic properties or lexically marked exception properties. If this attribute is uninstantiated, there is no phonetic restriction on the environment. The reason this is a collection attr (rather than atomic) is to allow for the situation during analysis before the user has managed to collapse what appear to be disparate environments into a single environment. (Note that the 'elsewhere' case can be represented by an empty environment under the assumption of disjunctive ordering.) Hence, a step in the stealth-to-wealth process will be to reduce the cardinality of this collection to one. A collection may of course also be useful for allomorphs which actually does appear in a disparate set of environments. For the reason why this is a ref attribute, rather than an owning attribute, see the discussion of MoMorphologicalData.PhoneEnvs. An important assumption here is that the phonetic environment to which this allomorph refers is the derived phonological environment. In the absence of phonological rules, this means that the phonetic environment refers to the allomorph(s) to its left, not to some base form of the morphemes. (If we later implement phonological rules, this implies we implement cyclic phonological processes.) The effect of iterative application of phonological rules would not be possible under this approach, although most cases might fall out from the step-wise attachment of affixes, which more or less amounts to cyclic rule application (without rules). Alternatively, we could allow reference to either (or both) the underlying and derived environments (which would in turn imply that every morpheme would need to have an underlying form); this would be similar to two-level phonology.
test Refer | Position | 5 | sequence | PhEnvironment
refers to an ordered seq of PhEnvironment, encoding the position relative to the stem in which this allomorph goes (for example, before the stem, after the stem, or between the first two consonants of the stem). A default value for this attr should be provided for prefixes and suffixes, based on MoForm.MorphType. For a prefix, this would be __#X (where X represents the entire stem), and for a suffix, X#__. This attr need not be displayed for prefixes and suffixes. Note that it would not be possible to simplify the model by eliminating this attr, and letting the position of infixation be determined by the phonological environment of the allomorph(s). The reason this can't be done is that what is important for purposes of allomorphy vs. what is important for positioning the infix, are two different things. The reason for having this attr as a property of the allomorph, rather than of the MSA, is that this allows us to distinguish two different allomorphs which differ as to whether they are infixed or not. For example, there is a Tagalog affix whose infixed form is -in-, and whose prefixed form is ?in- (although the word-initial glottal happens not to be written orthographically). An alternative to having this attr on MoAffixAllomorph would be to add a subclass of this class for infixes (as well as suprafixes and other sorts of affixes that must appear in a particular position, other than before or after the stem). This new subclass would then have the extra attribute for position. One disadvantage of having such a subclass, is that it would be the only subclass of MoAffixAllomorph, whereas in fact all specific types of affixes (prefixes, suffixes, infixes,...) are sub-types. Having a default value of this attr for prefixes and suffixes adequately characterizes the difference between prefixes and suffixes on the one hand, and infixes on the other. The attr is a seq (as opposed to atomic) to account for affixes whose position relative to the stem is determined by the phonology of the stem. For example, in Tagalog the in affix occurs after the first consonant of a C-initial stem, or (prefixed) before a vowel-initial stem. (Note that this implies that an affix may not be purely a prefix or infix, contrary to the implication of the MorphType attr. The alternative is to require the user to treat such an affix as having two allomorphs, one a prefix and one an infix; but this would seem to be an unnecessary burden for the user.) The attr is an ordered seq (as opposed to a collection) in order to allow disjunctive ordering. Taking the example given above, disjunctive ordering would require the following environments, stored in an ordered seq: #C__, #__ Nondisjunctive ordering would require the following environments (which could be stored in a collection): #C__, #__V Using an ordered seq does not force the parser/ generator to use the ordering, but allows for parsers which do use the order (such as Hermit Crab).
test Owning | MsEnvFeatures | 1 | atomic | FsFeatStruc
owns an FsFeatStruc, defining the morphosyntactic features which the stem to which this affix attaches must bear. See discussion of the MsEnvPartOfSpeech attribute above.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoDerivAffApp:AffixForm | 1 | atomic | MoAffixAllomorph
 | refers to the MoAffixAllomorph, giving the phonetic form of the affix.
test Refer'd by | MoCompoundRuleApp:Linker | 3 | atomic | MoAffixAllomorph
 | refers to an MoAffixAllomorph, that of the linker between the two parts of the compound. If there is no linker, this attr is none.


MoAffixForm

test num:28 | abbrev: afrm | abstract: true | module: Ling(num:5) | base: MoForm
 | This is an abstract class for affix allomorphs, with subclasses for Item-and-Process vs. Item-and-Arrangement treatment.

Direct Subclasses

  • MoAffixProcess
  • MoAffixAllomorph

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | InflectionClasses | 1 | collection | MoInflClass
refers to a collection of MoInflectionClass, giving the conjugation or declension classes to which this allomorph belongs. This supports the collapsing into allomorphs of affixes which differ only in their form and in their requirements for inflection class. The allomorph which is the default will not specify any inflection class, and will therefore be used for all inflection classes not specified by other allomorphs. An empty value of this attribute therefore does not mean that this allomorph is not used in any inflection classes. In theory, this attr should be atomic, at least for inflectional affixes. That is, an inflectional affix should either specify a single inflection class, or it should be the elsewhere case, in which case it does not specify any inflection class (Carstairs-McCarthy 1994). It is nonetheless defined here as a seq attr, (1) for stealth-to-wealth reasons, and (2) because this theoretical claim may be wrong. There should however be tools to help the analyst discover inflectional affixes which have more than one inflection class specified in this attr, and if possible correct the analysis.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoInflAffixSlotApp:AffixForm | 2 | atomic | MoAffixForm
 | refers to an MoAffixForm, the allomorph of the inflectional affix which was attached. If the application of this slot results in an implicit zero affix (because none of the MoInflectionalAffixMsas belonging to this MoInflAffixSlot matched the InflectionalFeatures of the owning MoDerivation), this AffixForm will be none.
test Owned by | MoBinaryCompoundRule:Linker | 3 | atomic | MoAffixForm
 | owns an MoAffixForm in the encoding of the language, giving the phoneme(s) inserted between the two parts of the compound (cf. Linguist List 10.1477, http://linguistlist.org/10/10-1477.html). If this field is empty, nothing is inserted between the two parts. The linker is semantically meaningless (else it would be a morpheme).


MoAffixProcess

test num:29 abbrev: proc abstract: false module: Ling(num:5) base: MoAffixForm
For Item-and-Process allomorphs (in the sense of 'Item and Process' morphology in which affixes are processes, not the sense in which allomorphy is caused by the action of phonological processes). Using the Output attr (defined below), it is possible to reduce the number of allomorphs of a given morpheme under the process approach. For example, an affix with an initial consonant whose voicing agrees with the voicing of the final phoneme of the stem can be described as a single allomorph by using the appropriate phonological properties. At the same time, since any one affix can have multiple MoAffixForm objects, including multiple MoAffixProcesses, it is not necessary that all allomorphy be accounted for within the Output attr. Indeed, with phonologically conditioned suppletion (Carstairs 1990), it will be necessary to resort to multiple allomorphs even under the process view. There is no provision in the model as it currently exists for '(re)adjustment rules', defined as "rules which change the segmental shape of designated morphemes in the immediate environment of other designated morphemes" (i.e. rules of truncation and allomorphy; Chomsky and Halle 1968: 238-239; Aronoff 1976, chapter five; Scalise 1986: 63-67). The assumption here is that morphological rules themselves will define any such allomorphy (and that eventually, phonological rules will be added to the model to deal with allomorphy that is not specific to a certain morpheme). Several objections could be raised against this: (1) It has been argued (Aronoff 1976, chapter five) that morphological rules are not the appropriate place to define allomorphy. (2) Treating allomorphy with morphological rules works well only when the allomorphy is inwardly sensitive, that is, when the allomorphy is in an affix, conditioned by the form of the stem to which it attaches. There is no obvious way in Item-and-Process morphology to treat outwardly-sensitive allomorphy which depends on the specific morpheme affected, as opposed to just the (underlying) phonetic form of that morpheme. In particular, it is difficult to treat allomorphy affecting a class of roots. For further discussion, see Maxwell 1996, appendix 3. Additional Notes: In regard to point (1) above, Mike Maxwell states: For the record, I do not find Aronoff’s arguments strong. In particular, there are better solutions using morphological rules than the rule of Truncation that he considers on page 89, which is effectively a straw man. In regard to point (2) above, one work-around would be to use paradigm classes.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Input | 2 | sequence | PhContextOrVar
 | Owns an ordered seq of PhContextOrVar, describing the form of the stem to which the affix attaches. The left-to-right order of the PhContextOrVars in this attribute corresponds to the order of the portions of the input word which match. (N.B.: There could be ambiguity, for instance if the input had two adjacent PhVariables. The system should check for this, and warn the user.) Given that PhContextOrVar can itself own an PhSequenceContext, the use of a seq attribute here may seem like overkill. However, it is only the topmost members of this Input attribute that can be numbered (the numbering is part of the user interface, and allows the user to point back to particular pieces of the input for the output). Perhaps this numbering can be done differently, in which case the Input attribute won't need to be seq.
test Owning | Output | 3 | sequence | MoRuleMapping
 | Owns an ordered seq of MoRuleMapping, describing the form output by attachment of this affix. Typically this consists of a copy of the Input plus some constant for the affix, but reduplication, infixation, simulfixes and suprafixes will be more complex. The left-to-right order of the MoRuleMapping objects in this attribute corresponds to the order of the pieces of the output word which will be constructed by the rule.

Back references (sorted by attribute name)

Type Name Num Card Sig


MoAlloAdhocProhib

test num:101 abbrev: acp abstract: false module: Ling(num:5) base: MoAdhocProhib
This is intended to capture co-occurrence restrictions between allomorphs which cannot be (or has not yet been) captured using morphosyntactic or phonological restrictions. There are some problems with this class as it stands. The use of the value Anywhere in the Adjacency attr serves to constrain any two or more allomorphs from cooccurring in a single word, whereas the use of the other possibilities in that attr only serves to constrain a set of two or more allomorphs from cooccuring with a single allomorph. This inconsistency could be eliminated by making Anywhere work like the other possibilities (but that would make it less useful), or by replacing the single Allomorphs attr with two attrs, one for one set of allomorphs, and one for another set. The co-occurrence restriction would then be between any allomorph from the first set and any allomorph from the second (and the meaning of the values SomewhereToLeft and SomewhereToRight would be clarified). This would of course have the disadvantage of making this class non-parallel to the class MoMorphemeAdhocCoProhibition. Another problem with this class is that there is no way to constrain what sorts of things can occur between the allomorphs with any of the values Anywhere, SomewhereToLeft and SomewhereToRight. For example, processes such as vowel harmony and nasal assimilation are often blocked by affixes with exceptional values for the features in question. This can be indicated by suitable phonological environments, but not by the use of an allomorph co-occurrence constraint. Was renamed from MoAllomorphAdhocCoProhibition for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Allomorphs | 1 | sequence | MoForm
 | refers to a seq of MoForm objects, the co-occurrence of which is ungrammatical. Usually, there will be exactly two such allomorphs. If there are three or more allomorphs, the intended meaning is that a word is ungrammatical in which all such morphemes appear (but the co-occurrence of only some of the morphemes is not prohibited). Having only one morpheme in this attribute should be flagged as a Warning, since such a restriction can do nothing. When the Adjacency attribute is 'Anywhere', the fact that this attribute is a seq, rather than a collection, is unimportant. But the order of allomorphs becomes important when the Adjacency attribute has any other value. Specifically, the order of the allomorphs in this attribute is interpreted as a left-to-right order.
Refer | FirstAllomorph | 2 | atomic | MoForm
test Refer | RestOfAllos | 3 | sequence | MoForm
 | Changed from RestOfAllomorphs.

Back references (sorted by attribute name)

Type Name Num Card Sig


MoBinaryCompoundRule

test num:106 | abbrev: mbcr | abstract: false | module: Ling(num:5) | base: MoCompoundRule
 | This is an abstract class (a subclass of MoCompoundRule), encompassing compounds where the branching is binary (most compounds are probably binary branching, although see the cautions in Fabb (1998) section 2.3). The two daughters are here referred to as the 'left' and 'right' constituent. Compounds of this class which contain more than two constituents must thus be built up recursively. Thus, manhole cover has the structure [[man hole] cover], rather than a flat structure. Note that there is no implication that the left- or right-hand elements of compounds are heads; headship is determined in MoEndocentricCompound.headLast.

Direct Subclasses

  • MoEndoCompound
  • MoCoordinateCompound
  • MoExoCompound

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | LeftMsa | 1 | atomic | MoStemMsa
 | owns an MoStemMsa, giving the morphosyntactic information about the left-hand member of this compound. If this MoStemMsa specifies a PartOfSpeech, then the left-hand member of this compound must belong to that part of speech. If this MoStemMsa specifies an FsFeatStruc, then the left-hand member of this compound must have (not unify with!) the features of that feature structure. Since the parts of speech are contained in an inheritance hierarchy, a question arises: if this MSA points to an abstract part of speech (verb, say), does a word with a more specific part of speech (transitive verb, say) match? In the absence of any reason to think it does not, I would suggest that reference to an abstract part of speech entails that more specific parts of speech are included. Otherwise, it is hard to imagine how one could use this attribute - it would be necessary to allow a collection of parts of speech, or else to have separate compound rule for each specific part of speech.
test Owning | Linker | 3 | atomic | MoAffixForm
 | owns an MoAffixForm in the encoding of the language, giving the phoneme(s) inserted between the two parts of the compound (cf. Linguist List 10.1477, http://linguistlist.org/10/10-1477.html). If this field is empty, nothing is inserted between the two parts. The linker is semantically meaningless (else it would be a morpheme).
test Owning | RightMsa | 2 | atomic | MoStemMsa
 | owns an MoStemMsa, giving the morphosyntactic information about the right-hand member of this compound, in the same fashion as the LeftMsa attribute.

Back references (sorted by attribute name)

Type Name Num Card Sig


MoCompoundRule

test num:30 abbrev: cmpr abstract: true module: Ling(num:5) base: CmObject
This is an abstract class, encompassing endocentric, exocentric, and coordinate compounds, as well as incorporation (e.g. incorporation of a direct object into a verb). There is a typology of compound types given in Spencer (1991: 310ff.); some of the compounds he discusses shade into idioms. This model does not attempt to account for the semantics of compounds in the compounding rule, since this is largely unpredictable. Nor do we attempt to account for argument linking. For example, Lieber (1983: 258) claims that an element of a compound must be able to link to all its obligatory internal arguments. That is, if an argument-taking element is a non-head, it must find its argument within the compound (Lieber's example is drawbridge, where bridge is the internal argument of draw); otherwise (if the argument-taking element is the head of the compound ), it can link to arguments which are external to the compound (Lieber's example is hand-weave). Accounting for argument linking would require at a minimum that we model argument requirements of lexemes (i.e. subcategorization lists). However, argument linking is also closely related to semantic and pragmatic issues, which are well outside the scope of our plans. Additional notes from Andy Black January 2002: The old way used ref attrs (at least to POS) because they directly referred to POS. The new way is for the compound rule to own an MSA (which in turn can refer to a POS and can own FS, etc.) So I'm rather sure that these MSA attrs of compound rules are supposed to be owning. If they were referring, I have no idea what MSA they would refer to. The Msas in a compound rule do not belong to a particular lexical item, they just happen to have all the relevant information needed by a compound rule. Response from Randy Regnier: Well, maybe then I am missing something. What will a compound rule actually control then? I gather it won’t actually use the MSA directly. I had assumed something along the lines of X and Y can be compounds. But if X and Y are independently owned Msas, then the parser will never find them in the lexicon. Randy Response from Andy: For all three stages, the manifestation of a compound rule is a rule in our word grammar rule. This rule will be of the form rule {Stem via compound rule crVAdv} Stem_1 = Stem_2 Stem_3 with appropriate constraints. The constraints will have to check the POS and FS of each MSA within the rule. They might end up looking like this: | constraints <Stem_2 synCat> = { posV / posVIntrans / posVTrans} <Stem_3 synCat> = posIncAdv where the values on the right hand side will come from these owned Msas (i.e. we will get the POS value from the POSs within the toMsa and fromMsa). We'll do something similar for the FS of these Msas. In the above constraints, it says that the left member has to be a verb (or one of its subtypes) and the right member has to be an "incorporated adverb." (This is from the ZPU data, where I think that the adverbial suffixes are really just incorporated adverbs, hence compounded.) The Stem_2 and Stem_3 get their "synCat" values from another rule: rule {Stem consisting of a single root} Stem = root | percolation <Stem synCat> = <root rootCat> (etc.) So the lexical items will be put into the word tree as "roots" and their lexical MSA info will be passed up to the Stem node. This Stem node may then become part of a compound rule (either as Stem_2 or as Stem_3).

Direct Subclasses

  • MoBinaryCompoundRule

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Description | 2 | MultiString |
 | Description of the compound rule.
test Basic | Name | 1 | MultiUnicode |
 | Short label for the compound rule.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Stratum | 7 | atomic | MoStratum
 | refers to an MoStratum, giving the stratum to which this rule belongs. The assumption behind the fact that this is an atomic attribute, is that a given compound rule (i.e. type of compound) can belong to only one stratum. If compounding happens in more than one stratum, then there must be more than one compounding rule. See also the discussion of MoStratum.vCompoundRules..
test Refer | ToProdRestrict | 8 | collection | CmPossibility
 | refers to a collection of CmPossibility, giving any restriction classes which the stem resulting from this compound rule will bear. Specifically: if this attribute is non-empty, the stem resulting from this rule will have these restriction classes as the value of its ProductivityRestrictions (overriding any restriction classes borne by the daughter stems). If on the other hand this attribute is empty, the ProductivityRestrictions of the output stem will be the same as those of the head (for MoEndocentricCompounds) or empty (for MoExocentricCompounds). Changed from ToProductivityRestrictions.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | WfiAnalysis:CompoundRuleApps | 12 | sequence | MoCompoundRule
 | Allows Morph Sketch Generator to extract example wordforms where a compound rule applied.
test Owned by | MoMorphData:CompoundRules | 2 | sequence | MoCompoundRule
 | owns a seq of MoCompoundRules. (Alternatively, these could be owned in the stratum to which they belong - see MoStratum.vCompoundRules for discussion.) The order corresponds to the order in which the compounding rules apply in a derivation.


MoCompoundRuleApp

test num:73 abbrev: cmpdruleapp abstract: false module: Ling(num:5) base: MoDerivTrace
This represents the application of a single MoCompoundRule, i.e. the morphological combination of any two stems. The stems are represented as two stems in the lexicon. Any further affixation is assumed to be attached to the head member of the compound, if this is an endocentric compound (i.e. the rule is of the class MoEndocentricCompound). If this is an exocentric compound (the rule is of the class MoExocentricCompound), then further affixation is applied to the entire word. Any phonological rules of the appropriate strata (the stratum of the compounding rule and all higher strata) will be applied. An alternative to having the members of the compound be stems, would be to allow the members to be MoDerivation objects. This would allow words or stems which were not stored in the lexicon. In their present form, MoDerivations are intended to contain a derivation beginning with an underlying form and ending at a surface form. If they could also be used inside compounds, the final form would usually be of a non-surface stratum.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | LeftForm | 1 | atomic | MoStemAllomorph
 | LeftForm: refers to a form (Wordform? MoStemAllomorph?), that of the left-hand member of the compound.
test Refer | Linker | 3 | atomic | MoAffixAllomorph
 | refers to an MoAffixAllomorph, that of the linker between the two parts of the compound. If there is no linker, this attr is none.
test Refer | RightForm | 2 | atomic | MoStemAllomorph
 | RightForm: refers to a form (Wordform? MoStemAllomorph?), that of the right-hand member of the compound.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoStratumApp:CompoundRuleApps | 2 | sequence | MoCompoundRuleApp
 | owns an ordered seq of MoCompoundRuleApp, representing the application of compound rules belonging to this stratum. The order is the order of application in derivation (which may be the reverse of the order in parsing).


MoCoordinateCompound

test num:107 | abbrev: ccpd | abstract: false | module: Ling(num:5) | base: MoBinaryCompoundRule
 | This is a concrete class (a subclass of MoCompoundRule), for compounds of which all the members are heads, as opposed to endocentric compounds, in which one member is the head, or exocentric compounds, in which no member is a head. This class also differs from endocentric and exocentric compounds in that the branching may be non-binary. There are several linguistic terms for this sort of compound, including 'co-ordinate compounds', 'appositional compounds', and 'dvandva compounds'. An example (taken from Fabb 1998, page 74; see also section 1.1.2) is the Tamil for 'courage, bravery and valour'.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


MoCopyFromInput

test num:103 | abbrev: cfin | abstract: false | module: Ling(num:5) | base: MoRuleMapping
 | Indicates that a portion of the input is to be copied over to the output without modification.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Content | 1 | atomic | PhContextOrVar
 | refers to a PhContextOrVar in MoAffixProcess.Input of the owner of this object; the meaning is that the stretch of the input word matched by that PhContextOrVar is copied over without alteration to the output.

Back references (sorted by attribute name)

Type Name Num Card Sig


MoDeriv

test num:100 | abbrev: mder | abstract: false | module: Ling(num:5) | base: CmObject
 | This represents the derivation of a word (or stem), i.e. the relationship between a 'surface' word and the stem, any derivational affixes, and the morphosyntactic inflectional features. A derivation gives the derivational order of attachment of affixes, application of compounding rules, and the application of phonological (morphophonemic and/or allophonic) rules. (However, phonological rules have not yet been defined for purposes of this specification.). In particular, the attr StratumApps contains the derivational order of strata, each of which in turn contains the order of attachment of affixes of that stratum. It is not clear whether this class is actually required. In particular, the StratumApps attr could instead be an attr on WfiAnalysis. But until that attr is added to WfiAnalysis, this class will serve. (Note that test cases may also require an attr pointing to their derivation.) Renamed from MoDerivation for the Firebird Port

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | StemForm | 1 | atomic | MoStemAllomorph
 | refers to an MoStemAllomorph, a stem found in the lexicon.
test Refer | StemMsa | 2 | atomic | MoStemMsa
 | refers to an MoStemMsa, a stem found in the lexicon. Note that this object and the allomorph pointed to by the StemForm must belong to the same LexEntry.
test Owning | InflectionalFeats | 3 | atomic | FsFeatStruc
 | Owns (but see below) an FsFeatStruc giving the inflectional features (to be) realized in this derivation. It is not clear whether this should be an owning or virtual attr. If derivations are always owned by some higher object that could logically hold such a feature structure (e.g. a test case or a cell in a paradigm), then this attr should just return that feature structure. Changed from InflectionalFeatures.
test Owning | StratumApps | 4 | sequence | MoStratumApp
 | owns an ordered seq of MoStratumApp structures, representing the sequence of applications of strata (i.e. of the affixes and phonological rules of those strata) to an underlying form. The order is from the deepest stratum to the shallowest.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | WfiAnalysis:Derivation | 6 | atomic | MoDeriv


MoDerivAffApp

test num:74 | abbrev: drvtnlaffapp | abstract: false | module: Ling(num:5) | base: MoDerivTrace
 | This represents the application of a single derivational affix to a stem.An assumption here is that there are no instances where two affixes must attach at the same time to a stem. This corresponds to the " Binary Branching Hypothesis" (Aronoff 1976, Scalise 1986: 146-151), which is generally accepted as correct. (Circumfixes would be considered to be a single affix which happens to wrap around the stem, not the simultaneous attachment of a prefix and a suffix.) Renamed from MoDerivationalAffixApp for the Firebird Port

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | AffixForm | 1 | atomic | MoAffixAllomorph
 | refers to the MoAffixAllomorph, giving the phonetic form of the affix.
test Refer | AffixMsa | 2 | atomic | MoDerivAffMsa
 | refers to an MoDerivationalAffixMsa, giving the morphosyntactic information about the affix.
test Owning | OutputMsa | 3 | atomic | MoDerivStepMsa
 | owns an MoDerivationalStepMsa, giving the morphosyntactic information resulting from attaching the derivational affix.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoStratumApp:DerivAffApp | 3 | sequence | MoDerivAffApp
 | Owns an ordered seq of MoDerivationalAffixApp, representing the attachment of derivational affixes belonging to this stratum. The order is the order of application in derivation (which may be the reverse of the order in parsing). Changed from DerivationalAffixApps.


MoDerivAffMsa

test num:31 abbrev: damsa abstract: false module: Ling(num:5) base: MoMorphSynAnalysis
This class is intended for derivational affixes. Since the current model does not allow for non-realizational versions of inflectional morphology, this class could probably be used to treat inflectional morphology under a Lieber-style analysis. According to the "Unitary Base Hypothesis", "the syntacticosemantic specification of the base of a word formation rule may be more or less complex, but it is always unique" (Scalise 1986: 136; see also Aronoff 1976: 47ff.). In our terms, there is a one-to-one relationship between a sense of a derivational affix and its morphosyntactic specification. While that could be captured in the conceptual model (of LexEntry for affixes), it is not. From a stealth-to-wealth standpoint, that may be just as well, although we could encourage it by procedural code (and doing so might push the linguist to deeper investigation of the semantics of affixes which are apparent counterexamples to the Unitary Base Hypothesis). There are some affixes (probably mostly derivational affixes) which attach only to stems of a specific phonological shape. For example, the English inchoative suffix -en attaches productively only to adjectives ending in t and d (brighten, *dimmen; exceptions such as blacken and darken are said to date from an earlier period in English, see Aronoff 1976: 79). The model does not provide for this sort of restriction on morphemes. One work-around is to encode the restriction at the level of the allomorph (MoAffixForm), and have only that one allomorph for the affix. Should derivational affixes be allowed to add exception features to a word (e.g. by percolation)? There are some arguments back and forth in Aronoff 1976: 52, although it certainly looks like derivational affixes should be able to have exception features (the question is whether they percolate). See also discussion under the MoStemMsa.ExceptionFeatures. enamed from MoDerivationalAffixMsa for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | AffixCategory | 8 | atomic | CmPossibility
In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. This field is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a CmPossibility of "derv" (derivational affix).
test Refer | FromInflectionClass | 5 | atomic | MoInflClass
specifies the inflection (conjugation or declension) class which the stem to which this affix attaches must belong. In general, derivational affixes are arguably not marked for this property, so this attribute may be superfluous. However, it will certainly be necessary if non-Inflectional inflectional morphology is to be modeled using this class. (And it may turn out that some derivational affixes are sensitive to the inflectional class of their stem.) Under the realizational model of inflectional morphology, the inflection class to which an allomorph of an inflectional (realizational) affix belongs is indicated by MoAffixForm.InflectionClasses. That attribute is also available for allomorphs of derivational affixes (i.e. this class). That might be overkill, in that if a derivational affix attaches to stems of a single inflectional class, we could assign a single allomorph to that affix, and capture the restriction of the affix to the inflectional class as a restriction on that allomorph. However, the fromInflectionClass attribute here is parallel to the toInflectionClass attribute (defined below), which is independently needed. (Andy suggests that it may also be the case that a derivational affix would apply to a single inflection class, but have multiple allomorphs, in which case it would be convenient to have the attribute here, thereby avoiding the need to mark each allomorph for the same inflection class.)
test Refer | FromPartOfSpeech | 3 | atomic | PartOfSpeech
specifies the category of the stem to which this affix attaches. See comments above on the "Unitary Base Hypothesis." Note also that in AMPLE, it is possible to map a series of categories into another series of categories; that capability is not defined here. If the parts of speech list is hierarchical, the problem could be partially circumvented by specifying an abstract category in this attribute. However, that would not solve the problem of mapping the output category, because at best we could specify more than a single output category. Note that we do not (yet) have provision for subcategorization lists or argument structure. This means that some restrictions on the stem to which an affix would be attached cannot be handled elegantly. (They could be handled inelegantly, by creating an ad hoc feature for each subcategorization, e.g. [+ditransitive].) For example, the English suffix -able attaches only to transitive verbs (washable, *seemable); the English suffix -ee attaches only to verbs which allow animate objects or indirect objects (addressee, *tearee) (examples from Scalise 1986: 45). Nor do we treat semantic restrictions on the base to which the affix attaches. For example, it has been proposed that the English prefix re- attaches only to verbs whose meaning entails a change of state (John repunched the holes in the paper, *John repunched Bill in the face) (Aronoff 1976: 47, observation attributed to an unpublished paper of Williams).
test Refer | FromProdRestrict | 13 | collection | CmPossibility
FromProductivityRestrictions: refers to a collection of CmPossibility, giving any restriction classes which the stem to which this affix attaches must bear. If this attribute is empty, this affix may attach to a stem regardless of what restriction classes the stem bears (see MoStemMsa.ProductivityRestrictions). If there are two or more restriction classes listed for this affix, then the stem must have at least all of these restriction classes in its MoStemMsa.ProductivityRestrictions attribute in order for this affix to attach to the stem. The stem could have more restriction classes, but not less. Changed from FromProductivityRestrictions.
test Refer | FromStemName | 10 | atomic | MoStemName
FromStemName: refers to an MoStemName, telling the stem to which this affix attaches. If this attr is empty, this affix attaches to the default stem of an MoStemMsa, as given by the vDefaultStems attr. (The vDefaultStems attr is a seq attr, to allow for a choice based on phonological constraints; in the absence of phonologically conditioned stem selection, there should be only one default stem.)
test Refer | Stratum | 12 | atomic | MoStratum
Stratum: refers to the MoStratum to which this MoMorphoSyntaxAnalysis object belongs. In an earlier version of this document, this attr belonged to MoForm. But that implied that one allomorph might belong to one stratum, and another allomorph to another stratum, which seems wrong. It is here, rather than on the superclass, because MoInflectionalAffixMsas do not need to "know" their stratum (their stratum is specified by the MoInflAffixTemplate in which they appear). (The other subclass of MoMorphoSyntaxAnalysis which has this attr is MoStemMsa.)
test Refer | ToInflectionClass | 6 | atomic | MoInflClass
specifies the inflection (conjugation or declension) class which the word derived from this affix attaches belongs. An example of the use of this attribute would be to mark the conjugation class resulting from the attachment of a verbalizer. Another example is the use of the noun (declension) class 3 in Swahili to mark dimunitives (Beard 1998: 62). Note that a PartOfSpeech has an attr defaultInflClass, to which a derived word will belong if no toInflClass is defined here.
test Refer | ToPartOfSpeech | 4 | atomic | PartOfSpeech
specifes the category(PartOfSpeech) of the word resulting from the attachment of this affix. Note that as with the FromPartOfSpeech, we do not (yet) cover subcategorization lists or argument structure here. Thus, we cannot handle subcategorization-changing affixes, such as causatives, by changing a subcategorization list, only by changing category or morphosyntactic features. Likewise, we cannot handle the change in argument structure that accompanies some category-changing affixes. For example, when the prefix en- verbalizes an adjective, the argument of which the adjective was predicated becomes the direct object of the verb (The picture is large - to enlarge the picture; example from Scalise 1986: 28).
test Refer | ToProdRestrict | 14 | collection | CmPossibility
Specifies any restriction classes which the MoDerivationalStepMsa resulting from attaching this affix to a stem will bear (in its ProductivityRestrictions attribute). Specifically: if this attribute is non-empty, the stem resulting from the attachment of this affix will have these restriction classes as the value of its ProductivityRestrictions (overriding any restriction classes borne by the stem to which this affix attached). If on the other hand this attribute is empty, the ProductivityRestrictions of the output stem will be the same as those of the input stem. Changed from ToProductivityRestrictions.
test Owning | FromMsFeatures | 1 | atomic | FsFeatStruc
specifies the morphosyntactic features which the stem to which this affix attaches must bear. See also the discussion of the FromPartOfSpeech attribute above.
test Owning | ToMsFeatures | 2 | atomic | FsFeatStruc
ToMsFeatures: owns a FsFeatStruc, giving the morphosyntactic features which the word derived from this affix contains. In brief, the morphosyntactic features of the output word will contain all these feature values plus any nonconflicting feature values of the stem, provided the features are included in PartOfSpeech.BearableFeatures or PartOfSpeech.InflectableFeatures of the output word. (Or putting it differently, the ToMsFeatures override any conflicting features which would otherwise be percolated up from the stem.)

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoDerivAffApp:AffixMsa | 2 | atomic | MoDerivAffMsa
 | refers to an MoDerivationalAffixMsa, giving the morphosyntactic information about the affix.


MoDerivStepMsa

test num:32 | abbrev: dsmsa | abstract: false | module: Ling(num:5) | base: MoMorphSynAnalysis
 | This gives the morphosyntactic properties of a stage in the derivation of an inflected word. Objects of this class are used in MoDerivationTrace objects. Renamed from MoDerivationalStepMsa for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | InflectionClass | 4 | atomic | MoInflClass
InflectionClass: refers to an MoInflectionClass. This gives the inflection class to which the word being derived belongs, at this stage in the derivation. The algorithm for computing this is rather complex (which is why I have not defined this as a virtual attr), but basically it is this: If the last MoDerivationalAffix attached specifies a ToInflectionClass, then this attr is that inflection class. If the last MoDerivationalAffix attached does not specify a ToInflectionClass, then we collect all the derivational affixes attached inside that one which have the same ToPartOfSpeech or a PartOfSpeech which is a subcategory or a supercategory of the last derivational affix's part of speech, stopping when we come to a part of speech which is not the same or a subcategory or a supercategory. The outermost of these affixes which specifies a ToInflectionClass is used for this stage's InflectionClass. If none of these affixes specifies a ToInflectionClass, and the MoStemMsa is accessible (meaning none of the affixes has a contrary ToPartOfSpeech), then we use the InflectionClass of that stem. If all of these possibilities fail, we use the vDefaultInflectionClass of the PartOfSpeech.
test Refer | PartOfSpeech | 1 | atomic | PartOfSpeech
refers to a PartOfSpeech, telling the category of the word.
test Refer | ProdRestrict | 6 | collection | CmPossibility
Specifies the restriction classes which the word has at this stage in the derivation. Changed from ProductivityRestrictions
test Owning | InflFeats | 3 | atomic | FsFeatStruc
Owns an FsFeatStruc, giving the morphosyntactic features which the word is to be inflected for at the end of the derivation. Changed from InflectionFeatures for the database port.
test Owning | MsFeatures | 2 | atomic | FsFeatStruc
owns an FsFeatStruc, giving the morphosyntactic features which result from percolation. N.B.: This does not include inflectional features which are to be realized by inflectional affixes (and which may be incompatible with the current part of speech, or contradict percolated features).

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoDerivAffApp:OutputMsa | 3 | atomic | MoDerivStepMsa
 | owns an MoDerivationalStepMsa, giving the morphosyntactic information resulting from attaching the derivational affix.


MoDerivTrace

test num:72 | abbrev: drvtntrc | abstract: true | module: Ling(num:5) | base: CmObject
 | This is an abstract class, which subsumes various kinds of trace structures. The assumption is that a derivation is a sequence of stratum applications (MoStratumApps), and that each stratum application is a sequence of derivational affix applications (MoDerivationalAffixes, possibly an inflectional template application (MoInflTemplateApp), and (when they are implemented) a sequence of phonological rule applications (MoPhonolRuleApps), in that order. (The ordering assumption would need to be modified to allow for cyclic phonological rule application.) Renamed from MoDerivationTrace for the Firebird Port.

Direct Subclasses

  • MoInflAffixSlotApp
  • MoStratumApp
  • MoInflTemplateApp
  • MoPhonolRuleApp
  • MoDerivAffApp
  • MoCompoundRuleApp

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | OutputForm | 1 | MultiUnicode |
 | owns a string in the encoding of this level, representing the form resulting from attaching an affix, applying an inflectional affix slot, or applying a phonological rule. However, this attr is overridden, and defined as a virtual attr, in the classes MoStratumApp and MoAffixTemplateApp. The parallel attr for output morphosyntactic properties is defined in the subclasses, because some of those subclasses change the morphosyntactic properties of the word (derivational affixes), some do not (inflectional affixes and templates, and phonological rules), while for strata application, the output MSA is the output MSA of the last trace object it owns.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


MoEndoCompound

test num:33 abbrev: endc abstract: false module: Ling(num:5) base: MoBinaryCompoundRule
This subclass of MoBinaryCompoundRule serves for endocentric compounds and incorporation structures, in which the morphosyntactic properties of the head constituent determine the morphosyntactic properties of the compound structure. Typically only the head is inflected, as well. Most English compounds are of this type. Note that the head constituent is best defined in terms of the relationship between the head and the whole, rather than the relationship between the two constituents; thus, the English killjoy is not endocentric, despite the fact that kill presumably selects joy. See Fabb (1998: 70). This class does not provide a way to override the percolation of the head's morphosyntactic properties to the output structure, this being essentially the definition of 'head'. However, this may be too strict a limitation, in that a construction might override the head properties by imposing a minor modification on the morphosyntactic properties of the output. For example, in languages with (true) incorporation, incorporation of the direct object may or may not make the resulting verb intransitive (Baker 1996: 31). We use the OverridingMsa attribute to override percolation of features, or (better) to change the subcategorization list of the head. Note:There are theory-internal considerations here. For example, Baker treats overt NPs in polysynthetic languages as adjuncts, not complements. In a certain sense, then, a verb - with or without an incorporated object noun - is not transitive. Endocentric compounds are inflected on their heads (Scalise 1986: 124), and the parsing/ generation algorithm will need to take this into consideration. Non-heads of endocentric compounds are usually uninflected, even when the word in question is always inflected in isolation. An English example is pluralia tantum words like scissors and trousers, which appear in their singular forms in compounds: scissor-handle and trouser-leg (example (68) in Scalise 1986: 123). This will be reflected in the LeftFeatures or RightFeatures of the appropriate member. Exceptions sometimes occur with irregular plurals: teethmarks (but cf. toothbrush, *teethbrush). Renamed from MoEndocentricCompound for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | HeadLast | 1 | Boolean |
 | owns a Boolean, defaulting to true (meaning that the right-hand constituent is the head).

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | OverridingMsa | 2 | atomic | MoStemMsa
 | Any attribute specified in this msa will override the corresponding attribute of the head msa of the compound.

Back references (sorted by attribute name)

Type Name Num Card Sig


MoExoCompound

test num:34 abbrev: exoc abstract: false module: Ling(num:5) base: MoBinaryCompoundRule
This subclass of MoBinaryCompoundRule serves for exocentric compounds, such as English killjoy or Spanish paracaidas 'parachute', in which neither constituent appears to be the head. To my knowledge, exocentric compounds are not inflected for their syntactic function, although the individual members of the compound may have their own inflection. For example, the Spanish example of the previous paragraph is made up of a preposition para 'for' and a feminine plural noun caidas 'falls'; the compound itself is masculine and ambiguous for number, but is not so inflected. Other Spanish examples include lavaplatos 'dish washer', consisting of the third person singular present indicative verb lava 'washes' and the masculine plural noun platos 'dishes'; and sacamuelas 'dentist', consisting of the third person singular present indicative verb saca 'removes' and the plural noun muelas 'teeth'. Lavaplatos is masculine and ambiguous for number, while sacamuelas is ambiguous for both gender and number. It is not clear how to specify this behavior. Renamed from MoExocentricCompound for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | ToMsa | 1 | atomic | MoStemMsa
 | owns an MoStemMsa, giving the morphosyntactic information about the output of this compound. (Since the morphosyntactic properties of the daughters cannot be inherited in an exocentric compound, there is no question here of conflicts between the properties specified in this attribute and the properties of the daughters.) There is no provision for choosing a part of speech based on the argument properties of either element of the compound.

Back references (sorted by attribute name)

Type Name Num Card Sig


MoForm

test num:35 abbrev: form abstract: true module: Ling(num:5) base: CmObject
This is an abstract class, with subclasses for roots and affixes. MoForms are stored in the Forms attr of LexEntries. That attr needs to be a sequence (not collection) attr, because the ordering of the allomorphs is relevant if their environments of occurrence are taken to be disjunctively ordered (a common assumption). For example, the English noun plural suffix (as well as the third person singular present tense verb suffix and the possessive enclitic) has the form /«z/ after strident sounds, /s/ after (non-strident) voiceless sounds, and /z/ elsewhere. The latter environment can most easily be represented as "otherwise," a characterization which requires disjunctive ordering. The environment for /s/ is also most simply represented if disjunctive ordering is assumed: /s/ appears after voiceless sounds, unless the /«z/ is more appropriate. Without disjunctive ordering, it would be necessary to explicitly disallow /s/ after strident sounds, recapitulating the information that /«z/ appears in that environment. When we add a morphophonology component, there will need to be a way of telling whether a given allomorph is predictable by phonological rule. In the case of a stem, this would require creating an underlying form, then trying to derive the entire paradigm of the stem from that underlying form. In order to thoroughly test the rule(s), it would also be necessary to test the paradigms of any other stems arising from the attachment of a derivational affix to that stem, and any compounds formed with the stem. The endpoint of the task of deriving allomorphs from underlying forms, is to reduce the number of allomorphs of each morpheme to one (apart from suppletion). A phonological rule can potentially modify any stem in the lexicon, so the introduction of a phonological rule implies full-fledged testing. Note however that the use of strata might ameliorate these effects. For example, if allomorphs are assigned to a higher stratum than underlying forms, and the phonological rule applies prior to that higher stratum, it cannot affect those allomorphs. This assumes the presence of the allomorphs is not required for purposes of the rule’s environment.

Direct Subclasses

  • MoAffixForm
  • MoStemAllomorph

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Form | 1 | MultiUnicode
It is not clear to me what is supposed to go into this attribute for process affixes (MoAffixProcess), since these do not have a form per se (and in some cases, such as reduplication, there is no form at all). One could use this for a description of the process affix, but that usage would then not parallel the usage in other subclasses. Null inflectional affixes are usually unnecessary in a realizational theory of morphology; putative null derivational affixes can usually be modeled by multiple parts of speech for (lexically listed) stems; and null stems are quite rare. Nonetheless, for purposes of stealth to wealth, as well as for the rare situation where null affixes or stems are actually required, this Form attr can hold an empty string. (See e.g. the discussion of spanned slots in the MoInflAffixTemplate class for one situation where null affixes may be necessary.) There is no assurance that all the strings in this multilingual attr will be null or non-null, but even this looseness may occasionally be useful—where an affix is overt in one encoding, but covert in another. An example would be an affix consisting of a tone: tones might be marked in some encodings, but unmarked in others.
test Basic | IsAbstract | 3 | Boolean
This is used to indicate a lexeme form is an abstract form (e.g.,-[C][V]^2, or iN) and should not be used for parsing.
Basic | LiftResidue | 4 | Unicode-big

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | MorphType | 2 | atomic | MoMorphType
refers to an MoMorphType which is an item on a possibilities list. Possibilities include at least: prefix, suffix, infix, circumfix, root, bound root, and probably proclitic and enclitic. Note that most of these are appropriate for one or the other subclass, but since there is only one possibilities list, the types must be limited by procedural code. Other kinds of affixation (circumfixes, simulfixes, suprafixes etc.) are probably beyond the capabilities of Item-and-Arrangement morphology, and may therefore need to be prevented from appearing (or grayed out) with the class MoAffixAllomorph. Additional Notes: It is of course possible to analyze reduplication as the attachment of a prosodic constituent, such as a syllable (see McCarthy and Prince 1990), provided there is some way of filling the melodic information into that skeleton. But the system described here does not provide a way of automatically copying such melodic information, so reduplication cannot be treated in that way at present. (And in many cases, reduplication under prosodic morphology requires the base to be parsed into two constituents, so that affixation still involves more than specifying the prosodic form of the affix.)

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | LexDb:AllomorphIndex | 11 | collection | MoForm
test Refer'd by | MoAlloAdhocProhib:Allomorphs | 1 | sequence | MoForm
 | refers to a seq of MoForm objects, the co-occurrence of which is ungrammatical. Usually, there will be exactly two such allomorphs. If there are three or more allomorphs, the intended meaning is that a word is ungrammatical in which all such morphemes appear (but the co-occurrence of only some of the morphemes is not prohibited). Having only one morpheme in this attribute should be flagged as a Warning, since such a restriction can do nothing. When the Adjacency attribute is 'Anywhere', the fact that this attribute is a seq, rather than a collection, is unimportant. But the order of allomorphs becomes important when the Adjacency attribute has any other value. Specifically, the order of the allomorphs in this attribute is interpreted as a left-to-right order.
test Owned by | LexEntry:AlternateForms | 30 | sequence | MoForm
 | This holds alternate forms, or allomorphs, in addition to the lexeme form. The lexeme form is also an allomorph if it is not abstract. These forms along with the lexeme form (when not abstract) are used by the parser.
Refer'd by | MoAlloAdhocProhib:FirstAllomorph | 2 | atomic | MoForm
test Owned by | LexEntry:LexemeForm | 29 | atomic | MoForm
 | The lexeme form is the form of the entry that is normally used by linguists in interlinear text. The lexeme form is either the default allomorph for this lexEntry (e.g. French 'march' as opposed to citation form 'marcher') or the abstract underlying representation of it. (e.g. -[C][V]^2) When it is an abstract representation, the IsAbstract property is set. The lexeme form is equivalent to the base form in LinguaLinks or the \lx field in MDF files.
Refer'd by | WfiMorphBundle:Morph | 2 | atomic | MoForm
test Refer'd by | MoAlloAdhocProhib:RestOfAllos | 3 | sequence | MoForm
 | Changed from RestOfAllomorphs.


MoGlossItem

test num:109 | abbrev: glit | abstract: false | module: Ling(num:5) | base: CmObject
 | Type specifies whether or not this MoGloss is: a. a container b. a gloss c. a separator character

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Abbreviation | 2 | MultiUnicode |
Basic | AfterSeparator | 4 | Unicode |
test Basic | ComplexNameFirst | 6 | Boolean |
 | to control whether the name gloss precedes or follows the value bundle gloss. It should be possible to specify global defaults for these, as well as to override them for specific gloss items.
test Basic | ComplexNameSeparator | 5 | Unicode |
 | separates the gloss for the feature name from the gloss string for the value bundle
test Basic | EticID | 11 | Unicode |
 | Stores a reference to the XML ID of the Etic Gloss List.
Basic | Name | 1 | MultiUnicode |
test Basic | Status | 7 | Boolean |
 | Each top-level gloss item in the master gloss list needs a status attribute to indicate whether the subtree it dominates is visible or hidden. A hidden gloss item corresponds to a feature structure type that is only embedded as the value of complex features and so does not appear in the gloss possibilities chooser as a top-level choice but appears only in subtrees under complex features.
test Basic | Type | 3 | Integer |
 | Types: 1. fsType The item corresponds to a feature structure type. 2. feature The item corresponds to an inflectional feature. 3. value The item corresponds to an inflectional feature value. 4. complex The item corresponds to a complex feature that embeds another feature structure. 5. deriv The item is the gloss for a derivational morpheme. 6. group The item is in the list only for the purpose of organization and grouping 7. xref The item is a cross-reference to the term that is used in preference to this one.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Target | 10 | atomic | MoGlossItem
Note also that this attribute has two different functions. 1. If a gloss item is a cross-reference, it needs a target attribute to point to a the preferred term in the master gloss list. A cross-reference item lists a term that the user would be looking for, but redirects the user to a standardized term elsewhere in the tree. 2. An additional status is added to indicate that a gloss item that has been copied into a subtree under a complex feature is a proxy for the original gloss item in the master gloss list. A proxy item uses the target attribute to point to its source item. No other attributes on a proxy item should be used since the values on the target item are its values. (The implementation might use term to store the "carried-down" suffix to the gloss string when carry is active.) visible The item is an original item that should be shown in the gloss chooser. hidden The item is an original item, but should not be shown in the gloss chooser. proxy The item should be shown in the gloss chooser, but it is a proxy standing in for an original item.
test Owning | FeatStructFrag | 8 | atomic | FsFeatStruc
A gloss item in the language-specific gloss system is formalized by a feature structure fragment. The feature structure for a glossed morpheme is thus the unification of all the feature structure fragments for its component gloss items. When the user selects gloss items from the language-specific gloss system to form a composite gloss, this analysis is stored in the MSA as a gloss bundle (which an attribute on MSA that stores a set of references to all the selected gloss items). The language-specific feature structure for an MSA is automatically generated by computing the unification of all the feature structure fragments in the gloss bundle. Changed from FeatureStructureFragment.
Owning | GlossItems | 9 | sequence | MoGlossItem

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoMorphSynAnalysis:GlossBundle | 3 | sequence | MoGlossItem
The functional gloss for this MSA is the ordered bundle of MoGlossItems that it points to. These are ordered as necessary to create the desired gloss string. When the user selects gloss items from the language-specific gloss system to form a composite gloss, this analysis is stored in the MSA as a gloss bundle (which an attribute on MSA that stores a set of references to all the selected gloss items). The language-specific feature structure for an MSA is automatically generated by computing the unification of all the feature structure fragments in the gloss bundle.
Owned by | MoGlossSystem:Glosses | 1 | collection | MoGlossItem
Owned by | MoGlossItem:GlossItems | 9 | sequence | MoGlossItem
test Refer'd by | MoGlossItem:Target | 10 | atomic | MoGlossItem
Note also that this attribute has two different functions. 1. If a gloss item is a cross-reference, it needs a target attribute to point to a the preferred term in the master gloss list. A cross-reference item lists a term that the user would be looking for, but redirects the user to a standardized term elsewhere in the tree. 2. An additional status is added to indicate that a gloss item that has been copied into a subtree under a complex feature is a proxy for the original gloss item in the master gloss list. A proxy item uses the target attribute to point to its source item. No other attributes on a proxy item should be used since the values on the target item are its values. (The implementation might use term to store the "carried-down" suffix to the gloss string when carry is active.) visible The item is an original item that should be shown in the gloss chooser. hidden The item is an original item, but should not be shown in the gloss chooser. proxy The item should be shown in the gloss chooser, but it is a proxy standing in for an original item.


MoGlossSystem

num:108 abbrev: glsys abstract: false module: Ling(num:5) base: CmObject

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Glosses | 1 | collection | MoGlossItem

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | MoMorphData:GlossSystem | 7 | atomic | MoGlossSystem


MoInflAffixSlot

test num:36 abbrev: aslt abstract: false module: Ling(num:5) base:
This represents a set of Inflectional Affixes which are in complementary distribution on morphosyntactic grounds, and which occupy the same position relative to the stem and to the affixes of other slots (usually; see discussion under MoInflAffixTemplate concerning exceptions to this positional interpretation). As with MoInflAffixTemplate, it is not possible to arrange the Affix Slots in an inheritance hierarchy, and for the same reason: the Affixes slot is a sequence attribute, and it is unclear how one slot could modify another slot's sequence of affixes in inheritance (or how this inheritance would be modified if the user changed Affixes slot of the inherited-from Affix Slot). However, the PartOfSpeech objects which own the Affix Slots are arranged in an inheritance hierarchy, and if a subcategory has an Affix Slot with the same name as one of its parent's Affix Slots, the subcategory's Affix Slot overrides that of the parent. Also, two distinct slots can refer to some of the same affixes (since the MoInflAffixSlots are owned in the lexicon). Note that there is no attribute here for the semantics (or "grammatical function") represented by the slot. This is intentional: a slot need not have any coherent semantics (Matthews 1972b: 116). To the extent that a slot does have a unified semantic function distinct from that of other slots, this can be captured by the Name attribute, e.g. "Person/tense.""Person/tense," and in the Description slot.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Description | 2 | MultiString |
 | multilingual string, containing the user's description/ explanation of this slot (optionally including any consistent semantics-or an explanation that there is no consistent semantics).
test Basic | Name | 1 | MultiUnicode |
 | See discussion in class documentation.
test Basic | Optional | 4 | Boolean |
 | Optional: Boolean, default False. A value of true indicates that this slot is optional and therefore does not have to appear. This is not intended for slots which have what might be called a zero morpheme-see the discussion of the 'Affixes' attribute immediately above. Rather, this attribute is intended for the situation in which a language optionally marks some feature-value combinations. For example, in Tzeltal the plurality of a noun is only optionally marked: a suffix indicates that the noun is plural, but the absence of a plural suffix does not mean the noun is necessarily singular. For this situation, an optional slot containing the plural morpheme would be appropriate. Implementation Note: In the Tzeltal case discussed above, it would probably be inappropriate for the parser to say that a noun without an overt plural suffix was ambiguous between a singular reading and a plural one. Rather, it should unambiguously parse as unmarked for plurality.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PartOfSpeech:AffixSlots | 6 | collection | MoInflAffixSlot
owns a collection seq of MoInflAffixSlot, which may be referred to in MoInflAffixTemplates.The reason for having the ownership of Affix Slots reside here, rather than their being owned by the Affix Templates themselves, is to allow different Affix Templates to share Affix Slots. For example, suppose that in some language, both subject and object agreement are marked on the verb, and that the user has accordingly specified distinct parts of speech (and therefore distinct paradigms) for transitive and intransitive verbs. In all likelihood, most of the slots will be alike (tense and aspect marking, etc., and perhaps the subject agreement slot). The common affix slots can be shared if they are owned by the super-category verb (see the attribute vAllAffixSlots, below). Similarly, in Tzeltal nouns use the same prefixes for marking possessors as transitive verbs use for marking subjects. Assuming appropriate morphosyntactic features could be devised to represent the person of possessors and subject-of-transitives in Tzeltal, it would be nice to use the same MoInflAffixSlot for both. But this would be impossible, if the Affix Slots were owned by the Affix Templates (since nouns and verbs do not in general share those templates). It becomes possible if the Affix Slots are owned at some point in the part of speech inheritance hierarchy above noun and (transitive) verb, and referred to by the Affix Templates for these two categories.
test Refer'd by | MoInflAffixTemplate:PrefixSlots | 6 | sequence | MoInflAffixSlot
refers to an ordered seq of MoInflAffixSlot, i.e. those slots which correspond (roughly) to prefixes. The order is from the innermost affix out, i.e. right-to-left. The reason for this attribute (and for the SuffixSlots attribute, below) is that the Slots attribute is a derivation order, i.e. the order in which the affixes are applied during a derivation; while the partition into prefix and suffix slots is for purposes of display, and to support the stealth-to-wealth concept (see discussion above, under slots). For most languages, the PrefixSlots and the SuffixSlots will partition the entire set of slots. Of course, this assumes that no affix slot contains both prefixes and suffixes (i.e. there is no discontinuous bleeding), and that affixes of reduplication, infixes, circumfixes, simulfixes etc. can be shoe-horned into one or the other of these attributes. There are almost certainly languages where this will not work, and for which the user may wish to ignore the prefix and suffix division. Accordingly, some alternative sort of display should be available for that situation. An example of such a language is Huave (Matthews 1972b), for which some slots contain both prefixes and suffixes; see also Stump's (1992) discussion of "ambifixal position classes."
test Refer'd by | MoInflAffixSlotApp:Slot | 1 | atomic | MoInflAffixSlot
refers to an MoInflAffixSlot in the MoInflAffixTemplate pointed to by the Template attr of my owner.
test Refer'd by | MoInflAffixTemplate:Slots | 3 | sequence | MoInflAffixSlot
refers to an ordered seq of MoInflAffixSlot; during the course of a derivation, each Affix Slot is applied in sequence, beginning with the top-most slot. While in many (most?) languages the order of attachment of Inflectional affixes is irrelevant, it may occasionally be necessary to specify a derivational order to account for allomorphy. Since the left-to-right order is likely to be discovered earlier than the derivation order, it will probably be necessary to provide a default derivation order which can be computed from the order in the PrefixSlots and SuffixSlots attributes (below). Existing front-ends to AMPLE (such as CarlaMen) do something similar by allowing the user to choose to apply all prefixes before all suffixes, or vice versa, and something similar will probably suffice as a default here.
Refer'd by | MoInflAffMsa:Slots | 7 | collection | MoInflAffixSlot
test Refer'd by | MoInflAffixTemplate:SuffixSlots | 7 | sequence | MoInflAffixSlot
refers to an ordered seq of MoInflAffixSlot, i.e. those slots which correspond (roughly) to suffixes. The order is from the innermost affix out, i.e. left-to-right. See discussion re PrefixSlots concerning other types of affixes.


MoInflAffixSlotApp

test num:75 | abbrev: inflaffsltapp | abstract: false | module: Ling(num:5) | base: MoDerivTrace
 | This represents the application of a slot in an inflectional affix template to a stem. Note that there is no class for the attachment of an inflectional affix (which would be parallel to the class MoDerivationalAffixApp). The reason is that sufficient information is contained in the application of the slot.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | AffixForm | 2 | atomic | MoAffixForm
 | refers to an MoAffixForm, the allomorph of the inflectional affix which was attached. If the application of this slot results in an implicit zero affix (because none of the MoInflectionalAffixMsas belonging to this MoInflAffixSlot matched the InflectionalFeatures of the owning MoDerivation), this AffixForm will be none.
test Refer | AffixMsa | 3 | atomic | MoInflAffMsa
 | refers to an MoInflectonalAffixMsa, the inflectional affix which was attached. Note that this MSA does not result in any change to the MSA of the word. As with the AffixForm attr, if the application of this slot results in an implicit zero affix (because none of the MoInflectionalAffixMsas belonging to this MoInflAffixSlot matched the InflectionalFeatures of the owning MoDerivation), this AffixMsa attr will be none.
test Refer | Slot | 1 | atomic | MoInflAffixSlot
 | refers to an MoInflAffixSlot in the MoInflAffixTemplate pointed to by the Template attr of my owner.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoInflTemplateApp:SlotApps | 2 | sequence | MoInflAffixSlotApp
owns an ordered seq of MoInflAffixSlotApps, representing the sequence of inflectional affix slots belonging to this template that were applied in the derivation. An alternative to having this attr and a separate class for slot applications, would be to have an attr here for inflectional affix applications themselves, bypassing the "middleman." The distinction between slot applications and the attachment of a particular affix belonging to a slot is that if no affix in a particular slot applies, the effect is that of an implicit zero affix. Under this alternative, there would thus be no indication that the slot in question had been tried. It seems better to have this attr record the slot applications, on the assumption that one wants to know if there was an implicit zero affix. I have defined this as an ordered seq, but it would be possible to derive the ordering from the order of the MoInflAffixSlots in the Slots attr of the MoInflAffixTemplate of this template application. However, this would not work if the user had changed the order of slots since this derivation was created.


MoInflAffixTemplate

test num:37 abbrev: atmp abstract: false module: Ling(num:5) base: CmObject
An Inflectional Affix Template allows for the implementation of 'template morphology' (Anderson 1992, Stump 1998; note that an affix template essentially corresponds to Stump's 'Paradigm Function Schema'). An Affix Template provides for a sequence of slots (Stump's term; 'rule blocks', in Anderson's terminology) in which Inflectional affixes may appear-in effect, order classes for affixes. However, there is a difference from traditional position (order) classes, in that the latter were intended to capture two things: cooccurrence restrictions, and linear order, whereas affix templates are intended to capture (most cases of) cooccurrence restrictions, and are to some extent agnostic about linear order. While the order of affixes in affix templates usually corresponds to the linear order, it is possible to have both prefixes and suffixes in the same template (or even in the same slot). The need for this (or more commonly, perhaps, for infixes and prefixes in the same template or slot) is not unheard of; Stump (1993a: 457) gives an example from Sanskrit in which one affix in a slot is a suffix, while the other is a simulfix. Even then, it is sometimes possible to treat the infix or simulfix (etc.) as if it were a slightly odd prefix or suffix. Examples of so-called 'discontinuous bleeding' between prefixes and suffixes also exist, but are rarer (see for example Matthews (1972b), particularly his "series 30" on page 113). In true cases of discontinuous bleeding, the slots of the template will no longer represent position classes. (Anderson 1992: 131, on the other hand, says that the question of whether slots/ blocks correspond to the traditional notion of position classes is open.) Having said this, it will usually be reasonable to begin under the stealth-to-wealth approach with a traditional position class approach, assuming that affixes that occur in the same position relative to the stem and to each other belong to the same slots. (Discovering these position classes could be assisted by a program like PARADIGM (Grimes 1983).) Only when discontinuous bleeding cannot be accounted for in other ways (e.g. by assuming that one or the other of the affixes in question requires a more specific set of Inflectional features) will it be necessary to combine prefixes and suffixes, say, into a single slot. It should also be noted that there is no attribute in the template (or on the slots) distinguishing those slots which are prefixes from those which are suffixes, although it would be easy to create a virtual attribute which would show this where appropriate (i.e. where all the affixes of a given slot are suffixes, or all are prefixes). MoInflAffixTemplates are owned by PartOfSpeech objects. It might be nice if distinct MoInflAffixTemplates could inherit properties from each other. For instance, the Affix Template for a transitive verb might be just like that of an intransitive verb, save for having an additional slot for affixes marking object agreement. Unfortunately, MoInflAffixTemplates probably cannot participate in inheritance, since their principal attribute is the ordered list of MoInflAffixSlots, and it is unclear how inheritance of elements in a list could be done. (For example, it is unclear how an object slot could be inserted among the slots of another template.) However, since the MoInflAffixSlots themselves are owned by the PartOfSpeech, it is quite possible for two MoInflAffixTemplates to share many of the sameMoInflAffixSlots. What they cannot inherit is the order of those shared slots; they can only copy one another's order (and naturally, the copy can be altered, destroying the identical orders-of course, sometimes that is the correct thing!). There is no provision as yet for "spanned orders", i.e. overlapping slots; Grimes (1983) gives the following hypothetical example (his figure 1, page 5): Order 6 5 4 3 2 1 0 Prefixes ma-na- ba- da- ga- ka- pa-ta- Stem sa-za- The model may need to be modified to accommodate spanned orders. A work-around would be to assign the affixes of the spanning slot to one of the spanned slots, and to create null affixes with the appropriate morphosyntactic features as fillers for the remaining spanned slots. In many cases, the morphosyntactic features of the non-null spanning affixes can be used for these null affixes as well.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Description | 2 | MultiString |
test Basic | Final | 8 | Boolean |
 | In languages like Quechua, one can inflect a verb stem with all but tense. Instead one adds a derivational affix (participle) which creates a noun. The resulting stem is then inflected like a noun. To model this, we need the regular verbal template (including tense) and a template that has all but tense. When the former is applied to a stem, it produces a well-formed word. The latter is not. If we add a boolean to MoInflAffixTemplate that indicates that the template is non-final, then we can have our word grammar reject an analysis that ends with the non-final template (i.e. it does not have the required derivation and inflection). The default value for this boolean would indicate "final". The attribute could be called Final (with a default value of "true").
Basic | Name | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | PrefixSlots | 6 | sequence | MoInflAffixSlot
refers to an ordered seq of MoInflAffixSlot, i.e. those slots which correspond (roughly) to prefixes. The order is from the innermost affix out, i.e. right-to-left. The reason for this attribute (and for the SuffixSlots attribute, below) is that the Slots attribute is a derivation order, i.e. the order in which the affixes are applied during a derivation; while the partition into prefix and suffix slots is for purposes of display, and to support the stealth-to-wealth concept (see discussion above, under slots). For most languages, the PrefixSlots and the SuffixSlots will partition the entire set of slots. Of course, this assumes that no affix slot contains both prefixes and suffixes (i.e. there is no discontinuous bleeding), and that affixes of reduplication, infixes, circumfixes, simulfixes etc. can be shoe-horned into one or the other of these attributes. There are almost certainly languages where this will not work, and for which the user may wish to ignore the prefix and suffix division. Accordingly, some alternative sort of display should be available for that situation. An example of such a language is Huave (Matthews 1972b), for which some slots contain both prefixes and suffixes; see also Stump's (1992) discussion of "ambifixal position classes."
test Refer | Slots | 3 | sequence | MoInflAffixSlot
refers to an ordered seq of MoInflAffixSlot; during the course of a derivation, each Affix Slot is applied in sequence, beginning with the top-most slot. While in many (most?) languages the order of attachment of Inflectional affixes is irrelevant, it may occasionally be necessary to specify a derivational order to account for allomorphy. Since the left-to-right order is likely to be discovered earlier than the derivation order, it will probably be necessary to provide a default derivation order which can be computed from the order in the PrefixSlots and SuffixSlots attributes (below). Existing front-ends to AMPLE (such as CarlaMen) do something similar by allowing the user to choose to apply all prefixes before all suffixes, or vice versa, and something similar will probably suffice as a default here.
test Refer | Stratum | 4 | atomic | MoStratum
refers to the MoStratum to which this MoInflAffixTemplate belongs. Normally that would be the final stratum (or at least to the final stratum in which morphology takes place; if one is modeling post-lexical phonology, that would usually be in a stratum after the inflectional morphology). However, in languages where some derivational affixes attach outside of (some) inflection, that derivational morphology (and any subsequent inflectional morphology) will be in a stratum outside of a stratum containing the inflectional affix template. This definition assumes there are no cycles, i.e. that one does not get the same kind of inflectional affixes both inside and outside of derivational affixes. That's not obviously correct, e.g. one might have [[[[Noun_root] noun_template ] verbalizer ] verb_template] and [[[[Verb_root] verb_template ] nominalizer ] noun_template] where the two instances of noun_template and of verb_template are the same. This would be a counterexample (or would require duplicating the templates in the two strata, obviously a sign that something is wrong with the analysis).
test Refer | SuffixSlots | 7 | sequence | MoInflAffixSlot
refers to an ordered seq of MoInflAffixSlot, i.e. those slots which correspond (roughly) to suffixes. The order is from the innermost affix out, i.e. left-to-right. See discussion re PrefixSlots concerning other types of affixes.
test Owning | Region | 5 | atomic | FsFeatStruc
owns an FsFeatStruc defining the region of the paradigm for which this template is relevant. The idea here is that in some regions of the template (typically, things like participles or imperatives), there may be fewer affix slots than in other regions. While one could use the same template for all regions, with affixes in some of the slots restricted to appearing only with certain features (such as [?participle]), this is probably not the simplest analysis (since it requires all affixes in those slots to be so marked, including what would otherwise be default affixes). If this attr is empty, then this template pertains to the entire paradigm except for any regions covered by templates ordered before this one in the PartOfSpeech.AffixTemplates attr of the owner.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PartOfSpeech:AffixTemplates | 5 | sequence | MoInflAffixTemplate
owns an ordered seq of MoInflAffixTemplates, which define how affixation (but not choice of stems) works for this part of speech. The reason this is an ordered sequence attribute, rather than atomic, is to allow the user to capture the fact that the number of slots can be different for different parts of the paradigm (infinitives, for example, or tenses which are partly inflected on the main verb and partly on an auxiliary verb). The order of templates in this attribute is relevant: the first MoInflAffixTemplates whose Region attr is a subset of the inflectional features to be realized on the word, is chosen.Note the assumption here that all the words belonging to a single part of speech have fundamentally the same paradigm (and therefore the same set of affix templates), and that differences are accounted by membership in distinct MoInflectionClasses (Carstairs 1987: 10-11, Carstairs-McCarthy 1998b: 324). The fact that in languages which mark the verb for agreement with both subject and object, transitive verbs have different paradigms from intransitive verbs (transitives usually have an additional slot for object marking-or for subject marking, in the case of ergative languages), might seem to be a counterexample. The reason that is not a counterexample, is that transitive and intransitive verbs can be treated as separate parts of speech using the inheritance hierarchy.
test Refer'd by | WfiAnalysis:InflTemplateApps | 13 | sequence | MoInflAffixTemplate
Allows Morph Sketch Generator to extract example wordforms where an inflectional template is used. Changed from InflectionalTemplateApps.
test Refer'd by | MoInflTemplateApp:Template | 1 | atomic | MoInflAffixTemplate
refers to the MoInflAffixTemplate whose application this trace structure represents.


MoInflAffMsa

test num:38 abbrev: amsa abstract: false module: Ling(num:5) base: MoMorphSynAnalysis
An MoInflectionalAffixMsa defines an inflectional affix, i.e. the features which the affix realizes together with the phonological process applied to a stem to yield an inflected stem. The meaning of the inflectional affix is supplied by the Sense(s) which point to this morphosyntactic information item, but it is duplicated by the InflectionFeatures attribute (below). In some theories, grammatical morphemes like inflectional affixes are held not to have a sense per se, but only grammatical meaning (which in the model described here, would be encoded directly in the nflectionFeatures attribute). Inflectional affixes are treated in a realizational approach, as in Anderson 1992 etc. There is no provision in the model at this point for alternative treatments of inflection, e.g. a Lieber-style analysis. That could probably be added as an alternative theory of inflectional morphology at a later date, although the price would be complication. MoInflectionalAffixMsas are owned in the lexical database. Thus, they may be referred to (indirectly) by different MoInflectionClasses. There will doubtless be other attributes of this class (such as glosses); those defined here are just the ones necessary for the paradigm model. Renamed from MoInflectionalAffixMsa for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | AffixCategory | 2 | atomic | CmPossibility
In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. This field is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a CmPossibility of "derv" (derivational affix).
test Refer | FromProdRestrict | 8 | collection | CmPossibility
Refers to a collection of CmPossibility, giving any restriction classes which the stem to which this affix attaches must bear. If this attribute is empty, this affix may attach to a stem regardless of what restriction classes the stem bears (see MoStemMsa.ProductivityRestrictions). If there are two or more restriction classes listed for this affix, then the stem must have at least all of these restriction classes in its MoStemMsa.ProductivityRestrictions attribute in order for this affix to attach to the stem. The stem could have more restriction classes, but not less. (Note that unlike the case with MoDerivationalAffixMsa, there is no 'to productivity restrictions' attribute for inflectional affixes: inflectional affixes cannot add restriction classes to a word.) Changed from FromProductivityRestrictions.
Refer | PartOfSpeech | 5 | atomic | PartOfSpeech
Refer | Slots | 7 | collection | MoInflAffixSlot
test Owning | InflFeats | 1 | atomic | FsFeatStruc
Owns an FsFeatStruc, representing the morphosyntactic features realized by this affix. Most commonly, the feature values of this FsFeatStruc will belong to the PartOfSpeechGrammar.doc - PartOfSpeech.vAllInflectableFeatures of the stem to which the inflectional affix attaches, but may also include any of the features in the vAllInherentFeatureValues or vAllBearableFeatures attrs. For example, in Tzeltal there are two incompletive aspect prefixes, distinguished by whether the stem to which they attach is transitive or intransitive. The aspect feature would be an inflectable feature of verbs, but the transitivity feature would be either an inherent feature of the stem (assuming transitive and intransitive verbs have distinct parts of speech) or a bearable feature (if transitive and intransitive verbs are both treated as having the part of speech verb, and are distinguished by the transitivity feature alone). In determining what feature values can be added to a given FsFeatStruc, it will probably be desirable to disallow conflicting feature values (or even assigning the same feature value twice). However, it is permissible to have two different feature values at different places in an FsComplexValue; for example, [[Subject [Person 1]] [Object [Person 2]]]. In the course of a stealth-to-wealth analysis, a single affix might occupy a set of cells in a paradigm, where the cells do not form a natural class, and where they are not an 'elsewhere' case, or at least the user does not recognize them as such. This situation can be accommodated by the use of FsFeatStruc.FeatDisj. The goal at the 'wealth' end would be to find a natural class for the cells, thereby eliminating the feature disjunction, or to use disjunctive ordering within an MoInflAffixSlot to allow the statement of the features in a non-disjunctive manner. Changed from InflectionFeatures for the database port.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoInflAffixSlotApp:AffixMsa | 3 | atomic | MoInflAffMsa
refers to an MoInflectonalAffixMsa, the inflectional affix which was attached. Note that this MSA does not result in any change to the MSA of the word. As with the AffixForm attr, if the application of this slot results in an implicit zero affix (because none of the MoInflectionalAffixMsas belonging to this MoInflAffixSlot matched the InflectionalFeatures of the owning MoDerivation), this AffixMsa attr will be none.
test Refer'd by | MoStemName:DefaultAffix | 6 | atomic | MoInflAffMsa
refers to an inflectional affix (MoInflectionalAffixMsa) that is attached to the stem selected by the DefaultStem to give this stem, if the stem's lexical entry does not have an MoStemAllomorph with this stem name. If this attribute is empty, the default shape of this kind of stem is the same as that of the default stem; effectively, the stem is then formed by null affixation. The situation in which this attribute is empty is common in languages where some lexemes have a suppletive stem, but where the majority of lexemes use a regular stem without any special affixation. In Spanish, for instance, some verbs have an irregular stem used in the first person singular present indicative and in the present subjunctive, but for most verbs, the stem used in these regions of the paradigm is the same as that used elsewhere. Note that in the course of doing S2W morphology, the user might initially assign Spanish stem-changing and non-stem-changing verbs to different paradigms. Later, noticing that the only difference between the two paradigms is the stem change, he could collapse the two paradigms (as advocated in Carstairs 1987, chapter 6), retaining the special '1s present indicative/present subjunctive' form for the irregular verbs, and leaving the '1s present indicative/present subjunctive' form empty for regular verbs. While it would be nice to limit the possibilities for this attr to less than all the affixes in the lexical database, it is not clear that there is any way to do so.


MoInflClass

test num:39 abbrev: infl abstract: false module: Ling(num:5) base: CmObject
Inflection Classes correspond to the traditional idea of declension classes (for nouns and adjectives) and conjugation classes (for verbs). The concept is sometimes collapsed with the notion of paradigms (e.g. the "er paradigm"), which may cause confusion. Inflection Classes are abstract in the sense that they give instructions for how to build the paradigm of a given lexeme; in that sense, they are like class definitions as contrasted with instances of a class. Inflection Classes are owned by a PartOfSpeechgrammar.rtf - PartOfSpeech or by another MoInflectionClass. They thus form a default inheritance hierarchy from most general to most specific, so that Inflection Classes that are specializations of other Inflection Classes can be defined. Importantly, such specializations can define cells of the paradigm which are filled in different ways-exceptions to the inheritance hierarchy. There are limits to how far a given Inflection Class can deviate from the Inflection Class that it inherits from. First, there is no provision for inheritance across branches of the tree, i.e. this is a "tree-structured" inheritance hierarchy. Inheritance across branches would allow e.g. the Spanish verb tener to be described as a specialization of both the class of verbs showing the e/ye alternation and of the class showing the n/ng alternation. The problem is that with this across-branches inheritance, it would be possible for a given lexeme to have conflicting properties (ways to fill a single cell) inherited from two or more classes, neither of which is a specialization of the other, and it would be unclear which property "wins." In phonology, an analogous problem would seem to arise with "phonological rule features," each of which can trigger a different set of phonological rules. But the problem is resolved (in derivational theories) because the extrinsic ordering of those rules resolves any conflict, essentially resulting in prioritized multiple inheritance. (Similarly for the inheritance of conflicting phonological constraints under theories with ranked violable constraints, such as Optimality Theory.) A second limitation on inheritance is that inflection classes cannot specify alternative dimensions to their paradigms (PartOfSpeech.InflectableFeatures), because the dimensions are defined by the PartOfSpeech that ultimately owns the inflection classes. This limitation is probably realistic. A third limitation is that while an Inflection Class can specify an entirely different MoInflAffixTemplate from that of its parent Inflection Class, it cannot specify that one slot within the Affix Template it inherits is different, or that one affix within a given MoInflAffixSlot of that inherited Affix Template is different. This is a serious limitation, as it might be desirable to describe sub-inflection classes in precisely this way. However, it is not clear how this could be implemented , particularly if the inherited-from Template or Slot changes. For example, if a daughter Inflection Class replaced one of the slots of the parent Inflection Class with another, what would happen if the user decided to split the parent class's slot into two slots, or combine it with another slot? Renamed from MoInflectionClass

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Abbreviation | 1 | MultiUnicode |
 | a multiUnicode string, storing an abbreviated form of the Name. Probably useful for displays. Probably defaults to the first eight or so chars of the Name.
test Basic | Description | 2 | MultiString |
 | multilingual string, containing the user's description/ explanation of this inflection class.
test Basic | Name | 3 | MultiUnicode |
 | A multiUnicode string, e.g. "3rd. declension" or "?er verbs".

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | ReferenceForms | 7 | collection | FsFeatStruc
ReferenceForms: owns a collection of FsFeatStruc, each of which defines the cell whose inflection uniquely picks out an inflection class. (Cf. Carstairs-McCarthy 1991, particularly section 8). Usually, the reference forms belonging to a PartOfSpeech will suffice for all the MoInflectionClasses, i.e. a single "Primary Reference Form" (Carstairs-McCarthy's term). In some cases, however, it may prove necessary to provide a secondary reference form to distinguish among "mixed" classes (see again the discussion in Carstairs-McCarthy 1991.) This attr is then where the secondary reference form would be stored. The classes which need to be distinguished by ReferenceForms will presumably constitute the members of the Subclasses attr of some parent inflection class, together with that parent inflection class. The appropriate class to list the ReferenceForms will then be that parent class, and the daughter classes will inherit that property via their vAllReferenceForms (see below). Note that this attribute performs no particular function in any of the algorithms used for computing affixed forms. However, it may be useful in the context of a dictionary, e.g. for providing principal parts.
test Owning | RulesOfReferral | 5 | sequence | MoReferralRule
owns a sequence of MoReferralRule. Like the attribute pRulesOfReferral in the class PartOfSpeech, except that rules of referral which are owned by the PartOfSpeech hold for all lexemes of that part of speech (regardless of inflection class), whereas rules of referral owned by this class hold only for lexemes of a particular class. (In Stump's (1993a) notation, the latter case corresponds to indicating a 'CLASS' for the Referral Rule.)
test Owning | StemNames | 6 | collection | MoStemName
owns a collection of MoStemNames, which define any non-default inflectional stems of the inflection class (but not the default stem) in addition to those found in the PartOfSpeech. The MoStemNames are interpreted as a disjunctively ordered list, i.e. in selecting a Stem for a given word, the list of StemNames is searched linearly, stopping at the first one for which one of its cells unifies with the FsFeatStruc of the word to be derived (see Choosing a Stem Allomorph). The order of the MoStemNames in this attribute is therefore important. If this attribute is empty, it defaults to the value of the same attribute in its owner. This allows e.g. defining a set of stem names for all verbs, and inheriting those names for all inflection classes of verb (as well as for all subcategories of verb). It should probably be possible to block such inheritance without specifying any stem names, so there needs to be some specified value for that ('nil', say).
test Owning | Subclasses | 4 | collection | MoInflClass
owns a collection of MoInflectionClasses, each of which is a specialization of this Inflection Class. Part of the S2W process is decreasing the number of inflection classes by pushing identical information in subclasses up into the parent inflection class, and by accounting for differences among subclasses in other ways (e.g. as phonologically predictable allomorphy, or by features such as gender that are not among the PartOfSpeech.InflectableFeatures attribute of the owner).

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | PartOfSpeech:DefaultInflectionClass | 12 | atomic | MoInflClass
refers to one of the classes in vAllInflectionClasses; defaults to the first MoInflectionClasses in vAllInflectionClasses (which would be the first class defined for this part of speech; this choice makes sense, i.e. the default is likely to be the largest inflection class, not a subclass of some class.) According to Wurzel (as described in Carstairs-McCarthy 1998b), the default class is the Inflection Class to which newly coined lexemes are usually assigned, to which lexemes from other classes 'drift' in the process of historical change, and the class to which children tend to assign lexemes before they learn the correct class. For our purposes, however, it may be simpler just to think of the default class as being the largest class numerically, i.e. the class to which words in the lexical database are assigned as a first guess.
test Refer'd by | MoDerivAffMsa:FromInflectionClass | 5 | atomic | MoInflClass
specifies the inflection (conjugation or declension) class which the stem to which this affix attaches must belong. In general, derivational affixes are arguably not marked for this property, so this attribute may be superfluous. However, it will certainly be necessary if non-Inflectional inflectional morphology is to be modeled using this class. (And it may turn out that some derivational affixes are sensitive to the inflectional class of their stem.) Under the realizational model of inflectional morphology, the inflection class to which an allomorph of an inflectional (realizational) affix belongs is indicated by MoAffixForm.InflectionClasses. That attribute is also available for allomorphs of derivational affixes (i.e. this class). That might be overkill, in that if a derivational affix attaches to stems of a single inflectional class, we could assign a single allomorph to that affix, and capture the restriction of the affix to the inflectional class as a restriction on that allomorph. However, the fromInflectionClass attribute here is parallel to the toInflectionClass attribute (defined below), which is independently needed. (Andy suggests that it may also be the case that a derivational affix would apply to a single inflection class, but have multiple allomorphs, in which case it would be convenient to have the attribute here, thereby avoiding the need to mark each allomorph for the same inflection class.)
test Refer'd by | MoStemMsa:InflectionClass | 3 | atomic | MoInflClass
refers to an MoInflectionClass (i.e. a conjugation or declension class). If none is listed, PartOfSpeech.vDefaultInflectionClass is used. If there is no vDefaultInflectionClass, then there are presumably no inflection classes (since the default value for vDefaultInflectionClass is the first inflection class of the paradigm). The assumption here is that inflection class membership is essentially an arbitrary label, i.e. that the inflection class membership of a stem cannot and should not be defined by a set of stem allomorphs or lists of 'principal parts' (see discussion in Carstairs-McCarthy 1998b: 332-334).
test Refer'd by | MoDerivStepMsa:InflectionClass | 4 | atomic | MoInflClass
InflectionClass: refers to an MoInflectionClass. This gives the inflection class to which the word being derived belongs, at this stage in the derivation. The algorithm for computing this is rather complex (which is why I have not defined this as a virtual attr), but basically it is this: If the last MoDerivationalAffix attached specifies a ToInflectionClass, then this attr is that inflection class. If the last MoDerivationalAffix attached does not specify a ToInflectionClass, then we collect all the derivational affixes attached inside that one which have the same ToPartOfSpeech or a PartOfSpeech which is a subcategory or a supercategory of the last derivational affix's part of speech, stopping when we come to a part of speech which is not the same or a subcategory or a supercategory. The outermost of these affixes which specifies a ToInflectionClass is used for this stage's InflectionClass. If none of these affixes specifies a ToInflectionClass, and the MoStemMsa is accessible (meaning none of the affixes has a contrary ToPartOfSpeech), then we use the InflectionClass of that stem. If all of these possibilities fail, we use the vDefaultInflectionClass of the PartOfSpeech.
test Refer'd by | MoAffixForm:InflectionClasses | 1 | collection | MoInflClass
refers to a collection of MoInflectionClass, giving the conjugation or declension classes to which this allomorph belongs. This supports the collapsing into allomorphs of affixes which differ only in their form and in their requirements for inflection class. The allomorph which is the default will not specify any inflection class, and will therefore be used for all inflection classes not specified by other allomorphs. An empty value of this attribute therefore does not mean that this allomorph is not used in any inflection classes. In theory, this attr should be atomic, at least for inflectional affixes. That is, an inflectional affix should either specify a single inflection class, or it should be the elsewhere case, in which case it does not specify any inflection class (Carstairs-McCarthy 1994). It is nonetheless defined here as a seq attr, (1) for stealth-to-wealth reasons, and (2) because this theoretical claim may be wrong. There should however be tools to help the analyst discover inflectional affixes which have more than one inflection class specified in this attr, and if possible correct the analysis.
test Owned by | PartOfSpeech:InflectionClasses | 4 | collection | MoInflClass
owns a collection seq of MoInflectionClasses, each of which is an inflection class (conjugation or declension class) immediately owned by this part of speech. This does not include sub-inflection classes of those classes, for which see vAllSubInflectionClasses; nor does it include any inflection classes defined on more abstract parts of speech, for which see vAllSuperInflectionClasses. See also vAllInflectionClasses.
test Owned by | MoInflClass:Subclasses | 4 | collection | MoInflClass
owns a collection of MoInflectionClasses, each of which is a specialization of this Inflection Class. Part of the S2W process is decreasing the number of inflection classes by pushing identical information in subclasses up into the parent inflection class, and by accounting for differences among subclasses in other ways (e.g. as phonologically predictable allomorphy, or by features such as gender that are not among the PartOfSpeech.InflectableFeatures attribute of the owner).
test Refer'd by | MoDerivAffMsa:ToInflectionClass | 6 | atomic | MoInflClass
specifies the inflection (conjugation or declension) class which the word derived from this affix attaches belongs. An example of the use of this attribute would be to mark the conjugation class resulting from the attachment of a verbalizer. Another example is the use of the noun (declension) class 3 in Swahili to mark dimunitives (Beard 1998: 62). Note that a PartOfSpeech has an attr defaultInflClass, to which a derived word will belong if no toInflClass is defined here.


MoInflTemplateApp

test num:76 | abbrev: infltmpltapp | abstract: false | module: Ling(num:5) | base: MoDerivTrace
 | This represents the application of an MoInflAffixTemplate to a stem.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Template | 1 | atomic | MoInflAffixTemplate
refers to the MoInflAffixTemplate whose application this trace structure represents.
test Owning | SlotApps | 2 | sequence | MoInflAffixSlotApp
owns an ordered seq of MoInflAffixSlotApps, representing the sequence of inflectional affix slots belonging to this template that were applied in the derivation. An alternative to having this attr and a separate class for slot applications, would be to have an attr here for inflectional affix applications themselves, bypassing the "middleman." The distinction between slot applications and the attachment of a particular affix belonging to a slot is that if no affix in a particular slot applies, the effect is that of an implicit zero affix. Under this alternative, there would thus be no indication that the slot in question had been tried. It seems better to have this attr record the slot applications, on the assumption that one wants to know if there was an implicit zero affix. I have defined this as an ordered seq, but it would be possible to derive the ordering from the order of the MoInflAffixSlots in the Slots attr of the MoInflAffixTemplate of this template application. However, this would not work if the user had changed the order of slots since this derivation was created.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoStratumApp:TemplateApp | 4 | atomic | MoInflTemplateApp
 | owns an MoInflAffixTemplateApp, representing the application of an MoInflAffixTemplate belonging to this stratum and matching the InflectionClass of the MoStemMsa at the point of application.


MoInsertNC

test num:69 | abbrev: insrtnc | abstract: false | module: Ling(num:5) | base: MoRuleMapping
 | Indicates that a natural class (the length of one phoneme, albeit perhaps incompletely instantiated, i.e. an archiphoneme) is to be inserted in the output at this point. The insertion of a natural class implies that the phonological component will sufficiently instantiate the inserted archiphoneme as to render it an unambiguous phoneme. This class is therefore irrelevant unless a phonological component has been implemented.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Content | 1 | atomic | PhNaturalClass
 | refers to a PhNaturalClass to be added into the output at this position.

Back references (sorted by attribute name)

Type Name Num Card Sig


MoInsertPhones

test num:68 | abbrev: insrtphns | abstract: false | module: Ling(num:5) | base: MoRuleMapping
 | Indicates that a sequence of phonemes (possibly including a boundary marker) is to be inserted at this position. This is the typical way of adding 'plain' affixal material. Note that to the user, this sequence may appear to be simply a string in the encoding of the language.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Content | 1 | sequence | PhTerminalUnit
 | refers to an ordered seq of PhPhonemes and/or PhBdryMarkers (thus the signature is the superclass PhTerminalUnit).

Back references (sorted by attribute name)

Type Name Num Card Sig


MoModifyFromInput

test num:70 | abbrev: modfrominpt | abstract: false | module: Ling(num:5) | base: MoRuleMapping
 | Indicates that a portion of the input is to be copied over to the output, but modified by the addition (or change) of certain features. This would be useful for a simulfix, for example; or for reduplication with modification.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Content | 1 | atomic | PhContextOrVar
 | refers to a PhContextOrVar from the input of the MoAffixProcess owning this object; the meaning is that the stretch of the input word matched by that PhContextOrVar is copied over to the output, but modified in accordance with the modification attribute. Typically, this will be a single phoneme, which is modified by the addition of one or two features (e.g. by being palatalized).
test Refer | Modification | 2 | atomic | PhNCFeatures
 | refers to an PhNCFeatures object, specifying the features to be added to the phonemes matched by the content to give a portion of the output.

Back references (sorted by attribute name)

Type Name Num Card Sig


MoMorphAdhocProhib

test num:102 | abbrev: acp | abstract: false | module: Ling(num:5) | base: MoAdhocProhib
 | This is intended to capture co-occurrence restrictions between morphemes which cannot be (or have not yet been) captured using morphosyntactic (or perhaps phonological) restrictions. The scope of the cooccurrence constraint is the entire word. The two or more morphemes participating in cooccurrence constraints are not constrained to be string-adjacent. However, it might be possible to restrict cooccurrence restrictions between exactly two morphemes to derivational order adjacency, i.e. to the last affix added. This would follow from Siegel's 'Adjacency Condition' (cited in Scalise 1986: 170). Renamed from MoMorphemeAdHocCoProhibition for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | FirstMorpheme | 2 | atomic | MoMorphSynAnalysis
test Refer | Morphemes | 1 | sequence | MoMorphSynAnalysis
 | refers to a collection seq of MoMorphoSyntaxAnalysis objects, the co-occurrence of which is ungrammatical. Usually, there will be exactly two such morphemes. If there are three or more morphemes, the intended meaning is that a word is ungrammatical in which all such morphemes appear (but the co-occurrence of only some of the morphemes is not prohibited). Having only one morpheme in this attribute should be flagged as a Warning, since such a restriction can do nothing. Note: we are assuming here that the user interface cannot simply prohibit constraints with a single morpheme, because they arise in the process of creating a constraint. (You cannot count to two until you've counted to one.)
test Refer | RestOfMorphs | 3 | sequence | MoMorphSynAnalysis
 | Changed from RestOfMorphemes.

Back references (sorted by attribute name)

Type Name Num Card Sig


MoMorphData

test num:40 | abbrev: mdat | abstract: false | module: Ling(num:5) | base: CmObject
 | This class holds the few items of information which are relevant only to the morphology. Presumably there will be virtual attributes for other things, e.g. all derivational affixes or all inflectional affixes. I have not defined these (but see the similar attributes of MoStratum). Renamed from MoMorphologicalData for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | ParserParameters | 8 | Unicode |
 | We need a place to put "maximum parses" and other related parameters. Note: The following parameters could easily need to be controlled by the user (and are already set as parameters in the XSLT that creates the AD.CTL file): prmMaxNull - maximum number of nulls <p/> prmMaxPrefixes - maximum number of prefixes (default is 5) <p/> prmMaxSuffixes - maximum number of suffixes (default is 255) <p/> prmMaxInfixes - maximum number of infixes (default is 0 unless there are infixes in which case it is 1) <p/> prmMaxRoots - maximum number of roots that can compound (default is 2 if there are compound rules; otherwise it is 1) <p/> [There is one other parameter for max number of properties, but we should be able to calculate that number based on the data - I'll fix this.]

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | AnalyzingAgents | 5 | collection | CmAgent
test Owning | AdhocCoProhibitions | 3 | collection | MoAdhocProhib
Used to hold the list of ad hoc cooccurrence restrictions. (Ideally, this is empty!)
test Owning | CompoundRules | 2 | sequence | MoCompoundRule
owns a seq of MoCompoundRules. (Alternatively, these could be owned in the stratum to which they belong - see MoStratum.vCompoundRules for discussion.) The order corresponds to the order in which the compounding rules apply in a derivation.
Owning | GlossSystem | 7 | atomic | MoGlossSystem
test Owning | ProdRestrict | 9 | atomic | CmPossibilityList
This reflects what is also referred to as exception features in the literature. It defines class identifiers that can be associated with non-productive derivational or inflectional affixes that only go on stems that belong to the same class. An example from English is the feature [+Latinate], marking that part of the English vocabulary which is etymologically derived from Latin, and which has certain synchronic properties. For example, the suffix -ity attaches only to [+Latinate] stems (Aronoff 1976: 51): felicity, vivacity, *widity, *strongity. The similar suffix -ness, on the other hand, attaches to more or less all adjectives regardless of this feature. Similar restrictions are apparently found in other languages which have undergone substantial borrowing, e.g. Mohawk and Dutch are said to have restrictions which depend on whether or not stems were borrowed from French. Maybe there are other sources of such restrictions as well. These restrictions cannot be handled by inflection classes. The reason is that inflection classes and exception features are likely to be cross-cutting distinctions. Changed from ProductivityRestrictions
test Owning | Strata | 1 | sequence | MoStratum
owns a col of MoStratum objects, in order from shallowest to deepest.
test Owning | TestSets | 6 | collection | WfiWordSet
WfiWordSets are a collection of words that the user might want to use to test his word grammar as he adjusts morphological rules and the lexicon.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:MorphologicalData | 22 | atomic | MoMorphData


MoMorphSynAnalysis

test num:41 abbrev: msa abstract: true module: Ling(num:5) base: CmObject
It is intended to group together the morphosyntactic information about a mono- or poly-morphemic object (roots, affixes, composite stems...); in essence, whatever morphosyntactic properties a parser could be expected to "know", as opposed to phonological or semantic properties. (The reference to a parser is for illustrative purposes only; MoMorphoSyntaxAnalysis objects are relevant regardless of whether the system contains a parser.) This is an abstract class. Subclasses for stems, derivational affixes, and inflectional affixes are discussed here; LexEntries also own MoMorphoSyntaxAnalysis objects, e.g. for words and idioms. Notice that the three subclasses have an attr named Allomorphs, although the signature is MoStemAllomorph in the case of MoStemMsa, and MoAffixForm in the case of the other two classes. Additional Notes: From a broad perspective, theories of morphology can be divided into morpheme-based theories and word-based (or better, lexeme-based) theories. Scalise (1986: 40; drawing on Aronoff 1976) lists the following characteristics of the 'Word Based Hypothesis' (in contradiction to a morpheme-based analysis): 1. The bases of Word Formation Rules (WFRs, i.e. derivational affixation) are words, not morphemes. One issue here is whether words like perceive, deceive, conceive etc. should be broken down into meaningless morphemes per?, de?, con?, and ?ceive (note that ?ceive has the allomorph ?cept in nominalizations of all these words: perception etc.). Similarly with respect to words like strawberry (where berry has its expected meaning, but straw does not) and cranberry (where cran apparently has no meaning apart from this word). Another issue is whether words like serendipity and total are polymorphemic (serendip + i + ty and tot + al); Aronoff would claim they are not. 2. These words must be existing words, as opposed to possible but non-existing words. For example, recitation cannot be derived from *recitate, nor approbation from *approbate. 3. The base of a WFR must be a single word, not more (i.e. a phrase; clitics are thus a separate issue) or less (a bound form; see point (1) above). 4. The input of a WFR must be a major category, i.e. N, V or A, or in some languages P. Adverbs are seldom discussed, but at least some adverbs (such as locatives and VP- or S-modifiers) would presumably be included under one of the other major categories. What is ruled out is that the base might be a category like determiner, 'particles', or an uninflectable adverb like very. 5. The output of a WFR must be a major category. However, the term 'word' in the above has led to confusion. Aronoff was not concerned in his 1976 book with inflectional affixation, so the term 'word' might be better understood as 'inflectional stem' or 'lexeme', i.e. the base to which inflectional affixes attach. Thus, if in some language, all words of a given category bear (overt) inflectional affixes, talking about the stems of that language does not violate the Word Based Hypothesis. What would violate the Word Based Hypothesis would be an analysis in which -ceive and -mit were stored in the lexicon as stems, and per-, de-, con- etc. were analyzed as prefixes attaching to such stems. Putting it differently, analyses which violate the criteria in points (1-3) might be seen as over-analysis. Thus, -ceive and -mit are not words (point 1), and they are certainly not existing words (point 2); at most, they are bound forms (point 3). The existence of subclasses of this class for sub-word things (stems and affixes) is not intended to prevent modeling lexeme-based theories. In fact, while the conceptual model given here does not actually prevent the user from doing morpheme-based morphology in violation of the Word Based Hypothesis, he is not encouraged to do so, since lexemes listed in the lexicon are expected to have meanings (senses) associated with them (issues 1-2). At the same time, the model does not enforce points (3-5), nor can it probably do so on a universal basis. For example, the borderline between major categories and minor categories (points 4-5) is not clear across languages. Some languages have inflectable prepositions, and it is at least conceivable in some of these languages that those prepositions will also serve as the base for derivational morphology. In summary, the model is intended to support lexeme- (stem-) based morphology to the extent possible. With regard to affixes: some theories (e.g. a-morphous morphology, Anderson 1992) do not consider affixes to be morphemes, in the sense of items listed in the lexicon. The existence of the classes MoInflectionalAffixMsa (for inflectional affixes) and MoDerivationalAffixMsa (for derivational affixes), and the storage of objects of such classes in LexEntry objects, is not intended as a theoretical statement. Renamed from MoMorphoSyntaxAnalysis for the Firebird Port.

Direct Subclasses

  • MoStemMsa
  • MoInflAffMsa
  • MoDerivStepMsa
  • MoDerivAffMsa
  • MoUnclassifiedAffixMsa

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | GlossString | 2 | Unicode |
 | Stores the gloss string generated by the sequence of MoGlossItems (association GlossBundle). The user can override this if necessary.
Basic | LiftResidue | 4 | Unicode-big |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Components | 1 | sequence | MoMorphSynAnalysis
points to an ordered seq of other MoMorphoSyntaxAnalysis objects, which are interpreted as the morphemes or stems that make up this object. Additional Notes: Ordinarily, this would only be appropriate for stems which are not roots, hence it would be an attribute of MoStemMsa. I believe it is here on the superclass because under the stealth-to-wealth concept, the user may be in a state where he realizes something is composite, but has not yet worked out all the morphemes of which it is composed. This attribute could then be used to point to the parts that have already been discovered. Possibly when the user succeeds in completely decomposing the stem or composite affix, this object could go away, although it may be beneficial to retain it for future comparisons. Another possible use might be for a portmanteaux affix with a partial analysis, or for 'complex' affixes like the English ?ation (which under the Word Based Hypothesis, cannot be composed of the suffixes ?at and ?ion because of its appearance in words like recitation, since there is no word *recitate). I have defined this as an ordered seq on the assumption that the order of the components will match the left-to-right order of the morphemes. This is not unproblematic: some morphemes may be unanalyzed, and some morphemes may not appear in a strict left-to-right order (e.g. infixes). The former problem could be fixed by the use of placeholder (uninstantiated) Msas; the latter could be fixed either by defining a canonical order, or by using derivational order instead.
test Refer | GlossBundle | 3 | sequence | MoGlossItem
The functional gloss for this MSA is the ordered bundle of MoGlossItems that it points to. These are ordered as necessary to create the desired gloss string. When the user selects gloss items from the language-specific gloss system to form a composite gloss, this analysis is stored in the MSA as a gloss bundle (which an attribute on MSA that stores a set of references to all the selected gloss items). The language-specific feature structure for an MSA is automatically generated by computing the unification of all the feature structure fragments in the gloss bundle.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoMorphSynAnalysis:Components | 1 | sequence | MoMorphSynAnalysis
points to an ordered seq of other MoMorphoSyntaxAnalysis objects, which are interpreted as the morphemes or stems that make up this object. Additional Notes: Ordinarily, this would only be appropriate for stems which are not roots, hence it would be an attribute of MoStemMsa. I believe it is here on the superclass because under the stealth-to-wealth concept, the user may be in a state where he realizes something is composite, but has not yet worked out all the morphemes of which it is composed. This attribute could then be used to point to the parts that have already been discovered. Possibly when the user succeeds in completely decomposing the stem or composite affix, this object could go away, although it may be beneficial to retain it for future comparisons. Another possible use might be for a portmanteaux affix with a partial analysis, or for 'complex' affixes like the English ?ation (which under the Word Based Hypothesis, cannot be composed of the suffixes ?at and ?ion because of its appearance in words like recitation, since there is no word *recitate). I have defined this as an ordered seq on the assumption that the order of the components will match the left-to-right order of the morphemes. This is not unproblematic: some morphemes may be unanalyzed, and some morphemes may not appear in a strict left-to-right order (e.g. infixes). The former problem could be fixed by the use of placeholder (uninstantiated) Msas; the latter could be fixed either by defining a canonical order, or by using derivational order instead.
Refer'd by | MoMorphAdhocProhib:FirstMorpheme | 2 | atomic | MoMorphSynAnalysis
test Refer'd by | MoMorphAdhocProhib:Morphemes | 1 | sequence | MoMorphSynAnalysis
refers to a collection seq of MoMorphoSyntaxAnalysis objects, the co-occurrence of which is ungrammatical. Usually, there will be exactly two such morphemes. If there are three or more morphemes, the intended meaning is that a word is ungrammatical in which all such morphemes appear (but the co-occurrence of only some of the morphemes is not prohibited). Having only one morpheme in this attribute should be flagged as a Warning, since such a restriction can do nothing. Note: we are assuming here that the user interface cannot simply prohibit constraints with a single morpheme, because they arise in the process of creating a constraint. (You cannot count to two until you've counted to one.)
Owned by | LexEntry:MorphoSyntaxAnalyses | 9 | collection | MoMorphSynAnalysis
Refer'd by | LexSense:MorphoSyntaxAnalysis | 1 | atomic | MoMorphSynAnalysis
Refer'd by | WfiMorphBundle:Msa | 3 | atomic | MoMorphSynAnalysis
test Refer'd by | MoMorphAdhocProhib:RestOfMorphs | 3 | sequence | MoMorphSynAnalysis
Changed from RestOfMorphemes.


MoMorphType

test num:42 | abbrev: mot | abstract: false | module: Ling(num:5) | base: CmPossibility
 | There is one of these objects for each morpheme type, and are owned by the CmPossibilityList for the language. The attributes name and abbreviation are inherited from the superclass, CmPossibility.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Postfix | 1 | Unicode |
 | like pPrefix, but added after the fForm. Often a dash for prefixes and infixes, and perhaps proclitics.
test Basic | Prefix | 2 | Unicode |
 | Attached to the beginning of the fForm of an MoForm which belongs to this MoMorphType for display purposes (??). Typically, this will be a dash for suffixes, infixes and perhaps enclitics.
test Basic | SecondaryOrder | 3 | Integer |
 | Determines sorting when there are homographic forms that are of different morph types. For example what order does in, in-, -in, in= and =in and -in- appear IN the dictionary.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoForm:MorphType | 2 | atomic | MoMorphType
refers to an MoMorphType which is an item on a possibilities list. Possibilities include at least: prefix, suffix, infix, circumfix, root, bound root, and probably proclitic and enclitic. Note that most of these are appropriate for one or the other subclass, but since there is only one possibilities list, the types must be limited by procedural code. Other kinds of affixation (circumfixes, simulfixes, suprafixes etc.) are probably beyond the capabilities of Item-and-Arrangement morphology, and may therefore need to be prevented from appearing (or grayed out) with the class MoAffixAllomorph. Additional Notes: It is of course possible to analyze reduplication as the attachment of a prosodic constituent, such as a syllable (see McCarthy and Prince 1990), provided there is some way of filling the melodic information into that skeleton. But the system described here does not provide a way of automatically copying such melodic information, so reduplication cannot be treated in that way at present. (And in many cases, reduplication under prosodic morphology requires the base to be parsed into two constituents, so that affixation still involves more than specifying the prosodic form of the affix.)


MoPhonolRuleApp

test num:77 | abbrev: phrulapp | abstract: false | module: Ling(num:5) | base: MoDerivTrace
 | This represents the application of a single phonological rule to a stem. Inasmuch as phonological rules are not defined in this document as yet, this is a placeholder for a future class.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | VacuousApp | 2 | Boolean |
 | Boolean; true means the rule applied vacuously, false means it made some change to the phonetic form to which it applied. The point of having this attr is for display purposes: it allows the user to quickly tell whether a rule made a change to its input. This could be defined either as an owning attr or as a virtual attr (the latter would test for equality of the vInputForm and OutputForm attrs). The alternative to having this attr would be to use a special mark in the OutputForm of this class (see definition of this attr in MoDerivationTrace) when a phonological rule applies vacuously. But that wouldn’t work if another MoDerivationTrace’s InputForm needs to refer to the OutputForm of this rule application.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Rule | 1 | atomic | CmObject
 | refers to the phonological rule (class to be defined) whose application this trace structure represents

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoStratumApp:PRuleApps | 5 | sequence | MoPhonolRuleApp
 | owns an ordered seq of MoPhonolRuleApp, representing the application of the phonological rules of this stratum. Note that the fact that this attr belongs to the MoStratumApp precludes modeling cyclic application. That restriction could easily be lifted. The order is the order of application in derivation (which may be the reverse of the order in parsing).


MoReferralRule

test num:44 abbrev: rrul abstract: false module: Ling(num:5) base: CmObject
Rules of Referral are used when one cell of a paradigm is realized in the same way as another cell-that is, to define syncretisms in a paradigm. Specifically, they are intended to describe syncretisms which cannot be captured by the use of underinstantiated morphosyntactic feature structures and disjunctive ordering of affixes. Typically, syncretisms appear in the more marked portions of the paradigm. As an example of a situation where referral rules are not necessary, suppose affix A marks the genitive case, affix B marks the dative case, and affix C is used elsewhere (perhaps in the nominative and accusative cases). This situation can be easily captured by the use of features and disjunctive ordering as follows: affix A realizes the morphosyntactic feature [genitive case], affix B realizes the feature [dative case], and affix C is not marked as realizing any morphosyntactic features-but crucially, it is ordered after affixes A and B. In this situation, there is no need for any rule of referral. An analysis using a default will always be possible where only a single feature is involved, and often in other situations. Another situation in which rules of referral are not necessary, is where the features realized by an affix constitute a natural class. For example, suppose a verb paradigm generally distinguishes singular and plural subject, as well as person of the subject, except that the second person singular and plural are represented by a single affix. While the other affixes mark feature values for both number and person, the second person affix can be seen as marking the natural class of second person. On the other hand, if a single affix marks, say, second person singular and third person plural, there is probably no natural class which captures these two categories. If these categories do not constitute an elsewhere case, then they would be candidates for a referral rule. Another situation in which a referral rule would be appropriate arises in an agglutinating language, where an entire syntagmatic series of affixes are the same for two positions in the paradigm. Stump (1993a) gives an example from Macedonian (see his table 2, page 452). Besides their ordinary use in capturing true cases of syncretism, rules of referral are also important in the context of stealth-to-wealth morphology. Specifically, the linguist can quickly capture syncretisms in a paradigm using rules of referral, and later decide whether there might be a more elegant way of capturing a syncretism using appropriate features, disjunctive ordering, and elsewhere cases. In the context of Stealth-to-wealth morphology, one way to initially assign a value to the Input and Output fields (defined below) of a Rule of Referral would be to select one or more cells in a paradigm as the Input, and one cell as the Output. The system could automatically remove any feature values from the output which were unchanged from the input, thereby simplifying the Output field. Later, the user could collapse several Rules of Referral which produced similar Outputs. For example, suppose a language has three genders, and that for each gender the accusative plural is syncretic with the corresponding nominative plural. Then as a first cut, the linguist might have three Rules of Referral, one for each gender. But these rules could be collapsed by removing the gender features from the inputs. Stump (1993a) discusses two kinds of rules of referral: 'broad rules', which say that one cell of a paradigm is realized in the same way as another cell; and 'narrow rules', which say that one rule (affix) is used in place of another. The difference is clearest in agglutinative systems (as opposed to so-called 'inflecting' languages, like Latin): under the narrow construal of rules of referral, it is possible for just one affix out of the sequence of affixes of a given word to be realized by a rule of referral. Under the broad construal, this cannot happen (or at least it cannot be said in quite those simple terms). Despite the limitations, I have defined rules of referral in this implementation to the 'broad' category. The reason is that 'narrow' rules of referral presuppose a more complicated sort of morphological rule system than what I am proposing here. Some of the effect of 'narrow' rules of referral could be obtained by allowing disjunction in the morphosyntactic feature specifications of Inflectional rules, which might be a simpler way to do it (and perhaps clearer for the user). In the theory of Distributed Morphology (see e.g. Halle and Marantz 1993; Noyer 1992, 1998; see also the discussion of the latter paper in Carstairs-McCarthy 1998a), rules of referral are replaced by rules of 'impoverishment', which (roughly speaking) delete morphosyntactic features from a word to be generated, rather than change them. I have not included rules of impoverishment in this model, on the assumption that working with such rules is probably too complex for most of our users, and that Distributed Morphology is a narrowly followed theory. (I'm sure its proponents wouldn't agree with me on that!)

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Description | 2 | MultiString |
 | multilingual string, containing the user's description/ explanation of this rule.
test Basic | Name | 1 | MultiUnicode |
 | a multiUnicode string. Not used in any algorithms, but people like to name things. Maybe we want an abbreviation (for displays), too?

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Input | 3 | atomic | FsFeatStruc
owns an FsFeatStruc, constituting the morphosyntactic feature values which must be present in a word in order for this Rule of Referral to apply. Often these features form an 'environment' which is not altered in the Output. However, this is true only if the input features are disjunctive with the output features. For instance, suppose in some language the nominative plural of nouns is syncretic with the nominative singular. Assuming singular and plural are the two possible values of 'number' in this language, this syncretism can be represented by a rule which has as input [case: nominative] and as output [number: singular]. But it is not always possible to make the input and output features disjunctive, particularly (but not only) where features are non-binary. For example, if the above syncretism held in a language which distinguished dual number, and the nominative dual was distinct from the singular (and plural) nominative forms, then it would be necessary to mention the 'number' feature both in the input and in the output, to prevent the rule from overapplying to the dual. It might be possible (and desirable) to have a view of rules of referral in which the input features which are unaffected in the output are distinguished (as a sort of environment) from the input features which are changed in the output. Additional notes: In Stump's (1993a, (11) page 457) format for a Rule of Referral, this corresponds to τ on the left-hand side.
test Owning | Output | 4 | atomic | FsFeatStruc
Constitutes the morphosyntactic feature values which the Rule of Referral outputs. Additional notes: In Stump's (1993a, (11) page 457) format for a Rule of Referral, this corresponds to [F1:v1...Fm:Vm]. Note that the input and output fields may refer to the same features, albeit with different values. This is particularly likely for non-binary features (see Stump's rules (20) and (28), for example), but may also be necessary with binary features (e.g. Stump's rule (54b)). Accordingly, it would be possible to split the input features into a set of features whose values will be changed in the output, and a set of features which effectively form the environment for the change. This could even be done in the 'view' of the rule.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PartOfSpeech:RulesOfReferral | 3 | sequence | MoReferralRule
 | owns an ordered seq of MoReferralRule; used for statements like "the accusative plural of nouns is identical to the nominative plural" or "the accusative plural of second declension nouns is identical to the nominative plural'. (Note that rules of referral which are owned by the PartOfSpeech hold for all lexemes of that part of speech, regardless of inflection class; whereas rules of referral owned by an MoInflectionClass hold only for lexemes of that class. In Stump's (1993a) notation, the latter case corresponds to indicating a 'CLASS' for the Referral Rule.)I (MM) have defined this as an ordered seq, because in rare cases one referral rule might override another such rule. See the discussion of the similar RulesOfReferral attr in MoInflectionClass.
test Owned by | MoInflClass:RulesOfReferral | 5 | sequence | MoReferralRule
 | owns a sequence of MoReferralRule. Like the attribute pRulesOfReferral in the class PartOfSpeech, except that rules of referral which are owned by the PartOfSpeech hold for all lexemes of that part of speech (regardless of inflection class), whereas rules of referral owned by this class hold only for lexemes of a particular class. (In Stump's (1993a) notation, the latter case corresponds to indicating a 'CLASS' for the Referral Rule.)


MoRuleMapping

test num:66 | abbrev: rlmp | abstract: true | module: Ling(num:5) | base: CmObject
 | An abstract class for the various sorts of things that a processual affix can 'do' to its input, such as copying all or part of the input, adding phonetic material, or modifying part of the input. (Deleting part of the input is done by not mentioning in the output the PhContextOrVar corresponding to that portion of the Input.) No attributes are defined here. All subclasses implement a Content attribute, but not necessarily in the same way.

Direct Subclasses

  • MoInsertNC
  • MoCopyFromInput
  • MoInsertPhones
  • MoModifyFromInput

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoAffixProcess:Output | 3 | sequence | MoRuleMapping
 | Owns an ordered seq of MoRuleMapping, describing the form output by attachment of this affix. Typically this consists of a copy of the Input plus some constant for the affix, but reduplication, infixation, simulfixes and suprafixes will be more complex. The left-to-right order of the MoRuleMapping objects in this attribute corresponds to the order of the pieces of the output word which will be constructed by the rule.


MoStemAllomorph

test num:45 abbrev: salo abstract: false module: Ling(num:5) base: MoForm
This represents the allomorph of a root. A polymorphemic stem may however be represented here under some stealth-to-wealth situations (see discussion of MoMorphoSyntaxAnalysis.Components). There are issues here with the interaction between Item-and-Process morphology and the use of root allomorphs. Namely, what is the root chosen on the basis of, if affixes are added processually (that is, as morphological rules which modify the form of the base)? One algorithm would be to try all the allomorphs of the root, attach whatever affixes are to be attached, and see if the output form of the root remains unchanged (meaning that the form of the root originally chosen was "right"). However, that encounters problems in that it is not possible in general to discriminate the root in the surface form of a word to which processual affixes have been attached; there may be no clear boundary between root and affix. It may therefore be the case that the use of this class to account for allomorphy (i.e. having more than one root allomorph for a given root lexeme) should be restricted to Item-and-Arrangement morphology, where an algorithm like that used in STAMP would work. However, this has severe implications for stealth-to-wealth work, in that adding a single Item-and-Process affix would mean that any use of this MoStemAllomorph class would break (at least if the affix and the root allomorphs were morphosyntactically compatible).

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | PhoneEnv | 2 | collection | PhEnvironment
 | refers to a collection of PhEnvironment objects, describing what the phonetic environment of this allomorph is. The reason this is a collection attr (rather than atomic) is to allow for the situation during analysis before the user has managed to collapse what appear to be disparate environments into a single environment. (Note that the 'elsewhere' case can be represented by an empty environment under the assumption of disjunctive ordering.) Hence, a step in the stealth-to-wealth process will be to reduce the cardinality of this collection to one. A collection may of course also be useful for allomorphs which actually does appear in a disparate set of environments. For discussion of why this is a ref attribute, rather than an owning attribute, see MoMorphologicalData.PhoneEnvs. If this attribute is uninstantiated, there is no phonetic restriction on the environment.
test Refer | StemName | 3 | atomic | MoStemName
 | refers to a MoStemName. Ordinarily, only one allomorph of any given stem will bear a given stem name, but this may not be true if there are phonologically conditioned allomorphs as well. If this attribute is empty, this stem is used as the default stem for the paradigm.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoCompoundRuleApp:LeftForm | 1 | atomic | MoStemAllomorph
 | LeftForm: refers to a form (Wordform? MoStemAllomorph?), that of the left-hand member of the compound.
test Refer'd by | MoCompoundRuleApp:RightForm | 2 | atomic | MoStemAllomorph
 | RightForm: refers to a form (Wordform? MoStemAllomorph?), that of the right-hand member of the compound.
test Refer'd by | MoDeriv:StemForm | 1 | atomic | MoStemAllomorph
 | refers to an MoStemAllomorph, a stem found in the lexicon.


MoStemMsa

test num:1 | abbrev: smsa | abstract: false | module: Ling(num:5) | base: MoMorphSynAnalysis
 | This class is for stems or roots. It is also used in MoBinaryCompoundRules to specify the morphosyntactic properties required of the daughters, and by MoExocentricCompound to specify the morphosyntactic properties of its output.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | FromPartsOfSpeech | 7 | collection | PartOfSpeech
The FromPartsOfSpeech lists the categories (POSes) of words that this clitic may attach to. It can delimit a subset of categories if need be or it can be empty.
test Refer | InflectionClass | 3 | atomic | MoInflClass
refers to an MoInflectionClass (i.e. a conjugation or declension class). If none is listed, PartOfSpeech.vDefaultInflectionClass is used. If there is no vDefaultInflectionClass, then there are presumably no inflection classes (since the default value for vDefaultInflectionClass is the first inflection class of the paradigm). The assumption here is that inflection class membership is essentially an arbitrary label, i.e. that the inflection class membership of a stem cannot and should not be defined by a set of stem allomorphs or lists of 'principal parts' (see discussion in Carstairs-McCarthy 1998b: 332-334).
test Refer | PartOfSpeech | 2 | atomic | PartOfSpeech
Most users will be more familiar with the notion of PartOfSpeech or morphosyntactic category than the notion of the object MorphoSyntacticInformation. This attribute, PartOfSpeech, stores the reference to the PartOfSpeech.
test Refer | ProdRestrict | 6 | collection | CmPossibility
Refers to a collection of CmPossibility, giving any exceptional properties of the stem that relate to restricting the productivity of affixes. (Other terms for this are 'exception features,' 'rule features' and 'ad hoc features'.) Usually these represent restrictions which are shared among a set of more than two morphemes (unlike AMPLE's 'ad hoc pairs', which concern a pair of morphemes). An example from English is the feature [+Latinate], marking that part of the English vocabulary which is etymologically derived from Latin, and which has certain synchronic properties. For example, the suffix -ity attaches only to [+Latinate] stems (Aronoff 1976: 51): felicity, vivacity, *widity, *strongity The similar suffix -ness, on the other hand, attaches to more or less all adjectives regardless of this feature. Similar restrictions are apparently found in other languages which have undergone substantial borrowing, e.g. Mohawk and Dutch are said to have restrictions which depend on whether or not stems were borrowed from French. Maybe there are other sources of such restrictions as well. These restrictions cannot be handled by inflection classes. The reason is that inflection classes and exception features are likely to be cross-cutting distinctions. Another sort of restriction for which exception features have sometimes been used, is for certain restricted (morpho-)phonological alternations, such as the Velar Softening rule of English (Chomsky and Halle 1968; Aronoff 1976: 51). However, this use is sometimes complicated by restrictions on adjacency, which cannot be easily modeled. An apparent alternative to exception features would be morphosyntactic features. However, exception features are (by definition) invisible to the syntax, and the use of morphosyntactic features for this purpose could incorrectly prevent unification of features in syntax, e.g. if we build an NP consisting of a [+Latinate] noun and an [-Latinate] determiner. See also MoDerivationalAffixMsa.FromProductivityRestrictions. Do exception features percolate? There is some inconclusive discussion of this in Aronoff 1976: 52. Note that the answer to this will not directly affect the domain model, only the parser and generator (unless we decide to leave it up to the user, and put a toggle somewhere). See also note under MoDerivationalAffixMsa. Changed from ProductivityRestrictions.
test Refer | Stratum | 5 | atomic | MoStratum
refers to the MoStratum to which this MoMorphoSyntaxAnalysis object belongs. In an earlier version of this document, this attr belonged to MoForm. But that implied that one allomorph might belong to one stratum, and another allomorph to another stratum, which seems wrong. It is here, rather than on the superclass, because MoInflectionalAffixMsas do not need to "know" their stratum (their stratum is specified by the MoInflAffixTemplate in which they appear). (The other subclass of MoMorphoSyntaxAnalysis which has this attr is MoDerivationalAffixMsa.)
test Owning | MsFeatures | 1 | atomic | FsFeatStruc
gives any morphosyntactic features belonging to the stem in addition to those specified by PartOfSpeech.InherentFeatureValues. In most cases, there will be none, but this attribute may be useful for exceptional words (such as the pluralia tantum words pants and scissors, which are grammatically plural even though the default for English nouns is singular). The features are restricted to those in vAllPossibleFeatures of my PartOfSpeech.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoBinaryCompoundRule:LeftMsa | 1 | atomic | MoStemMsa
 | owns an MoStemMsa, giving the morphosyntactic information about the left-hand member of this compound. If this MoStemMsa specifies a PartOfSpeech, then the left-hand member of this compound must belong to that part of speech. If this MoStemMsa specifies an FsFeatStruc, then the left-hand member of this compound must have (not unify with!) the features of that feature structure. Since the parts of speech are contained in an inheritance hierarchy, a question arises: if this MSA points to an abstract part of speech (verb, say), does a word with a more specific part of speech (transitive verb, say) match? In the absence of any reason to think it does not, I would suggest that reference to an abstract part of speech entails that more specific parts of speech are included. Otherwise, it is hard to imagine how one could use this attribute - it would be necessary to allow a collection of parts of speech, or else to have separate compound rule for each specific part of speech.
test Owned by | MoEndoCompound:OverridingMsa | 2 | atomic | MoStemMsa
 | Any attribute specified in this msa will override the corresponding attribute of the head msa of the compound.
test Owned by | MoBinaryCompoundRule:RightMsa | 2 | atomic | MoStemMsa
 | owns an MoStemMsa, giving the morphosyntactic information about the right-hand member of this compound, in the same fashion as the LeftMsa attribute.
test Refer'd by | MoDeriv:StemMsa | 2 | atomic | MoStemMsa
 | refers to an MoStemMsa, a stem found in the lexicon. Note that this object and the allomorph pointed to by the StemForm must belong to the same LexEntry.
test Owned by | MoExoCompound:ToMsa | 1 | atomic | MoStemMsa
 | owns an MoStemMsa, giving the morphosyntactic information about the output of this compound. (Since the morphosyntactic properties of the daughters cannot be inherited in an exocentric compound, there is no question here of conflicts between the properties specified in this attribute and the properties of the daughters.) There is no provision for choosing a part of speech based on the argument properties of either element of the compound.


MoStemName

test num:47 abbrev: snam abstract: false module: Ling(num:5) base: CmObject
This represents one of the various inflectional stems used in a paradigm, other than the default stem. The assumption is that the stems with this stem name cannot be derived by a reasonable phonological rule (or at least that such a rule has not been written yet), and that the stem cannot be treated as an allomorph whose appearance is predictable by its phonological environment. Part of the stealth-to-wealth process consists of replacing such stems where possible with phonologically predictable allomorphs that do not have a particular stem name &#xA; &#xD; Additional Notes about PARADIGMS:&br This describes the various classes in the Morphology model that have to do with paradigms. The term'paradigm&apos here refers to the linguistic concept, not a sort of application for working with N-dimensional tables. (Bruce Waters has worked on the latter, and certainly table handling functionality will be necessary to work with linguistic paradigms.) The assumption here is that for some languages, paradigms will be a useful way of exploring the morphology. There is no class called /'Paradigm\'. Paradigms are instead treated as a sort of virtual attribute (see MoStemMsa.vParadigm). This is not intended to be a theoretical stand; some theories of morphology assign a fundamental status to paradigms (Carstairs 1987, Stump 1993a, 1993b), while others do not (Lieber 1992, Halle and Marantz 1993). The conceptual model defined in this document is intended to be compatible with both views.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Abbreviation | 1 | MultiUnicode |
 | a multiUnicode string, storing an abbreviated form of the Name. Probably useful for displays. Probably defaults to the first eight or so chars of the Name &#xA &#xD Another test.
test Basic | Description | 2 | MultiString |
 | multilingual string, containing the user' s description/ explanation of this stem (e.g. how it might be replaced by a suitable phonologically-based allomorphy condition, or why it cannot be so replaced).&#xA; Another test.&#xD; Another test.
test Basic | Name | 3 | MultiUnicode |
 | multiUnicode string; a convenient name, such as &apos 3-stem&apos (in Latin, cf. Aronoff 1992)

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | DefaultAffix | 6 | atomic | MoInflAffMsa
refers to an inflectional affix (MoInflectionalAffixMsa) that is attached to the stem selected by the DefaultStem to give this stem, if the stem's lexical entry does not have an MoStemAllomorph with this stem name. If this attribute is empty, the default shape of this kind of stem is the same as that of the default stem; effectively, the stem is then formed by null affixation. The situation in which this attribute is empty is common in languages where some lexemes have a suppletive stem, but where the majority of lexemes use a regular stem without any special affixation. In Spanish, for instance, some verbs have an irregular stem used in the first person singular present indicative and in the present subjunctive, but for most verbs, the stem used in these regions of the paradigm is the same as that used elsewhere. Note that in the course of doing S2W morphology, the user might initially assign Spanish stem-changing and non-stem-changing verbs to different paradigms. Later, noticing that the only difference between the two paradigms is the stem change, he could collapse the two paradigms (as advocated in Carstairs 1987, chapter 6), retaining the special '1s present indicative/present subjunctive' form for the irregular verbs, and leaving the '1s present indicative/present subjunctive' form empty for regular verbs. While it would be nice to limit the possibilities for this attr to less than all the affixes in the lexical database, it is not clear that there is any way to do so.
test Refer | DefaultStem | 7 | atomic | MoStemName
refers to another MoStemName, which specifies the stem to be used (in conjunction with the DefaultAffix, if the latter is specified) if the stem's lexical entry does not list an MoStemAllomorph with this stem name. That is, if a lexeme does not have an irregular (listed) stem, this attribute specifies that some more regular stem will be used, either as a base (if there is a DefaultAffix) or by itself (if there is no DefaultAffix). If no DefaultStem is specified, then for any lexeme which does not explicitly list an (irregular) MoStemAllomorph with this stem name, the base for this MoStemName has the same form as the lexeme's (MoStemMsa's) DefaultStems. (The DefaultStems attr is a seq, allowing for phonological selection of one among several default stems; most often, the seq will contain a single stem.) Thus a regular stem for a given stem is constructed from the DefaultStem of that lexeme as specified by this MoStemName plus the DefaultAffix given by this MoStemName. This covers the common situation in which a relatively small subset of the words of a given paradigm have irregular forms, while the others have a stem based on the default stem with or without a stem-forming affix. Note that we can get into an infinite loop here, if any MoStemName calls for itself or (more likely) another MoStemName which (recursively) calls for the first MoStemName. This of course constitutes an error; fortunately, it should be easy to detect this situation. The possibilities for this attr are the StemNames of the PartOfSpeech which owns this MoStemName (not including this MoStemName).
test Owning | Regions | 4 | collection | FsFeatStruc
owns a collection of FsFeatStrucs. Conceptually, this is analogous to MoInflectionalAffixMsa.InflectionalFeatures, defining the parts of the paradigm that use this stem. However, unlike an inflectional affix, it is possible for a stem to have more than one FsFeatStruc and therefore pertain to more than one contiguous region of a paradigm, i.e. a stem need have no particular (or at least no consistent) semantics over and above the semantics of the lexeme it belongs to. (Again, see Aronoff 1992.) An example is the '1sg/subj' stem which for many Spanish verbs is used for the past subjunctive and the 1sg present indicative, such as teng- 'have'. In addition to being relevant to one or more regions of a paradigm, a stem may be relevant to derivational morphology. This is indicated in the model by referencing the MoStemName from the MoDerivationalAffixMsa.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoStemName:DefaultStem | 7 | atomic | MoStemName
refers to another MoStemName, which specifies the stem to be used (in conjunction with the DefaultAffix, if the latter is specified) if the stem's lexical entry does not list an MoStemAllomorph with this stem name. That is, if a lexeme does not have an irregular (listed) stem, this attribute specifies that some more regular stem will be used, either as a base (if there is a DefaultAffix) or by itself (if there is no DefaultAffix). If no DefaultStem is specified, then for any lexeme which does not explicitly list an (irregular) MoStemAllomorph with this stem name, the base for this MoStemName has the same form as the lexeme's (MoStemMsa's) DefaultStems. (The DefaultStems attr is a seq, allowing for phonological selection of one among several default stems; most often, the seq will contain a single stem.) Thus a regular stem for a given stem is constructed from the DefaultStem of that lexeme as specified by this MoStemName plus the DefaultAffix given by this MoStemName. This covers the common situation in which a relatively small subset of the words of a given paradigm have irregular forms, while the others have a stem based on the default stem with or without a stem-forming affix. Note that we can get into an infinite loop here, if any MoStemName calls for itself or (more likely) another MoStemName which (recursively) calls for the first MoStemName. This of course constitutes an error; fortunately, it should be easy to detect this situation. The possibilities for this attr are the StemNames of the PartOfSpeech which owns this MoStemName (not including this MoStemName).
test Refer'd by | MoDerivAffMsa:FromStemName | 10 | atomic | MoStemName
FromStemName: refers to an MoStemName, telling the stem to which this affix attaches. If this attr is empty, this affix attaches to the default stem of an MoStemMsa, as given by the vDefaultStems attr. (The vDefaultStems attr is a seq attr, to allow for a choice based on phonological constraints; in the absence of phonologically conditioned stem selection, there should be only one default stem.)
test Refer'd by | MoStemAllomorph:StemName | 3 | atomic | MoStemName
refers to a MoStemName. Ordinarily, only one allomorph of any given stem will bear a given stem name, but this may not be true if there are phonologically conditioned allomorphs as well. If this attribute is empty, this stem is used as the default stem for the paradigm.
test Owned by | PartOfSpeech:StemNames | 7 | collection | MoStemName
owns a collection seq of MoStemNames, which define any non-default inflectional stems of the category (but not the default stem). For example, Aronoff (1992) discusses what he calls the '3-stem' of Latin verbs, a form which exists in all verb conjugations, and which is used as the base in a variety of places of the paradigm (which places are not identifiable on semantic or other grounds without using 'or'). The MoStemNames are interpreted as a disjunctively ordered list, i.e. in selecting a Stem for a given word, the list of StemNames is searched linearly, stopping at the first one for which one of its cells unifies with the FsFeatStruc of the word to be derived (see Choosing a Stem Allomorph). The order of the MoStemNames in this attribute is therefore important.If this attribute is empty, it defaults to the value of the same attribute in its owner. This allows e.g. defining a set of stem names for all verbs, and inheriting those names for subcategories of verb. It should probably be possible to block such inheritance without specifying any stem names, so there needs to be some specified value for that ('nil', say). An example might be modal verbs in English, which are presumably a subclass of verbs, but which lack certain forms.
test Owned by | MoInflClass:StemNames | 6 | collection | MoStemName
owns a collection of MoStemNames, which define any non-default inflectional stems of the inflection class (but not the default stem) in addition to those found in the PartOfSpeech. The MoStemNames are interpreted as a disjunctively ordered list, i.e. in selecting a Stem for a given word, the list of StemNames is searched linearly, stopping at the first one for which one of its cells unifies with the FsFeatStruc of the word to be derived (see Choosing a Stem Allomorph). The order of the MoStemNames in this attribute is therefore important. If this attribute is empty, it defaults to the value of the same attribute in its owner. This allows e.g. defining a set of stem names for all verbs, and inheriting those names for all inflection classes of verb (as well as for all subcategories of verb). It should probably be possible to block such inheritance without specifying any stem names, so there needs to be some specified value for that ('nil', say).


MoStratum

test num:48 abbrev: stra abstract: false module: Ling(num:5) base: CmObject
Strata are a concept borrowed from the theory of Lexical Phonology (see e.g. Kaisse and Shaw 1985); the term " level" is sometimes used synonymously. A given affix belongs to a single stratum; typically, a given phonological rule applies in a single stratum as well, but it is possible for a phonological rule to apply in a contiguous sequence of strata. The assumption that there can be a contiguous sequence of strata of course presupposes that the strata are arranged in a fixed linear order. Most versions of Lexical Phonology indeed made this assumption, but it was abandoned in some later versions (e.g. Inkelas and Orgun 1998). Inasmuch as phonological rules have not been defined yet for purposes of this application, the use of strata may seem superfluous. However, strata still may be useful for languages in which some derivational affixes appear outside of some inflectional affixes. That is, there would be a 'deeper' stratum for the inner inflectional affixes, and a shallower stratum for the derivational affixes in question, as well as for the outer inflectional affixes. The conceptual model makes no attempt to build in any universal or common properties of strata, or of their ordering. For example, it has been observed that for a number of languages, all derivational rules seem to precede all compounding rules (Scalise 1986: 115-122). This observation is not built in to the model, although it would be possible to ship a " starter" setup having this behavior.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Abbreviation | 1 | MultiUnicode |
 | stores an abbreviated form of the Name. Probably useful for displays. Probably defaults to the first eight or so chars of the Name.
test Basic | Description | 2 | MultiString |
 | For the user's description/explanation of this stratum.
test Basic | Name | 3 | MultiUnicode |
 | Not used in any algorithms, but people like to name things...

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Phonemes | 4 | atomic | PhPhonemeSet
 | refers to a PhPhonemeSet which provides the phonemes and boundary markers relevant to this stratum. In Hermit Crab, there were two attributes similar to this on strata: an InputLevelOfRepresentation, and an OutputLevelOfRepresentation. It was not clear that this bought anything that having different levels of representation in successive strata would not have bought.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | PhSegmentRule:FinalStratum | 5 | atomic | MoStratum
The final stratum to which this rule applies.
test Refer'd by | PhSegmentRule:InitialStratum | 4 | atomic | MoStratum
The initial stratum to which this rule applies. If not specified, this rule applies to all strata.
test Owned by | MoMorphData:Strata | 1 | sequence | MoStratum
owns a col of MoStratum objects, in order from shallowest to deepest.
test Refer'd by | MoCompoundRule:Stratum | 7 | atomic | MoStratum
refers to an MoStratum, giving the stratum to which this rule belongs. The assumption behind the fact that this is an atomic attribute, is that a given compound rule (i.e. type of compound) can belong to only one stratum. If compounding happens in more than one stratum, then there must be more than one compounding rule. See also the discussion of MoStratum.vCompoundRules..
test Refer'd by | MoDerivAffMsa:Stratum | 12 | atomic | MoStratum
Stratum: refers to the MoStratum to which this MoMorphoSyntaxAnalysis object belongs. In an earlier version of this document, this attr belonged to MoForm. But that implied that one allomorph might belong to one stratum, and another allomorph to another stratum, which seems wrong. It is here, rather than on the superclass, because MoInflectionalAffixMsas do not need to "know" their stratum (their stratum is specified by the MoInflAffixTemplate in which they appear). (The other subclass of MoMorphoSyntaxAnalysis which has this attr is MoStemMsa.)
test Refer'd by | MoStemMsa:Stratum | 5 | atomic | MoStratum
refers to the MoStratum to which this MoMorphoSyntaxAnalysis object belongs. In an earlier version of this document, this attr belonged to MoForm. But that implied that one allomorph might belong to one stratum, and another allomorph to another stratum, which seems wrong. It is here, rather than on the superclass, because MoInflectionalAffixMsas do not need to "know" their stratum (their stratum is specified by the MoInflAffixTemplate in which they appear). (The other subclass of MoMorphoSyntaxAnalysis which has this attr is MoDerivationalAffixMsa.)
test Refer'd by | MoStratumApp:Stratum | 1 | atomic | MoStratum
refers to the MoStratum whose application this trace structure represents.
test Refer'd by | MoInflAffixTemplate:Stratum | 4 | atomic | MoStratum
refers to the MoStratum to which this MoInflAffixTemplate belongs. Normally that would be the final stratum (or at least to the final stratum in which morphology takes place; if one is modeling post-lexical phonology, that would usually be in a stratum after the inflectional morphology). However, in languages where some derivational affixes attach outside of (some) inflection, that derivational morphology (and any subsequent inflectional morphology) will be in a stratum outside of a stratum containing the inflectional affix template. This definition assumes there are no cycles, i.e. that one does not get the same kind of inflectional affixes both inside and outside of derivational affixes. That's not obviously correct, e.g. one might have [[[[Noun_root] noun_template ] verbalizer ] verb_template] and [[[[Verb_root] verb_template ] nominalizer ] noun_template] where the two instances of noun_template and of verb_template are the same. This would be a counterexample (or would require duplicating the templates in the two strata, obviously a sign that something is wrong with the analysis).


MoStratumApp

test num:78 | abbrev: strapp | abstract: false | module: Ling(num:5) | base: MoDerivTrace
 | This represents the application of a single stratum (rule block) to a stem, including affixation and/or phonological rules.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Stratum | 1 | atomic | MoStratum
 | refers to the MoStratum whose application this trace structure represents.
test Owning | CompoundRuleApps | 2 | sequence | MoCompoundRuleApp
 | owns an ordered seq of MoCompoundRuleApp, representing the application of compound rules belonging to this stratum. The order is the order of application in derivation (which may be the reverse of the order in parsing).
test Owning | DerivAffApp | 3 | sequence | MoDerivAffApp
 | Owns an ordered seq of MoDerivationalAffixApp, representing the attachment of derivational affixes belonging to this stratum. The order is the order of application in derivation (which may be the reverse of the order in parsing). Changed from DerivationalAffixApps.
test Owning | PRuleApps | 5 | sequence | MoPhonolRuleApp
 | owns an ordered seq of MoPhonolRuleApp, representing the application of the phonological rules of this stratum. Note that the fact that this attr belongs to the MoStratumApp precludes modeling cyclic application. That restriction could easily be lifted. The order is the order of application in derivation (which may be the reverse of the order in parsing).
test Owning | TemplateApp | 4 | atomic | MoInflTemplateApp
 | owns an MoInflAffixTemplateApp, representing the application of an MoInflAffixTemplate belonging to this stratum and matching the InflectionClass of the MoStemMsa at the point of application.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoDeriv:StratumApps | 4 | sequence | MoStratumApp
 | owns an ordered seq of MoStratumApp structures, representing the sequence of applications of strata (i.e. of the affixes and phonological rules of those strata) to an underlying form. The order is from the deepest stratum to the shallowest.


MoUnclassifiedAffixMsa

num:117 abbrev: uamsa abstract: false module: Ling(num:5) base: MoMorphSynAnalysis

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | PartOfSpeech | 1 | atomic | PartOfSpeech

Back references (sorted by attribute name)

Type Name Num Card Sig


Note

test num:3 | abbrev: nt | abstract: false | module: Cellar(num:0) | base: CmObject
 | Used for all manner of notes.

Direct Subclasses

  • Segment

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Content | 1 | MultiString-big |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | Segment:Notes | 4 | collection | Note
Owned by | Segment:Notes | 4 | sequence | Note


PartOfSpeech

test num:49 abbrev: pos abstract: false module: Ling(num:5) base: CmPossibility
This class represents an expansion of the LinguaLinks authority list of parts of speech. The attributes given below represent only those attributes which are more or less relevant to the morphology, e.g. there is nothing here (yet) about phrase structure rules that the category might head or be made of (the latter in the case of compounding, if at least some compounds are to be treated syntactically). Nor is there any discussion here about phrasal categories, i.e. I discuss only X0 categories.The categories are arranged in an inheritance hierarchy, using the provision for hierarchies built in to the superclass of this class, CmPossibility. Thus, the categories of transitive and intransitive verbs could be subcategories of the category verb, etc. This brings up an interesting question with respect to phrasal categories, where the subcategories do not head distinct kinds of phrasal categories. (That is, languages do not treat VPs headed by transitive verbs differently from VPs headed by intransitive verbs.) I will not discuss this issue yet.The owner of the root of the part of speech hierarchy needs to implement a few of these attributes as virtual attributes returning none in order to stop the recursion, e.g. vAllInherentFeatureValues and vAllAffixSlots.Under some theories (cf. Chomsky 1970), the use of an atomic category is superfluous, given that atomic categories are treated as abbreviations for sets of morphosyntactic feature values. Even if we were to follow this approach, though, it seems likely that atomic categories would be useful in the context of the stealth-to-wealth approach.Note that attributes for name (cpName), abbreviation (cpAbbreviation), and subcategories (cpSubPossibilities) are inherited from the superclass CmPossibility, and are therefore not described here.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | CatalogSourceId | 13 | Unicode |
 | This property is used to store a unique key string indicating the reference for the part of speech from the Gold (or some other) master list.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | BearableFeatures | 8 | collection | FsFeatDefn
refers to a collection seq of FsFeatureDefn, each of which is a morphosyntactic feature which a word of this part of speech can bear. This is primarily intended for features which may be important to the derivational morphology, although these features may also be relevant to inflectional morphology. For example, the English suffix -ess is added only to animate nouns: waitress, lioness, actress, but *tabless, *officess; ?ful attaches to abstract nouns: graceful, useful, helpful, but *personful, *buildingful, *actorful.The notion of features that a given part of speech can bear is generally implicit in works on morphology, but see Lieber 1992: 90-91.
test Refer | DefaultInflectionClass | 12 | atomic | MoInflClass
refers to one of the classes in vAllInflectionClasses; defaults to the first MoInflectionClasses in vAllInflectionClasses (which would be the first class defined for this part of speech; this choice makes sense, i.e. the default is likely to be the largest inflection class, not a subclass of some class.) According to Wurzel (as described in Carstairs-McCarthy 1998b), the default class is the Inflection Class to which newly coined lexemes are usually assigned, to which lexemes from other classes 'drift' in the process of historical change, and the class to which children tend to assign lexemes before they learn the correct class. For our purposes, however, it may be simpler just to think of the default class as being the largest class numerically, i.e. the class to which words in the lexical database are assigned as a first guess.
test Refer | InflectableFeats | 9 | collection | FsFeatDefn
refers to a collection seq of FsFeatureDefn, each of which is a morphosyntactic feature which a word of this part of speech is inflected for. Note that MoInflectionalAffixMsas may be sensitive to other features as well. Changed from InflectableFeatures
test Owning | AffixSlots | 6 | collection | MoInflAffixSlot
owns a collection seq of MoInflAffixSlot, which may be referred to in MoInflAffixTemplates.The reason for having the ownership of Affix Slots reside here, rather than their being owned by the Affix Templates themselves, is to allow different Affix Templates to share Affix Slots. For example, suppose that in some language, both subject and object agreement are marked on the verb, and that the user has accordingly specified distinct parts of speech (and therefore distinct paradigms) for transitive and intransitive verbs. In all likelihood, most of the slots will be alike (tense and aspect marking, etc., and perhaps the subject agreement slot). The common affix slots can be shared if they are owned by the super-category verb (see the attribute vAllAffixSlots, below). Similarly, in Tzeltal nouns use the same prefixes for marking possessors as transitive verbs use for marking subjects. Assuming appropriate morphosyntactic features could be devised to represent the person of possessors and subject-of-transitives in Tzeltal, it would be nice to use the same MoInflAffixSlot for both. But this would be impossible, if the Affix Slots were owned by the Affix Templates (since nouns and verbs do not in general share those templates). It becomes possible if the Affix Slots are owned at some point in the part of speech inheritance hierarchy above noun and (transitive) verb, and referred to by the Affix Templates for these two categories.
test Owning | AffixTemplates | 5 | sequence | MoInflAffixTemplate
owns an ordered seq of MoInflAffixTemplates, which define how affixation (but not choice of stems) works for this part of speech. The reason this is an ordered sequence attribute, rather than atomic, is to allow the user to capture the fact that the number of slots can be different for different parts of the paradigm (infinitives, for example, or tenses which are partly inflected on the main verb and partly on an auxiliary verb). The order of templates in this attribute is relevant: the first MoInflAffixTemplates whose Region attr is a subset of the inflectional features to be realized on the word, is chosen.Note the assumption here that all the words belonging to a single part of speech have fundamentally the same paradigm (and therefore the same set of affix templates), and that differences are accounted by membership in distinct MoInflectionClasses (Carstairs 1987: 10-11, Carstairs-McCarthy 1998b: 324). The fact that in languages which mark the verb for agreement with both subject and object, transitive verbs have different paradigms from intransitive verbs (transitives usually have an additional slot for object marking-or for subject marking, in the case of ergative languages), might seem to be a counterexample. The reason that is not a counterexample, is that transitive and intransitive verbs can be treated as separate parts of speech using the inheritance hierarchy.
test Owning | DefaultFeatures | 11 | atomic | FsFeatStruc
A feature structure which specifies features that should be assumed in the absence of any inflectional affixes for the features defined. Example: In English, nouns are by default singular [num:sg].
test Owning | EmptyParadigmCells | 2 | collection | FsFeatStruc
owns a collection seq of FsFeatStruc, indicating the cells (feature-value combinations) which are disallowed in the paradigm. This is intended to account for defective paradigms, which are not common (e.g. deponent verbs in Greek, which are verbs that have no active forms). Since defective paradigms are relatively rare, this will probably be a seldom-used attribute. It is not intended to account for syncretism in the paradigm, i.e. the situation where one cell 'uses' the affixes of another cell (for which MoReferralRules are supplied instead, should disjunctive ordering of the affixes in an MoInflAffixSlot not suffice.).Since this attribute is defined at the level of the part of speech, it is not possible to define cells which are empty in only one inflection class. It is not obvious that this is correct, e.g. it is not obvious that deponent verbs in Greek belonged to a separate part of speech from other verbs. Pluralia tantum words like scissors and trousers are another example, since it is not clear that they belong to a separate part of speech from other nouns. Yet another example of a set of words that cannot plausibly be assigned to a separate category comes from Russian. Halle (1973: 7-8) says there are about a hundred verbs, all in a particular conjugation class, which lack first person singular non-past forms. It is unclear what the status of this gap is; it may be semantically or pragmatically based (some of the glosses are 'I conquer', 'I talk rudely', 'I behave foolishly'). According to Halle, "Russian grammar books frequently note that such forms… 'do not exist', or 'are not used', or 'are avoided'." Perhaps this is more of a sociolinguistic issue. Jensen (1990: 117-119) discusses some other defective paradigms, although he admits that his Latin examples are suspect: the defective paradigm is based on the corpus of Latin literature, and it may be that the corpus, not the paradigm, is defective. Jensen also lists as examples a few French verbs which lack certain forms: "cloré ['to close, enclose']… lacks the passé simple and the first and second persons plural of the present. Gésir ['to lie'] lacks all tenses but the present and imperfect indicative, and lacks the first and second persons singular of the present." He notes that synonyms supply the missing forms, so these gaps probably cannot be explained on semantic or pragmatic grounds. Jensen also gives as examples English modal verbs, which lack participle and 'infinitive' (to V) forms. In this case, the customary solution is to create a separate part of speech (modals), as a subclass of the category Verb.There are at least two verbs in English with defective paradigms: sight-see (*sight-sees, *sight-saw, sight-seen-but sight-seeing), and beware (which occurs only in this base form. Another puzzle with respect to defective paradigms, is the fact that while the singular of pluralia tantum words is ungrammatical in isolation, they are found in compounds: scissor-handle and trouser-leg. It is not clear how a defective distribution of certain elements of the paradigm should be handled. Matthews (1972a: 197, fn. 2) suggests that defective paradigms be handled in the syntax, although it is unclear how this would work.
test Owning | InflectionClasses | 4 | collection | MoInflClass
owns a collection seq of MoInflectionClasses, each of which is an inflection class (conjugation or declension class) immediately owned by this part of speech. This does not include sub-inflection classes of those classes, for which see vAllSubInflectionClasses; nor does it include any inflection classes defined on more abstract parts of speech, for which see vAllSuperInflectionClasses. See also vAllInflectionClasses.
test Owning | InherFeatVal | 1 | atomic | FsFeatStruc
Owns a FsFeatStruc, representing (some of) the feature values inherently associated with this category (e.g. [+N +V]). Changed from InherentFeatureValues
test Owning | ReferenceForms | 10 | collection | FsFeatStruc
owns a collection seq of FsFeatStruc, each of which defines the cell whose inflection uniquely picks out an inflection class. (Cf. Carstairs-McCarthy 1991, particularly section 8). Usually, the reference forms belonging to a part of speech will suffice for all the MoInflectionClasses, i.e. a single "Primary Reference Form" (Carstairs-McCarthy's term). In some cases, however, it may prove necessary to provide a secondary reference form to distinguish among "mixed" classes (see again the discussion in Carstairs-McCarthy 1991.) Any secondary reference forms are provided in the attr of the same name of the particular MoInflectionClasses to which they pertain.Note that this attribute performs no particular function in any of the algorithms used for computing affixed forms. However, it may be useful in the context of a dictionary, e.g. for providing principal parts.
test Owning | RulesOfReferral | 3 | sequence | MoReferralRule
owns an ordered seq of MoReferralRule; used for statements like "the accusative plural of nouns is identical to the nominative plural" or "the accusative plural of second declension nouns is identical to the nominative plural'. (Note that rules of referral which are owned by the PartOfSpeech hold for all lexemes of that part of speech, regardless of inflection class; whereas rules of referral owned by an MoInflectionClass hold only for lexemes of that class. In Stump's (1993a) notation, the latter case corresponds to indicating a 'CLASS' for the Referral Rule.)I (MM) have defined this as an ordered seq, because in rare cases one referral rule might override another such rule. See the discussion of the similar RulesOfReferral attr in MoInflectionClass.
test Owning | StemNames | 7 | collection | MoStemName
owns a collection seq of MoStemNames, which define any non-default inflectional stems of the category (but not the default stem). For example, Aronoff (1992) discusses what he calls the '3-stem' of Latin verbs, a form which exists in all verb conjugations, and which is used as the base in a variety of places of the paradigm (which places are not identifiable on semantic or other grounds without using 'or'). The MoStemNames are interpreted as a disjunctively ordered list, i.e. in selecting a Stem for a given word, the list of StemNames is searched linearly, stopping at the first one for which one of its cells unifies with the FsFeatStruc of the word to be derived (see Choosing a Stem Allomorph). The order of the MoStemNames in this attribute is therefore important.If this attribute is empty, it defaults to the value of the same attribute in its owner. This allows e.g. defining a set of stem names for all verbs, and inheriting those names for subcategories of verb. It should probably be possible to block such inheritance without specifying any stem names, so there needs to be some specified value for that ('nil', say). An example might be modal verbs in English, which are presumably a subclass of verbs, but which lack certain forms.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | WfiAnalysis:Category | 3 | atomic | PartOfSpeech
test Refer'd by | MoDerivAffMsa:FromPartOfSpeech | 3 | atomic | PartOfSpeech
specifies the category of the stem to which this affix attaches. See comments above on the "Unitary Base Hypothesis." Note also that in AMPLE, it is possible to map a series of categories into another series of categories; that capability is not defined here. If the parts of speech list is hierarchical, the problem could be partially circumvented by specifying an abstract category in this attribute. However, that would not solve the problem of mapping the output category, because at best we could specify more than a single output category. Note that we do not (yet) have provision for subcategorization lists or argument structure. This means that some restrictions on the stem to which an affix would be attached cannot be handled elegantly. (They could be handled inelegantly, by creating an ad hoc feature for each subcategorization, e.g. [+ditransitive].) For example, the English suffix -able attaches only to transitive verbs (washable, *seemable); the English suffix -ee attaches only to verbs which allow animate objects or indirect objects (addressee, *tearee) (examples from Scalise 1986: 45). Nor do we treat semantic restrictions on the base to which the affix attaches. For example, it has been proposed that the English prefix re- attaches only to verbs whose meaning entails a change of state (John repunched the holes in the paper, *John repunched Bill in the face) (Aronoff 1976: 47, observation attributed to an unpublished paper of Williams).
test Refer'd by | MoStemMsa:FromPartsOfSpeech | 7 | collection | PartOfSpeech
The FromPartsOfSpeech lists the categories (POSes) of words that this clitic may attach to. It can delimit a subset of categories if need be or it can be empty.
test Refer'd by | PhSegRuleRHS:InputPOSes | 4 | collection | PartOfSpeech
When present, this limits the rule application to apply only when the input is for one of the Parts of Speech given in the collection. The hierarchical nature of Parts of Speech is respected, so if "transitive verb" is a sub-category of "verb" and one specifies "verb" as an input POS, then the rule will also apply to "transitive verb.
test Refer'd by | MoAffixAllomorph:MsEnvPartOfSpeech | 4 | atomic | PartOfSpeech
refers to a PartOfSpeech, defining the morphosyntactic features which the stem to which this affix attaches must bear. Together with the MsEnvFeatures attribute (below), this attribute defines the morphosyntactic context in which this allomorph must appear. However, there are linguistic reasons for thinking that allomorphs should not in fact be able to specify morphosyntactic requirements on their environment. That is, there are often (always?) better analyses of allomorphy which do not rely on the morphosyntactic properties of the stem (see e.g. Matthews' 1972b reanalysis of Huave). The attribute is there because AMPLE provides that power (although AMPLE allows the user to test the morphosyntactic properties of arbitrary morphemes to the left or right, while the intention here is that an allomorph can only test the morphosyntactic properties of the stem to which it attaches). Since the parts of speech are contained in an inheritance hierarchy, a question arises: if this attr points to an abstract part of speech (verb, say), does a stem with a more specific part of speech (transitive verb, say) match? In the absence of any reason to think it does not, I would suggest that reference to an abstract part of speech entails that more specific parts of speech are included. Otherwise, it is hard to imagine how one could use this attribute-it would be necessary to allow a seq, or else to have separate but homophonous allomorphs for each specific part of speech. It is not clear what should be done if there are conflicts between the morphosyntactic requirements imposed by this attribute, and those imposed by the affix owning this allomorph. Such conflicts "should" not arise (since allomorphs shouldn't have special morphosyntactic requirements of their own, as argued in the previous paragraph). While it would be fairly simple to ensure that conflicts do not arise between stated morphosyntactic properties, there is the potential for implicit conflicts (e.g. the affix calls for attachment to a noun, while the allomorph requires that the stem have a certain feature value for subject agreement-something which nouns presumably do not mark).
Refer'd by | ReversalIndexEntry:PartOfSpeech | 3 | atomic | PartOfSpeech
test Refer'd by | MoStemMsa:PartOfSpeech | 2 | atomic | PartOfSpeech
Most users will be more familiar with the notion of PartOfSpeech or morphosyntactic category than the notion of the object MorphoSyntacticInformation. This attribute, PartOfSpeech, stores the reference to the PartOfSpeech.
test Refer'd by | MoDerivStepMsa:PartOfSpeech | 1 | atomic | PartOfSpeech
refers to a PartOfSpeech, telling the category of the word.
Refer'd by | MoUnclassifiedAffixMsa:PartOfSpeech | 1 | atomic | PartOfSpeech
Refer'd by | MoInflAffMsa:PartOfSpeech | 5 | atomic | PartOfSpeech
test Refer'd by | MoDerivAffMsa:ToPartOfSpeech | 4 | atomic | PartOfSpeech
specifes the category(PartOfSpeech) of the word resulting from the attachment of this affix. Note that as with the FromPartOfSpeech, we do not (yet) cover subcategorization lists or argument structure here. Thus, we cannot handle subcategorization-changing affixes, such as causatives, by changing a subcategorization list, only by changing category or morphosyntactic features. Likewise, we cannot handle the change in argument structure that accompanies some category-changing affixes. For example, when the prefix en- verbalizes an adjective, the argument of which the adjective was predicated becomes the direct object of the verb (The picture is large - to enlarge the picture; example from Scalise 1986: 28).


PhBdryMarker

test num:91 | abbrev: bdrymrkr | abstract: false | module: Ling(num:5) | base: PhTerminalUnit
 | This represents a boundary marker, e.g. a morpheme boundary or a word boundary.There is no requirement that the user define any boundary markers.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PhPhonemeSet:BoundaryMarkers | 3 | collection | PhBdryMarker
 | collection seq of PhBdryMarker
Refer'd by | PhSimpleContextBdry:FeatureStructure | 1 | atomic | PhBdryMarker


PhCode

test num:98 | abbrev: phme | abstract: false | module: Ling(num:5) | base: CmObject
 | a representation of the phoneme or boundary marker in a particular encoding. eg. in English, the phoneme /f/ has the Codes: ph, f and gh.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Representation | 1 | MultiUnicode |
 | Put something here.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PhTerminalUnit:Codes | 3 | sequence | PhCode
 | a collection of PhCodes (which amounts to a seq of strings), each in a single encoding (but not perhaps all in the same encoding). Each string is a representation of the phoneme or boundary marker in that encoding.


PhContextOrVar

test num:80 | abbrev: conorvar | abstract: true | module: Ling(num:5) | base: CmObject
 | Under Cellar1, this would be an OrSignature. Since Cellar2 lacks OrSignatures, this is instead a superclass for phonetic contexts and variables. (Morphological rules of the type advocated e.g. by Aronoff (1976) require both, in order to match both a specific part of a stem and the remainder of the stem; phonological rules of the SPE type only require phonetic contexts.)

Direct Subclasses

  • PhPhonContext
  • PhVariable

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoCopyFromInput:Content | 1 | atomic | PhContextOrVar
 | refers to a PhContextOrVar in MoAffixProcess.Input of the owner of this object; the meaning is that the stretch of the input word matched by that PhContextOrVar is copied over without alteration to the output.
test Refer'd by | MoModifyFromInput:Content | 1 | atomic | PhContextOrVar
 | refers to a PhContextOrVar from the input of the MoAffixProcess owning this object; the meaning is that the stretch of the input word matched by that PhContextOrVar is copied over to the output, but modified in accordance with the modification attribute. Typically, this will be a single phoneme, which is modified by the addition of one or two features (e.g. by being palatalized).
test Owned by | PhPhonData:Contexts | 4 | sequence | PhContextOrVar
 | Change this here.
test Owned by | MoAffixProcess:Input | 2 | sequence | PhContextOrVar
 | Owns an ordered seq of PhContextOrVar, describing the form of the stem to which the affix attaches. The left-to-right order of the PhContextOrVars in this attribute corresponds to the order of the portions of the input word which match. (N.B.: There could be ambiguity, for instance if the input had two adjacent PhVariables. The system should check for this, and warn the user.) Given that PhContextOrVar can itself own an PhSequenceContext, the use of a seq attribute here may seem like overkill. However, it is only the topmost members of this Input attribute that can be numbered (the numbering is part of the user interface, and allows the user to point back to particular pieces of the input for the output). Perhaps this numbering can be done differently, in which case the Input attribute won't need to be seq.


PhEnvironment

test num:97 | abbrev: phen | abstract: false | module: Ling(num:5) | base: CmObject
 | This represents a pairing of left and right contexts for an allomorph or a phonological rule. Any given allomorph or rule can have a sequence of such pairings, although in general the goal of the analysis will be to reduce the number of pairs to one.PhEnvironment objects are owned in the PhPhonologicalData object., and referred to by the PhoneEnv attr of MoForms (allomorphs) and by the (to-be-designed) phonological rules.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | AMPLEStringSegment | 6 | Unicode |
 | This is for storing AMPLE and Shoebox (converted to AMPLE) info about phonetic environments. This will probably be eventually deleted when we decide what to do with Shoebox/AMPLE import and relationship to the LexEntry legacy information.
Basic | Description | 2 | MultiString |
Basic | Name | 1 | MultiUnicode |
test Basic | StringRepresentation | 8 | String |
 | This simple string representation of the phonetic environment is parsed by specialized field editor for use by AMPLE. For Phase 1 implementation. Phase 2 will use Left and Right contexts.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | LeftContext | 4 | atomic | PhPhonContext
Refer | RightContext | 5 | atomic | PhPhonContext

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | PhPhonData:Environments | 2 | sequence | PhEnvironment
test Refer'd by | MoStemAllomorph:PhoneEnv | 2 | collection | PhEnvironment
refers to a collection of PhEnvironment objects, describing what the phonetic environment of this allomorph is. The reason this is a collection attr (rather than atomic) is to allow for the situation during analysis before the user has managed to collapse what appear to be disparate environments into a single environment. (Note that the 'elsewhere' case can be represented by an empty environment under the assumption of disjunctive ordering.) Hence, a step in the stealth-to-wealth process will be to reduce the cardinality of this collection to one. A collection may of course also be useful for allomorphs which actually does appear in a disparate set of environments. For discussion of why this is a ref attribute, rather than an owning attribute, see MoMorphologicalData.PhoneEnvs. If this attribute is uninstantiated, there is no phonetic restriction on the environment.
test Refer'd by | MoAffixAllomorph:PhoneEnv | 2 | collection | PhEnvironment
refers to a collection of PhEnvironment objects, describing what the phonetic environment of this allomorph is. The use of the term 'phonetic' is not intended to distinguish this from a phonological context, merely to say that the context is described in terms of its phonetic properties, not its morphosyntactic properties or lexically marked exception properties. If this attribute is uninstantiated, there is no phonetic restriction on the environment. The reason this is a collection attr (rather than atomic) is to allow for the situation during analysis before the user has managed to collapse what appear to be disparate environments into a single environment. (Note that the 'elsewhere' case can be represented by an empty environment under the assumption of disjunctive ordering.) Hence, a step in the stealth-to-wealth process will be to reduce the cardinality of this collection to one. A collection may of course also be useful for allomorphs which actually does appear in a disparate set of environments. For the reason why this is a ref attribute, rather than an owning attribute, see the discussion of MoMorphologicalData.PhoneEnvs. An important assumption here is that the phonetic environment to which this allomorph refers is the derived phonological environment. In the absence of phonological rules, this means that the phonetic environment refers to the allomorph(s) to its left, not to some base form of the morphemes. (If we later implement phonological rules, this implies we implement cyclic phonological processes.) The effect of iterative application of phonological rules would not be possible under this approach, although most cases might fall out from the step-wise attachment of affixes, which more or less amounts to cyclic rule application (without rules). Alternatively, we could allow reference to either (or both) the underlying and derived environments (which would in turn imply that every morpheme would need to have an underlying form); this would be similar to two-level phonology.
test Refer'd by | MoAffixAllomorph:Position | 5 | sequence | PhEnvironment
refers to an ordered seq of PhEnvironment, encoding the position relative to the stem in which this allomorph goes (for example, before the stem, after the stem, or between the first two consonants of the stem). A default value for this attr should be provided for prefixes and suffixes, based on MoForm.MorphType. For a prefix, this would be __#X (where X represents the entire stem), and for a suffix, X#__. This attr need not be displayed for prefixes and suffixes. Note that it would not be possible to simplify the model by eliminating this attr, and letting the position of infixation be determined by the phonological environment of the allomorph(s). The reason this can't be done is that what is important for purposes of allomorphy vs. what is important for positioning the infix, are two different things. The reason for having this attr as a property of the allomorph, rather than of the MSA, is that this allows us to distinguish two different allomorphs which differ as to whether they are infixed or not. For example, there is a Tagalog affix whose infixed form is -in-, and whose prefixed form is ?in- (although the word-initial glottal happens not to be written orthographically). An alternative to having this attr on MoAffixAllomorph would be to add a subclass of this class for infixes (as well as suprafixes and other sorts of affixes that must appear in a particular position, other than before or after the stem). This new subclass would then have the extra attribute for position. One disadvantage of having such a subclass, is that it would be the only subclass of MoAffixAllomorph, whereas in fact all specific types of affixes (prefixes, suffixes, infixes,...) are sub-types. Having a default value of this attr for prefixes and suffixes adequately characterizes the difference between prefixes and suffixes on the one hand, and infixes on the other. The attr is a seq (as opposed to atomic) to account for affixes whose position relative to the stem is determined by the phonology of the stem. For example, in Tagalog the in affix occurs after the first consonant of a C-initial stem, or (prefixed) before a vowel-initial stem. (Note that this implies that an affix may not be purely a prefix or infix, contrary to the implication of the MorphType attr. The alternative is to require the user to treat such an affix as having two allomorphs, one a prefix and one an infix; but this would seem to be an unnecessary burden for the user.) The attr is an ordered seq (as opposed to a collection) in order to allow disjunctive ordering. Taking the example given above, disjunctive ordering would require the following environments, stored in an ordered seq: #C__, #__ Nondisjunctive ordering would require the following environments (which could be stored in a collection): #C__, #__V Using an ordered seq does not force the parser/ generator to use the ordering, but allows for parsers which do use the order (such as Hermit Crab).


PhFeatureConstraint

test num:96 abbrev: ftconstr abstract: false module: Ling(num:5) base: CmObject
This class appears here for purposes of future development; it is not intended to be implemented immediately. It will serve for constraints requiring agreement or disagreement with respect to a single feature or a set of features all dominated by a single nonterminal node (e.g. the set of features under a 'place' node), and for rules of assimilation and dissimilation. It resembles the use of alpha variables in SPE, and the use of linking conventions in autosegmental phonology.In the SPE convention, the features within a given rule which are meant to agree or disagree are labeled consecutively with Greek letters (with the letters being preceded by a minus sign for disagreement). This requires some mechanism in the rule itself for labeling constraints; the labels would appear as part of the PhFeatureConstraints, but would not actually represent an attribute of the constraints. In autosegmental phonology, (positive) PhFeatureConstraints within a rule are joined by a line (and must obey certain adjacency constraints). Negative constraints as such do not exist in autosegmental phonology; dissimilation is instead seen as the result of unlinking, followed by the insertion of a default feature value.This class may be more generally useful, e.g. for person/number agreement in syntax. In that case, this class should probably be defined in the Feature System model, rather than here.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Feature | 1 | atomic | FsFeatDefn
 | refers to an FsFeatureDefnPhFeatureNode, the feature with respect to which the constraint ensures agreement (or disagreement).The use of an atomic attr, rather than a seq attr, emulates to a certain extent the insight of autosegmental phonology and feature geometry that a rule can change (or refer to in the environment) only a single feature node. Note however that the fact that the feature can be a nonterminal feature (an FsComplexFeature), allows agreement with respect to a number of features dominated by a single node (e.g. a place of articulation feature, which might dominate the features labial, coronal, and back).

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PhPhonData:FeatConstraints | 5 | sequence | PhFeatureConstraint
The feature constraints are what allow us to use alpha notation in phonological rules (to deal with things like assimilation to place of articulation). It is a sequence so we can know the alpha value (is it alpha, beta, gamma, or delta, say). The user need never see these as a list to be edited or maintained by hand. The UI can show them as greek letters in phonological rule displays.
test Refer'd by | PhSimpleContextNC:MinusConstr | 3 | sequence | PhFeatureConstraint
refers to a collection seq of PhFeatureConstraints; see discussion under the plusConstraints attr. A feature in question is required to have opposite value from a plusConstraint elsewhere in the rule, and thus makes sense only if a constraint with the same value appears elsewhere in the rule.See implementation comments under plusConstraints. Changed from MinusConstraints for the Firebird Port.
test Refer'd by | PhSimpleContextNC:PlusConstr | 2 | sequence | PhFeatureConstraint
Refers to a collection seq of PhFeatureConstraint. The use of a plusConstraint only makes sense if there are two or more contexts in a rule that make use of the same constraint. If two such constraints occur in the environment of the rule (treating the input as part of the environment), then the feature referred to by the constraint is required to have the same value in every place where the word matches the pattern. For example, if a plusConstraint for the feature voiced appears on two adjacent consonant contexts in a rule, then the word being matched must have two adjacent consonants with identical voicing. If one of the constraints is in the environment and one in the output of the rule, then the effect is that of a rule of assimilation: in the form output by the rule, the phoneme affected by the rule will have the same value as the value on the phoneme matched by the environment.This attribute is not intended to be implemented immediately, but is included here for completeness (since it is apparently difficult to add new attributes once a COM interface has been defined).Note that although this attr is defined as a collection seq (not an ordered seq), the order is assumed to be stable. Otherwise the labels used in SPE-style rules would be subject to change. On the other hand, the use of a seq attr here may be overkill; from a linguistic standpoint, a single constraint (plus or minus) might be adequate. Renamed from PlusConstraints for the Firebird port.


PhIterationContext

test num:82 | abbrev: itrtncontxt | abstract: false | module: Ling(num:5) | base: PhPhonContext
 | A PhIterationContext represents a context that can be iterated, that is, which can appear adjacent from M to N times. This encompasses Kleene star (0 to infinite number of times) and the '+' notation commonly used in Unix regular expressions (1 to infinite number of times), as well as the sorts of 'between one and three' contexts commonly used in SPE to refer to consonant clusters.More modern theories of phonology dispense with iteration contexts in favor of syllable structure, feet, etc.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Maximum | 2 | Integer |
 | an Integer (defaults to infinite; note that there needs to be a way to display and set a value of " infinity" )
test Basic | Minimum | 1 | Integer |
 | an Integer (defaults to zero)

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Member | 3 | atomic | PhPhonContext
 | a PhPhonologicalContext (but not normally another PhIterationContext)

Back references (sorted by attribute name)

Type Name Num Card Sig


PhMetathesisRule

test num:130 | abbrev: phmetar | abstract: false | module: Ling(num:5) | base: PhSegmentRule
 | A metathesis rule is a (transformational) phonological rule that allows the reordering of segments. (See Kenstowicz and Kisseberth 1979:269ff.)

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | StrucChange | 3 | String |
 | The structural change (i.e. the output )of the rule. It contains an ordered sequence of integers, each of which corresponds to an index in the structural description. Since we do not have a way to model a sequence of integers, we use a string to store the integers. The integers are separated by a space.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


PhNaturalClass

test num:93 | abbrev: natclass | abstract: true | module: Ling(num:5) | base: CmObject
 | An abstract class for the various kinds of natural classes. Note that the subclasses have several attrs in common (e.g. stratum), but that these attrs are defined differently in the various subclasses.Attributes: In addition to the attr given here, all subclasses define a segments attr, either as a ref or a virtual attr, depending on whether the subclass is defined intensionally or extensionally. If this class was generalized beyond phonology, the attr's name should be generalized, e.g. to members.

Direct Subclasses

  • PhNCFeatures
  • PhNCSegments

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Abbreviation | 4 | MultiUnicode |
Basic | Description | 3 | MultiString |
Basic | Name | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoInsertNC:Content | 1 | atomic | PhNaturalClass
 | refers to a PhNaturalClass to be added into the output at this position.
Refer'd by | PhSimpleContextNC:FeatureStructure | 1 | atomic | PhNaturalClass
test Owned by | PhPhonData:NaturalClasses | 3 | sequence | PhNaturalClass
 | Change this here.


PhNCFeatures

test num:94 | abbrev: ncfts | abstract: false | module: Ling(num:5) | base: PhNaturalClass
 | A natural class picked out by a (small) number of feature values (an intensional definition). In classical generative phonology (e.g. SPE = Chomsky and Halle 1968), this was the only way to define a natural class.If this class is generalized beyond phonology, an appropriate name might be NCIntensional.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Features | 1 | atomic | FsFeatStruc
 | owns an FsFeatStruc, specifying the feature values which characterize this natural class. The meaning is that any phoneme which includes (N.B.: not unifies with) the specified feature values matches this natural class.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoModifyFromInput:Modification | 2 | atomic | PhNCFeatures
 | refers to an PhNCFeatures object, specifying the features to be added to the phonemes matched by the content to give a portion of the output.


PhNCSegments

test num:95 | abbrev: ncssegmts | abstract: false | module: Ling(num:5) | base: PhNaturalClass
 | A natural class picked out by specifying the segments which are members (i.e. an extensional definition). This was not an option in classical generative phonology (e.g. SPE = Chomsky and Halle 1968), and opens the possibility of abuse, i.e. setting up unnatural natural classes. It is included here to support the stealth-to-wealth process by letting the user set up a preliminary natural class based on intuitions. There should therefore be a method to help the user change an object of this class to the class PhNCFeatures.If this class is generalized beyond phonology, an appropriate name might be NCExtensional.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Segments | 1 | collection | PhPhoneme
 | refers to a collection seq of PhPhoneme, which are interpreted as the members of this class.

Back references (sorted by attribute name)

Type Name Num Card Sig


PhPhonContext

test num:81 | abbrev: pctx | abstract: true | module: Ling(num:5) | base: PhContextOrVar
 | An abstract superclass of various kinds of contexts, which together encode regular expressions over an alphabet of PhNaturalClasses, strings, phonemes, and boundary markers (used in e.g. the LeftPhoneEnv and RightPhoneEnv attrs of PhEnvironment). Renamed from PhPhonologicalContext for the Firebird Port.

Direct Subclasses

  • PhSequenceContext
  • PhIterationContext
  • PhSimpleContext

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Name | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Description | 2 | atomic | StText

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | PhEnvironment:LeftContext | 4 | atomic | PhPhonContext
test Owned by | PhSegRuleRHS:LeftContext | 1 | atomic | PhPhonContext
 | The left context of the rule.
test Refer'd by | PhIterationContext:Member | 3 | atomic | PhPhonContext
 | a PhPhonologicalContext (but not normally another PhIterationContext)
test Refer'd by | PhSequenceContext:Members | 1 | sequence | PhPhonContext
 | an ordered seq of PhPhonologicalContext (but not normally another PhSequenceContext)
Refer'd by | PhEnvironment:RightContext | 5 | atomic | PhPhonContext
test Owned by | PhSegRuleRHS:RightContext | 2 | atomic | PhPhonContext
 | The right context of the rule.


PhPhonData

test num:99 | abbrev: pdat | abstract: false | module: Ling(num:5) | base: CmObject
 | This is the ultimate owner of phonological data, parallel to the MoMorphologicalData object in the Morphology model. In particular, PhPhonemeSets, PhEnvironments, and PhNaturalClasses are owned here. The reason for the ownership of these objects residing here, rather than in the MoForm (allomorphs) or phonological rules where they are used, is to allow for their re-use. For example, a step in going from an allomorph-based description to a phonological rule-based description is to find all the allomorphs that have similar environments. This step is expedited if the environments are re-used (since they will be identical). Even if they are not identical, the fact that they all reside in one location makes them easier to search for similar environments. Renamed from PhPhonologicalData for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Contexts | 4 | sequence | PhContextOrVar
 | Change this here.
Owning | Environments | 2 | sequence | PhEnvironment
test Owning | FeatConstraints | 5 | sequence | PhFeatureConstraint
 | The feature constraints are what allow us to use alpha notation in phonological rules (to deal with things like assimilation to place of articulation). It is a sequence so we can know the alpha value (is it alpha, beta, gamma, or delta, say). The user need never see these as a list to be edited or maintained by hand. The UI can show them as greek letters in phonological rule displays.
test Owning | NaturalClasses | 3 | sequence | PhNaturalClass
 | Change this here.
test Owning | PhonemeSets | 1 | sequence | PhPhonemeSet
 | owns a collection of PhPhonemeSets, describing the phonemic inventory of the language. The reason for allowing this to be a collection (rather than atomic) is to allow for phonological descriptions at multiple levels (strata),
test Owning | PhonRuleFeats | 6 | atomic | CmPossibilityList
 | The rule features are a way to limit the application of rules, either by excluding or requiring these "features." The CmPossibilityList contains zero or more PhPhonRuleFeat classes. These refer to a CmObject, where that CmObject would probably be a MoInflClass (e.g. a conjugation class), an FsSymFeatVal (e.g. feminine gender), or a CmPossibility (for an exception "feature").
test Owning | PhonRules | 7 | sequence | PhSegmentRule
 | These are the ordered sequence of phonological rules. They are given in the order in which they are to be applied.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:PhonologicalData | 35 | atomic | PhPhonData


PhPhoneme

test num:92 | abbrev: phme | abstract: false | module: Ling(num:5) | base: PhTerminalUnit
 | This represents a single phoneme. The exact meaning of the term 'phoneme' (e.g. whether biuniqueness is assumed) is not under focus here. For the purposes of this document, it is sufficient to treat units of the encoding which have some linguistic reality as if they were phonemes. One implication is that two different spellings of the same phoneme (e.g. Spanish 'c' and 'qu' for the phoneme /k/) correspond to one phoneme.It is likely that some attributes (such as a featural decomposition) will be added later, as needed for phonology applications. The back-references from the PhNaturalClasses are also likely to be important.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | BasicIPASymbol | 1 | String |
 | This is the IPA symbol for the basic phonetic form of this phoneme. We use it to produce a first guess at the phonological features and the (English) description of this phoneme. We also show it in the Grammar Sketch.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Features | 2 | atomic | FsFeatStruc
 | The Features attribute is how the user provides the phonological features of a phoneme (phonological segment). This means that the features contained in the FsFeatStruc must be from LangProject:PhFeatureSystem.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | PhSimpleContextSeg:FeatureStructure | 1 | atomic | PhPhoneme
 | Allows the user to write phonological rules that are sensitive to a particular phoneme (as opposed to a class of phonemes).
test Owned by | PhPhonemeSet:Phonemes | 2 | collection | PhPhoneme
 | collection seq of PhPhoneme.
test Refer'd by | PhNCSegments:Segments | 1 | collection | PhPhoneme
 | refers to a collection seq of PhPhoneme, which are interpreted as the members of this class.


PhPhonemeSet

test num:89 | abbrev: phnmeset | abstract: false | module: Ling(num:5) | base: CmObject
 | This holds a set of phonemes and boundary markers which belong to a certain " level." The reason for having a special object to hold such a set, rather than storing the phonemes individually in an attr of the class MoStratum, is that several strata may use the same set of phonemes.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Description | 4 | MultiString |
Basic | Name | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | BoundaryMarkers | 3 | collection | PhBdryMarker
 | collection seq of PhBdryMarker
test Owning | Phonemes | 2 | collection | PhPhoneme
 | collection seq of PhPhoneme.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoStratum:Phonemes | 4 | atomic | PhPhonemeSet
 | refers to a PhPhonemeSet which provides the phonemes and boundary markers relevant to this stratum. In Hermit Crab, there were two attributes similar to this on strata: an InputLevelOfRepresentation, and an OutputLevelOfRepresentation. It was not clear that this bought anything that having different levels of representation in successive strata would not have bought.
test Owned by | PhPhonData:PhonemeSets | 1 | sequence | PhPhonemeSet
 | owns a collection of PhPhonemeSets, describing the phonemic inventory of the language. The reason for allowing this to be a collection (rather than atomic) is to allow for phonological descriptions at multiple levels (strata),


PhPhonRuleFeat

test num:132 | abbrev: pprf | abstract: false | module: Ling(num:5) | base: CmPossibility
 | A phonological rule feature requirement, such as conjugation class membership, exception feature (aka productivity restriction) or gender. It limits the application of a phonological rule. See PhSegRuleRHS.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Item | 1 | atomic | CmObject
 | This refers to a CmObject, where that CmObject would probably be a MoInflClass (e.g. a conjugation class), an FsSymFeatVal (e.g. feminine gender), or a CmPossibility (for an exception "feature"). Any such MoInflClass would be owned by a PartOfSpeech (or by a nested MoInflClass within a PartOfSpeech); any such FsSymFeatVal would be owned by an FsClosedFeature; and the exception "feature" CmPossibility would be in the possibility list owned by MoMorphData:ProdRestrict.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | PhSegRuleRHS:ExclRuleFeats | 5 | collection | PhPhonRuleFeat
 | This refers to a set of rule features (which are a possibility list). This encodes negative rule feature requirements, such as conjugation class membership or gender. In order for this rule to apply to a lexical entry, the lexical entry must not contain in its Rule Features list any of the feature names of this list. If this field is omitted, there are no excluded rule features. Warning: The names in the RequiredRuleFeatures list and this list should be mutually exclusive.
test Refer'd by | PhSegRuleRHS:ReqRuleFeats | 6 | collection | PhPhonRuleFeat
 | These are required rule features. This collection refers to a set of rule features (which are a possibility list). This encodes positive rule feature requirements, such as conjugation class membership or gender. In order for this rule to apply to a lexical entry, the lexical entry must contain in its Rule Features list all the feature names of this list. If this field is omitted, there are no required Rule Features. Warning: The names in the ExcludedRuleFeatures list and this list should be mutually exclusive.


PhRegularRule

test num:129 | abbrev: phregrule | abstract: false | module: Ling(num:5) | base: PhSegmentRule
 | A regular rule is a phonological rule that inserts (epenthesizes) a segment (such as a vowel or consonant), fills in or changes some feature values, or else it deletes a segment (or possibly more than one segment). There is no provision for epenthesizing boundary markers.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | RightHandSides | 1 | sequence | PhSegRuleRHS
 | The right hand sides of the rule (i.e. the B, C, and D of the general formula (A -> B / C _ D).

Back references (sorted by attribute name)

Type Name Num Card Sig


PhSegmentRule

test num:128 | abbrev: segrule | abstract: false | module: Ling(num:5) | base: CmObject
 | A phonological rule. As currently designed, the rules resemble those of classical generative phonology, in that the input, output, and environments are defined in terms of phonetic features (not segments or autosegments). There is currently no concept of disjunctive rules, although that could be added. We support rule features (i.e. nonphonetic features, such as the feature [+Latinate] of SPE) and rules which are sensitive to the part of speech of the word to which they apply. A phonological rule may act as either an allophonic or morphophonemic rule in structuralist phonology would. We allow for (phonological) metathesis rules, also.

Direct Subclasses

  • PhRegularRule
  • PhMetathesisRule

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Description | 1 | MultiString |
 | A description of the rule, possibly including hyperlinks to some items that motivated the rule.
test Basic | Direction | 3 | Integer |
 | The direction and manner in which the rule applies. The possible values are: 1 - left-to-right iterative; 2 - right-to-left iterative; 3 - simultaneous.
test Basic | Name | 2 | MultiUnicode |
 | A name to help the user identify the rule in a list of phonological rules.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | FinalStratum | 5 | atomic | MoStratum
 | The final stratum to which this rule applies.
test Refer | InitialStratum | 4 | atomic | MoStratum
 | The initial stratum to which this rule applies. If not specified, this rule applies to all strata.
test Owning | StrucDesc | 6 | sequence | PhSimpleContext
 | For regular rules, this is the structural description of the rule (i.e the A in the general formula of A -> B / C _ D). If A is missing, then this is an insertion (epenthetic) rule. For metathesis rules, this is the structural description (i.e. the input) of the rule. Each ordered PhSimpleContext corresponds to a number (the index) that can be referred to in the structural change attribute.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PhPhonData:PhonRules | 7 | sequence | PhSegmentRule
 | These are the ordered sequence of phonological rules. They are given in the order in which they are to be applied.


PhSegRuleRHS

test num:131 | abbrev: segrhs | abstract: false | module: Ling(num:5) | base: CmObject
 | This class delineates the basic requirements for the application of a rule (the "right-hand-side" of the arrow in a traditional phonological rule).

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | ExclRuleFeats | 5 | collection | PhPhonRuleFeat
 | This refers to a set of rule features (which are a possibility list). This encodes negative rule feature requirements, such as conjugation class membership or gender. In order for this rule to apply to a lexical entry, the lexical entry must not contain in its Rule Features list any of the feature names of this list. If this field is omitted, there are no excluded rule features. Warning: The names in the RequiredRuleFeatures list and this list should be mutually exclusive.
test Refer | InputPOSes | 4 | collection | PartOfSpeech
 | When present, this limits the rule application to apply only when the input is for one of the Parts of Speech given in the collection. The hierarchical nature of Parts of Speech is respected, so if "transitive verb" is a sub-category of "verb" and one specifies "verb" as an input POS, then the rule will also apply to "transitive verb.
test Refer | ReqRuleFeats | 6 | collection | PhPhonRuleFeat
 | These are required rule features. This collection refers to a set of rule features (which are a possibility list). This encodes positive rule feature requirements, such as conjugation class membership or gender. In order for this rule to apply to a lexical entry, the lexical entry must contain in its Rule Features list all the feature names of this list. If this field is omitted, there are no required Rule Features. Warning: The names in the ExcludedRuleFeatures list and this list should be mutually exclusive.
test Owning | LeftContext | 1 | atomic | PhPhonContext
 | The left context of the rule.
test Owning | RightContext | 2 | atomic | PhPhonContext
 | The right context of the rule.
test Owning | StrucChange | 3 | sequence | PhSimpleContext
 | The structural change (i.e. the output) of the rule. If this is missing, the rule is a deletion rule

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PhRegularRule:RightHandSides | 1 | sequence | PhSegRuleRHS
 | The right hand sides of the rule (i.e. the B, C, and D of the general formula (A -> B / C _ D).


PhSequenceContext

test num:83 | abbrev: seqcontxt | abstract: false | module: Ling(num:5) | base: PhPhonContext
 | A PhSequenceContext represents a sequence of other contexts (commonly represented by concatenation).

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Members | 1 | sequence | PhPhonContext
 | an ordered seq of PhPhonologicalContext (but not normally another PhSequenceContext)

Back references (sorted by attribute name)

Type Name Num Card Sig


PhSimpleContext

test num:84 | abbrev: simcontxt | abstract: true | module: Ling(num:5) | base: PhPhonContext
 | A PhSimpleContext represents the 'atoms' of phonetic regular expressions, analogous to terminal nodes in phrase structure rules. The subclasses define simple contexts in terms of natural classes (= sets of phonemes), phonemes, and boundary markers. It would also be possible to define a subclass for defining contexts in terms of strings, bypassing the need for translating strings into sequences of phonemes. As a linguist, I have avoided that, butAttributes:None defined here. All subclasses define a featureStructure attr, but they do so differently for each class.

Direct Subclasses

  • PhSimpleContextBdry
  • PhSimpleContextSeg
  • PhSimpleContextNC

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PhSegRuleRHS:StrucChange | 3 | sequence | PhSimpleContext
 | The structural change (i.e. the output) of the rule. If this is missing, the rule is a deletion rule
test Owned by | PhSegmentRule:StrucDesc | 6 | sequence | PhSimpleContext
 | For regular rules, this is the structural description of the rule (i.e the A in the general formula of A -> B / C _ D). If A is missing, then this is an insertion (epenthetic) rule. For metathesis rules, this is the structural description (i.e. the input) of the rule. Each ordered PhSimpleContext corresponds to a number (the index) that can be referred to in the structural change attribute.


PhSimpleContextBdry

num:85 abbrev: smplectxtbdry abstract: false module: Ling(num:5) base: PhSimpleContext

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | FeatureStructure | 1 | atomic | PhBdryMarker

Back references (sorted by attribute name)

Type Name Num Card Sig


PhSimpleContextNC

test num:86 | abbrev: simcontxtnc | abstract: false | module: Ling(num:5) | base: PhSimpleContext
 | Used for natural classes (sets of phonemes).

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | FeatureStructure | 1 | atomic | PhNaturalClass
test Refer | MinusConstr | 3 | sequence | PhFeatureConstraint
refers to a collection seq of PhFeatureConstraints; see discussion under the plusConstraints attr. A feature in question is required to have opposite value from a plusConstraint elsewhere in the rule, and thus makes sense only if a constraint with the same value appears elsewhere in the rule.See implementation comments under plusConstraints. Changed from MinusConstraints for the Firebird Port.
test Refer | PlusConstr | 2 | sequence | PhFeatureConstraint
Refers to a collection seq of PhFeatureConstraint. The use of a plusConstraint only makes sense if there are two or more contexts in a rule that make use of the same constraint. If two such constraints occur in the environment of the rule (treating the input as part of the environment), then the feature referred to by the constraint is required to have the same value in every place where the word matches the pattern. For example, if a plusConstraint for the feature voiced appears on two adjacent consonant contexts in a rule, then the word being matched must have two adjacent consonants with identical voicing. If one of the constraints is in the environment and one in the output of the rule, then the effect is that of a rule of assimilation: in the form output by the rule, the phoneme affected by the rule will have the same value as the value on the phoneme matched by the environment.This attribute is not intended to be implemented immediately, but is included here for completeness (since it is apparently difficult to add new attributes once a COM interface has been defined).Note that although this attr is defined as a collection seq (not an ordered seq), the order is assumed to be stable. Otherwise the labels used in SPE-style rules would be subject to change. On the other hand, the use of a seq attr here may be overkill; from a linguistic standpoint, a single constraint (plus or minus) might be adequate. Renamed from PlusConstraints for the Firebird port.

Back references (sorted by attribute name)

Type Name Num Card Sig


PhSimpleContextSeg

test num:87 | abbrev: smplectxtseg | abstract: false | module: Ling(num:5) | base: PhSimpleContext
 | Used for segments (phonemes).

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | FeatureStructure | 1 | atomic | PhPhoneme
 | Allows the user to write phonological rules that are sensitive to a particular phoneme (as opposed to a class of phonemes).

Back references (sorted by attribute name)

Type Name Num Card Sig


PhTerminalUnit

test num:90 | abbrev: termunit | abstract: true | module: Ling(num:5) | base: CmObject
 | assumption here is that there is a way to convert between the representation of the form of a WfiWordform as a string in some encoding, and a sequence of phonemes (and perhaps boundary markers). How straightforward this method is depends on the orthography, and on some basic decisions as to how linguistically true the translation into phonemes is intended to be. See the codes attr for some discussion.

Direct Subclasses

  • PhPhoneme
  • PhBdryMarker

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Description | 2 | MultiString |
test Basic | Name | 1 | MultiUnicode |
 | a string, often a single character or a single base character plus some diacritics.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Codes | 3 | sequence | PhCode
 | a collection of PhCodes (which amounts to a seq of strings), each in a single encoding (but not perhaps all in the same encoding). Each string is a representation of the phoneme or boundary marker in that encoding.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | MoInsertPhones:Content | 1 | sequence | PhTerminalUnit
 | refers to an ordered seq of PhPhonemes and/or PhBdryMarkers (thus the signature is the superclass PhTerminalUnit).


PhVariable

test num:88 | abbrev: var | abstract: false | module: Ling(num:5) | base: PhContextOrVar
 | This represents a variable in morphological rules (see the input and output attrs of MoAffixProcess). A variable corresponds to '.*' in Unix-style regular expressions, i.e. a sequence of zero or more items (in this case, phonemes and/or boundary markers). They are usually shown by an uppercase letter, e.g. 'X'.Attributes:None.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


PubDivision

test num:43 | abbrev: cmpd | abstract: false | module: Cellar(num:0) | base: CmObject
 | Content for a distinct portion of a publication (document). A CmPubDivision is the largest sub-unit of content organization in a publication.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | DifferentEvenHF | 2 | Boolean |
 | True - if a different header and footer will be used on the even pages in the division. False - if the default header and footer will normally be used for even pages.
test Basic | DifferentFirstHF | 1 | Boolean |
 | True - if a different header and footer will be used on the first page of the division. False - if the normal header and footer (depending on the page number) will be used.
test Basic | NumColumns | 6 | Integer |
 | Default number of columns of text for the page layout. This is an overall layout parameter and only applies to sections or paragraphs that permit multi-column layout. E.g. a Title can be set to always lay out in a single column, regardless of this setting.
test Basic | StartAt | 3 | Integer |
 | Enumeration of options for where the content of the division begins: pdContinuous, pdNew, pdOdd

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | HFSet | 5 | atomic | PubHFSet
 | Changed from HeaderFooterSettings.
test Owning | PageLayout | 4 | atomic | PubPageLayout
 | The page layout parameters for this division specifying page size, margins, header and footer positions, etc.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | Publication:Divisions | 8 | sequence | PubDivision
 | The content divisions (i.e. sections) that determine overall content of the publication.


PubHeader

test num:46 | abbrev: cmph | abstract: false | module: Cellar(num:0) | base: CmObject
 | The contents of the portion of the header that is centered between the margins.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | CenteredText | 2 | String |
 | The contents of the portion of the header that is centered between the margins.
test Basic | InsideAlignedText | 1 | String |
 | The contents of the portion of the header that is aligned with the inside margin.
test Basic | OutsideAlignedText | 3 | String |
 | The contents of the portion of the header that is aligned with the outside margin.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PubHFSet:DefaultFooter | 4 | atomic | PubHeader
 | The contents of the default footer for pages of a publication division (odd pages use the default footer).
test Owned by | PubHFSet:DefaultHeader | 3 | atomic | PubHeader
 | The contents of the default header for pages of a publication division (odd pages use the default header).
test Owned by | PubHFSet:EvenFooter | 8 | atomic | PubHeader
 | The contents of the footer for the even pages of a publication division when different from the default.
test Owned by | PubHFSet:EvenHeader | 7 | atomic | PubHeader
 | The contents of the header for the even pages of a publication division when different from the default.
test Owned by | PubHFSet:FirstFooter | 6 | atomic | PubHeader
 | The contents of the footer for the first page of a publication division when different from the default.
test Owned by | PubHFSet:FirstHeader | 5 | atomic | PubHeader
 | The contents of the header for the first page of a publication division when different from the default.


PubHFSet

test num:45 | abbrev: cmps | abstract: false | module: Cellar(num:0) | base: CmObject
 | Contains a set of headers and footers for a division or section of a publication Renamed from PubHeaderFooterSet for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Description | 2 | String-big |
Basic | Name | 1 | Unicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | DefaultFooter | 4 | atomic | PubHeader
 | The contents of the default footer for pages of a publication division (odd pages use the default footer).
test Owning | DefaultHeader | 3 | atomic | PubHeader
 | The contents of the default header for pages of a publication division (odd pages use the default header).
test Owning | EvenFooter | 8 | atomic | PubHeader
 | The contents of the footer for the even pages of a publication division when different from the default.
test Owning | EvenHeader | 7 | atomic | PubHeader
 | The contents of the header for the even pages of a publication division when different from the default.
test Owning | FirstFooter | 6 | atomic | PubHeader
 | The contents of the footer for the first page of a publication division when different from the default.
test Owning | FirstHeader | 5 | atomic | PubHeader
 | The contents of the header for the first page of a publication division when different from the default.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | CmMajorObject:HeaderFooterSets | 6 | collection | PubHFSet
 | Used to define preset header/footer layouts that can be selected and copied to a publication division. Reason: needed to implement TE-1468
test Owned by | PubDivision:HFSet | 5 | atomic | PubHFSet
 | Changed from HeaderFooterSettings.


Publication

num:42 abbrev: cmpb abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | BaseFontSize | 15 | Integer |
 | Default font size for the publication, in millipoints.
test Basic | BaseLineSpacing | 16 | Integer |
 | Default line spacing for the publication in millipoints, negative if Exact spacing, positive if At Least spacing.
test Basic | BindingEdge | 12 | Integer |
 | Enumeration indicating on which edge the publication is to be bound (which determines the position of the gutter margin): 0 (default) — indicating left 1 — indicating right 2 — indicating top any other value — indicating error: not defined
Basic | Description | 2 | String-big |
test Basic | FootnoteSepWidth | 9 | Integer |
 | Width of the separator line between the body text and the footnote text in parts per thousand of the column width. Valid values are 0-1000: 0 — indicating that no separator line will appear 1000 — indicating that separator line will be drawn for the full width of the footnote column 333 — indicating a standard 1/3 column width separator line any other value — indicating a custom proportion of the separator line to the column width.
test Basic | GutterLoc | 7 | Integer |
 | Enumeration indicating the which edge of the paper has the gutter margin, i.e. the bound edge of the publication. The valid values are: glLeft, glRight, glTop.
test Basic | GutterMargin | 6 | Integer |
 | Width of gutter margin from bound edge.
test Basic | IsLandscape | 5 | Boolean |
 | True if orientation of page is “landscape”
Basic | Name | 1 | Unicode |
test Basic | PageHeight | 3 | Integer |
 | The height of the trimmed page in the final publication, in millipoints. This includes the top and bottom margins and the printable height of the text area. 0(default) — indicating the equal to the paper size positive value — indicating a specific size page size to lay out on the paper
test Basic | PageWidth | 4 | Integer |
 | The width of the trimmed page in the final publication, in millipoints. This includes the inside and outside margins and the printable width of the text area but it does not include the gutter margin. 0(default) — indicating the equal to the paper size positive value — indicating a specific size page size to lay out on the paper
test Basic | PaperHeight | 10 | Integer |
 | The physical height of the sheet of paper to be printed, in millipoints. This, together with the PaperWidth property, determines the paper size that is requested from a printer. 0(default) — indicating the default paper size for the printer positive value — indicating a specific size requested from the printer
test Basic | PaperWidth | 11 | Integer |
 | The physical width of the sheet of paper to be printed, in millipoints. This, together with the PaperHeight property, determines the paper size that is requested from a printer. 0(default) — indicating the default paper size for the printer positive value — indicating a specific size requested from the printer
test Basic | SheetLayout | 13 | Integer |
 | enumeration designating the way pages are laid out on each sheet of paper for printing: 0 (default) — indicating simplex: 1 front (recto) page per sheet. (Implies that the gutter margin is always on the leading side of the page.) 1 — indicating duplex: 1 front (recto) page and 1 back (verso) page per sheet (Implies that the gutter margin alternates between the leading and trailing sides of alternate pages.) 2 — indicating booklet: 2 front (recto) pages and 2 back (verso) pages per sheet, side-by-side. (Implies two gutter margins in the center of the sheet, on each side.) any other value — indicating error: not defined
test Basic | SheetsPerSig | 14 | Integer |
 | Number of sheets of paper in each signature for booklet layout. The number of pages per signature will equal four times this value for typical booklet printing. (A 'signature' is a set of sheets in a book, folded together for binding as a unit).

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Divisions | 8 | sequence | PubDivision
 | The content divisions (i.e. sections) that determine overall content of the publication.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | CmMajorObject:Publications | 5 | collection | Publication
 | A collection of all of the publication layouts available for output from the translated scripture database.


PubPageLayout

test num:44 | abbrev: cmpl | abstract: false | module: Cellar(num:0) | base: CmObject
 | Encapsulates page layout parameters specifying page margins, header and footer positions, etc. The internal unit of measurement for page layout parameters is millipoints. A CmPageLayout is a page style specification applied to a CmPubDivision. Each CmDivision owns one copy of CmPageLayout. (Other objects may be made owners of CmPageLayout(s) as the design progresses.)

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Description | 2 | String-big |
test Basic | IsBuiltIn | 10 | Boolean |
 | True if the object is factory supplied.
test Basic | IsModified | 11 | Boolean |
 | True if the object’s properties have been modified from the default (approved) settings.
test Basic | MarginBottom | 4 | Integer |
 | Height of bottom margin from bottom of page
test Basic | MarginInside | 5 | Integer |
 | Width of inside margin from gutter margin. Footnote: The first implementation will support only “mirror margins”
test Basic | MarginOutside | 6 | Integer |
 | Width of outside margin from outside edge
test Basic | MarginTop | 3 | Integer |
 | Height of top margin from top of page
Basic | Name | 1 | Unicode |
test Basic | PosFooter | 8 | Integer |
 | Position of top of footer from bottom of page
test Basic | PosHeader | 7 | Integer |
 | Position of bottom of header from top of page.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | PubDivision:PageLayout | 4 | atomic | PubPageLayout
 | The page layout parameters for this division specifying page size, margins, header and footer positions, etc.


PunctuationForm

num:11 abbrev: pf abstract: false module: Ling(num:5) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Form | 1 | String |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


Reminder

test num:7 | abbrev: rem | abstract: false | module: Notebk(num:4) | base: CmObject
 | This class provides a means for the user to indicate areas where he wants to do further research. He can then look at a list of all of the Reminders within a notebook, and order his research to address these topics. Eventually, we will probably expand this class to include an indication of priority, and perhaps other fields. But this begins to cross the line into the Project Management software we wish to design and develop, so at this point we are going to keep it relatively simple.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Date | 2 | GenDate |
 | A date which the user can set to be reminded to do something or check something.
test Basic | Description | 1 | String-big |
 | The nature of the reminder, e.g., a question to get answered, or a note about some work that should be done.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | RnResearchNbk:Reminders | 2 | collection | Reminder
 | At a global level, the user can use this attribute to view all of the reminders that have been made within the individual records. (The view will presumably permit ordering (and/or sorting) and filtering of these reminders, in support of creating printouts that can help guide further work or elicitation.)
test Refer'd by | RnGenericRec:Reminders | 3 | collection | Reminder
 | A place where the user can record reminders for further research, such as further editing to do to the record, or additional types of data to seek, or whatever comes to mind.


ReversalIndex

num:52 abbrev: revi abstract: false module: Ling(num:5) base: CmMajorObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | WritingSystem | 4 | Unicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Entries | 3 | collection | ReversalIndexEntry
Owning | PartsOfSpeech | 1 | atomic | CmPossibilityList

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | LexDb:ReversalIndexes | 17 | collection | ReversalIndex
 | Ken Zook: We are pretty well beyond the point where we'll ever allow multiple language projects in a database, so I think it's time we make these indexes owned. Since they are really part of the lexical database, I'm recommending they be owned by the lexical database.


ReversalIndexEntry

num:53 abbrev: reve abstract: false module: Ling(num:5) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | ReversalForm | 6 | MultiUnicode |
 | This property contains the index entry forms. The primary form is in the ReversalIndex_WritingSystem. Other acceptable writing systems are ones that are the same language as the primary form (the IcuLocal is identical up to the first _).

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | PartOfSpeech | 3 | atomic | PartOfSpeech
Owning | Subentries | 2 | collection | ReversalIndexEntry

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | ReversalIndex:Entries | 3 | collection | ReversalIndexEntry
Refer'd by | LexSense:ReversalEntries | 9 | collection | ReversalIndexEntry
Owned by | ReversalIndexEntry:Subentries | 2 | collection | ReversalIndexEntry


RnGenericRec

test num:4 | abbrev: genr | abstract: false | module: Notebk(num:4) | base: CmObject
 | This is a superclass that encapsulates basic, shared behavior for Event and Analysis records Rdnamed from RnGenericRecord for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | DateCreated | 10 | Time |
 | The date and time that the record is created.
test Basic | DateModified | 11 | Time |
 | The date and time that the record is last modified.
test Basic | DateOfEvent | <html> <head> </head> <body> <p> 16 </p> </body> </html> | GenDate |
 | The date of the event.
test Basic | Title | 1 | String |
 | A caption or title for the record, such as "Emilio and Maria's Wedding".

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | AnthroCodes | 7 | collection | CmAnthroItem
 | OcmCodes - User applies OCM tags to this particular record.April 5, 2001 - The following documentation needs to be updated.This is where the user applies tagging at the scope of the entire record. Tags will be to such lists as the FRAME (the modified Outline of Cultural Materials), a grammar outline, and numerous other outlines that will be included with the system. After doing this tagging, the user will be able to quickly find all records that pertain to a particular topic. (In the user interface, we will provide mechanisms to facilitate fast tagging, including choosing which outline to tag from.)
test Refer | Confidence | 5 | atomic | CmPossibility
 | An indication of how confident the researcher is about the data in this record. Example values high, medium, low, uncertain.
test Refer | CounterEvidence | 17 | sequence | RnGenericRec
 | Data records which refute the hypothesis.
test Refer | CrossReferences | 12 | collection | CrossReference
 | A RnGenericRecord can refer to one or more CrossReference objects. For version 1 of Research Notebook, CrossReference objects will have two backreferences representing a bi-directional cross-reference.
test Refer | Locations | 24 | collection | CmLocation
 | A list of locations in which the event occurred.
test Refer | PhraseTags | 8 | collection | CmPossibility
 | The Tags attribute is used for explicit tagging by the end-user, where he indicates that a given tag applies to the entire record. The PhraseTags attribute by contrast is a behind-the-scenes tag. When the user tags a word or phrase within a description, the editing mechanism will add that tag to this attribute. The purpose is to provide a means for fast searching. The user can do a quick back-reference search to arrive at the appropriate records, and then do a text search to find the actual tagged phrase. In this manner we avoid having to do a sequential search through every record in the notebook.
test Refer | Reminders | 3 | collection | Reminder
 | A place where the user can record reminders for further research, such as further editing to do to the record, or additional types of data to seek, or whatever comes to mind.
test Refer | Researchers | 4 | collection | CmPerson
 | Tthe persons who obtained, entered, or analyzed the data. If more than one person was involved, then all researchers can be cited here.
test Refer | Restrictions | 6 | collection | CmPossibility
 | Any restrictions that might exist for this data.
test Refer | SeeAlso | 15 | collection | RnGenericRec
 | See Also cross-references for Events or Analyses
test Refer | Sources | 25 | collection | CmPerson
 | The person(s) who reported the event to the researcher.
test Refer | Status | 18 | atomic | CmPossibility
 | An indication of the current status of the record. Included default possibilities include: Confirmed, Disproved, Pending
test Refer | SupersededBy | 7 | collection | RnGenericRec
 | A hypothesis can be superceeded by another hypothesis; this attribute refers to that superceeding hypothesis.
test Refer | SupportingEvidence | 20 | sequence | RnGenericRec
 | Data records which support the hypothesis.
test Refer | TimeOfEvent | 26 | collection | CmPossibility
 | The time that the event occurred. The types of items in the list here can be vernacular words that capture how the culture captures different times during the day.
test Refer | Type | 27 | atomic | CmPossibility
 | The type of event. Included possibilities include: Performance, Almanac, Conversation, Observation, Literature Summary.
test Owning | Conclusions | 21 | atomic | StText
 | A summary of the results of the research.
test Owning | Description | 29 | atomic | StText
 | The content of the event.
test Owning | Discussion | 32 | atomic | StText
 | Any pertinent discussion relating to the hypothesis.
test Owning | ExternalMaterials | 13 | atomic | StText
 | A listing of any external sources, such as tape or video records, pictures in a scrapbook, etc.
test Owning | FurtherQuestions | 14 | atomic | StText
 | Questions that have arisen as a result of trying to prove a hypothesis or when examining an event record. These may be used later in elicitation sessions or become the bases of new hypotheses.
test Owning | Hypothesis | 22 | atomic | StText
 | A statement of the hypothesis.
test Owning | Participants | 30 | collection | RnRoledPartic
 | A list of roles involved in the event and the participants who fill those roles. The user can specify participants directly in which case their role is assigned as unspecified.
test Owning | PersonalNotes | 31 | atomic | StText
 | Notes of a personal, perhaps non-publishable nature. You know ... personal frustrations, swear words and the like that you want to hide when your administrator checks your work.
test Owning | ResearchPlan | 23 | atomic | StText
 | A plan for researching the hypothesis. Eventually we will tie this into project management; for now we just supply a text description.
test Owning | SubRecords | 9 | sequence | RnGenericRec
 | A collection of lower-level records. This permits a hierarchical grouping of records (e.g., all of the records dealing with Emilio and Maria's Wedding.) By placing this attribute at the RnGenericRecord level, we are making the claim that any type of record can have subrecords. Thus, for example, a Formal Interview might include some Observations that happened during the interview; a Performance Record might include several formal interviews about the performance; a Cartographic Record might include Reports on Conversations that helped in creating the map.
test Owning | VersionHistory | 2 | atomic | StText
 | A collection of versions that the record has gone through. This includes an archival of previous versions of the actual records.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | RnGenericRec:CounterEvidence | 17 | sequence | RnGenericRec
 | Data records which refute the hypothesis.
test Owned by | RnResearchNbk:Records | 1 | collection | RnGenericRec
 | A collection containing all of the top-level records in the notebook. (Keep in mind that records can contain records, so that this attribute only contains the top-level records.) This is the main content attribute of the notebook.
test Refer'd by | RnGenericRec:SeeAlso | 15 | collection | RnGenericRec
 | See Also cross-references for Events or Analyses
test Owned by | RnGenericRec:SubRecords | 9 | sequence | RnGenericRec
 | A collection of lower-level records. This permits a hierarchical grouping of records (e.g., all of the records dealing with Emilio and Maria's Wedding.) By placing this attribute at the RnGenericRecord level, we are making the claim that any type of record can have subrecords. Thus, for example, a Formal Interview might include some Observations that happened during the interview; a Performance Record might include several formal interviews about the performance; a Cartographic Record might include Reports on Conversations that helped in creating the map.
test Refer'd by | RnGenericRec:SupersededBy | 7 | collection | RnGenericRec
 | A hypothesis can be superceeded by another hypothesis; this attribute refers to that superceeding hypothesis.
test Refer'd by | RnGenericRec:SupportingEvidence | 20 | sequence | RnGenericRec
 | Data records which support the hypothesis.


RnResearchNbk

test num:1 | abbrev: rnb | abstract: false | module: Notebk(num:4) | base: CmMajorObject
 | The ResearchNotebook is the major containing object for the various records that are stored in the notebook. Renamed from RnResearchNotebook for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | CrossReferences | 4 | collection | CrossReference
 | CrossReference objects that capture crossReferences between two RnGenericRecords are owned here by the ResearchNotebook.
test Owning | Records | 1 | collection | RnGenericRec
 | A collection containing all of the top-level records in the notebook. (Keep in mind that records can contain records, so that this attribute only contains the top-level records.) This is the main content attribute of the notebook.
test Owning | RecTypes | 3 | atomic | CmPossibilityList
 | A list of event types that the user can modify. Types included by default are: Performance, Almanac, Conversation, Observation, LiteratureSummary.
test Owning | Reminders | 2 | collection | Reminder
 | At a global level, the user can use this attribute to view all of the reminders that have been made within the individual records. (The view will presumably permit ordering (and/or sorting) and filtering of these reminders, in support of creating printouts that can help guide further work or elicitation.)

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:ResearchNotebook | 15 | atomic | RnResearchNbk


RnRoledPartic

test num:10 | abbrev: rps | abstract: false | module: Notebk(num:4) | base: CmObject
 | Captures participants and their roles in a recorded event. Renamed from RnRoledParticipants for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Participants | 1 | collection | CmPerson
 | A list of people (or one person) involved in the event in the role specified below.
test Refer | Role | 2 | atomic | CmPossibility
 | The role of the above participant(s). The role may be set to "unspecified."

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | RnGenericRec:Participants | 30 | collection | RnRoledPartic
 | A list of roles involved in the event and the participants who fill those roles. The user can specify participants directly in which case their role is assigned as unspecified.


ScrBook

test num:2 | abbrev: scrb | abstract: false | module: Scripture(num:3) | base: CmObject
 | A translated book of Scripture. This container holds ScrSections which are where the actual verse texts are stored.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Abbrev | 5 | MultiUnicode |
 | The abbreviation for the name of the Scripture Book. Initialized from ScrBookRef.BookAbbrev. For books that belong to Scripture.ScriptureBooks, this name should be in synch. with ScrBookRef.BookAbbrev. After books are moved to ScrDraft.Books, they retain the abbreviation that they had at the time that they were archived. This allows the historic metadata to be persisted. Otherwise the metadata in an archived book would change as ScrBookRef changes.
test Basic | CanonicalNum | 13 | Integer |
 | Canonical Book number, a unique sequential ID number for which book of the canon that this one is. May be used for ordering the books in canonical order and for identifying the book to other applications. Persists the canonical identity of a book even if the BookId becomes invalid.
test Basic | IdText | 8 | Unicode |
 | Id line from SF files (needed for import/export)
test Basic | Name | 2 | MultiUnicode |
 | The full book name for the Scripture Book. Initialized from ScrBookRef.BookName. For books that belong to Scripture.ScriptureBooks, this name should be in synch. with ScrBookRef.BookName. After books are moved to ScrDraft.Books, they retain the Name that they had at the time that they were archived. This allows the historic metadata to be persisted. Otherwise the metadata in an archived book would change as ScrBookRef changes.
test Basic | UseChapterNumHeading | 12 | Boolean |
 | In this book chapter number headings will be used instead of drop-cap chapter numbers in the text.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | BookId | 3 | atomic | ScrBookRef
 | A reference to a ScrBookRef. This association is for convenience. The correct item in ScrBookRef could also be found using ScrBook.CanonicalNum.
Owning | Diffs | 11 | collection | ScrDifference
Owning | Footnotes | 10 | sequence | ScrFootnote
test Owning | Sections | 1 | sequence | ScrSection
 | A ScrBook is made up of ScrSections. ScrSections represent short passages of Scripture. For example, Matthew 1:1-17 in the NIV is a ScrSection with a heading of "The Genealogy of Jesus."
test Owning | Title | 4 | atomic | StText
 | The Title can be a sequence of paragraphs. We might thus have a paragraph style for Main Title and for SubTitles to support titles like: The <SubTitlePrevious> Acts <MainTitle> of the Apostles <SubTitleFollowing>

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | ScrDraft:Books | 2 | sequence | ScrBook
test Owned by | Scripture:ScriptureBooks | 1 | sequence | ScrBook
 | The Scripture object is a container for an ordered collection of ScrBooks (Scripture Books).


ScrBookAnnotations

test num:17 | abbrev: scba | abstract: false | module: Scripture(num:3) | base: CmObject
 | Contains annotations about one book of Scripture. Scripture annotations are stored book-by-book to make for faster access and filtering. These annotations are only for consultant notes, scripture notes and other content that discusses the scripture content. At present (Jan/2006), we have not decided where to put the annotations that will be generated by the checking tools.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | ChkHistRecs | 3 | collection | ScrCheckRun
 | Records the date and results of the latest run of each check
test Owning | Notes | 2 | sequence | ScrScriptureNote
 | Scripture notes for this book of Scripture. These annotations include consultant notes, translator notes and also "error" annotations generated by checking tools.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | Scripture:BookAnnotations | 24 | sequence | ScrBookAnnotations
 | Book-by-book sequence of annotations that are specific to the scripture text. As of January 2006, these are just scripture notes. We have not yet decided whether to store the annotations generated by checking tools here Scripture annotations are stored book-by-book to make for faster access and filtering.


ScrBookRef

test num:4 | abbrev: scbr | abstract: false | module: Scripture(num:3) | base: CmObject
 | ScrBookRef holds the default naming metadata of a given canonical Scripture book, by writing system. ScrBookRef no longer stores the 3-letter UBS book reference code. The 3-letter UBS book ref is now managed by the business layer of the application.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | BookAbbrev | 3 | MultiUnicode |
 | The default human-readable book abbreviation, e.g. 2 Cor., for each writing system.
test Basic | BookName | 1 | MultiUnicode |
 | The current full book name, e.g. 2 Corinthians for each writing system.
test Basic | BookNameAlt | 4 | MultiUnicode |
 | The current alternate full book name, e.g. II Corinthians, for each writing system.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | ScrBook:BookId | 3 | atomic | ScrBookRef
 | A reference to a ScrBookRef. This association is for convenience. The correct item in ScrBookRef could also be found using ScrBook.CanonicalNum.
Owned by | ScrRefSystem:Books | 1 | sequence | ScrBookRef


ScrCheckRun

test num:19 | abbrev: sccr | abstract: false | module: Scripture(num:3) | base: CmObject
 | Records the date and results of a run of a check.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | CheckId | 1 | Guid |
 | A GUID uniquely identifying the check.
test Basic | Result | 3 | Integer |
 | Result of the check. An integer representing an enumeration (0 - No inconsistencies found; 1 - Only ignored inconsistencies found; 2 - Unignored inconsistencies found).
test Basic | RunDate | 2 | Time |
 | Date and time the check was completed.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | ScrBookAnnotations:ChkHistRecs | 3 | collection | ScrCheckRun
 | Records the date and results of the latest run of each check


ScrDifference

test num:11 | abbrev: sdif | abstract: false | module: Scripture(num:3) | base: CmObject
 | contains the information about one difference between a ScrBook and a ScrBook revision. We have a diff tool that allows comparing two versions of scripture books. While a person is comparing versions, we want to provide the capability of leaving and resuming the comparison process at a later time. In order to do this, we need to save a list of differences and an HVO of a revision book in the database.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | DiffType | 3 | Integer |
 | an integer to identify the type of difference.<p/> Verse not found in current book: MissingInCurrent.<p/> Verse not found in revision book: MissingInRevision. <p/> Text of verse in current and revision differ: TextDifference.<p/>
test Basic | RefEnd | 2 | Integer |
 | an integer to store a reference for where the difference ends.
test Basic | RefStart | 1 | Integer |
 | an integer to store a reference for where the difference starts.
test Basic | RevLim | 5 | Integer |
 | the offset in the paragraph past the end of the difference verse.
test Basic | RevMin | 4 | Integer |
 | the offset in the paragraph where the difference begins.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | RevParagraph | 6 | atomic | StPara
 | the paragraph in the revision that the difference is in.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | ScrBook:Diffs | 11 | collection | ScrDifference


ScrDraft

test num:10 | abbrev: sdrf | abstract: false | module: Scripture(num:3) | base: CmObject
 | Enumeration: 0 - Saved Version; 1 - Imported Version

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | DateCreated | 3 | Time |
 | The date and time that the record is created. Not automatically the same as the time stamp on a CmObject.
Basic | Description | 1 | Unicode |
test Basic | Protected | 5 | Boolean |
 | Stores whether certain saved versions can be deleted.
test Basic | Type | 4 | Integer |
 | 0 = Saved Version; 1 = Imported Version

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Books | 2 | sequence | ScrBook

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | Scripture:ArchivedDrafts | 9 | collection | ScrDraft


ScrFootnote

num:20 abbrev: scrF abstract: false module: Scripture(num:3) base: StFootnote

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | ScrBook:Footnotes | 10 | sequence | ScrFootnote


ScrImportP6Project

test num:14 | abbrev: sipp | abstract: false | module: Scripture(num:3) | base: ScrImportSource
 | Variant of ImportSource used to designate a Paratext 6 project.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | ParatextID | 1 | Unicode |
 | The Paratext ID number for the Paratext project.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


ScrImportSet

test num:8 | abbrev: scis | abstract: false | module: Scripture(num:3) | base: CmObject
 | Stores named sets of import settings for importing scripture. Renamed from ScrImportSettings for tye Firebird Port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Description | 6 | MultiUnicode |
 | Display description for each instance of import settings.
test Basic | ImportProjToken | 3 | Unicode |
 | Token to be used for loading project using ScriptureObjects
test Basic | ImportType | 1 | Integer |
 | Enumeration: Unknown = 0; Paratext = 1; Other = 2
test Basic | Name | 5 | MultiUnicode |
 | Display name for this instance of import settings. May be null if settings are not part of a list of settings displayed to the user.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | BackTransSources | 8 | collection | ScrImportSource
 | Sources for scripture back translations. More than one is used only if back translations are written in diverse analysis languages.
test Owning | NoteMappings | 11 | collection | ScrMarkerMapping
 | The mappings (from delimited external data to internal data structure) that apply to the annotations sources in this group of settings. Markers in the various annotation sources must be compatible within an instance of ScrImportSettings so one collection of mappings is used for all note sources.
test Owning | NoteSources | 9 | collection | ScrImportSource
 | Sources for annotations. Different sources are useful to group different kinds of annotations and/or different originators.
test Owning | ScriptureMappings | 10 | collection | ScrMarkerMapping
 | The mappings (from delimited external data to internal data structure) that apply to the scripture and back translations sources in this group fo settings. Markers used in both the scripture and back translations sources must be used equivalently within an instance of ScrImportSettings, so one collection of mappings is used for both types of sources.
test Owning | ScriptureSources | 7 | collection | ScrImportSource
 | Currently (Dec 2005) a single source for scripture is suported but this is made a collection to make future expansion feasible.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | Scripture:ImportSettings | 7 | collection | ScrImportSet
 | Scripture Import Settings. Supports multiple configurations for importing Scripture and related data from external files.


ScrImportSFFiles

test num:15 | abbrev: sisf | abstract: false | module: Scripture(num:3) | base: ScrImportSource
 | Variant of ScrImportSource used to designate a list of Standard Format files.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | FileFormat | 1 | Integer |
 | Enumeration, may be used to designate the format variation of the standard format files in this source (Paratext 5, USFM, etc.) so that import can be tailored to the format.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Files | 2 | collection | CmFile
 | The files that this source comprises. Currently (Dec 2005) plan to only set the OriginalPath in the CmFile.

Back references (sorted by attribute name)

Type Name Num Card Sig


ScrImportSource

test num:13 | abbrev: ssrc | abstract: true | module: Scripture(num:3) | base:
 | Abstract Class for source of the incoming data, the information needed to set uup an import stream.

Direct Subclasses

  • ScrImportP6Project
  • ScrImportSFFiles

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | ICULocale | 1 | Unicode |
 | Permits the writing system of the data to be specified globally for the source. If NULL, the default writing system for the context will be used.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | NoteType | 2 | atomic | CmAnnotationDefn

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | ScrImportSet:BackTransSources | 8 | collection | ScrImportSource
 | Sources for scripture back translations. More than one is used only if back translations are written in diverse analysis languages.
test Owned by | ScrImportSet:NoteSources | 9 | collection | ScrImportSource
 | Sources for annotations. Different sources are useful to group different kinds of annotations and/or different originators.
test Owned by | ScrImportSet:ScriptureSources | 7 | collection | ScrImportSource
 | Currently (Dec 2005) a single source for scripture is suported but this is made a collection to make future expansion feasible.


Scripture

test num:1 | abbrev: scrp | abstract: false | module: Scripture(num:3) | base: CmMajorObject
 | This object exists to hold all language project Scripture-related data. It serves as a specialized folder.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Bridge | 6 | Unicode |
 | Bridge is a string (usually one character) that bridges contiguous chapter and/or verse ranges in a reference. In the U.S.A., this is traditionally a dash (-), e.g., Mat 24:16-25; Rev 1:7-2:9.
test Basic | ChapterLabel | 22 | String |
 | String that will be insterted when a chapter number heading is genetrated.
test Basic | ChapterVerseSepr | 4 | Unicode |
 | ChapterVerseSepr is a string (usually one character) that separates the chapter number from the verse number in a reference. In the U.S.A., this is a traditionally colon (:), e.g., Mat 24:16.
test Basic | ConvertCVDigitsOnExport | 18 | Boolean |
 | Whether or not to convert from "European" digits, (1, 2, 3) from scripts using Unicode code points. Renamed from ConvertCVNumsToEuropeanDigitsOnExport
test Basic | CrossRefMarkerSymbol | 28 | Unicode |
 | The custom marker that will be used as a literal string for the cross-reference callout (typically a single character).
test Basic | CrossRefMarkerType | 29 | Integer |
 | Enumeration of cross-reference callout options: 0 = 'alphabetic sequence' 1 = 'custom symbol' 2 = 'no marker displayed in text' other values will be added for other kinds of sequences. Note: coordinate these enumeration values with FootnoteMarkerType.
test Basic | CrossRefsCombinedWithFootnotes | 30 | Boolean |
 | Indicates whether cross-references are to be combined with the general footnote layout (true) or are to be layed out separately (false).
test Basic | DisplayCrossRefReference | 27 | Boolean |
 | True if the "source" chapter and verse reference of the cross-reference should be displayed in the note; False otherwise
test Basic | DisplayFootnoteReference | 12 | Boolean |
 | True if the chapter and verse of the footnote should be displayed below in the footnote; False otherwise.
test Basic | DisplaySymbolInCrossRef | 32 | Boolean |
 | If true, display the custom symbol callout in cross-reference footnotes (as well as in the text) when the custom symbol option is chosen for the CrossRefMarkerType property.
test Basic | DisplaySymbolInFootnote | 31 | Boolean |
 | If true, display the custom symbol marker in general footnotes (as well as in the text) when the custom symbol option is chosen for the FootnoteMarkerType property.
test Basic | FootnoteMarkerSymbol | 10 | Unicode |
 | The custom marker that will be used as a literal string for the callout (typically a single character).
test Basic | FootnoteMarkerType | 26 | Integer |
 | Enumeration of footnote callout options: 0 = 'alphabetic sequence' 1 = 'custom symbol' 2 = 'no marker displayed in text' other values will be added for other kinds of sequences. Note: coordinate these enumeration values with FootnoteMarkerType.
test Basic | PsalmLabel | 23 | String |
 | String that will be inserted when a Psalm number heading is generated.
test Basic | RefSepr | 3 | Unicode |
 | RefSepr is a string (usually one character) that separates complete references or chapter/verse references in a list. In the U.S.A., this is traditionally a semi-colon (;), e.g., Mat 24:16; Rev 1:2;4:5.
test Basic | RestartFootnoteBoundary | 14 | Integer |
 | Where to restart the footnote sequence, represented as an enumeration (Chapter, Book, OT/NT, etc.)
test Basic | RestartFootnoteSequence | 13 | Boolean |
 | True if the footnote sequence should be restarted (..., y, z, a, b, ...), false otherwise (..., y, z, aa, ab, ..)
test Basic | ScriptDigitZero | 16 | Integer |
 | This stores the Unicode character for zero in the given script. It is assumed this is a decimal based system that has consecutive code points from 0 through 9. Note that Tamil does not have a character for zero, but Unicode reserves a code point U+0BE6 for this position so that it can still be used in calculations to find the remaining digits. (Tamil actually displays a Latin 0 for zero.)
test Basic | UseScriptDigits | 15 | Boolean |
 | This Boolean tells the Scripture tool to use script chapter/verse digits instead of ASCII (latin) numbers.
test Basic | VersePunct | 20 | Unicode |
 | String of zero or more vernacular punctuation characters that will be appended automatically to all inserted verse numbers. Null by default.
test Basic | VerseSepr | 5 | Unicode |
 | VerseSepr is a string (usually one character) that separates non-contiguous verse numbers in a list. In the U.S.A., this is traditionally a comma (,), e.g., Mat 24:16,25.
test Basic | Versification | 19 | Integer |
 | Designates one of a several versification schemes. A versification scheme defines how the content of each book of the Bible is partitioned into verses and defines the reference (chapter and verse number) for each verse. Translation Editor determines the number of verses in each chapter based on the versification scheme. Versification is to be enumerated as follows (matches Paratext versification schemes): (0) - Unknown (1) - Original, Masoretic for OT, Nestle-Aland for NT (2) - Septuagint for (OT) (3) - Vulgate, like the Latin Vulgate, used by many modern versions including French (4) - English, like the RSV, used by many translations patterned on the English text. (5) - Custom, user specified (not yet implemented in Paratext)

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | ArchivedDrafts | 9 | collection | ScrDraft
test Owning | BookAnnotations | 24 | sequence | ScrBookAnnotations
 | Book-by-book sequence of annotations that are specific to the scripture text. As of January 2006, these are just scripture notes. We have not yet decided whether to store the annotations generated by checking tools here Scripture annotations are stored book-by-book to make for faster access and filtering.
test Owning | ImportSettings | 7 | collection | ScrImportSet
 | Scripture Import Settings. Supports multiple configurations for importing Scripture and related data from external files.
test Owning | NoteCategories | 25 | atomic | CmPossibilityList
 | List of categories that identify the types of issues that a ScrScriptureNote might deal with. Changed from ScriptureNoteCategories.
test Owning | Resources | 33 | collection | CmResource
 | The named external resources (e.g. xml files) used by Translation Editor and their version numbers.
test Owning | ScriptureBooks | 1 | sequence | ScrBook
 | The Scripture object is a container for an ordered collection of ScrBooks (Scripture Books).
test Owning | Styles | 2 | collection | StStyle
 | Scripture requires text style attributes that are uniquely different from styles for general documents in the project. This new style sheet (collection of styles) can be structured just like the style sheet in the Language Project, but is used for all texts authored in the Scripture Editor - Drafts, Back Translations, Notes, UNS Questions, etc. This allows us to: a. utilize styles that are specific for Scripture use; b. avoid conflicts with the LangProject style sheet if, for example, a Style named 'Paragraph' is desired for both general documents and Scripture

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:TranslatedScripture | 40 | atomic | Scripture


ScrMarkerMapping

test num:16 | abbrev: scmm | abstract: false | module: Scripture(num:3) | base: CmObject
 | Settings for mapping between the external data's delimiting markers and the internal data.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | BeginMarker | 1 | Unicode |
 | Marker used for opening delimiter of a data run.
test Basic | Domain | 5 | Integer |
 | Designates the internal destination stream or sub-stream for the data. The integer is a bit-slice composite of an internal enumeration: h0000 - unknown domain h0001 - scripture domain h0002 - back translation domain h0004 - notes domain h0008 - footnote domain
test Basic | EndMarker | 2 | Unicode |
 | Marker used for closing delimiter of a data run.
test Basic | Excluded | 3 | Boolean |
 | If true, exclude this delimited data from being imported.
test Basic | ICULocale | 6 | Unicode |
 | Permits the writing system of the data to be specified, if it is not based on context and if it is different than the global setting.
test Basic | Target | 4 | Integer |
 | Enumeration that designates whether the mapping is to a style (text in the main data stream with this style) or to a metadata property and if to a property, which property. 0 - maps to a style 1 - maps to a Figure 2 - maps to a Chapter Label 3 - maps to Title Short other values TBD, not a closed enumeration.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | NoteType | 11 | atomic | CmAnnotationDefn
test Refer | Style | 10 | atomic | StStyle
 | Style to apply to data in an internal text stream. Ignored of Target is <> 0.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | ScrImportSet:NoteMappings | 11 | collection | ScrMarkerMapping
 | The mappings (from delimited external data to internal data structure) that apply to the annotations sources in this group of settings. Markers in the various annotation sources must be compatible within an instance of ScrImportSettings so one collection of mappings is used for all note sources.
test Owned by | ScrImportSet:ScriptureMappings | 10 | collection | ScrMarkerMapping
 | The mappings (from delimited external data to internal data structure) that apply to the scripture and back translations sources in this group fo settings. Markers used in both the scripture and back translations sources must be used equivalently within an instance of ScrImportSettings, so one collection of mappings is used for both types of sources.


ScrRefSystem

test num:3 | abbrev: scrf | abstract: false | module: Scripture(num:3) | base:
 | ScrRefSystemt stores the complete set of Scripture book names and abbreviations as ScrBookRef objects. The project (ScrBookRef) no longer stores the 3-letter UBS book ref. The 3-letter UBS book ref is now managed by the business code. ScrRefSystem persists known book names and abbreviations that are loaded from external data and also persists the most recently known vernacular book names and abbreviations, even if a book is deleted. Allows the user to customize book names and abbreviations for the project independently from the external resource data. When a Scripture book is added to Scripture, it gets its names and abbreviations from ScrBookRef. In the future ScrRefSystem may also be used to persist vernacular book names and abbreviations entered by the user in a canonical reference checking tool so that BCV references can be checked even for Scripture Books that do not yet exist as a ScrBook.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Books | 1 | sequence | ScrBookRef

Back references (sorted by attribute name)

Type Name Num Card Sig


ScrScriptureNote

test num:18 | abbrev: scsn | abstract: false | module: Scripture(num:3) | base: CmBaseAnnotation
 | A general annotation for Scripture, derived from CmBaseAnnotation. Has fields (owned StJournalText objects) widely used for annotating Scripture, e.g., translator notes, consultant notes.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | DateResolved | 8 | Time |
 | Date that this scripture note was changed to the resolved status.
test Basic | ResolutionStatus | 1 | Integer |
 | Place to indicate a status for whether and how the issue which the note concerns has been resolved. This is an open for enumeration for internal use whose meaning can change depending on the annotation type.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Categories | 2 | sequence | CmPossibility
 | Place to indicate zero to many standard categories to which the issue discussed in the note might belong. USB and CONNOT categories will be supplied on a factory installed list. This is an open (user modifiable) list.
test Owning | Discussion | 4 | atomic | StJournalText
 | The core contents of the note, the reviewer’s discussion (explanation) of the translation or interpretation issue. Not to be confused with the discussion between users in response to the note which is contained in the Responses collection.
test Owning | Quote | 3 | atomic | StJournalText
 | Quotation from the scripture text to indicate the topic of the note. May be in an analysis language, a vernacular language or both.
test Owning | Recommendation | 5 | atomic | StJournalText
 | The reviewer's summary recommendation concerning the issue. For consultant notes, may contain a suggested rendering, test questions to ask the translation team, or other specific course of action recommended.
test Owning | Resolution | 6 | atomic | StJournalText
 | The reviewer's description of how the issue raised in the note was resolved. Used in conjunction with the ResolutionStatus attribute when details are needed.
test Owning | Responses | 7 | sequence | StJournalText
 | Place to record discussion between the stakeholders in response to the note. In consultant notes, a two-way interchange between the consultant and consultee.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | ScrBookAnnotations:Notes | 2 | sequence | ScrScriptureNote
 | Scripture notes for this book of Scripture. These annotations include consultant notes, translator notes and also "error" annotations generated by checking tools.


ScrSection

test num:5 | abbrev: scsc | abstract: false | module: Scripture(num:3) | base: CmObject
 | A ScrSection represents a passage of Scripture. These are often given their own non-canonical headings in various published versions of the Bible. For example, in the NIV, Matthew 1:1-17 is ScrSection with the heading "The Genealogy of Jesus."

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | VerseRefEnd | 4 | Integer |
 | Refer to doc for VerseRefStart
test Basic | VerseRefMax | 6 | Integer |
 | The maximum book-chapter-verse reference found within the section. This is a calculated property, stored for processing convenience, not primary data.
test Basic | VerseRefMin | 5 | Integer |
 | The minimum book-chapter-verse reference found within the section. This is a calculated property, stored for processing convenience, not primary data.
test Basic | VerseRefStart | 3 | Integer |
 | VerseRefStart and VerseRefEnd are integers that contain book, chapter, and verse numbers in the form BBCCCVVV. Together these two properties indicate the range of references spanned by a Scripture section. Note that the the first two digits (the book part) should always be identical and is redundant since the ScrSection is owned by a ScrBook. Reasons for change: This change allows us to: a. Prepare to remove the Reference string from the StTxtPara object; b. Display appropriate references in the concordance for words that appear in section headings; c. Know what Scripture is covered by a particular section without parsing all the paragraphs it contains or accessing the ScrRef table; d. Prepare for the possibility of having chapter breaks embedded inside paragraphs.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Owning | Content | 2 | atomic | StText
 | A ScrSection has Content - the actual verses themselves. Content has a signature of StText allowing us to have multiple paragraphs, paragraph styles and character styles all of which will be used extensively for verse material. Chapter and verse references are character styles found in the Contents of the StTxtPara.
test Owning | Heading | 1 | atomic | StText
 | Headings are extra-canonical material used to help the reader know what a particular passage is about. Example: "The Genealogy of Jesus" for the passage (ScrSection) of Matthew 1:1-17. Although these are normally just a short-line, they sometimes are multi-lined including Headings and Subheadings. Thus the signature here is a StText - allowing us to have multiple paragraphs, paragraph styles and character styles.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | ScrBook:Sections | 1 | sequence | ScrSection
 | A ScrBook is made up of ScrSections. ScrSections represent short passages of Scripture. For example, Matthew 1:1-17 in the NIV is a ScrSection with a heading of "The Genealogy of Jesus."


ScrTxtPara

num:21 abbrev: ScTP abstract: false module: Scripture(num:3) base: StTxtPara

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


Segment

test num:6 | abbrev: seg | abstract: false | module: Cellar(num:0) | base: Note CmObject
 | Represents a sentence or segment length part of a paragraph.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | BeginOffset | 1 | Integer |
Basic | FreeTranslation | 2 | MultiString-big |
Basic | LiteralTranslation | 3 | MultiString-big |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Analyses | 6 | sequence | CmObject
Refer | Analyses | 5 | sequence | CmObject
Owning | Notes | 4 | collection | Note
Owning | Notes | 4 | sequence | Note

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | ConstChartWordGroup:BeginSegment | 1 | atomic | Segment
 | If BeginSegment is null, then there are no words in the WordGroup and this represents a User-entered marker indicating the User wants a special "missing" marker to show up in this cell highlighting that fact that nothing occurs in this cell (presumably because normally there would be something in this column). [Presentation note: currently this is displayed as "---".]
Refer'd by | TextTag:BeginSegment | 1 | atomic | Segment
Refer'd by | ConstChartWordGroup:EndSegment | 2 | atomic | Segment
Refer'd by | TextTag:EndSegment | 2 | atomic | Segment
Owned by | StTxtPara:Segments | 6 | sequence | Segment
Owned by | StTxtPara:Segments | 6 | sequence | Segment


StFootnote

num:39 abbrev: stfn abstract: false module: Cellar(num:0) base: StText

Direct Subclasses

  • ScrFootnote

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | FootnoteMarker | 1 | String |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


StJournalText

test num:68 | abbrev: stjt | abstract: false | module: Cellar(num:0) | base: StText
 | Text object for texts that must be signed and dated by the content creator. Intended for journal-type data entries where it is important to account for what changes were made and when they were made and by whom. Originally implemented for use with Scripture annotations.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | DateCreated | 1 | Time |
 | The displayed date when the journal entry was originally created.
test Basic | DateModified | 2 | Time |
 | The displayed date that the journal entry was last modified.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | CreatedBy | 3 | atomic | CmPerson
 | From a list of users, the person who created the journal entry.
test Refer | ModifiedBy | 4 | atomic | CmPerson
 | From a list of users, the person who last modified the journal entry.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | ScrScriptureNote:Discussion | 4 | atomic | StJournalText
 | The core contents of the note, the reviewer’s discussion (explanation) of the translation or interpretation issue. Not to be confused with the discussion between users in response to the note which is contained in the Responses collection.
test Owned by | ScrScriptureNote:Quote | 3 | atomic | StJournalText
 | Quotation from the scripture text to indicate the topic of the note. May be in an analysis language, a vernacular language or both.
test Owned by | ScrScriptureNote:Recommendation | 5 | atomic | StJournalText
 | The reviewer's summary recommendation concerning the issue. For consultant notes, may contain a suggested rendering, test questions to ask the translation team, or other specific course of action recommended.
test Owned by | ScrScriptureNote:Resolution | 6 | atomic | StJournalText
 | The reviewer's description of how the issue raised in the note was resolved. Used in conjunction with the ResolutionStatus attribute when details are needed.
test Owned by | ScrScriptureNote:Responses | 7 | sequence | StJournalText
 | Place to record discussion between the stakeholders in response to the note. In consultant notes, a two-way interchange between the consultant and consultee.


StPara

test num:15 | abbrev: spar | abstract: true | module: Cellar(num:0) | base:
 | An abstract class used to group the StParagraph and StTable classes

Direct Subclasses

  • StTxtPara

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | StyleRules | 2 | TextPropBinary |
 | When the user applies formatting to a specific paragraph apart from using a pre-defined style, that formatting information is stored here. It includes information such as font, font style, margins, etc.

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | ScrDifference:RevParagraph | 6 | atomic | StPara
 | the paragraph in the revision that the difference is in.


StStyle

test num:17 | abbrev: ssty | abstract: false | module: Cellar(num:0) | base: CmObject
 | Represents a style used to display a kind of paragraph

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Context | 11 | Integer
The high level structure to which the application of a style is limited. To be enumerated as follows: stcnGeneral – indicating Not limited to a single context. stcnText – The main text (eg. of scripture). stcnScrIntro – Introduction to a book of scripture stcnScrAnnotation – Annotation to the scripture text (e.g. consultant notes) stcnFigure – Captions, etc. associated with graphic elements stcnInternal – Styles that are applied by the program and modifiable by the user stcnScrTitle – The title of a scripture book. (others as needed)
test Basic | Function | 13 | Integer
Tthe functional context for a style within a given structural context (presently only defined for section ‘body’ structures). To be enumerated as follows: stusProse - indicating prose within a section body structure stusLine - indicating poetry within a section body structure stusList - indicating a list within a section body structure stusTable - indicating a table within a section body structure stusChapter - indicating a reference chapter number within a scripture section body structure stusVerse - indicating a reference verse number within a scripture section body structure null - indicating Style is unrestricted for use within the context and structure. (others as needed)
test Basic | IsBuiltIn | 7 | Boolean
TRUE means this style was in the default FW style sheet and that the user will not be allowed to delete or rename these styles; FALSE means this style was added by the user. For further discussion, see below: John W. (Mar 20, 2002) adds that in the "Default Style Sheet" specification, we talk about "factory" styles: "This document describes the style sheet that will ship with the FieldWorks Translation Editor. Generally speaking, users can add, modify or delete styles; this document is concerned with the style sheet as it is installed from the factory, and thus the "factory styles" which cannot be renamed or deleted.. There are two sets of styles, one for published materials (Scripture text, introductions, etc.) and one for non-published materials (back translation, consultant notes, etc.) For the former we started with the main styles found in the Paratext stylesheet for the TEV, and modified it as is appropriate for the FieldWorks environment. For the styles listed below (that is, in the specification refered to by John W.) 1. The user will not be permitted to rename or delete these. 2. The user is permitted to change their attributes, including paragraph, font, etc. 3. The user is permitted to edit their "Usage" attribute. " Ken Z. added on Mar 20, 2002: We need some way of saying that certain styles are used by code, and thus can't be deleted or renamed. I believe this might be done right now by hard coding these style names in the styles dialog to keep them from being changed. It seems like IsBuiltIn should be able to serve this function so that we can designate certain styles as built-in and therefore guaranteed to always be there. Unless Bryan or someone else sees a reason not to do this, I think we should add this to the specification. As such, it will be used by more than just the Translation Editor. Ken Z. also notes the following: As for Lela-Teli sample styles, they should not have the IsBuiltIn property set even though they are delivered "from the factory". From all responses, I think it is safe to say that any style that has the IsBuiltIn flag set should not be deleted or renamed by any program.
test Basic | IsModified | 8 | Boolean
This applies only to built-in styles; TRUE means the user changed its properties.
test Basic | IsPublishedTextStyle | 6 | Boolean
TRUE = the style is for use in published text; FALSE = the style is for non-published text
Basic | Name | 1 | Unicode
Basic | Rules | 5 | TextPropBinary
test Basic | Structure | 12 | Integer
The substructure of a Context to which the application of a style is limited. (Presently only used to distinguish the substructures of scripture sections.) To be enumerated as follows: ststHeading - indicating The Heading of a scripture or scripture introduction section. ststContent - indicating The Content of a scripture or scripture introduction section. null - indicating Style is unrestricted for use within this context. (others as needed)
Basic | Type | 4 | Integer | min: 0 | max:255
test Basic | Usage | 14 | MultiUnicode
A description of the expected usage of the style, displayed on the General tab in the Style dialog.
test Basic | UserLevel | 9 | Integer
A number 0-4 indicating the level of user likely to use this style. Default = 0

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | BasedOn | 2 | atomic | StStyle
Refer | Next | 3 | atomic | StStyle

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | StStyle:BasedOn | 2 | atomic | StStyle
Refer'd by | StStyle:Next | 3 | atomic | StStyle
test Refer'd by | ScrMarkerMapping:Style | 10 | atomic | StStyle
 | Style to apply to data in an internal text stream. Ignored of Target is <> 0.
test Owned by | Scripture:Styles | 2 | collection | StStyle
 | Scripture requires text style attributes that are uniquely different from styles for general documents in the project. This new style sheet (collection of styles) can be structured just like the style sheet in the Language Project, but is used for all texts authored in the Scripture Editor - Drafts, Back Translations, Notes, UNS Questions, etc. This allows us to: a. utilize styles that are specific for Scripture use; b. avoid conflicts with the LangProject style sheet if, for example, a Style named 'Paragraph' is desired for both general documents and Scripture
Owned by | LangProject:Styles | 23 | collection | StStyle


StText

test num:14 | abbrev: stxt | abstract: false | module: Cellar(num:0) | base: CmObject
 | An object used to represent a moderately structured text (a sequence of styled paragraphs).

Direct Subclasses

  • StFootnote
  • StJournalText

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | RightToLeft | 2 | Boolean |
 | Specifies whether the overall document direction for this structured text is right-to-left (true) or not (false).

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Paragraphs | 1 | sequence | StTxtPara
Owning | Paragraphs | 1 | sequence | StTxtPara
Owning | Tags | 3 | collection | TextTag

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | DsConstChart:BasedOn | 1 | atomic | StText
 | The linguistic text that the chart organizes (currently part of a Text, but could also be part of Scripture).
test Owned by | RnGenericRec:Conclusions | 21 | atomic | StText
 | A summary of the results of the research.
test Owned by | ScrSection:Content | 2 | atomic | StText
 | A ScrSection has Content - the actual verses themselves. Content has a signature of StText allowing us to have multiple paragraphs, paragraph styles and character styles all of which will be used extensively for verse material. Chapter and verse references are character styles found in the Contents of the StTxtPara.
Owned by | LexAppendix:Contents | 1 | atomic | StText
Owned by | Text:Contents | 8 | atomic | StText
Owned by | PhPhonContext:Description | 2 | atomic | StText
test Owned by | RnGenericRec:Description | 29 | atomic | StText
 | The content of the event.
test Owned by | CmPossibility:Discussion | 12 | atomic | StText
 | Any pertinent discussion for this Possibility.
test Owned by | RnGenericRec:Discussion | 32 | atomic | StText
 | Any pertinent discussion relating to the hypothesis.
test Owned by | RnGenericRec:ExternalMaterials | 13 | atomic | StText
 | A listing of any external sources, such as tape or video records, pictures in a scrapbook, etc.
test Owned by | RnGenericRec:FurtherQuestions | 14 | atomic | StText
 | Questions that have arisen as a result of trying to prove a hypothesis or when examining an event record. These may be used later in elicitation sessions or become the bases of new hypotheses.
test Owned by | ScrSection:Heading | 1 | atomic | StText
 | Headings are extra-canonical material used to help the reader know what a particular passage is about. Example: "The Genealogy of Jesus" for the passage (ScrSection) of Matthew 1:1-17. Although these are normally just a short-line, they sometimes are multi-lined including Headings and Subheadings. Thus the signature here is a StText - allowing us to have multiple paragraphs, paragraph styles and character styles.
test Owned by | RnGenericRec:Hypothesis | 22 | atomic | StText
 | A statement of the hypothesis.
Owned by | LexDb:Introduction | 12 | atomic | StText
Owned by | CmAgent:Notes | 4 | atomic | StText
test Owned by | RnGenericRec:PersonalNotes | 31 | atomic | StText
 | Notes of a personal, perhaps non-publishable nature. You know ... personal frustrations, swear words and the like that you want to hide when your administrator checks your work.
test Owned by | RnGenericRec:ResearchPlan | 23 | atomic | StText
 | A plan for researching the hypothesis. Eventually we will tie this into project management; for now we just supply a text description.
test Owned by | CmAnnotation:Text | 7 | atomic | StText
 | To handle multiparagraph annotations.
test Owned by | ScrBook:Title | 4 | atomic | StText
 | The Title can be a sequence of paragraphs. We might thus have a paragraph style for Main Title and for SubTitles to support titles like: The <SubTitlePrevious> Acts <MainTitle> of the Apostles <SubTitleFollowing>
test Owned by | RnGenericRec:VersionHistory | 2 | atomic | StText
 | A collection of versions that the record has gone through. This includes an archival of previous versions of the actual records.


StText

num: abbrev: abstract: false module: Cellar(num:0) base:

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type Name Num Card Sig


StTxtPara

test num:16 | abbrev: tpar | abstract: false | module: Cellar(num:0) | base: StPara
 | This represents a standard paragraph found in text.

Direct Subclasses

  • ScrTxtPara

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Contents | 2 | String-big |
 | The string of text found within a paragraph. The signature here is bigString which allows for embedded formatting and language encodings.
test Basic | Label | 1 | String |
 | Label to appear at start of paragraph (in margin, if negative first line indent). Note: This attribute is not currently used. John Thomson's original intent was to use it for the kind of paragraph that has something hanging out in the left margin that isn't predictable (as a bullet or number is) from the stylesheet. The classic example would be a list of terms, with the term sticking out to the left. Since we don't yet have tabs implemented, we could set things up to allow the main body of the paragraph to be aligned, and the label out in the margin.
test Basic | ParselsCurrent | 3 | Boolean |
 | This would be set true whenever the paragraph is parsed (tokenized), and false whenever it is edited (changes to StTxtPara.Contents or StText.Paragraphs). This allows us to re-parse only the texts that need it, now that the parser always makes real, persistent annotations.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | ObjRefs | 6 | collection | CmObject
 | For Scripture, by convention this refers to ScrRef objects (a subclass of CmObject). In other texts we might possibly have a use for referring to other targets--for example, ChoicesListItems like OCM codes, if we decided to go down to the paragraph level but didn't want to go all the way to tagging phrases. This could also foreseeably be used for referencing schemes for vernacular text (apart from a Scripture referencing system). It also avoids the philosophical problem of having a property unique to Scripture on a very general-purpose object.
test Refer | TextObjects | 4 | sequence | CmObject
 | The Contents of StTxtPara are parsed into TextObjects. The event that triggers parsing is yet to be determined but will probably be when the StTxtPara loses focus. Parsed objects include Wordforms, Punctuation, and References (including ScrRefs if the contents are translated Scripture). A sequence of references are set to each of these objects as they are found in their respective inventories (Wordform Inventory, Punctuation Inventory, and ReferenceScheme) This attribute exists in order to allow for a concordance by WfiWordform, (currently including punctuation), PunctuationForm and/or ScrRef. This attribute is a "lite" version of AnalyzedTextObjects. This attribute should only be used if a particular application of StTxtPara requires concordances.
test Owning | AnalyzedTextObjects | 5 | sequence | CmObject
 | AnalyzedTextObjects is used when there are associated analyses with any objects in the text. It is primarily meant for morphological interlinear analysis of text. Reference pointers to TxtWordformInContext (one for every word, punctuation and reference in the text) are set in a sequence. Note: the name of the class will likely change to TxtObjInContext because it handles more than just words. Refer to the documentation on TxtWordformInContext for more information. This attribute is used only if the application requires it. It does not obviate the need for TextObjects
Owning | Segments | 6 | sequence | Segment
Owning | Segments | 6 | sequence | Segment
test Owning | Translations | 8 | collection | CmTranslation
 | Refer to the documentation on LpTranslation.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | StText:Paragraphs | 1 | sequence | StTxtPara
Owned by | StText:Paragraphs | 1 | sequence | StTxtPara


Text

test num:54 | abbrev: text | abstract: false | module: Ling(num:5) | base: CmMajorObject
 | This Text object will probably be replaced by RnEvent or a new subclass of RnEvent (Larry Hayashi, May 6, 2004).

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Abbreviation | 10 | MultiUnicode |
 | This abbreviation is used when referencing segments from the text.
test Basic | IsTranslated | 11 | Boolean |
 | The user will set this for texts that have translated material as opposed to original texts.
Basic | SoundFilePath | 3 | Unicode |
Basic | Source | 2 | MultiString |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
test Refer | Genres | 9 | collection | CmPossibility
 | This associates a text with any number of genres.
Owning | Contents | 8 | atomic | StText

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:Texts | 6 | collection | Text


TextTag

num:22 abbrev: tt abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | BeginAnalysisIndex | 3 | Integer |
 | These indices refer to the index of an IAnalysis object in a Segment.Analyses sequence.
test Basic | EndAnalysisIndex | 4 | Integer |
 | These indices refer to the index of an IAnalysis object in a Segment.Analyses sequence.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | BeginSegment | 1 | atomic | Segment
Refer | EndSegment | 2 | atomic | Segment
Refer | Tag | 5 | atomic | CmPossibility

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | StText:Tags | 3 | collection | TextTag


UserAppFeatAct

test num:41 | abbrev: uafa | abstract: false | module: Cellar(num:0) | base:
 | Renamed from UserAppFeatureActivated for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | ActivatedLevel | 4 | Integer |
test Basic | ApplicationId | 2 | Guid |
 | From AppCompat$? Which apps are installed? Look in registry?
test Basic | FeatureId | 3 | Integer |
 | An application returns a hard-coded array of its available features. Features have ids that are referenced in this FeatureId field. UserConfigAccount, ApplicationId, FeatureId form a unique key for the object.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | UserConfigAcct | 1 | collection | UserConfigAcct

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:ActivatedFeatures | 46 | collection | UserAppFeatAct


UserConfigAcct

test num:40 | abbrev: ucac | abstract: false | module: Cellar(num:0) | base: CmObject
 | Renamed from UserConfigAccount for Firebird port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | HasMaintenance | 3 | Boolean |
test Basic | Sid | 1 | Binary |
 | Same as Sid in the Syslogins table in the master DB.
test Basic | UserLevel | 2 | Integer |
 | Beginner = 1, Intermediate = 3, Advanced = 5

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | LangProject:UserAccounts | 45 | collection | UserConfigAcct
Refer'd by | UserAppFeatAct:UserConfigAcct | 1 | collection | UserConfigAcct


UserView

num:18 abbrev: uvw abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | App | 3 | Guid |  |
Basic | Details | 5 | Binary |  |
Basic | Name | 1 | MultiUnicode |  |
Basic | SubType | 7 | Integer |  |
Basic | System | 6 | Boolean |  |
Basic | Type | 2 | Integer | min: 0 | max:127

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Records | 4 | collection | UserViewRec

Back references (sorted by attribute name)

Type Name Num Card Sig


UserViewField

num:20 abbrev: uvf abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Details | 9 | Binary |  |
Basic | Flid | 4 | Integer |  |
Basic | HelpString | 2 | MultiUnicode |  |
Basic | IsCustomField | 11 | Boolean |  |
Basic | Label | 1 | MultiUnicode |  |
Basic | Required | 6 | Integer | min: 0 | max:127
Basic | Style | 7 | Unicode |  |
Basic | Type | 3 | Integer | min: 0 | max:127
Basic | Visibility | 5 | Integer | min: 0 | max:127
Basic | WritingSystem | 13 | Unicode |  |
test Basic | WsSelector | 14 | Integer |  |
 | Refer to documentation on CmPossibilityList_WsSelector.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | PossList | 12 | atomic | CmPossibilityList
Refer | SubfieldOf | 8 | atomic | UserViewField

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | UserViewRec:Fields | 3 | sequence | UserViewField
Refer'd by | UserViewField:SubfieldOf | 8 | atomic | UserViewField


UserViewRec

num:19 abbrev: uvr abstract: false module: Cellar(num:0) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Clsid | 1 | Integer |  |
Basic | Details | 4 | Binary |  |
Basic | Level | 2 | Integer | min: 0 | max:127

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Fields | 3 | sequence | UserViewField

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | UserView:Records | 4 | collection | UserViewRec


WfiAnalysis

test num:59 | abbrev: ana | abstract: false | module: Ling(num:5) | base: CmObject
 | The WfiAnalysis class contains an analysis for a given wordform, which is defined as how to make morpheme cuts on the wordform, a part of speech for the wordform, plus a sequence of one or more corresponding interpretations of te analysis. Thus English bears would have one analysis related to the animal, and another related to the verb to carry.

Basic Attributes (sorted by attribute name)

Type Name Num Signature Other

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Category | 3 | atomic | PartOfSpeech
test Refer | CompoundRuleApps | 12 | sequence | MoCompoundRule
 | Allows Morph Sketch Generator to extract example wordforms where a compound rule applied.
test Refer | InflTemplateApps | 13 | sequence | MoInflAffixTemplate
 | Allows Morph Sketch Generator to extract example wordforms where an inflectional template is used. Changed from InflectionalTemplateApps.
test Refer | Stems | 5 | collection | LexEntry
 | In a thorough analysis this attribute will not be used. However, if the linguist wishes to only analyze stems this is an easy way to accomplish this.
Owning | Derivation | 6 | atomic | MoDeriv
Owning | Meanings | 10 | collection | WfiGloss
Owning | MorphBundles | 11 | sequence | WfiMorphBundle
test Owning | MsFeatures | 4 | atomic | FsFeatStruc
 | WfiAnalysis parallels MorphoSyntacticItem in the lexical database. Allowing MSFeatures here allows the user to easily convert a wordform to a subentry. This also supports S2W in that a user may know the features that a wordform bears but not its component parts (e.g may know that it's plural without knowing what the plural morpheme is). Additionally, in the case of suppletion, there may not be a morpheme to identify.

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | WfiWordform:Analyses | 2 | collection | WfiAnalysis
test Refer'd by | CmAgentEvaluation:Evaluations | 14 | collection | WfiAnalysis
 | Refers to either the Approves or Disapproves evaluations of various agents to indicate that the agent does or does not approve this analysis.


WfiGloss

test num:60 | abbrev: glos | abstract: false | module: Ling(num:5) | base: CmObject
 | The WfiGloss class contains a meaning of the parent interpretation. For example, the senses in the parent interpretation might be 3S-Carry; the meanings could then be 'he carries', 'she carries', 'it carries'.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Form | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type Name Num Card Sig

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Refer'd by | ChkRendering:Meaning | 2 | atomic | WfiGloss
 | The literal meaning of the vernacular term or phrase used for rendering the ChkTerm. This will be displayed as the back translation of the vernacular rendering. This is optional, but when supplied (by the user) must be one of the glosses for one of the senses of the SurfaceForm.
Owned by | WfiAnalysis:Meanings | 10 | collection | WfiGloss


WfiMorphBundle

num:112 abbrev: wmrb abstract: false module: Ling(num:5) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Form | 1 | MultiString |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Morph | 2 | atomic | MoForm
Refer | Msa | 3 | atomic | MoMorphSynAnalysis
Refer | Sense | 4 | atomic | LexSense

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | WfiAnalysis:MorphBundles | 11 | sequence | WfiMorphBundle


WfiWordform

test num:62 | abbrev: wfm | abstract: false | module: Ling(num:5) | base: CmObject
 | The WfiWordform class contains information about an individual wordform, including its various analyses.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
test Basic | Checksum | 4 | Integer |  |
 | We calculate a checksum based on the result string returned from the parser. If this value has changed from the last time, we file the new results. Otherwise, we leave the results alone.
test Basic | Form | 1 | MultiUnicode |  |
 | The form of the word. This is multiUnicode in order to allow the user to encode the wordform in more than one encoding (for example, in Japanese a word can be encoded in Kanji, Hiragana, Katakana or Romanji).
test Basic | SpellingStatus | 3 | Integer | min: 0 | max:2
 | The current status of a wordform (e.g. undecided, correct, incorrect). This will be used to display and allow the changing of a word's status in the concordance view of the translation editor.

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Analyses | 2 | collection | WfiAnalysis

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | WfiWordSet:Cases | 4 | collection | WfiWordform
test Refer'd by | ChkRef:Rendering | 5 | atomic | WfiWordform
 | The target vernacular rendering of the checking item at this reference.
test Refer'd by | ChkRendering:SurfaceForm | 1 | atomic | WfiWordform
 | A vernacular wordform that occurs in the text and is a valid equivalent for rendering the term that owns this ChkRendering object. This is required to be filled in when a ChkRendering is created.


WfiWordSet

num:105 abbrev: wwst abstract: false module: Ling(num:5) base: CmObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | Description | 2 | MultiString |
Basic | Name | 1 | MultiUnicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | Cases | 4 | collection | WfiWordform

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
test Owned by | MoMorphData:TestSets | 6 | collection | WfiWordSet
 | WfiWordSets are a collection of words that the user might want to use to test his word grammar as he adjusts morphological rules and the lexicon.


WordFormLookup

test num:64 | abbrev: wli | abstract: false | module: Ling(num:5) | base: CmObject
 | Renameed from WordformLookupItem for the Firebird Port.

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | AnthroCentral | 4 | Integer | min: 0 | max:32768
Basic | Form | 1 | String |  |
Basic | ThesaurusCentral | 2 | Integer | min: 0 | max:32768

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Refer | AnthroCodes | 5 | collection | CmAnthroItem
Refer | ThesaurusItems | 3 | collection | CmPossibility

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Owned by | WordformLookupList:Wordforms | 1 | collection | WordFormLookup


WordformLookupList

num:65 abbrev: wll abstract: false module: Ling(num:5) base: CmMajorObject

Basic Attributes (sorted by attribute name)

Type | Name | Num | Signature | Other
Basic | WritingSystem | 3 | Unicode |

Owning and reference attributes (sorted by type and then attribute name)

Type | Name | Num | Card | Sig
Owning | Wordforms | 1 | collection | WordFormLookup

Back references (sorted by attribute name)

Type | Name | Num | Card | Sig
Refer'd by | LangProject:WordformLookupLists | 11 | collection | WordformLookupList


Association Slots Report

View: | Hide Browser | Browser on the left | Browser on the right | Dictionary
Report: | General Info | Association Ends | Tagged Values

Association Slots

General Info
Name | Slots
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffMsa
End B | <unnamed> | 0..* | MoInflAffixSlot

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffMsa
Association | Slots
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlot
Association | Slots
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association LexemeForm Report

Report: | General Info | Association Ends | Tagged Values

Association LexemeForm

The lexeme form is the form of the entry that is normally used by linguists in interlinear text. The lexeme form is either the default allomorph for this lexEntry (e.g. French 'march' as opposed to citation form 'marcher') or the abstract underlying representation of it. (e.g. -[C][V]^2) When it is an abstract representation, the IsAbstract property is set. The lexeme form is equivalent to the base form in LinguaLinks or the \lx field in MDF files.

General Info
Name | LexemeForm
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntry
End B | <unnamed> | 1 | MoForm

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 29 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | LexemeForm
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoForm
Association | LexemeForm
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AlternateForms Report

Report: | General Info | Association Ends | Tagged Values

Association AlternateForms

This holds alternate forms, or allomorphs, in addition to the lexeme form. The lexeme form is also an allomorph if it is not abstract. These forms along with the lexeme form (when not abstract) are used by the parser.

General Info
Name | AlternateForms
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntry
End B | <unnamed> | 0..* | MoForm

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 30 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | AlternateForms
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoForm
Association | AlternateForms
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Pictures Report

Report: | General Info | Association Ends | Tagged Values

Association Pictures

General Info
Name | Pictures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | CmPicture

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | Pictures
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPicture
Association | Pictures
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association OverridingMsa Report

Report: | General Info | Association Ends | Tagged Values

Association OverridingMsa

Any attribute specified in this msa will override the corresponding attribute of the head msa of the compound.

General Info
Name | OverridingMsa
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoEndoCompound
End B | <unnamed> | 1 | MoStemMsa

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoEndoCompound
Association | OverridingMsa
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | OverridingMsa
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ProdRestrict Report

Report: | General Info | Association Ends | Tagged Values

Association ProdRestrict

This reflects what is also referred to as exception features in the literature. It defines class identifiers that can be associated with non-productive derivational or inflectional affixes that only go on stems that belong to the same class. An example from English is the feature [+Latinate], marking that part of the English vocabulary which is etymologically derived from Latin, and which has certain synchronic properties. For example, the suffix -ity attaches only to [+Latinate] stems (Aronoff 1976: 51): felicity, vivacity, *widity, *strongity. The similar suffix -ness, on the other hand, attaches to more or less all adjectives regardless of this feature. Similar restrictions are apparently found in other languages which have undergone substantial borrowing, e.g. Mohawk and Dutch are said to have restrictions which depend on whether or not stems were borrowed from French. Maybe there are other sources of such restrictions as well. These restrictions cannot be handled by inflection classes. The reason is that inflection classes and exception features are likely to be cross-cutting distinctions. Changed from ProductivityRestrictions

General Info
Name | ProdRestrict
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphData
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 9 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphData
Association | ProdRestrict
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | ProdRestrict
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ProdRestrict Report

Report: | General Info | Association Ends | Tagged Values

Association ProdRestrict

Refers to a collection of CmPossibility, giving any exceptional properties of the stem that relate to restricting the productivity of affixes. (Other terms for this are 'exception features,' 'rule features' and 'ad hoc features'.) Usually these represent restrictions which are shared among a set of more than two morphemes (unlike AMPLE's 'ad hoc pairs', which concern a pair of morphemes). An example from English is the feature [+Latinate], marking that part of the English vocabulary which is etymologically derived from Latin, and which has certain synchronic properties. For example, the suffix -ity attaches only to [+Latinate] stems (Aronoff 1976: 51): felicity, vivacity, *widity, *strongity The similar suffix -ness, on the other hand, attaches to more or less all adjectives regardless of this feature. Similar restrictions are apparently found in other languages which have undergone substantial borrowing, e.g. Mohawk and Dutch are said to have restrictions which depend on whether or not stems were borrowed from French. Maybe there are other sources of such restrictions as well. These restrictions cannot be handled by inflection classes. The reason is that inflection classes and exception features are likely to be cross-cutting distinctions. Another sort of restriction for which exception features have sometimes been used, is for certain restricted (morpho-)phonological alternations, such as the Velar Softening rule of English (Chomsky and Halle 1968; Aronoff 1976: 51). However, this use is sometimes complicated by restrictions on adjacency, which cannot be easily modeled. An apparent alternative to exception features would be morphosyntactic features. However, exception features are (by definition) invisible to the syntax, and the use of morphosyntactic features for this purpose could incorrectly prevent unification of features in syntax, e.g. if we build an NP consisting of a [+Latinate] noun and an [-Latinate] determiner. See also MoDerivationalAffixMsa.FromProductivityRestrictions. Do exception features percolate? There is some inconclusive discussion of this in Aronoff 1976: 52. Note that the answer to this will not directly affect the domain model, only the parser and generator (unless we decide to leave it up to the user, and put a toggle somewhere). See also note under MoDerivationalAffixMsa. Changed from ProductivityRestrictions.

General Info
Name | ProdRestrict
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemMsa
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | ProdRestrict
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | ProdRestrict
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ToProdRestrict Report

Report: | General Info | Association Ends | Tagged Values

Association ToProdRestrict

Specifies any restriction classes which the MoDerivationalStepMsa resulting from attaching this affix to a stem will bear (in its ProductivityRestrictions attribute). Specifically: if this attribute is non-empty, the stem resulting from the attachment of this affix will have these restriction classes as the value of its ProductivityRestrictions (overriding any restriction classes borne by the stem to which this affix attached). If on the other hand this attribute is empty, the ProductivityRestrictions of the output stem will be the same as those of the input stem. Changed from ToProductivityRestrictions.

General Info
Name | ToProdRestrict
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | ToProdRestrict
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | ToProdRestrict
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association FromProdRestrict Report

Report: | General Info | Association Ends | Tagged Values

Association FromProdRestrict

FromProductivityRestrictions: refers to a collection of CmPossibility, giving any restriction classes which the stem to which this affix attaches must bear. If this attribute is empty, this affix may attach to a stem regardless of what restriction classes the stem bears (see MoStemMsa.ProductivityRestrictions). If there are two or more restriction classes listed for this affix, then the stem must have at least all of these restriction classes in its MoStemMsa.ProductivityRestrictions attribute in order for this affix to attach to the stem. The stem could have more restriction classes, but not less. Changed from FromProductivityRestrictions.

General Info
Name | FromProdRestrict
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | FromProdRestrict
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | FromProdRestrict
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association FromProdRestrict Report

Report: | General Info | Association Ends | Tagged Values

Association FromProdRestrict

Refers to a collection of CmPossibility, giving any restriction classes which the stem to which this affix attaches must bear. If this attribute is empty, this affix may attach to a stem regardless of what restriction classes the stem bears (see MoStemMsa.ProductivityRestrictions). If there are two or more restriction classes listed for this affix, then the stem must have at least all of these restriction classes in its MoStemMsa.ProductivityRestrictions attribute in order for this affix to attach to the stem. The stem could have more restriction classes, but not less. (Note that unlike the case with MoDerivationalAffixMsa, there is no 'to productivity restrictions' attribute for inflectional affixes: inflectional affixes cannot add restriction classes to a word.) Changed from FromProductivityRestrictions.

General Info
Name | FromProdRestrict
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffMsa
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffMsa
Association | FromProdRestrict
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | FromProdRestrict
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ProdRestrict Report

Report: | General Info | Association Ends | Tagged Values

Association ProdRestrict

Specifies the restriction classes which the word has at this stage in the derivation. Changed from ProductivityRestrictions

General Info
Name | ProdRestrict
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivStepMsa
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivStepMsa
Association | ProdRestrict
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | ProdRestrict
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ToProdRestrict Report

Report: | General Info | Association Ends | Tagged Values

Association ToProdRestrict

refers to a collection of CmPossibility, giving any restriction classes which the stem resulting from this compound rule will bear. Specifically: if this attribute is non-empty, the stem resulting from this rule will have these restriction classes as the value of its ProductivityRestrictions (overriding any restriction classes borne by the daughter stems). If on the other hand this attribute is empty, the ProductivityRestrictions of the output stem will be the same as those of the head (for MoEndocentricCompounds) or empty (for MoExocentricCompounds). Changed from ToProductivityRestrictions.

General Info
Name | ToProdRestrict
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoCompoundRule
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoCompoundRule
Association | ToProdRestrict
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | ToProdRestrict
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Pronunciations Report

Report: | General Info | Association Ends | Tagged Values

Association Pronunciations

We may need more than one pronunciation per entry. For example either/neither have two different pronunciations. Some people may want to order these based on frequency of use, so it is a sequence instead of a collection.

General Info
Name | Pronunciations
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntry
End B | <unnamed> | 0..* | LexPronunciation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 31 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | Pronunciations
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexPronunciation
Association | Pronunciations
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmMedia


Association MediaFile Report

Report: | General Info | Association Ends | Tagged Values

Association MediaFile

Multiple CmMedia objects may reference a single media file, so this property is a reference to a file. CmFile. As with pictures, media files will be copied to root\media directory where root is determined by LangProject_ExtLinkRootDir, which defaults to c:\program files\FieldWorks if not set (or some other location?).

General Info
Name | MediaFile
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmMedia
End B | <unnamed> | 1 | CmFile

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmMedia
Association | MediaFile
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFile
Association | MediaFile
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Media Report

Report: | General Info | Association Ends | Tagged Values

Association Media

This contains a lit of folders holding media file objects. For now, we will have one CmFolder called "Local Media" that holds all media.

General Info
Name | Media
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | CmFolder

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 51 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Media
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFolder
Association | Media
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Location Report

Report: | General Info | Association Ends | Tagged Values

Association Location

Some pronunciations can be related to specific areas, so this points to the location list.

General Info
Name | Location
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexPronunciation
End B | <unnamed> | 1 | CmLocation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexPronunciation
Association | Location
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmLocation
Association | Location
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association MediaFiles Report

Report: | General Info | Association Ends | Tagged Values

Association MediaFiles

A pronunciation may have more than one media file to allow for a man's voice and a woman's voice, slight dialect differences, etc.

General Info
Name | MediaFiles
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexPronunciation
End B | <unnamed> | 0..* | CmMedia

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexPronunciation
Association | MediaFiles
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmMedia
Association | MediaFiles
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association PictureFile Report

Report: | General Info | Association Ends | Tagged Values

Association PictureFile

General Info
Name | PictureFile
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPicture
End B | <unnamed> | 1 | CmFile

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPicture
Association | PictureFile
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFile
Association | PictureFile
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ChkSense


Association Books Report

Report: | General Info | Association Ends | Tagged Values

Association Books

General Info
Name | Books
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrRefSystem
End B | <unnamed> | 0..* | ScrBookRef

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrRefSystem
Association | Books
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBookRef
Association | Books
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Sense Report

Report: | General Info | Association Ends | Tagged Values

Association Sense

In Scripture, a target lexical sense for a key term. More generically, a lexical sense associated with a checklist item. With the LexSense as a starting point, the stem, citation form, literal meaning, definition, gloss and likely inflectional word forms for the rendering can be determined. Note that we do not determine the lexical stem directly but rather make a semantic connection to it through the particular sense of the stem that is relevant to the ChkItem. We can always determine the stem from the sense but not vice versa.

General Info
Name | Sense
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ChkSense
End B | <unnamed> | 1 | LexSense

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ChkSense
Association | Sense
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | Sense
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ChkHistRecs Report

Report: | General Info | Association Ends | Tagged Values

Association ChkHistRecs

Records the date and results of the latest run of each check

General Info
Name | ChkHistRecs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrBookAnnotations
End B | <unnamed> | 0..* | ScrCheckRun

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBookAnnotations
Association | ChkHistRecs
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrCheckRun
Association | ChkHistRecs
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ScrCheckRun


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | LexEntryRef


Association EntryRefs Report

Report: | General Info | Association Ends | Tagged Values

Association EntryRefs

This property is empty for main entries. For variant and complex entries, one or more LexEntryRef is used to point to the major entries. One variant entry could apply to more than one main entry, so each one could have a separate LexEntryRef. It’s possible for an entry to be a complex entry as well as a variant. This could be represented by one or more LexEntryRefs. Some may want to order multiple entries in a particular way, so we have a sequence instead of a collection.

General Info
Name | EntryRefs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntry
End B | <unnamed> | 0..* | LexEntryRef

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 34 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | EntryRefs
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntryRef
Association | EntryRefs
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association ComponentLexemes Report

Report: | General Info | Association Ends | Tagged Values

Association ComponentLexemes

The UI limits this to a sequence of LexEntry or LexSense. For variants, this field points to the main entry or sense. When not hidden, this will produce a minor variant entry that always shows the main entry referenced here. This variant will always be shown in the main entry being referenced. ComponentLexemes is ignored in this case. For complex entries, this property lists the components for this idiom, derivation, compound, etc. All of the listed components will be displayed in the subentry following the headword. For example, emphanizoo (cmpd. of en, pha, -an, -id). Whether they get displayed as subentries is controlled by the PrimaryLexemes property. This allows the user to specify component lexemes for productive lexemes without cluttering the printed dictionary.]

General Info
Name | ComponentLexemes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntryRef
End B | <unnamed> | 0..* | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntryRef
Association | ComponentLexemes
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | ComponentLexemes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association VariantEntryTypes Report

Report: | General Info | Association Ends | Tagged Values

Association VariantEntryTypes

This Variant Entry Types list is used to classify a LexEntryRef via VariantEntryTypes. ItemClsid should be set to LexEntryType, IsSorted to true, and Depth to 127. The list is hierarchical with the top level being the type of variant (e.g., dialectal) and subitems being the conditions (e.g., British English, American English) for that type of variant. Normally the user will set this property to a subitem, although a top level item could be used if the user does not want to specify the condition. The user is free to provide additional nesting if useful. All items in the list will be LexEntryType, so the user will need to specify an appropriate Abbreviation and ReverseAbbr for each item in the list. This gives greater control to the user than having the program try to piece together information from a hierarchy of LexEntryTypes. The Abbreviation is used when displaying the main entry from the minor entry (e.g., Brit. dial. of color). The ReverseAbbr is used when displaying the minor entry from the main entry (e.g., Brit. dial. colour). Entries using this list will be displayed as minor entries in the dictionary; usually following the main entry headword and will typically produce a separate minor entry in the dictionary referring to the main entry. The initial list may have: Dialectal Variant British American Free Variant Inflectional Variant Singular Plural First Person Singular (1SG) Third Person Singular Present (3SG.PRES) Location New York Los Angeles Register Formal Informal Sociolect Upper Class Lower Class Spelling Variant

General Info
Name | VariantEntryTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 22 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | VariantEntryTypes
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | VariantEntryTypes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ComplexEntryTypes Report

Report: | General Info | Association Ends | Tagged Values

Association ComplexEntryTypes

This Complex Entry Types list is used to classify a LexEntryRef via the ComplexEntryTypes property. ItemClsid should be set to LexEntryType, IsSorted to true, and Depth to 127. The list will typically be flat, but the user is free to introduce a hierarchy if desirable. When entries use this list, they will be displayed as subentries in the dictionary. Entries using this list will be displayed as subentries in the dictionary; usually at the end of the major entry and will typically produce a separate major entry in the dictionary referring to the main entry. The display is dependent on whether a root-based or stem-based view of the dictionary is being printed. The initial list may have: Acronym Compound Contractions Derivation Idiom Phrasal Verb Saying

General Info
Name | ComplexEntryTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 23 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | ComplexEntryTypes
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | ComplexEntryTypes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association VariantEntryTypes Report

Report: | General Info | Association Ends | Tagged Values

Association VariantEntryTypes

This points to one or more LexEntryType items in the Variant Entry Types list for variant entries. It is unused for complex entries, although the model allows for both to be used if desirable. Normally a variant LexEntryRef will only use PrimaryLexemes to point to a single entry or sense. Entries using VariantEntryTypes will be displayed as minor entries in the dictionary; usually following the main entry headword and will typically produce a separate minor entry in the dictionary referring to the main entry. The LexEntryType is used to determine how to display the variant information in the main entry context as well as the minor entry context. The Variant Entry Types list is hierarchical with the top level being the type of variant (e.g., dialectal) and subitems being the conditions (e.g., British English, American English) for that type of variant. Normally the user will set this property to a subitem, although a top level item could be used if the user does not want to specify the condition. Each LexEntryType Abbreviation and ReverseAbbr should contain everything needed for displaying the references for this entry. Flex will not attempt to combine names from different hierarchical levels. The Abbreviation is used when displaying the main entry from the minor entry (e.g., Brit. dial. of color). The ReverseAbbr is used when displaying the minor entry from the main entry (e.g., Brit. dial. colour). This is a sequence because some minor entries can have more than one relationship to the same main entry. For example, colour is a spelling variant and a British dialectal variant. The user could use two LexEntryRefs to represent this, but it would be easier to use a single LexEntryRef with two VariantEntryTypes references.

General Info
Name | VariantEntryTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntryRef
End B | <unnamed> | 0..* | LexEntryType

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntryRef
Association | VariantEntryTypes
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntryType
Association | VariantEntryTypes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association ComplexEntryTypes Report

Report: | General Info | Association Ends | Tagged Values

Association ComplexEntryTypes

This property points to one or more items in the Complex Entry Types list for complex entries. It is unused for variant entries, although the model allows for both to be used if desirable. Normally a complex LexEntryRef will point to more than one main entry or sense via PrimaryLexemes and ComponentLexemes. Entries using ComplexEntryTypes will be displayed as subentries in the dictionary; usually at the end of the major entry and will typically produce a separate major entry in the dictionary referring to the main entry. The display is dependent on whether a root-based or stem-based view of the dictionary is being printed. The referenced LexEntryType is used to control the display of the complex information in the main entry context as well as the minor entry context. See the description of VariantEntryTypes for using the information from the LexEntryRef for display purposes.

General Info
Name | ComplexEntryTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntryRef
End B | <unnamed> | 0..* | LexEntryType

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntryRef
Association | ComplexEntryTypes
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntryType
Association | ComplexEntryTypes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association PrimaryLexemes Report

Report: | General Info | Association Ends | Tagged Values

Association PrimaryLexemes

The UI limits this to a sequence of LexEntry or LexSense. For variants, this field is unused. For complex entries, this field points to a subset of ComponentLexemes. The entries or senses in this property determine the main entries that will have subentries generated for this entry. For example, if ComponentLexemes has kick, the, bucket, and PrimaryLexemes only has kick, then kick is the only entry that will show a ‘kick the bucket’ subentry in a root-based display.

General Info
Name | PrimaryLexemes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntryRef
End B | <unnamed> | 0..* | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntryRef
Association | PrimaryLexemes
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | PrimaryLexemes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association PhFeatureSystem Report

Report: | General Info | Association Ends | Tagged Values

Association PhFeatureSystem

This feature system contains the phonological features used by phonological rules. They are kept separate from the morpho-syntactic features in the MsFeatureSystem attribute.

General Info
Name | PhFeatureSystem
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | FsFeatureSystem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 154 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | PhFeatureSystem
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatureSystem
Association | PhFeatureSystem
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association FeatConstraints Report

Report: | General Info | Association Ends | Tagged Values

Association FeatConstraints

The feature constraints are what allow us to use alpha notation in phonological rules (to deal with things like assimilation to place of articulation). It is a sequence so we can know the alpha value (is it alpha, beta, gamma, or delta, say). The user need never see these as a list to be edited or maintained by hand. The UI can show them as greek letters in phonological rule displays.

General Info
Name | FeatConstraints
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonData
End B | <unnamed> | 0..* | PhFeatureConstraint

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonData
Association | FeatConstraints
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhFeatureConstraint
Association | FeatConstraints
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association PhonRuleFeats Report

Report: | General Info | Association Ends | Tagged Values

Association PhonRuleFeats

The rule features are a way to limit the application of rules, either by excluding or requiring these "features." The CmPossibilityList contains zero or more PhPhonRuleFeat classes. These refer to a CmObject, where that CmObject would probably be a MoInflClass (e.g. a conjugation class), an FsSymFeatVal (e.g. feminine gender), or a CmPossibility (for an exception "feature").

General Info
Name | PhonRuleFeats
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonData
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonData
Association | PhonRuleFeats
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | PhonRuleFeats
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Features Report

Report: | General Info | Association Ends | Tagged Values

Association Features

The Features attribute is how the user provides the phonological features of a phoneme (phonological segment). This means that the features contained in the FsFeatStruc must be from LangProject:PhFeatureSystem.

General Info
Name | Features
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhoneme
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhoneme
Association | Features
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | Features
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhSegmentRule


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhSegRuleRHS


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | PhPhonRuleFeat


Association Item Report

Report: | General Info | Association Ends | Tagged Values

Association Item

This refers to a CmObject, where that CmObject would probably be a MoInflClass (e.g. a conjugation class), an FsSymFeatVal (e.g. feminine gender), or a CmPossibility (for an exception "feature"). Any such MoInflClass would be owned by a PartOfSpeech (or by a nested MoInflClass within a PartOfSpeech); any such FsSymFeatVal would be owned by an FsClosedFeature; and the exception "feature" CmPossibility would be in the possibility list owned by MoMorphData:ProdRestrict.

General Info
Name | Item
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonRuleFeat
End B | <unnamed> | 1 | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonRuleFeat
Association | Item
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | Item
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association PhonRules Report

Report: | General Info | Association Ends | Tagged Values

Association PhonRules

These are the ordered sequence of phonological rules. They are given in the order in which they are to be applied.

General Info
Name | PhonRules
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonData
End B | <unnamed> | 0..* | PhSegmentRule

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 | 7

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonData
Association | PhonRules
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegmentRule
Association | PhonRules
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association InitialStratum Report

Report: | General Info | Association Ends | Tagged Values

Association InitialStratum

The initial stratum to which this rule applies. If not specified, this rule applies to all strata.

General Info
Name | InitialStratum
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSegmentRule
End B | <unnamed> | 1 | MoStratum

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegmentRule
Association | InitialStratum
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratum
Association | InitialStratum
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association FinalStratum Report

Report: | General Info | Association Ends | Tagged Values

Association FinalStratum

The final stratum to which this rule applies.

General Info
Name | FinalStratum
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSegmentRule
End B | <unnamed> | 1 | MoStratum

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegmentRule
Association | FinalStratum
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratum
Association | FinalStratum
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association LeftContext Report

Report: | General Info | Association Ends | Tagged Values

Association LeftContext

The left context of the rule.

General Info
Name | LeftContext
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSegRuleRHS
End B | <unnamed> | 1 | PhPhonContext

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegRuleRHS
Association | LeftContext
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonContext
Association | LeftContext
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association RightContext Report

Report: | General Info | Association Ends | Tagged Values

Association RightContext

The right context of the rule.

General Info
Name | RightContext
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSegRuleRHS
End B | <unnamed> | 1 | PhPhonContext

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegRuleRHS
Association | RightContext
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonContext
Association | RightContext
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association StrucChange Report

Report: | General Info | Association Ends | Tagged Values

Association StrucChange

The structural change (i.e. the output) of the rule. If this is missing, the rule is a deletion rule

General Info
Name | StrucChange
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSegRuleRHS
End B | <unnamed> | 0..* | PhSimpleContext

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegRuleRHS
Association | StrucChange
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSimpleContext
Association | StrucChange
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association InputPOSes Report

Report: | General Info | Association Ends | Tagged Values

Association InputPOSes

When present, this limits the rule application to apply only when the input is for one of the Parts of Speech given in the collection. The hierarchical nature of Parts of Speech is respected, so if "transitive verb" is a sub-category of "verb" and one specifies "verb" as an input POS, then the rule will also apply to "transitive verb.

General Info
Name | InputPOSes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSegRuleRHS
End B | <unnamed> | 0..* | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegRuleRHS
Association | InputPOSes
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | InputPOSes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ExclRuleFeats Report

Report: | General Info | Association Ends | Tagged Values

Association ExclRuleFeats

This refers to a set of rule features (which are a possibility list). This encodes negative rule feature requirements, such as conjugation class membership or gender. In order for this rule to apply to a lexical entry, the lexical entry must not contain in its Rule Features list any of the feature names of this list. If this field is omitted, there are no excluded rule features. Warning: The names in the RequiredRuleFeatures list and this list should be mutually exclusive.

General Info
Name | ExclRuleFeats
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSegRuleRHS
End B | <unnamed> | 0..* | PhPhonRuleFeat

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegRuleRHS
Association | ExclRuleFeats
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonRuleFeat
Association | ExclRuleFeats
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ReqRuleFeats Report

Report: | General Info | Association Ends | Tagged Values

Association ReqRuleFeats

These are required rule features. This collection refers to a set of rule features (which are a possibility list). This encodes positive rule feature requirements, such as conjugation class membership or gender. In order for this rule to apply to a lexical entry, the lexical entry must contain in its Rule Features list all the feature names of this list. If this field is omitted, there are no required Rule Features. Warning: The names in the ExcludedRuleFeatures list and this list should be mutually exclusive.

General Info
Name | ReqRuleFeats
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSegRuleRHS
End B | <unnamed> | 0..* | PhPhonRuleFeat

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegRuleRHS
Association | ReqRuleFeats
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonRuleFeat
Association | ReqRuleFeats
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhSegmentRule
Child Element | PhRegularRule


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhSegmentRule
Child Element | PhMetathesisRule


Association RightHandSides Report

Report: | General Info | Association Ends | Tagged Values

Association RightHandSides

The right hand sides of the rule (i.e. the B, C, and D of the general formula (A -> B / C _ D).

General Info
Name | RightHandSides
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhRegularRule
End B | <unnamed> | 0..* | PhSegRuleRHS

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhRegularRule
Association | RightHandSides
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegRuleRHS
Association | RightHandSides
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association StrucDesc Report

Report: | General Info | Association Ends | Tagged Values

Association StrucDesc

For regular rules, this is the structural description of the rule (i.e the A in the general formula of A -> B / C _ D). If A is missing, then this is an insertion (epenthetic) rule. For metathesis rules, this is the structural description (i.e. the input) of the rule. Each ordered PhSimpleContext corresponds to a number (the index) that can be referred to in the structural change attribute.

General Info
Name | StrucDesc
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSegmentRule
End B | <unnamed> | 0..* | PhSimpleContext

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSegmentRule
Association | StrucDesc
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSimpleContext
Association | StrucDesc
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association TextMarkupTags Report

Report: | General Info | Association Ends | Tagged Values

Association TextMarkupTags

Top eval Possibilities are major tag categories ( Syntax, Semantics, RRG, etc.) The actual tags are their SubPossibilities [After V1, more hierarchy may be possible.]

General Info
Name | TextMarkupTags
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 55 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | TextMarkupTags
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | TextMarkupTags
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association SupportingEvidence Report

Report: | General Info | Association Ends | Tagged Values

Association SupportingEvidence

Data records which support the hypothesis.

General Info
Name | SupportingEvidence
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | RnGenericRec

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | SupportingEvidence
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | SupportingEvidence
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association CounterEvidence Report

Report: | General Info | Association Ends | Tagged Values

Association CounterEvidence

Data records which refute the hypothesis.

General Info
Name | CounterEvidence
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | RnGenericRec

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | CounterEvidence
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | CounterEvidence
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association SupersededBy Report

Report: | General Info | Association Ends | Tagged Values

Association SupersededBy

A hypothesis can be superceeded by another hypothesis; this attribute refers to that superceeding hypothesis.

General Info
Name | SupersededBy
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | RnGenericRec

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | SupersededBy
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | SupersededBy
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Status Report

Report: | General Info | Association Ends | Tagged Values

Association Status

An indication of the current status of the record. Included default possibilities include: Confirmed, Disproved, Pending

General Info
Name | Status
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Status
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Status
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Hypothesis Report

Report: | General Info | Association Ends | Tagged Values

Association Hypothesis

A statement of the hypothesis.

General Info
Name | Hypothesis
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Hypothesis
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Hypothesis
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Conclusions Report

Report: | General Info | Association Ends | Tagged Values

Association Conclusions

A summary of the results of the research.

General Info
Name | Conclusions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Conclusions
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Conclusions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Discussion Report

Report: | General Info | Association Ends | Tagged Values

Association Discussion

Any pertinent discussion relating to the hypothesis.

General Info
Name | Discussion
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Discussion
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Discussion
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ResearchPlan Report

Report: | General Info | Association Ends | Tagged Values

Association ResearchPlan

A plan for researching the hypothesis. Eventually we will tie this into project management; for now we just supply a text description.

General Info
Name | ResearchPlan
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | ResearchPlan
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | ResearchPlan
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Sources Report

Report: | General Info | Association Ends | Tagged Values

Association Sources

The person(s) who reported the event to the researcher.

General Info
Name | Sources
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | CmPerson

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Sources
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | Sources
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Participants Report

Report: | General Info | Association Ends | Tagged Values

Association Participants

A list of roles involved in the event and the participants who fill those roles. The user can specify participants directly in which case their role is assigned as unspecified.

General Info
Name | Participants
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | RnRoledPartic

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Participants
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnRoledPartic
Association | Participants
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Type Report

Report: | General Info | Association Ends | Tagged Values

Association Type

The type of event. Included possibilities include: Performance, Almanac, Conversation, Observation, Literature Summary.

General Info
Name | Type
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Type
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Type
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association TimeOfEvent Report

Report: | General Info | Association Ends | Tagged Values

Association TimeOfEvent

The time that the event occurred. The types of items in the list here can be vernacular words that capture how the culture captures different times during the day.

General Info
Name | TimeOfEvent
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | TimeOfEvent
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | TimeOfEvent
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Description Report

Report: | General Info | Association Ends | Tagged Values

Association Description

The content of the event.

General Info
Name | Description
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Description
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Description
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association PersonalNotes Report

Report: | General Info | Association Ends | Tagged Values

Association PersonalNotes

Notes of a personal, perhaps non-publishable nature. You know ... personal frustrations, swear words and the like that you want to hide when your administrator checks your work.

General Info
Name | PersonalNotes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | PersonalNotes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | PersonalNotes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | StFootnote
Child Element | ScrFootnote


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | StTxtPara
Child Element | ScrTxtPara


Association Locations Report

Report: | General Info | Association Ends | Tagged Values

Association Locations

A list of locations in which the event occurred.

General Info
Name | Locations
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | CmLocation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 24 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Locations
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmLocation
Association | Locations
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Interface Report

Report: | General Info

Interface <unnamed>

General Info
Name | <unnamed>
Visibility | public
Abstract | false
Leaf | false
Root | false


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PunctuationForm


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | Note


Stereotype port Report

Report: | General Info

Stereotype port

General Info
Name | port
Base Classes | Attribute
Abstract | false
Leaf | false
Root | false


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | Segment


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | TextTag


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ConstituentChartCellPart


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ConstChartRow


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | ConstituentChartCellPart
Child Element | ConstChartWordGroup


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | ConstituentChartCellPart
Child Element | ConstChartMovedTextMarker


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | ConstituentChartCellPart
Child Element | ConstChartTag


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | ConstituentChartCellPart
Child Element | ConstChartClauseMarker


Class Diagram

Report: | General Info

Class Diagram Tagging

StText StTxtPara Paragraphs Paragraphs TextTag CmPossibility Tag Tag Tags Tags Note CmObject PunctuationForm EndSegment EndSegment Segment Notes Notes Segments Segments Analyses Analyses BeginSegment BeginSegment

General Info
Name | Tagging
Type | Class Diagram


Association Paragraphs Report

Report: | General Info | Association Ends | Tagged Values

Association Paragraphs

General Info
Name | Paragraphs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StText
End B | <unnamed> | 0..* | StTxtPara

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Paragraphs
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StTxtPara
Association | Paragraphs
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association EndSegment Report

Report: | General Info | Association Ends | Tagged Values

Association EndSegment

General Info
Name | EndSegment
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | TextTag
End B | <unnamed> | 1 | Segment

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | TextTag
Association | EndSegment
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Segment
Association | EndSegment
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Tag Report

Report: | General Info | Association Ends | Tagged Values

Association Tag

General Info
Name | Tag
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | TextTag
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | TextTag
Association | Tag
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Tag
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Tags Report

Report: | General Info | Association Ends | Tagged Values

Association Tags

General Info
Name | Tags
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StText
End B | <unnamed> | 0..* | TextTag

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Tags
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | TextTag
Association | Tags
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Notes Report

Report: | General Info | Association Ends | Tagged Values

Association Notes

General Info
Name | Notes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Segment
End B | <unnamed> | 0..* | Note

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Segment
Association | Notes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Note
Association | Notes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Rows Report

Report: | General Info | Association Ends | Tagged Values

Association Rows

The main content of the chart. Each ConstChartRow represents a row/clause.

General Info
Name | Rows
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | DsConstChart
End B | <unnamed> | 0..* | ConstChartRow

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | DsConstChart
Association | Rows
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstChartRow
Association | Rows
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association DependentClauses Report

Report: | General Info | Association Ends | Tagged Values

Association DependentClauses

Indicates that the specified rows are dependent clauses (or song or speech).

General Info
Name | DependentClauses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ConstChartClauseMarker
End B | <unnamed> | 0..* | ConstChartRow

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstChartClauseMarker
Association | DependentClauses
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstChartRow
Association | DependentClauses
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Tag Report

Report: | General Info | Association Ends | Tagged Values

Association Tag

The CmPossibilities come from the list of chart tags (discourse chart markers).

General Info
Name | Tag
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ConstChartTag
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstChartTag
Association | Tag
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Tag
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association BeginSegment Report

Report: | General Info | Association Ends | Tagged Values

Association BeginSegment

If BeginSegment is null, then there are no words in the WordGroup and this represents a User-entered marker indicating the User wants a special "missing" marker to show up in this cell highlighting that fact that nothing occurs in this cell (presumably because normally there would be something in this column). [Presentation note: currently this is displayed as "---".]

General Info
Name | BeginSegment
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ConstChartWordGroup
End B | <unnamed> | 1 | Segment

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstChartWordGroup
Association | BeginSegment
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Segment
Association | BeginSegment
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association EndSegment Report

Report: | General Info | Association Ends | Tagged Values

Association EndSegment

General Info
Name | EndSegment
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ConstChartWordGroup
End B | <unnamed> | 1 | Segment

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstChartWordGroup
Association | EndSegment
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Segment
Association | EndSegment
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association WordGroup Report

Report: | General Info | Association Ends | Tagged Values

Association WordGroup

The target ConstChartWordGroup is in the column that shows the actual position of the text, while the marker indicates where the ￢ﾀﾜsomething was moved from here￢ﾀﾝ marker should appear. WordGroup is bidirectional on purpose. We need to maintain a back-reference here.

General Info
Name | WordGroup
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ConstChartMovedTextMarker
End B | <unnamed> | 1 | ConstChartWordGroup

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstChartMovedTextMarker
Association | WordGroup
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstChartWordGroup
Association | WordGroup
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Column Report

Report: | General Info | Association Ends | Tagged Values

Association Column

Specifically a column identifier.

General Info
Name | Column
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ConstituentChartCellPart
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstituentChartCellPart
Association | Column
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Column
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Cells Report

Report: | General Info | Association Ends | Tagged Values

Association Cells

General Info
Name | Cells
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ConstChartRow
End B | <unnamed> | 0..* | ConstituentChartCellPart

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstChartRow
Association | Cells
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ConstituentChartCellPart
Association | Cells
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Analyses Report

Report: | General Info | Association Ends | Tagged Values

Association Analyses

General Info
Name | Analyses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Segment
End B | <unnamed> | 0..* | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Segment
Association | Analyses
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | Analyses
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Segments Report

Report: | General Info | Association Ends | Tagged Values

Association Segments

General Info
Name | Segments
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StTxtPara
End B | <unnamed> | 0..* | Segment

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StTxtPara
Association | Segments
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Segment
Association | Segments
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association BeginSegment Report

Report: | General Info | Association Ends | Tagged Values

Association BeginSegment

General Info
Name | BeginSegment
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | TextTag
End B | <unnamed> | 1 | Segment

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | TextTag
Association | BeginSegment
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Segment
Association | BeginSegment
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Approves Report

Report: | General Info | Association Ends | Tagged Values

Association Approves

The agent evaluation which objects being evaluated refer to in order to indicate that this agent approves or accepts them.

General Info
Name | Approves
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmAgent
End B | <unnamed> | 1 | CmAgentEvaluation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAgent
Association | Approves
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAgentEvaluation
Association | Approves
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Disproves Report

Report: | General Info | Association Ends | Tagged Values

Association Disproves

The agent evaluation which objects being evaluated refer to in order to indicate that this agent disapproves or does not accept them.

General Info
Name | Disproves
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmAgent
End B | <unnamed> | 1 | CmAgentEvaluation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 8 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAgent
Association | Disproves
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAgentEvaluation
Association | Disproves
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Evaluations Report

Report: | General Info | Association Ends | Tagged Values

Association Evaluations

Refers to either the Approves or Disapproves evaluations of various agents to indicate that the agent does or does not approve this analysis.

General Info
Name | Evaluations
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> | 0..* | CmAgentEvaluation
End B | <unnamed> |  | WfiAnalysis

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 14, |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAgentEvaluation
Association | Evaluations
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | Evaluations
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibilityList
Child Element | CmPossibility


Association Possibilities Report

Report: | General Info | Association Ends | Tagged Values

Association Possibilities

General Info
Name | Possibilities
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPossibilityList
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 8 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | Possibilities
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Possibilities
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmResource


Association Resources Report

Report: | General Info | Association Ends | Tagged Values

Association Resources

The named external resources (e.g. xml files) used by Translation Editor and their version numbers.

General Info
Name | Resources
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Scripture
End B | <unnamed> | 0..* | CmResource

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 33 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Scripture
Association | Resources
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmResource
Association | Resources
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Resources Report

Report: | General Info | Association Ends | Tagged Values

Association Resources

The named external resources (e.g. xml files) used by FLEX and their version numbers.

General Info
Name | Resources
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 0..* | CmResource

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 21 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | Resources
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmResource
Association | Resources
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Class Diagram

Report: | General Info

Class Diagram Discourse

LangProject CmPossibilityList CmMajorObject CmPossibility DsChart <unnamed> <unnamed> DsConstChart <unnamed> <unnamed> Template Template StText BasedOn BasedOn DsDiscourseData ConstChartTempl ConstChartTempl Charts Charts DiscourseData DiscourseData SubPossibilities SubPossibilities ChartMarkers ChartMarkers StTxtPara Segment CmObject ConstChartRow Rows Rows ConstituentChartCellPart ConstChartWordGroup ConstChartMovedTextMarker ConstChartClauseMarker ConstChartTag <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> DependentClauses DependentClauses Tag Tag BeginSegment BeginSegment EndSegment EndSegment WordGroup WordGroup Column Column Cells Cells Analyses Analyses Segments Segments

General Info
Name | Discourse
Type | Class Diagram


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmMajorObject
Child Element | DsChart


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | DsChart
Child Element | DsConstChart


Association Template Report

Report: | General Info | Association Ends | Tagged Values

Association Template

Type of Discourse Chart. Each type of chart can have a different organization and layout of columns. Template must refer to a top-level CmPossibility in (eventually one of?) the template possibility lists of the DsDiscourseData (a Template).

General Info
Name | Template
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | DsChart
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | DsChart
Association | Template
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Template
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association BasedOn Report

Report: | General Info | Association Ends | Tagged Values

Association BasedOn

The linguistic text that the chart organizes (currently part of a Text, but could also be part of Scripture).

General Info
Name | BasedOn
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | DsConstChart
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | DsConstChart
Association | BasedOn
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | BasedOn
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | DsDiscourseData


Association ConstChartTempl Report

Report: | General Info | Association Ends | Tagged Values

Association ConstChartTempl

Templates describing possible chart organizations. Top level Possibilities are Chart Templates. SubPossibilities represent groups of columns or columns. (This is stretching the idea of 'possibilities' somewhat, and it is unusual that the top-level possibilities are really a different kind of thing from the leaves, but it can be thought of as an extension of the idea that non-leaf nodes perform a grouping function.) Changed from ConstChartTemplates for the port.

General Info
Name | ConstChartTempl
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | DsDiscourseData
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | DsDiscourseData
Association | ConstChartTempl
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | ConstChartTempl
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Charts Report

Report: | General Info | Association Ends | Tagged Values

Association Charts

Actual instances of discourse charts (tentatively of all types, even though we currently only have one type: Constituent Chart).

General Info
Name | Charts
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | DsDiscourseData
End B | <unnamed> | 0..* | DsChart

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | DsDiscourseData
Association | Charts
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | DsChart
Association | Charts
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association DiscourseData Report

Report: | General Info | Association Ends | Tagged Values

Association DiscourseData

The place for all our discourse analysis data.

General Info
Name | DiscourseData
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | DsDiscourseData

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 53 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | DiscourseData
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | DsDiscourseData
Association | DiscourseData
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ChkRendering


Association SurfaceForm Report

Report: | General Info | Association Ends | Tagged Values

Association SurfaceForm

A vernacular wordform that occurs in the text and is a valid equivalent for rendering the term that owns this ChkRendering object. This is required to be filled in when a ChkRendering is created.

General Info
Name | SurfaceForm
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ChkRendering
End B | <unnamed> | 1 | WfiWordform

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ChkRendering
Association | SurfaceForm
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiWordform
Association | SurfaceForm
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Meaning Report

Report: | General Info | Association Ends | Tagged Values

Association Meaning

The literal meaning of the vernacular term or phrase used for rendering the ChkTerm. This will be displayed as the back translation of the vernacular rendering. This is optional, but when supplied (by the user) must be one of the glosses for one of the senses of the SurfaceForm.

General Info
Name | Meaning
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ChkRendering
End B | <unnamed> | 1 | WfiGloss

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ChkRendering
Association | Meaning
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiGloss
Association | Meaning
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Renderings Report

Report: | General Info | Association Ends | Tagged Values

Association Renderings

Represents the renderings (i.e. vernacular equivalents) for a term. A ChkRendering is added whenever a rendering is ascribed to a ChkRef for which a ChkRendering does not already exist in this collection.

General Info
Name | Renderings
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ChkTerm
End B | <unnamed> | 0..* | ChkRendering

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ChkTerm
Association | Renderings
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ChkRendering
Association | Renderings
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association NoteMappings Report

Report: | General Info | Association Ends | Tagged Values

Association NoteMappings

The mappings (from delimited external data to internal data structure) that apply to the annotations sources in this group of settings. Markers in the various annotation sources must be compatible within an instance of ScrImportSettings so one collection of mappings is used for all note sources.

General Info
Name | NoteMappings
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrImportSet
End B | <unnamed> | 0..* | ScrMarkerMapping

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 11 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSet
Association | NoteMappings
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrMarkerMapping
Association | NoteMappings
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | ScrImportSource
Child Element | ScrImportP6Project


Association ScriptureMappings Report

Report: | General Info | Association Ends | Tagged Values

Association ScriptureMappings

The mappings (from delimited external data to internal data structure) that apply to the scripture and back translations sources in this group fo settings. Markers used in both the scripture and back translations sources must be used equivalently within an instance of ScrImportSettings, so one collection of mappings is used for both types of sources.

General Info
Name | ScriptureMappings
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrImportSet
End B | <unnamed> | 0..* | ScrMarkerMapping

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 10 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSet
Association | ScriptureMappings
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrMarkerMapping
Association | ScriptureMappings
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ScriptureSources Report

Report: | General Info | Association Ends | Tagged Values

Association ScriptureSources

Currently (Dec 2005) a single source for scripture is suported but this is made a collection to make future expansion feasible.

General Info
Name | ScriptureSources
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrImportSet
End B | <unnamed> | 0..* | ScrImportSource

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSet
Association | ScriptureSources
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSource
Association | ScriptureSources
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association BackTransSources Report

Report: | General Info | Association Ends | Tagged Values

Association BackTransSources

Sources for scripture back translations. More than one is used only if back translations are written in diverse analysis languages.

General Info
Name | BackTransSources
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrImportSet
End B | <unnamed> | 0..* | ScrImportSource

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 8 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSet
Association | BackTransSources
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSource
Association | BackTransSources
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association NoteSources Report

Report: | General Info | Association Ends | Tagged Values

Association NoteSources

Sources for annotations. Different sources are useful to group different kinds of annotations and/or different originators.

General Info
Name | NoteSources
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrImportSet
End B | <unnamed> | 0..* | ScrImportSource

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 9 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSet
Association | NoteSources
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSource
Association | NoteSources
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | ScrImportSource
Child Element | ScrImportSFFiles


Association ImportSettings Report

Report: | General Info | Association Ends | Tagged Values

Association ImportSettings

Scripture Import Settings. Supports multiple configurations for importing Scripture and related data from external files.

General Info
Name | ImportSettings
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Scripture
End B | <unnamed> | 0..* | ScrImportSet

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Scripture
Association | ImportSettings
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSet
Association | ImportSettings
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ScrImportSet


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ScrMarkerMapping


Association Style Report

Report: | General Info | Association Ends | Tagged Values

Association Style

Style to apply to data in an internal text stream. Ignored of Target is <> 0.

General Info
Name | Style
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrMarkerMapping
End B | <unnamed> | 1 | StStyle

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 10 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrMarkerMapping
Association | Style
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StStyle
Association | Style
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Files Report

Report: | General Info | Association Ends | Tagged Values

Association Files

The files that this source comprises. Currently (Dec 2005) plan to only set the OriginalPath in the CmFile.

General Info
Name | Files
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrImportSFFiles
End B | <unnamed> | 0..* | CmFile

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSFFiles
Association | Files
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFile
Association | Files
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association NoteType Report

Report: | General Info | Association Ends | Tagged Values

Association NoteType

General Info
Name | NoteType
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrMarkerMapping
End B | <unnamed> | 1 | CmAnnotationDefn

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 11 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrMarkerMapping
Association | NoteType
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotationDefn
Association | NoteType
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association NoteType Report

Report: | General Info | Association Ends | Tagged Values

Association NoteType

General Info
Name | NoteType
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrImportSource
End B | <unnamed> | 1 | CmAnnotationDefn

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrImportSource
Association | NoteType
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotationDefn
Association | NoteType
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Quote Report

Report: | General Info | Association Ends | Tagged Values

Association Quote

Quotation from the scripture text to indicate the topic of the note. May be in an analysis language, a vernacular language or both.

General Info
Name | Quote
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrScriptureNote
End B | <unnamed> | 1 | StJournalText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrScriptureNote
Association | Quote
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StJournalText
Association | Quote
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Discussion Report

Report: | General Info | Association Ends | Tagged Values

Association Discussion

The core contents of the note, the reviewer’s discussion (explanation) of the translation or interpretation issue. Not to be confused with the discussion between users in response to the note which is contained in the Responses collection.

General Info
Name | Discussion
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrScriptureNote
End B | <unnamed> | 1 | StJournalText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrScriptureNote
Association | Discussion
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StJournalText
Association | Discussion
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Resolution Report

Report: | General Info | Association Ends | Tagged Values

Association Resolution

The reviewer's description of how the issue raised in the note was resolved. Used in conjunction with the ResolutionStatus attribute when details are needed.

General Info
Name | Resolution
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrScriptureNote
End B | <unnamed> | 1 | StJournalText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrScriptureNote
Association | Resolution
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StJournalText
Association | Resolution
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Recommendation Report

Report: | General Info | Association Ends | Tagged Values

Association Recommendation

The reviewer's summary recommendation concerning the issue. For consultant notes, may contain a suggested rendering, test questions to ask the translation team, or other specific course of action recommended.

General Info
Name | Recommendation
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrScriptureNote
End B | <unnamed> | 1 | StJournalText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrScriptureNote
Association | Recommendation
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StJournalText
Association | Recommendation
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Responses Report

Report: | General Info | Association Ends | Tagged Values

Association Responses

Place to record discussion between the stakeholders in response to the note. In consultant notes, a two-way interchange between the consultant and consultee.

General Info
Name | Responses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrScriptureNote
End B | <unnamed> | 0..* | StJournalText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrScriptureNote
Association | Responses
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StJournalText
Association | Responses
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmBaseAnnotation
Child Element | ScrScriptureNote


Association CreatedBy Report

Report: | General Info | Association Ends | Tagged Values

Association CreatedBy

From a list of users, the person who created the journal entry.

General Info
Name | CreatedBy
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StJournalText
End B | <unnamed> | 1 | CmPerson

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StJournalText
Association | CreatedBy
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | CreatedBy
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ModifiedBy Report

Report: | General Info | Association Ends | Tagged Values

Association ModifiedBy

From a list of users, the person who last modified the journal entry.

General Info
Name | ModifiedBy
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StJournalText
End B | <unnamed> | 1 | CmPerson

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StJournalText
Association | ModifiedBy
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | ModifiedBy
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | StText
Child Element | StJournalText


Association Categories Report

Report: | General Info | Association Ends | Tagged Values

Association Categories

Place to indicate zero to many standard categories to which the issue discussed in the note might belong. USB and CONNOT categories will be supplied on a factory installed list. This is an open (user modifiable) list.

General Info
Name | Categories
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrScriptureNote
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrScriptureNote
Association | Categories
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Categories
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Notes Report

Report: | General Info | Association Ends | Tagged Values

Association Notes

Scripture notes for this book of Scripture. These annotations include consultant notes, translator notes and also "error" annotations generated by checking tools.

General Info
Name | Notes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrBookAnnotations
End B | <unnamed> | 0..* | ScrScriptureNote

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBookAnnotations
Association | Notes
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrScriptureNote
Association | Notes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association BookAnnotations Report

Report: | General Info | Association Ends | Tagged Values

Association BookAnnotations

Book-by-book sequence of annotations that are specific to the scripture text. As of January 2006, these are just scripture notes. We have not yet decided whether to store the annotations generated by checking tools here Scripture annotations are stored book-by-book to make for faster access and filtering.

General Info
Name | BookAnnotations
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Scripture
End B | <unnamed> | 0..* | ScrBookAnnotations

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 24 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Scripture
Association | BookAnnotations
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBookAnnotations
Association | BookAnnotations
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association NoteCategories Report

Report: | General Info | Association Ends | Tagged Values

Association NoteCategories

List of categories that identify the types of issues that a ScrScriptureNote might deal with. Changed from ScriptureNoteCategories.

General Info
Name | NoteCategories
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Scripture
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 25 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Scripture
Association | NoteCategories
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | NoteCategories
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ScrBookAnnotations


Association MainEntriesOrSenses Report

Report: | General Info | Association Ends | Tagged Values

Association MainEntriesOrSenses

If a user has specified Morphology, then FW should by default set a link to the entry that has a morph type of root. In the case of two or more roots, FW makes an arbitrary decision. Like other parts of the WW system, default choices should be indicated to the user so they can review them. In the majority of cases for subentry-like entries this will be only one entry (establishment points to establish) but with the possibility of more for entries that have more than one root in them (blackboard may point to board and black). For inflected forms, there will ALWAYS be only one entry pointed to (men points to man). (This used to be on LexSubentry and MainEntryOrSense on LexMinorEntry.) Subentries can be "subs" of either a major entry, another subentry, a minor entry (very rare) or a particular sense of any of the above. In this latter case, common in Philippine and Indonesian lexicons, the subentry usually appears under the sense of the entry.

General Info
Name | MainEntriesOrSenses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntry
End B | <unnamed> | 0..* | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 19 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | MainEntriesOrSenses
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | MainEntriesOrSenses
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | LexEntryType


Tag Definition max Report

Report: | General Info | Typed Values

Data types
Tag Definition max

General Info
Name | max
Multiplicity | 1
Type | integer
Default Value | 127
Base Classes | Attribute

Typed Values
Value | Owner
127 | MappingType
127 | RefType


Tag Definition min Report

Report: | General Info | Typed Values

Data types
Tag Definition min

General Info
Name | min
Multiplicity | 1
Type | integer
Default Value | 0
Base Classes | Attribute

Typed Values
Value | Owner
0 | MappingType


Association References Report

Report: | General Info | Association Ends | Tagged Values

Association References

This holds the possibility list that holds LexRefType items which own the actual references.

General Info
Name | References
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 19 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | References
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | References
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | LexRefType


Association Members Report

Report: | General Info | Association Ends | Tagged Values

Association Members

This holds all of the references of this type.

General Info
Name | Members
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexRefType
End B | <unnamed> | 0..* | LexReference

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexRefType
Association | Members
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexReference
Association | Members
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | LexReference


Association Features Report

Report: | General Info | Association Ends | Tagged Values

Association Features

The order of features will be used in the Gloss Assistant system to put feature values in the correct glossing order. For example, the user may want the FsFeatStrucType of TAM (tense aspect modality) to be ordered Aspect, Modality and Tense.

General Info
Name | Features
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsFeatStrucType
End B | <unnamed> | 0..* | FsFeatDefn

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStrucType
Association | Features
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatDefn
Association | Features
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Features Report

Report: | General Info | Association Ends | Tagged Values

Association Features

General Info
Name | Features
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsFeatureSystem
End B | <unnamed> | 0..* | FsFeatDefn

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatureSystem
Association | Features
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatDefn
Association | Features
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Targets Report

Report: | General Info | Association Ends | Tagged Values

Association Targets

General Info
Name | Targets
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexReference
End B | <unnamed> | 0..* | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexReference
Association | Targets
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | Targets
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association FromPartsOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association FromPartsOfSpeech

The FromPartsOfSpeech lists the categories (POSes) of words that this clitic may attach to. It can delimit a subset of categories if need be or it can be empty.

General Info
Name | FromPartsOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemMsa
End B | <unnamed> | 0..* | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | FromPartsOfSpeech
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | FromPartsOfSpeech
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association GenreList Report

Report: | General Info | Association Ends | Tagged Values

Association GenreList

This property holds the list of defined genres (instances of CmPossibility) used by texts.

General Info
Name | GenreList
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 52 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | GenreList
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | GenreList
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Genres Report

Report: | General Info | Association Ends | Tagged Values

Association Genres

This associates a text with any number of genres.

General Info
Name | Genres
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Text
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 9 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Text
Association | Genres
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Genres
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ChartMarkers Report

Report: | General Info | Association Ends | Tagged Values

Association ChartMarkers

This list stores markers that can be inserted into the chart to provide additional labelling. The top-level is several different kinds of markers (initially Tense/Aspect/Mood, Pronouns, and Demonstatives), and below those are the (sometimes hierarchical) lists of possible markers for that type. Combining them like this makes it easy to add new categories as well as items.

General Info
Name | ChartMarkers
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | DsDiscourseData
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | DsDiscourseData
Association | ChartMarkers
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | ChartMarkers
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoMorphSynAnalysis
Child Element | MoUnclassifiedAffixMsa


Association PartOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association PartOfSpeech

General Info
Name | PartOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoUnclassifiedAffixMsa
End B | <unnamed> | 1 | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoUnclassifiedAffixMsa
Association | PartOfSpeech
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | PartOfSpeech
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Class Diagram

Report: | General Info

Class Diagram Morphology Affixes

LexEntry MoMorphAdhocProhib MoMorphSynAnalysis Components Components Morphemes Morphemes FirstMorpheme FirstMorpheme RestOfMorphs RestOfMorphs MorphoSyntaxAnalyses MorphoSyntaxAnalyses MoStemMsa <unnamed> <unnamed> MoDerivAffMsa <unnamed> <unnamed> MoDerivStepMsa <unnamed> <unnamed> MoUnclassifiedAffixMsa <unnamed> <unnamed> MoInflAffMsa <unnamed> <unnamed> FsFeatStruc FromMsFeatures FromMsFeatures MsFeatures MsFeatures ToMsFeatures ToMsFeatures MsFeatures MsFeatures InflFeats InflFeats InflFeats InflFeats PartOfSpeech PartOfSpeech PartOfSpeech PartOfSpeech PartOfSpeech ReferenceForms ReferenceForms FromPartOfSpeech FromPartOfSpeech EmptyParadigmCells EmptyParadigmCells DefaultFeatures DefaultFeatures PartOfSpeech PartOfSpeech InherFeatVal InherFeatVal ToPartOfSpeech ToPartOfSpeech MoInflClass ReferenceForms ReferenceForms FromInflectionClass FromInflectionClass InflectionClass InflectionClass Subclasses Subclasses ToInflectionClass ToInflectionClass InflectionClass InflectionClass InflectionClasses InflectionClasses DefaultInflectionClass DefaultInflectionClass MoStratum Stratum Stratum Stratum Stratum CmPossibility Confidence Confidence Restrictions Restrictions <unnamed> <unnamed> AffixCategory AffixCategory Status Status AffixCategory AffixCategory SubPossibilities SubPossibilities MoStemName StemNames StemNames DefaultStem DefaultStem FromStemName FromStemName StemNames StemNames Regions Regions DefaultAffix DefaultAffix MoBinaryCompoundRule LeftMsa LeftMsa RightMsa RightMsa MoExoCompound ToMsa ToMsa <unnamed> <unnamed> MoInflAffixSlot PartOfSpeech PartOfSpeech Slots Slots FromPartsOfSpeech FromPartsOfSpeech

General Info
Name | Morphology Affixes
Type | Class Diagram


Association ReversalIndexes Report

Report: | General Info | Association Ends | Tagged Values

Association ReversalIndexes

Ken Zook: We are pretty well beyond the point where we'll ever allow multiple language projects in a database, so I think it's time we make these indexes owned. Since they are really part of the lexical database, I'm recommending they be owned by the lexical database.

General Info
Name | ReversalIndexes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 0..* | ReversalIndex

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 17 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | ReversalIndexes
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ReversalIndex
Association | ReversalIndexes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association PartOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association PartOfSpeech

General Info
Name | PartOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffMsa
End B | <unnamed> | 1 | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffMsa
Association | PartOfSpeech
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | PartOfSpeech
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Package UML Standard Profile index

Stereotypes
access
appliedProfile
association
association
auxiliary
balking
balking
become
boundary
call
control
copy
create
create
create
database
derive
destroy
destroy
document
document
entity
executable
executable
facade
file
file
focus
framework
friend
global
global
implementation
implementation
implementationClass
implicit
import
instantiate
invariant
library
library
local
local
metaclass
metamodel
modelLibrary
modelLibrary
parameter
parameter
postcondition
powertype
precondition
process
profile
realize
refine
requirement
responsibility
schema
self
self
send
signalflow
source
stateInvariant
stub
systemModel
table
table
table
thread
time-out
time-out
topLevel
trace
type
useCaseModel
utility
Tag Definitions
abbrev
abbrev1
num
num
num
num1
num2
num3


PackageUML Standard Profile Report

Report: | General Info | Stereotypes | Inner Elements

Package UML Standard Profile

General Info
Name | UML Standard Profile
Abstract | false
Leaf | false
Root | false

Stereotypes
<<profile>>

Inner Elements
Name | Type
access | Stereotype
appliedProfile | Stereotype
association | Stereotype
association | Stereotype
auxiliary | Stereotype
balking | Stereotype
balking | Stereotype
become | Stereotype
boundary | Stereotype
call | Stereotype
control | Stereotype
copy | Stereotype
create | Stereotype
create | Stereotype
create | Stereotype
database | Stereotype
derive | Stereotype
destroy | Stereotype
destroy | Stereotype
document | Stereotype
document | Stereotype
entity | Stereotype
executable | Stereotype
executable | Stereotype
facade | Stereotype
file | Stereotype
file | Stereotype
focus | Stereotype
framework | Stereotype
friend | Stereotype
global | Stereotype
global | Stereotype
implementation | Stereotype
implementation | Stereotype
implementationClass | Stereotype
implicit | Stereotype
import | Stereotype
instantiate | Stereotype
invariant | Stereotype
library | Stereotype
library | Stereotype
local | Stereotype
local | Stereotype
metaclass | Stereotype
metamodel | Stereotype
modelLibrary | Stereotype
modelLibrary | Stereotype
parameter | Stereotype
parameter | Stereotype
postcondition | Stereotype
powertype | Stereotype
precondition | Stereotype
process | Stereotype
profile | Stereotype
realize | Stereotype
refine | Stereotype
requirement | Stereotype
responsibility | Stereotype
schema | Stereotype
self | Stereotype
self | Stereotype
send | Stereotype
signalflow | Stereotype
source | Stereotype
stateInvariant | Stereotype
stub | Stereotype
systemModel | Stereotype
table | Stereotype
table | Stereotype
table | Stereotype
thread | Stereotype
time-out | Stereotype
time-out | Stereotype
topLevel | Stereotype
trace | Stereotype
type | Stereotype
useCaseModel | Stereotype
utility | Stereotype
abbrev | Tag Definition
abbrev1 | Tag Definition
num | Tag Definition
num | Tag Definition
num | Tag Definition
num1 | Tag Definition
num2 | Tag Definition
num3 | Tag Definition


Association Appendixes Report

Report: | General Info | Association Ends | Tagged Values

Association Appendixes

General Info
Name | Appendixes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | LexAppendix

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | Appendixes
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexAppendix
Association | Appendixes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | UserConfigAcct


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhContextOrVar
Child Element | PhPhonContext


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhContextOrVar
Child Element | PhVariable


Association Analyses Report

Report: | General Info | Association Ends | Tagged Values

Association Analyses

General Info
Name | Analyses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiWordform
End B | <unnamed> | 0..* | WfiAnalysis

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiWordform
Association | Analyses
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | Analyses
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | CmPerson


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | CmAnthroItem


Association PartOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association PartOfSpeech

refers to a PartOfSpeech, telling the category of the word.

General Info
Name | PartOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivStepMsa
End B | <unnamed> | 1 | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivStepMsa
Association | PartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | PartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ToPartOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association ToPartOfSpeech

specifes the category(PartOfSpeech) of the word resulting from the attachment of this affix. Note that as with the FromPartOfSpeech, we do not (yet) cover subcategorization lists or argument structure here. Thus, we cannot handle subcategorization-changing affixes, such as causatives, by changing a subcategorization list, only by changing category or morphosyntactic features. Likewise, we cannot handle the change in argument structure that accompanies some category-changing affixes. For example, when the prefix en- verbalizes an adjective, the argument of which the adjective was predicated becomes the direct object of the verb (The picture is large - to enlarge the picture; example from Scalise 1986: 28).

General Info
Name | ToPartOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 1 | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | ToPartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | ToPartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association FromPartOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association FromPartOfSpeech

specifies the category of the stem to which this affix attaches. See comments above on the "Unitary Base Hypothesis." Note also that in AMPLE, it is possible to map a series of categories into another series of categories; that capability is not defined here. If the parts of speech list is hierarchical, the problem could be partially circumvented by specifying an abstract category in this attribute. However, that would not solve the problem of mapping the output category, because at best we could specify more than a single output category. Note that we do not (yet) have provision for subcategorization lists or argument structure. This means that some restrictions on the stem to which an affix would be attached cannot be handled elegantly. (They could be handled inelegantly, by creating an ad hoc feature for each subcategorization, e.g. [+ditransitive].) For example, the English suffix -able attaches only to transitive verbs (washable, *seemable); the English suffix -ee attaches only to verbs which allow animate objects or indirect objects (addressee, *tearee) (examples from Scalise 1986: 45). Nor do we treat semantic restrictions on the base to which the affix attaches. For example, it has been proposed that the English prefix re- attaches only to verbs whose meaning entails a change of state (John repunched the holes in the paper, *John repunched Bill in the face) (Aronoff 1976: 47, observation attributed to an unpublished paper of Williams).

General Info
Name | FromPartOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 1 | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | FromPartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | FromPartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association PhoneEnv Report

Report: | General Info | Association Ends | Tagged Values

Association PhoneEnv

refers to a collection of PhEnvironment objects, describing what the phonetic environment of this allomorph is. The reason this is a collection attr (rather than atomic) is to allow for the situation during analysis before the user has managed to collapse what appear to be disparate environments into a single environment. (Note that the 'elsewhere' case can be represented by an empty environment under the assumption of disjunctive ordering.) Hence, a step in the stealth-to-wealth process will be to reduce the cardinality of this collection to one. A collection may of course also be useful for allomorphs which actually does appear in a disparate set of environments. For discussion of why this is a ref attribute, rather than an owning attribute, see MoMorphologicalData.PhoneEnvs. If this attribute is uninstantiated, there is no phonetic restriction on the environment.

General Info
Name | PhoneEnv
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemAllomorph
End B | <unnamed> | 0..* | PhEnvironment

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemAllomorph
Association | PhoneEnv
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhEnvironment
Association | PhoneEnv
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Position Report

Report: | General Info | Association Ends | Tagged Values

Association Position

refers to an ordered seq of PhEnvironment, encoding the position relative to the stem in which this allomorph goes (for example, before the stem, after the stem, or between the first two consonants of the stem). A default value for this attr should be provided for prefixes and suffixes, based on MoForm.MorphType. For a prefix, this would be __#X (where X represents the entire stem), and for a suffix, X#__. This attr need not be displayed for prefixes and suffixes. Note that it would not be possible to simplify the model by eliminating this attr, and letting the position of infixation be determined by the phonological environment of the allomorph(s). The reason this can't be done is that what is important for purposes of allomorphy vs. what is important for positioning the infix, are two different things. The reason for having this attr as a property of the allomorph, rather than of the MSA, is that this allows us to distinguish two different allomorphs which differ as to whether they are infixed or not. For example, there is a Tagalog affix whose infixed form is -in-, and whose prefixed form is ?in- (although the word-initial glottal happens not to be written orthographically). An alternative to having this attr on MoAffixAllomorph would be to add a subclass of this class for infixes (as well as suprafixes and other sorts of affixes that must appear in a particular position, other than before or after the stem). This new subclass would then have the extra attribute for position. One disadvantage of having such a subclass, is that it would be the only subclass of MoAffixAllomorph, whereas in fact all specific types of affixes (prefixes, suffixes, infixes,...) are sub-types. Having a default value of this attr for prefixes and suffixes adequately characterizes the difference between prefixes and suffixes on the one hand, and infixes on the other. The attr is a seq (as opposed to atomic) to account for affixes whose position relative to the stem is determined by the phonology of the stem. For example, in Tagalog the in affix occurs after the first consonant of a C-initial stem, or (prefixed) before a vowel-initial stem. (Note that this implies that an affix may not be purely a prefix or infix, contrary to the implication of the MorphType attr. The alternative is to require the user to treat such an affix as having two allomorphs, one a prefix and one an infix; but this would seem to be an unnecessary burden for the user.) The attr is an ordered seq (as opposed to a collection) in order to allow disjunctive ordering. Taking the example given above, disjunctive ordering would require the following environments, stored in an ordered seq: #C__, #__ Nondisjunctive ordering would require the following environments (which could be stored in a collection): #C__, #__V Using an ordered seq does not force the parser/ generator to use the ordering, but allows for parsers which do use the order (such as Hermit Crab).

General Info
Name | Position
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAffixAllomorph
End B | <unnamed> | 0..* | PhEnvironment

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixAllomorph
Association | Position
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhEnvironment
Association | Position
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association PhoneEnv Report

Report: | General Info | Association Ends | Tagged Values

Association PhoneEnv

refers to a collection of PhEnvironment objects, describing what the phonetic environment of this allomorph is. The use of the term 'phonetic' is not intended to distinguish this from a phonological context, merely to say that the context is described in terms of its phonetic properties, not its morphosyntactic properties or lexically marked exception properties. If this attribute is uninstantiated, there is no phonetic restriction on the environment. The reason this is a collection attr (rather than atomic) is to allow for the situation during analysis before the user has managed to collapse what appear to be disparate environments into a single environment. (Note that the 'elsewhere' case can be represented by an empty environment under the assumption of disjunctive ordering.) Hence, a step in the stealth-to-wealth process will be to reduce the cardinality of this collection to one. A collection may of course also be useful for allomorphs which actually does appear in a disparate set of environments. For the reason why this is a ref attribute, rather than an owning attribute, see the discussion of MoMorphologicalData.PhoneEnvs. An important assumption here is that the phonetic environment to which this allomorph refers is the derived phonological environment. In the absence of phonological rules, this means that the phonetic environment refers to the allomorph(s) to its left, not to some base form of the morphemes. (If we later implement phonological rules, this implies we implement cyclic phonological processes.) The effect of iterative application of phonological rules would not be possible under this approach, although most cases might fall out from the step-wise attachment of affixes, which more or less amounts to cyclic rule application (without rules). Alternatively, we could allow reference to either (or both) the underlying and derived environments (which would in turn imply that every morpheme would need to have an underlying form); this would be similar to two-level phonology.

General Info
Name | PhoneEnv
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAffixAllomorph
End B | <unnamed> | 0..* | PhEnvironment

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixAllomorph
Association | PhoneEnv
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhEnvironment
Association | PhoneEnv
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association MsFeatures Report

Report: | General Info | Association Ends | Tagged Values

Association MsFeatures

gives any morphosyntactic features belonging to the stem in addition to those specified by PartOfSpeech.InherentFeatureValues. In most cases, there will be none, but this attribute may be useful for exceptional words (such as the pluralia tantum words pants and scissors, which are grammatically plural even though the default for English nouns is singular). The features are restricted to those in vAllPossibleFeatures of my PartOfSpeech.

General Info
Name | MsFeatures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemMsa
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | MsFeatures
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | MsFeatures
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association InherFeatVal Report

Report: | General Info | Association Ends | Tagged Values

Association InherFeatVal

Owns a FsFeatStruc, representing (some of) the feature values inherently associated with this category (e.g. [+N +V]). Changed from InherentFeatureValues

General Info
Name | InherFeatVal
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | InherFeatVal
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | InherFeatVal
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ReferenceForms Report

Report: | General Info | Association Ends | Tagged Values

Association ReferenceForms

owns a collection seq of FsFeatStruc, each of which defines the cell whose inflection uniquely picks out an inflection class. (Cf. Carstairs-McCarthy 1991, particularly section 8). Usually, the reference forms belonging to a part of speech will suffice for all the MoInflectionClasses, i.e. a single "Primary Reference Form" (Carstairs-McCarthy's term). In some cases, however, it may prove necessary to provide a secondary reference form to distinguish among "mixed" classes (see again the discussion in Carstairs-McCarthy 1991.) Any secondary reference forms are provided in the attr of the same name of the particular MoInflectionClasses to which they pertain.Note that this attribute performs no particular function in any of the algorithms used for computing affixed forms. However, it may be useful in the context of a dictionary, e.g. for providing principal parts.

General Info
Name | ReferenceForms
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 0..* | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | ReferenceForms
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | ReferenceForms
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association EmptyParadigmCells Report

Report: | General Info | Association Ends | Tagged Values

Association EmptyParadigmCells

owns a collection seq of FsFeatStruc, indicating the cells (feature-value combinations) which are disallowed in the paradigm. This is intended to account for defective paradigms, which are not common (e.g. deponent verbs in Greek, which are verbs that have no active forms). Since defective paradigms are relatively rare, this will probably be a seldom-used attribute. It is not intended to account for syncretism in the paradigm, i.e. the situation where one cell 'uses' the affixes of another cell (for which MoReferralRules are supplied instead, should disjunctive ordering of the affixes in an MoInflAffixSlot not suffice.).Since this attribute is defined at the level of the part of speech, it is not possible to define cells which are empty in only one inflection class. It is not obvious that this is correct, e.g. it is not obvious that deponent verbs in Greek belonged to a separate part of speech from other verbs. Pluralia tantum words like scissors and trousers are another example, since it is not clear that they belong to a separate part of speech from other nouns. Yet another example of a set of words that cannot plausibly be assigned to a separate category comes from Russian. Halle (1973: 7-8) says there are about a hundred verbs, all in a particular conjugation class, which lack first person singular non-past forms. It is unclear what the status of this gap is; it may be semantically or pragmatically based (some of the glosses are 'I conquer', 'I talk rudely', 'I behave foolishly'). According to Halle, "Russian grammar books frequently note that such forms… 'do not exist', or 'are not used', or 'are avoided'." Perhaps this is more of a sociolinguistic issue. Jensen (1990: 117-119) discusses some other defective paradigms, although he admits that his Latin examples are suspect: the defective paradigm is based on the corpus of Latin literature, and it may be that the corpus, not the paradigm, is defective. Jensen also lists as examples a few French verbs which lack certain forms: "cloré ['to close, enclose']… lacks the passé simple and the first and second persons plural of the present. Gésir ['to lie'] lacks all tenses but the present and imperfect indicative, and lacks the first and second persons singular of the present." He notes that synonyms supply the missing forms, so these gaps probably cannot be explained on semantic or pragmatic grounds. Jensen also gives as examples English modal verbs, which lack participle and 'infinitive' (to V) forms. In this case, the customary solution is to create a separate part of speech (modals), as a subclass of the category Verb.There are at least two verbs in English with defective paradigms: sight-see (*sight-sees, *sight-saw, sight-seen-but sight-seeing), and beware (which occurs only in this base form. Another puzzle with respect to defective paradigms, is the fact that while the singular of pluralia tantum words is ungrammatical in isolation, they are found in compounds: scissor-handle and trouser-leg. It is not clear how a defective distribution of certain elements of the paradigm should be handled. Matthews (1972a: 197, fn. 2) suggests that defective paradigms be handled in the syntax, although it is unclear how this would work.

General Info
Name | EmptyParadigmCells
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 0..* | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | EmptyParadigmCells
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | EmptyParadigmCells
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association DefaultFeatures Report

Report: | General Info | Association Ends | Tagged Values

Association DefaultFeatures

A feature structure which specifies features that should be assumed in the absence of any inflectional affixes for the features defined. Example: In English, nouns are by default singular [num:sg].

General Info
Name | DefaultFeatures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | DefaultFeatures
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | DefaultFeatures
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AffixCategory Report

Report: | General Info | Association Ends | Tagged Values

Association AffixCategory

In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. This field is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a CmPossibility of "derv" (derivational affix).

General Info
Name | AffixCategory
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | AffixCategory
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | AffixCategory
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association InflFeats Report

Report: | General Info | Association Ends | Tagged Values

Association InflFeats

Owns an FsFeatStruc, representing the morphosyntactic features realized by this affix. Most commonly, the feature values of this FsFeatStruc will belong to the PartOfSpeechGrammar.doc - PartOfSpeech.vAllInflectableFeatures of the stem to which the inflectional affix attaches, but may also include any of the features in the vAllInherentFeatureValues or vAllBearableFeatures attrs. For example, in Tzeltal there are two incompletive aspect prefixes, distinguished by whether the stem to which they attach is transitive or intransitive. The aspect feature would be an inflectable feature of verbs, but the transitivity feature would be either an inherent feature of the stem (assuming transitive and intransitive verbs have distinct parts of speech) or a bearable feature (if transitive and intransitive verbs are both treated as having the part of speech verb, and are distinguished by the transitivity feature alone). In determining what feature values can be added to a given FsFeatStruc, it will probably be desirable to disallow conflicting feature values (or even assigning the same feature value twice). However, it is permissible to have two different feature values at different places in an FsComplexValue; for example, [[Subject [Person 1]] [Object [Person 2]]]. In the course of a stealth-to-wealth analysis, a single affix might occupy a set of cells in a paradigm, where the cells do not form a natural class, and where they are not an 'elsewhere' case, or at least the user does not recognize them as such. This situation can be accommodated by the use of FsFeatStruc.FeatDisj. The goal at the 'wealth' end would be to find a natural class for the cells, thereby eliminating the feature disjunction, or to use disjunctive ordering within an MoInflAffixSlot to allow the statement of the features in a non-disjunctive manner. Changed from InflectionFeatures for the database port.

General Info
Name | InflFeats
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffMsa
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: Questions |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffMsa
Association | InflFeats
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | InflFeats
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association MsEnvPartOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association MsEnvPartOfSpeech

refers to a PartOfSpeech, defining the morphosyntactic features which the stem to which this affix attaches must bear. Together with the MsEnvFeatures attribute (below), this attribute defines the morphosyntactic context in which this allomorph must appear. However, there are linguistic reasons for thinking that allomorphs should not in fact be able to specify morphosyntactic requirements on their environment. That is, there are often (always?) better analyses of allomorphy which do not rely on the morphosyntactic properties of the stem (see e.g. Matthews' 1972b reanalysis of Huave). The attribute is there because AMPLE provides that power (although AMPLE allows the user to test the morphosyntactic properties of arbitrary morphemes to the left or right, while the intention here is that an allomorph can only test the morphosyntactic properties of the stem to which it attaches). Since the parts of speech are contained in an inheritance hierarchy, a question arises: if this attr points to an abstract part of speech (verb, say), does a stem with a more specific part of speech (transitive verb, say) match? In the absence of any reason to think it does not, I would suggest that reference to an abstract part of speech entails that more specific parts of speech are included. Otherwise, it is hard to imagine how one could use this attribute-it would be necessary to allow a seq, or else to have separate but homophonous allomorphs for each specific part of speech. It is not clear what should be done if there are conflicts between the morphosyntactic requirements imposed by this attribute, and those imposed by the affix owning this allomorph. Such conflicts "should" not arise (since allomorphs shouldn't have special morphosyntactic requirements of their own, as argued in the previous paragraph). While it would be fairly simple to ensure that conflicts do not arise between stated morphosyntactic properties, there is the potential for implicit conflicts (e.g. the affix calls for attachment to a noun, while the allomorph requires that the stem have a certain feature value for subject agreement-something which nouns presumably do not mark).

General Info
Name | MsEnvPartOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAffixAllomorph
End B | <unnamed> | 1 | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixAllomorph
Association | MsEnvPartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | MsEnvPartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AffixTemplates Report

Report: | General Info | Association Ends | Tagged Values

Association AffixTemplates

owns an ordered seq of MoInflAffixTemplates, which define how affixation (but not choice of stems) works for this part of speech. The reason this is an ordered sequence attribute, rather than atomic, is to allow the user to capture the fact that the number of slots can be different for different parts of the paradigm (infinitives, for example, or tenses which are partly inflected on the main verb and partly on an auxiliary verb). The order of templates in this attribute is relevant: the first MoInflAffixTemplates whose Region attr is a subset of the inflectional features to be realized on the word, is chosen.Note the assumption here that all the words belonging to a single part of speech have fundamentally the same paradigm (and therefore the same set of affix templates), and that differences are accounted by membership in distinct MoInflectionClasses (Carstairs 1987: 10-11, Carstairs-McCarthy 1998b: 324). The fact that in languages which mark the verb for agreement with both subject and object, transitive verbs have different paradigms from intransitive verbs (transitives usually have an additional slot for object marking-or for subject marking, in the case of ergative languages), might seem to be a counterexample. The reason that is not a counterexample, is that transitive and intransitive verbs can be treated as separate parts of speech using the inheritance hierarchy.

General Info
Name | AffixTemplates
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 0..* | MoInflAffixTemplate

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | AffixTemplates
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixTemplate
Association | AffixTemplates
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association AffixSlots Report

Report: | General Info | Association Ends | Tagged Values

Association AffixSlots

owns a collection seq of MoInflAffixSlot, which may be referred to in MoInflAffixTemplates.The reason for having the ownership of Affix Slots reside here, rather than their being owned by the Affix Templates themselves, is to allow different Affix Templates to share Affix Slots. For example, suppose that in some language, both subject and object agreement are marked on the verb, and that the user has accordingly specified distinct parts of speech (and therefore distinct paradigms) for transitive and intransitive verbs. In all likelihood, most of the slots will be alike (tense and aspect marking, etc., and perhaps the subject agreement slot). The common affix slots can be shared if they are owned by the super-category verb (see the attribute vAllAffixSlots, below). Similarly, in Tzeltal nouns use the same prefixes for marking possessors as transitive verbs use for marking subjects. Assuming appropriate morphosyntactic features could be devised to represent the person of possessors and subject-of-transitives in Tzeltal, it would be nice to use the same MoInflAffixSlot for both. But this would be impossible, if the Affix Slots were owned by the Affix Templates (since nouns and verbs do not in general share those templates). It becomes possible if the Affix Slots are owned at some point in the part of speech inheritance hierarchy above noun and (transitive) verb, and referred to by the Affix Templates for these two categories.

General Info
Name | AffixSlots
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 0..* | MoInflAffixSlot

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | AffixSlots
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlot
Association | AffixSlots
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association InflTemplateApps Report

Report: | General Info | Association Ends | Tagged Values

Association InflTemplateApps

Allows Morph Sketch Generator to extract example wordforms where an inflectional template is used. Changed from InflectionalTemplateApps.

General Info
Name | InflTemplateApps
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiAnalysis
End B | <unnamed> | 0..* | MoInflAffixTemplate

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 13 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | InflTemplateApps
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixTemplate
Association | InflTemplateApps
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association MsFeatures Report

Report: | General Info | Association Ends | Tagged Values

Association MsFeatures

WfiAnalysis parallels MorphoSyntacticItem in the lexical database. Allowing MSFeatures here allows the user to easily convert a wordform to a subentry. This also supports S2W in that a user may know the features that a wordform bears but not its component parts (e.g may know that it's plural without knowing what the plural morpheme is). Additionally, in the case of suppletion, there may not be a morpheme to identify.

General Info
Name | MsFeatures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiAnalysis
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | MsFeatures
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | MsFeatures
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Tag Definition Modification date Report

Report: | General Info | Typed Values

Tag Definition Modification date

General Info
Name | Modification date
Multiplicity | 1
Type | String
Base Classes | DiagramData

Typed Values
Value | Owner
2/17/05 4:03 PM | CmObjectGeneralizations


Tag Definition Creation date Report

Report: | General Info | Typed Values

Tag Definition Creation date

General Info
Name | Creation date
Multiplicity | 1
Type | String
Base Classes | DiagramData

Typed Values
Value | Owner
2/17/05 4:03 PM | CmObjectGeneralizations


Tag Definition Author Report

Report: | General Info | Typed Values

Tag Definition Author

General Info
Name | Author
Multiplicity | 1
Type | String
Base Classes | DiagramData

Typed Values
Value | Owner
wickberg | CmObjectGeneralizations


Class Diagram

Report: | General Info

Class Diagram Checklists

ChkTerm WfiWordform WfiAnalysis LexEntry Analyses Analyses Stems Stems ChkRef CmPossibility Confidence Confidence Restrictions Restrictions SubPossibilities SubPossibilities Status Status <unnamed> <unnamed> Occurrences Occurrences Rendering Rendering ChkSense LexSense Senses Senses Sense Sense ChkRendering SurfaceForm SurfaceForm WfiGloss Meaning Meaning Renderings Renderings

General Info
Name | Checklists
Type | Class Diagram


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | ChkTerm


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ChkRef


Association CheckLists Report

Report: | General Info | Association Ends | Tagged Values

Association CheckLists

The CheckLists will be a collection of CmPossibilityList objects, each with a unique identifier. For example, one CmPossibilityList will be called KeyTerms which will represent a hierarchical list of Biblical key terms. The possibility lists can be imported programmatically from external files. Each CmPossibilityList will hold ChkItem objects (derived from CmPossibility).

General Info
Name | CheckLists
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 50 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | CheckLists
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | CheckLists
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Occurrences Report

Report: | General Info | Association Ends | Tagged Values

Association Occurrences

List of references where this checking item needs to be checked. E.g., a list of scripture references where a specific sense of a key term needs to be checked.

General Info
Name | Occurrences
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ChkTerm
End B | <unnamed> | 0..* | ChkRef

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ChkTerm
Association | Occurrences
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ChkRef
Association | Occurrences
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Rendering Report

Report: | General Info | Association Ends | Tagged Values

Association Rendering

The target vernacular rendering of the checking item at this reference.

General Info
Name | Rendering
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ChkRef
End B | <unnamed> | 1 | WfiWordform

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ChkRef
Association | Rendering
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiWordform
Association | Rendering
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Select an object to view from above.


Classes/Interfaces

Interfaces
<unnamed>

Classes
 | <unnamed>
 | <unnamed>
 | <unnamed>
 | ChkRef
 | ChkRendering
 | ChkSense
 | ChkTerm
 | CmAgent
 | CmAgentEvaluation
 | CmAnnotation
 | CmAnnotationDefn
 | CmAnthroItem
 | CmBaseAnnotation
 | CmCell
 | CmCustomItem
 | CmDomainQ
 | CmFile
 | CmFilter
 | CmFolder
 | CmIndirectAnnotation
 | CmLocation
 | CmMajorObject
 | CmMedia
 | CmMediaAnnotation
 | CmObject
 | CmObject
 | CmOverlay
 | CmPerson
 | CmPicture
 | CmPossibility
 | CmPossibilityList
 | CmProject
 | CmResource
 | CmRow
 | CmSemanticDomain
 | CmTranslation
 | ConstChartClauseMarker
 | ConstChartMovedTextMarker
 | ConstChartRow
 | ConstChartTag
 | ConstChartWordGroup
 | ConstituentChartCellPart
 | CrossReference
 | DsChart
 | DsConstChart
 | DsDiscourseData
 | FsAbstractStructure
 | FsClosedFeature
 | FsClosedValue
 | FsComplexFeature
 | FsComplexValue
 | FsDisjunctiveValue
 | FsFeatDefn
 | FsFeatStruc
 | FsFeatStrucDisj
 | FsFeatStrucType
 | FsFeatureSpecification
 | FsFeatureSystem
 | FsNegatedValue
 | FsOpenFeature
 | FsOpenValue
 | FsSharedValue
 | FsSymFeatVal
 | LangProject
 | LexAppendix
 | LexDb
 | LexEntry
 | LexEntryRef
 | LexEntryType
 | LexEtymology
 | LexExampleSentence
 | LexPronunciation
 | LexReference
 | LexRefType
 | LexSense
 | MoAdhocProhib
 | MoAdhocProhibGr
 | MoAffixAllomorph
 | MoAffixForm
 | MoAffixProcess
 | MoAlloAdhocProhib
 | MoBinaryCompoundRule
 | MoCompoundRule
 | MoCompoundRuleApp
 | MoCoordinateCompound
 | MoCopyFromInput
 | MoDeriv
 | MoDerivAffApp
 | MoDerivAffMsa
 | MoDerivStepMsa
 | MoDerivTrace
 | MoEndoCompound
 | MoExoCompound
 | MoForm
 | MoGlossItem
 | MoGlossSystem
 | MoInflAffixSlot
 | MoInflAffixSlotApp
 | MoInflAffixTemplate
 | MoInflAffMsa
 | MoInflClass
 | MoInflTemplateApp
 | MoInsertNC
 | MoInsertPhones
 | MoModifyFromInput
 | MoMorphAdhocProhib
 | MoMorphData
 | MoMorphSynAnalysis
 | MoMorphType
 | MoPhonolRuleApp
 | MoReferralRule
 | MoRuleMapping
 | MoStemAllomorph
 | MoStemMsa
 | MoStemName
 | MoStratum
 | MoStratumApp
 | MoUnclassifiedAffixMsa
 | Note
 | PartOfSpeech
 | PhBdryMarker
 | PhCode
 | PhContextOrVar
 | PhEnvironment
 | PhFeatureConstraint
 | PhIterationContext
 | PhMetathesisRule
 | PhNaturalClass
 | PhNCFeatures
 | PhNCSegments
 | PhPhonContext
 | PhPhonData
 | PhPhoneme
 | PhPhonemeSet
 | PhPhonRuleFeat
 | PhRegularRule
 | PhSegmentRule
 | PhSegRuleRHS
 | PhSequenceContext
 | PhSimpleContext
 | PhSimpleContextBdry
 | PhSimpleContextNC
 | PhSimpleContextSeg
 | PhTerminalUnit
 | PhVariable
 | PubDivision
 | PubHeader
 | PubHFSet
 | Publication
 | PubPageLayout
 | PunctuationForm
 | Reminder
 | ReversalIndex
 | ReversalIndexEntry
 | RnGenericRec
 | RnResearchNbk
 | RnRoledPartic
 | ScrBook
 | ScrBookAnnotations
 | ScrBookRef
 | ScrCheckRun
 | ScrDifference
 | ScrDraft
 | ScrFootnote
 | ScrImportP6Project
 | ScrImportSet
 | ScrImportSFFiles
 | ScrImportSource
 | Scripture
 | ScrMarkerMapping
 | ScrRefSystem
 | ScrScriptureNote
 | ScrSection
 | ScrTxtPara
 | Segment
 | StFootnote
 | StJournalText
 | StPara
 | StStyle
 | StText
 | StText
 | StTxtPara
 | Text
 | TextTag
 | UserAppFeatAct
 | UserConfigAcct
 | UserView
 | UserViewField
 | UserViewRec
 | WfiAnalysis
 | WfiGloss
 | WfiMorphBundle
 | WfiWordform
 | WfiWordSet
 | WordFormLookup
 | WordformLookupList


Diagrams
 | ***Legend for CELLAR Diagrams
 | Annotations
 | CellarServer
 | Checklists
 | CmAgent
 | CmPossibility
 | Data Notebook
 | Discourse
 | FsFeature System
 | Interlinear Texts
 | Language Project
 | Lexical Database
 | Morphological Derivation
 | Morphological Glossing
 | Morphology
 | Morphology Affixes
 | MorphologyOld
 | MorphoPhonology
 | PartOfSpeech
 | Publications
 | Scripture
 | Structured Text
 | Tagging
 | User Configuations
 | UserViews
 | Wordform Inventory


Dictionary

View: | Hide Browser | Browser on the left | Browser on the right
Index: | | A | B | C | D | E | F | G | H | I | K | L | M | N | O | P | Q | R | S | T | U | V | W | Z | Symbol | Unnamed |

Dictionary

A
Abbrev | Attribute from Class ScrBook | The abbreviation for the name of the Scripture Book. Initialized from ScrBookRef.BookAbbrev. For books that belong to Scripture.ScriptureBooks, this name should be in synch. with ScrBookRef.BookAbbrev. After books are moved to ScrDraft.Books, they retain the abbreviation that they had at the time that they were archived. This allows the historic metadata to be persisted. Otherwise the metadata in an archived book would change as ScrBookRef changes.
abbrev | TagDefinition from Package UML Standard Profile
abbrev1 | TagDefinition from Package UML Standard Profile
Abbreviation | Attribute from Class Text | This abbreviation is used when referencing segments from the text.
Abbreviation | Attribute from Class MoInflClass | a multiUnicode string, storing an abbreviated form of the Name. Probably useful for displays. Probably defaults to the first eight or so chars of the Name.
Abbreviation | Attribute from Class MoStemName | a multiUnicode string, storing an abbreviated form of the Name. Probably useful for displays. Probably defaults to the first eight or so chars of the Name Another test.
Abbreviation | Attribute from Class MoStratum | stores an abbreviated form of the Name. Probably useful for displays. Probably defaults to the first eight or so chars of the Name.
Abbreviation | Attribute from Class FsFeatDefn
Abbreviation | Attribute from Class FsSymFeatVal
Abbreviation | Attribute from Class FsFeatStrucType
Abbreviation | Attribute from Class CmPossibilityList
Abbreviation | Attribute from Class CmPossibility
Abbreviation | Attribute from Class MoGlossItem
Abbreviation | Attribute from Class PhNaturalClass
access | Stereotype from Package UML Standard Profile | Access is a stereotyped permission dependency between two namespaces, denoting that the public contents of the target namespace are accessible to the namespace of the source package.
ActivatedFeatures | Association from Package LangProj
ActivatedLevel | Attribute from Class UserAppFeatAct
ActualForm | Operation from Class MoStemMsa | ActualForm(FsFeatureStucture): a virtual attr which when queried with a particular FsFeatureStucture as an argument returns the WfiWordform of the corresponding suppletive cell (see the attr vSuppletiveForms) if any, or else the value of the corresponding vRegularForm (which may be none, if the paradigm is defective). Suppletive cells thus override regular cells in this attr. This attr is atomic, in contrast with the seq attr vSuppletiveForms. Also, the WfiWordform returned by this attr may or may not have an owner, depending on whether or not the result came from the WordformInventory, or was constructed on the fly.
AdhocCoProhibitions | Association from Package Ling | Used to hold the list of ad hoc cooccurrence restrictions. (Ideally, this is empty!)
AdhocCoProhibitions | Operation from Class MoMorphSynAnalysis | a virtual attr, consisting of the backrefs to this object from MoAdhocCoProhibition objects. The other refs from each such co-occurrence object point to other morphemes with which this stem or affix cannot co-occur.
Adjacency | Attribute from Class MoAdhocProhib | refers to one of the following possibilities: Anywhere: The morphemes (or allomorphs) in question are constrained from appearing anywhere together in the same word. SomewhereToLeft and SomewhereToRight: The second (and later) morpheme (or allomorph) is constrained from appearing anywhere in the word to the left (right) of the first morpheme (respectively, allomorph). AdjacentToLeft and AdjacentToRight: The second (and later) morpheme (or allomorph) is constrained from appearing immediately to the left (right) of the first morpheme (respectively, allomorph) in the same word.
AffixCategories | Association from Package LangProj | In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. The AffixCategoryList is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a MoAffixCategory of "derv" (derivational affix). Refer to MoInflectionalAffixMsa and MoDerivationalAffixMsa for more information.
AffixCategory | Association from Package Ling | In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. This field is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a CmPossibility of "derv" (derivational affix).
AffixCategory | Association from Package Ling | In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. This field is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a CmPossibility of "derv" (derivational affix).
AffixForm | Association from Package Ling | refers to the MoAffixAllomorph, giving the phonetic form of the affix.
AffixForm | Association from Package Ling | refers to an MoAffixForm, the allomorph of the inflectional affix which was attached. If the application of this slot results in an implicit zero affix (because none of the MoInflectionalAffixMsas belonging to this MoInflAffixSlot matched the InflectionalFeatures of the owning MoDerivation), this AffixForm will be none.
AffixMsa | Association from Package Ling | refers to an MoDerivationalAffixMsa, giving the morphosyntactic information about the affix.
AffixMsa | Association from Package Ling | refers to an MoInflectonalAffixMsa, the inflectional affix which was attached. Note that this MSA does not result in any change to the MSA of the word. As with the AffixForm attr, if the application of this slot results in an implicit zero affix (because none of the MoInflectionalAffixMsas belonging to this MoInflAffixSlot matched the InflectionalFeatures of the owning MoDerivation), this AffixMsa attr will be none.
AffixSlots | Association from Package Ling | owns a collection seq of MoInflAffixSlot, which may be referred to in MoInflAffixTemplates.The reason for having the ownership of Affix Slots reside here, rather than their being owned by the Affix Templates themselves, is to allow different Affix Templates to share Affix Slots. For example, suppose that in some language, both subject and object agreement are marked on the verb, and that the user has accordingly specified distinct parts of speech (and therefore distinct paradigms) for transitive and intransitive verbs. In all likelihood, most of the slots will be alike (tense and aspect marking, etc., and perhaps the subject agreement slot). The common affix slots can be shared if they are owned by the super-category verb (see the attribute vAllAffixSlots, below). Similarly, in Tzeltal nouns use the same prefixes for marking possessors as transitive verbs use for marking subjects. Assuming appropriate morphosyntactic features could be devised to represent the person of possessors and subject-of-transitives in Tzeltal, it would be nice to use the same MoInflAffixSlot for both. But this would be impossible, if the Affix Slots were owned by the Affix Templates (since nouns and verbs do not in general share those templates). It becomes possible if the Affix Slots are owned at some point in the part of speech inheritance hierarchy above noun and (transitive) verb, and referred to by the Affix Templates for these two categories.
AffixTemplates | Association from Package Ling | owns an ordered seq of MoInflAffixTemplates, which define how affixation (but not choice of stems) works for this part of speech. The reason this is an ordered sequence attribute, rather than atomic, is to allow the user to capture the fact that the number of slots can be different for different parts of the paradigm (infinitives, for example, or tenses which are partly inflected on the main verb and partly on an auxiliary verb). The order of templates in this attribute is relevant: the first MoInflAffixTemplates whose Region attr is a subset of the inflectional features to be realized on the word, is chosen.Note the assumption here that all the words belonging to a single part of speech have fundamentally the same paradigm (and therefore the same set of affix templates), and that differences are accounted by membership in distinct MoInflectionClasses (Carstairs 1987: 10-11, Carstairs-McCarthy 1998b: 324). The fact that in languages which mark the verb for agreement with both subject and object, transitive verbs have different paradigms from intransitive verbs (transitives usually have an additional slot for object marking-or for subject marking, in the case of ergative languages), might seem to be a counterexample. The reason that is not a counterexample, is that transitive and intransitive verbs can be treated as separate parts of speech using the inheritance hierarchy.
AfterSeparator | Attribute from Class MoGlossItem
Alias | Attribute from Class CmPerson
AllomorphIndex | Association from Package Ling
Allomorphs | Association from Package Ling | refers to a seq of MoForm objects, the co-occurrence of which is ungrammatical. Usually, there will be exactly two such allomorphs. If there are three or more allomorphs, the intended meaning is that a word is ungrammatical in which all such morphemes appear (but the co-occurrence of only some of the morphemes is not prohibited). Having only one morpheme in this attribute should be flagged as a Warning, since such a restriction can do nothing. When the Adjacency attribute is 'Anywhere', the fact that this attribute is a seq, rather than a collection, is unimportant. But the order of allomorphs becomes important when the Adjacency attribute has any other value. Specifically, the order of the allomorphs in this attribute is interpreted as a left-to-right order.
Allomorphs | Operation from Class MoDerivAffMsa | virtual attr returning a seq of MoAffixForm, giving the stored allomorphs of this Msa. The following definition will work for the subclass MoAffixAllomorph; whether it will also work for MoAffixProcess depends on how that class is ultimately defined (in particular, on whether it has an attr MsEnvPartOfSpeech): selectIf({|A| (accepts(^A) of !MoAffixForm and ((isMissing of MsEnvPartOfSpeech of ^A) or (MsEnvPartOfSpeech of ^A = my FromPartOfSpeech) ) ) }) of Forms of my owner In the process of converting an Item-and-Arrangement description into an Item-and-Process description, the user may delete allomorphs which are derivable by phonological rule from an underlying form, and collapse allomorphs which can be derived by an IP-type morphological rule (see MoAffixProcess).
Allomorphs | Operation from Class MoStemMsa | a virtual attr returning a seq of MoStemAllomorph, giving the allomorphs which are stored (and are therefore presumably not predictable by phonological rule). Defined as selectIf({|A| (isMissing of StemName of ^A or includes(StemName of ^A) over StemNames of my partOfSpeech) }) of selectIf({|A| accepts(^A) of !MoStemAllomorph}) of forms of my owner i.e. the stem allomorphs of the LexEntry which are available to this stem by virtue of its part of speech. Normally, there should be no more than one stem in this attr with a given MoStemName, and only one stem with no stem name. However, it will be possible to violate this one-to-one limit if the stems with the same stem name (or those with no stem) are disjunctive by virtue of the phonological environments in which they may appear. In trivial cases, it may be possible to ensure that this criterion is met. For example, if one stem appears before consonants and the other before vowels, this criterion is met. But there are other cases for which it will be more difficult to ensure disjunctiveness. The result will be ambiguity in the algorithm for choosing a stem allomorph. In the process of converting an Item-and-Arrangement description into an Item-and-Process description with underlying forms (in which allomorphs are generated “on the fly” using phonological rules), the user will be deleting allomorphs which are predictable by rule. At present, the model does not have phonological rules, so this issue is moot. The order of the stems in this attr is not important; the disjunctive ordering of stems based on their StemName attribute is based on the order of the MoStemName objects in PartOfSpeechGrammar.doc - PartOfSpeech.vAllStemNames, not on the order of the stems here. (I.e. it is not possible for a given lexeme to impose a different disjunctive order from that given by its inflection class.) It might be convenient to display the allomorphs in this attr in the disjunctive order, or perhaps in the reverse order (from most general to most specific).
Allomorphs | Operation from Class MoInflAffMsa | virtual attr returning a seq of MoAffixForm. Defined as selectIf({|P| accepts(^P) of !MoAffixForm}) of Forms of my owner Unlike the analogous attrs on MoStemMsa and on MoDerivationalAffixMsa, there doesn't seem to be the possibility-or probably the need-for filtering the allomorphs belonging to the owning LexEntry according to their part of speech.
AllowsComment | Attribute from Class CmAnnotationDefn | True = user can type in a comment associated with the Annotation. False = user cannot type in a comment. Example: a user may tag a section of text with OCM 152 but also want to provide a comment as to why he tagged it in this way.
AllowsFeatureStructure | Attribute from Class CmAnnotationDefn | T = Annotation can carry a FsFeatStruc.
AllowsInstanceOf | Attribute from Class CmAnnotationDefn | T = Annotation can be selected from a list of instances of a particular CmObject. Example: OCM annotations are contextual instances of the AnthroList items.
AllReferenceForms | Operation from Class MoInflClass | a virtual attr returning the complete set of reference forms for this inflection class. May be defined as: [my ReferenceForms, if accepts(my owner) of !MoInflectionClass then vAllReferenceForms of my owner] Note that there would be no reason to have duplicate FsFeatStrucs in this attr. While this could be enforced by defining this attr to return only the unique elements, it might be better to define an update handler on the ReferenceForms attr to resolve duplication between feature structures defined in any given inflection class, and inherited feature structures (whether inherited by this inflection class, or inherited from this feature class).
AllRulesOfReferral | Operation from Class MoInflClass | virtual attribute returning all rules of referral for this inflection class. Defined as follows: [my RulesOfReferral, selectIf({|RR| not of includes(name of ^RR) over name of my RulesOfReferral}) of vAllRulesOfReferral of my owner] Note that under this definition, if there is both this inflection class and a higher inflection class have a rule of referral with the same name, the rule for this inflection class takes precedence.
AllStemNames | Operation from Class MoInflClass | a virtual attr returning the stem names defined in this inflection class, any higher (more abstract) inflection classes, and in the part of speech to which this inflection class belongs. Since we have inheritance of stem names from part of speech and from inflection class, some difficult problems arise if the user attempts to add the same stem name to both. The resolution is to have prioritized multiple inheritance, with the stem name of the inflection class "winning." That is, the definition of default stem and default affix given in the stem name belonging to the inflection class supercedes that given in the part of speech. (A stem name defined on a given inflection class also supercedes that defined on a super-inflection class, but that behavior is given by ordinary inheritance, so that no issue of prioritized inheritance arises here.) One way to define this inheritance would be to list all the inherited stem names in order of inheritance, beginning with the StemNames attr of the current inflection class and proceeding to those inherited from more abstract levels, but to allow the use of only the first of those stem names. Alternatively (and perhaps less error-prone), would be to define this attr to include only those stem names valid for this inflection class. Under this view, the definition would be something like the following: [my StemNames, selectIf({|SN| not of includes(name of ^SN) over name of my StemNames}) of vAllStemNames of my owner]
AllSubClasses | Operation from Class MoInflClass | a virtual returning all the MoInflectionClasses for this inflection class. (= [my Subclasses, vAllSubclasses of my Subclasses]).
AlternateForms | Association from Package Ling | This holds alternate forms, or allomorphs, in addition to the lexeme form. The lexeme form is also an allomorph if it is not abstract. These forms along with the lexeme form (when not abstract) are used by the parser.
AMPLEStringSegment | Attribute from Class PhEnvironment | This is for storing AMPLE and Shoebox (converted to AMPLE) info about phonetic environments. This will probably be eventually deleted when we decide what to do with Shoebox/AMPLE import and relationship to the LexEntry legacy information.
Analyses | Association
Analyses | Association from Package Ling
AnalysisStatus | Association from Package LangProj
AnalysisWss | Attribute from Class LangProject | Changed from AnalysisWritingSystems This is a space-delimited list of writing system tags.
AnalyzedTextObjects | Association from Package Cellar | AnalyzedTextObjects is used when there are associated analyses with any objects in the text. It is primarily meant for morphological interlinear analysis of text. Reference pointers to TxtWordformInContext (one for every word, punctuation and reference in the text) are set in a sequence. Note: the name of the class will likely change to TxtObjInContext because it handles more than just words. Refer to the documentation on TxtWordformInContext for more information. This attribute is used only if the application requires it. It does not obviate the need for TextObjects
AnalyzingAgents | Association from Package Ling
AnalyzingAgents | Association from Package LangProj | At this point, in time (Jan, 2002) CmAnalyzingAgents are used only by MoMorphological data. Refer to CmAnalyzingAgent for more info.
AnnotationDefs | Association from Package LangProj | Changed from AnnotationDefinitions.
Annotations | Association from Package LangProj
Annotations | Class Diagram
AnnotationType | Association from Package Cellar | An annotation is of a particular type. The AnnotationDefn defines possible behaviors for an annotation.
AnthroCentral | Attribute from Class WordFormLookup
AnthroCodes | Association from Package Ling
AnthroCodes | Association from Package Ling
AnthroCodes | Association from Package Notebk | OcmCodes - User applies OCM tags to this particular record.April 5, 2001 - The following documentation needs to be updated.This is where the user applies tagging at the scope of the entire record. Tags will be to such lists as the FRAME (the modified Outline of Cultural Materials), a grammar outline, and numerous other outlines that will be included with the system. After doing this tagging, the user will be able to quickly find all records that pertain to a particular topic. (In the user interface, we will provide mechanisms to facilitate fast tagging, including choosing which outline to tag from.)
AnthroList | Association from Package LangProj
AnthroNote | Attribute from Class LexSense
App | Attribute from Class UserView
App | Attribute from Class CmFilter
Appendixes | Association from Package Ling
Appendixes | Association from Package Ling
ApplicationId | Attribute from Class UserAppFeatAct | From AppCompat$? Which apps are installed? Look in registry?
appliedProfile | Stereotype from Package UML Standard Profile | This dependency is used to indicate which profiles are applicable to a package. Typically, the client is an ordinary package or a model (but could be any other kind of package), while the supplier is a profile package. This means that the profile applies transitively to the model elements contained in the client package, including the client package itself.
AppliesTo | Association from Package Cellar
Approves | Association from Package Cellar | The agent evaluation which objects being evaluated refer to in order to indicate that this agent approves or accepts them.
ArchivedDrafts | Association from Package Scripture
association | Stereotype from Package UML Standard Profile | Specifies a real association (default and redundant, but may be included AssociationEnd for emphasis).
association | Stereotype from Package UML Standard Profile | Association is a constraint applied to a link-end, specifying that the corresponding instance is visible via association.
Author | TagDefinition
auxiliary | Stereotype from Package UML Standard Profile | Specifies a class that supports another more central or fundamental class, typically by implementing secondary logic or control flow. The class that the auxiliary supports may be defined explicitly using a Focus class or implicitly by a dependency relationship. Auxiliary classes are typically used together with Focus classes, and are particularly useful for specifying the secondary business logic or control flow of components during design. See also: «focus».
B
BackColor | Attribute from Class CmPossibility | BackColor for overlay functionality.
BackTransSources | Association | Sources for scripture back translations. More than one is used only if back translations are written in diverse analysis languages.
balking | Stereotype from Package UML Standard Profile | message In the balking message case the sender abandons the message if the receiver is not ready.
balking | Stereotype from Package UML Standard Profile | message In the balking message case the sender abandons the message if the receiver is not ready.
BasedOn | Association from Package Cellar | The linguistic text that the chart organizes (currently part of a Text, but could also be part of Scripture).
BasedOn | Association from Package Cellar
BaseFontSize | Attribute from Class Publication | Default font size for the publication, in millipoints.
BaseLineSpacing | Attribute from Class Publication | Default line spacing for the publication in millipoints, negative if Exact spacing, positive if At Least spacing.
BasicIPASymbol | Attribute from Class PhPhoneme | This is the IPA symbol for the basic phonetic form of this phoneme. We use it to produce a first guess at the phonological features and the (English) description of this phoneme. We also show it in the Grammar Sketch.
BearableFeatures | Association from Package Ling | refers to a collection seq of FsFeatureDefn, each of which is a morphosyntactic feature which a word of this part of speech can bear. This is primarily intended for features which may be important to the derivational morphology, although these features may also be relevant to inflectional morphology. For example, the English suffix -ess is added only to animate nouns: waitress, lioness, actress, but *tabless, *officess; ?ful attaches to abstract nouns: graceful, useful, helpful, but *personful, *buildingful, *actorful.The notion of features that a given part of speech can bear is generally implicit in works on morphology, but see Lieber 1992: 90-91.
become | Stereotype from Package UML Standard Profile | Specifies a Flow relationship, source and target of which represent the same instance at different points in time, but each with potentially different values, state instance, and roles. A Become Dependency from A to B means that instance A becomes B with possibly new values, state instance, and roles at a different moment in time/space.
BeginAnalysisIndex | Attribute from Class TextTag | These indices refer to the index of an IAnalysis object in a Segment.Analyses sequence.
BeginAnalysisIndex | Attribute from Class ConstChartWordGroup | Indicate the words that occur in the indicated cell of the chart.
BeginMarker | Attribute from Class ScrMarkerMapping | Marker used for opening delimiter of a data run.
BeginObject | Association from Package Cellar
BeginOffset | Attribute from Class Segment
BeginOffset | Attribute from Class CmBaseAnnotation | For Annotations that annotate a text string fragment or a media file fragment, we set the BeginOffset and EndOffset.
BeginRef | Attribute from Class CmBaseAnnotation | For Scripture use, this will be used to store begin Scripture references. The int actually encodes book, chapter, and verse for Consultant Notes, Translator Notes, Change History Notes, etc. The attribute is available for other uses in other applications.
BeginSegment | Association from Package Cellar | If BeginSegment is null, then there are no words in the WordGroup and this represents a User-entered marker indicating the User wants a special "missing" marker to show up in this cell highlighting that fact that nothing occurs in this cell (presumably because normally there would be something in this column). [Presentation note: currently this is displayed as "---".]
BeginSegment | Association from Package Cellar
Bibliography | Attribute from Class LexEntry | Bibliographic information
Bibliography | Attribute from Class LexSense
bigString | DataType from Package Data types
bigUnicode | DataType from Package Data types
binary | DataType from Package Data types
binary | DataType from Package Data types
BindingEdge | Attribute from Class Publication | Enumeration indicating on which edge the publication is to be bound (which determines the position of the gutter margin): 0 (default) — indicating left 1 — indicating right 2 — indicating top any other value — indicating error: not defined
BookAbbrev | Attribute from Class ScrBookRef | The default human-readable book abbreviation, e.g. 2 Cor., for each writing system.
BookAnnotations | Association | Book-by-book sequence of annotations that are specific to the scripture text. As of January 2006, these are just scripture notes. We have not yet decided whether to store the annotations generated by checking tools here Scripture annotations are stored book-by-book to make for faster access and filtering.
BookId | Association from Package Scripture | A reference to a ScrBookRef. This association is for convenience. The correct item in ScrBookRef could also be found using ScrBook.CanonicalNum.
BookName | Attribute from Class ScrBookRef | The current full book name, e.g. 2 Corinthians for each writing system.
BookNameAlt | Attribute from Class ScrBookRef | The current alternate full book name, e.g. II Corinthians, for each writing system.
Books | Association
Books | Association from Package Scripture
boolean | DataType from Package Data types
boundary | Stereotype from Package UML Standard Profile | A boundary is a class that lies on the periphery of a system, but within it. It interacts with actors outside the system as well as with entity, control, and other boundary classes within the system.
BoundaryMarkers | Association from Package Ling | collection seq of PhBdryMarker
Bridge | Attribute from Class Scripture | Bridge is a string (usually one character) that bridges contiguous chapter and/or verse ranges in a reference. In the U.S.A., this is traditionally a dash (-), e.g., Mat 24:16-25; Rev 1:7-2:9.
C
call | Stereotype from Package UML Standard Profile | Call is a stereotyped usage dependency whose source is an operation and whose target is an operation. The relationship may also be subsumed to the class containing an operation, with the meaning that there exists an operation in the class to which the dependency applies. A call dependency specifies that the source operation or an operation in the source class invokes the target operation or an operation in the target class. A call dependency may connect a source operation to any target operation that is within scope including, but not limited to, operations of the enclosing classifier and operations of other visible classifiers.
CanCreateOrphan | Attribute from Class CmAnnotationDefn | When the objects an Annotation refers to are deleted: T = Keep Annotation F = Delete Annotation For some types of annotations we may want the annotation to persist, even though the object it annotates no longer exists. What happens to an annotation when the object it annotates disappears: 1. If the object it points to goes away, get rid of the annotation. 2. If the range becomes empty the Annotation goes away. QUESTIONS: 3. If something gets deleted at the beginning or the end, do you jump right or left? 4. If an object is owned by another object, do you move the annotation to the owner? Refer to http://mpj.cx/twiki/bin/view.pl/Wordworks/Mar2003OutcomesMinutesDiscussions for further discussion.
CanonicalNum | Attribute from Class ScrBook | Canonical Book number, a unique sequential ID number for which book of the canon that this one is. May be used for ordering the books in canonical order and for identifying the book to other applications. Persists the canonical identity of a book even if the BookId becomes invalid.
Caption | Attribute from Class CmPicture | The caption in a string/publication/etc.
Cases | Association from Package Ling
CatalogSourceId | Attribute from Class FsFeatStrucType | Needed to make inflection feature catalog UI work.
CatalogSourceId | Attribute from Class FsFeatDefn | Needed to make inflection feature catalog UI work.
CatalogSourceId | Attribute from Class FsSymFeatVal | Needed to make inflection feature catalog UI work.
CatalogSourceId | Attribute from Class PartOfSpeech | This property is used to store a unique key string indicating the reference for the part of speech from the Gold (or some other) master list.
Categories | Association from Package Cellar | Place to indicate zero to many standard categories to which the issue discussed in the note might belong. USB and CONNOT categories will be supplied on a factory installed list. This is an open (user modifiable) list.
Category | Association from Package Ling
Cellar | Project model
Cellar | Package from Package Component View
CellarServer | Class Diagram
Cells | Association from Package Ling
Cells | Association from Package Cellar
CenteredText | Attribute from Class PubHeader | The contents of the portion of the header that is centered between the margins.
ChapterLabel | Attribute from Class Scripture | String that will be insterted when a chapter number heading is genetrated.
ChapterVerseSepr | Attribute from Class Scripture | ChapterVerseSepr is a string (usually one character) that separates the chapter number from the verse number in a reference. In the U.S.A., this is a traditionally colon (:), e.g., Mat 24:16.
ChartMarkers | Association from Package Ling | This list stores markers that can be inserted into the chart to provide additional labelling. The top-level is several different kinds of markers (initially Tense/Aspect/Mood, Pronouns, and Demonstatives), and below those are the (sometimes hierarchical) lists of possible markers for that type. Combining them like this makes it easy to add new categories as well as items.
Charts | Association from Package Ling | Actual instances of discourse charts (tentatively of all types, even though we currently only have one type: Constituent Chart).
CheckId | Attribute from Class ScrCheckRun | A GUID uniquely identifying the check.
CheckLists | Association from Package Cellar | The CheckLists will be a collection of CmPossibilityList objects, each with a unique identifier. For example, one CmPossibilityList will be called KeyTerms which will represent a hierarchical list of Biblical key terms. The possibility lists can be imported programmatically from external files. Each CmPossibilityList will hold ChkItem objects (derived from CmPossibility).
Checklists | Class Diagram
Checksum | Attribute from Class WfiWordform | We calculate a checksum based on the result string returned from the parser. If this value has changed from the last time, we file the new results. Otherwise, we leave the results alone.
ChkHistRecs | Association | Records the date and results of the latest run of each check
ChkRef | Class from Package Ling | This object contains details about an occurrence of a ChkTerm in the original text so the user can see where a rendering of that term is supposed to exist, as well as information about the actual rendering in the vernacular text.The Ref, Location, and KeyWord fields together comprise a unique key that can be used if necessary to associate this object with a node in a similar list which is organized differently.
ChkRendering | Class from Package Ling | Represents a rendering (i.e. vernacular equivalent) for a term. This class exists to allow a single place where users can identify the specific gloss for each unique rendering of a key term or name and record an explanation about the rendering decision.
ChkSense | Class from Package Ling | Relates a check item to a particular lexical sense of a lexical item. Stores explanatory information about this relationship. From this sense other information about the lexeme can be inferred, such as the lexical stem or the citation form. The lexical item may be inflected but the inflection is not pertinent to the check item. (If a specific inflection with a special sense is needed, add a lexical entry for the specific inflection as a subentry of the more general lexical item and add the special sense to this subentry.) Needed by Key Terms checking and other semantically-based checklists.
ChkTerm | Class from Package Ling | List item for a term to be checked for proper rendering to an equivalent term or terms for one or more references in a vernacular text. The CmPossibility.Name field will contain the Lemma form of the term in the original language (i.e., Greek or Hebrew) in the grc or heb alternative. ("grc" and "heb" are the ICU locales.) The primary English gloss would be in the en alternative, and glosses in other localizations would be stored in their respective alternatives. Since terms will often have multiple vernacular equivalents, and we need to be able to store literal back translations for those, the Name will not be used for vernacular equivalents. The CmPossibilty.Description can contain additional information about the term in the analysis language(s). It might also contain a list of other derived forms of the term in the original language.
CitationForm | Attribute from Class LexEntry | If this is missing, then this defaults to the lexicalForm but the user has the option of specifying a real citation form especially useful for bound roots.
ClassId | Attribute from Class CmFilter
ClauseType | Attribute from Class ConstChartRow | This is an enum with these values: Normal, Dependent, Song, and Speech.
Clsid | Attribute from Class UserViewRec
CmAgent | Class from Package Cellar | A human or computational analysis agent associated with various linguistic analyses. Currently (Jan, 2002) are used only by the morphological parsing system for words. Using agents, the system stores whether or not a particular word parse is validated by the lexicon and the state of the word grammar. The UI will allow the user to also create word parses manually (thus a human agent) or to indicate to the system that he, the user, has verified a computational parse.
CmAgent | Class Diagram
CmAgentEvaluation | Class from Package Cellar
CmAnnotation | Class from Package Cellar | The user can annotate another object in any number of ways. An annotation represents some level of analysis or tagging on a object or fragment of an object (a portion of text, or a media file). Analyses can include a freeform comment, a tag from a tag list, a featureStructure or combination of the above. There are two particular uses of this object that we are thinking of right now: a. tagging texts or media files with various types of annotations (OCM, grammatical, semantic, etc.) and b. tagging objects with system level annotations ... for example, parses with "incomplete analysis". This model is extremely generalized and it may be that we need to add subclasses for specialized behaviours. We may want to subclass the current Annotation class to make lighter annotation classes. For example, EndObject and OtherObjects might go on a "MultiObjectAnnotation". TextWordformInContext (which has been removed from the model ... we may perhaps need a subclass) will definitely not care about the endObject. The majority of annotations won't need an EndObject ... only those that span multiple paragraphs. For now, Annotations are ownerless. Might need to have it owned by LangProject for cache purposes. Question: Can an annotation point to two or more objects from different projects? At this point it cannot cross databases because we would need an attribute for the database itself.
CmAnnotationDefn | Class from Package Cellar | In all likelyhood, a subclass of CmPossibility. Defines a possible type of annotation.
CmAnthroItem | Class from Package Cellar
CmBaseAnnotation | Class from Package Cellar
CmCell | Class from Package Cellar
CmCustomItem | Class from Package Cellar | Purpose is to allow users to add custom fields to custom lists without affecting standard lists.Since these lists are global in a database (since we are modifying the Field$ table) they can't be owned by a language project, so custom lists will be another unowned object.
CmDomainQ | Class from Package Cellar | Was CmDomainQuestion
CmFile | Class from Package Cellar
CmFilter | Class from Package Cellar
CmFolder | Class from Package Cellar
CmIndirectAnnotation | Class from Package Cellar
CmLocation | Class from Package Cellar
CmMajorObject | Class from Package Cellar
CmMedia | Class from Package Cellar | This provides a class for linking to a media file which may be a .wav sound clip, .wmv movie clip, etc. It also allows the user to enter a label describing the file contents.
CmMediaAnnotation | Class from Package Cellar | Yet to be defined. Will probably point to a RnMedia item.
CmObject | Class
CmObject | Class from Package Cellar
CmOverlay | Class from Package Cellar | An overlay is a collection of CmPossibilities used to mark up text in a StText. The formatting for each item is defined by properties on the CmPossibiliy. In the original model, we had model CmOverlayTag that could carry their own formatting apart from the formatting defined in the CmPossibility. In the current model, we have removed this capability.
CmPerson | Class from Package Cellar
CmPicture | Class from Package Cellar
CmPossibility | Class from Package Cellar | In regards to how this is implemented in FieldWorks, Ken says ... In SQL code, you could place a CmPerson in a "MoMorphTypeList" and it would be perfectly happy. However, our list editor always uses the ItemClsid to create any new items that are created in the list, so it is enforced in this way. Presumably, any other application that might create possibilities would also check ItemClsid and create the correct type of object for the list. If not, it is a bug.
CmPossibility | Class Diagram
CmPossibilityList | Class from Package Cellar
CmProject | Class from Package Cellar
CmResource | Class from Package Cellar | Name and version of an external data resource used by FieldWorks
CmRow | Class from Package Cellar
CmSemanticDomain | Class from Package Cellar | This class is used to represent around 1,800 of Ron Moe's semantic domains (backslashes refer to his Standard Format markers): \is 2.7.1 -- maps to English Abbreviation of CmPossibility \sd -- maps to English Name of CmPossibility \sdf -- maps to French Name of CmPossibility \dd -- maps to English Description of CmPossibility
CmTranslation | Class from Package Cellar | Used for handling various types of translations of a paragraph. For Scripture this includes a back translation. For vernacular texts, this includes free and literal translations.
Codes | Association from Package Ling | a collection of PhCodes (which amounts to a seq of strings), each in a single encoding (but not perhaps all in the same encoding). Each string is a representation of the phoneme or boundary marker in that encoding.
Column | Association from Package Cellar | Specifically a column identifier.
ColumnInfo | Attribute from Class CmFilter
Comment | Attribute from Class LexEntry | Free text field for notes about environment of a variant or any other note. (This used to be on LexVariant and LexMinorEntry.)
Comment | Attribute from Class LexReference | This allows the user to add a comment to the set. We don't allow comments on individual links, but generally this comment can refer to individual items, if desired.
Comment | Attribute from Class CrossReference | To be used after version 1 for indicating the reason for a cross-reference. It is quite likely that a pointer to a list of types of cross-references will also be included in the future.
Comment Attribute from Class CmAnnotation Not sure what the signature here should be yet. multiBigString, multiUnicode, StText?

Probably, in most cases, only BigString will be needed.

Comment | Attribute from Class LexEtymology
CompDetails | Attribute from Class CmAnnotation | Data stored and used by specialized computer agents (e.g. computational parsers) in the FieldWorks system. Most likely will be stored in XML format.
ComplexEntryTypes | Association from Package Cellar | This Complex Entry Types list is used to classify a LexEntryRef via the ComplexEntryTypes property. ItemClsid should be set to LexEntryType, IsSorted to true, and Depth to 127. The list will typically be flat, but the user is free to introduce a hierarchy if desirable. When entries use this list, they will be displayed as subentries in the dictionary. Entries using this list will be displayed as subentries in the dictionary; usually at the end of the major entry and will typically produce a separate major entry in the dictionary referring to the main entry. The display is dependent on whether a root-based or stem-based view of the dictionary is being printed. The initial list may have: Acronym Compound Contractions Derivation Idiom Phrasal Verb Saying
ComplexEntryTypes | Association from Package Ling | This property points to one or more items in the Complex Entry Types list for complex entries. It is unused for variant entries, although the model allows for both to be used if desirable. Normally a complex LexEntryRef will point to more than one main entry or sense via PrimaryLexemes and ComponentLexemes. Entries using ComplexEntryTypes will be displayed as subentries in the dictionary; usually at the end of the major entry and will typically produce a separate major entry in the dictionary referring to the main entry. The display is dependent on whether a root-based or stem-based view of the dictionary is being printed. The referenced LexEntryType is used to control the display of the complex information in the main entry context as well as the minor entry context. See the description of VariantEntryTypes for using the information from the LexEntryRef for display purposes.
ComplexNameFirst | Attribute from Class MoGlossItem | to control whether the name gloss precedes or follows the value bundle gloss. It should be possible to specify global defaults for these, as well as to override them for specific gloss items.
ComplexNameSeparator | Attribute from Class MoGlossItem | separates the gloss for the feature name from the gloss string for the value bundle
ComponentLexemes | Association from Package Cellar | The UI limits this to a sequence of LexEntry or LexSense. For variants, this field points to the main entry or sense. When not hidden, this will produce a minor variant entry that always shows the main entry referenced here. This variant will always be shown in the main entry being referenced. ComponentLexemes is ignored in this case. For complex entries, this property lists the components for this idiom, derivation, compound, etc. All of the listed components will be displayed in the subentry following the headword. For example, emphanizoo (cmpd. of en, pha, -an, -id). Whether they get displayed as subentries is controlled by the PrimaryLexemes property. This allows the user to specify component lexemes for productive lexemes without cluttering the printed dictionary.]
Components | Association from Package Ling | points to an ordered seq of other MoMorphoSyntaxAnalysis objects, which are interpreted as the morphemes or stems that make up this object. Additional Notes: Ordinarily, this would only be appropriate for stems which are not roots, hence it would be an attribute of MoStemMsa. I believe it is here on the superclass because under the stealth-to-wealth concept, the user may be in a state where he realizes something is composite, but has not yet worked out all the morphemes of which it is composed. This attribute could then be used to point to the parts that have already been discovered. Possibly when the user succeeds in completely decomposing the stem or composite affix, this object could go away, although it may be beneficial to retain it for future comparisons. Another possible use might be for a portmanteaux affix with a partial analysis, or for 'complex' affixes like the English ?ation (which under the Word Based Hypothesis, cannot be composed of the suffixes ?at and ?ion because of its appearance in words like recitation, since there is no word *recitate). I have defined this as an ordered seq on the assumption that the order of the components will match the left-to-right order of the morphemes. This is not unproblematic: some morphemes may be unanalyzed, and some morphemes may not appear in a strict left-to-right order (e.g. infixes). The former problem could be fixed by the use of placeholder (uninstantiated) Msas; the latter could be fixed either by defining a canonical order, or by using derivational order instead.
Component View | Package
CompoundRuleApps | Association from Package Ling | owns an ordered seq of MoCompoundRuleApp, representing the application of compound rules belonging to this stratum. The order is the order of application in derivation (which may be the reverse of the order in parsing).
CompoundRuleApps | Association from Package Ling | Allows Morph Sketch Generator to extract example wordforms where a compound rule applied.
CompoundRules | Association from Package Ling | owns a seq of MoCompoundRules. (Alternatively, these could be owned in the stratum to which they belong - see MoStratum.vCompoundRules for discussion.) The order corresponds to the order in which the compounding rules apply in a derivation.
CompoundRules | Operation from Class MoStratum | a virtual attribute, returning the seq of MoCompoundRules which belong to this stratum. Alternatively, this could be an owning attribute (rather than having the rules owned in the MoMorphologicalData object). The issues of belonging to a single stratum that occur with derivational and inflectional affixes, which are owned in lexical entries, and which imply that those classes should refer to their stratum rather than vice versa, do not occur here.
Conclusions | Association from Package Notebk | A summary of the results of the research.
Confidence | Association from Package Cellar | Indicates confidence in the data collected for this possibility item. This value comes from a user-defined list that is used by many different FieldWorks objects (Events, Analysis Records, Lexical Entries and their Senses, etc.) These values are user-definable and initially include: Low, Medium and High as possibilities.
Confidence | Association from Package Notebk | An indication of how confident the researcher is about the data in this record. Example values high, medium, low, uncertain.
ConfidenceLevels | Association from Package LangProj
ConstChartClauseMarker | Class from Package Ling
ConstChartMovedTextMarker | Class from Package Ling
ConstChartRow | Class from Package Ling
ConstChartTag | Class from Package Ling
ConstChartTempl | Association from Package Ling | Templates describing possible chart organizations. Top level Possibilities are Chart Templates. SubPossibilities represent groups of columns or columns. (This is stretching the idea of 'possibilities' somewhat, and it is unusual that the top-level possibilities are really a different kind of thing from the leaves, but it can be thought of as an extension of the idea that non-leaf nodes perform a grouping function.) Changed from ConstChartTemplates for the port.
ConstChartWordGroup | Class from Package Ling | This column shows the actual position of the text. ConstChartWordGroup's Begin/EndAnalysisIndices refer to Segment's Analyses sequence
ConstituentChartCellPart | Class from Package Ling
Content | Association from Package Ling | refers to a PhNaturalClass to be added into the output at this position.
Content | Association from Package Ling | refers to a PhContextOrVar in MoAffixProcess.Input of the owner of this object; the meaning is that the stretch of the input word matched by that PhContextOrVar is copied over without alteration to the output.
Content | Association from Package Ling | refers to an ordered seq of PhPhonemes and/or PhBdryMarkers (thus the signature is the superclass PhTerminalUnit).
Content | Association from Package Ling | refers to a PhContextOrVar from the input of the MoAffixProcess owning this object; the meaning is that the stretch of the input word matched by that PhContextOrVar is copied over to the output, but modified in accordance with the modification attribute. Typically, this will be a single phoneme, which is modified by the addition of one or two features (e.g. by being palatalized).
Content | Association from Package Scripture | A ScrSection has Content - the actual verses themselves. Content has a signature of StText allowing us to have multiple paragraphs, paragraph styles and character styles all of which will be used extensively for verse material. Chapter and verse references are character styles found in the Contents of the StTxtPara.
Content | Attribute from Class Note
Contents | Association from Package Ling
Contents | Association from Package Cellar
Contents | Association from Package Ling
Contents | Attribute from Class CmCell
Contents | Attribute from Class StTxtPara | The string of text found within a paragraph. The signature here is bigString which allows for embedded formatting and language encodings.
Context | Attribute from Class StStyle | The high level structure to which the application of a style is limited. To be enumerated as follows: stcnGeneral – indicating Not limited to a single context. stcnText – The main text (eg. of scripture). stcnScrIntro – Introduction to a book of scripture stcnScrAnnotation – Annotation to the scripture text (e.g. consultant notes) stcnFigure – Captions, etc. associated with graphic elements stcnInternal – Styles that are applied by the program and modifiable by the user stcnScrTitle – The title of a scripture book. (others as needed)
Contexts | Association from Package Ling | Change this here.
control | Stereotype from Package UML Standard Profile | A control is a class whose objects manage interactions between collections of objects. A control class usually has behavior that is specific for one use case, and a control object usually does not outlive the use case realizations in which it participates.
ConvertCVDigitsOnExport | Attribute from Class Scripture | Whether or not to convert from "European" digits, (1, 2, 3) from scripts using Unicode code points. Renamed from ConvertCVNumsToEuropeanDigitsOnExport
copy | Stereotype from Package UML Standard Profile | Specifies a Flow relationship, the source and target of which are different instances, but each with the same values, state instance, and roles (but a distinct identity). A Copy Dependency from A to B means that B is an exact copy of A. Future changes in A are not necessarily reflected in B.
CopyCutPastable | Attribute from Class CmAnnotationDefn | T = annotations of this type are copied and pasted when their annotated object is copied and pasted. F = these types of annotations are NOT copied along with their annotation object.
Copyright | Attribute from Class CmFile | Publishable information about the copyright that should appear on the copyright page of the publication.
CounterEvidence | Association from Package Notebk | Data records which refute the hypothesis.
create | Stereotype from Package UML Standard Profile | Specifies that the designated feature creates an instance of the BehavioralFeature classifier to which the feature is attached. May be promoted to the Classifier containing the feature.
create | Stereotype from Package UML Standard Profile | Create is a stereotyped call event denoting that the instance receiving that event has just been created. For state machines, it triggers the initial transition at the topmost level of the state machine (and is the only kind of trigger that may be applied to an initial transition).
create | Stereotype from Package UML Standard Profile | Create is a stereotyped usage dependency denoting that the client classifier creates instances of the supplier classifier.
CreatedBy | Association | From a list of users, the person who created the journal entry.
Creation date | TagDefinition
CrossReference | Class from Package Cellar | May 23, 2001. This is to be used for cross references between objects. In its current state, it will be used ONLY for bidirectional (cf. unidirectional or cross-reference sets of greater than 2) cross-references. Although there is a comment attribute on this object, it will not be used in version 1 of the Research Notebook.
CrossReferences | Association from Package Notebk | CrossReference objects that capture crossReferences between two RnGenericRecords are owned here by the ResearchNotebook.
CrossReferences | Association from Package Notebk | A RnGenericRecord can refer to one or more CrossReference objects. For version 1 of Research Notebook, CrossReference objects will have two backreferences representing a bi-directional cross-reference.
CrossRefMarkerSymbol | Attribute from Class Scripture | The custom marker that will be used as a literal string for the cross-reference callout (typically a single character).
CrossRefMarkerType | Attribute from Class Scripture | Enumeration of cross-reference callout options: 0 = 'alphabetic sequence' 1 = 'custom symbol' 2 = 'no marker displayed in text' other values will be added for other kinds of sequences. Note: coordinate these enumeration values with FootnoteMarkerType.
CrossRefsCombinedWithFootnotes | Attribute from Class Scripture | Indicates whether cross-references are to be combined with the general footnote layout (true) or are to be layed out separately (false).
CurAnalysisWss | Attribute from Class LangProject | This is a space-delimited list of writing system tags.
CurPronunWss | Attribute from Class LangProject | Changed from CurrentPronunciationWritingSystems This is a space-delimited list of writing system tags.
CurVernWss | Attribute from Class LangProject | Changed from CurrentVernacularWritingSystems This is a space-delimited list of writing system tags
CVPattern | Attribute from Class LexPronunciation | This provides a place to store CV patterns of the pronunciation form. It defaults to the top analysis writing system, but being a string, it can be forced to some other writing system.
D
database | Stereotype from Package UML Standard Profile
Data Notebook | Class Diagram
Data types | Package
Date | Attribute from Class Reminder | A date which the user can set to be reminded to do something or check something.
DateCreated | Attribute from Class StJournalText | The displayed date when the journal entry was originally created.
DateCreated | Attribute from Class ScrDraft | The date and time that the record is created. Not automatically the same as the time stamp on a CmObject.
DateCreated | Attribute from Class CmAnnotation | Date stamp for when this annotation was created, for display to the user. This may differ from the internally generated timestamp that is used for record locking and conflict detection.
DateCreated | Attribute from Class LexEntry
DateCreated | Attribute from Class CmMajorObject
DateCreated | Attribute from Class CmPossibility
DateCreated | Attribute from Class CmProject
DateCreated | Attribute from Class RnGenericRec | The date and time that the record is created.
DateModified | Attribute from Class StJournalText | The displayed date that the journal entry was last modified.
DateModified | Attribute from Class CmAnnotation | Date and time that this annotation was last modified, for display to the user and for use by automated checking tools. Allows explicit tracking of relevent modifications versus the automatic date stamp created by the database engine.
DateModified | Attribute from Class LexEntry
DateModified | Attribute from Class CmMajorObject
DateModified | Attribute from Class CmPossibility
DateModified | Attribute from Class CmProject
DateModified | Attribute from Class RnGenericRec | The date and time that the record is last modified.
DateOfBirth | Attribute from Class CmPerson
DateOfDeath | Attribute from Class CmPerson
DateOfEvent | Attribute from Class RnGenericRec | The date of the event.
DateResolved | Attribute from Class ScrScriptureNote | Date that this scripture note was changed to the resolved status.
Default | Association from Package Cellar | Feature of number might have a default value of singular.
DefaultAffix | Association from Package Ling | refers to an inflectional affix (MoInflectionalAffixMsa) that is attached to the stem selected by the DefaultStem to give this stem, if the stem's lexical entry does not have an MoStemAllomorph with this stem name. If this attribute is empty, the default shape of this kind of stem is the same as that of the default stem; effectively, the stem is then formed by null affixation. The situation in which this attribute is empty is common in languages where some lexemes have a suppletive stem, but where the majority of lexemes use a regular stem without any special affixation. In Spanish, for instance, some verbs have an irregular stem used in the first person singular present indicative and in the present subjunctive, but for most verbs, the stem used in these regions of the paradigm is the same as that used elsewhere. Note that in the course of doing S2W morphology, the user might initially assign Spanish stem-changing and non-stem-changing verbs to different paradigms. Later, noticing that the only difference between the two paradigms is the stem change, he could collapse the two paradigms (as advocated in Carstairs 1987, chapter 6), retaining the special '1s present indicative/present subjunctive' form for the irregular verbs, and leaving the '1s present indicative/present subjunctive' form empty for regular verbs. While it would be nice to limit the possibilities for this attr to less than all the affixes in the lexical database, it is not clear that there is any way to do so.
DefaultFeatures | Association from Package Ling | A feature structure which specifies features that should be assumed in the absence of any inflectional affixes for the features defined. Example: In English, nouns are by default singular [num:sg].
DefaultFooter | Association from Package Cellar | The contents of the default footer for pages of a publication division (odd pages use the default footer).
DefaultHeader | Association from Package Cellar | The contents of the default header for pages of a publication division (odd pages use the default header).
DefaultInflectionClass | Association from Package Ling | refers to one of the classes in vAllInflectionClasses; defaults to the first MoInflectionClasses in vAllInflectionClasses (which would be the first class defined for this part of speech; this choice makes sense, i.e. the default is likely to be the largest inflection class, not a subclass of some class.) According to Wurzel (as described in Carstairs-McCarthy 1998b), the default class is the Inflection Class to which newly coined lexemes are usually assigned, to which lexemes from other classes 'drift' in the process of historical change, and the class to which children tend to assign lexemes before they learn the correct class. For our purposes, however, it may be simpler just to think of the default class as being the largest class numerically, i.e. the class to which words in the lexical database are assigned as a first guess.
DefaultStem | Association from Package Ling | refers to another MoStemName, which specifies the stem to be used (in conjunction with the DefaultAffix, if the latter is specified) if the stem's lexical entry does not list an MoStemAllomorph with this stem name. That is, if a lexeme does not have an irregular (listed) stem, this attribute specifies that some more regular stem will be used, either as a base (if there is a DefaultAffix) or by itself (if there is no DefaultAffix). If no DefaultStem is specified, then for any lexeme which does not explicitly list an (irregular) MoStemAllomorph with this stem name, the base for this MoStemName has the same form as the lexeme's (MoStemMsa's) DefaultStems. (The DefaultStems attr is a seq, allowing for phonological selection of one among several default stems; most often, the seq will contain a single stem.) Thus a regular stem for a given stem is constructed from the DefaultStem of that lexeme as specified by this MoStemName plus the DefaultAffix given by this MoStemName. This covers the common situation in which a relatively small subset of the words of a given paradigm have irregular forms, while the others have a stem based on the default stem with or without a stem-forming affix. Note that we can get into an infinite loop here, if any MoStemName calls for itself or (more likely) another MoStemName which (recursively) calls for the first MoStemName. This of course constitutes an error; fortunately, it should be easy to detect this situation. The possibilities for this attr are the StemNames of the PartOfSpeech which owns this MoStemName (not including this MoStemName).
DefaultStems | Operation from Class MoStemMsa | virtual attribute, returning a seq of "default" stems: selectIf({ |A| not of exists of StemName of ^A)}) of my vAllomorphs In other words, any allomorph of this stem which does not have a stem name is a default allomorph. Ordinarily, there will be only one such allomorph, unless there are phonologically determined allomorphs of the default stem. See also the discussion below of the vNondefaultStems attr.
Definition | Attribute from Class LexSense | This is multiString to allow for embedding of one encoding within another and also to allow the user to manipulate formatting of different parts of the string.
DependentClauses | Association from Package Ling | Indicates that the specified rows are dependent clauses (or song or speech).
Depth | Attribute from Class CmPossibilityList
DerivAffApp | Association from Package Ling | Owns an ordered seq of MoDerivationalAffixApp, representing the attachment of derivational affixes belonging to this stratum. The order is the order of application in derivation (which may be the reverse of the order in parsing). Changed from DerivationalAffixApps.
Derivation | Association from Package Ling
DerivationalAffixes | Operation from Class MoStratum | a virtual attribute, returning the seq of MoDerivationalAffixMsa which belong to this stratum. The affixes refer to the stratum, rather than vice versa, in order to ensure that each affix belongs to a single stratum. Note that it would not work for the signature of this attr to be LexEntry, since it would be quite possible for that LexEntry to own other MoMorphoSyntaxAnalysis objects, some of which might not be MoDerivationalAffixMsas.
DerivationalAffixes | Operation from Class MoMorphData | a virtual attribute, returning the seq of MoDerivationalAffixMsa objects in the lexical database of this language. This supports theories in which affixes are not treated as morphemes in the linguistic lexicon.
derive | Stereotype from Package UML Standard Profile | (Name for the stereotyped class is Derivation.) Specifies a derivation relationship among model elements that are usually, but not necessarily, of the same type. A derived dependency specifies that the client may be computed from the supplier. The mapping specifies the computation. The client may be implemented for design reasons, such as efficiency, even though it is logically redundant.
Description | Association from Package Notebk | The content of the event.
Description | Association from Package Ling
Description | Attribute from Class PhSegmentRule | A description of the rule, possibly including hyperlinks to some items that motivated the rule.
Description | Attribute from Class CmPicture | Illustration description. This material does not show up on the printed page. This can include special publishing notes, etc.
Description | Attribute from Class ScrImportSet | Display description for each instance of import settings.
Description | Attribute from Class PhNaturalClass
Description | Attribute from Class MoInflClass | multilingual string, containing the user's description/ explanation of this inflection class.
Description | Attribute from Class MoInflAffixSlot | multilingual string, containing the user's description/ explanation of this slot (optionally including any consistent semantics-or an explanation that there is no consistent semantics).
Description | Attribute from Class WfiWordSet
Description | Attribute from Class MoCompoundRule | Description of the compound rule.
Description | Attribute from Class MoStemName | multilingual string, containing the user' s description/ explanation of this stem (e.g. how it might be replaced by a suitable phonologically-based allomorphy condition, or why it cannot be so replaced). Another test. Another test.
Description | Attribute from Class MoStratum | For the user's description/explanation of this stratum.
Description | Attribute from Class PhTerminalUnit
Description | Attribute from Class PhEnvironment
Description | Attribute from Class MoInflAffixTemplate
Description | Attribute from Class MoReferralRule | multilingual string, containing the user's description/ explanation of this rule.
Description | Attribute from Class PhPhonemeSet
Description | Attribute from Class FsFeatDefn
Description | Attribute from Class FsSymFeatVal
Description | Attribute from Class FsFeatStrucType
Description | Attribute from Class CmPossibility
Description | Attribute from Class CmMajorObject
Description | Attribute from Class CmProject
Description | Attribute from Class CmFolder
Description | Attribute from Class Reminder | The nature of the reminder, e.g., a question to get answered, or a note about some work that should be done.
Description | Attribute from Class MoAdhocProhibGr
Description | Attribute from Class ScrDraft
Description | Attribute from Class Publication
Description | Attribute from Class PubPageLayout
Description | Attribute from Class PubHFSet
Description | Attribute from Class CmFile
destroy | Stereotype from Package UML Standard Profile | Destroy is a stereotyped call event denoting that the instance receiving the event is being destroyed.
destroy | Stereotype from Package UML Standard Profile | Specifies that the designated feature destroys an instance of the BehavioralFeature classifier to which the feature is attached. May be promoted to the classifier containing the feature.
Details | Attribute from Class UserView
Details | Attribute from Class UserViewRec
Details | Attribute from Class UserViewField
DifferentEvenHF | Attribute from Class PubDivision | True - if a different header and footer will be used on the even pages in the division. False - if the default header and footer will normally be used for even pages.
DifferentFirstHF | Attribute from Class PubDivision | True - if a different header and footer will be used on the first page of the division. False - if the normal header and footer (depending on the page number) will be used.
Diffs | Association from Package Scripture
DiffType Attribute from Class ScrDifference an integer to identify the type of difference.

Verse not found in current book: MissingInCurrent.

Verse not found in revision book: MissingInRevision.

Text of verse in current and revision differ: TextDifference.
Direction | Attribute from Class PhSegmentRule | The direction and manner in which the rule applies. The possible values are: 1 - left-to-right iterative; 2 - right-to-left iterative; 3 - simultaneous.
Discourse | Class Diagram
DiscourseData | Association from Package LangProj | The place for all our discourse analysis data.
DiscourseNote | Attribute from Class LexSense
Discussion | Association from Package Notebk | Any pertinent discussion relating to the hypothesis.
Discussion | Association | The core contents of the note, the reviewer’s discussion (explanation) of the translation or interpretation issue. Not to be confused with the discussion between users in response to the note which is contained in the Responses collection.
Discussion | Association from Package Cellar | Any pertinent discussion for this Possibility.
DisplayCrossRefReference | Attribute from Class Scripture | True if the "source" chapter and verse reference of the cross-reference should be displayed in the note; False otherwise
DisplayFootnoteMarker | Attribute from Class StFootnote | True if the footnote marker used to mark the footnote in the text should also be displayed below in the footnote pane; False otherwise. (This attribute is no longer used for Scripture footnotes. Display of the marker is now determined according to whether or not the marker in the text is sequential.)
DisplayFootnoteReference | Attribute from Class Scripture | True if the chapter and verse of the footnote should be displayed below in the footnote; False otherwise.
DisplayFootnoteReference | Attribute from Class StFootnote | True if the back-reference of the footnote should be displayed below in the footnote; False otherwise. (This attribute is no longer used for scripture footnoes. Display of References is now determined for all footnotes by the DisplayFootnoteReference attribute on Scripture).
DisplayOption | Attribute from Class CmPossibilityList | This determines whether we display name (kpntName = 0), name and abbreviation (kpntNameAndAbbrev = 1), or abbreviation (kpntAbbreviation = 2) when we display names.
DisplaySymbolInCrossRef | Attribute from Class Scripture | If true, display the custom symbol callout in cross-reference footnotes (as well as in the text) when the custom symbol option is chosen for the CrossRefMarkerType property.
DisplaySymbolInFootnote | Attribute from Class Scripture | If true, display the custom symbol marker in general footnotes (as well as in the text) when the custom symbol option is chosen for the FootnoteMarkerType property.
DisplayToRightOfValues | Attribute from Class FsFeatDefn | For use in the Gloss Assistant: T = Display the value of GlossAbbreviation to the right of any displayed values in the gloss (only if ShowInGloss = T) F = Display to the left (only if ShowInGloss = T) Example: ANIM:CL cf. CL:ANIM representing [ CLASS [ ANIMATE ] ]
Disproves | Association from Package Cellar | The agent evaluation which objects being evaluated refer to in order to indicate that this agent disapproves or does not accept them.
Divisions | Association from Package Cellar | The content divisions (i.e. sections) that determine overall content of the publication.
document | Stereotype from Package UML Standard Profile | Denotes a generic file that is not a «source» file or «executable». Subclass of «file».
document | Stereotype from Package UML Standard Profile | Denotes a document.
Domain | Attribute from Class ScrMarkerMapping | Designates the internal destination stream or sub-stream for the data. The integer is a bit-slice composite of an internal enumeration: h0000 - unknown domain h0001 - scripture domain h0002 - back translation domain h0004 - notes domain h0008 - footnote domain
DomainTypes | Association from Package Ling
DomainTypes | Association from Package Ling
DoNotUseForParsing | Attribute from Class LexEntry | The user may initially add entries not knowing if they are highly regular/predictable. Once discovering that an entry is "non-lexical", the user may still want to retain for example sentences, conjugation charts, etc. This boolean specifies that the parser is not to use the morphs or MSA info in its parsing. Default = False.
DsChart | Class from Package Ling | This is the discourse chart. This will be subclassed into a Longacre/Levinsohn Constituent Chart, and will be the base class for other discourse charts.
DsConstChart | Class from Package Ling | This class represents a Longacre/Levinsohn type Constituent Chart. Syntactic columns vs TextSegment rows. For a brief summary and an example, see Chapter 8 in Dooley and Levinsohn, "Analyzing Discourse".
DsDiscourseData | Class from Package Ling | This gathers all the discourse-related material into one place.
E
Education | Association from Package Cellar
Education | Association from Package LangProj
EmptyParadigmCells | Association from Package Ling | owns a collection seq of FsFeatStruc, indicating the cells (feature-value combinations) which are disallowed in the paradigm. This is intended to account for defective paradigms, which are not common (e.g. deponent verbs in Greek, which are verbs that have no active forms). Since defective paradigms are relatively rare, this will probably be a seldom-used attribute. It is not intended to account for syncretism in the paradigm, i.e. the situation where one cell 'uses' the affixes of another cell (for which MoReferralRules are supplied instead, should disjunctive ordering of the affixes in an MoInflAffixSlot not suffice.).Since this attribute is defined at the level of the part of speech, it is not possible to define cells which are empty in only one inflection class. It is not obvious that this is correct, e.g. it is not obvious that deponent verbs in Greek belonged to a separate part of speech from other verbs. Pluralia tantum words like scissors and trousers are another example, since it is not clear that they belong to a separate part of speech from other nouns. Yet another example of a set of words that cannot plausibly be assigned to a separate category comes from Russian. Halle (1973: 7-8) says there are about a hundred verbs, all in a particular conjugation class, which lack first person singular non-past forms. It is unclear what the status of this gap is; it may be semantically or pragmatically based (some of the glosses are 'I conquer', 'I talk rudely', 'I behave foolishly'). According to Halle, "Russian grammar books frequently note that such forms… 'do not exist', or 'are not used', or 'are avoided'." Perhaps this is more of a sociolinguistic issue. Jensen (1990: 117-119) discusses some other defective paradigms, although he admits that his Latin examples are suspect: the defective paradigm is based on the corpus of Latin literature, and it may be that the corpus, not the paradigm, is defective. Jensen also lists as examples a few French verbs which lack certain forms: "cloré ['to close, enclose']… lacks the passé simple and the first and second persons plural of the present. Gésir ['to lie'] lacks all tenses but the present and imperfect indicative, and lacks the first and second persons singular of the present." He notes that synonyms supply the missing forms, so these gaps probably cannot be explained on semantic or pragmatic grounds. Jensen also gives as examples English modal verbs, which lack participle and 'infinitive' (to V) forms. In this case, the customary solution is to create a separate part of speech (modals), as a subclass of the category Verb.There are at least two verbs in English with defective paradigms: sight-see (*sight-sees, *sight-saw, sight-seen-but sight-seeing), and beware (which occurs only in this base form. Another puzzle with respect to defective paradigms, is the fact that while the singular of pluralia tantum words is ungrammatical in isolation, they are found in compounds: scissor-handle and trouser-leg. It is not clear how a defective distribution of certain elements of the paradigm should be handled. Matthews (1972a: 197, fn. 2) suggests that defective paradigms be handled in the syntax, although it is unclear how this would work.
EncyclopedicInfo | Attribute from Class LexSense
EndAnalysisIndex | Attribute from Class TextTag | These indices refer to the index of an IAnalysis object in a Segment.Analyses sequence.
EndAnalysisIndex | Attribute from Class ConstChartWordGroup | Indicate the words that occur in the indicated cell of the chart.
EndDependentClauseGroup | Attribute from Class ConstChartRow
EndMarker | Attribute from Class ScrMarkerMapping | Marker used for closing delimiter of a data run.
EndObject | Association from Package Cellar
EndOffset | Attribute from Class CmBaseAnnotation | See BeginOffset.
EndParagraph | Attribute from Class ConstChartRow
EndRef | Attribute from Class CmBaseAnnotation | For Scripture use, this will be used to store end Scripture references. The int actually encodes book, chapter, and verse for Consultant Notes, Translator Notes, Change History Notes, etc. The attribute is available for other uses in other applications.
EndSegment | Association
EndSegment | Association from Package Cellar
EndSentence | Attribute from Class ConstChartRow
entity | Stereotype from Package UML Standard Profile | An entity is a passive class; that is, its objects do not initiate interactions on their own. An entity object may participate in many different use case realizations and usually outlives any single interaction.
Entries | Association from Package Ling
Entries | Association from Package Ling | This is a list of all types of entries. It is sorted by citationForm, thus we no longer need the citationForm index.
EntryRefs | Association from Package Ling | This property is empty for main entries. For variant and complex entries, one or more LexEntryRef is used to point to the major entries. One variant entry could apply to more than one main entry, so each one could have a separate LexEntryRef. It’s possible for an entry to be a complex entry as well as a variant. This could be represented by one or more LexEntryRefs. Some may want to order multiple entries in a particular way, so we have a sequence instead of a collection.
Environments | Association from Package Ling
EthnologueCode | Attribute from Class LangProject
EticID | Attribute from Class MoGlossItem | Stores a reference to the XML ID of the Etic Gloss List.
Etymology | Association from Package Ling | Each entry can have one etymology specification.
Evaluations | Association from Package Ling | Refers to either the Approves or Disapproves evaluations of various agents to indicate that the agent does or does not approve this analysis.
EvenFooter | Association from Package Cellar | The contents of the footer for the even pages of a publication division when different from the default.
EvenHeader | Association from Package Cellar | The contents of the header for the even pages of a publication division when different from the default.
Example | Attribute from Class LexExampleSentence | This multilingual attribute holds the vernacular example sentence prior to tokenization. After tokenization it is cleared and the contents are transferred to the contents attribute. It is multilingual to allow multiple encodings in the same language (e.g., Thai, Laotian, and Vietnamese). It is multiString rather than multiUnicode to allow formatting - for example, applying bold to the word associated with the LexEntry.
Examples | Association from Package Ling
ExampleSentences | Attribute from Class CmDomainQ | Example: (Ron Moe's Standard Format): \xe We got up before ... A list of sample sentences illustrating words elicited from this question. The illustrated word may be bolded. We may have sentences in more than one language. If there are multiple sentences, they are all placed in the same string.
ExampleWords | Attribute from Class CmDomainQ | Example: (Ron Moe's Standard Format): \ex air, aerial, airspace, atmosphere A list of sample words in this category. The list may be in English or other languages (e.g., \exf). The words are comma delimited. They are not formatted and they do not have any embedded languages. These words may be used when searching for possible domains for a sense based on the sense gloss. If this process is too slow, we may need to go to separate wordform lists, but we are hoping that complexity will not be necessary.
ExclRuleFeats | Association from Package Ling | This refers to a set of rule features (which are a possibility list). This encodes negative rule feature requirements, such as conjugation class membership or gender. In order for this rule to apply to a lexical entry, the lexical entry must not contain in its Rule Features list any of the feature names of this list. If this field is omitted, there are no excluded rule features. Warning: The names in the RequiredRuleFeatures list and this list should be mutually exclusive.
ExcludeAsHeadword | Attribute from Class LexEntry | By default each entry will show up as a headword. If this flag is set, then dictionary views should not include this item as a headword. (This replaces IsIncludedAsHeadword so that 0 can be the default.)
Excluded | Attribute from Class ScrMarkerMapping | If true, exclude this delimited data from being imported.
executable | Stereotype from Package UML Standard Profile | Denotes a program file that can be executed on a computer system.Subclass of «file».
executable | Stereotype from Package UML Standard Profile | Denotes a program that may be run on a node.
Explanation | Attribute from Class ChkSense | A short explanation of the relationship of the lexical sense to the check item. For example, in the Key Terms list, may add an additional explanation of why the lexical item is chosen to render the key term, beyond the definition given for the Sense.
Explanation | Attribute from Class ChkRendering | An optional short explanation of why this rendering was chosen to render the term.
ExternalMaterials | Association from Package Notebk | A listing of any external sources, such as tape or video records, pictures in a scrapbook, etc.
ExtLinkRootDir | Attribute from Class LangProject | External Link Root Directory: External links may have a full path name or a relative path name. This property holds the relative path definition when relative path names are used. It could be a physical path name (e.g., c:\FwData) or a network name that could be accessed by other users (e.g., \\ls-daffy\FwData).
F
facade | Stereotype from Package UML Standard Profile | A facade is a stereotyped package containing only references to model elements owned by another package. It is used to provide a public view of some of the contents of a package. A facade does not contain any model elements of its own.
FeatConstraints | Association from Package Ling | The feature constraints are what allow us to use alpha notation in phonological rules (to deal with things like assimilation to place of articulation). It is a sequence so we can know the alpha value (is it alpha, beta, gamma, or delta, say). The user need never see these as a list to be edited or maintained by hand. The UI can show them as greek letters in phonological rule displays.
FeatStructFrag | Association from Package Ling | A gloss item in the language-specific gloss system is formalized by a feature structure fragment. The feature structure for a glossed morpheme is thus the unification of all the feature structure fragments for its component gloss items. When the user selects gloss items from the language-specific gloss system to form a composite gloss, this analysis is stored in the MSA as a gloss bundle (which an attribute on MSA that stores a set of references to all the selected gloss items). The language-specific feature structure for an MSA is automatically generated by computing the unification of all the feature structure fragments in the gloss bundle. Changed from FeatureStructureFragment.
FeatSys | Package from Package Component View
Feature | Association from Package Ling | refers to an FsFeatureDefnPhFeatureNode, the feature with respect to which the constraint ensures agreement (or disagreement).The use of an atomic attr, rather than a seq attr, emulates to a certain extent the insight of autosegmental phonology and feature geometry that a rule can change (or refer to in the environment) only a single feature node. Note however that the fact that the feature can be a nonterminal feature (an FsComplexFeature), allows agreement with respect to a number of features dominated by a single node (e.g. a place of articulation feature, which might dominate the features labial, coronal, and back).
Feature | Association from Package Cellar
FeatureDisjunctions | Association from Package Cellar
FeatureId | Attribute from Class UserAppFeatAct | An application returns a hard-coded array of its available features. Features have ids that are referenced in this FeatureId field. UserConfigAccount, ApplicationId, FeatureId form a unique key for the object.
Features | Association from Package Cellar | The Features attribute is how the user provides the phonological features of a phoneme (phonological segment). This means that the features contained in the FsFeatStruc must be from LangProject:PhFeatureSystem.
Features | Association from Package Cellar | The order of features will be used in the Gloss Assistant system to put feature values in the correct glossing order. For example, the user may want the FsFeatStrucType of TAM (tense aspect modality) to be ordered Aspect, Modality and Tense.
Features | Association from Package Cellar
Features | Association from Package Ling | owns an FsFeatStruc, specifying the feature values which characterize this natural class. The meaning is that any phoneme which includes (N.B.: not unifies with) the specified feature values matches this natural class.
Features | Association from Package Cellar
FeatureSpecs | Association from Package Cellar
FeatureStructure | Association from Package Ling | Allows the user to write phonological rules that are sensitive to a particular phoneme (as opposed to a class of phonemes).
FeatureStructure | Association from Package Ling
FeatureStructure | Association from Package Ling
FieldId | Attribute from Class CmFilter
FieldInfo | Attribute from Class CmFilter
Fields | Association from Package Cellar
FieldWorkLocation | Attribute from Class LangProject
file | Stereotype from Package UML Standard Profile | Denotes a physical file in the context of the system developed.
file | Stereotype from Package UML Standard Profile | Denotes a document containing source code or data.
FileFormat | Attribute from Class ScrImportSFFiles | Enumeration, may be used to designate the format variation of the standard format files in this source (Paratext 5, USFM, etc.) so that import can be tailored to the format.
Files | Association | The files that this source comprises. Currently (Dec 2005) plan to only set the OriginalPath in the CmFile.
Files | Association from Package Cellar
Filters | Association from Package LangProj
Final | Attribute from Class MoInflAffixTemplate | In languages like Quechua, one can inflect a verb stem with all but tense. Instead one adds a derivational affix (participle) which creates a noun. The resulting stem is then inflected like a noun. To model this, we need the regular verbal template (including tense) and a template that has all but tense. When the former is applied to a stem, it produces a well-formed word. The latter is not. If we add a boolean to MoInflAffixTemplate that indicates that the template is non-final, then we can have our word grammar reject an analysis that ends with the non-final template (i.e. it does not have the required derivation and inflection). The default value for this boolean would indicate "final". The attribute could be called Final (with a default value of "true").
FinalStratum | Association from Package Ling | The final stratum to which this rule applies.
FirstAllomorph | Association from Package Ling
FirstFooter | Association from Package Cellar | The contents of the footer for the first page of a publication division when different from the default.
FirstHeader | Association from Package Cellar | The contents of the header for the first page of a publication division when different from the default.
FirstMorpheme | Association from Package Ling
Flid | Attribute from Class UserViewField
Flid | Attribute from Class CmBaseAnnotation | An annotation knows what it is annotating through the BeginObject reference attribute and the Begin and EndOffsets. For those annotations that are not on objects themselves but data within the object, we we need to identify which attribute holds the data through the field id (abbrev: FLID) found in the FieldWorks RDBMS.
float | DataType from Package Data types
focus | Stereotype from Package UML Standard Profile | Specifies a class that defines the core logic or control flow for one or more auxiliary classes that support it. Support classes may be defined explicitly using Auxiliary classes or implicitly by dependency relationships. Focus classes are typically used together with one or more Auxiliary classes, and are particularly useful for specifying the core business logic or control flow of components during design. See also: «auxiliary».
FootnoteMarker | Attribute from Class StFootnote
FootnoteMarkerSymbol | Attribute from Class Scripture | The custom marker that will be used as a literal string for the callout (typically a single character).
FootnoteMarkerType | Attribute from Class Scripture | Enumeration of footnote callout options: 0 = 'alphabetic sequence' 1 = 'custom symbol' 2 = 'no marker displayed in text' other values will be added for other kinds of sequences. Note: coordinate these enumeration values with FootnoteMarkerType.
Footnotes | Association from Package Scripture
FootnoteSepWidth | Attribute from Class Publication | Width of the separator line between the body text and the footnote text in parts per thousand of the column width. Valid values are 0-1000: 0 — indicating that no separator line will appear 1000 — indicating that separator line will be drawn for the full width of the footnote column 333 — indicating a standard 1/3 column width separator line any other value — indicating a custom proportion of the separator line to the column width.
ForeColor | Attribute from Class CmPossibility | ForeColor for overlay functionality.
Form | Attribute from Class PunctuationForm
Form | Attribute from Class WfiWordform | The form of the word. This is multiUnicode in order to allow the user to encode the wordform in more than one encoding (for example, in Japanese a word can be encoded in Kanji, Hiragana, Katakana or Romanji).
Form | Attribute from Class MoForm | It is not clear to me what is supposed to go into this attribute for process affixes (MoAffixProcess), since these do not have a form per se (and in some cases, such as reduplication, there is no form at all). One could use this for a description of the process affix, but that usage would then not parallel the usage in other subclasses. Null inflectional affixes are usually unnecessary in a realizational theory of morphology; putative null derivational affixes can usually be modeled by multiple parts of speech for (lexically listed) stems; and null stems are quite rare. Nonetheless, for purposes of stealth to wealth, as well as for the rare situation where null affixes or stems are actually required, this Form attr can hold an empty string. (See e.g. the discussion of spanned slots in the MoInflAffixTemplate class for one situation where null affixes may be necessary.) There is no assurance that all the strings in this multilingual attr will be null or non-null, but even this looseness may occasionally be useful—where an affix is overt in one encoding, but covert in another. An example would be an affix consisting of a tone: tones might be marked in some encodings, but unmarked in others.
Form | Attribute from Class WordFormLookup
Form | Attribute from Class LexPronunciation | This is the pronunciation usually in an approximately phonemic encoding for purposes of showing up in the printed dictionary.The pronunciation can be represented with more than one encoding.
Form | Attribute from Class WfiGloss
Form | Attribute from Class WfiMorphBundle
Form | Attribute from Class LexEtymology
framework | Stereotype from Package UML Standard Profile | A framework is a stereotyped package consisting mainly of patterns, where patterns are defined as template collaborations.
FreeTranslation | Attribute from Class Segment
friend | Stereotype from Package UML Standard Profile | Friend is a stereotyped permission dependency whose source is a model element, such as an operation, class, or package, and whose target is a model element in a different package, such as an operation, class or package. A friend relationship grants the source access to the target regardless of the declared visibility. It extends the visibility of the supplier so that the client can see into the supplier.
FromInflectionClass | Association from Package Ling | specifies the inflection (conjugation or declension) class which the stem to which this affix attaches must belong. In general, derivational affixes are arguably not marked for this property, so this attribute may be superfluous. However, it will certainly be necessary if non-Inflectional inflectional morphology is to be modeled using this class. (And it may turn out that some derivational affixes are sensitive to the inflectional class of their stem.) Under the realizational model of inflectional morphology, the inflection class to which an allomorph of an inflectional (realizational) affix belongs is indicated by MoAffixForm.InflectionClasses. That attribute is also available for allomorphs of derivational affixes (i.e. this class). That might be overkill, in that if a derivational affix attaches to stems of a single inflectional class, we could assign a single allomorph to that affix, and capture the restriction of the affix to the inflectional class as a restriction on that allomorph. However, the fromInflectionClass attribute here is parallel to the toInflectionClass attribute (defined below), which is independently needed. (Andy suggests that it may also be the case that a derivational affix would apply to a single inflection class, but have multiple allomorphs, in which case it would be convenient to have the attribute here, thereby avoiding the need to mark each allomorph for the same inflection class.)
FromMsFeatures | Association from Package Ling | specifies the morphosyntactic features which the stem to which this affix attaches must bear. See also the discussion of the FromPartOfSpeech attribute above.
FromPartOfSpeech | Association from Package Ling | specifies the category of the stem to which this affix attaches. See comments above on the "Unitary Base Hypothesis." Note also that in AMPLE, it is possible to map a series of categories into another series of categories; that capability is not defined here. If the parts of speech list is hierarchical, the problem could be partially circumvented by specifying an abstract category in this attribute. However, that would not solve the problem of mapping the output category, because at best we could specify more than a single output category. Note that we do not (yet) have provision for subcategorization lists or argument structure. This means that some restrictions on the stem to which an affix would be attached cannot be handled elegantly. (They could be handled inelegantly, by creating an ad hoc feature for each subcategorization, e.g. [+ditransitive].) For example, the English suffix -able attaches only to transitive verbs (washable, *seemable); the English suffix -ee attaches only to verbs which allow animate objects or indirect objects (addressee, *tearee) (examples from Scalise 1986: 45). Nor do we treat semantic restrictions on the base to which the affix attaches. For example, it has been proposed that the English prefix re- attaches only to verbs whose meaning entails a change of state (John repunched the holes in the paper, *John repunched Bill in the face) (Aronoff 1976: 47, observation attributed to an unpublished paper of Williams).
FromPartsOfSpeech | Association from Package Ling | The FromPartsOfSpeech lists the categories (POSes) of words that this clitic may attach to. It can delimit a subset of categories if need be or it can be empty.
FromProdRestrict | Association from Package Ling | FromProductivityRestrictions: refers to a collection of CmPossibility, giving any restriction classes which the stem to which this affix attaches must bear. If this attribute is empty, this affix may attach to a stem regardless of what restriction classes the stem bears (see MoStemMsa.ProductivityRestrictions). If there are two or more restriction classes listed for this affix, then the stem must have at least all of these restriction classes in its MoStemMsa.ProductivityRestrictions attribute in order for this affix to attach to the stem. The stem could have more restriction classes, but not less. Changed from FromProductivityRestrictions.
FromProdRestrict | Association from Package Ling | Refers to a collection of CmPossibility, giving any restriction classes which the stem to which this affix attaches must bear. If this attribute is empty, this affix may attach to a stem regardless of what restriction classes the stem bears (see MoStemMsa.ProductivityRestrictions). If there are two or more restriction classes listed for this affix, then the stem must have at least all of these restriction classes in its MoStemMsa.ProductivityRestrictions attribute in order for this affix to attach to the stem. The stem could have more restriction classes, but not less. (Note that unlike the case with MoDerivationalAffixMsa, there is no 'to productivity restrictions' attribute for inflectional affixes: inflectional affixes cannot add restriction classes to a word.) Changed from FromProductivityRestrictions.
FromStemName | Association from Package Ling | FromStemName: refers to an MoStemName, telling the stem to which this affix attaches. If this attr is empty, this affix attaches to the default stem of an MoStemMsa, as given by the vDefaultStems attr. (The vDefaultStems attr is a seq attr, to allow for a choice based on phonological constraints; in the absence of phonologically conditioned stem selection, there should be only one default stem.)
FsAbstractStructure | Class from Package Cellar
FsClosedFeature | Class from Package Cellar
FsClosedValue | Class from Package Cellar
FsComplexFeature | Class from Package Cellar
FsComplexValue | Class from Package Cellar
FsDisjunctiveValue | Class from Package Cellar
FsFeatDefn | Class from Package Cellar | Changed from FsFeatureDefn
FsFeatStruc | Class from Package Cellar | Changed FsFeatureStructure to FSFeatStruc
FsFeatStruc | Parameter from Operation RegularForm
FsFeatStruc | Parameter from Operation ActualForm
FsFeatStrucDisj | Class from Package Cellar | Note: the type of an FsFeatStrucDisj should be inherited from that of its disjuncts, and the types of those disjuncts must be the same. (MM: Sep 2001) Changed FsFeatureStructureDisJunction to FsFeatStrucDisj
FsFeatStrucType | Class from Package Cellar | Changed FsFeatureStructureType to FsFeatStrucType
FsFeatureSpecification | Class from Package Cellar
FsFeatureSystem | Class from Package Cellar
FsFeature System | Class Diagram
FsNegatedValue | Class from Package Cellar
FsOpenFeature | Class from Package Cellar
FsOpenValue | Class from Package Cellar
FsSharedValue | Class from Package Cellar
FsSymFeatVal | Class from Package Cellar | Renamed from FsSymbolicFeatureValue for the Firebird Port.
Function | Attribute from Class StStyle | Tthe functional context for a style within a given structural context (presently only defined for section ‘body’ structures). To be enumerated as follows: stusProse - indicating prose within a section body structure stusLine - indicating poetry within a section body structure stusList - indicating a list within a section body structure stusTable - indicating a table within a section body structure stusChapter - indicating a reference chapter number within a scripture section body structure stusVerse - indicating a reference verse number within a scripture section body structure null - indicating Style is unrestricted for use within the context and structure. (others as needed)
FurtherQuestions | Association from Package Notebk | Questions that have arisen as a result of trying to prove a hypothesis or when examining an event record. These may be used later in elicitation sessions or become the bases of new hypotheses.
G
genDate | DataType from Package Data types
Gender | Attribute from Class CmPerson
GeneralNote | Attribute from Class LexSense
GenreList | Association from Package Cellar | This property holds the list of defined genres (instances of CmPossibility) used by texts.
Genres | Association from Package Cellar | This associates a text with any number of genres.
global | Stereotype from Package UML Standard Profile | Specifies that the target is a global value that is known to all elements AssociationEnd rather than an actual association.
global | Stereotype from Package UML Standard Profile | Global is a constraint applied to a link-end, specifying that the corresponding instance is visible because it is in a global scope relative to the link.
Gloss | Attribute from Class LexSense
Gloss | Attribute from Class LexEtymology
GlossAbbreviation | Attribute from Class FsSymFeatVal | Used by the Gloss Assistant to construct glosses. For gloss components that are not to be shown, leave this attribute empty. The gloss abbreviation is distinguished from the standard abbreviation because the latter is used for constructing feature representations where an empty abbreviation would be highly confusing.
GlossAbbreviation | Attribute from Class FsFeatDefn | Used by the Gloss Assistant to construct glosses. For gloss components that are not to be shown, leave this attribute empty. The gloss abbreviation is distinguished from the standard abbreviation because the latter is used for constructing feature representations where an empty abbreviation would be highly confusing. MultiUnicode to allow for different Abbreviations for the same concept found in different glossing languages.
GlossBundle | Association from Package Ling | The functional gloss for this MSA is the ordered bundle of MoGlossItems that it points to. These are ordered as necessary to create the desired gloss string. When the user selects gloss items from the language-specific gloss system to form a composite gloss, this analysis is stored in the MSA as a gloss bundle (which an attribute on MSA that stores a set of references to all the selected gloss items). The language-specific feature structure for an MSA is automatically generated by computing the unification of all the feature structure fragments in the gloss bundle.
Glosses | Association from Package Ling
GlossItems | Association from Package Ling
GlossString | Attribute from Class MoMorphSynAnalysis | Stores the gloss string generated by the sequence of MoGlossItems (association GlossBundle). The user can override this if necessary.
GlossSystem | Association from Package Ling
GrammarNote | Attribute from Class LexSense
guid | DataType from Package Data types
GutterLoc | Attribute from Class Publication | Enumeration indicating the which edge of the paper has the gutter margin, i.e. the bound edge of the publication. The valid values are: glLeft, glRight, glTop.
GutterMargin | Attribute from Class Publication | Width of gutter margin from bound edge.
H
HasMaintenance | Attribute from Class UserConfigAcct
HeaderFooterSets | Association from Package Cellar | Used to define preset header/footer layouts that can be selected and copied to a publication division. Reason: needed to implement TE-1468
Heading | Association from Package Scripture | Headings are extra-canonical material used to help the reader know what a particular passage is about. Example: "The Genealogy of Jesus" for the passage (ScrSection) of Matthew 1:1-17. Although these are normally just a short-line, they sometimes are multi-lined including Headings and Subheadings. Thus the signature here is a StText - allowing us to have multiple paragraphs, paragraph styles and character styles.
HeadLast | Attribute from Class MoEndoCompound | owns a Boolean, defaulting to true (meaning that the right-hand constituent is the head).
HelpFile | Attribute from Class CmPossibilityList
HelpId | Attribute from Class CmPossibility | Used by the help system to launch the appropriate help topic for the Possibility item.
HelpString | Attribute from Class UserViewField
HFSet | Association from Package Cellar | Changed from HeaderFooterSettings.
Hidden | Attribute from Class CmPossibility | Indicates whether overlay bracketing should be hidden or not. True = Hidden.
HideMinorEntry | Attribute from Class LexEntryRef | This field indicates whether the variant or compound entry should be listed as a minor entry referencing the main entry in the lexicon. The lexicographer typically wants to limit minor entries to ones that are not alphabetically close to the main entry. It defaults to 0 which is easiest to implement in the model and is probably the most common situation. The UI for this could say Show Minor Entry, if desired. If there are multiple LexEntryRefs in the same entry, the entry will show as a minor entry unless all of the LexEntryRefs have HideMinorEntry set to 1. The minor entry would only display information for LexEntryRefs that have this property set to 0. For example, we could limit a reference on a minor entry (e.g., Entry: man (pl. men) Entry: people (reg. var. men) Minor Entry: men pl. of man, but not reg. var. of people) I don’t think this is a good example, but I suspect someone might have a productive derivation where they would only want to list a few of the references in the minor entry. By leaving this property on LexEntryRef, this would be possible. If we are certain that everyone will always want to list every occurrence in a minor entry for a variant or a subentry, then we could add this to LexEntry instead of LexEntryRef. We are using an integer instead of a Boolean for the possibility of controlling printing for different dictionary publications. Each bit in the integer could represent a Boolean for a particular dictionary, thus allowing 32 different dictionaries. We are not implementing the support for multiple dictionaries at this point, and the final design may use a different means for controlling minor entries.
HomographNumber | Attribute from Class LexEntry
Human | Attribute from Class CmAgent | T = human, F = computational agent.
Hypothesis | Association from Package Notebk | A statement of the hypothesis.
I
ICULocale | Attribute from Class ScrImportSource | Permits the writing system of the data to be specified globally for the source. If NULL, the default writing system for the context will be used.
ICULocale | Attribute from Class ScrMarkerMapping | Permits the writing system of the data to be specified, if it is not based on context and if it is different than the global setting.
IdText | Attribute from Class ScrBook | Id line from SF files (needed for import/export)
image | DataType from Package Data types
implementation | Stereotype from Package UML Standard Profile | Specifies the implementation of a class in some programming language (for example, C++, Smalltalk, Java) in which an instance may not have more than one class. This is in contrast to Class, for which an instance may have multiple classes at one time and may gain or lose classes over time, and an object (a child of instance) may dynamically have multiple classes. An Implementation class is said to realize a Type if it provides all of the operations defined for the Type with the same behavior as specified for the Type’s operations. An Implementation Class may realize a number of different Types. Note that the physical attributes and associations of the Implementation class do not have to be the same as those of any Type it realizes and that the Implementation Class may provide methods for its operations in terms of its physical attributes and associations. See also: «type».
implementation | Stereotype from Package UML Standard Profile | Specifies that the child inherits the implementation of the parent (its attributes, operations and methods) but does not make public the supplier s interfaces nor guarantee to support them, thereby violating substitutability. This is private inheritance and is usually used only for programming implementation purposes.
implementationClass | Stereotype from Package UML Standard Profile | Specifies the implementation of a class in some programming Class language in which an instance may not have more than one class. This is in contrast to a general UML Class, for which an instance may have multiple classes at one time and may gain or lose classes over time, and an object (a child of instance) may dynamically have multiple classes.
implicit | Stereotype from Package UML Standard Profile | The «implicit» stereotype is applied to an association, specifying that the association is not manifest, but rather is only conceptual.
import | Stereotype from Package UML Standard Profile | Import is a stereotyped permission dependency between two namespaces, denoting that the public contents of the target package are added to the namespace of the source package.
ImportProjToken | Attribute from Class ScrImportSet | Token to be used for loading project using ScriptureObjects
ImportResidue | Attribute from Class LexEntry | A place where we can store standard format markers that are not processed in any other way.
ImportResidue | Attribute from Class LexSense | A place where we can store standard format markers that are not processed in any other way.
ImportSettings | Association from Package Scripture | Scripture Import Settings. Supports multiple configurations for importing Scripture and related data from external files.
ImportSettings | Attribute from Class ScrImportSet | ImportSettings (binary) - binary data containing import settings. Changed from unicode to binary because that is what the Scripture Import module is passing to FW. THIS ATTRIBUTE IS NOW DEPRECATED (DEC 2005), REPLACED BY ScrMarkerMapping, ScrImportSource AND NEW ATTRIBUTES ON ScrImportSettings. INFORMATION IN THIS ATTRIBUTE WILL BE MIGRATED BY TE CODE.
ImportType | Attribute from Class ScrImportSet | Enumeration: Unknown = 0; Paratext = 1; Other = 2
InflectableFeats | Association from Package Ling | refers to a collection seq of FsFeatureDefn, each of which is a morphosyntactic feature which a word of this part of speech is inflected for. Note that MoInflectionalAffixMsas may be sensitive to other features as well. Changed from InflectableFeatures
InflectionalAffixes | Operation from Class MoStratum | a virtual attribute, returning the seq of MoInflectionalAffixMsa which belong to this stratum. The affixes refer to the stratum, rather than vice versa, in order to ensure that each affix belongs to a single stratum.
InflectionalAffixes | Operation from Class MoMorphData | a virtual attribute, returning the seq of MoInflectionalAffixMsa in the lexical database of this language. This supports theories in which affixes are not treated as morphemes in the linguistic lexicon.
InflectionalFeats | Association from Package Ling | Owns (but see below) an FsFeatStruc giving the inflectional features (to be) realized in this derivation. It is not clear whether this should be an owning or virtual attr. If derivations are always owned by some higher object that could logically hold such a feature structure (e.g. a test case or a cell in a paradigm), then this attr should just return that feature structure. Changed from InflectionalFeatures.
InflectionClass | Association from Package Ling | refers to an MoInflectionClass (i.e. a conjugation or declension class). If none is listed, PartOfSpeech.vDefaultInflectionClass is used. If there is no vDefaultInflectionClass, then there are presumably no inflection classes (since the default value for vDefaultInflectionClass is the first inflection class of the paradigm). The assumption here is that inflection class membership is essentially an arbitrary label, i.e. that the inflection class membership of a stem cannot and should not be defined by a set of stem allomorphs or lists of 'principal parts' (see discussion in Carstairs-McCarthy 1998b: 332-334).
InflectionClass | Association from Package Ling | InflectionClass: refers to an MoInflectionClass. This gives the inflection class to which the word being derived belongs, at this stage in the derivation. The algorithm for computing this is rather complex (which is why I have not defined this as a virtual attr), but basically it is this: If the last MoDerivationalAffix attached specifies a ToInflectionClass, then this attr is that inflection class. If the last MoDerivationalAffix attached does not specify a ToInflectionClass, then we collect all the derivational affixes attached inside that one which have the same ToPartOfSpeech or a PartOfSpeech which is a subcategory or a supercategory of the last derivational affix's part of speech, stopping when we come to a part of speech which is not the same or a subcategory or a supercategory. The outermost of these affixes which specifies a ToInflectionClass is used for this stage's InflectionClass. If none of these affixes specifies a ToInflectionClass, and the MoStemMsa is accessible (meaning none of the affixes has a contrary ToPartOfSpeech), then we use the InflectionClass of that stem. If all of these possibilities fail, we use the vDefaultInflectionClass of the PartOfSpeech.
InflectionClasses | Association from Package Ling | refers to a collection of MoInflectionClass, giving the conjugation or declension classes to which this allomorph belongs. This supports the collapsing into allomorphs of affixes which differ only in their form and in their requirements for inflection class. The allomorph which is the default will not specify any inflection class, and will therefore be used for all inflection classes not specified by other allomorphs. An empty value of this attribute therefore does not mean that this allomorph is not used in any inflection classes. In theory, this attr should be atomic, at least for inflectional affixes. That is, an inflectional affix should either specify a single inflection class, or it should be the elsewhere case, in which case it does not specify any inflection class (Carstairs-McCarthy 1994). It is nonetheless defined here as a seq attr, (1) for stealth-to-wealth reasons, and (2) because this theoretical claim may be wrong. There should however be tools to help the analyst discover inflectional affixes which have more than one inflection class specified in this attr, and if possible correct the analysis.
InflectionClasses | Association from Package Ling | owns a collection seq of MoInflectionClasses, each of which is an inflection class (conjugation or declension class) immediately owned by this part of speech. This does not include sub-inflection classes of those classes, for which see vAllSubInflectionClasses; nor does it include any inflection classes defined on more abstract parts of speech, for which see vAllSuperInflectionClasses. See also vAllInflectionClasses.
InflFeats | Association from Package Ling | Owns an FsFeatStruc, representing the morphosyntactic features realized by this affix. Most commonly, the feature values of this FsFeatStruc will belong to the PartOfSpeechGrammar.doc - PartOfSpeech.vAllInflectableFeatures of the stem to which the inflectional affix attaches, but may also include any of the features in the vAllInherentFeatureValues or vAllBearableFeatures attrs. For example, in Tzeltal there are two incompletive aspect prefixes, distinguished by whether the stem to which they attach is transitive or intransitive. The aspect feature would be an inflectable feature of verbs, but the transitivity feature would be either an inherent feature of the stem (assuming transitive and intransitive verbs have distinct parts of speech) or a bearable feature (if transitive and intransitive verbs are both treated as having the part of speech verb, and are distinguished by the transitivity feature alone). In determining what feature values can be added to a given FsFeatStruc, it will probably be desirable to disallow conflicting feature values (or even assigning the same feature value twice). However, it is permissible to have two different feature values at different places in an FsComplexValue; for example, [[Subject [Person 1]] [Object [Person 2]]]. In the course of a stealth-to-wealth analysis, a single affix might occupy a set of cells in a paradigm, where the cells do not form a natural class, and where they are not an 'elsewhere' case, or at least the user does not recognize them as such. This situation can be accommodated by the use of FsFeatStruc.FeatDisj. The goal at the 'wealth' end would be to find a natural class for the cells, thereby eliminating the feature disjunction, or to use disjunctive ordering within an MoInflAffixSlot to allow the statement of the features in a non-disjunctive manner. Changed from InflectionFeatures for the database port.
InflFeats | Association from Package Ling | Owns an FsFeatStruc, giving the morphosyntactic features which the word is to be inflected for at the end of the derivation. Changed from InflectionFeatures for the database port.
InflTemplateApps | Association from Package Ling | Allows Morph Sketch Generator to extract example wordforms where an inflectional template is used. Changed from InflectionalTemplateApps.
InherFeatVal | Association from Package Ling | Owns a FsFeatStruc, representing (some of) the feature values inherently associated with this category (e.g. [+N +V]). Changed from InherentFeatureValues
InitialStratum | Association from Package Ling | The initial stratum to which this rule applies. If not specified, this rule applies to all strata.
Input | Association from Package Ling | owns an FsFeatStruc, constituting the morphosyntactic feature values which must be present in a word in order for this Rule of Referral to apply. Often these features form an 'environment' which is not altered in the Output. However, this is true only if the input features are disjunctive with the output features. For instance, suppose in some language the nominative plural of nouns is syncretic with the nominative singular. Assuming singular and plural are the two possible values of 'number' in this language, this syncretism can be represented by a rule which has as input [case: nominative] and as output [number: singular]. But it is not always possible to make the input and output features disjunctive, particularly (but not only) where features are non-binary. For example, if the above syncretism held in a language which distinguished dual number, and the nominative dual was distinct from the singular (and plural) nominative forms, then it would be necessary to mention the 'number' feature both in the input and in the output, to prevent the rule from overapplying to the dual. It might be possible (and desirable) to have a view of rules of referral in which the input features which are unaffected in the output are distinguished (as a sort of environment) from the input features which are changed in the output. Additional notes: In Stump's (1993a, (11) page 457) format for a Rule of Referral, this corresponds to τ on the left-hand side.
Input | Association from Package Ling | Owns an ordered seq of PhContextOrVar, describing the form of the stem to which the affix attaches. The left-to-right order of the PhContextOrVars in this attribute corresponds to the order of the portions of the input word which match. (N.B.: There could be ambiguity, for instance if the input had two adjacent PhVariables. The system should check for this, and warn the user.) Given that PhContextOrVar can itself own an PhSequenceContext, the use of a seq attribute here may seem like overkill. However, it is only the topmost members of this Input attribute that can be numbered (the numbering is part of the user interface, and allows the user to point back to particular pieces of the input for the output). Perhaps this numbering can be done differently, in which case the Input attribute won't need to be seq.
InputForm | Operation from Class MoDerivTrace | virtual attr, returning a string; defined as follows: if exists of my predecessor then outputForm of my predecessor else inputForm of my owner Represents the phonetic form of the input to this trace object.
InputMsa | Operation from Class MoDerivTrace | virtual attr, returning a MoMorphoSyntaxAnalysis object; defined as follows: if exists of my predecessor then outputMsa of my predecessor else inputMsa of my owner Represents the morphosyntactic properties of the input to this trace object.
InputPOSes | Association from Package Ling | When present, this limits the rule application to apply only when the input is for one of the Parts of Speech given in the collection. The hierarchical nature of Parts of Speech is respected, so if "transitive verb" is a sub-category of "verb" and one specifies "verb" as an input POS, then the rule will also apply to "transitive verb.
InsideAlignedText | Attribute from Class PubHeader | The contents of the portion of the header that is aligned with the inside margin.
InstanceOf | Association from Package Cellar | Annotations, in many cases, are tags from a predefined list of objects. We might want to mark up a text for OCM codes. A particular annotation in context may tag an instance of OCM code 152. WordformsInContext are tagged with Wordforms found in the WordformInventory.
InstanceOfSignature | Attribute from Class CmAnnotationDefn | ClassDefn id from metatable. States that this AnnotationDefn allows instances of a particular class.
instantiate | Stereotype from Package UML Standard Profile | A stereotyped usage dependency among classifiers indicating that operations on the client create instances of the supplier.
integer | DataType from Package Data types
Interlinear Texts | Class Diagram
InternalPath | Attribute from Class CmFile
Introduction | Association from Package Ling
invariant | Stereotype from Package UML Standard Profile | Specifies a constraint that must be attached to a set of classifiers or relationships. It indicates that the conditions of the constraint must hold over time (for the time period of concern in the particular containing element) for the classifiers or relationships and their instances.
IsAbstract | Attribute from Class MoForm | This is used to indicate a lexeme form is an abstract form (e.g.,-[C][V]^2, or iN) and should not be used for parsing.
IsBodyInSeparateSubentry | Attribute from Class LexDb
IsBuiltIn | Attribute from Class StStyle | TRUE means this style was in the default FW style sheet and that the user will not be allowed to delete or rename these styles; FALSE means this style was added by the user. For further discussion, see below: John W. (Mar 20, 2002) adds that in the "Default Style Sheet" specification, we talk about "factory" styles: "This document describes the style sheet that will ship with the FieldWorks Translation Editor. Generally speaking, users can add, modify or delete styles; this document is concerned with the style sheet as it is installed from the factory, and thus the "factory styles" which cannot be renamed or deleted.. There are two sets of styles, one for published materials (Scripture text, introductions, etc.) and one for non-published materials (back translation, consultant notes, etc.) For the former we started with the main styles found in the Paratext stylesheet for the TEV, and modified it as is appropriate for the FieldWorks environment. For the styles listed below (that is, in the specification refered to by John W.) 1. The user will not be permitted to rename or delete these. 2. The user is permitted to change their attributes, including paragraph, font, etc. 3. The user is permitted to edit their "Usage" attribute. " Ken Z. added on Mar 20, 2002: We need some way of saying that certain styles are used by code, and thus can't be deleted or renamed. I believe this might be done right now by hard coding these style names in the styles dialog to keep them from being changed. It seems like IsBuiltIn should be able to serve this function so that we can designate certain styles as built-in and therefore guaranteed to always be there. Unless Bryan or someone else sees a reason not to do this, I think we should add this to the specification. As such, it will be used by more than just the Translation Editor. Ken Z. also notes the following: As for Lela-Teli sample styles, they should not have the IsBuiltIn property set even though they are delivered "from the factory". From all responses, I think it is safe to say that any style that has the IsBuiltIn flag set should not be deleted or renamed by any program.
IsBuiltIn | Attribute from Class PubPageLayout | True if the object is factory supplied.
IsClosed | Attribute from Class CmPossibilityList
IsCustomField | Attribute from Class UserViewField
IsHeadwordCitationForm | Attribute from Class LexDb | Used for flags to determine which form to use for headword, etc.
IsLandscape | Attribute from Class Publication | True if orientation of page is “landscape”
IsModified | Attribute from Class StStyle | This applies only to built-in styles; TRUE means the user changed its properties.
IsModified | Attribute from Class PubPageLayout | True if the object’s properties have been modified from the default (approved) settings.
IsProtected | Attribute from Class CmPossibility | This flag is set for items that are accessed by the software via GUIDs. The software is assuming that this item is always present with the same GUID on all machines. When set, a user can still edit the item, but it cannot be deleted.
IsPublishedTextStyle | Attribute from Class StStyle | TRUE = the style is for use in published text; FALSE = the style is for non-published text
IsResearcher | Attribute from Class CmPerson
IsSorted | Attribute from Class CmPossibilityList
IsTranslated | Attribute from Class Text | The user will set this for texts that have translated material as opposed to original texts.
IsVernacular | Attribute from Class CmPossibilityList | This indicates whether the list will display vernacular (True) or analysis encodings (false) as the default.
Item | Association | This refers to a CmObject, where that CmObject would probably be a MoInflClass (e.g. a conjugation class), an FsSymFeatVal (e.g. feminine gender), or a CmPossibility (for an exception "feature"). Any such MoInflClass would be owned by a PartOfSpeech (or by a nested MoInflClass within a PartOfSpeech); any such FsSymFeatVal would be owned by an FsClosedFeature; and the exception "feature" CmPossibility would be in the possibility list owned by MoMorphData:ProdRestrict.
ItemClsid | Attribute from Class CmPossibilityList | This is the clsid of the items that can be inserted into this list.
K
KeyWord | Attribute from Class ChkRef | In the Biblical Terms list, this will contain the specific Greek or Hebrew word(s) in the original text, though not necessarily the surface (i.e., inflected) form. This may be useful to display for the user. Together with the Ref and Location, this might be useful for associating existing ChkRef objects with ChkTerms in a list that is being restructured according to a new system of organization.
L
Label | Attribute from Class CmMedia | This allows a user to enter a label for each media file in multiple writing systems. It also allows formatting or embedded writing systems.
Label | Attribute from Class ConstChartRow
Label | Attribute from Class StTxtPara | Label to appear at start of paragraph (in margin, if negative first line indent). Note: This attribute is not currently used. John Thomson's original intent was to use it for the kind of paragraph that has something hanging out in the left margin that isn't predictable (as a bullet or number is) from the stylesheet. The classic example would be a list of terms, with the term sticking out to the left. Since we don't yet have tabs implemented, we could set things up to allow the main body of the paragraph to be aligned, and the label out in the margin.
Label | Attribute from Class UserViewField
LangProj | Package from Package Component View
LangProject | Class from Package LangProj | Renamed from LanguageProject for the Firebird Port.
Language Project | Class Diagram
LayoutPos | Attribute from Class CmPicture | An enumeration: 0 - Center Column (no text wrapping around picture, shrinks picture proportionately if wider than the column, caption can occupy full column width); 1 - Center Page (top or bottom of page only, no text wrapping around picture, shrinks picture proportionately if wider than the column, caption can occupy full page width); 2 - Right-align in Column (text wraps to the left of picture, caption can occupy same width as picture); 3 - Left-align in Column (text wraps to the right of picture, caption can occupy same width as picture); 4 - Fill Column (grows picture if necessary to fill column width, caption can occupy full column width); 5 - Fill Page (top or bottom of page only, grows picture if necessary to fill page width, caption can occupy full page width); 6 Full Page (picture occupies full page, grows/shrinks picture if necessary).
LeftContext | Association from Package Ling | The left context of the rule.
LeftContext | Association from Package Ling
LeftForm | Association from Package Ling | LeftForm: refers to a form (Wordform? MoStemAllomorph?), that of the left-hand member of the compound.
LeftMsa | Association from Package Ling | owns an MoStemMsa, giving the morphosyntactic information about the left-hand member of this compound. If this MoStemMsa specifies a PartOfSpeech, then the left-hand member of this compound must belong to that part of speech. If this MoStemMsa specifies an FsFeatStruc, then the left-hand member of this compound must have (not unify with!) the features of that feature structure. Since the parts of speech are contained in an inheritance hierarchy, a question arises: if this MSA points to an abstract part of speech (verb, say), does a word with a more specific part of speech (transitive verb, say) match? In the absence of any reason to think it does not, I would suggest that reference to an abstract part of speech entails that more specific parts of speech are included. Otherwise, it is hard to imagine how one could use this attribute - it would be necessary to allow a collection of parts of speech, or else to have separate compound rule for each specific part of speech.
Level | Attribute from Class UserViewRec
LexAppendix | Class from Package Ling
LexDb | Association from Package LangProj
LexDb | Class from Package Ling | This is the main class for the lexical database. See the LexicalDatabases domain documentation for an overview describing general concepts and external connections. Most of the internal structure is described in subdomains of this same reference. Renamed from LexicalDatabase for the port to Firebird.
LexemeForm | Association from Package Ling | The lexeme form is the form of the entry that is normally used by linguists in interlinear text. The lexeme form is either the default allomorph for this lexEntry (e.g. French 'march' as opposed to citation form 'marcher') or the abstract underlying representation of it. (e.g. -[C][V]^2) When it is an abstract representation, the IsAbstract property is set. The lexeme form is equivalent to the base form in LinguaLinks or the \lx field in MDF files.
LexEntry | Class from Package Ling | This class describes the attributes common to LexMinorEntry, LexMajorEntry and their subclasses.Ken, I added the virtual lexicalForm but I think that we need to add this as an owning attribute.
LexEntryRef | Class from Package Ling | A LexEntryRef object is a general purpose link from a variant or complex entry to one or more major entries. It also classifies the link using variant and/or complex entry types that determine how the references are displayed (e.g., minor entry or subentry, and the abbreviations associated with the reference). The UI may restrict what gets used in a particular LexEntryRef. For example, for a variant entry, the UI might limit VariantEntryTypes to a single type and PrimaryLexemes to a single entry while hiding ComplexEntryTypes and ComponentLexemes. For complex entries it might limit ComplexEntryTypes to a single type and hide VariantEntryTypes. On the other hand, the UI could make all of these available so the user could set combinations of variant and complex entries from a single LexEntryRef when they refer to the same major entries.
LexEntryType | Class from Package Ling
LexEtymology | Class from Package Ling | History of the entry
LexExampleSentence | Class from Package Ling | This provides several additional attributes that are needed for example sentences in a lexical database.
Lexical Database | Class Diagram
LexicalFormIndex | Association from Package Ling
LexPronunciation | Class from Package Ling
LexReference | Class from Package Ling | This class represents a set of lexical relations between senses or references between entries. For lexical relations, it can represent general sets, binary sets, scales, or trees. For entry references it can represent general sets, binary sets, and trees. The type of reference, based on the MappingType of the owner, determines how targets will be interpreted in the UI as well as the class of the targets we want to process for this type.
LexRefType | Class from Package Ling | This class identifies the type of a relation being stored in all of the LexReference items owned in Members. The MappingType enum determines the type of set we are representing. The type of set determines how the name and abbreviations are used. When the name and abbreviation are the same for both directions of the relation (set, pair, and scale relations), they are stored in CmPossibility_Name and CmPossibility_Abbreviation. When the name and abbreviation are different (tree), CmPossibility_Name and CmPossibility_Abbreviation would specify the specific/part labels while LexReferenceType_ReverseName and LexReferenceType_ReverseAbbreviation would be used for the generic/whole label. Renamed from LexReferenceType for the Firebird port.
LexSense | Class from Package Ling
library | Stereotype from Package UML Standard Profile | Denotes a static or dynamic library file. Subclass of «file».
library | Stereotype from Package UML Standard Profile | Denotes a static or dynamic library.
LiftResidue | Attribute from Class LexEntry | Stores XML data that's not part of our model.
LiftResidue | Attribute from Class MoForm
LiftResidue | Attribute from Class LexEtymology
LiftResidue | Attribute from Class LexReference
LiftResidue | Attribute from Class LexSense
LiftResidue | Attribute from Class MoMorphSynAnalysis
LiftResidue | Attribute from Class LexExampleSentence
LiftResidue | Attribute from Class LexPronunciation
LiftResidue | Attribute from Class LexEntryRef
Ling | Package from Package Component View
Linker | Association from Package Ling | owns an MoAffixForm in the encoding of the language, giving the phoneme(s) inserted between the two parts of the compound (cf. Linguist List 10.1477, http://linguistlist.org/10/10-1477.html). If this field is empty, nothing is inserted between the two parts. The linker is semantically meaningless (else it would be a morpheme).
Linker | Association from Package Ling | refers to an MoAffixAllomorph, that of the linker between the two parts of the compound. If there is no linker, this attr is none.
ListVersion | Attribute from Class CmPossibilityList | Uniquely identifies a particular version of the possiblity llist so that version changes can be detected and update routines run.
LiteralMeaning | Attribute from Class LexEntry | This field is here for ease of use for the user. However, if the user fills out the components on the MSA of the subentry, the literal meaning can be derived. If Literal Meaning is empty and the components are filled in, the derived literal meaning should be displayed as virtual (in italics perhaps?) (It used to be on LexSubentry.)
LiteralTranslation | Attribute from Class Segment
local | Stereotype from Package UML Standard Profile | Specifies that the relationship represents a local variable within a AssociationEnd procedure rather than an actual association.
local | Stereotype from Package UML Standard Profile | Local is a constraint applied to a link-end, specifying that the corresponding instance is visible because it is in a local scope relative to the link.
Location | Association from Package Cellar | Some pronunciations can be related to specific areas, so this points to the location list.
Location | Attribute from Class ChkRef | Information about the location of the ChkTerm in the original source text (for Scripture terms, the 1-based index of the word in the verse in the original language). Leave as 0 if not needed.
LocationMax | Attribute from Class CmPicture | Depending on the value of LocationRangeType, specifies the maximum Scripture reference or the number of paragraphs after the paragraph containing the ORC reference at which this picture can be laid out.
LocationMin | Attribute from Class CmPicture | Depending on the value of LocationRangeType, specifies the minimum Scripture reference or the number of paragraphs before the paragraph containing the ORC reference at which this picture can be laid out.
LocationRangeType | Attribute from Class CmPicture | LocationRangeType, LocationMin and LocationMax together are used to prevent gaps at the end of a page from trying to lay out a picture at an exact location (i.e., where the ORC is). LocationRangeType is an enumeration indicating the type of data contained in LocationMin and LocationMax: 0 - LocationMin and LocationMax are ignored, and the picture must lay out on the line following the ORC, even if this results in a gap; 1 - LocationMin and LocationMax contain Scripture references having the format BBCCCVVV, which encodes book, chapter, and verse; 2 - LocationMin and LocationMax represent a number of paragraphs before or after the paragraph containing the ORC. In non-Scripture text, LocationRangeType should always be 0 or 2.
Locations | Association from Package Cellar | A list of locations in which the event occurred.
Locations | Association from Package LangProj
LouwNidaCodes | Attribute from Class CmSemanticDomain | Example: (Ron Moe's Standard Format): \ln 23G Live, Die Multiple Louw & Nida references map to one Unicode string with semicolons as delimiters. At this point, due to royalties, we do not plan to provide the complete Louw & Nida list in our database.
M
MainCountry | Attribute from Class LangProject
MainEntriesOrSenses | Association from Package Cellar | If a user has specified Morphology, then FW should by default set a link to the entry that has a morph type of root. In the case of two or more roots, FW makes an arbitrary decision. Like other parts of the WW system, default choices should be indicated to the user so they can review them. In the majority of cases for subentry-like entries this will be only one entry (establishment points to establish) but with the possibility of more for entries that have more than one root in them (blackboard may point to board and black). For inflected forms, there will ALWAYS be only one entry pointed to (men points to man). (This used to be on LexSubentry and MainEntryOrSense on LexMinorEntry.) Subentries can be "subs" of either a major entry, another subentry, a minor entry (very rare) or a particular sense of any of the above. In this latter case, common in Philippine and Indonesian lexicons, the subentry usually appears under the sense of the entry.
MappingType | Attribute from Class LexRefType | MappingType (max=127) (used as an enum) with possible values: 0 = sense collection (unordered many to many) 1 = sense pair (one to one) 2 = sense tree (one to unordered many) 3 = sense sequence (ordered many to many) 4 = entry collection (unordered many to many) 5 = entry pair (one to one) 6 = entry tree (one to unordered many) 7 = entry or sense collection (unordered many to many) 8 = entry or sense tree (one to ordered many) This enum determines the type of relation represented by the set. It basically determines how the software treats the items in LexReference_Targets. For 0-3 the button to the right would call up a sense chooser. For 4-6 it would call up an entry chooser. For 7-8 it would call up a chooser that allows either entries or senses. For all but 2, 6, and 8 the field label for all items would come from CmPossibility_Abbreviation. For 2, 6, and 8, the label for the first item would be CmPossibility_Abbreviation, while the label for the other items would be CmLexRefType_ReverseAbbreviation.
MarginBottom | Attribute from Class PubPageLayout | Height of bottom margin from bottom of page
MarginInside | Attribute from Class PubPageLayout | Width of inside margin from gutter margin. Footnote: The first implementation will support only “mirror margins”
MarginOutside | Attribute from Class PubPageLayout | Width of outside margin from outside edge
MarginTop | Attribute from Class PubPageLayout | Height of top margin from top of page
max | TagDefinition from Package Data types
MaxDupOccur | Attribute from Class CmAnnotationDefn | The user should be able to set the limit of each type of checking error, as appropriate for each project and stage. MaxDupOccur stores how many "duplicate" errors are allowed for each type of check. Other types of annotations could use this if it's useful. ("Duplicates" would be defined differently for different types of annotations.)
Maximum | Attribute from Class PhIterationContext | an Integer (defaults to infinite; note that there needs to be a way to display and set a value of " infinity" )
Meaning | Association from Package Ling | The literal meaning of the vernacular term or phrase used for rendering the ChkTerm. This will be displayed as the back translation of the vernacular rendering. This is optional, but when supplied (by the user) must be one of the glosses for one of the senses of the SurfaceForm.
Meanings | Association from Package Ling
Media | Association from Package LangProj | This contains a lit of folders holding media file objects. For now, we will have one CmFolder called "Local Media" that holds all media.
MediaFile | Association from Package Cellar | Multiple CmMedia objects may reference a single media file, so this property is a reference to a file. CmFile. As with pictures, media files will be copied to root\media directory where root is determined by LangProject_ExtLinkRootDir, which defaults to c:\program files\FieldWorks if not set (or some other location?).
MediaFiles | Association from Package Ling | A pronunciation may have more than one media file to allow for a man's voice and a woman's voice, slight dialect differences, etc.
Member | Association from Package Ling | a PhPhonologicalContext (but not normally another PhIterationContext)
Members | Association | This holds all of the references of this type.
Members | Association from Package Ling | an ordered seq of PhPhonologicalContext (but not normally another PhSequenceContext)
Members | Association from Package Ling
MergesAfter | Attribute from Class ConstituentChartCellPart
MergesBefore | Attribute from Class ConstituentChartCellPart
metaclass | Stereotype from Package UML Standard Profile | Specifies that the instances of the classifier are classes.
metamodel | Stereotype from Package UML Standard Profile | A metamodel is a stereotyped model denoting that the model is an abstraction of another model, i.e., it is a model of a model. Hence, if M2 is a model of the model M1, then M2 is a metamodel of M1. It follows then that classes in M1 are instances of metaclasses in M2. The stereotype can be recursively applied, as in the case of a 4-layer metamodel architecture.
min | TagDefinition from Package Data types
Minimum | Attribute from Class PhIterationContext | an Integer (defaults to zero)
MinusConstr | Association from Package Ling | refers to a collection seq of PhFeatureConstraints; see discussion under the plusConstraints attr. A feature in question is required to have opposite value from a plusConstraint elsewhere in the rule, and thus makes sense only if a constraint with the same value appears elsewhere in the rule.See implementation comments under plusConstraints. Changed from MinusConstraints for the Firebird Port.
MoAdhocProhib | Class from Package Ling | This abstract class is intended to capture co-occurrence restrictions between morphemes or allomorphs which cannot be captured using morphosyntactic or phonological restrictions. Linguistically speaking, this is perhaps as bad a kludge as you can imagine. We allow it here for reasons of stealth-to-wealth work, with the understanding that the program will twist the user's arm into getting rid of these later on (perhaps by flagging each of these constraints with a Warning). The technique is borrowed from AMPLE's ad hoc pairs. Note however that, Aronoff (1976: 53) gives as an example of a negative constraint the fact that the suffix -ness does not attach to adjectives of the form X-ate, X-ant, or X-ent. So maybe this isn't such a kludge after all. On the other hand, Aronoff's examples are largely statistical generalizations, that is, tendencies - as opposed to hard constraints. It may be that we should also have positive cooccurrence constraints. Aronoff (1976: 63) lists a number of "forms of the base" which are compatible with the English prefix un-, among them X-en (where -en is the past participle suffix), X-ing, and X-able, which would be examples of positive constraints. However, un- also attaches to a good many monomorphemic stems (roots, e.g. unhappy), so it may be that this is not a real generalization. In addition to the attributes below, there should probably be an attribute to point to analyses which are ruled out by these constraints. These could be either grammatical words for which the parser would generate an incorrect analysis if it were not for this constraint, or ungrammatical words which the user has supplied, and which would be parsed if not for this constraint. It may even be desirable to allow individual constraints to be turned off in the parsing of such examples, in order to verify that the constraint works, and that it is (still) needed. However, the need for such an attr is probably more general than this class; see my email of 18 Jan 2000. Attributes: (Note also that both subclasses define an attribute to hold a seq of objects that are prohibited from co-occurring. For MoMorphemeAdhocCoProhibition, these objects are MoMorphoSyntaxAnalysis objects, representing morphemes; for MoAllomorphAdhocCoProhibition, these are MoForm objects, representing allomorphs.) Renamed from MoAdhocCoProhibition for the Firebird Port.
MoAdhocProhibGr | Class from Package Ling | Allows the user to group MoAdhocProhib to provide "some rationale" for the adhoc. Renamed from MoAdhocProhibGr for the Firebird port.
MoAffixAllomorph | Class from Package Ling | For Item-and-Arrangement allomorphs. Regardless of theoretical propensities, this is the sort of analysis that linguists usually start out with (with the probable exception of reduplicative affixation, at least once the linguist has figured out that the affix is reduplicative). In the current model, each allomorph is owned by a single affix (LexEntry). It has sometimes been argued that the phonological form is shared among distinct morphemes (Robins 1959). For example, in English the third person present tense verbal suffix, the noun plural suffix, and the possessive clitic all arguably have the same form. The LinguaLinks conceptual model supports this viewpoint, but it appears to have caused a great deal of confusion among users (Larry Hayashi, email 13 April 1999), and even programming bugs. The model described here does not support the independence of allomorphs from morphemes; rather, each morpheme owns its own allomorphs.
MoAffixForm | Class from Package Ling | This is an abstract class for affix allomorphs, with subclasses for Item-and-Process vs. Item-and-Arrangement treatment.
MoAffixProcess | Class from Package Ling | For Item-and-Process allomorphs (in the sense of 'Item and Process' morphology in which affixes are processes, not the sense in which allomorphy is caused by the action of phonological processes). Using the Output attr (defined below), it is possible to reduce the number of allomorphs of a given morpheme under the process approach. For example, an affix with an initial consonant whose voicing agrees with the voicing of the final phoneme of the stem can be described as a single allomorph by using the appropriate phonological properties. At the same time, since any one affix can have multiple MoAffixForm objects, including multiple MoAffixProcesses, it is not necessary that all allomorphy be accounted for within the Output attr. Indeed, with phonologically conditioned suppletion (Carstairs 1990), it will be necessary to resort to multiple allomorphs even under the process view. There is no provision in the model as it currently exists for '(re)adjustment rules', defined as "rules which change the segmental shape of designated morphemes in the immediate environment of other designated morphemes" (i.e. rules of truncation and allomorphy; Chomsky and Halle 1968: 238-239; Aronoff 1976, chapter five; Scalise 1986: 63-67). The assumption here is that morphological rules themselves will define any such allomorphy (and that eventually, phonological rules will be added to the model to deal with allomorphy that is not specific to a certain morpheme). Several objections could be raised against this: (1) It has been argued (Aronoff 1976, chapter five) that morphological rules are not the appropriate place to define allomorphy. (2) Treating allomorphy with morphological rules works well only when the allomorphy is inwardly sensitive, that is, when the allomorphy is in an affix, conditioned by the form of the stem to which it attaches. There is no obvious way in Item-and-Process morphology to treat outwardly-sensitive allomorphy which depends on the specific morpheme affected, as opposed to just the (underlying) phonetic form of that morpheme. In particular, it is difficult to treat allomorphy affecting a class of roots. For further discussion, see Maxwell 1996, appendix 3. Additional Notes: In regard to point (1) above, Mike Maxwell states: For the record, I do not find Aronoff’s arguments strong. In particular, there are better solutions using morphological rules than the rule of Truncation that he considers on page 89, which is effectively a straw man. In regard to point (2) above, one work-around would be to use paradigm classes.
MoAlloAdhocProhib | Class from Package Ling | This is intended to capture co-occurrence restrictions between allomorphs which cannot be (or has not yet been) captured using morphosyntactic or phonological restrictions. There are some problems with this class as it stands. The use of the value Anywhere in the Adjacency attr serves to constrain any two or more allomorphs from cooccurring in a single word, whereas the use of the other possibilities in that attr only serves to constrain a set of two or more allomorphs from cooccuring with a single allomorph. This inconsistency could be eliminated by making Anywhere work like the other possibilities (but that would make it less useful), or by replacing the single Allomorphs attr with two attrs, one for one set of allomorphs, and one for another set. The co-occurrence restriction would then be between any allomorph from the first set and any allomorph from the second (and the meaning of the values SomewhereToLeft and SomewhereToRight would be clarified). This would of course have the disadvantage of making this class non-parallel to the class MoMorphemeAdhocCoProhibition. Another problem with this class is that there is no way to constrain what sorts of things can occur between the allomorphs with any of the values Anywhere, SomewhereToLeft and SomewhereToRight. For example, processes such as vowel harmony and nasal assimilation are often blocked by affixes with exceptional values for the features in question. This can be indicated by suitable phonological environments, but not by the use of an allomorph co-occurrence constraint. Was renamed from MoAllomorphAdhocCoProhibition for the Firebird Port.
MoBinaryCompoundRule | Class from Package Ling | This is an abstract class (a subclass of MoCompoundRule), encompassing compounds where the branching is binary (most compounds are probably binary branching, although see the cautions in Fabb (1998) section 2.3). The two daughters are here referred to as the 'left' and 'right' constituent. Compounds of this class which contain more than two constituents must thus be built up recursively. Thus, manhole cover has the structure [[man hole] cover], rather than a flat structure. Note that there is no implication that the left- or right-hand elements of compounds are heads; headship is determined in MoEndocentricCompound.headLast.
MoCompoundRule | Class from Package Ling | This is an abstract class, encompassing endocentric, exocentric, and coordinate compounds, as well as incorporation (e.g. incorporation of a direct object into a verb). There is a typology of compound types given in Spencer (1991: 310ff.); some of the compounds he discusses shade into idioms. This model does not attempt to account for the semantics of compounds in the compounding rule, since this is largely unpredictable. Nor do we attempt to account for argument linking. For example, Lieber (1983: 258) claims that an element of a compound must be able to link to all its obligatory internal arguments. That is, if an argument-taking element is a non-head, it must find its argument within the compound (Lieber's example is drawbridge, where bridge is the internal argument of draw); otherwise (if the argument-taking element is the head of the compound ), it can link to arguments which are external to the compound (Lieber's example is hand-weave). Accounting for argument linking would require at a minimum that we model argument requirements of lexemes (i.e. subcategorization lists). However, argument linking is also closely related to semantic and pragmatic issues, which are well outside the scope of our plans. Additional notes from Andy Black January 2002: The old way used ref attrs (at least to POS) because they directly referred to POS. The new way is for the compound rule to own an MSA (which in turn can refer to a POS and can own FS, etc.) So I'm rather sure that these MSA attrs of compound rules are supposed to be owning. If they were referring, I have no idea what MSA they would refer to. The Msas in a compound rule do not belong to a particular lexical item, they just happen to have all the relevant information needed by a compound rule. Response from Randy Regnier: Well, maybe then I am missing something. What will a compound rule actually control then? I gather it won’t actually use the MSA directly. I had assumed something along the lines of X and Y can be compounds. But if X and Y are independently owned Msas, then the parser will never find them in the lexicon. Randy Response from Andy: For all three stages, the manifestation of a compound rule is a rule in our word grammar rule. This rule will be of the form rule {Stem via compound rule crVAdv} Stem_1 = Stem_2 Stem_3 with appropriate constraints. The constraints will have to check the POS and FS of each MSA within the rule. They might end up looking like this: | constraints = { posV / posVIntrans / posVTrans} = posIncAdv where the values on the right hand side will come from these owned Msas (i.e. we will get the POS value from the POSs within the toMsa and fromMsa). We'll do something similar for the FS of these Msas. In the above constraints, it says that the left member has to be a verb (or one of its subtypes) and the right member has to be an "incorporated adverb." (This is from the ZPU data, where I think that the adverbial suffixes are really just incorporated adverbs, hence compounded.) The Stem_2 and Stem_3 get their "synCat" values from another rule: rule {Stem consisting of a single root} Stem = root | percolation = (etc.) So the lexical items will be put into the word tree as "roots" and their lexical MSA info will be passed up to the Stem node. This Stem node may then become part of a compound rule (either as Stem_2 or as Stem_3).
MoCompoundRuleApp | Class from Package Ling | This represents the application of a single MoCompoundRule, i.e. the morphological combination of any two stems. The stems are represented as two stems in the lexicon. Any further affixation is assumed to be attached to the head member of the compound, if this is an endocentric compound (i.e. the rule is of the class MoEndocentricCompound). If this is an exocentric compound (the rule is of the class MoExocentricCompound), then further affixation is applied to the entire word. Any phonological rules of the appropriate strata (the stratum of the compounding rule and all higher strata) will be applied. An alternative to having the members of the compound be stems, would be to allow the members to be MoDerivation objects. This would allow words or stems which were not stored in the lexicon. In their present form, MoDerivations are intended to contain a derivation beginning with an underlying form and ending at a surface form. If they could also be used inside compounds, the final form would usually be of a non-surface stratum.
MoCoordinateCompound | Class from Package Ling | This is a concrete class (a subclass of MoCompoundRule), for compounds of which all the members are heads, as opposed to endocentric compounds, in which one member is the head, or exocentric compounds, in which no member is a head. This class also differs from endocentric and exocentric compounds in that the branching may be non-binary. There are several linguistic terms for this sort of compound, including 'co-ordinate compounds', 'appositional compounds', and 'dvandva compounds'. An example (taken from Fabb 1998, page 74; see also section 1.1.2) is the Tamil for 'courage, bravery and valour'.
MoCopyFromInput | Class from Package Ling | Indicates that a portion of the input is to be copied over to the output without modification.
modelLibrary | Stereotype from Package UML Standard Profile | A model library is a stereotyped package that contains model elements that are intended to be reused by other packages. A model library differs from a profile in that a model library does not extend the metamodel using stereotypes and tagged definitions. A model library is analogous to a class library in some programming languages.
modelLibrary | Stereotype from Package UML Standard Profile | This dependency means that the supplier package is being used as a model library associated with a profile. The client is a package that is stereotyped as a profile and the supplier is a non-profile package that contains shared model elements, such as classes and data types.
MoDeriv | Class from Package Ling | This represents the derivation of a word (or stem), i.e. the relationship between a 'surface' word and the stem, any derivational affixes, and the morphosyntactic inflectional features. A derivation gives the derivational order of attachment of affixes, application of compounding rules, and the application of phonological (morphophonemic and/or allophonic) rules. (However, phonological rules have not yet been defined for purposes of this specification.). In particular, the attr StratumApps contains the derivational order of strata, each of which in turn contains the order of attachment of affixes of that stratum. It is not clear whether this class is actually required. In particular, the StratumApps attr could instead be an attr on WfiAnalysis. But until that attr is added to WfiAnalysis, this class will serve. (Note that test cases may also require an attr pointing to their derivation.) Renamed from MoDerivation for the Firebird Port
MoDerivAffApp | Class from Package Ling | This represents the application of a single derivational affix to a stem.An assumption here is that there are no instances where two affixes must attach at the same time to a stem. This corresponds to the " Binary Branching Hypothesis" (Aronoff 1976, Scalise 1986: 146-151), which is generally accepted as correct. (Circumfixes would be considered to be a single affix which happens to wrap around the stem, not the simultaneous attachment of a prefix and a suffix.) Renamed from MoDerivationalAffixApp for the Firebird Port
MoDerivAffMsa | Class from Package Ling | This class is intended for derivational affixes. Since the current model does not allow for non-realizational versions of inflectional morphology, this class could probably be used to treat inflectional morphology under a Lieber-style analysis. According to the "Unitary Base Hypothesis", "the syntacticosemantic specification of the base of a word formation rule may be more or less complex, but it is always unique" (Scalise 1986: 136; see also Aronoff 1976: 47ff.). In our terms, there is a one-to-one relationship between a sense of a derivational affix and its morphosyntactic specification. While that could be captured in the conceptual model (of LexEntry for affixes), it is not. From a stealth-to-wealth standpoint, that may be just as well, although we could encourage it by procedural code (and doing so might push the linguist to deeper investigation of the semantics of affixes which are apparent counterexamples to the Unitary Base Hypothesis). There are some affixes (probably mostly derivational affixes) which attach only to stems of a specific phonological shape. For example, the English inchoative suffix -en attaches productively only to adjectives ending in t and d (brighten, *dimmen; exceptions such as blacken and darken are said to date from an earlier period in English, see Aronoff 1976: 79). The model does not provide for this sort of restriction on morphemes. One work-around is to encode the restriction at the level of the allomorph (MoAffixForm), and have only that one allomorph for the affix. Should derivational affixes be allowed to add exception features to a word (e.g. by percolation)? There are some arguments back and forth in Aronoff 1976: 52, although it certainly looks like derivational affixes should be able to have exception features (the question is whether they percolate). See also discussion under the MoStemMsa.ExceptionFeatures. enamed from MoDerivationalAffixMsa for the Firebird Port.
MoDerivStepMsa | Class from Package Ling | This gives the morphosyntactic properties of a stage in the derivation of an inflected word. Objects of this class are used in MoDerivationTrace objects. Renamed from MoDerivationalStepMsa for the Firebird Port.
MoDerivTrace | Class from Package Ling | This is an abstract class, which subsumes various kinds of trace structures. The assumption is that a derivation is a sequence of stratum applications (MoStratumApps), and that each stratum application is a sequence of derivational affix applications (MoDerivationalAffixes, possibly an inflectional template application (MoInflTemplateApp), and (when they are implemented) a sequence of phonological rule applications (MoPhonolRuleApps), in that order. (The ordering assumption would need to be modified to allow for cyclic phonological rule application.) Renamed from MoDerivationTrace for the Firebird Port.
Modification | Association from Package Ling | refers to an PhNCFeatures object, specifying the features to be added to the phonemes matched by the content to give a portion of the output.
Modification date | TagDefinition
ModifiedBy | Association | From a list of users, the person who last modified the journal entry.
MoEndoCompound | Class from Package Ling | This subclass of MoBinaryCompoundRule serves for endocentric compounds and incorporation structures, in which the morphosyntactic properties of the head constituent determine the morphosyntactic properties of the compound structure. Typically only the head is inflected, as well. Most English compounds are of this type. Note that the head constituent is best defined in terms of the relationship between the head and the whole, rather than the relationship between the two constituents; thus, the English killjoy is not endocentric, despite the fact that kill presumably selects joy. See Fabb (1998: 70). This class does not provide a way to override the percolation of the head's morphosyntactic properties to the output structure, this being essentially the definition of 'head'. However, this may be too strict a limitation, in that a construction might override the head properties by imposing a minor modification on the morphosyntactic properties of the output. For example, in languages with (true) incorporation, incorporation of the direct object may or may not make the resulting verb intransitive (Baker 1996: 31). We use the OverridingMsa attribute to override percolation of features, or (better) to change the subcategorization list of the head. Note:There are theory-internal considerations here. For example, Baker treats overt NPs in polysynthetic languages as adjuncts, not complements. In a certain sense, then, a verb - with or without an incorporated object noun - is not transitive. Endocentric compounds are inflected on their heads (Scalise 1986: 124), and the parsing/ generation algorithm will need to take this into consideration. Non-heads of endocentric compounds are usually uninflected, even when the word in question is always inflected in isolation. An English example is pluralia tantum words like scissors and trousers, which appear in their singular forms in compounds: scissor-handle and trouser-leg (example (68) in Scalise 1986: 123). This will be reflected in the LeftFeatures or RightFeatures of the appropriate member. Exceptions sometimes occur with irregular plurals: teethmarks (but cf. toothbrush, *teethbrush). Renamed from MoEndocentricCompound for the Firebird Port.
MoExoCompound | Class from Package Ling | This subclass of MoBinaryCompoundRule serves for exocentric compounds, such as English killjoy or Spanish paracaidas 'parachute', in which neither constituent appears to be the head. To my knowledge, exocentric compounds are not inflected for their syntactic function, although the individual members of the compound may have their own inflection. For example, the Spanish example of the previous paragraph is made up of a preposition para 'for' and a feminine plural noun caidas 'falls'; the compound itself is masculine and ambiguous for number, but is not so inflected. Other Spanish examples include lavaplatos 'dish washer', consisting of the third person singular present indicative verb lava 'washes' and the masculine plural noun platos 'dishes'; and sacamuelas 'dentist', consisting of the third person singular present indicative verb saca 'removes' and the plural noun muelas 'teeth'. Lavaplatos is masculine and ambiguous for number, while sacamuelas is ambiguous for both gender and number. It is not clear how to specify this behavior. Renamed from MoExocentricCompound for the Firebird Port.
MoForm | Class from Package Ling | This is an abstract class, with subclasses for roots and affixes. MoForms are stored in the Forms attr of LexEntries. That attr needs to be a sequence (not collection) attr, because the ordering of the allomorphs is relevant if their environments of occurrence are taken to be disjunctively ordered (a common assumption). For example, the English noun plural suffix (as well as the third person singular present tense verb suffix and the possessive enclitic) has the form /«z/ after strident sounds, /s/ after (non-strident) voiceless sounds, and /z/ elsewhere. The latter environment can most easily be represented as "otherwise," a characterization which requires disjunctive ordering. The environment for /s/ is also most simply represented if disjunctive ordering is assumed: /s/ appears after voiceless sounds, unless the /«z/ is more appropriate. Without disjunctive ordering, it would be necessary to explicitly disallow /s/ after strident sounds, recapitulating the information that /«z/ appears in that environment. When we add a morphophonology component, there will need to be a way of telling whether a given allomorph is predictable by phonological rule. In the case of a stem, this would require creating an underlying form, then trying to derive the entire paradigm of the stem from that underlying form. In order to thoroughly test the rule(s), it would also be necessary to test the paradigms of any other stems arising from the attachment of a derivational affix to that stem, and any compounds formed with the stem. The endpoint of the task of deriving allomorphs from underlying forms, is to reduce the number of allomorphs of each morpheme to one (apart from suppletion). A phonological rule can potentially modify any stem in the lexicon, so the introduction of a phonological rule implies full-fledged testing. Note however that the use of strata might ameliorate these effects. For example, if allomorphs are assigned to a higher stratum than underlying forms, and the phonological rule applies prior to that higher stratum, it cannot affect those allomorphs. This assumes the presence of the allomorphs is not required for purposes of the rule’s environment.
MoGlossItem | Class from Package Ling | Type specifies whether or not this MoGloss is: a. a container b. a gloss c. a separator character
MoGlossSystem | Class from Package Ling
MoInflAffixSlot | Class from Package Ling | This represents a set of Inflectional Affixes which are in complementary distribution on morphosyntactic grounds, and which occupy the same position relative to the stem and to the affixes of other slots (usually; see discussion under MoInflAffixTemplate concerning exceptions to this positional interpretation). As with MoInflAffixTemplate, it is not possible to arrange the Affix Slots in an inheritance hierarchy, and for the same reason: the Affixes slot is a sequence attribute, and it is unclear how one slot could modify another slot's sequence of affixes in inheritance (or how this inheritance would be modified if the user changed Affixes slot of the inherited-from Affix Slot). However, the PartOfSpeech objects which own the Affix Slots are arranged in an inheritance hierarchy, and if a subcategory has an Affix Slot with the same name as one of its parent's Affix Slots, the subcategory's Affix Slot overrides that of the parent. Also, two distinct slots can refer to some of the same affixes (since the MoInflAffixSlots are owned in the lexicon). Note that there is no attribute here for the semantics (or "grammatical function") represented by the slot. This is intentional: a slot need not have any coherent semantics (Matthews 1972b: 116). To the extent that a slot does have a unified semantic function distinct from that of other slots, this can be captured by the Name attribute, e.g. "Person/tense.""Person/tense," and in the Description slot.
MoInflAffixSlotApp | Class from Package Ling | This represents the application of a slot in an inflectional affix template to a stem. Note that there is no class for the attachment of an inflectional affix (which would be parallel to the class MoDerivationalAffixApp). The reason is that sufficient information is contained in the application of the slot.
MoInflAffixTemplate | Class from Package Ling | An Inflectional Affix Template allows for the implementation of 'template morphology' (Anderson 1992, Stump 1998; note that an affix template essentially corresponds to Stump's 'Paradigm Function Schema'). An Affix Template provides for a sequence of slots (Stump's term; 'rule blocks', in Anderson's terminology) in which Inflectional affixes may appear-in effect, order classes for affixes. However, there is a difference from traditional position (order) classes, in that the latter were intended to capture two things: cooccurrence restrictions, and linear order, whereas affix templates are intended to capture (most cases of) cooccurrence restrictions, and are to some extent agnostic about linear order. While the order of affixes in affix templates usually corresponds to the linear order, it is possible to have both prefixes and suffixes in the same template (or even in the same slot). The need for this (or more commonly, perhaps, for infixes and prefixes in the same template or slot) is not unheard of; Stump (1993a: 457) gives an example from Sanskrit in which one affix in a slot is a suffix, while the other is a simulfix. Even then, it is sometimes possible to treat the infix or simulfix (etc.) as if it were a slightly odd prefix or suffix. Examples of so-called 'discontinuous bleeding' between prefixes and suffixes also exist, but are rarer (see for example Matthews (1972b), particularly his "series 30" on page 113). In true cases of discontinuous bleeding, the slots of the template will no longer represent position classes. (Anderson 1992: 131, on the other hand, says that the question of whether slots/ blocks correspond to the traditional notion of position classes is open.) Having said this, it will usually be reasonable to begin under the stealth-to-wealth approach with a traditional position class approach, assuming that affixes that occur in the same position relative to the stem and to each other belong to the same slots. (Discovering these position classes could be assisted by a program like PARADIGM (Grimes 1983).) Only when discontinuous bleeding cannot be accounted for in other ways (e.g. by assuming that one or the other of the affixes in question requires a more specific set of Inflectional features) will it be necessary to combine prefixes and suffixes, say, into a single slot. It should also be noted that there is no attribute in the template (or on the slots) distinguishing those slots which are prefixes from those which are suffixes, although it would be easy to create a virtual attribute which would show this where appropriate (i.e. where all the affixes of a given slot are suffixes, or all are prefixes). MoInflAffixTemplates are owned by PartOfSpeech objects. It might be nice if distinct MoInflAffixTemplates could inherit properties from each other. For instance, the Affix Template for a transitive verb might be just like that of an intransitive verb, save for having an additional slot for affixes marking object agreement. Unfortunately, MoInflAffixTemplates probably cannot participate in inheritance, since their principal attribute is the ordered list of MoInflAffixSlots, and it is unclear how inheritance of elements in a list could be done. (For example, it is unclear how an object slot could be inserted among the slots of another template.) However, since the MoInflAffixSlots themselves are owned by the PartOfSpeech, it is quite possible for two MoInflAffixTemplates to share many of the sameMoInflAffixSlots. What they cannot inherit is the order of those shared slots; they can only copy one another's order (and naturally, the copy can be altered, destroying the identical orders-of course, sometimes that is the correct thing!). There is no provision as yet for "spanned orders", i.e. overlapping slots; Grimes (1983) gives the following hypothetical example (his figure 1, page 5): Order 6 5 4 3 2 1 0 Prefixes ma-na- ba- da- ga- ka- pa-ta- Stem sa-za- The model may need to be modified to accommodate spanned orders. A work-around would be to assign the affixes of the spanning slot to one of the spanned slots, and to create null affixes with the appropriate morphosyntactic features as fillers for the remaining spanned slots. In many cases, the morphosyntactic features of the non-null spanning affixes can be used for these null affixes as well.
MoInflAffMsa | Class from Package Ling | An MoInflectionalAffixMsa defines an inflectional affix, i.e. the features which the affix realizes together with the phonological process applied to a stem to yield an inflected stem. The meaning of the inflectional affix is supplied by the Sense(s) which point to this morphosyntactic information item, but it is duplicated by the InflectionFeatures attribute (below). In some theories, grammatical morphemes like inflectional affixes are held not to have a sense per se, but only grammatical meaning (which in the model described here, would be encoded directly in the nflectionFeatures attribute). Inflectional affixes are treated in a realizational approach, as in Anderson 1992 etc. There is no provision in the model at this point for alternative treatments of inflection, e.g. a Lieber-style analysis. That could probably be added as an alternative theory of inflectional morphology at a later date, although the price would be complication. MoInflectionalAffixMsas are owned in the lexical database. Thus, they may be referred to (indirectly) by different MoInflectionClasses. There will doubtless be other attributes of this class (such as glosses); those defined here are just the ones necessary for the paradigm model. Renamed from MoInflectionalAffixMsa for the Firebird Port.
MoInflClass | Class from Package Ling | Inflection Classes correspond to the traditional idea of declension classes (for nouns and adjectives) and conjugation classes (for verbs). The concept is sometimes collapsed with the notion of paradigms (e.g. the "er paradigm"), which may cause confusion. Inflection Classes are abstract in the sense that they give instructions for how to build the paradigm of a given lexeme; in that sense, they are like class definitions as contrasted with instances of a class. Inflection Classes are owned by a PartOfSpeechgrammar.rtf - PartOfSpeech or by another MoInflectionClass. They thus form a default inheritance hierarchy from most general to most specific, so that Inflection Classes that are specializations of other Inflection Classes can be defined. Importantly, such specializations can define cells of the paradigm which are filled in different ways-exceptions to the inheritance hierarchy. There are limits to how far a given Inflection Class can deviate from the Inflection Class that it inherits from. First, there is no provision for inheritance across branches of the tree, i.e. this is a "tree-structured" inheritance hierarchy. Inheritance across branches would allow e.g. the Spanish verb tener to be described as a specialization of both the class of verbs showing the e/ye alternation and of the class showing the n/ng alternation. The problem is that with this across-branches inheritance, it would be possible for a given lexeme to have conflicting properties (ways to fill a single cell) inherited from two or more classes, neither of which is a specialization of the other, and it would be unclear which property "wins." In phonology, an analogous problem would seem to arise with "phonological rule features," each of which can trigger a different set of phonological rules. But the problem is resolved (in derivational theories) because the extrinsic ordering of those rules resolves any conflict, essentially resulting in prioritized multiple inheritance. (Similarly for the inheritance of conflicting phonological constraints under theories with ranked violable constraints, such as Optimality Theory.) A second limitation on inheritance is that inflection classes cannot specify alternative dimensions to their paradigms (PartOfSpeech.InflectableFeatures), because the dimensions are defined by the PartOfSpeech that ultimately owns the inflection classes. This limitation is probably realistic. A third limitation is that while an Inflection Class can specify an entirely different MoInflAffixTemplate from that of its parent Inflection Class, it cannot specify that one slot within the Affix Template it inherits is different, or that one affix within a given MoInflAffixSlot of that inherited Affix Template is different. This is a serious limitation, as it might be desirable to describe sub-inflection classes in precisely this way. However, it is not clear how this could be implemented , particularly if the inherited-from Template or Slot changes. For example, if a daughter Inflection Class replaced one of the slots of the parent Inflection Class with another, what would happen if the user decided to split the parent class's slot into two slots, or combine it with another slot? Renamed from MoInflectionClass
MoInflTemplateApp | Class from Package Ling | This represents the application of an MoInflAffixTemplate to a stem.
MoInsertNC | Class from Package Ling | Indicates that a natural class (the length of one phoneme, albeit perhaps incompletely instantiated, i.e. an archiphoneme) is to be inserted in the output at this point. The insertion of a natural class implies that the phonological component will sufficiently instantiate the inserted archiphoneme as to render it an unambiguous phoneme. This class is therefore irrelevant unless a phonological component has been implemented.
MoInsertPhones | Class from Package Ling | Indicates that a sequence of phonemes (possibly including a boundary marker) is to be inserted at this position. This is the typical way of adding 'plain' affixal material. Note that to the user, this sequence may appear to be simply a string in the encoding of the language.
MoModifyFromInput | Class from Package Ling | Indicates that a portion of the input is to be copied over to the output, but modified by the addition (or change) of certain features. This would be useful for a simulfix, for example; or for reduplication with modification.
MoMorphAdhocProhib | Class from Package Ling | This is intended to capture co-occurrence restrictions between morphemes which cannot be (or have not yet been) captured using morphosyntactic (or perhaps phonological) restrictions. The scope of the cooccurrence constraint is the entire word. The two or more morphemes participating in cooccurrence constraints are not constrained to be string-adjacent. However, it might be possible to restrict cooccurrence restrictions between exactly two morphemes to derivational order adjacency, i.e. to the last affix added. This would follow from Siegel's 'Adjacency Condition' (cited in Scalise 1986: 170). Renamed from MoMorphemeAdHocCoProhibition for the Firebird Port.
MoMorphData | Class from Package Ling | This class holds the few items of information which are relevant only to the morphology. Presumably there will be virtual attributes for other things, e.g. all derivational affixes or all inflectional affixes. I have not defined these (but see the similar attributes of MoStratum). Renamed from MoMorphologicalData for the Firebird Port.
MoMorphSynAnalysis | Class from Package Ling | It is intended to group together the morphosyntactic information about a mono- or poly-morphemic object (roots, affixes, composite stems...); in essence, whatever morphosyntactic properties a parser could be expected to "know", as opposed to phonological or semantic properties. (The reference to a parser is for illustrative purposes only; MoMorphoSyntaxAnalysis objects are relevant regardless of whether the system contains a parser.) This is an abstract class. Subclasses for stems, derivational affixes, and inflectional affixes are discussed here; LexEntries also own MoMorphoSyntaxAnalysis objects, e.g. for words and idioms. Notice that the three subclasses have an attr named Allomorphs, although the signature is MoStemAllomorph in the case of MoStemMsa, and MoAffixForm in the case of the other two classes. Additional Notes: From a broad perspective, theories of morphology can be divided into morpheme-based theories and word-based (or better, lexeme-based) theories. Scalise (1986: 40; drawing on Aronoff 1976) lists the following characteristics of the 'Word Based Hypothesis' (in contradiction to a morpheme-based analysis): 1. The bases of Word Formation Rules (WFRs, i.e. derivational affixation) are words, not morphemes. One issue here is whether words like perceive, deceive, conceive etc. should be broken down into meaningless morphemes per?, de?, con?, and ?ceive (note that ?ceive has the allomorph ?cept in nominalizations of all these words: perception etc.). Similarly with respect to words like strawberry (where berry has its expected meaning, but straw does not) and cranberry (where cran apparently has no meaning apart from this word). Another issue is whether words like serendipity and total are polymorphemic (serendip + i + ty and tot + al); Aronoff would claim they are not. 2. These words must be existing words, as opposed to possible but non-existing words. For example, recitation cannot be derived from *recitate, nor approbation from *approbate. 3. The base of a WFR must be a single word, not more (i.e. a phrase; clitics are thus a separate issue) or less (a bound form; see point (1) above). 4. The input of a WFR must be a major category, i.e. N, V or A, or in some languages P. Adverbs are seldom discussed, but at least some adverbs (such as locatives and VP- or S-modifiers) would presumably be included under one of the other major categories. What is ruled out is that the base might be a category like determiner, 'particles', or an uninflectable adverb like very. 5. The output of a WFR must be a major category. However, the term 'word' in the above has led to confusion. Aronoff was not concerned in his 1976 book with inflectional affixation, so the term 'word' might be better understood as 'inflectional stem' or 'lexeme', i.e. the base to which inflectional affixes attach. Thus, if in some language, all words of a given category bear (overt) inflectional affixes, talking about the stems of that language does not violate the Word Based Hypothesis. What would violate the Word Based Hypothesis would be an analysis in which -ceive and -mit were stored in the lexicon as stems, and per-, de-, con- etc. were analyzed as prefixes attaching to such stems. Putting it differently, analyses which violate the criteria in points (1-3) might be seen as over-analysis. Thus, -ceive and -mit are not words (point 1), and they are certainly not existing words (point 2); at most, they are bound forms (point 3). The existence of subclasses of this class for sub-word things (stems and affixes) is not intended to prevent modeling lexeme-based theories. In fact, while the conceptual model given here does not actually prevent the user from doing morpheme-based morphology in violation of the Word Based Hypothesis, he is not encouraged to do so, since lexemes listed in the lexicon are expected to have meanings (senses) associated with them (issues 1-2). At the same time, the model does not enforce points (3-5), nor can it probably do so on a universal basis. For example, the borderline between major categories and minor categories (points 4-5) is not clear across languages. Some languages have inflectable prepositions, and it is at least conceivable in some of these languages that those prepositions will also serve as the base for derivational morphology. In summary, the model is intended to support lexeme- (stem-) based morphology to the extent possible. With regard to affixes: some theories (e.g. a-morphous morphology, Anderson 1992) do not consider affixes to be morphemes, in the sense of items listed in the lexicon. The existence of the classes MoInflectionalAffixMsa (for inflectional affixes) and MoDerivationalAffixMsa (for derivational affixes), and the storage of objects of such classes in LexEntry objects, is not intended as a theoretical statement. Renamed from MoMorphoSyntaxAnalysis for the Firebird Port.
MoMorphType | Class from Package Ling | There is one of these objects for each morpheme type, and are owned by the CmPossibilityList for the language. The attributes name and abbreviation are inherited from the superclass, CmPossibility.
MoPhonolRuleApp | Class from Package Ling | This represents the application of a single phonological rule to a stem. Inasmuch as phonological rules are not defined in this document as yet, this is a placeholder for a future class.
MoReferralRule | Class from Package Ling | Rules of Referral are used when one cell of a paradigm is realized in the same way as another cell-that is, to define syncretisms in a paradigm. Specifically, they are intended to describe syncretisms which cannot be captured by the use of underinstantiated morphosyntactic feature structures and disjunctive ordering of affixes. Typically, syncretisms appear in the more marked portions of the paradigm. As an example of a situation where referral rules are not necessary, suppose affix A marks the genitive case, affix B marks the dative case, and affix C is used elsewhere (perhaps in the nominative and accusative cases). This situation can be easily captured by the use of features and disjunctive ordering as follows: affix A realizes the morphosyntactic feature [genitive case], affix B realizes the feature [dative case], and affix C is not marked as realizing any morphosyntactic features-but crucially, it is ordered after affixes A and B. In this situation, there is no need for any rule of referral. An analysis using a default will always be possible where only a single feature is involved, and often in other situations. Another situation in which rules of referral are not necessary, is where the features realized by an affix constitute a natural class. For example, suppose a verb paradigm generally distinguishes singular and plural subject, as well as person of the subject, except that the second person singular and plural are represented by a single affix. While the other affixes mark feature values for both number and person, the second person affix can be seen as marking the natural class of second person. On the other hand, if a single affix marks, say, second person singular and third person plural, there is probably no natural class which captures these two categories. If these categories do not constitute an elsewhere case, then they would be candidates for a referral rule. Another situation in which a referral rule would be appropriate arises in an agglutinating language, where an entire syntagmatic series of affixes are the same for two positions in the paradigm. Stump (1993a) gives an example from Macedonian (see his table 2, page 452). Besides their ordinary use in capturing true cases of syncretism, rules of referral are also important in the context of stealth-to-wealth morphology. Specifically, the linguist can quickly capture syncretisms in a paradigm using rules of referral, and later decide whether there might be a more elegant way of capturing a syncretism using appropriate features, disjunctive ordering, and elsewhere cases. In the context of Stealth-to-wealth morphology, one way to initially assign a value to the Input and Output fields (defined below) of a Rule of Referral would be to select one or more cells in a paradigm as the Input, and one cell as the Output. The system could automatically remove any feature values from the output which were unchanged from the input, thereby simplifying the Output field. Later, the user could collapse several Rules of Referral which produced similar Outputs. For example, suppose a language has three genders, and that for each gender the accusative plural is syncretic with the corresponding nominative plural. Then as a first cut, the linguist might have three Rules of Referral, one for each gender. But these rules could be collapsed by removing the gender features from the inputs. Stump (1993a) discusses two kinds of rules of referral: 'broad rules', which say that one cell of a paradigm is realized in the same way as another cell; and 'narrow rules', which say that one rule (affix) is used in place of another. The difference is clearest in agglutinative systems (as opposed to so-called 'inflecting' languages, like Latin): under the narrow construal of rules of referral, it is possible for just one affix out of the sequence of affixes of a given word to be realized by a rule of referral. Under the broad construal, this cannot happen (or at least it cannot be said in quite those simple terms). Despite the limitations, I have defined rules of referral in this implementation to the 'broad' category. The reason is that 'narrow' rules of referral presuppose a more complicated sort of morphological rule system than what I am proposing here. Some of the effect of 'narrow' rules of referral could be obtained by allowing disjunction in the morphosyntactic feature specifications of Inflectional rules, which might be a simpler way to do it (and perhaps clearer for the user). In the theory of Distributed Morphology (see e.g. Halle and Marantz 1993; Noyer 1992, 1998; see also the discussion of the latter paper in Carstairs-McCarthy 1998a), rules of referral are replaced by rules of 'impoverishment', which (roughly speaking) delete morphosyntactic features from a word to be generated, rather than change them. I have not included rules of impoverishment in this model, on the assumption that working with such rules is probably too complex for most of our users, and that Distributed Morphology is a narrowly followed theory. (I'm sure its proponents wouldn't agree with me on that!)
Morph | Association from Package Ling
MorphBundles | Association from Package Ling
Morphemes | Association from Package Ling | refers to a collection seq of MoMorphoSyntaxAnalysis objects, the co-occurrence of which is ungrammatical. Usually, there will be exactly two such morphemes. If there are three or more morphemes, the intended meaning is that a word is ungrammatical in which all such morphemes appear (but the co-occurrence of only some of the morphemes is not prohibited). Having only one morpheme in this attribute should be flagged as a Warning, since such a restriction can do nothing. Note: we are assuming here that the user interface cannot simply prohibit constraints with a single morpheme, because they arise in the process of creating a constraint. (You cannot count to two until you've counted to one.)
MorphologicalData | Association from Package LangProj
Morphological Derivation | Class Diagram
Morphological Glossing | Class Diagram
Morphology | Class Diagram
Morphology Affixes | Class Diagram
MorphologyOld | Class Diagram
MorphoPhonology | Class Diagram
MorphoSyntaxAnalyses | Association from Package Ling
MorphoSyntaxAnalysis | Association from Package Ling
MorphType | Association from Package Ling | refers to an MoMorphType which is an item on a possibilities list. Possibilities include at least: prefix, suffix, infix, circumfix, root, bound root, and probably proclitic and enclitic. Note that most of these are appropriate for one or the other subclass, but since there is only one possibilities list, the types must be limited by procedural code. Other kinds of affixation (circumfixes, simulfixes, suprafixes etc.) are probably beyond the capabilities of Item-and-Arrangement morphology, and may therefore need to be prevented from appearing (or grayed out) with the class MoAffixAllomorph. Additional Notes: It is of course possible to analyze reduplication as the attachment of a prosodic constituent, such as a syllable (see McCarthy and Prince 1990), provided there is some way of filling the melodic information into that skeleton. But the system described here does not provide a way of automatically copying such melodic information, so reduplication cannot be treated in that way at present. (And in many cases, reduplication under prosodic morphology requires the base to be parsed into two constituents, so that affixation still involves more than specifying the prosodic form of the affix.)
MorphTypes | Association from Package Ling
MoRuleMapping | Class from Package Ling | An abstract class for the various sorts of things that a processual affix can 'do' to its input, such as copying all or part of the input, adding phonetic material, or modifying part of the input. (Deleting part of the input is done by not mentioning in the output the PhContextOrVar corresponding to that portion of the Input.) No attributes are defined here. All subclasses implement a Content attribute, but not necessarily in the same way.
MoStemAllomorph | Class from Package Ling | This represents the allomorph of a root. A polymorphemic stem may however be represented here under some stealth-to-wealth situations (see discussion of MoMorphoSyntaxAnalysis.Components). There are issues here with the interaction between Item-and-Process morphology and the use of root allomorphs. Namely, what is the root chosen on the basis of, if affixes are added processually (that is, as morphological rules which modify the form of the base)? One algorithm would be to try all the allomorphs of the root, attach whatever affixes are to be attached, and see if the output form of the root remains unchanged (meaning that the form of the root originally chosen was "right"). However, that encounters problems in that it is not possible in general to discriminate the root in the surface form of a word to which processual affixes have been attached; there may be no clear boundary between root and affix. It may therefore be the case that the use of this class to account for allomorphy (i.e. having more than one root allomorph for a given root lexeme) should be restricted to Item-and-Arrangement morphology, where an algorithm like that used in STAMP would work. However, this has severe implications for stealth-to-wealth work, in that adding a single Item-and-Process affix would mean that any use of this MoStemAllomorph class would break (at least if the affix and the root allomorphs were morphosyntactically compatible).
MoStemMsa | Class from Package Ling | This class is for stems or roots. It is also used in MoBinaryCompoundRules to specify the morphosyntactic properties required of the daughters, and by MoExocentricCompound to specify the morphosyntactic properties of its output.
MoStemName | Class from Package Ling | This represents one of the various inflectional stems used in a paradigm, other than the default stem. The assumption is that the stems with this stem name cannot be derived by a reasonable phonological rule (or at least that such a rule has not been written yet), and that the stem cannot be treated as an allomorph whose appearance is predictable by its phonological environment. Part of the stealth-to-wealth process consists of replacing such stems where possible with phonologically predictable allomorphs that do not have a particular stem name Additional Notes about PARADIGMS:&br This describes the various classes in the Morphology model that have to do with paradigms. The term'paradigm&apos here refers to the linguistic concept, not a sort of application for working with N-dimensional tables. (Bruce Waters has worked on the latter, and certainly table handling functionality will be necessary to work with linguistic paradigms.) The assumption here is that for some languages, paradigms will be a useful way of exploring the morphology. There is no class called /'Paradigm\'. Paradigms are instead treated as a sort of virtual attribute (see MoStemMsa.vParadigm). This is not intended to be a theoretical stand; some theories of morphology assign a fundamental status to paradigms (Carstairs 1987, Stump 1993a, 1993b), while others do not (Lieber 1992, Halle and Marantz 1993). The conceptual model defined in this document is intended to be compatible with both views.
MoStratum | Class from Package Ling | Strata are a concept borrowed from the theory of Lexical Phonology (see e.g. Kaisse and Shaw 1985); the term " level" is sometimes used synonymously. A given affix belongs to a single stratum; typically, a given phonological rule applies in a single stratum as well, but it is possible for a phonological rule to apply in a contiguous sequence of strata. The assumption that there can be a contiguous sequence of strata of course presupposes that the strata are arranged in a fixed linear order. Most versions of Lexical Phonology indeed made this assumption, but it was abandoned in some later versions (e.g. Inkelas and Orgun 1998). Inasmuch as phonological rules have not been defined yet for purposes of this application, the use of strata may seem superfluous. However, strata still may be useful for languages in which some derivational affixes appear outside of some inflectional affixes. That is, there would be a 'deeper' stratum for the inner inflectional affixes, and a shallower stratum for the derivational affixes in question, as well as for the outer inflectional affixes. The conceptual model makes no attempt to build in any universal or common properties of strata, or of their ordering. For example, it has been observed that for a number of languages, all derivational rules seem to precede all compounding rules (Scalise 1986: 115-122). This observation is not built in to the model, although it would be possible to ship a " starter" setup having this behavior.
MoStratumApp | Class from Package Ling | This represents the application of a single stratum (rule block) to a stem, including affixation and/or phonological rules.
MoUnclassifiedAffixMsa | Class from Package Ling
Msa | Association from Package Ling
MsEnvFeatures | Association from Package Ling | owns an FsFeatStruc, defining the morphosyntactic features which the stem to which this affix attaches must bear. See discussion of the MsEnvPartOfSpeech attribute above.
MsEnvPartOfSpeech | Association from Package Ling | refers to a PartOfSpeech, defining the morphosyntactic features which the stem to which this affix attaches must bear. Together with the MsEnvFeatures attribute (below), this attribute defines the morphosyntactic context in which this allomorph must appear. However, there are linguistic reasons for thinking that allomorphs should not in fact be able to specify morphosyntactic requirements on their environment. That is, there are often (always?) better analyses of allomorphy which do not rely on the morphosyntactic properties of the stem (see e.g. Matthews' 1972b reanalysis of Huave). The attribute is there because AMPLE provides that power (although AMPLE allows the user to test the morphosyntactic properties of arbitrary morphemes to the left or right, while the intention here is that an allomorph can only test the morphosyntactic properties of the stem to which it attaches). Since the parts of speech are contained in an inheritance hierarchy, a question arises: if this attr points to an abstract part of speech (verb, say), does a stem with a more specific part of speech (transitive verb, say) match? In the absence of any reason to think it does not, I would suggest that reference to an abstract part of speech entails that more specific parts of speech are included. Otherwise, it is hard to imagine how one could use this attribute-it would be necessary to allow a seq, or else to have separate but homophonous allomorphs for each specific part of speech. It is not clear what should be done if there are conflicts between the morphosyntactic requirements imposed by this attribute, and those imposed by the affix owning this allomorph. Such conflicts "should" not arise (since allomorphs shouldn't have special morphosyntactic requirements of their own, as argued in the previous paragraph). While it would be fairly simple to ensure that conflicts do not arise between stated morphosyntactic properties, there is the potential for implicit conflicts (e.g. the affix calls for attachment to a noun, while the allomorph requires that the stem have a certain feature value for subject agreement-something which nouns presumably do not mark).
MsFeatures | Association from Package Ling | gives any morphosyntactic features belonging to the stem in addition to those specified by PartOfSpeech.InherentFeatureValues. In most cases, there will be none, but this attribute may be useful for exceptional words (such as the pluralia tantum words pants and scissors, which are grammatically plural even though the default for English nouns is singular). The features are restricted to those in vAllPossibleFeatures of my PartOfSpeech.
MsFeatures | Association from Package Ling | WfiAnalysis parallels MorphoSyntacticItem in the lexical database. Allowing MSFeatures here allows the user to easily convert a wordform to a subentry. This also supports S2W in that a user may know the features that a wordform bears but not its component parts (e.g may know that it's plural without knowing what the plural morpheme is). Additionally, in the case of suppletion, there may not be a morpheme to identify.
MsFeatures | Association from Package Ling | owns an FsFeatStruc, giving the morphosyntactic features which result from percolation. N.B.: This does not include inflectional features which are to be realized by inflectional affixes (and which may be incompatible with the current part of speech, or contradict percolated features).
MsFeatureSystem | Association from Package LangProj
Multi | Attribute from Class CmAnnotationDefn | Indicates whether this annotation type needs "multi" capabilities. Also need to indicate which encodings to offer the user. Vernacular, Analysis, etc.
multiBigString | DataType from Package Data types
multiBigUnicode | DataType from Package Data types
multiString | DataType from Package Data types
multiUnicode | DataType from Package Data types
N
Name | Attribute from Class PhSegmentRule | A name to help the user identify the rule in a list of phonological rules.
Name | Attribute from Class CmResource | Internal name for the resource (the application is responsible for defining the resource and the interface to the resource).
Name | Attribute from Class ScrImportSet | Display name for this instance of import settings. May be null if settings are not part of a list of settings displayed to the user.
Name | Attribute from Class LexReference | This allows the user to add a name to the set.
Name | Attribute from Class PhNaturalClass
Name | Attribute from Class MoInflClass | A multiUnicode string, e.g. "3rd. declension" or "?er verbs".
Name | Attribute from Class MoInflAffixSlot | See discussion in class documentation.
Name | Attribute from Class PhPhonContext
Name | Attribute from Class WfiWordSet
Name | Attribute from Class MoCompoundRule | Short label for the compound rule.
Name | Attribute from Class MoStemName | multiUnicode string; a convenient name, such as &apos 3-stem&apos (in Latin, cf. Aronoff 1992)
Name | Attribute from Class MoStratum | Not used in any algorithms, but people like to name things...
Name | Attribute from Class PhTerminalUnit | a string, often a single character or a single base character plus some diacritics.
Name | Attribute from Class PhEnvironment
Name | Attribute from Class MoInflAffixTemplate
Name | Attribute from Class MoReferralRule | a multiUnicode string. Not used in any algorithms, but people like to name things. Maybe we want an abbreviation (for displays), too?
Name | Attribute from Class FsSymFeatVal
Name | Attribute from Class PhPhonemeSet
Name | Attribute from Class FsFeatDefn
Name | Attribute from Class FsFeatStrucType
Name | Attribute from Class ScrBook | The full book name for the Scripture Book. Initialized from ScrBookRef.BookName. For books that belong to Scripture.ScriptureBooks, this name should be in synch. with ScrBookRef.BookName. After books are moved to ScrDraft.Books, they retain the Name that they had at the time that they were archived. This allows the historic metadata to be persisted. Otherwise the metadata in an archived book would change as ScrBookRef changes.
Name | Attribute from Class CmPossibility
Name | Attribute from Class CmAgent | Arbitrary name of the agent. Examples: Larry, AMPLE, XEROXParser, HermitCrab.
Name | Attribute from Class CmMajorObject
Name | Attribute from Class StStyle
Name | Attribute from Class CmOverlay
Name | Attribute from Class UserView
Name | Attribute from Class CmFolder
Name | Attribute from Class CmFilter
Name | Attribute from Class MoGlossItem
Name | Attribute from Class MoAdhocProhibGr
Name | Attribute from Class Publication
Name | Attribute from Class PubPageLayout
Name | Attribute from Class PubHFSet
Name | Attribute from Class CmFile
NaturalClasses | Association from Package Ling | Change this here.
Next | Association from Package Cellar
NonDefaultStems | Operation from Class MoStemMsa | virtual attribute, returning a seq of "nondefault" stems: selectIf({ |A| exists of StemName of ^A}) of my vAllomorphs -in other words, the allomorphs of this stem which have a stem name. For instance, in Spanish there might be an inflection class for verbs that conjugate like tener. The irregular allomorphs of the stems (tien-, teng-, tendr-, tuv-) would be stored in the LexEntries as MoStemAllomorphs having the appropriate StemNames, while the "basic" stem ten- would be stored as an allomorph without a stem name. Normally, only irregular inflected stems will be stored, while regular stems can be derived by rule (see MoStemName). But there is nothing to prevent the user from storing regular stems, and under the S2W concept, it is quite likely the user will in fact store many regular stems before realizing that they are regular. Accordingly, the program will have a way to check whether stored stems are identical to the stems that would be derived by rule, in which case the irregular stem can be 'un-stored' at the user's discretion. N.B.: For any MoStemName that does not appear among the vNondefaultStems, it is assumed that the appropriate stem can be deduced on the basis of the algorithm given in Choosing a Stem.
Note | Class from Package Cellar | Used for all manner of notes.
Notebk | Package from Package Component View
NoteCategories | Association | List of categories that identify the types of issues that a ScrScriptureNote might deal with. Changed from ScriptureNoteCategories.
NoteMappings | Association | The mappings (from delimited external data to internal data structure) that apply to the annotations sources in this group of settings. Markers in the various annotation sources must be compatible within an instance of ScrImportSettings so one collection of mappings is used for all note sources.
Notes | Association
Notes | Association | Scripture notes for this book of Scripture. These annotations include consultant notes, translator notes and also "error" annotations generated by checking tools.
Notes | Association from Package Cellar
Notes | Attribute from Class ConstChartRow
NoteSources | Association | Sources for annotations. Different sources are useful to group different kinds of annotations and/or different originators.
NoteType | Association from Package Cellar
NoteType | Association from Package Cellar
num | TagDefinition from Package UML Standard Profile
num | TagDefinition from Package UML Standard Profile | 24
num | TagDefinition from Package UML Standard Profile | 139
num1 | TagDefinition from Package UML Standard Profile
num2 | TagDefinition from Package UML Standard Profile
num3 | TagDefinition from Package UML Standard Profile
NumColumns | Attribute from Class PubDivision | Default number of columns of text for the page layout. This is an overall layout parameter and only applies to sections or paragraphs that permit multi-column layout. E.g. a Title can be set to always lay out in a single column, regardless of this setting.
numeric | DataType from Package Data types
O
ObjRefs | Association from Package Cellar | For Scripture, by convention this refers to ScrRef objects (a subclass of CmObject). In other texts we might possibly have a use for referring to other targets--for example, ChoicesListItems like OCM codes, if we decided to go down to the paragraph level but didn't want to go all the way to tagging phrases. This could also foreseeably be used for referencing schemes for vernacular text (apart from a Scripture referencing system). It also avoids the philosophical problem of having a property unique to Scripture on a very general-purpose object.
Occurrences | Association from Package Ling | List of references where this checking item needs to be checked. E.g., a list of scripture references where a specific sense of a key term needs to be checked.
OcmCodes | Attribute from Class CmSemanticDomain | Example: (Ron Moe's Standard Format): \hr 761 Life and Death Multiple OCM references map to one Unicode string with semicolons as delimiters. Some users may not have an OCM code in their database due to royalties, so we can't make actual links to a list.
OcmRefs | Association | For those that do have an OCM list, we will set links to the appropriate items. We anticipate our program establishing these links when the OCM list is added to the database.
Optional | Attribute from Class MoInflAffixSlot | Optional: Boolean, default False. A value of true indicates that this slot is optional and therefore does not have to appear. This is not intended for slots which have what might be called a zero morpheme-see the discussion of the 'Affixes' attribute immediately above. Rather, this attribute is intended for the situation in which a language optionally marks some feature-value combinations. For example, in Tzeltal the plurality of a noun is only optionally marked: a suffix indicates that the noun is plural, but the absence of a plural suffix does not mean the noun is necessarily singular. For this situation, an optional slot containing the plural morpheme would be appropriate. Implementation Note: In the Tzeltal case discussed above, it would probably be inappropriate for the parser to say that a noun without an overt plural suffix was ambiguous between a singular reading and a plural one. Rather, it should unambiguously parse as unmarked for plurality.
OriginalPath | Attribute from Class CmFile
OtherObjects | Association from Package Cellar
Output | Association from Package Ling | Owns an ordered seq of MoRuleMapping, describing the form output by attachment of this affix. Typically this consists of a copy of the Input plus some constant for the affix, but reduplication, infixation, simulfixes and suprafixes will be more complex. The left-to-right order of the MoRuleMapping objects in this attribute corresponds to the order of the pieces of the output word which will be constructed by the rule.
Output | Association from Package Ling | Constitutes the morphosyntactic feature values which the Rule of Referral outputs. Additional notes: In Stump's (1993a, (11) page 457) format for a Rule of Referral, this corresponds to [F1:v1...Fm:Vm]. Note that the input and output fields may refer to the same features, albeit with different values. This is particularly likely for non-binary features (see Stump's rules (20) and (28), for example), but may also be necessary with binary features (e.g. Stump's rule (54b)). Accordingly, it would be possible to split the input features into a set of features whose values will be changed in the output, and a set of features which effectively form the environment for the change. This could even be done in the 'view' of the rule.
OutputForm | Attribute from Class MoDerivTrace | owns a string in the encoding of this level, representing the form resulting from attaching an affix, applying an inflectional affix slot, or applying a phonological rule. However, this attr is overridden, and defined as a virtual attr, in the classes MoStratumApp and MoAffixTemplateApp. The parallel attr for output morphosyntactic properties is defined in the subclasses, because some of those subclasses change the morphosyntactic properties of the word (derivational affixes), some do not (inflectional affixes and templates, and phonological rules), while for strata application, the output MSA is the output MSA of the last trace object it owns.
OutputForm | Operation from Class MoInflTemplateApp | a virtual attr returning a string, representing the form which is the output of this template application. Defined as OutputForm of last over my slotApps Overrides the OutputForm attr of the superclass.
OutputForm | Operation from Class MoStratumApp | a virtual attr returning a multiUnicode string, representing the form which is the output of this stratum. Overrides the OutputForm attr of the superclass. On the assumption that within a stratum, there is a strict order of [compounding rules, derivational affixes, inflectional affixes, (non-cyclic) phonological rules], this could be defined as: first over [OutputForm of first over [my PRuleApps, my TemplateApp, my DerivationalAffixApps, my CompoundRuleApps], my vInputForm] The last case (where the output form is identical to the input form) reflects the situation where no changes were made to the form in this stratum.
OutputMsa | Association from Package Ling | owns an MoDerivationalStepMsa, giving the morphosyntactic information resulting from attaching the derivational affix.
OutputMsa | Operation from Class MoStratumApp | a virtual attr returning an MoDerivationalStepMsa. May be defined as first over [OutputMsa of last over my DerivationalAffixApps, OutputMsa of last over my CompoundRuleApps, my vInputForm] The last case (where the output MSA is identical to the input MSA) reflects the situation where no derivational affixes were attached in this stratum, and no compounding rules applied. Note that inflectional affixes and phonological rules do not affect the MSA.
OutsideAlignedText | Attribute from Class PubHeader | The contents of the portion of the header that is aligned with the outside margin.
Overlays | Association from Package LangProj
OverridingMsa | Association from Package Ling | Any attribute specified in this msa will override the corresponding attribute of the head msa of the compound.
P
PageHeight | Attribute from Class Publication | The height of the trimmed page in the final publication, in millipoints. This includes the top and bottom margins and the printable height of the text area. 0(default) — indicating the equal to the paper size positive value — indicating a specific size page size to lay out on the paper
PageLayout | Association from Package Cellar | The page layout parameters for this division specifying page size, margins, header and footer positions, etc.
PageWidth | Attribute from Class Publication | The width of the trimmed page in the final publication, in millipoints. This includes the inside and outside margins and the printable width of the text area but it does not include the gutter margin. 0(default) — indicating the equal to the paper size positive value — indicating a specific size page size to lay out on the paper
PaperHeight | Attribute from Class Publication | The physical height of the sheet of paper to be printed, in millipoints. This, together with the PaperWidth property, determines the paper size that is requested from a printer. 0(default) — indicating the default paper size for the printer positive value — indicating a specific size requested from the printer
PaperWidth | Attribute from Class Publication | The physical width of the sheet of paper to be printed, in millipoints. This, together with the PaperHeight property, determines the paper size that is requested from a printer. 0(default) — indicating the default paper size for the printer positive value — indicating a specific size requested from the printer
Paragraphs | Association from Package Cellar
Paragraphs | Association from Package Cellar
parameter | Stereotype from Package UML Standard Profile | Specifies that the relationship represents a procedure parameter rather than AssociationEnd an actual association.
parameter | Stereotype from Package UML Standard Profile | Parameter is a constraint applied to a link-end, specifying that the corresponding instance is visible because it is in a parameter scope relative to the link.
ParatextID | Attribute from Class ScrImportP6Project | The Paratext ID number for the Paratext project.
ParselsCurrent | Attribute from Class StTxtPara | This would be set true whenever the paragraph is parsed (tokenized), and false whenever it is edited (changes to StTxtPara.Contents or StText.Paragraphs). This allows us to re-parse only the texts that need it, now that the parser always makes real, persistent annotations.
ParserParameters Attribute from Class MoMorphData We need a place to put "maximum parses" and other related parameters. Note: The following parameters could easily need to be controlled by the user (and are already set as parameters in the XSLT that creates the AD.CTL file): prmMaxNull - maximum number of nulls

prmMaxPrefixes - maximum number of prefixes (default is 5)

prmMaxSuffixes - maximum number of suffixes (default is 255)

prmMaxInfixes - maximum number of infixes (default is 0 unless there are infixes in which case it is 1)

prmMaxRoots - maximum number of roots that can compound (default is 2 if there are compound rules; otherwise it is 1)

[There is one other parameter for max number of properties, but we should be able to calculate that number based on the data - I'll fix this.]

Participants | Association from Package Notebk | A list of roles involved in the event and the participants who fill those roles. The user can specify participants directly in which case their role is assigned as unspecified.
Participants | Association from Package Notebk | A list of people (or one person) involved in the event in the role specified below.
PartOfSpeech | Association from Package Ling
PartOfSpeech | Association from Package Ling
PartOfSpeech | Association from Package Ling | refers to a PartOfSpeech, telling the category of the word.
PartOfSpeech | Association from Package Ling
PartOfSpeech | Association from Package Ling | Most users will be more familiar with the notion of PartOfSpeech or morphosyntactic category than the notion of the object MorphoSyntacticInformation. This attribute, PartOfSpeech, stores the reference to the PartOfSpeech.
PartOfSpeech | Class from Package Ling | This class represents an expansion of the LinguaLinks authority list of parts of speech. The attributes given below represent only those attributes which are more or less relevant to the morphology, e.g. there is nothing here (yet) about phrase structure rules that the category might head or be made of (the latter in the case of compounding, if at least some compounds are to be treated syntactically). Nor is there any discussion here about phrasal categories, i.e. I discuss only X0 categories.The categories are arranged in an inheritance hierarchy, using the provision for hierarchies built in to the superclass of this class, CmPossibility. Thus, the categories of transitive and intransitive verbs could be subcategories of the category verb, etc. This brings up an interesting question with respect to phrasal categories, where the subcategories do not head distinct kinds of phrasal categories. (That is, languages do not treat VPs headed by transitive verbs differently from VPs headed by intransitive verbs.) I will not discuss this issue yet.The owner of the root of the part of speech hierarchy needs to implement a few of these attributes as virtual attributes returning none in order to stop the recursion, e.g. vAllInherentFeatureValues and vAllAffixSlots.Under some theories (cf. Chomsky 1970), the use of an atomic category is superfluous, given that atomic categories are treated as abbreviations for sets of morphosyntactic feature values. Even if we were to follow this approach, though, it seems likely that atomic categories would be useful in the context of the stealth-to-wealth approach.Note that attributes for name (cpName), abbreviation (cpAbbreviation), and subcategories (cpSubPossibilities) are inherited from the superclass CmPossibility, and are therefore not described here.
PartOfSpeech | Class Diagram
PartsOfSpeech | Association from Package Ling
PartsOfSpeech | Association from Package LangProj
People | Association from Package LangProj
PersonalNotes | Association from Package Notebk | Notes of a personal, perhaps non-publishable nature. You know ... personal frustrations, swear words and the like that you want to hide when your administrator checks your work.
PhBdryMarker | Class from Package Ling | This represents a boundary marker, e.g. a morpheme boundary or a word boundary.There is no requirement that the user define any boundary markers.
PhCode | Class from Package Ling | a representation of the phoneme or boundary marker in a particular encoding. eg. in English, the phoneme /f/ has the Codes: ph, f and gh.
PhContextOrVar | Class from Package Ling | Under Cellar1, this would be an OrSignature. Since Cellar2 lacks OrSignatures, this is instead a superclass for phonetic contexts and variables. (Morphological rules of the type advocated e.g. by Aronoff (1976) require both, in order to match both a specific part of a stem and the remainder of the stem; phonological rules of the SPE type only require phonetic contexts.)
PhEnvironment | Class from Package Ling | This represents a pairing of left and right contexts for an allomorph or a phonological rule. Any given allomorph or rule can have a sequence of such pairings, although in general the goal of the analysis will be to reduce the number of pairs to one.PhEnvironment objects are owned in the PhPhonologicalData object., and referred to by the PhoneEnv attr of MoForms (allomorphs) and by the (to-be-designed) phonological rules.
PhFeatureConstraint | Class from Package Ling | This class appears here for purposes of future development; it is not intended to be implemented immediately. It will serve for constraints requiring agreement or disagreement with respect to a single feature or a set of features all dominated by a single nonterminal node (e.g. the set of features under a 'place' node), and for rules of assimilation and dissimilation. It resembles the use of alpha variables in SPE, and the use of linking conventions in autosegmental phonology.In the SPE convention, the features within a given rule which are meant to agree or disagree are labeled consecutively with Greek letters (with the letters being preceded by a minus sign for disagreement). This requires some mechanism in the rule itself for labeling constraints; the labels would appear as part of the PhFeatureConstraints, but would not actually represent an attribute of the constraints. In autosegmental phonology, (positive) PhFeatureConstraints within a rule are joined by a line (and must obey certain adjacency constraints). Negative constraints as such do not exist in autosegmental phonology; dissimilation is instead seen as the result of unlinking, followed by the insertion of a default feature value.This class may be more generally useful, e.g. for person/number agreement in syntax. In that case, this class should probably be defined in the Feature System model, rather than here.
PhFeatureSystem | Association from Package Cellar | This feature system contains the phonological features used by phonological rules. They are kept separate from the morpho-syntactic features in the MsFeatureSystem attribute.
PhIterationContext | Class from Package Ling | A PhIterationContext represents a context that can be iterated, that is, which can appear adjacent from M to N times. This encompasses Kleene star (0 to infinite number of times) and the '+' notation commonly used in Unix regular expressions (1 to infinite number of times), as well as the sorts of 'between one and three' contexts commonly used in SPE to refer to consonant clusters.More modern theories of phonology dispense with iteration contexts in favor of syllable structure, feet, etc.
PhMetathesisRule | Class from Package Ling | A metathesis rule is a (transformational) phonological rule that allows the reordering of segments. (See Kenstowicz and Kisseberth 1979:269ff.)
PhNaturalClass | Class from Package Ling | An abstract class for the various kinds of natural classes. Note that the subclasses have several attrs in common (e.g. stratum), but that these attrs are defined differently in the various subclasses.Attributes: In addition to the attr given here, all subclasses define a segments attr, either as a ref or a virtual attr, depending on whether the subclass is defined intensionally or extensionally. If this class was generalized beyond phonology, the attr's name should be generalized, e.g. to members.
PhNCFeatures | Class from Package Ling | A natural class picked out by a (small) number of feature values (an intensional definition). In classical generative phonology (e.g. SPE = Chomsky and Halle 1968), this was the only way to define a natural class.If this class is generalized beyond phonology, an appropriate name might be NCIntensional.
PhNCSegments | Class from Package Ling | A natural class picked out by specifying the segments which are members (i.e. an extensional definition). This was not an option in classical generative phonology (e.g. SPE = Chomsky and Halle 1968), and opens the possibility of abuse, i.e. setting up unnatural natural classes. It is included here to support the stealth-to-wealth process by letting the user set up a preliminary natural class based on intuitions. There should therefore be a method to help the user change an object of this class to the class PhNCFeatures.If this class is generalized beyond phonology, an appropriate name might be NCExtensional.
PhoneEnv | Association from Package Ling | refers to a collection of PhEnvironment objects, describing what the phonetic environment of this allomorph is. The reason this is a collection attr (rather than atomic) is to allow for the situation during analysis before the user has managed to collapse what appear to be disparate environments into a single environment. (Note that the 'elsewhere' case can be represented by an empty environment under the assumption of disjunctive ordering.) Hence, a step in the stealth-to-wealth process will be to reduce the cardinality of this collection to one. A collection may of course also be useful for allomorphs which actually does appear in a disparate set of environments. For discussion of why this is a ref attribute, rather than an owning attribute, see MoMorphologicalData.PhoneEnvs. If this attribute is uninstantiated, there is no phonetic restriction on the environment.
PhoneEnv | Association from Package Ling | refers to a collection of PhEnvironment objects, describing what the phonetic environment of this allomorph is. The use of the term 'phonetic' is not intended to distinguish this from a phonological context, merely to say that the context is described in terms of its phonetic properties, not its morphosyntactic properties or lexically marked exception properties. If this attribute is uninstantiated, there is no phonetic restriction on the environment. The reason this is a collection attr (rather than atomic) is to allow for the situation during analysis before the user has managed to collapse what appear to be disparate environments into a single environment. (Note that the 'elsewhere' case can be represented by an empty environment under the assumption of disjunctive ordering.) Hence, a step in the stealth-to-wealth process will be to reduce the cardinality of this collection to one. A collection may of course also be useful for allomorphs which actually does appear in a disparate set of environments. For the reason why this is a ref attribute, rather than an owning attribute, see the discussion of MoMorphologicalData.PhoneEnvs. An important assumption here is that the phonetic environment to which this allomorph refers is the derived phonological environment. In the absence of phonological rules, this means that the phonetic environment refers to the allomorph(s) to its left, not to some base form of the morphemes. (If we later implement phonological rules, this implies we implement cyclic phonological processes.) The effect of iterative application of phonological rules would not be possible under this approach, although most cases might fall out from the step-wise attachment of affixes, which more or less amounts to cyclic rule application (without rules). Alternatively, we could allow reference to either (or both) the underlying and derived environments (which would in turn imply that every morpheme would need to have an underlying form); this would be similar to two-level phonology.
Phonemes | Association from Package Ling | collection seq of PhPhoneme.
Phonemes | Association from Package Ling | refers to a PhPhonemeSet which provides the phonemes and boundary markers relevant to this stratum. In Hermit Crab, there were two attributes similar to this on strata: an InputLevelOfRepresentation, and an OutputLevelOfRepresentation. It was not clear that this bought anything that having different levels of representation in successive strata would not have bought.
PhonemeSets | Association from Package Ling | owns a collection of PhPhonemeSets, describing the phonemic inventory of the language. The reason for allowing this to be a collection (rather than atomic) is to allow for phonological descriptions at multiple levels (strata),
PhonologicalData | Association from Package LangProj
PhonologicalRules | Operation from Class MoStratum | a virtual attribute, returning the seq of Phonological Rules which operate in this stratum. (The class definitions for Phonological Rules have not been written yet.) Unlike affixes, a phonological rule can belong to more than one stratum. However, the usual assumption in lexical phonology was that the strata to which a phonological rule belonged had to be contiguous. Thus, a rule will specify the first and last stratum to which the rule belongs (the order of the strata being inferable from MoMorphologicalData.Strata).
PhonologyNote | Attribute from Class LexSense
PhonRuleFeats | Association from Package Cellar | The rule features are a way to limit the application of rules, either by excluding or requiring these "features." The CmPossibilityList contains zero or more PhPhonRuleFeat classes. These refer to a CmObject, where that CmObject would probably be a MoInflClass (e.g. a conjugation class), an FsSymFeatVal (e.g. feminine gender), or a CmPossibility (for an exception "feature").
PhonRules | Association from Package Ling | These are the ordered sequence of phonological rules. They are given in the order in which they are to be applied.
PhPhonContext | Class from Package Ling | An abstract superclass of various kinds of contexts, which together encode regular expressions over an alphabet of PhNaturalClasses, strings, phonemes, and boundary markers (used in e.g. the LeftPhoneEnv and RightPhoneEnv attrs of PhEnvironment). Renamed from PhPhonologicalContext for the Firebird Port.
PhPhonData | Class from Package Ling | This is the ultimate owner of phonological data, parallel to the MoMorphologicalData object in the Morphology model. In particular, PhPhonemeSets, PhEnvironments, and PhNaturalClasses are owned here. The reason for the ownership of these objects residing here, rather than in the MoForm (allomorphs) or phonological rules where they are used, is to allow for their re-use. For example, a step in going from an allomorph-based description to a phonological rule-based description is to find all the allomorphs that have similar environments. This step is expedited if the environments are re-used (since they will be identical). Even if they are not identical, the fact that they all reside in one location makes them easier to search for similar environments. Renamed from PhPhonologicalData for the Firebird Port.
PhPhoneme | Class from Package Ling | This represents a single phoneme. The exact meaning of the term 'phoneme' (e.g. whether biuniqueness is assumed) is not under focus here. For the purposes of this document, it is sufficient to treat units of the encoding which have some linguistic reality as if they were phonemes. One implication is that two different spellings of the same phoneme (e.g. Spanish 'c' and 'qu' for the phoneme /k/) correspond to one phoneme.It is likely that some attributes (such as a featural decomposition) will be added later, as needed for phonology applications. The back-references from the PhNaturalClasses are also likely to be important.
PhPhonemeSet | Class from Package Ling | This holds a set of phonemes and boundary markers which belong to a certain " level." The reason for having a special object to hold such a set, rather than storing the phonemes individually in an attr of the class MoStratum, is that several strata may use the same set of phonemes.
PhPhonRuleFeat | Class from Package Ling | A phonological rule feature requirement, such as conjugation class membership, exception feature (aka productivity restriction) or gender. It limits the application of a phonological rule. See PhSegRuleRHS.
PhraseTags | Association from Package Notebk | The Tags attribute is used for explicit tagging by the end-user, where he indicates that a given tag applies to the entire record. The PhraseTags attribute by contrast is a behind-the-scenes tag. When the user tags a word or phrase within a description, the editing mechanism will add that tag to this attribute. The purpose is to provide a means for fast searching. The user can do a quick back-reference search to arrive at the appropriate records, and then do a text search to find the actual tagged phrase. In this manner we avoid having to do a sequential search through every record in the notebook.
PhRegularRule | Class from Package Ling | A regular rule is a phonological rule that inserts (epenthesizes) a segment (such as a vowel or consonant), fills in or changes some feature values, or else it deletes a segment (or possibly more than one segment). There is no provision for epenthesizing boundary markers.
PhSegmentRule | Class from Package Ling | A phonological rule. As currently designed, the rules resemble those of classical generative phonology, in that the input, output, and environments are defined in terms of phonetic features (not segments or autosegments). There is currently no concept of disjunctive rules, although that could be added. We support rule features (i.e. nonphonetic features, such as the feature [+Latinate] of SPE) and rules which are sensitive to the part of speech of the word to which they apply. A phonological rule may act as either an allophonic or morphophonemic rule in structuralist phonology would. We allow for (phonological) metathesis rules, also.
PhSegRuleRHS | Class from Package Ling | This class delineates the basic requirements for the application of a rule (the "right-hand-side" of the arrow in a traditional phonological rule).
PhSequenceContext | Class from Package Ling | A PhSequenceContext represents a sequence of other contexts (commonly represented by concatenation).
PhSimpleContext | Class from Package Ling | A PhSimpleContext represents the 'atoms' of phonetic regular expressions, analogous to terminal nodes in phrase structure rules. The subclasses define simple contexts in terms of natural classes (= sets of phonemes), phonemes, and boundary markers. It would also be possible to define a subclass for defining contexts in terms of strings, bypassing the need for translating strings into sequences of phonemes. As a linguist, I have avoided that, butAttributes:None defined here. All subclasses define a featureStructure attr, but they do so differently for each class.
PhSimpleContextBdry | Class from Package Ling
PhSimpleContextNC | Class from Package Ling | Used for natural classes (sets of phonemes).
PhSimpleContextSeg | Class from Package Ling | Used for segments (phonemes).
PhTerminalUnit | Class from Package Ling | assumption here is that there is a way to convert between the representation of the form of a WfiWordform as a string in some encoding, and a sequence of phonemes (and perhaps boundary markers). How straightforward this method is depends on the orthography, and on some basic decisions as to how linguistically true the translation into phonemes is intended to be. See the codes attr for some discussion.
PhVariable | Class from Package Ling | This represents a variable in morphological rules (see the input and output attrs of MoAffixProcess). A variable corresponds to '.*' in Unix-style regular expressions, i.e. a sequence of zero or more items (in this case, phonemes and/or boundary markers). They are usually shown by an uppercase letter, e.g. 'X'.Attributes:None.
PictureFile | Association from Package Cellar
Pictures | Association from Package Ling
Pictures | Association from Package LangProj
PlaceOfBirth | Association from Package Cellar
PlacesOfResidence | Association from Package Cellar
PlusConstr | Association from Package Ling | Refers to a collection seq of PhFeatureConstraint. The use of a plusConstraint only makes sense if there are two or more contexts in a rule that make use of the same constraint. If two such constraints occur in the environment of the rule (treating the input as part of the environment), then the feature referred to by the constraint is required to have the same value in every place where the word matches the pattern. For example, if a plusConstraint for the feature voiced appears on two adjacent consonant contexts in a rule, then the word being matched must have two adjacent consonants with identical voicing. If one of the constraints is in the environment and one in the output of the rule, then the effect is that of a rule of assimilation: in the form output by the rule, the phoneme affected by the rule will have the same value as the value on the phoneme matched by the environment.This attribute is not intended to be implemented immediately, but is included here for completeness (since it is apparently difficult to add new attributes once a COM interface has been defined).Note that although this attr is defined as a collection seq (not an ordered seq), the order is assumed to be stable. Otherwise the labels used in SPE-style rules would be subject to change. On the other hand, the use of a seq attr here may be overkill; from a linguistic standpoint, a single constraint (plus or minus) might be adequate. Renamed from PlusConstraints for the Firebird port.
port | Stereotype
PosFooter | Attribute from Class PubPageLayout | Position of top of footer from bottom of page
PosHeader | Attribute from Class PubPageLayout | Position of bottom of header from top of page.
Position | Association from Package Ling | refers to an ordered seq of PhEnvironment, encoding the position relative to the stem in which this allomorph goes (for example, before the stem, after the stem, or between the first two consonants of the stem). A default value for this attr should be provided for prefixes and suffixes, based on MoForm.MorphType. For a prefix, this would be __#X (where X represents the entire stem), and for a suffix, X#__. This attr need not be displayed for prefixes and suffixes. Note that it would not be possible to simplify the model by eliminating this attr, and letting the position of infixation be determined by the phonological environment of the allomorph(s). The reason this can't be done is that what is important for purposes of allomorphy vs. what is important for positioning the infix, are two different things. The reason for having this attr as a property of the allomorph, rather than of the MSA, is that this allows us to distinguish two different allomorphs which differ as to whether they are infixed or not. For example, there is a Tagalog affix whose infixed form is -in-, and whose prefixed form is ?in- (although the word-initial glottal happens not to be written orthographically). An alternative to having this attr on MoAffixAllomorph would be to add a subclass of this class for infixes (as well as suprafixes and other sorts of affixes that must appear in a particular position, other than before or after the stem). This new subclass would then have the extra attribute for position. One disadvantage of having such a subclass, is that it would be the only subclass of MoAffixAllomorph, whereas in fact all specific types of affixes (prefixes, suffixes, infixes,...) are sub-types. Having a default value of this attr for prefixes and suffixes adequately characterizes the difference between prefixes and suffixes on the one hand, and infixes on the other. The attr is a seq (as opposed to atomic) to account for affixes whose position relative to the stem is determined by the phonology of the stem. For example, in Tagalog the in affix occurs after the first consonant of a C-initial stem, or (prefixed) before a vowel-initial stem. (Note that this implies that an affix may not be purely a prefix or infix, contrary to the implication of the MorphType attr. The alternative is to require the user to treat such an affix as having two allomorphs, one a prefix and one an infix; but this would seem to be an unnecessary burden for the user.) The attr is an ordered seq (as opposed to a collection) in order to allow disjunctive ordering. Taking the example given above, disjunctive ordering would require the following environments, stored in an ordered seq: #C__, #__ Nondisjunctive ordering would require the following environments (which could be stored in a collection): #C__, #__V Using an ordered seq does not force the parser/ generator to use the ordering, but allows for parsers which do use the order (such as Hermit Crab).
Positions | Association from Package Cellar
Positions | Association from Package LangProj
Possibilities | Association from Package Cellar
PossItems | Association from Package Cellar | An Overlay can have a number of CmPossibilities associated with it for the purposes of tagging text. These CmPossibilities come from a particular CmPossibilityList (defined by PossList). For example, the user might have an overlay for OCM codes having to do with marriage and fishing. He might have another overlay with OCM codes that have to do with cooking.
PossList | Association from Package Cellar
PossList | Association from Package Cellar | The list that a CmOverlay gets its PossItems from.
postcondition | Stereotype from Package UML Standard Profile | Specifies a constraint that must be attached to an operation, and denotes that the conditions of the constraint must hold after the invocation of the operation.
Postfix | Attribute from Class MoMorphType | like pPrefix, but added after the fForm. Often a dash for prefixes and infixes, and perhaps proclitics.
powertype | Stereotype from Package UML Standard Profile | Specifies that the classifier is a metaclass whose instances are siblings marked by the same discriminator. For example, the metaclass TreeSpecies might be a power type for the subclasses of Tree that represent different species, such as AppleTree, BananaTree, and CherryTree.
precondition | Stereotype from Package UML Standard Profile | Specifies a constraint that must be attached to an operation, and denotes that the conditions of the constraint must hold for the invocation of the operation.
Predecessor | Operation from Class MoPhonolRuleApp | a virtual attr, returning the last MoDerivationTrace prior to this one within the current MoStratumApp, else (if this phonological rule is the first thing to apply in the current stratum) none.
Predecessor | Operation from Class MoInflTemplateApp | virtual attr returning the last MoDerivationalAffixApp of this stratum, if any; else none.
Predecessor | Operation from Class MoInflAffixSlotApp | virtual attr, returning the preceding MoInflAffixSlotApp (or none, if this is the first slot in the template).
Predecessor | Operation from Class MoDerivTrace | virtual attr returning another object of this class; defined differently in each subclass. The purpose of this attr is to be used in the definitions of the attrs vInputForm and vInputMsa. This will return nothing for the first stratum application in the derivation, for the first affix to attach in a given stratum, and for the first phonological rule to apply in a stratum in which no affixes have attached. (For each of these cases, the input form or input MSA will be taken from the owner.)
Predecessor | Operation from Class MoCompoundRuleApp | virtual attr, returning the previous MoCompoundRuleApp in my owner, if any; else (if this is the first compounding rule to be attached in the current stratum) none.
Predecessor | Operation from Class MoDerivAffApp | virtual attr, returning the previous MoDerivationalAffixApp in my owner, if any; else (if this is the first derivational affix to be attached in the current stratum) none.
Prefix | Attribute from Class MoMorphType | Attached to the beginning of the fForm of an MoForm which belongs to this MoMorphType for display purposes (??). Typically, this will be a dash for suffixes, infixes and perhaps enclitics.
PrefixSlots | Association from Package Ling | refers to an ordered seq of MoInflAffixSlot, i.e. those slots which correspond (roughly) to prefixes. The order is from the innermost affix out, i.e. right-to-left. The reason for this attribute (and for the SuffixSlots attribute, below) is that the Slots attribute is a derivation order, i.e. the order in which the affixes are applied during a derivation; while the partition into prefix and suffix slots is for purposes of display, and to support the stealth-to-wealth concept (see discussion above, under slots). For most languages, the PrefixSlots and the SuffixSlots will partition the entire set of slots. Of course, this assumes that no affix slot contains both prefixes and suffixes (i.e. there is no discontinuous bleeding), and that affixes of reduplication, infixes, circumfixes, simulfixes etc. can be shoe-horned into one or the other of these attributes. There are almost certainly languages where this will not work, and for which the user may wish to ignore the prefix and suffix division. Accordingly, some alternative sort of display should be available for that situation. An example of such a language is Huave (Matthews 1972b), for which some slots contain both prefixes and suffixes; see also Stump's (1992) discussion of "ambifixal position classes."
Preposed | Attribute from Class ConstChartMovedTextMarker
PreventChoiceAboveLevel | Attribute from Class CmPossibilityList
PreventDuplicates | Attribute from Class CmPossibilityList
PreventNodeChoices | Attribute from Class CmPossibilityList
PrimaryLexemes | Association from Package Cellar | The UI limits this to a sequence of LexEntry or LexSense. For variants, this field is unused. For complex entries, this field points to a subset of ComponentLexemes. The entries or senses in this property determine the main entries that will have subentries generated for this entry. For example, if ComponentLexemes has kick, the, bucket, and PrimaryLexemes only has kick, then kick is the only entry that will show a ‘kick the bucket’ subentry in a root-based display.
process | Stereotype from Package UML Standard Profile | Specifies a classifier that represents a heavy-weight flow of control.
ProdRestrict | Association from Package Cellar | This reflects what is also referred to as exception features in the literature. It defines class identifiers that can be associated with non-productive derivational or inflectional affixes that only go on stems that belong to the same class. An example from English is the feature [+Latinate], marking that part of the English vocabulary which is etymologically derived from Latin, and which has certain synchronic properties. For example, the suffix -ity attaches only to [+Latinate] stems (Aronoff 1976: 51): felicity, vivacity, *widity, *strongity. The similar suffix -ness, on the other hand, attaches to more or less all adjectives regardless of this feature. Similar restrictions are apparently found in other languages which have undergone substantial borrowing, e.g. Mohawk and Dutch are said to have restrictions which depend on whether or not stems were borrowed from French. Maybe there are other sources of such restrictions as well. These restrictions cannot be handled by inflection classes. The reason is that inflection classes and exception features are likely to be cross-cutting distinctions. Changed from ProductivityRestrictions
ProdRestrict | Association from Package Ling | Refers to a collection of CmPossibility, giving any exceptional properties of the stem that relate to restricting the productivity of affixes. (Other terms for this are 'exception features,' 'rule features' and 'ad hoc features'.) Usually these represent restrictions which are shared among a set of more than two morphemes (unlike AMPLE's 'ad hoc pairs', which concern a pair of morphemes). An example from English is the feature [+Latinate], marking that part of the English vocabulary which is etymologically derived from Latin, and which has certain synchronic properties. For example, the suffix -ity attaches only to [+Latinate] stems (Aronoff 1976: 51): felicity, vivacity, *widity, *strongity The similar suffix -ness, on the other hand, attaches to more or less all adjectives regardless of this feature. Similar restrictions are apparently found in other languages which have undergone substantial borrowing, e.g. Mohawk and Dutch are said to have restrictions which depend on whether or not stems were borrowed from French. Maybe there are other sources of such restrictions as well. These restrictions cannot be handled by inflection classes. The reason is that inflection classes and exception features are likely to be cross-cutting distinctions. Another sort of restriction for which exception features have sometimes been used, is for certain restricted (morpho-)phonological alternations, such as the Velar Softening rule of English (Chomsky and Halle 1968; Aronoff 1976: 51). However, this use is sometimes complicated by restrictions on adjacency, which cannot be easily modeled. An apparent alternative to exception features would be morphosyntactic features. However, exception features are (by definition) invisible to the syntax, and the use of morphosyntactic features for this purpose could incorrectly prevent unification of features in syntax, e.g. if we build an NP consisting of a [+Latinate] noun and an [-Latinate] determiner. See also MoDerivationalAffixMsa.FromProductivityRestrictions. Do exception features percolate? There is some inconclusive discussion of this in Aronoff 1976: 52. Note that the answer to this will not directly affect the domain model, only the parser and generator (unless we decide to leave it up to the user, and put a toggle somewhere). See also note under MoDerivationalAffixMsa. Changed from ProductivityRestrictions.
ProdRestrict | Association from Package Ling | Specifies the restriction classes which the word has at this stage in the derivation. Changed from ProductivityRestrictions
profile | Stereotype from Package UML Standard Profile | A profile is a stereotyped package that contains model elements that have been customized for a specific domain or purpose using extension mechanisms, such as stereotypes, tagged definitions, and constraints. A profile may also specify model libraries on which it depends and the metamodel subset that it extends. (The latter is specified via an applicableSubset tag definition.)
PromptText | Attribute from Class CmFilter
PromptUser | Attribute from Class CmAnnotationDefn | Should the user be prompted before annotated object is deleted? T = Prompt user. F = Delete without prompt.
Pronunciations | Association from Package Ling | We may need more than one pronunciation per entry. For example either/neither have two different pronunciations. Some people may want to order these based on frequency of use, so it is a sequence instead of a collection.
Protected | Attribute from Class ScrDraft | Stores whether certain saved versions can be deleted.
PRuleApps | Association from Package Ling | owns an ordered seq of MoPhonolRuleApp, representing the application of the phonological rules of this stratum. Note that the fact that this attr belongs to the MoStratumApp precludes modeling cyclic application. That restriction could easily be lifted. The order is the order of application in derivation (which may be the reverse of the order in parsing).
PsalmLabel | Attribute from Class Scripture | String that will be inserted when a Psalm number heading is generated.
PubDivision | Class from Package Cellar | Content for a distinct portion of a publication (document). A CmPubDivision is the largest sub-unit of content organization in a publication.
PubHeader | Class from Package Cellar | The contents of the portion of the header that is centered between the margins.
PubHFSet | Class from Package Cellar | Contains a set of headers and footers for a division or section of a publication Renamed from PubHeaderFooterSet for the Firebird Port.
Publication | Class from Package Cellar
Publications | Association from Package Scripture | A collection of all of the publication layouts available for output from the translated scripture database.
Publications | Class Diagram
PubPageLayout | Class from Package Cellar | Encapsulates page layout parameters specifying page margins, header and footer positions, etc. The internal unit of measurement for page layout parameters is millipoints. A CmPageLayout is a page style specification applied to a CmPubDivision. Each CmDivision owns one copy of CmPageLayout. (Other objects may be made owners of CmPageLayout(s) as the design progresses.)
PunctuationForm | Class from Package Cellar
Q
Question | Attribute from Class CmDomainQ | Example: (Ron Moe's Standard Format): \qu (2) What words refer... The question is not formatted and has no embedded languages. It is multi because we may have translations in other languages (e.g., \quf are French translations).
Questions | Association from Package Cellar | Each domain has a list of questions used to elicit words. Each question has sample words and sentences, so we group these together into CmDomainQ. The domain then owns a sequence of these. They need to be ordered since important questions come first.
Quote | Association | Quotation from the scripture text to indicate the topic of the note. May be in an analysis language, a vernacular language or both.
R
realize | Stereotype from Package UML Standard Profile | (Name for the stereotyped class is Realization.) Specifies a realization relationship between a specification model element or elements (the supplier) and a model element or elements that implement it (the client). The implementation model element is required to support all of the operations or received signals that the specification model element declares. The implementation model element must make or inherit its own declarations of the operations and signal receptions. The mapping specifies the relationship between the two. The mapping may or may not be computable. Realization can be used to model stepwise refinement, optimizations, transformations, templates, model synthesis, framework composition, etc.
Recommendation | Association | The reviewer's summary recommendation concerning the issue. For consultant notes, may contain a suggested rendering, test questions to ask the translation team, or other specific course of action recommended.
Records | Association from Package Cellar
Records | Association from Package Notebk | A collection containing all of the top-level records in the notebook. (Keep in mind that records can contain records, so that this attribute only contains the top-level records.) This is the main content attribute of the notebook.
RecTypes | Association from Package Notebk | A list of event types that the user can modify. Types included by default are: Performance, Almanac, Conversation, Observation, LiteratureSummary.
Ref | Attribute from Class ChkRef | Index to a target text unit. For Scripture the BCV (book/chapter/verse) reference in the English versification.
RefEnd | Attribute from Class ScrDifference | an integer to store a reference for where the difference ends.
Reference | Attribute from Class LexExampleSentence
ReferenceForms | Association from Package Ling | owns a collection seq of FsFeatStruc, each of which defines the cell whose inflection uniquely picks out an inflection class. (Cf. Carstairs-McCarthy 1991, particularly section 8). Usually, the reference forms belonging to a part of speech will suffice for all the MoInflectionClasses, i.e. a single "Primary Reference Form" (Carstairs-McCarthy's term). In some cases, however, it may prove necessary to provide a secondary reference form to distinguish among "mixed" classes (see again the discussion in Carstairs-McCarthy 1991.) Any secondary reference forms are provided in the attr of the same name of the particular MoInflectionClasses to which they pertain.Note that this attribute performs no particular function in any of the algorithms used for computing affixed forms. However, it may be useful in the context of a dictionary, e.g. for providing principal parts.
ReferenceForms | Association from Package Ling | ReferenceForms: owns a collection of FsFeatStruc, each of which defines the cell whose inflection uniquely picks out an inflection class. (Cf. Carstairs-McCarthy 1991, particularly section 8). Usually, the reference forms belonging to a PartOfSpeech will suffice for all the MoInflectionClasses, i.e. a single "Primary Reference Form" (Carstairs-McCarthy's term). In some cases, however, it may prove necessary to provide a secondary reference form to distinguish among "mixed" classes (see again the discussion in Carstairs-McCarthy 1991.) This attr is then where the secondary reference form would be stored. The classes which need to be distinguished by ReferenceForms will presumably constitute the members of the Subclasses attr of some parent inflection class, together with that parent inflection class. The appropriate class to list the ReferenceForms will then be that parent class, and the daughter classes will inherit that property via their vAllReferenceForms (see below). Note that this attribute performs no particular function in any of the algorithms used for computing affixed forms. However, it may be useful in the context of a dictionary, e.g. for providing principal parts.
References | Association from Package Ling | This holds the possibility list that holds LexRefType items which own the actual references.
refine | Stereotype from Package UML Standard Profile
RefNumber | Attribute from Class FsFeatureSpecification
RefSepr | Attribute from Class Scripture | RefSepr is a string (usually one character) that separates complete references or chapter/verse references in a list. In the U.S.A., this is traditionally a semi-colon (;), e.g., Mat 24:16; Rev 1:2;4:5.
RefStart | Attribute from Class ScrDifference | an integer to store a reference for where the difference starts.
RefType | Attribute from Class LexEntryRef | This property is needed in the UI to know whether the current LexEntryRef should show up as a variant or a complex form. We currently use VariantTypes and ComplexFormTypes to determine this, but there are occasions when both of these are missing but we still need to show something in the UI. This integer will be used as an enum with 0 for variants and 1 for complex forms. We may later need to specify inflected forms and perhaps combinations of these.
Region | Association from Package Ling | owns an FsFeatStruc defining the region of the paradigm for which this template is relevant. The idea here is that in some regions of the template (typically, things like participles or imperatives), there may be fewer affix slots than in other regions. While one could use the same template for all regions, with affixes in some of the slots restricted to appearing only with certain features (such as [?participle]), this is probably not the simplest analysis (since it requires all affixes in those slots to be so marked, including what would otherwise be default affixes). If this attr is empty, then this template pertains to the entire paradigm except for any regions covered by templates ordered before this one in the PartOfSpeech.AffixTemplates attr of the owner.
Regions | Association from Package Ling | owns a collection of FsFeatStrucs. Conceptually, this is analogous to MoInflectionalAffixMsa.InflectionalFeatures, defining the parts of the paradigm that use this stem. However, unlike an inflectional affix, it is possible for a stem to have more than one FsFeatStruc and therefore pertain to more than one contiguous region of a paradigm, i.e. a stem need have no particular (or at least no consistent) semantics over and above the semantics of the lexeme it belongs to. (Again, see Aronoff 1992.) An example is the '1sg/subj' stem which for many Spanish verbs is used for the past subjunctive and the 1sg present indicative, such as teng- 'have'. In addition to being relevant to one or more regions of a paradigm, a stem may be relevant to derivational morphology. This is indicated in the model by referencing the MoStemName from the MoDerivationalAffixMsa.
RegularForm | Operation from Class MoStemMsa | vRegularForm(FsFeatureStucture): a virtual attr (on the assumption that the filler can be quickly generated) which when queried with a particular FsFeatureStucture as an argument returns the regular form (a WfiWordform) expected for those features, as calculated by PartOfSpeechGrammar.doc - PartOfSpeech.RulesOfReferral and PartOfSpeechGrammar.doc - PartOfSpeech.EmptyParadigmCells, and MoInflectionClass.RulesOfReferral (see the algorithm in Computing Affixed Forms). (If queried with a feature structure corresponding to an empty cell in a defective paradigm, this attr will return none.) Note that this attr returns a regular form (rather than an irregular form from a suppletive cell) when queried with an FsFeatureStucture that corresponds to a suppletive cell. One reason for having the capability of ignoring the suppletive forms, is that from the user’s point of view, nearly everything will be suppletive when first investigating a language, and it will be important to be able to tell whether the rules discovered thus far account for the form in a particular cell (which would render the storage of an explicit form superfluous). By comparing the result of querying a vRegularForm with the form found in the vSuppletiveForms attribute, it will be possible to tell how observationally adequate the rules are. (The attr for returning the suppletive form, if it exists, or else a regular form, is vActualForm.) This attr is atomic, in contrast with the seq attr vSuppletiveForms.
RelatedDomains | Association | Example: (Ron Moe's Standard Format):\cf Weather; Cloud; Star We use this property to link related domains. Ideally this should be a bidirectional link, but so far we do not provide this capability in our conceptual model. So for now we'll live with unidirectional links.
Reminder | Class from Package Notebk | This class provides a means for the user to indicate areas where he wants to do further research. He can then look at a list of all of the Reminders within a notebook, and order his research to address these topics. Eventually, we will probably expand this class to include an indication of priority, and perhaps other fields. But this begins to cross the line into the Project Management software we wish to design and develop, so at this point we are going to keep it relatively simple.
Reminders | Association from Package Notebk | At a global level, the user can use this attribute to view all of the reminders that have been made within the individual records. (The view will presumably permit ordering (and/or sorting) and filtering of these reminders, in support of creating printouts that can help guide further work or elicitation.)
Reminders | Association from Package Notebk | A place where the user can record reminders for further research, such as further editing to do to the record, or additional types of data to seek, or whatever comes to mind.
Rendering | Association from Package Ling | The target vernacular rendering of the checking item at this reference.
Renderings | Association from Package Ling | Represents the renderings (i.e. vernacular equivalents) for a term. A ChkRendering is added whenever a rendering is ascribed to a ChkRef for which a ChkRendering does not already exist in this collection.
Representation | Attribute from Class PhCode | Put something here.
ReqRuleFeats | Association from Package Ling | These are required rule features. This collection refers to a set of rule features (which are a possibility list). This encodes positive rule feature requirements, such as conjugation class membership or gender. In order for this rule to apply to a lexical entry, the lexical entry must contain in its Rule Features list all the feature names of this list. If this field is omitted, there are no required Rule Features. Warning: The names in the ExcludedRuleFeatures list and this list should be mutually exclusive.
Required | Attribute from Class UserViewField
requirement | Stereotype from Package UML Standard Profile | Specifies a desired feature, property, or behavior of an element as part Comment of a system.
Researchers | Association from Package Cellar | The person(s) who created/modified this Possibility record or any of its fields.
Researchers | Association from Package Notebk | Tthe persons who obtained, entered, or analyzed the data. If more than one person was involved, then all researchers can be cited here.
ResearchNotebook | Association from Package LangProj
ResearchPlan | Association from Package Notebk | A plan for researching the hypothesis. Eventually we will tie this into project management; for now we just supply a text description.
Resolution | Association | The reviewer's description of how the issue raised in the note was resolved. Used in conjunction with the ResolutionStatus attribute when details are needed.
ResolutionStatus | Attribute from Class ScrScriptureNote | Place to indicate a status for whether and how the issue which the note concerns has been resolved. This is an open for enumeration for internal use whose meaning can change depending on the annotation type.
Resources | Association from Package Scripture | The named external resources (e.g. xml files) used by Translation Editor and their version numbers.
Resources | Association from Package Ling | The named external resources (e.g. xml files) used by FLEX and their version numbers.
Responses | Association | Place to record discussion between the stakeholders in response to the note. In consultant notes, a two-way interchange between the consultant and consultee.
responsibility | Stereotype from Package UML Standard Profile | Specifies a contract or an obligation of an element in its relationship Comment to other elements.
RestartFootnoteBoundary | Attribute from Class Scripture | Where to restart the footnote sequence, represented as an enumeration (Chapter, Book, OT/NT, etc.)
RestartFootnoteSequence | Attribute from Class Scripture | True if the footnote sequence should be restarted (..., y, z, a, b, ...), false otherwise (..., y, z, aa, ab, ..)
RestOfAllos | Association from Package Ling | Changed from RestOfAllomorphs.
RestOfMorphs | Association from Package Ling | Changed from RestOfMorphemes.
Restrictions | Association from Package Cellar | Indicates whether the data for this possibility item has restrictions for presentation to certain audiences. This value comes from a user-defined list that is used by many different FieldWorks objects (Events, Analysis Records, Lexical Entries and their Senses, etc.) These values are user-definable and initially include: No restrictions, Do not publish, Case by case, Unknown
Restrictions | Association from Package LangProj
Restrictions | Association from Package Notebk | Any restrictions that might exist for this data.
Restrictions | Attribute from Class LexEntry | Only certain people can use the entry under certain circumstances
Restrictions | Attribute from Class LexSense
Result | Attribute from Class ScrCheckRun | Result of the check. An integer representing an enumeration (0 - No inconsistencies found; 1 - Only ignored inconsistencies found; 2 - Unignored inconsistencies found).
ReversalEntries | Association from Package Ling
ReversalForm | Attribute from Class ReversalIndexEntry | This property contains the index entry forms. The primary form is in the ReversalIndex_WritingSystem. Other acceptable writing systems are ones that are the same language as the primary form (the IcuLocal is identical up to the first _).
ReversalIndex | Class from Package Ling
ReversalIndexEntry | Class from Package Ling
ReversalIndexes | Association from Package Ling | Ken Zook: We are pretty well beyond the point where we'll ever allow multiple language projects in a database, so I think it's time we make these indexes owned. Since they are really part of the lexical database, I'm recommending they be owned by the lexical database.
ReverseAbbr | Attribute from Class LexEntryType | This abbreviation may be used in the minor/subentry when referring to the major entry. For example, CmPossibility_Abbreviation could have "var." and LexEntryType_ReverseAbbr could have "var. of"
ReverseAbbreviation | Attribute from Class LexRefType | This is used for the generic/whole abbreviation for trees.
ReverseName | Attribute from Class LexRefType | This is used for the generic/whole name for trees.
RevLim | Attribute from Class ScrDifference | the offset in the paragraph past the end of the difference verse.
RevMin | Attribute from Class ScrDifference | the offset in the paragraph where the difference begins.
RevParagraph | Association from Package Scripture | the paragraph in the revision that the difference is in.
RightContext | Association from Package Ling | The right context of the rule.
RightContext | Association from Package Ling
RightForm | Association from Package Ling | RightForm: refers to a form (Wordform? MoStemAllomorph?), that of the right-hand member of the compound.
RightGlossSep | Attribute from Class FsFeatDefn | Specifies the separator symbol that should appear to the right of a gloss component when the Gloss Assistant system constructs a gloss. MultiUnicode to allow for different glossing separators used in different languages. Renamed from RightGlossSeparator for the Firebird port.
RightGlossSep | Attribute from Class FsSymFeatVal | Specifies the separator symbol that should appear to the right of a gloss component when the Gloss Assistant system constructs a gloss. MultiUnicode to allow for different glossing separators used in different languages. Changed from RightGlossSeparator for the Firebird Port.
RightHandSides | Association from Package Ling | The right hand sides of the rule (i.e. the B, C, and D of the general formula (A -> B / C _ D).
RightMsa | Association from Package Ling | owns an MoStemMsa, giving the morphosyntactic information about the right-hand member of this compound, in the same fashion as the LeftMsa attribute.
RightToLeft | Attribute from Class StText | Specifies whether the overall document direction for this structured text is right-to-left (true) or not (false).
RnGenericRec | Class from Package Notebk | This is a superclass that encapsulates basic, shared behavior for Event and Analysis records Rdnamed from RnGenericRecord for the Firebird Port.
RnResearchNbk | Class from Package Notebk | The ResearchNotebook is the major containing object for the various records that are stored in the notebook. Renamed from RnResearchNotebook for the Firebird Port.
RnRoledPartic | Class from Package Notebk | Captures participants and their roles in a recorded event. Renamed from RnRoledParticipants for the Firebird Port.
Role | Association from Package Notebk | The role of the above participant(s). The role may be set to "unspecified."
Roles | Association from Package LangProj
Rows | Association from Package Ling | The main content of the chart. Each ConstChartRow represents a row/clause.
Rows | Association from Package Cellar
Rule | Association from Package Ling | refers to the phonological rule (class to be defined) whose application this trace structure represents
Rules | Attribute from Class StStyle
RulesOfReferral | Association from Package Ling | owns an ordered seq of MoReferralRule; used for statements like "the accusative plural of nouns is identical to the nominative plural" or "the accusative plural of second declension nouns is identical to the nominative plural'. (Note that rules of referral which are owned by the PartOfSpeech hold for all lexemes of that part of speech, regardless of inflection class; whereas rules of referral owned by an MoInflectionClass hold only for lexemes of that class. In Stump's (1993a) notation, the latter case corresponds to indicating a 'CLASS' for the Referral Rule.)I (MM) have defined this as an ordered seq, because in rare cases one referral rule might override another such rule. See the discussion of the similar RulesOfReferral attr in MoInflectionClass.
RulesOfReferral | Association from Package Ling | owns a sequence of MoReferralRule. Like the attribute pRulesOfReferral in the class PartOfSpeech, except that rules of referral which are owned by the PartOfSpeech hold for all lexemes of that part of speech (regardless of inflection class), whereas rules of referral owned by this class hold only for lexemes of a particular class. (In Stump's (1993a) notation, the latter case corresponds to indicating a 'CLASS' for the Referral Rule.)
RunDate | Attribute from Class ScrCheckRun | Date and time the check was completed.
S
ScaleFactor | Attribute from Class CmPicture | Percentage by which picture is grown or shrunk. Not used if the LayoutPos is 4 (Fill Column), 5 (Fill Page), 6 (Full Page).
schema | Stereotype from Package UML Standard Profile
ScientificName | Attribute from Class LexSense
ScrBook | Class from Package Scripture | A translated book of Scripture. This container holds ScrSections which are where the actual verse texts are stored.
ScrBookAnnotations | Class from Package Scripture | Contains annotations about one book of Scripture. Scripture annotations are stored book-by-book to make for faster access and filtering. These annotations are only for consultant notes, scripture notes and other content that discusses the scripture content. At present (Jan/2006), we have not decided where to put the annotations that will be generated by the checking tools.
ScrBookRef | Class from Package Scripture | ScrBookRef holds the default naming metadata of a given canonical Scripture book, by writing system. ScrBookRef no longer stores the 3-letter UBS book reference code. The 3-letter UBS book ref is now managed by the business layer of the application.
ScrCheckRun | Class from Package Scripture | Records the date and results of a run of a check.
ScrDifference | Class from Package Scripture | contains the information about one difference between a ScrBook and a ScrBook revision. We have a diff tool that allows comparing two versions of scripture books. While a person is comparing versions, we want to provide the capability of leaving and resuming the comparison process at a later time. In order to do this, we need to save a list of differences and an HVO of a revision book in the database.
ScrDraft | Class from Package Scripture | Enumeration: 0 - Saved Version; 1 - Imported Version
ScrFootnote | Class from Package Scripture
ScrImportP6Project | Class from Package Scripture | Variant of ImportSource used to designate a Paratext 6 project.
ScrImportSet | Class from Package Scripture | Stores named sets of import settings for importing scripture. Renamed from ScrImportSettings for tye Firebird Port.
ScrImportSFFiles | Class from Package Scripture | Variant of ScrImportSource used to designate a list of Standard Format files.
ScrImportSource | Class from Package Scripture | Abstract Class for source of the incoming data, the information needed to set uup an import stream.
ScriptDigitZero | Attribute from Class Scripture | This stores the Unicode character for zero in the given script. It is assumed this is a decimal based system that has consecutive code points from 0 through 9. Note that Tamil does not have a character for zero, but Unicode reserves a code point U+0BE6 for this position so that it can still be used in calculations to find the remaining digits. (Tamil actually displays a Latin 0 for zero.)
Scripture | Class from Package Scripture | This object exists to hold all language project Scripture-related data. It serves as a specialized folder.
Scripture | Class Diagram
Scripture | Package from Package Component View
ScriptureBooks | Association from Package Scripture | The Scripture object is a container for an ordered collection of ScrBooks (Scripture Books).
ScriptureMappings | Association | The mappings (from delimited external data to internal data structure) that apply to the scripture and back translations sources in this group fo settings. Markers used in both the scripture and back translations sources must be used equivalently within an instance of ScrImportSettings, so one collection of mappings is used for both types of sources.
ScriptureSources | Association | Currently (Dec 2005) a single source for scripture is suported but this is made a collection to make future expansion feasible.
ScrMarkerMapping | Class from Package Scripture | Settings for mapping between the external data's delimiting markers and the internal data.
ScrRefSystem | Class from Package Scripture | ScrRefSystemt stores the complete set of Scripture book names and abbreviations as ScrBookRef objects. The project (ScrBookRef) no longer stores the 3-letter UBS book ref. The 3-letter UBS book ref is now managed by the business code. ScrRefSystem persists known book names and abbreviations that are loaded from external data and also persists the most recently known vernacular book names and abbreviations, even if a book is deleted. Allows the user to customize book names and abbreviations for the project independently from the external resource data. When a Scripture book is added to Scripture, it gets its names and abbreviations from ScrBookRef. In the future ScrRefSystem may also be used to persist vernacular book names and abbreviations entered by the user in a canonical reference checking tool so that BCV references can be checked even for Scripture Books that do not yet exist as a ScrBook.
ScrScriptureNote | Class from Package Scripture | A general annotation for Scripture, derived from CmBaseAnnotation. Has fields (owned StJournalText objects) widely used for annotating Scripture, e.g., translator notes, consultant notes.
ScrSection | Class from Package Scripture | A ScrSection represents a passage of Scripture. These are often given their own non-canonical headings in various published versions of the Bible. For example, in the NIV, Matthew 1:1-17 is ScrSection with the heading "The Genealogy of Jesus."
ScrTxtPara | Class from Package Scripture
SecondaryOrder | Attribute from Class MoMorphType | Determines sorting when there are homographic forms that are of different morph types. For example what order does in, in-, -in, in= and =in and -in- appear IN the dictionary.
Sections | Association from Package Scripture | A ScrBook is made up of ScrSections. ScrSections represent short passages of Scripture. For example, Matthew 1:1-17 in the NIV is a ScrSection with a heading of "The Genealogy of Jesus."
SeeAlso | Association from Package Notebk | See Also cross-references for Events or Analyses
SeeAlso | Attribute from Class ChkTerm | Alternate glosses (in UI/analysis writing systems) that should appear in the list of terms (when sorted/grouped by gloss). Multiple glosses are separated by semi-colons.
Segment | Class from Package Cellar | Represents a sentence or segment length part of a paragraph.
Segments | Association from Package Cellar
Segments | Association from Package Ling | refers to a collection seq of PhPhoneme, which are interpreted as the members of this class.
self | Stereotype from Package UML Standard Profile | Specifies that the relationship represents a reference to the object that AssociationEnd owns an operation or action rather than an actual association.
self | Stereotype from Package UML Standard Profile | Self is a constraint applied to a link-end, specifying that the corresponding instance is visible because it is the dispatcher of the request.
SemanticDomainList | Association from Package LangProj
SemanticDomains | Association from Package Ling
SemanticsNote | Attribute from Class LexSense
send | Stereotype from Package UML Standard Profile | «send» Usage Send is a stereotyped usage dependency whose source is an operation and whose target is a signal, specifying that the source sends the target signal.
Sense | Association from Package Ling | In Scripture, a target lexical sense for a key term. More generically, a lexical sense associated with a checklist item. With the LexSense as a starting point, the stem, citation form, literal meaning, definition, gloss and likely inflectional word forms for the rendering can be determined. Note that we do not determine the lexical stem directly but rather make a semantic connection to it through the particular sense of the stem that is relevant to the ChkItem. We can always determine the stem from the sense but not vice versa.
Sense | Association from Package Ling
Senses | Association from Package Ling
Senses | Association from Package Ling | I am not currently sure whether senses belong on minor entries or not but we did allow this in LinguaLinks so I will leave it here for now for compatibility's sake.
SenseType | Association from Package Ling
SenseTypes | Association from Package Ling
Severity | Attribute from Class CmAnnotationDefn | For example, we may want to indicate the following with visual cues. Severity: 0 = NA 1 = Critical 2 = Problem 3 = Warning 4 = Suggestion User
SheetLayout | Attribute from Class Publication | enumeration designating the way pages are laid out on each sheet of paper for printing: 0 (default) — indicating simplex: 1 front (recto) page per sheet. (Implies that the gutter margin is always on the leading side of the page.) 1 — indicating duplex: 1 front (recto) page and 1 back (verso) page per sheet (Implies that the gutter margin alternates between the leading and trailing sides of alternate pages.) 2 — indicating booklet: 2 front (recto) pages and 2 back (verso) pages per sheet, side-by-side. (Implies two gutter margins in the center of the sheet, on each side.) any other value — indicating error: not defined
SheetsPerSig | Attribute from Class Publication | Number of sheets of paper in each signature for booklet layout. The number of pages per signature will equal four times this value for typical booklet printing. (A 'signature' is a set of sheets in a book, folded together for binding as a unit).
ShowInGloss | Attribute from Class FsFeatDefn | For use in the Gloss Assistant: T = Display the value of GlossAbbreviation in the gloss. F = Do not display the value
ShowInGloss | Attribute from Class FsSymFeatVal | For use in the Gloss Assistant: T = Display the value of GlossAbbreviation in the gloss. F = Do not display the value
ShowPrompt | Attribute from Class CmFilter
Sid | Attribute from Class UserConfigAcct | Same as Sid in the Syslogins table in the master DB.
signalflow | Stereotype from Package UML Standard Profile | Signalflow is a stereotype of ObjectFlowState with a Signal as its type.
Slot | Association from Package Ling | refers to an MoInflAffixSlot in the MoInflAffixTemplate pointed to by the Template attr of my owner.
SlotApps | Association from Package Ling | owns an ordered seq of MoInflAffixSlotApps, representing the sequence of inflectional affix slots belonging to this template that were applied in the derivation. An alternative to having this attr and a separate class for slot applications, would be to have an attr here for inflectional affix applications themselves, bypassing the "middleman." The distinction between slot applications and the attachment of a particular affix belonging to a slot is that if no affix in a particular slot applies, the effect is that of an implicit zero affix. Under this alternative, there would thus be no indication that the slot in question had been tried. It seems better to have this attr record the slot applications, on the assumption that one wants to know if there was an implicit zero affix. I have defined this as an ordered seq, but it would be possible to derive the ordering from the order of the MoInflAffixSlots in the Slots attr of the MoInflAffixTemplate of this template application. However, this would not work if the user had changed the order of slots since this derivation was created.
Slots | Association from Package Ling
Slots | Association from Package Ling | refers to an ordered seq of MoInflAffixSlot; during the course of a derivation, each Affix Slot is applied in sequence, beginning with the top-most slot. While in many (most?) languages the order of attachment of Inflectional affixes is irrelevant, it may occasionally be necessary to specify a derivational order to account for allomorphy. Since the left-to-right order is likely to be discovered earlier than the derivation order, it will probably be necessary to provide a default derivation order which can be computed from the order in the PrefixSlots and SuffixSlots attributes (below). Existing front-ends to AMPLE (such as CarlaMen) do something similar by allowing the user to choose to apply all prefixes before all suffixes, or vice versa, and something similar will probably suffice as a default here.
SocioLinguisticsNote | Attribute from Class LexSense
SortSpec | Attribute from Class CmPossibility
SoundFilePath | Attribute from Class Text
Source | Association from Package Cellar | Who made this annotation. If a computer parser, the agent will be that parser.
Source | Attribute from Class Text
Source | Attribute from Class LexEtymology
Source | Attribute from Class LexSense
source | Stereotype from Package UML Standard Profile | Denotes a source file that can be compiled into an executable file.Subclass of «file».
Sources | Association from Package Notebk | The person(s) who reported the event to the researcher.
SpellingStatus | Attribute from Class WfiWordform | The current status of a wordform (e.g. undecided, correct, incorrect). This will be used to display and allow the changing of a word's status in the concordance view of the translation editor.
StartAt | Attribute from Class PubDivision | Enumeration of options for where the content of the division begins: pdContinuous, pdNew, pdOdd
StartDependentClauseGroup | Attribute from Class ConstChartRow
StateInformation | Attribute from Class CmAgent | Defines what constraint groups are turned off. (Example: in morphological parsing we might turn off a set of rules). It is represented as XML and is empty unless the morphological system is in debug mode. We have not yet determined the nature of the XML representation (Jan 17, 2002).
stateInvariant | Stereotype from Package UML Standard Profile | Specifies a constraint that must be attached to a state vertex in a state machine that has a classifier for a context. The stereotype indicates that the constraint holds for instances of the classifier when an instance is in that state.
Status | Association from Package Notebk | An indication of the current status of the record. Included default possibilities include: Confirmed, Disproved, Pending
Status | Association from Package Cellar | The status of this Possibility. This is a user-definable list but initial list will include: Confirmed, Disproved, Pending.
Status | Association from Package Ling
Status | Association from Package Ling
Status | Attribute from Class ChkRef | Checking status for this item (as defined by the reference-keyword).
Status | Attribute from Class MoGlossItem | Each top-level gloss item in the master gloss list needs a status attribute to indicate whether the subtree it dominates is visible or hidden. A hidden gloss item corresponds to a feature structure type that is only embedded as the value of complex features and so does not appear in the gloss possibilities chooser as a top-level choice but appears only in subtrees under complex features.
Status | Attribute from Class CmTranslation | A label to hold any kind of metadata about the Translation, in particular used for its status (as in “fresh” or “stale”, etc.). These labels can be stored and retrieved independently for each writing system and so correspond the parallel string in the Translation for each writing system. Different types of CmTranslations can have different sets of status labels according to the need of the type.
StemForm | Association from Package Ling | refers to an MoStemAllomorph, a stem found in the lexicon.
StemForm | Operation from Class MoInflAffixSlotApp | virtual attr returning a string, defined as my vInputForm. Basically superfluous, but retained for parallelism with the AffixForm attr.
StemForm | Operation from Class MoDerivAffApp | virtual attr returning a multiUnicode string, defined as my vInputForm. Basically superfluous, but retained for parallelism with the AffixForm attr.
StemMsa | Association from Package Ling | refers to an MoStemMsa, a stem found in the lexicon. Note that this object and the allomorph pointed to by the StemForm must belong to the same LexEntry.
StemMsa | Operation from Class MoInflAffixSlotApp | virtual attr returning an MoStemMsa, defined as my vInputMsa. Like the vStemForm, this is basically superfluous.
StemMsa | Operation from Class MoDerivAffApp | virtual attr returning an MoStemMsa, defined as my vInputMsa. Like the vStemForm (see the superclass), largely superfluous.
StemName | Association from Package Ling | refers to a MoStemName. Ordinarily, only one allomorph of any given stem will bear a given stem name, but this may not be true if there are phonologically conditioned allomorphs as well. If this attribute is empty, this stem is used as the default stem for the paradigm.
StemNames | Association from Package Ling | owns a collection seq of MoStemNames, which define any non-default inflectional stems of the category (but not the default stem). For example, Aronoff (1992) discusses what he calls the '3-stem' of Latin verbs, a form which exists in all verb conjugations, and which is used as the base in a variety of places of the paradigm (which places are not identifiable on semantic or other grounds without using 'or'). The MoStemNames are interpreted as a disjunctively ordered list, i.e. in selecting a Stem for a given word, the list of StemNames is searched linearly, stopping at the first one for which one of its cells unifies with the FsFeatStruc of the word to be derived (see Choosing a Stem Allomorph). The order of the MoStemNames in this attribute is therefore important.If this attribute is empty, it defaults to the value of the same attribute in its owner. This allows e.g. defining a set of stem names for all verbs, and inheriting those names for subcategories of verb. It should probably be possible to block such inheritance without specifying any stem names, so there needs to be some specified value for that ('nil', say). An example might be modal verbs in English, which are presumably a subclass of verbs, but which lack certain forms.
StemNames | Association from Package Ling | owns a collection of MoStemNames, which define any non-default inflectional stems of the inflection class (but not the default stem) in addition to those found in the PartOfSpeech. The MoStemNames are interpreted as a disjunctively ordered list, i.e. in selecting a Stem for a given word, the list of StemNames is searched linearly, stopping at the first one for which one of its cells unifies with the FsFeatStruc of the word to be derived (see Choosing a Stem Allomorph). The order of the MoStemNames in this attribute is therefore important. If this attribute is empty, it defaults to the value of the same attribute in its owner. This allows e.g. defining a set of stem names for all verbs, and inheriting those names for all inflection classes of verb (as well as for all subcategories of verb). It should probably be possible to block such inheritance without specifying any stem names, so there needs to be some specified value for that ('nil', say).
Stems | Association from Package Ling | In a thorough analysis this attribute will not be used. However, if the linguist wishes to only analyze stems this is an easy way to accomplish this.
StFootnote | Class from Package Cellar
StJournalText | Class from Package Cellar | Text object for texts that must be signed and dated by the content creator. Intended for journal-type data entries where it is important to account for what changes were made and when they were made and by whom. Originally implemented for use with Scripture annotations.
StPara | Class from Package Cellar | An abstract class used to group the StParagraph and StTable classes
Strata | Association from Package Ling | owns a col of MoStratum objects, in order from shallowest to deepest.
Stratum | Association from Package Ling | refers to an MoStratum, giving the stratum to which this rule belongs. The assumption behind the fact that this is an atomic attribute, is that a given compound rule (i.e. type of compound) can belong to only one stratum. If compounding happens in more than one stratum, then there must be more than one compounding rule. See also the discussion of MoStratum.vCompoundRules..
Stratum | Association from Package Ling | Stratum: refers to the MoStratum to which this MoMorphoSyntaxAnalysis object belongs. In an earlier version of this document, this attr belonged to MoForm. But that implied that one allomorph might belong to one stratum, and another allomorph to another stratum, which seems wrong. It is here, rather than on the superclass, because MoInflectionalAffixMsas do not need to "know" their stratum (their stratum is specified by the MoInflAffixTemplate in which they appear). (The other subclass of MoMorphoSyntaxAnalysis which has this attr is MoStemMsa.)
Stratum | Association from Package Ling | refers to the MoStratum to which this MoMorphoSyntaxAnalysis object belongs. In an earlier version of this document, this attr belonged to MoForm. But that implied that one allomorph might belong to one stratum, and another allomorph to another stratum, which seems wrong. It is here, rather than on the superclass, because MoInflectionalAffixMsas do not need to "know" their stratum (their stratum is specified by the MoInflAffixTemplate in which they appear). (The other subclass of MoMorphoSyntaxAnalysis which has this attr is MoDerivationalAffixMsa.)
Stratum | Association from Package Ling | refers to the MoStratum whose application this trace structure represents.
Stratum | Association from Package Ling | refers to the MoStratum to which this MoInflAffixTemplate belongs. Normally that would be the final stratum (or at least to the final stratum in which morphology takes place; if one is modeling post-lexical phonology, that would usually be in a stratum after the inflectional morphology). However, in languages where some derivational affixes attach outside of (some) inflection, that derivational morphology (and any subsequent inflectional morphology) will be in a stratum outside of a stratum containing the inflectional affix template. This definition assumes there are no cycles, i.e. that one does not get the same kind of inflectional affixes both inside and outside of derivational affixes. That's not obviously correct, e.g. one might have [[[[Noun_root] noun_template ] verbalizer ] verb_template] and [[[[Verb_root] verb_template ] nominalizer ] noun_template] where the two instances of noun_template and of verb_template are the same. This would be a counterexample (or would require duplicating the templates in the two strata, obviously a sign that something is wrong with the analysis).
StratumApps | Association from Package Ling | owns an ordered seq of MoStratumApp structures, representing the sequence of applications of strata (i.e. of the affixes and phonological rules of those strata) to an underlying form. The order is from the deepest stratum to the shallowest.
string | DataType from Package Data types
StringRepresentation | Attribute from Class PhEnvironment | This simple string representation of the phonetic environment is parsed by specialized field editor for use by AMPLE. For Phase 1 implementation. Phase 2 will use Left and Right contexts.
StrucChange | Association from Package Ling | The structural change (i.e. the output) of the rule. If this is missing, the rule is a deletion rule
StrucChange | Attribute from Class PhMetathesisRule | The structural change (i.e. the output )of the rule. It contains an ordered sequence of integers, each of which corresponds to an index in the structural description. Since we do not have a way to model a sequence of integers, we use a string to store the integers. The integers are separated by a space.
StrucDesc | Association from Package Ling | For regular rules, this is the structural description of the rule (i.e the A in the general formula of A -> B / C _ D). If A is missing, then this is an insertion (epenthetic) rule. For metathesis rules, this is the structural description (i.e. the input) of the rule. Each ordered PhSimpleContext corresponds to a number (the index) that can be referred to in the structural change attribute.
Structure | Attribute from Class StStyle | The substructure of a Context to which the application of a style is limited. (Presently only used to distinguish the substructures of scripture sections.) To be enumerated as follows: ststHeading - indicating The Heading of a scripture or scripture introduction section. ststContent - indicating The Content of a scripture or scripture introduction section. null - indicating Style is unrestricted for use within this context. (others as needed)
Structured Text | Class Diagram
StStyle | Class from Package Cellar | Represents a style used to display a kind of paragraph
StText | Class
StText | Class from Package Cellar | An object used to represent a moderately structured text (a sequence of styled paragraphs).
StTxtPara | Class from Package Cellar | This represents a standard paragraph found in text.
stub | Stereotype from Package UML Standard Profile | A stub is a stereotyped package representing a package that is incompletely transferred; specifically, a stub provides the public parts of the package, but nothing more.
Style | Association | Style to apply to data in an internal text stream. Ignored of Target is <> 0.
Style | Attribute from Class UserViewField
StyleName | Attribute from Class StPara | Name of the style to apply to this paragraph. May be a standard style, or one of those defined in the Stylesheet attribute of the owning StText.
StyleRules | Attribute from Class StPara | When the user applies formatting to a specific paragraph apart from using a pre-defined style, that formatting information is stored here. It includes information such as font, font style, margins, etc.
Styles | Association from Package Scripture | Scripture requires text style attributes that are uniquely different from styles for general documents in the project. This new style sheet (collection of styles) can be structured just like the style sheet in the Language Project, but is used for all texts authored in the Scripture Editor - Drafts, Back Translations, Notes, UNS Questions, etc. This allows us to: a. utilize styles that are specific for Scripture use; b. avoid conflicts with the LangProject style sheet if, for example, a Style named 'Paragraph' is desired for both general documents and Scripture
Styles | Association from Package LangProj
Subclasses | Association from Package Ling | owns a collection of MoInflectionClasses, each of which is a specialization of this Inflection Class. Part of the S2W process is decreasing the number of inflection classes by pushing identical information in subclasses up into the parent inflection class, and by accounting for differences among subclasses in other ways (e.g. as phonologically predictable allomorphy, or by features such as gender that are not among the PartOfSpeech.InflectableFeatures attribute of the owner).
Subentries | Association from Package Ling
SubfieldOf | Association from Package Cellar
SubFolders | Association from Package Cellar
SubPossibilities | Association from Package Cellar
SubRecords | Association from Package Notebk | A collection of lower-level records. This permits a hierarchical grouping of records (e.g., all of the records dealing with Emilio and Maria's Wedding.) By placing this attribute at the RnGenericRecord level, we are making the claim that any type of record can have subrecords. Thus, for example, a Formal Interview might include some Observations that happened during the interview; a Performance Record might include several formal interviews about the performance; a Cartographic Record might include Reports on Conversations that helped in creating the map.
SubType | Attribute from Class UserView
SuffixSlots | Association from Package Ling | refers to an ordered seq of MoInflAffixSlot, i.e. those slots which correspond (roughly) to suffixes. The order is from the innermost affix out, i.e. left-to-right. See discussion re PrefixSlots concerning other types of affixes.
Summary | Attribute from Class LexEntryRef | This field is available for summary information to show with the variant info being displayed from the main entry. It may be in more than one language and might support formatting and embedded languages. Chuck Grimes feels this is important and it is not simply the gloss of the variant entry. This field would contain the MDF \ve, \vn, and \vr information, which may be the name of a dialect and/or any pertinent comment, such as usage restrictions, simple gloss, or inflection. In MDF the contents of \ve is displayed after the variant in parentheses. Since the \ve field is imported from the major entry, and the \ve may differ for the same \va used in different entries, by storing the information with the LexEntryRef we do not lose anything. If we imported it into the SummaryDefinition of the minor entry, we would have to concatenate the various \ve fields and would lose the distinction of which reference they came from. However, my searches so far have not uncovered any place two different main entries refer to the same variant entry, If this does not happen, we could probably ignore this and just use the SummaryDefinition of the minor entry. When displaying the variant entry in a main entry, this summary could be printed following the variant headword. When displaying a subentry in a main entry in the stem-based format, this summary would be displayed following the subentry headword. Would we ever need a different summary for two different LexEntryRefs owned by the same entry? If not, we could do without this property.
SummaryDefinition | Attribute from Class LexEntry | This is a short definition at an entry level. (It used to be on LexMajorEntry.)
SupersededBy | Association from Package Notebk | A hypothesis can be superceeded by another hypothesis; this attribute refers to that superceeding hypothesis.
SuppletiveForms | Operation from Class MoStemMsa | virtual attr, returning a seq of LexInflectedVariant, indicating stored forms which presumably deviate from the normal paradigm for this stem's PartOfSpeechGrammar.doc - PartOfSpeech and MoInflectionClass. Defined something like: selectIf({|V| exists over selectIf({|SM|(my PartOfSpeech = PartOfSpeech of ^SM) }) of selectIf({|M| accepts(^M) of !MoStemMsa}) of MorphoSyntaxAnalysis of ^V }) over inflectedVariants of my entry In other words, this attr returns those stems (LexInflectedVariants) of the LexEntry owning this MSA which have the same part of speech as this one. I'm assuming an attr LexEntry.inflectedVariants, defined to use the backrefs from LexInflectedVariants.MainEntryOrSense. This hypothetical attr should return LexInflectedVariants objects; that is, if a backref is to a LexSense, it should instead return the LexInflectedVariants object that owns that LexSense. The attr should also return a set, that is, it should remove any duplicates. (It is unclear whether the hypothetical inflectedVariants attr should return all LexEntry objects, or only LexInflectedVariants. The former is probably preferable, since it would be simple to filter the result to return only LexInflectedVariants if that was what was needed, whereas it would be hard to add LexEntry objects later. It's always easier to saw a board shorter than it is to saw it longer.) The motivation for this attr is to find all the listed forms of a given stem, in order to look for duplicates, or to determine whether forms which were deemed unpredictable at an earlier stage of analysis may turn out later on to be predictable (and therefore not needing to be listed any longer). It is possible (though probably unusual, maybe even wrong) to have a suppletive form where the part of speech calls for an empty cell, i.e. one or more of the forms returned by this attr can contradict PartOfSpeechGrammar.doc - PartOfSpeech.EmptyParadigmCells.
SupportingEvidence | Association from Package Notebk | Data records which support the hypothesis.
SurfaceForm | Association from Package Ling | A vernacular wordform that occurs in the text and is a valid equivalent for rendering the term that owns this ChkRendering object. This is required to be filled in when a ChkRendering is created.
SurfaceForm | Operation from Class MoDeriv | virtual attr returning a string (in the language's "surface" encoding), representing the form of the surface word resulting from the derivation. Defined as OutputForm of last over my StratumApps. The assumption here is that this MoDerivation will always have a trace (stored in MoStratumApps.StratumApps) from which we can get such a surface form. If there is no trace, then this isn't really a derivation. We may also wish to refer to a verified surface form in the Wordform Inventory, in which case we would need a reference attr to point to that object. However, that is likely to be an attr of the object owing this MoDerivation, e.g. a test object or a cell in a paradigm.
SurfaceMorphoSyntaxAnalysis: Operation from Class MoDeriv virtual attr returning an MoMorphoSyntaxAnalysis object, defining the morphosyntactic properties of the surface word resulting from the derivation. Defined as follows (see comments concerning the similarly defined vSurfaceForm attr): OutputMsa of last over my StratumApps This will include both the morphosyntactic properties of the stem (as derived by percolation from the stem found in the lexical database and derivational affixes attached to it during the course of the derivation), and the inflectional features which were to be "realized" on the inflected word. (These are present by virtue of the cell in the paradigm which the derivation is to fill, regardless of whether any inflectional affixes realizing those features have actually been attached. Thus, the English word dog would bear the inflectional feature [?plural], even though there is no singular affix on the word-nor does English have such an affix.)
System | Attribute from Class UserView
systemModel | Stereotype from Package UML Standard Profile | A systemModel is a stereotyped model that contains a collection of models of the same physical system. A systemModel also contains all relationships and constraints between model elements contained in different models.
T
table | Stereotype from Package UML Standard Profile | Denotes a database table.
table | Stereotype from Package UML Standard Profile
table | Stereotype from Package UML Standard Profile | Denotes a data base table.
Tag | Association from Package Cellar
Tag | Association from Package Cellar | The CmPossibilities come from the list of chart tags (discourse chart markers).
Tagging | Class Diagram
Tags | Association
Target | Association from Package Ling | Note also that this attribute has two different functions. 1. If a gloss item is a cross-reference, it needs a target attribute to point to a the preferred term in the master gloss list. A cross-reference item lists a term that the user would be looking for, but redirects the user to a standardized term elsewhere in the tree. 2. An additional status is added to indicate that a gloss item that has been copied into a subtree under a complex feature is a proxy for the original gloss item in the master gloss list. A proxy item uses the target attribute to point to its source item. No other attributes on a proxy item should be used since the values on the target item are its values. (The implementation might use term to store the "carried-down" suffix to the gloss string when carry is active.) visible The item is an original item that should be shown in the gloss chooser. hidden The item is an original item, but should not be shown in the gloss chooser. proxy The item should be shown in the gloss chooser, but it is a proxy standing in for an original item.
Target | Attribute from Class ScrMarkerMapping | Enumeration that designates whether the mapping is to a style (text in the main data stream with this style) or to a metadata property and if to a property, which property. 0 - maps to a style 1 - maps to a Figure 2 - maps to a Chapter Label 3 - maps to Title Short other values TBD, not a closed enumeration.
Targets | Association from Package Cellar
Template | Association from Package Cellar | Type of Discourse Chart. Each type of chart can have a different organization and layout of columns. Template must refer to a top-level CmPossibility in (eventually one of?) the template possibility lists of the DsDiscourseData (a Template).
Template | Association from Package Ling | refers to the MoInflAffixTemplate whose application this trace structure represents.
TemplateApp | Association from Package Ling | owns an MoInflAffixTemplateApp, representing the application of an MoInflAffixTemplate belonging to this stratum and matching the InflectionClass of the MoStemMsa at the point of application.
TermId | Attribute from Class ChkTerm | A fixed identifier that matches the term in one or more external source files (e.g., BiblicalTerms.xml, localizations of that file, and/or files that link terms to semantic domains) to uniquely identify the term so it can be correctly matched (and updated, etc.) from the right entry in the external files. This can also be used to obtain a consistent secondary sort when two key terms have identical Lemma forms and/or glosses.
TestSets | Association from Package Ling | WfiWordSets are a collection of words that the user might want to use to test his word grammar as he adjusts morphological rules and the lexicon.
Text | Association from Package Cellar | To handle multiparagraph annotations.
Text | Class from Package Ling | This Text object will probably be replaced by RnEvent or a new subclass of RnEvent (Larry Hayashi, May 6, 2004).
TextMarkupTags | Association from Package Cellar | Top eval Possibilities are major tag categories ( Syntax, Semantics, RRG, etc.) The actual tags are their SubPossibilities [After V1, more hierarchy may be possible.]
TextObjects | Association from Package Cellar | The Contents of StTxtPara are parsed into TextObjects. The event that triggers parsing is yet to be determined but will probably be when the StTxtPara loses focus. Parsed objects include Wordforms, Punctuation, and References (including ScrRefs if the contents are translated Scripture). A sequence of references are set to each of these objects as they are found in their respective inventories (Wordform Inventory, Punctuation Inventory, and ReferenceScheme) This attribute exists in order to allow for a concordance by WfiWordform, (currently including punctuation), PunctuationForm and/or ScrRef. This attribute is a "lite" version of AnalyzedTextObjects. This attribute should only be used if a particular application of StTxtPara requires concordances.
textPropBinary | DataType from Package Data types | textPropertiesBinary - This is distinguished from binary so that FDO can make a distinction between the binary data that occurs as the properties of StText and regular binary. If they are both defined as binary, there is no way to distinguish the two in the SQLServer database. For more information contact Eberhard Beilharz.
Texts | Association from Package LangProj
TextTag | Class from Package Cellar
Thesaurus | Association from Package LangProj
ThesaurusCentral | Attribute from Class WordFormLookup
ThesaurusItems | Association from Package Ling
ThesaurusItems | Association from Package Ling
thread | Stereotype from Package UML Standard Profile | Classifier Specifies a classifier that represents a flow of control.
time | DataType from Package Data types
TimeOfDay | Association from Package LangProj
TimeOfEvent | Association from Package Notebk | The time that the event occurred. The types of items in the list here can be vernacular words that capture how the culture captures different times during the day.
time-out | Stereotype from Package UML Standard Profile | A time-out message the sender sends for a given period of time while waiting for acknowledgment by recipient. The sender is freed up if the acknowledgment does not occur within the duration specified in the description.
time-out | Stereotype from Package UML Standard Profile | A time-out message the sender sends for a given period of time while waiting for acknowledgment by recipient. The sender is freed up if the acknowledgment does not occur within the duration specified in the description.
Title | Association from Package Scripture | The Title can be a sequence of paragraphs. We might thus have a paragraph style for Main Title and for SubTitles to support titles like: The Acts of the Apostles
Title | Attribute from Class RnGenericRec | A caption or title for the record, such as "Emilio and Maria's Wedding".
ToInflectionClass | Association from Package Ling | specifies the inflection (conjugation or declension) class which the word derived from this affix attaches belongs. An example of the use of this attribute would be to mark the conjugation class resulting from the attachment of a verbalizer. Another example is the use of the noun (declension) class 3 in Swahili to mark dimunitives (Beard 1998: 62). Note that a PartOfSpeech has an attr defaultInflClass, to which a derived word will belong if no toInflClass is defined here.
ToMsa | Association from Package Ling | owns an MoStemMsa, giving the morphosyntactic information about the output of this compound. (Since the morphosyntactic properties of the daughters cannot be inherited in an exocentric compound, there is no question here of conflicts between the properties specified in this attribute and the properties of the daughters.) There is no provision for choosing a part of speech based on the argument properties of either element of the compound.
ToMsFeatures | Association from Package Ling | ToMsFeatures: owns a FsFeatStruc, giving the morphosyntactic features which the word derived from this affix contains. In brief, the morphosyntactic features of the output word will contain all these feature values plus any nonconflicting feature values of the stem, provided the features are included in PartOfSpeech.BearableFeatures or PartOfSpeech.InflectableFeatures of the output word. (Or putting it differently, the ToMsFeatures override any conflicting features which would otherwise be percolated up from the stem.)
Tone | Attribute from Class LexPronunciation | This provides a place to store tone patterns of the pronunciation form. It defaults to the top analysis writing system, but being a string, it can be forced to some other writing system. Tone may be marked as HL, 12, etc.
ToPartOfSpeech | Association from Package Ling | specifes the category(PartOfSpeech) of the word resulting from the attachment of this affix. Note that as with the FromPartOfSpeech, we do not (yet) cover subcategorization lists or argument structure here. Thus, we cannot handle subcategorization-changing affixes, such as causatives, by changing a subcategorization list, only by changing category or morphosyntactic features. Likewise, we cannot handle the change in argument structure that accompanies some category-changing affixes. For example, when the prefix en- verbalizes an adjective, the argument of which the adjective was predicated becomes the direct object of the verb (The picture is large - to enlarge the picture; example from Scalise 1986: 28).
topLevel | Stereotype from Package UML Standard Profile | TopLevel is a stereotype of package denoting the top-most package in a containment hierarchy. The topLevel stereotype defines the outer limit for looking up names, as namespaces see outwards. A topLevel subsystem represents the top of the subsystem containment hierarchy, i.e., it is the model element that represents the boundary of the entire physical system being modeled.
ToProdRestrict | Association from Package Ling | Specifies any restriction classes which the MoDerivationalStepMsa resulting from attaching this affix to a stem will bear (in its ProductivityRestrictions attribute). Specifically: if this attribute is non-empty, the stem resulting from the attachment of this affix will have these restriction classes as the value of its ProductivityRestrictions (overriding any restriction classes borne by the stem to which this affix attached). If on the other hand this attribute is empty, the ProductivityRestrictions of the output stem will be the same as those of the input stem. Changed from ToProductivityRestrictions.
ToProdRestrict | Association from Package Ling | refers to a collection of CmPossibility, giving any restriction classes which the stem resulting from this compound rule will bear. Specifically: if this attribute is non-empty, the stem resulting from this rule will have these restriction classes as the value of its ProductivityRestrictions (overriding any restriction classes borne by the daughter stems). If on the other hand this attribute is empty, the ProductivityRestrictions of the output stem will be the same as those of the head (for MoEndocentricCompounds) or empty (for MoExocentricCompounds). Changed from ToProductivityRestrictions.
trace | Stereotype from Package UML Standard Profile | (Name for the stereotyped class is Trace.) Specifies a trace relationship between model elements or sets of model elements that represent the same concept in different models. Traces are mainly used for tracking requirements and changes across models. Since model changes can occur in both directions, the directionality of the dependency can often be ignored. The mapping specifies the relationship between the two, but it is rarely computable and is usually informal.
TranslatedScripture | Association from Package LangProj
Translation | Attribute from Class CmTranslation | The signature is multiBigString allowing us to have translations in multiple languages (e.g. ENG, FRN, SPN).
Translations | Association from Package Ling
Translations | Association from Package Cellar | Refer to the documentation on LpTranslation.
TranslationTags | Association from Package LangProj
Type | Association from Package Notebk | The type of event. Included possibilities include: Performance, Almanac, Conversation, Observation, Literature Summary.
Type | Association from Package Ling | The type of translation: free, literal, back, front, etc.
Type | Association from Package Cellar
Type | Association from Package Cellar
Type | Attribute from Class ScrDraft | 0 = Saved Version; 1 = Imported Version
Type | Attribute from Class UserView
Type | Attribute from Class StStyle
Type | Attribute from Class CmFilter
Type | Attribute from Class UserViewField
Type | Attribute from Class MoGlossItem | Types: 1. fsType The item corresponds to a feature structure type. 2. feature The item corresponds to an inflectional feature. 3. value The item corresponds to an inflectional feature value. 4. complex The item corresponds to a complex feature that embeds another feature structure. 5. deriv The item is the gloss for a derivational morpheme. 6. group The item is in the list only for the purpose of organization and grouping 7. xref The item is a cross-reference to the term that is used in preference to this one.
type | Stereotype from Package UML Standard Profile | Specifies a domain of objects together with the operations applicable to the objects, without defining the physical implementation of those objects. A type may not contain any methods, maintain its own thread of control, or be nested. However, it may have attributes and associations. The associations of a Type are defined solely for the purpose of specifying the behavior of the type's operations and do not represent the implementation of state data.
Types | Association from Package Cellar
U
UML Standard Profile | Package
UnderColor | Attribute from Class CmPossibility | UnderColor for overlay functionality - the color of the "underline" style when used in Overlays.
UnderStyle | Attribute from Class CmPossibility | UnderStyle - style of the underline used in overlays functionality.
unicode | DataType from Package Data types
Usage | Attribute from Class StStyle | A description of the expected usage of the style, displayed on the General tab in the Style dialog.
UsageTypes | Association from Package Ling
UsageTypes | Association from Package Ling
useCaseModel | Stereotype from Package UML Standard Profile | A use case model specifies the services a system provides to its users; that is, the different ways of using the system, and whose top-level package is a use case system.
UseChapterNumHeading | Attribute from Class ScrBook | In this book chapter number headings will be used instead of drop-cap chapter numbers in the text.
UseExtendedFields | Attribute from Class CmPossibilityList
UserAccounts | Association from Package LangProj
UserAppFeatAct | Class from Package Cellar | Renamed from UserAppFeatureActivated for the Firebird Port.
UserCanCreate Attribute from Class CmAnnotationDefn Perhaps the only reason for this attribute is so that we can limit the AnnotationDefns displayed in a GUI that the user selects from. Perhaps it is better to use a boolean:

UserCanCreate: T | F

UserConfigAcct | Association from Package Cellar
UserConfigAcct | Class from Package Cellar | Renamed from UserConfigAccount for Firebird port.
User Configuations | Class Diagram
UserLevel | Attribute from Class StStyle | A number 0-4 indicating the level of user likely to use this style. Default = 0
UserLevel | Attribute from Class UserConfigAcct | Beginner = 1, Intermediate = 3, Advanced = 5
UserView | Class from Package Cellar
UserViewField | Class from Package Cellar
UserViewRec | Class from Package Cellar
UserViews | Class Diagram
UseScriptDigits | Attribute from Class Scripture | This Boolean tells the Scripture tool to use script chapter/verse digits instead of ASCII (latin) numbers.
utility | Stereotype from Package UML Standard Profile | Specifies a classifier that has no instances, but rather denotes a named collection of non-member attributes and operations, all of which are class-scoped.
V
VacuousApp | Attribute from Class MoPhonolRuleApp | Boolean; true means the rule applied vacuously, false means it made some change to the phonetic form to which it applied. The point of having this attr is for display purposes: it allows the user to quickly tell whether a rule made a change to its input. This could be defined either as an owning attr or as a virtual attr (the latter would test for equality of the vInputForm and OutputForm attrs). The alternative to having this attr would be to use a special mark in the OutputForm of this class (see definition of this attr in MoDerivationTrace) when a phonological rule applies vacuously. But that wouldn’t work if another MoDerivationTrace’s InputForm needs to refer to the OutputForm of this rule application.
Value | Association from Package Cellar
Value | Association from Package Cellar
Value | Association from Package Cellar | Every Fs*Value class has an attribute of "Value". The only one that has multiple items is FsDisjunctiveValue (after all, how can you have a disjunction with only one item?). In a sense, even for FsDisjunctiveValue, there is only one "value" associated with a disjunction: it's the first one that "works." For consistency within the entire Fs*Value set, the attribute for FsDisjunctiveValue is in the singular as "Value" rather than "Values" even though it is a collection.
Value | Association from Package Cellar
Value | Association from Package Cellar
Value | Attribute from Class FsOpenValue
Values | Association from Package Cellar
ValueState | Attribute from Class FsFeatureSpecification
VariantEntryTypes | Association from Package Cellar | This Variant Entry Types list is used to classify a LexEntryRef via VariantEntryTypes. ItemClsid should be set to LexEntryType, IsSorted to true, and Depth to 127. The list is hierarchical with the top level being the type of variant (e.g., dialectal) and subitems being the conditions (e.g., British English, American English) for that type of variant. Normally the user will set this property to a subitem, although a top level item could be used if the user does not want to specify the condition. The user is free to provide additional nesting if useful. All items in the list will be LexEntryType, so the user will need to specify an appropriate Abbreviation and ReverseAbbr for each item in the list. This gives greater control to the user than having the program try to piece together information from a hierarchy of LexEntryTypes. The Abbreviation is used when displaying the main entry from the minor entry (e.g., Brit. dial. of color). The ReverseAbbr is used when displaying the minor entry from the main entry (e.g., Brit. dial. colour). Entries using this list will be displayed as minor entries in the dictionary; usually following the main entry headword and will typically produce a separate minor entry in the dictionary referring to the main entry. The initial list may have: Dialectal Variant British American Free Variant Inflectional Variant Singular Plural First Person Singular (1SG) Third Person Singular Present (3SG.PRES) Location New York Los Angeles Register Formal Informal Sociolect Upper Class Lower Class Spelling Variant
VariantEntryTypes | Association from Package Ling | This points to one or more LexEntryType items in the Variant Entry Types list for variant entries. It is unused for complex entries, although the model allows for both to be used if desirable. Normally a variant LexEntryRef will only use PrimaryLexemes to point to a single entry or sense. Entries using VariantEntryTypes will be displayed as minor entries in the dictionary; usually following the main entry headword and will typically produce a separate minor entry in the dictionary referring to the main entry. The LexEntryType is used to determine how to display the variant information in the main entry context as well as the minor entry context. The Variant Entry Types list is hierarchical with the top level being the type of variant (e.g., dialectal) and subitems being the conditions (e.g., British English, American English) for that type of variant. Normally the user will set this property to a subitem, although a top level item could be used if the user does not want to specify the condition. Each LexEntryType Abbreviation and ReverseAbbr should contain everything needed for displaying the references for this entry. Flex will not attempt to combine names from different hierarchical levels. The Abbreviation is used when displaying the main entry from the minor entry (e.g., Brit. dial. of color). The ReverseAbbr is used when displaying the minor entry from the main entry (e.g., Brit. dial. colour). This is a sequence because some minor entries can have more than one relationship to the same main entry. For example, colour is a spelling variant and a British dialectal variant. The user could use two LexEntryRefs to represent this, but it would be easier to use a single LexEntryRef with two VariantEntryTypes references.
VernWss | Attribute from Class LangProject | Changed from VernacularWritingSystems This is a space-delimited list of writing system tags.
VersePunct | Attribute from Class Scripture | String of zero or more vernacular punctuation characters that will be appended automatically to all inserted verse numbers. Null by default.
VerseRefEnd | Attribute from Class ScrSection | Refer to doc for VerseRefStart
VerseRefMax | Attribute from Class ScrSection | The maximum book-chapter-verse reference found within the section. This is a calculated property, stored for processing convenience, not primary data.
VerseRefMin | Attribute from Class ScrSection | The minimum book-chapter-verse reference found within the section. This is a calculated property, stored for processing convenience, not primary data.
VerseRefStart | Attribute from Class ScrSection | VerseRefStart and VerseRefEnd are integers that contain book, chapter, and verse numbers in the form BBCCCVVV. Together these two properties indicate the range of references spanned by a Scripture section. Note that the the first two digits (the book part) should always be identical and is redundant since the ScrSection is owned by a ScrBook. Reasons for change: This change allows us to: a. Prepare to remove the Reference string from the StTxtPara object; b. Display appropriate references in the concordance for words that appear in section headings; c. Know what Scripture is covered by a particular section without parsing all the paragraphs it contains or accessing the ScrRef table; d. Prepare for the possibility of having chapter breaks embedded inside paragraphs.
VerseSepr | Attribute from Class Scripture | VerseSepr is a string (usually one character) that separates non-contiguous verse numbers in a list. In the U.S.A., this is traditionally a comma (,), e.g., Mat 24:16,25.
Versification | Attribute from Class Scripture | Designates one of a several versification schemes. A versification scheme defines how the content of each book of the Bible is partitioned into verses and defines the reference (chapter and verse number) for each verse. Translation Editor determines the number of verses in each chapter based on the versification scheme. Versification is to be enumerated as follows (matches Paratext versification schemes): (0) - Unknown (1) - Original, Masoretic for OT, Nestle-Aland for NT (2) - Septuagint for (OT) (3) - Vulgate, like the Latin Vulgate, used by many modern versions including French (4) - English, like the RSV, used by many translations patterned on the English text. (5) - Custom, user specified (not yet implemented in Paratext)
Version | Attribute from Class CmResource | Version number for the external resource, stored in the database to determine when the version number in the external copy no longer matches.
Version | Attribute from Class CmAgent | This attribute is not finalized but for now possible values include:Normal - represents the parser using the current state of the grammar and lexicon. Debug - represents the parser using a limited grammar (user has turned off some group of constraints) Milestone - represents the parser using a particular grammar and lexicon at a particular time as recorded on CmObject (date created). Works in conjunction with StateInformation.
VersionHistory | Association from Package Notebk | A collection of versions that the record has gone through. This includes an archival of previous versions of the actual records.
Visibility | Attribute from Class UserViewField
void | DataType from Package Data types
W
WfiAnalysis | Class from Package Ling | The WfiAnalysis class contains an analysis for a given wordform, which is defined as how to make morpheme cuts on the wordform, a part of speech for the wordform, plus a sequence of one or more corresponding interpretations of te analysis. Thus English bears would have one analysis related to the animal, and another related to the verb to carry.
WfiGloss | Class from Package Ling | The WfiGloss class contains a meaning of the parent interpretation. For example, the senses in the parent interpretation might be 3S-Carry; the meanings could then be 'he carries', 'she carries', 'it carries'.
WfiMorphBundle | Class from Package Ling
WfiWordform | Class from Package Ling | The WfiWordform class contains information about an individual wordform, including its various analyses.
WfiWordSet | Class from Package Ling
Wordform Inventory | Class Diagram
WordFormLookup | Class from Package Ling | Renameed from WordformLookupItem for the Firebird Port.
WordformLookupList | Class from Package Ling
WordformLookupLists | Association from Package LangProj
Wordforms | Association from Package Ling
WordGroup | Association from Package Ling | The target ConstChartWordGroup is in the column that shows the actual position of the text, while the marker indicates where the ￢ﾀﾜsomething was moved from here￢ﾀﾝ marker should appear. WordGroup is bidirectional on purpose. We need to maintain a back-reference here.
WorldRegion | Attribute from Class LangProject
WritingSystem | Attribute from Class FsOpenFeature
WritingSystem | Attribute from Class ReversalIndex
WritingSystem | Attribute from Class UserViewField
WritingSystem | Attribute from Class CmPossibilityList
WritingSystem | Attribute from Class CmBaseAnnotation
WritingSystem | Attribute from Class WordformLookupList
WsSelector | Attribute from Class CmPossibilityList | // the application to get the appropriate writing system from the application. For example, // a language project has a list of one or more analysis encodings. kwsAnal would // tell the program to use the first writing system in this list. #define kwsAnal 0xffffffff // (-1) The first analysis writing system. #define kwsVern 0xfffffffe // (-2) The first vernacular writing system. #define kwsAnals 0xfffffffd // (-3) All analysis writing system. #define kwsVerns 0xfffffffc // (-4) All vernacular writing system. #define kwsAnalVerns 0xfffffffb // (-5) All analysis then All vernacular writing system. #define kwsVernAnals 0xfffffffa // (-6) All vernacular then All analysis writing system. #define kwsLim 0xfffffff9 // (-7) One beyond the last magic value.
WsSelector | Attribute from Class UserViewField | Refer to documentation on CmPossibilityList_WsSelector.
WsSelector | Attribute from Class CmBaseAnnotation | Refer to documentation on CmPossibilityList_WsSelector.
WsSelector | Attribute from Class FsOpenFeature | Refer to documentation on CmPossibilityList_WsSelector.
Z
ZeroWidth | Attribute from Class CmAnnotationDefn | T = Annotations of this type are have the same Begin and EndOffset and thus zeroWidth. Potential example: footnotes markers.
Symbol
***Legend for CELLAR Diagrams | Class Diagram
Unnamed
<unnamed> | AssociationEnd from Association Slots
<unnamed> | AssociationEnd from Association Slots
<unnamed> | AssociationEnd from Association LexemeForm
<unnamed> | AssociationEnd from Association LexemeForm
<unnamed> | AssociationEnd from Association AlternateForms
<unnamed> | AssociationEnd from Association AlternateForms
<unnamed> | AssociationEnd from Association Pictures
<unnamed> | AssociationEnd from Association Pictures
<unnamed> | AssociationEnd from Association OverridingMsa
<unnamed> | AssociationEnd from Association OverridingMsa
<unnamed> | AssociationEnd from Association ProdRestrict
<unnamed> | AssociationEnd from Association ProdRestrict
<unnamed> | AssociationEnd from Association ProdRestrict
<unnamed> | AssociationEnd from Association ProdRestrict
<unnamed> | AssociationEnd from Association ToProdRestrict
<unnamed> | AssociationEnd from Association ToProdRestrict
<unnamed> | AssociationEnd from Association FromProdRestrict
<unnamed> | AssociationEnd from Association FromProdRestrict
<unnamed> | AssociationEnd from Association FromProdRestrict
<unnamed> | AssociationEnd from Association FromProdRestrict
<unnamed> | AssociationEnd from Association ProdRestrict
<unnamed> | AssociationEnd from Association ProdRestrict
<unnamed> | AssociationEnd from Association ToProdRestrict
<unnamed> | AssociationEnd from Association ToProdRestrict
<unnamed> | AssociationEnd from Association Pronunciations
<unnamed> | AssociationEnd from Association Pronunciations
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association MediaFile
<unnamed> | AssociationEnd from Association MediaFile
<unnamed> | AssociationEnd from Association Media
<unnamed> | AssociationEnd from Association Media
<unnamed> | AssociationEnd from Association Location
<unnamed> | AssociationEnd from Association Location
<unnamed> | AssociationEnd from Association MediaFiles
<unnamed> | AssociationEnd from Association MediaFiles
<unnamed> | AssociationEnd from Association PictureFile
<unnamed> | AssociationEnd from Association PictureFile
<unnamed> | Generalization from Package Ling
<unnamed> | AssociationEnd from Association Books
<unnamed> | AssociationEnd from Association Books
<unnamed> | AssociationEnd from Association Sense
<unnamed> | AssociationEnd from Association Sense
<unnamed> | AssociationEnd from Association ChkHistRecs
<unnamed> | AssociationEnd from Association ChkHistRecs
<unnamed> | Generalization
<unnamed> | Class
<unnamed> | Class
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association EntryRefs
<unnamed> | AssociationEnd from Association EntryRefs
<unnamed> | AssociationEnd from Association ComponentLexemes
<unnamed> | AssociationEnd from Association ComponentLexemes
<unnamed> | AssociationEnd from Association VariantEntryTypes
<unnamed> | AssociationEnd from Association VariantEntryTypes
<unnamed> | AssociationEnd from Association ComplexEntryTypes
<unnamed> | AssociationEnd from Association ComplexEntryTypes
<unnamed> | AssociationEnd from Association VariantEntryTypes
<unnamed> | AssociationEnd from Association VariantEntryTypes
<unnamed> | AssociationEnd from Association ComplexEntryTypes
<unnamed> | AssociationEnd from Association ComplexEntryTypes
<unnamed> | AssociationEnd from Association PrimaryLexemes
<unnamed> | AssociationEnd from Association PrimaryLexemes
<unnamed> | AssociationEnd from Association PhFeatureSystem
<unnamed> | AssociationEnd from Association PhFeatureSystem
<unnamed> | AssociationEnd from Association FeatConstraints
<unnamed> | AssociationEnd from Association FeatConstraints
<unnamed> | AssociationEnd from Association PhonRuleFeats
<unnamed> | AssociationEnd from Association PhonRuleFeats
<unnamed> | AssociationEnd from Association Features
<unnamed> | AssociationEnd from Association Features
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | AssociationEnd from Association Item
<unnamed> | AssociationEnd from Association Item
<unnamed> | AssociationEnd from Association PhonRules
<unnamed> | AssociationEnd from Association PhonRules
<unnamed> | AssociationEnd from Association InitialStratum
<unnamed> | AssociationEnd from Association InitialStratum
<unnamed> | AssociationEnd from Association FinalStratum
<unnamed> | AssociationEnd from Association FinalStratum
<unnamed> | AssociationEnd from Association LeftContext
<unnamed> | AssociationEnd from Association LeftContext
<unnamed> | AssociationEnd from Association RightContext
<unnamed> | AssociationEnd from Association RightContext
<unnamed> | AssociationEnd from Association StrucChange
<unnamed> | AssociationEnd from Association StrucChange
<unnamed> | AssociationEnd from Association InputPOSes
<unnamed> | AssociationEnd from Association InputPOSes
<unnamed> | AssociationEnd from Association ExclRuleFeats
<unnamed> | AssociationEnd from Association ExclRuleFeats
<unnamed> | AssociationEnd from Association ReqRuleFeats
<unnamed> | AssociationEnd from Association ReqRuleFeats
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association RightHandSides
<unnamed> | AssociationEnd from Association RightHandSides
<unnamed> | AssociationEnd from Association StrucDesc
<unnamed> | AssociationEnd from Association StrucDesc
<unnamed> | AssociationEnd from Association TextMarkupTags
<unnamed> | AssociationEnd from Association TextMarkupTags
<unnamed> | AssociationEnd from Association SupportingEvidence
<unnamed> | AssociationEnd from Association SupportingEvidence
<unnamed> | AssociationEnd from Association CounterEvidence
<unnamed> | AssociationEnd from Association CounterEvidence
<unnamed> | AssociationEnd from Association SupersededBy
<unnamed> | AssociationEnd from Association SupersededBy
<unnamed> | AssociationEnd from Association Status
<unnamed> | AssociationEnd from Association Status
<unnamed> | AssociationEnd from Association Hypothesis
<unnamed> | AssociationEnd from Association Hypothesis
<unnamed> | AssociationEnd from Association Conclusions
<unnamed> | AssociationEnd from Association Conclusions
<unnamed> | AssociationEnd from Association Discussion
<unnamed> | AssociationEnd from Association Discussion
<unnamed> | AssociationEnd from Association ResearchPlan
<unnamed> | AssociationEnd from Association ResearchPlan
<unnamed> | AssociationEnd from Association Sources
<unnamed> | AssociationEnd from Association Sources
<unnamed> | AssociationEnd from Association Participants
<unnamed> | AssociationEnd from Association Participants
<unnamed> | AssociationEnd from Association Type
<unnamed> | AssociationEnd from Association Type
<unnamed> | AssociationEnd from Association TimeOfEvent
<unnamed> | AssociationEnd from Association TimeOfEvent
<unnamed> | AssociationEnd from Association Description
<unnamed> | AssociationEnd from Association Description
<unnamed> | AssociationEnd from Association PersonalNotes
<unnamed> | AssociationEnd from Association PersonalNotes
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association Locations
<unnamed> | AssociationEnd from Association Locations
<unnamed> | Interface
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association Paragraphs
<unnamed> | AssociationEnd from Association Paragraphs
<unnamed> | AssociationEnd from Association EndSegment
<unnamed> | AssociationEnd from Association EndSegment
<unnamed> | AssociationEnd from Association Tag
<unnamed> | AssociationEnd from Association Tag
<unnamed> | AssociationEnd from Association Tags
<unnamed> | AssociationEnd from Association Tags
<unnamed> | AssociationEnd from Association Notes
<unnamed> | AssociationEnd from Association Notes
<unnamed> | Class
<unnamed> | AssociationEnd from Association Rows
<unnamed> | AssociationEnd from Association Rows
<unnamed> | AssociationEnd from Association DependentClauses
<unnamed> | AssociationEnd from Association DependentClauses
<unnamed> | AssociationEnd from Association Tag
<unnamed> | AssociationEnd from Association Tag
<unnamed> | AssociationEnd from Association BeginSegment
<unnamed> | AssociationEnd from Association BeginSegment
<unnamed> | AssociationEnd from Association EndSegment
<unnamed> | AssociationEnd from Association EndSegment
<unnamed> | AssociationEnd from Association WordGroup
<unnamed> | AssociationEnd from Association WordGroup
<unnamed> | AssociationEnd from Association Column
<unnamed> | AssociationEnd from Association Column
<unnamed> | AssociationEnd from Association Cells
<unnamed> | AssociationEnd from Association Cells
<unnamed> | AssociationEnd from Association Analyses
<unnamed> | AssociationEnd from Association Analyses
<unnamed> | AssociationEnd from Association Segments
<unnamed> | AssociationEnd from Association Segments
<unnamed> | AssociationEnd from Association BeginSegment
<unnamed> | AssociationEnd from Association BeginSegment
<unnamed> | AssociationEnd from Association Approves
<unnamed> | AssociationEnd from Association Approves
<unnamed> | AssociationEnd from Association Disproves
<unnamed> | AssociationEnd from Association Disproves
<unnamed> | AssociationEnd from Association Evaluations
<unnamed> | AssociationEnd from Association Evaluations
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Possibilities
<unnamed> | AssociationEnd from Association Possibilities
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Resources
<unnamed> | AssociationEnd from Association Resources
<unnamed> | AssociationEnd from Association Resources
<unnamed> | AssociationEnd from Association Resources
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association Template
<unnamed> | AssociationEnd from Association Template
<unnamed> | AssociationEnd from Association BasedOn
<unnamed> | AssociationEnd from Association BasedOn
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association ConstChartTempl
<unnamed> | AssociationEnd from Association ConstChartTempl
<unnamed> | AssociationEnd from Association Charts
<unnamed> | AssociationEnd from Association Charts
<unnamed> | AssociationEnd from Association DiscourseData
<unnamed> | AssociationEnd from Association DiscourseData
<unnamed> | Generalization from Package Ling
<unnamed> | AssociationEnd from Association SurfaceForm
<unnamed> | AssociationEnd from Association SurfaceForm
<unnamed> | AssociationEnd from Association Meaning
<unnamed> | AssociationEnd from Association Meaning
<unnamed> | AssociationEnd from Association Renderings
<unnamed> | AssociationEnd from Association Renderings
<unnamed> | AssociationEnd from Association ScriptureSources
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association ScriptureSources
<unnamed> | AssociationEnd from Association ScriptureMappings
<unnamed> | AssociationEnd from Association ScriptureMappings
<unnamed> | AssociationEnd from Association BackTransSources
<unnamed> | AssociationEnd from Association NoteMappings
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association NoteMappings
<unnamed> | AssociationEnd from Association NoteSources
<unnamed> | AssociationEnd from Association NoteSources
<unnamed> | AssociationEnd from Association BackTransSources
<unnamed> | AssociationEnd from Association ImportSettings
<unnamed> | AssociationEnd from Association ImportSettings
<unnamed> | Generalization
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association Style
<unnamed> | AssociationEnd from Association Style
<unnamed> | AssociationEnd from Association Files
<unnamed> | AssociationEnd from Association Files
<unnamed> | AssociationEnd from Association NoteType
<unnamed> | AssociationEnd from Association NoteType
<unnamed> | AssociationEnd from Association NoteType
<unnamed> | AssociationEnd from Association NoteType
<unnamed> | AssociationEnd from Association Quote
<unnamed> | AssociationEnd from Association Recommendation
<unnamed> | AssociationEnd from Association Responses
<unnamed> | AssociationEnd from Association Discussion
<unnamed> | AssociationEnd from Association Resolution
<unnamed> | AssociationEnd from Association Discussion
<unnamed> | AssociationEnd from Association Recommendation
<unnamed> | AssociationEnd from Association Resolution
<unnamed> | AssociationEnd from Association Quote
<unnamed> | AssociationEnd from Association Responses
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association CreatedBy
<unnamed> | AssociationEnd from Association CreatedBy
<unnamed> | AssociationEnd from Association ModifiedBy
<unnamed> | AssociationEnd from Association ModifiedBy
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Categories
<unnamed> | AssociationEnd from Association Categories
<unnamed> | AssociationEnd from Association Notes
<unnamed> | AssociationEnd from Association Notes
<unnamed> | AssociationEnd from Association BookAnnotations
<unnamed> | AssociationEnd from Association BookAnnotations
<unnamed> | AssociationEnd from Association NoteCategories
<unnamed> | AssociationEnd from Association NoteCategories
<unnamed> | Generalization from Package Scripture
<unnamed> | AssociationEnd from Association MainEntriesOrSenses
<unnamed> | AssociationEnd from Association MainEntriesOrSenses
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association References
<unnamed> | AssociationEnd from Association References
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association Members
<unnamed> | AssociationEnd from Association Members
<unnamed> | Generalization from Package Ling
<unnamed> | AssociationEnd from Association Features
<unnamed> | AssociationEnd from Association Features
<unnamed> | AssociationEnd from Association Features
<unnamed> | AssociationEnd from Association Features
<unnamed> | AssociationEnd from Association Targets
<unnamed> | AssociationEnd from Association Targets
<unnamed> | AssociationEnd from Association FromPartsOfSpeech
<unnamed> | AssociationEnd from Association FromPartsOfSpeech
<unnamed> | AssociationEnd from Association GenreList
<unnamed> | AssociationEnd from Association GenreList
<unnamed> | AssociationEnd from Association Genres
<unnamed> | AssociationEnd from Association Genres
<unnamed> | AssociationEnd from Association ChartMarkers
<unnamed> | AssociationEnd from Association ChartMarkers
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association ReversalIndexes
<unnamed> | AssociationEnd from Association ReversalIndexes
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association Appendixes
<unnamed> | AssociationEnd from Association Appendixes
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | AssociationEnd from Association Analyses
<unnamed> | AssociationEnd from Association Analyses
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association ToPartOfSpeech
<unnamed> | AssociationEnd from Association ToPartOfSpeech
<unnamed> | AssociationEnd from Association FromPartOfSpeech
<unnamed> | AssociationEnd from Association FromPartOfSpeech
<unnamed> | AssociationEnd from Association PhoneEnv
<unnamed> | AssociationEnd from Association PhoneEnv
<unnamed> | AssociationEnd from Association Position
<unnamed> | AssociationEnd from Association Position
<unnamed> | AssociationEnd from Association PhoneEnv
<unnamed> | AssociationEnd from Association PhoneEnv
<unnamed> | AssociationEnd from Association MsFeatures
<unnamed> | AssociationEnd from Association MsFeatures
<unnamed> | AssociationEnd from Association InherFeatVal
<unnamed> | AssociationEnd from Association InherFeatVal
<unnamed> | AssociationEnd from Association ReferenceForms
<unnamed> | AssociationEnd from Association ReferenceForms
<unnamed> | AssociationEnd from Association EmptyParadigmCells
<unnamed> | AssociationEnd from Association EmptyParadigmCells
<unnamed> | AssociationEnd from Association DefaultFeatures
<unnamed> | AssociationEnd from Association DefaultFeatures
<unnamed> | AssociationEnd from Association AffixCategory
<unnamed> | AssociationEnd from Association AffixCategory
<unnamed> | AssociationEnd from Association InflFeats
<unnamed> | AssociationEnd from Association InflFeats
<unnamed> | AssociationEnd from Association MsEnvPartOfSpeech
<unnamed> | AssociationEnd from Association MsEnvPartOfSpeech
<unnamed> | AssociationEnd from Association AffixTemplates
<unnamed> | AssociationEnd from Association AffixTemplates
<unnamed> | AssociationEnd from Association AffixSlots
<unnamed> | AssociationEnd from Association AffixSlots
<unnamed> | AssociationEnd from Association InflTemplateApps
<unnamed> | AssociationEnd from Association InflTemplateApps
<unnamed> | AssociationEnd from Association MsFeatures
<unnamed> | AssociationEnd from Association MsFeatures
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | AssociationEnd from Association CheckLists
<unnamed> | AssociationEnd from Association CheckLists
<unnamed> | AssociationEnd from Association Occurrences
<unnamed> | AssociationEnd from Association Occurrences
<unnamed> | AssociationEnd from Association Rendering
<unnamed> | AssociationEnd from Association Rendering
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | AssociationEnd from Association SenseTypes
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | AssociationEnd from Association SenseTypes
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Ling
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association InflFeats
<unnamed> | AssociationEnd from Association AllomorphIndex
<unnamed> | AssociationEnd from Association InflFeats
<unnamed> | AssociationEnd from Association AllomorphIndex
<unnamed> | AssociationEnd from Association Environments
<unnamed> | AssociationEnd from Association StemForm
<unnamed> | AssociationEnd from Association Entries
<unnamed> | AssociationEnd from Association Entries
<unnamed> | AssociationEnd from Association Environments
<unnamed> | AssociationEnd from Association StemForm
<unnamed> | AssociationEnd from Association PartsOfSpeech
<unnamed> | AssociationEnd from Association Regions
<unnamed> | AssociationEnd from Association PartsOfSpeech
<unnamed> | AssociationEnd from Association Regions
<unnamed> | AssociationEnd from Association UsageTypes
<unnamed> | AssociationEnd from Association StemMsa
<unnamed> | AssociationEnd from Association StemMsa
<unnamed> | AssociationEnd from Association UsageTypes
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association FeatureStructure
<unnamed> | AssociationEnd from Association FeatureStructure
<unnamed> | AssociationEnd from Association FeatureStructure
<unnamed> | AssociationEnd from Association FeatureStructure
<unnamed> | AssociationEnd from Association ReversalEntries
<unnamed> | AssociationEnd from Association CompoundRuleApps
<unnamed> | AssociationEnd from Association ReversalEntries
<unnamed> | AssociationEnd from Association Slots
<unnamed> | AssociationEnd from Association Slots
<unnamed> | AssociationEnd from Association CompoundRuleApps
<unnamed> | AssociationEnd from Association RightMsa
<unnamed> | AssociationEnd from Association DerivAffApp
<unnamed> | AssociationEnd from Association RightMsa
<unnamed> | AssociationEnd from Association DerivAffApp
<unnamed> | AssociationEnd from Association InflectionClass
<unnamed> | AssociationEnd from Association Entries
<unnamed> | AssociationEnd from Association ReferenceForms
<unnamed> | AssociationEnd from Association ReferenceForms
<unnamed> | AssociationEnd from Association Entries
<unnamed> | AssociationEnd from Association InflectionClass
<unnamed> | AssociationEnd from Association Strata
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association Strata
<unnamed> | AssociationEnd from Association MsFeatures
<unnamed> | AssociationEnd from Association AdhocCoProhibitions
<unnamed> | AssociationEnd from Association Template
<unnamed> | AssociationEnd from Association AdhocCoProhibitions
<unnamed> | AssociationEnd from Association StemNames
<unnamed> | AssociationEnd from Association SenseType
<unnamed> | AssociationEnd from Association AffixMsa
<unnamed> | AssociationEnd from Association AffixMsa
<unnamed> | AssociationEnd from Association MsFeatures
<unnamed> | AssociationEnd from Association Template
<unnamed> | AssociationEnd from Association StemNames
<unnamed> | AssociationEnd from Association SenseType
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association TestSets
<unnamed> | AssociationEnd from Association Senses
<unnamed> | AssociationEnd from Association InflectableFeats
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association Morphemes
<unnamed> | AssociationEnd from Association InflectableFeats
<unnamed> | AssociationEnd from Association TestSets
<unnamed> | AssociationEnd from Association Senses
<unnamed> | AssociationEnd from Association Morphemes
<unnamed> | AssociationEnd from Association MorphTypes
<unnamed> | AssociationEnd from Association Type
<unnamed> | AssociationEnd from Association Cases
<unnamed> | AssociationEnd from Association Subclasses
<unnamed> | AssociationEnd from Association Type
<unnamed> | AssociationEnd from Association MorphTypes
<unnamed> | AssociationEnd from Association Cases
<unnamed> | AssociationEnd from Association Subclasses
<unnamed> | AssociationEnd from Association FromStemName
<unnamed> | AssociationEnd from Association InflectionClasses
<unnamed> | AssociationEnd from Association FromStemName
<unnamed> | AssociationEnd from Association InflectionClasses
<unnamed> | AssociationEnd from Association MorphoSyntaxAnalysis
<unnamed> | AssociationEnd from Association Translations
<unnamed> | AssociationEnd from Association Output
<unnamed> | AssociationEnd from Association Translations
<unnamed> | AssociationEnd from Association MorphoSyntaxAnalysis
<unnamed> | AssociationEnd from Association Output
<unnamed> | AssociationEnd from Association LeftContext
<unnamed> | AssociationEnd from Association Linker
<unnamed> | AssociationEnd from Association InflectionClass
<unnamed> | AssociationEnd from Association Content
<unnamed> | AssociationEnd from Association Content
<unnamed> | AssociationEnd from Association Linker
<unnamed> | AssociationEnd from Association NaturalClasses
<unnamed> | AssociationEnd from Association NaturalClasses
<unnamed> | AssociationEnd from Association LeftContext
<unnamed> | AssociationEnd from Association InflectionClass
<unnamed> | AssociationEnd from Association Wordforms
<unnamed> | AssociationEnd from Association Components
<unnamed> | AssociationEnd from Association Components
<unnamed> | AssociationEnd from Association Wordforms
<unnamed> | AssociationEnd from Association MorphoSyntaxAnalyses
<unnamed> | AssociationEnd from Association DomainTypes
<unnamed> | AssociationEnd from Association MorphoSyntaxAnalyses
<unnamed> | AssociationEnd from Association Content
<unnamed> | AssociationEnd from Association Stems
<unnamed> | AssociationEnd from Association Content
<unnamed> | AssociationEnd from Association DomainTypes
<unnamed> | AssociationEnd from Association Stems
<unnamed> | AssociationEnd from Association AffixMsa
<unnamed> | AssociationEnd from Association PRuleApps
<unnamed> | AssociationEnd from Association RightContext
<unnamed> | AssociationEnd from Association RightContext
<unnamed> | AssociationEnd from Association DefaultAffix
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association DefaultAffix
<unnamed> | AssociationEnd from Association PartOfSpeech
<unnamed> | AssociationEnd from Association PRuleApps
<unnamed> | AssociationEnd from Association AffixMsa
<unnamed> | AssociationEnd from Association PlusConstr
<unnamed> | AssociationEnd from Association DefaultStem
<unnamed> | AssociationEnd from Association AnthroCodes
<unnamed> | AssociationEnd from Association AnthroCodes
<unnamed> | AssociationEnd from Association PlusConstr
<unnamed> | AssociationEnd from Association Slot
<unnamed> | AssociationEnd from Association DefaultStem
<unnamed> | AssociationEnd from Association Codes
<unnamed> | AssociationEnd from Association Contexts
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association Slot
<unnamed> | AssociationEnd from Association Contexts
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association Contents
<unnamed> | AssociationEnd from Association SlotApps
<unnamed> | AssociationEnd from Association Contents
<unnamed> | AssociationEnd from Association Examples
<unnamed> | AssociationEnd from Association SlotApps
<unnamed> | AssociationEnd from Association MorphType
<unnamed> | AssociationEnd from Association MorphType
<unnamed> | AssociationEnd from Association Examples
<unnamed> | AssociationEnd from Association Codes
<unnamed> | AssociationEnd from Association StratumApps
<unnamed> | AssociationEnd from Association StemNames
<unnamed> | AssociationEnd from Association Phonemes
<unnamed> | AssociationEnd from Association Phonemes
<unnamed> | AssociationEnd from Association StratumApps
<unnamed> | AssociationEnd from Association StemNames
<unnamed> | AssociationEnd from Association InflectionClasses
<unnamed> | AssociationEnd from Association DomainTypes
<unnamed> | AssociationEnd from Association DomainTypes
<unnamed> | AssociationEnd from Association ToMsa
<unnamed> | AssociationEnd from Association InflectionClasses
<unnamed> | AssociationEnd from Association ToMsa
<unnamed> | AssociationEnd from Association PrefixSlots
<unnamed> | AssociationEnd from Association MinusConstr
<unnamed> | AssociationEnd from Association PrefixSlots
<unnamed> | AssociationEnd from Association MinusConstr
<unnamed> | AssociationEnd from Association Content
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Content
<unnamed> | AssociationEnd from Association UsageTypes
<unnamed> | AssociationEnd from Association UsageTypes
<unnamed> | AssociationEnd from Association Input
<unnamed> | AssociationEnd from Association Feature
<unnamed> | AssociationEnd from Association Feature
<unnamed> | AssociationEnd from Association RulesOfReferral
<unnamed> | AssociationEnd from Association Input
<unnamed> | AssociationEnd from Association RulesOfReferral
<unnamed> | AssociationEnd from Association Members
<unnamed> | AssociationEnd from Association RulesOfReferral
<unnamed> | AssociationEnd from Association RulesOfReferral
<unnamed> | AssociationEnd from Association Members
<unnamed> | AssociationEnd from Association Member
<unnamed> | AssociationEnd from Association Member
<unnamed> | AssociationEnd from Association Introduction
<unnamed> | AssociationEnd from Association Description
<unnamed> | AssociationEnd from Association ThesaurusItems
<unnamed> | AssociationEnd from Association ThesaurusItems
<unnamed> | AssociationEnd from Association Description
<unnamed> | AssociationEnd from Association Introduction
<unnamed> | AssociationEnd from Association PhonemeSets
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association LeftForm
<unnamed> | AssociationEnd from Association AnthroCodes
<unnamed> | AssociationEnd from Association LeftForm
<unnamed> | AssociationEnd from Association Rule
<unnamed> | AssociationEnd from Association AnthroCodes
<unnamed> | AssociationEnd from Association ThesaurusItems
<unnamed> | AssociationEnd from Association Segments
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association ThesaurusItems
<unnamed> | AssociationEnd from Association Segments
<unnamed> | AssociationEnd from Association Subentries
<unnamed> | AssociationEnd from Association ToInflectionClass
<unnamed> | AssociationEnd from Association Senses
<unnamed> | AssociationEnd from Association Senses
<unnamed> | AssociationEnd from Association PhonemeSets
<unnamed> | AssociationEnd from Association ToInflectionClass
<unnamed> | AssociationEnd from Association Rule
<unnamed> | AssociationEnd from Association Subentries
<unnamed> | AssociationEnd from Association ToMsFeatures
<unnamed> | AssociationEnd from Association AnalyzingAgents
<unnamed> | AssociationEnd from Association AnalyzingAgents
<unnamed> | AssociationEnd from Association Phonemes
<unnamed> | AssociationEnd from Association ToMsFeatures
<unnamed> | AssociationEnd from Association Phonemes
<unnamed> | AssociationEnd from Association Linker
<unnamed> | AssociationEnd from Association AffixForm
<unnamed> | AssociationEnd from Association AffixForm
<unnamed> | AssociationEnd from Association Linker
<unnamed> | AssociationEnd from Association OutputMsa
<unnamed> | AssociationEnd from Association Features
<unnamed> | AssociationEnd from Association DefaultInflectionClass
<unnamed> | AssociationEnd from Association OutputMsa
<unnamed> | AssociationEnd from Association BoundaryMarkers
<unnamed> | AssociationEnd from Association CompoundRules
<unnamed> | AssociationEnd from Association DefaultInflectionClass
<unnamed> | AssociationEnd from Association Features
<unnamed> | AssociationEnd from Association CompoundRules
<unnamed> | AssociationEnd from Association BoundaryMarkers
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association Derivation
<unnamed> | AssociationEnd from Association Region
<unnamed> | AssociationEnd from Association AffixCategory
<unnamed> | AssociationEnd from Association Derivation
<unnamed> | AssociationEnd from Association AffixForm
<unnamed> | AssociationEnd from Association AffixForm
<unnamed> | AssociationEnd from Association Appendixes
<unnamed> | AssociationEnd from Association Region
<unnamed> | AssociationEnd from Association Stratum
<unnamed> | AssociationEnd from Association Appendixes
<unnamed> | AssociationEnd from Association Content
<unnamed> | AssociationEnd from Association LexicalFormIndex
<unnamed> | AssociationEnd from Association AffixCategory
<unnamed> | AssociationEnd from Association Content
<unnamed> | AssociationEnd from Association BearableFeatures
<unnamed> | AssociationEnd from Association FromMsFeatures
<unnamed> | AssociationEnd from Association Output
<unnamed> | AssociationEnd from Association BearableFeatures
<unnamed> | AssociationEnd from Association FromMsFeatures
<unnamed> | AssociationEnd from Association LexicalFormIndex
<unnamed> | AssociationEnd from Association Category
<unnamed> | AssociationEnd from Association Category
<unnamed> | AssociationEnd from Association Output
<unnamed> | AssociationEnd from Association TemplateApp
<unnamed> | AssociationEnd from Association RightForm
<unnamed> | AssociationEnd from Association StemName
<unnamed> | AssociationEnd from Association RightForm
<unnamed> | AssociationEnd from Association LeftMsa
<unnamed> | AssociationEnd from Association FeatureStructure
<unnamed> | AssociationEnd from Association SuffixSlots
<unnamed> | AssociationEnd from Association TemplateApp
<unnamed> | AssociationEnd from Association StemName
<unnamed> | AssociationEnd from Association Modification
<unnamed> | AssociationEnd from Association LeftMsa
<unnamed> | AssociationEnd from Association Modification
<unnamed> | AssociationEnd from Association MsEnvFeatures
<unnamed> | AssociationEnd from Association FeatureStructure
<unnamed> | AssociationEnd from Association MsEnvFeatures
<unnamed> | AssociationEnd from Association Allomorphs
<unnamed> | AssociationEnd from Association Input
<unnamed> | AssociationEnd from Association Allomorphs
<unnamed> | AssociationEnd from Association SuffixSlots
<unnamed> | AssociationEnd from Association Input
<unnamed> | AssociationEnd from Association FromInflectionClass
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Value
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association InflectionalFeats
<unnamed> | AssociationEnd from Association FromInflectionClass
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Value
<unnamed> | AssociationEnd from Association InflectionalFeats
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Type
<unnamed> | AssociationEnd from Association FeatureSpecs
<unnamed> | AssociationEnd from Association Types
<unnamed> | AssociationEnd from Association Values
<unnamed> | AssociationEnd from Association Types
<unnamed> | AssociationEnd from Association Values
<unnamed> | AssociationEnd from Association FeatureDisjunctions
<unnamed> | AssociationEnd from Association FeatureDisjunctions
<unnamed> | AssociationEnd from Association Type
<unnamed> | AssociationEnd from Association Contents
<unnamed> | AssociationEnd from Association FeatureSpecs
<unnamed> | AssociationEnd from Association Contents
<unnamed> | AssociationEnd from Association Feature
<unnamed> | AssociationEnd from Association Value
<unnamed> | AssociationEnd from Association Type
<unnamed> | AssociationEnd from Association Value
<unnamed> | AssociationEnd from Association Value
<unnamed> | AssociationEnd from Association Type
<unnamed> | AssociationEnd from Association ScriptureBooks
<unnamed> | AssociationEnd from Association Value
<unnamed> | AssociationEnd from Association Value
<unnamed> | AssociationEnd from Association Default
<unnamed> | AssociationEnd from Association Styles
<unnamed> | AssociationEnd from Association Feature
<unnamed> | AssociationEnd from Association Value
<unnamed> | AssociationEnd from Association Value
<unnamed> | AssociationEnd from Association Value
<unnamed> | AssociationEnd from Association ScriptureBooks
<unnamed> | AssociationEnd from Association Default
<unnamed> | AssociationEnd from Association Styles
<unnamed> | AssociationEnd from Association Sections
<unnamed> | AssociationEnd from Association Title
<unnamed> | AssociationEnd from Association Title
<unnamed> | AssociationEnd from Association BookId
<unnamed> | AssociationEnd from Association Content
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Sections
<unnamed> | AssociationEnd from Association BookId
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Content
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Heading
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Heading
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Notebk
<unnamed> | Generalization from Package Notebk
<unnamed> | Generalization from Package Notebk
<unnamed> | Generalization from Package Notebk
<unnamed> | AssociationEnd from Association Positions
<unnamed> | AssociationEnd from Association Positions
<unnamed> | AssociationEnd from Association BasedOn
<unnamed> | AssociationEnd from Association BasedOn
<unnamed> | AssociationEnd from Association SubfieldOf
<unnamed> | AssociationEnd from Association PossList
<unnamed> | AssociationEnd from Association PossItems
<unnamed> | AssociationEnd from Association SubfieldOf
<unnamed> | AssociationEnd from Association Notes
<unnamed> | AssociationEnd from Association Paragraphs
<unnamed> | AssociationEnd from Association Status
<unnamed> | AssociationEnd from Association PlacesOfResidence
<unnamed> | AssociationEnd from Association PlacesOfResidence
<unnamed> | AssociationEnd from Association Notes
<unnamed> | AssociationEnd from Association PossItems
<unnamed> | AssociationEnd from Association Status
<unnamed> | AssociationEnd from Association AnalyzedTextObjects
<unnamed> | AssociationEnd from Association Paragraphs
<unnamed> | AssociationEnd from Association PossList
<unnamed> | AssociationEnd from Association AnalyzedTextObjects
<unnamed> | AssociationEnd from Association SubPossibilities
<unnamed> | AssociationEnd from Association Confidence
<unnamed> | AssociationEnd from Association Researchers
<unnamed> | AssociationEnd from Association Researchers
<unnamed> | AssociationEnd from Association SubPossibilities
<unnamed> | AssociationEnd from Association Discussion
<unnamed> | AssociationEnd from Association Records
<unnamed> | AssociationEnd from Association Discussion
<unnamed> | AssociationEnd from Association Confidence
<unnamed> | Attribute from Class CmLocation
<unnamed> | AssociationEnd from Association Records
<unnamed> | AssociationEnd from Association Fields
<unnamed> | AssociationEnd from Association Cells
<unnamed> | AssociationEnd from Association Next
<unnamed> | AssociationEnd from Association TextObjects
<unnamed> | AssociationEnd from Association Cells
<unnamed> | AssociationEnd from Association Fields
<unnamed> | AssociationEnd from Association TextObjects
<unnamed> | AssociationEnd from Association Next
<unnamed> | AssociationEnd from Association Rows
<unnamed> | AssociationEnd from Association Rows
<unnamed> | AssociationEnd from Association ObjRefs
<unnamed> | AssociationEnd from Association SubFolders
<unnamed> | AssociationEnd from Association PossList
<unnamed> | AssociationEnd from Association SubFolders
<unnamed> | AssociationEnd from Association Education
<unnamed> | AssociationEnd from Association PossList
<unnamed> | AssociationEnd from Association Education
<unnamed> | AssociationEnd from Association ObjRefs
<unnamed> | AssociationEnd from Association PlaceOfBirth
<unnamed> | AssociationEnd from Association Filters
<unnamed> | AssociationEnd from Association Filters
<unnamed> | AssociationEnd from Association Styles
<unnamed> | AssociationEnd from Association Styles
<unnamed> | AssociationEnd from Association Texts
<unnamed> | AssociationEnd from Association PlaceOfBirth
<unnamed> | AssociationEnd from Association MsFeatureSystem
<unnamed> | AssociationEnd from Association Locations
<unnamed> | AssociationEnd from Association Texts
<unnamed> | Generalization from Package LangProj
<unnamed> | AssociationEnd from Association Restrictions
<unnamed> | AssociationEnd from Association MsFeatureSystem
<unnamed> | AssociationEnd from Association Locations
<unnamed> | AssociationEnd from Association Restrictions
<unnamed> | AssociationEnd from Association Roles
<unnamed> | AssociationEnd from Association Roles
<unnamed> | AssociationEnd from Association Restrictions
<unnamed> | AssociationEnd from Association Positions
<unnamed> | AssociationEnd from Association AffixCategories
<unnamed> | AssociationEnd from Association Overlays
<unnamed> | AssociationEnd from Association ResearchNotebook
<unnamed> | AssociationEnd from Association AnthroList
<unnamed> | AssociationEnd from Association AnalysisStatus
<unnamed> | AssociationEnd from Association AffixCategories
<unnamed> | AssociationEnd from Association TranslationTags
<unnamed> | AssociationEnd from Association Restrictions
<unnamed> | AssociationEnd from Association AnalyzingAgents
<unnamed> | AssociationEnd from Association AnalysisStatus
<unnamed> | AssociationEnd from Association PartsOfSpeech
<unnamed> | AssociationEnd from Association TranslationTags
<unnamed> | AssociationEnd from Association PartsOfSpeech
<unnamed> | AssociationEnd from Association ResearchNotebook
<unnamed> | AssociationEnd from Association AnthroList
<unnamed> | AssociationEnd from Association Thesaurus
<unnamed> | AssociationEnd from Association AnalyzingAgents
<unnamed> | AssociationEnd from Association TimeOfDay
<unnamed> | AssociationEnd from Association Positions
<unnamed> | AssociationEnd from Association TimeOfDay
<unnamed> | AssociationEnd from Association Overlays
<unnamed> | AssociationEnd from Association SubRecords
<unnamed> | AssociationEnd from Association People
<unnamed> | AssociationEnd from Association Education
<unnamed> | AssociationEnd from Association WordformLookupLists
<unnamed> | AssociationEnd from Association LexDb
<unnamed> | AssociationEnd from Association PhonologicalData
<unnamed> | AssociationEnd from Association WordformLookupLists
<unnamed> | AssociationEnd from Association ConfidenceLevels
<unnamed> | AssociationEnd from Association LexDb
<unnamed> | AssociationEnd from Association MorphologicalData
<unnamed> | AssociationEnd from Association ConfidenceLevels
<unnamed> | AssociationEnd from Association MorphologicalData
<unnamed> | AssociationEnd from Association PhonologicalData
<unnamed> | AssociationEnd from Association SubRecords
<unnamed> | AssociationEnd from Association Thesaurus
<unnamed> | AssociationEnd from Association Education
<unnamed> | AssociationEnd from Association People
<unnamed> | AssociationEnd from Association FurtherQuestions
<unnamed> | AssociationEnd from Association AnthroCodes
<unnamed> | AssociationEnd from Association FurtherQuestions
<unnamed> | AssociationEnd from Association AnthroCodes
<unnamed> | AssociationEnd from Association ExternalMaterials
<unnamed> | AssociationEnd from Association ExternalMaterials
<unnamed> | AssociationEnd from Association Participants
<unnamed> | AssociationEnd from Association RecTypes
<unnamed> | AssociationEnd from Association SeeAlso
<unnamed> | AssociationEnd from Association PhraseTags
<unnamed> | AssociationEnd from Association RecTypes
<unnamed> | AssociationEnd from Association SeeAlso
<unnamed> | AssociationEnd from Association Participants
<unnamed> | AssociationEnd from Association PhraseTags
<unnamed> | AssociationEnd from Association VersionHistory
<unnamed> | AssociationEnd from Association Researchers
<unnamed> | AssociationEnd from Association VersionHistory
<unnamed> | AssociationEnd from Association Restrictions
<unnamed> | AssociationEnd from Association CrossReferences
<unnamed> | AssociationEnd from Association CrossReferences
<unnamed> | AssociationEnd from Association Confidence
<unnamed> | AssociationEnd from Association Role
<unnamed> | AssociationEnd from Association Confidence
<unnamed> | AssociationEnd from Association Records
<unnamed> | AssociationEnd from Association Records
<unnamed> | AssociationEnd from Association Researchers
<unnamed> | AssociationEnd from Association Restrictions
<unnamed> | AssociationEnd from Association Reminders
<unnamed> | AssociationEnd from Association CrossReferences
<unnamed> | AssociationEnd from Association Reminders
<unnamed> | AssociationEnd from Association Role
<unnamed> | AssociationEnd from Association Reminders
<unnamed> | AssociationEnd from Association CrossReferences
<unnamed> | AssociationEnd from Association Reminders
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Target
<unnamed> | AssociationEnd from Association Target
<unnamed> | AssociationEnd from Association GlossItems
<unnamed> | AssociationEnd from Association GlossItems
<unnamed> | AssociationEnd from Association GlossBundle
<unnamed> | AssociationEnd from Association GlossBundle
<unnamed> | AssociationEnd from Association GlossSystem
<unnamed> | AssociationEnd from Association GlossSystem
<unnamed> | AssociationEnd from Association Glosses
<unnamed> | AssociationEnd from Association Glosses
<unnamed> | AssociationEnd from Association FeatStructFrag
<unnamed> | AssociationEnd from Association FeatStructFrag
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Ling
<unnamed> | AssociationEnd from Association Members
<unnamed> | AssociationEnd from Association Members
<unnamed> | AssociationEnd from Association OtherObjects
<unnamed> | AssociationEnd from Association EndObject
<unnamed> | AssociationEnd from Association AppliesTo
<unnamed> | AssociationEnd from Association BeginObject
<unnamed> | AssociationEnd from Association BeginObject
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association InstanceOf
<unnamed> | AssociationEnd from Association AppliesTo
<unnamed> | AssociationEnd from Association InstanceOf
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association EndObject
<unnamed> | AssociationEnd from Association OtherObjects
<unnamed> | AssociationEnd from Association AnnotationType
<unnamed> | AssociationEnd from Association Source
<unnamed> | AssociationEnd from Association AnnotationType
<unnamed> | AssociationEnd from Association Source
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Annotations
<unnamed> | AssociationEnd from Association Annotations
<unnamed> | AssociationEnd from Association Text
<unnamed> | AssociationEnd from Association Text
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Footnotes
<unnamed> | AssociationEnd from Association Footnotes
<unnamed> | AssociationEnd from Association FirstMorpheme
<unnamed> | AssociationEnd from Association FirstMorpheme
<unnamed> | AssociationEnd from Association RestOfMorphs
<unnamed> | AssociationEnd from Association RestOfMorphs
<unnamed> | AssociationEnd from Association ArchivedDrafts
<unnamed> | AssociationEnd from Association ArchivedDrafts
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Books
<unnamed> | AssociationEnd from Association Books
<unnamed> | AssociationEnd from Association Diffs
<unnamed> | AssociationEnd from Association Diffs
<unnamed> | AssociationEnd from Association RevParagraph
<unnamed> | AssociationEnd from Association RevParagraph
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Meanings
<unnamed> | AssociationEnd from Association Meanings
<unnamed> | AssociationEnd from Association MorphBundles
<unnamed> | AssociationEnd from Association MorphBundles
<unnamed> | AssociationEnd from Association Morph
<unnamed> | AssociationEnd from Association Morph
<unnamed> | AssociationEnd from Association Msa
<unnamed> | AssociationEnd from Association Msa
<unnamed> | AssociationEnd from Association Sense
<unnamed> | AssociationEnd from Association Sense
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association UserAccounts
<unnamed> | AssociationEnd from Association UserAccounts
<unnamed> | AssociationEnd from Association ActivatedFeatures
<unnamed> | AssociationEnd from Association ActivatedFeatures
<unnamed> | AssociationEnd from Association UserConfigAcct
<unnamed> | AssociationEnd from Association UserConfigAcct
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Contents
<unnamed> | AssociationEnd from Association Contents
<unnamed> | AssociationEnd from Association CompoundRuleApps
<unnamed> | AssociationEnd from Association CompoundRuleApps
<unnamed> | AssociationEnd from Association Features
<unnamed> | AssociationEnd from Association Features
<unnamed> | AssociationEnd from Association HeaderFooterSets
<unnamed> | AssociationEnd from Association HeaderFooterSets
<unnamed> | AssociationEnd from Association Translations
<unnamed> | AssociationEnd from Association Translations
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association PageLayout
<unnamed> | AssociationEnd from Association PageLayout
<unnamed> | AssociationEnd from Association Divisions
<unnamed> | AssociationEnd from Association Divisions
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association TranslatedScripture
<unnamed> | AssociationEnd from Association TranslatedScripture
<unnamed> | AssociationEnd from Association Publications
<unnamed> | AssociationEnd from Association Publications
<unnamed> | AssociationEnd from Association FirstAllomorph
<unnamed> | AssociationEnd from Association FirstAllomorph
<unnamed> | AssociationEnd from Association RestOfAllos
<unnamed> | AssociationEnd from Association RestOfAllos
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association HFSet
<unnamed> | AssociationEnd from Association HFSet
<unnamed> | AssociationEnd from Association DefaultHeader
<unnamed> | AssociationEnd from Association DefaultHeader
<unnamed> | AssociationEnd from Association DefaultFooter
<unnamed> | AssociationEnd from Association DefaultFooter
<unnamed> | AssociationEnd from Association FirstHeader
<unnamed> | AssociationEnd from Association FirstHeader
<unnamed> | AssociationEnd from Association EvenFooter
<unnamed> | AssociationEnd from Association EvenFooter
<unnamed> | AssociationEnd from Association FirstFooter
<unnamed> | AssociationEnd from Association FirstFooter
<unnamed> | AssociationEnd from Association EvenHeader
<unnamed> | AssociationEnd from Association EvenHeader
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Files
<unnamed> | AssociationEnd from Association Files
<unnamed> | AssociationEnd from Association Pictures
<unnamed> | AssociationEnd from Association Pictures
<unnamed> | Generalization from Package Cellar
<unnamed> | AssociationEnd from Association Etymology
<unnamed> | AssociationEnd from Association Etymology
<unnamed> | AssociationEnd from Association Status
<unnamed> | AssociationEnd from Association Status
<unnamed> | AssociationEnd from Association Status
<unnamed> | AssociationEnd from Association Status
<unnamed> | Generalization from Package Cellar
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association OcmRefs
<unnamed> | AssociationEnd from Association OcmRefs
<unnamed> | AssociationEnd from Association RelatedDomains
<unnamed> | AssociationEnd from Association RelatedDomains
<unnamed> | Generalization
<unnamed> | AssociationEnd from Association Questions
<unnamed> | AssociationEnd from Association Questions
<unnamed> | AssociationEnd from Association SemanticDomains
<unnamed> | AssociationEnd from Association SemanticDomains
<unnamed> | AssociationEnd from Association SemanticDomainList
<unnamed> | AssociationEnd from Association SemanticDomainList
<unnamed> | AssociationEnd from Association AnnotationDefs
<unnamed> | AssociationEnd from Association AnnotationDefs


Tag Definition num Report

Report: | General Info | Typed Values

UML Standard Profile
Tag Definition num

General Info
Name | num
Multiplicity | 1
Type | String
Base Classes | Attribute

Typed Values
Value | Owner
4 | Abbreviation
4 | WritingSystem
10 | Abbreviation
11 | IsTranslated
4 | Checksum
2 | Reference
4 | LiftResidue
6 | ReversalForm
13 | CatalogSourceId
3 | IsAbstract
4 | LiftResidue
2 | GlossString
4 | LiftResidue
15 | AnthroNote
16 | Bibliography
17 | DiscourseNote
18 | EncyclopedicInfo
19 | GeneralNote
20 | GrammarNote
21 | PhonologyNote
22 | Restrictions
23 | SemanticsNote
24 | SocioLinguisticsNote
25 | Source
30 | ImportResidue
31 | LiftResidue
12 | Bibliography
14 | Restrictions
17 | SummaryDefinition
18 | LiteralMeaning
25 | Comment
26 | DoNotUseForParsing
27 | ExcludeAsHeadword
32 | ImportResidue
33 | LiftResidue
8 | StringRepresentation
1 | BasicIPASymbol
3 | WritingSystem
8 | Final
5 | CVPattern
6 | Tone
7 | LiftResidue
8 | ParserParameters
1 | Name
2 | Abbreviation
3 | Type
4 | AfterSeparator
5 | ComplexNameSeparator
6 | ComplexNameFirst
7 | Status
11 | EticID
1 | Name
2 | Description
1 | Form
1 | Comment
2 | Form
3 | Gloss
4 | Source
5 | LiftResidue
2 | SeeAlso
4 | TermId
1 | Ref
2 | KeyWord
4 | Status
6 | Location
1 | ReverseAbbr
3 | Name
1 | Comment
4 | LiftResidue
4 | ReverseName
1 | ReverseAbbreviation
2 | MappingType
1 | Explanation
3 | Explanation
5 | HideMinorEntry
6 | Summary
7 | LiftResidue
8 | RefType
1 | Description
2 | Name
3 | Direction
3 | StrucChange
2 | Preposed
1 | Notes
2 | ClauseType
3 | EndParagraph
4 | EndSentence
5 | StartDependentClauseGroup
6 | EndDependentClauseGroup
8 | Label
3 | BeginAnalysisIndex
4 | EndAnalysisIndex
2 | MergesAfter
3 | MergesBefore
19 | Versification
4 | ChapterVerseSepr
20 | VersePunct
5 | VerseSepr
6 | Bridge
15 | UseScriptDigits
16 | ScriptDigitZero
18 | ConvertCVDigitsOnExport
22 | ChapterLabel
23 | PsalmLabel
10 | FootnoteMarkerSymbol
3 | RefSepr
12 | DisplayFootnoteReference
13 | RestartFootnoteSequence
14 | RestartFootnoteBoundary
26 | FootnoteMarkerType
27 | DisplayCrossRefReference
28 | CrossRefMarkerSymbol
29 | CrossRefMarkerType
30 | CrossRefsCombinedWithFootnotes
31 | DisplaySymbolInFootnote
32 | DisplaySymbolInCrossRef
8 | IdText
12 | UseChapterNumHeading
13 | CanonicalNum
5 | VerseRefMin
6 | VerseRefMax
1 | Description
3 | DateCreated
4 | Type
5 | Protected
1 | RefStart
2 | RefEnd
3 | DiffType
4 | RevMin
5 | RevLim
8 | DateResolved
1 | CheckId
2 | RunDate
3 | Result
18 | WsSelector
21 | ListVersion
17 | WritingSystem
3 | Status
20 | IsProtected
9 | CatalogSourceId
7 | CatalogSourceId
3 | WsSelector
2 | WritingSystem
5 | CatalogSourceId
11 | Context
12 | Structure
9 | UserLevel
13 | Function
14 | Usage
3 | ParselsCurrent
14 | WsSelector
13 | WritingSystem
3 | AllowsComment
4 | AllowsFeatureStructure
5 | AllowsInstanceOf
6 | InstanceOfSignature
7 | UserCanCreate
8 | CanCreateOrphan
9 | PromptUser
10 | CopyCutPastable
11 | ZeroWidth
12 | Multi
13 | Severity
14 | MaxDupOccur
1 | CompDetails
2 | Comment
9 | DateCreated
10 | DateModified
1 | BeginOffset
3 | Flid
4 | EndOffset
9 | WsSelector
10 | BeginRef
11 | EndRef
8 | WritingSystem
1 | FootnoteMarker
2 | DisplayFootnoteReference
3 | DisplayFootnoteMarker
1 | Sid
2 | UserLevel
3 | HasMaintenance
2 | ApplicationId
3 | FeatureId
4 | ActivatedLevel
3 | PageHeight
4 | PageWidth
5 | IsLandscape
1 | Name
2 | Description
6 | GutterMargin
7 | GutterLoc
9 | FootnoteSepWidth
10 | PaperHeight
11 | PaperWidth
12 | BindingEdge
13 | SheetLayout
14 | SheetsPerSig
15 | BaseFontSize
16 | BaseLineSpacing
1 | DifferentFirstHF
2 | DifferentEvenHF
3 | StartAt
6 | NumColumns
1 | Name
2 | Description
3 | MarginTop
4 | MarginBottom
5 | MarginInside
6 | MarginOutside
7 | PosHeader
8 | PosFooter
10 | IsBuiltIn
11 | IsModified
1 | Name
2 | Description
1 | InsideAlignedText
2 | CenteredText
3 | OutsideAlignedText
1 | Name
2 | Description
3 | OriginalPath
4 | InternalPath
5 | Copyright
3 | Caption
4 | Description
5 | LayoutPos
6 | ScaleFactor
7 | LocationRangeType
8 | LocationMin
9 | LocationMax
1 | LouwNidaCodes
2 | OcmCodes
1 | Question
2 | ExampleWords
3 | ExampleSentences
1 | DateCreated
2 | DateModified
1 | Label
1 | Name
2 | Version
1 | Content
1 | Form
2 | FreeTranslation
1 | BeginOffset
3 | LiteralTranslation
3 | BeginAnalysisIndex
4 | EndAnalysisIndex
19 | CurAnalysisWss
17 | AnalysisWss
18 | CurVernWss
20 | CurPronunWss
41 | VernWss


Package index

Project: FieldWorks
Packages
Component View
Data types
UML Standard Profile
Interfaces
<unnamed>
Classes
<unnamed>
<unnamed>
<unnamed>
CmObject
StText
Diagrams
***Legend for CELLAR Diagrams
Annotations
CellarServer
Checklists
CmAgent
CmPossibility
Data Notebook
Discourse
FsFeature System
Interlinear Texts
Language Project
Lexical Database
Morphological Derivation
Morphological Glossing
Morphology
Morphology Affixes
MorphologyOld
MorphoPhonology
PartOfSpeech
Publications
Scripture
Structured Text
Tagging
User Configuations
UserViews
Wordform Inventory
Stereotypes
port
Tag Definitions
Author
Creation date
Modification date
Associations
Analyses [Segment - CmObject]
BackTransSources [ScrImportSet - ScrImportSource]
BookAnnotations [Scripture - ScrBookAnnotations]
Books [ScrRefSystem - ScrBookRef]
ChkHistRecs [ScrBookAnnotations - ScrCheckRun]
CreatedBy [StJournalText - CmPerson]
Discussion [ScrScriptureNote - StJournalText]
EndSegment [TextTag - Segment]
Files [ScrImportSFFiles - CmFile]
Item [PhPhonRuleFeat - CmObject]
Members [LexRefType - LexReference]
ModifiedBy [StJournalText - CmPerson]
NoteCategories [Scripture - CmPossibilityList]
NoteMappings [ScrImportSet - ScrMarkerMapping]
Notes [ScrBookAnnotations - ScrScriptureNote]
Notes [Segment - Note]
NoteSources [ScrImportSet - ScrImportSource]
OcmRefs [CmSemanticDomain - CmAnthroItem]
Quote [ScrScriptureNote - StJournalText]
Recommendation [ScrScriptureNote - StJournalText]
RelatedDomains [CmSemanticDomain - CmSemanticDomain]
Resolution [ScrScriptureNote - StJournalText]
Responses [ScrScriptureNote - StJournalText]
ScriptureMappings [ScrImportSet - ScrMarkerMapping]
ScriptureSources [ScrImportSet - ScrImportSource]
Style [ScrMarkerMapping - StStyle]
Tags [StText - TextTag]
Generalizations
<unnamed> [CmSemanticDomain - CmPossibility]
<unnamed> [CmDomainQ - CmObject]
<unnamed> [MoUnclassifiedAffixMsa - MoMorphSynAnalysis]
<unnamed> [LexEntryType - CmPossibility]
<unnamed> [LexRefType - CmPossibility]
<unnamed> [ScrImportP6Project - ScrImportSource]
<unnamed> [ScrImportSFFiles - ScrImportSource]
<unnamed> [ScrImportSet - CmObject]
<unnamed> [ScrMarkerMapping - CmObject]
<unnamed> [ScrScriptureNote - CmBaseAnnotation]
<unnamed> [CmMedia - CmObject]
<unnamed> [ScrCheckRun - CmObject]
<unnamed> [DsChart - CmMajorObject]
<unnamed> [DsConstChart - DsChart]
<unnamed> [DsDiscourseData - CmObject]
<unnamed> [LexEntryRef - CmObject]
<unnamed> [PhRegularRule - PhSegmentRule]
<unnamed> [PhMetathesisRule - PhSegmentRule]
<unnamed> [ScrFootnote - StFootnote]
<unnamed> [ScrTxtPara - StTxtPara]
<unnamed> [PunctuationForm - CmObject]
<unnamed> [Note - CmObject]
<unnamed> [Segment - CmObject]
<unnamed> [TextTag - CmObject]
<unnamed> [ConstituentChartCellPart - CmObject]
<unnamed> [ConstChartRow - CmObject]
<unnamed> [ConstChartWordGroup - ConstituentChartCellPart]
<unnamed> [ConstChartMovedTextMarker - ConstituentChartCellPart]
<unnamed> [ConstChartTag - ConstituentChartCellPart]
<unnamed> [ConstChartClauseMarker - ConstituentChartCellPart]


Model Report

Report: | | Inner Elements | Inner Relations

Project FieldWorks (Model Cellar)

Inner Elements
Name | Type
<unnamed> | Interface
<unnamed> | Class
<unnamed> | Class
<unnamed> | Class
CmObject | Class
StText | Class
Component View | Package
Data types | Package
UML Standard Profile | Package
***Legend for CELLAR Diagrams | Class Diagram
Annotations | Class Diagram
CellarServer | Class Diagram
Checklists | Class Diagram
CmAgent | Class Diagram
CmPossibility | Class Diagram
Data Notebook | Class Diagram
Discourse | Class Diagram
FsFeature System | Class Diagram
Interlinear Texts | Class Diagram
Language Project | Class Diagram
Lexical Database | Class Diagram
Morphological Derivation | Class Diagram
Morphological Glossing | Class Diagram
Morphology | Class Diagram
Morphology Affixes | Class Diagram
MorphologyOld | Class Diagram
MorphoPhonology | Class Diagram
PartOfSpeech | Class Diagram
Publications | Class Diagram
Scripture | Class Diagram
Structured Text | Class Diagram
Tagging | Class Diagram
User Configuations | Class Diagram
UserViews | Class Diagram
Wordform Inventory | Class Diagram
port | Stereotype
Author | Tag Definition
Creation date | Tag Definition
Modification date | Tag Definition

Inner Relations
Association Analyses [Segment - CmObject]
Association BackTransSources [ScrImportSet - ScrImportSource]
Association BookAnnotations [Scripture - ScrBookAnnotations]
Association Books [ScrRefSystem - ScrBookRef]
Association ChkHistRecs [ScrBookAnnotations - ScrCheckRun]
Association CreatedBy [StJournalText - CmPerson]
Association Discussion [ScrScriptureNote - StJournalText]
Association EndSegment [TextTag - Segment]
Association Files [ScrImportSFFiles - CmFile]
Association Item [PhPhonRuleFeat - CmObject]
Association Members [LexRefType - LexReference]
Association ModifiedBy [StJournalText - CmPerson]
Association NoteCategories [Scripture - CmPossibilityList]
Association NoteMappings [ScrImportSet - ScrMarkerMapping]
Association Notes [ScrBookAnnotations - ScrScriptureNote]
Association Notes [Segment - Note]
Association NoteSources [ScrImportSet - ScrImportSource]
Association OcmRefs [CmSemanticDomain - CmAnthroItem]
Association Quote [ScrScriptureNote - StJournalText]
Association Recommendation [ScrScriptureNote - StJournalText]
Association RelatedDomains [CmSemanticDomain - CmSemanticDomain]
Association Resolution [ScrScriptureNote - StJournalText]
Association Responses [ScrScriptureNote - StJournalText]
Association ScriptureMappings [ScrImportSet - ScrMarkerMapping]
Association ScriptureSources [ScrImportSet - ScrImportSource]
Association Style [ScrMarkerMapping - StStyle]
Association Tags [StText - TextTag]
Generalization <unnamed> [CmSemanticDomain - CmPossibility]
Generalization <unnamed> [CmDomainQ - CmObject]
Generalization <unnamed> [MoUnclassifiedAffixMsa - MoMorphSynAnalysis]
Generalization <unnamed> [LexEntryType - CmPossibility]
Generalization <unnamed> [LexRefType - CmPossibility]
Generalization <unnamed> [ScrImportP6Project - ScrImportSource]
Generalization <unnamed> [ScrImportSFFiles - ScrImportSource]
Generalization <unnamed> [ScrImportSet - CmObject]
Generalization <unnamed> [ScrMarkerMapping - CmObject]
Generalization <unnamed> [ScrScriptureNote - CmBaseAnnotation]
Generalization <unnamed> [CmMedia - CmObject]
Generalization <unnamed> [ScrCheckRun - CmObject]
Generalization <unnamed> [DsChart - CmMajorObject]
Generalization <unnamed> [DsConstChart - DsChart]
Generalization <unnamed> [DsDiscourseData - CmObject]
Generalization <unnamed> [LexEntryRef - CmObject]
Generalization <unnamed> [PhRegularRule - PhSegmentRule]
Generalization <unnamed> [PhMetathesisRule - PhSegmentRule]
Generalization <unnamed> [ScrFootnote - StFootnote]
Generalization <unnamed> [ScrTxtPara - StTxtPara]
Generalization <unnamed> [PunctuationForm - CmObject]
Generalization <unnamed> [Note - CmObject]
Generalization <unnamed> [Segment - CmObject]
Generalization <unnamed> [TextTag - CmObject]
Generalization <unnamed> [ConstituentChartCellPart - CmObject]
Generalization <unnamed> [ConstChartRow - CmObject]
Generalization <unnamed> [ConstChartWordGroup - ConstituentChartCellPart]
Generalization <unnamed> [ConstChartMovedTextMarker - ConstituentChartCellPart]
Generalization <unnamed> [ConstChartTag - ConstituentChartCellPart]
Generalization <unnamed> [ConstChartClauseMarker - ConstituentChartCellPart]


Stereotype table Report

Report: | General Info

UML Standard Profile
Stereotype table

Denotes a database table.

General Info
Name | table
Base Classes | Artifact
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram ***Legend for CELLAR Diagrams

MoDeriv CmObject CmOverlay <unnamed> <unnamed> MoAffixProcess MoRuleMapping Output Output CmAgent CmAgent

General Info
Name | ***Legend for CELLAR Diagrams
Type | Class Diagram


Class Diagram

Report: | General Info

Class Diagram Morphology

LangProject MorphologicalData MorphologicalData MoMorphData PhonologicalData PhonologicalData PhPhonData PhPhonContext RightContext RightContext LeftContext LeftContext Environments Environments PhEnvironment CompoundRules CompoundRules MoCompoundRule MoBinaryCompoundRule <unnamed> <unnamed> <unnamed> <unnamed> MoEndoCompound <unnamed> <unnamed> MoExoCompound Strata Strata Stratum Stratum MoStratum CmAgent AnalyzingAgents AnalyzingAgents AnalyzingAgents AnalyzingAgents WfiWordSet TestSets TestSets PhPhonemeSet PhonemeSets PhonemeSets Phonemes Phonemes MoMorphSynAnalysis Stratum Stratum MoStemMsa <unnamed> <unnamed> MoInflClass Subclasses Subclasses InflectionClass InflectionClass PartOfSpeech DefaultInflectionClass DefaultInflectionClass InflectionClasses InflectionClasses PartOfSpeech PartOfSpeech MoInflAffMsa <unnamed> <unnamed> MoDerivAffMsa <unnamed> <unnamed> FromInflectionClass FromInflectionClass ToInflectionClass ToInflectionClass MoStemName DefaultStem DefaultStem StemNames StemNames DefaultAffix DefaultAffix StemNames StemNames FromStemName FromStemName Stratum Stratum MoDerivStepMsa InflectionClass InflectionClass <unnamed> <unnamed> MoAdhocProhib AdhocCoProhibitions AdhocCoProhibitions MoAlloAdhocProhib <unnamed> <unnamed> MoMorphAdhocProhib <unnamed> <unnamed> Morphemes Morphemes MoForm Allomorphs Allomorphs LeftMsa LeftMsa RightMsa RightMsa ToMsa ToMsa MoCoordinateCompound <unnamed> <unnamed> WfiWordform Cases Cases WfiAnalysis Analyses Analyses Components Components MoMorphType MorphType MorphType MoStemAllomorph StemName StemName PhoneEnv PhoneEnv <unnamed> <unnamed> FsFeatStruc DefaultFeatures DefaultFeatures FromMsFeatures FromMsFeatures EmptyParadigmCells EmptyParadigmCells ReferenceForms ReferenceForms ToMsFeatures ToMsFeatures ToProdRestrict ToProdRestrict FromProdRestrict FromProdRestrict InherFeatVal InherFeatVal FsFeatStruc ProdRestrict ProdRestrict MsFeatures MsFeatures MsFeatures MsFeatures ProdRestrict ProdRestrict InflFeats InflFeats FsFeatStruc InflFeats InflFeats FromProdRestrict FromProdRestrict FsFeatStruc MoAffixForm Linker Linker MoInflClass FsFeatStruc PartOfSpeech MoAffixAllomorph MsEnvFeatures MsEnvFeatures PhoneEnv PhoneEnv Position Position <unnamed> <unnamed> InflectionClasses InflectionClasses MoAffixForm MoAffixProcess PhContextOrVar Contexts Contexts Input Input MoRuleMapping Output Output MoReferralRule RulesOfReferral RulesOfReferral Regions Regions ReferenceForms ReferenceForms MsFeatures MsFeatures Output Output Input Input FsFeatStruc MoInflAffixTemplate AffixTemplates AffixTemplates Stratum Stratum Region Region MoInflAffixSlot AffixSlots AffixSlots PrefixSlots PrefixSlots Slots Slots SuffixSlots SuffixSlots MoDeriv Derivation Derivation <unnamed> <unnamed> MoModifyFromInput MoInsertNC MoInsertPhones <unnamed> <unnamed> Content Content <unnamed> <unnamed> <unnamed> <unnamed> LexEntry MorphoSyntaxAnalyses MorphoSyntaxAnalyses LexEntry MoCopyFromInput Content Content CmPossibility AffixCategory AffixCategory AffixCategory AffixCategory MoAdhocProhibGr <unnamed> <unnamed> Members Members FirstMorpheme FirstMorpheme RestOfMorphs RestOfMorphs CompoundRuleApps CompoundRuleApps InflTemplateApps InflTemplateApps FirstAllomorph FirstAllomorph RestOfAllos RestOfAllos MoAffixForm <unnamed> <unnamed> <unnamed> <unnamed> WfiAnalysis PhEnvironment FsFeatStruc PartOfSpeech PartOfSpeech FsFeatStruc CmPossibility FsFeatStruc MsEnvPartOfSpeech MsEnvPartOfSpeech FsFeatStruc MoUnclassifiedAffixMsa <unnamed> <unnamed> PartOfSpeech PartOfSpeech OverridingMsa OverridingMsa CmPossibilityList ProdRestrict ProdRestrict CmPossibility CmPossibility CmPossibility FromPartsOfSpeech FromPartsOfSpeech Lexical Database CmPossibility

General Info
Name | Morphology
Type | Class Diagram


Stereotype document Report

Report: | General Info

UML Standard Profile
Stereotype document

Denotes a generic file that is not a «source» file or «executable». Subclass of «file».

General Info
Name | document
Base Classes | Artifact
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram Morphological Glossing

MoGlossItem Target Target GlossItems GlossItems MoGlossSystem MoMorphData MoMorphSynAnalysis Components Components GlossBundle GlossBundle GlossSystem GlossSystem Glosses Glosses FsFeatStruc FeatStructFrag FeatStructFrag

General Info
Name | Morphological Glossing
Type | Class Diagram


Stereotype library Report

Report: | General Info

UML Standard Profile
Stereotype library

Denotes a static or dynamic library file. Subclass of «file».

General Info
Name | library
Base Classes | Artifact
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram UserViews

UserView SubfieldOf SubfieldOf UserViewField Records Records Fields Fields UserViewRec CmPossibility CmPossibilityList PossList PossList Possibilities Possibilities

General Info
Name | UserViews
Type | Class Diagram


Class Diagram

Report: | General Info

Class Diagram FsFeature System

FsFeatureSpecification FsFeatDefn Feature Feature Default Default FsSharedValue Value Value FsFeatStruc FeatureSpecs FeatureSpecs FsDisjunctiveValue <unnamed> <unnamed> FsComplexValue FsClosedValue <unnamed> <unnamed> FsNegatedValue <unnamed> <unnamed> FsOpenValue <unnamed> <unnamed> FsFeatureSystem FsOpenFeature FsComplexFeature FsClosedFeature <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> FsFeatStrucType Types Types Type Type Type Type FsAbstractStructure Value Value <unnamed> <unnamed> FsFeatStrucDisj Contents Contents FeatureDisjunctions FeatureDisjunctions <unnamed> <unnamed> FsSymFeatVal Value Value Value Value Values Values Value Value LangProject MsFeatureSystem MsFeatureSystem <unnamed> <unnamed> <unnamed> <unnamed> Features Features Features Features

General Info
Name | FsFeature System
Type | Class Diagram


Class Diagram

Report: | General Info

Class Diagram Morphological Derivation

MoDerivTrace MoDerivAffApp <unnamed> <unnamed> MoCompoundRuleApp <unnamed> <unnamed> MoInflTemplateApp Template Template <unnamed> <unnamed> MoStratumApp CompoundRuleApps CompoundRuleApps DerivAffApp DerivAffApp TemplateApp TemplateApp <unnamed> <unnamed> MoInflAffixSlotApp SlotApps SlotApps <unnamed> <unnamed> MoPhonolRuleApp <unnamed> <unnamed> PRuleApps PRuleApps MoDeriv StratumApps StratumApps MoStemAllomorph LeftForm LeftForm RightForm RightForm StemForm StemForm MoStemMsa StemMsa StemMsa FsFeatStruc InflectionalFeats InflectionalFeats MoStratum Stratum Stratum Stratum Stratum MoAffixAllomorph AffixForm AffixForm Linker Linker MoDerivAffMsa AffixMsa AffixMsa MoDerivStepMsa OutputMsa OutputMsa MoInflAffixTemplate Stratum Stratum MoInflAffixSlot SuffixSlots SuffixSlots Slots Slots Slot Slot PrefixSlots PrefixSlots MoAffixForm AffixForm AffixForm <unnamed> <unnamed> MoInflAffMsa AffixMsa AffixMsa PartOfSpeech PartOfSpeech PartOfSpeech Region Region FromPartsOfSpeech FromPartsOfSpeech

General Info
Name | Morphological Derivation
Type | Class Diagram


Class Diagram

Report: | General Info

Class Diagram Data Notebook

SubRecords SubRecords RnGenericRec Type Type CmPossibility Restrictions Restrictions AnthroCodes AnthroCodes Confidence Confidence Confidence Confidence PhraseTags PhraseTags SubPossibilities SubPossibilities Status Status Restrictions Restrictions Reminders Reminders Reminder CrossReference CrossReferences CrossReferences <unnamed> <unnamed> CmAnthroItem CrossReferences CrossReferences Records Records Reminders Reminders RnResearchNbk PersonalNotes PersonalNotes Description Description Discussion Discussion VersionHistory VersionHistory ExternalMaterials ExternalMaterials StText Status Status Conclusions Conclusions Hypothesis Hypothesis SupersededBy SupersededBy FurtherQuestions FurtherQuestions CounterEvidence CounterEvidence ResearchPlan ResearchPlan SupportingEvidence SupportingEvidence Discussion Discussion Participants Participants Role Role RnRoledPartic Researchers Researchers Participants Participants <unnamed> <unnamed> Positions Positions Education Education Sources Sources Researchers Researchers CmPerson SeeAlso SeeAlso TimeOfEvent TimeOfEvent LangProject CmMajorObject CmPossibilityList <unnamed> <unnamed> RecTypes RecTypes ResearchNotebook ResearchNotebook CmPossibility CmLocation Locations Locations

General Info
Name | Data Notebook
Type | Class Diagram


Stereotype file Report

Report: | General Info

UML Standard Profile
Stereotype file

Denotes a physical file in the context of the system developed.

General Info
Name | file
Base Classes | Artifact
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram CmPossibility

Restrictions Restrictions SubPossibilities SubPossibilities Status Status Confidence Confidence CmPossibility CmCustomItem <unnamed> <unnamed> Education Education Positions Positions Researchers Researchers CmPerson PlacesOfResidence PlacesOfResidence <unnamed> <unnamed> PlaceOfBirth PlaceOfBirth CmLocation CmAnthroItem CmOverlay PossItems PossItems MoMorphType <unnamed> <unnamed> PartOfSpeech <unnamed> <unnamed> CmPossibilityList PossList PossList CmSemanticDomain <unnamed> <unnamed> OcmRefs OcmRefs RelatedDomains RelatedDomains CmDomainQ Questions Questions CmAnnotationDefn <unnamed> <unnamed> ChkTerm <unnamed> <unnamed> <unnamed> <unnamed> CmMajorObject <unnamed> <unnamed>

General Info
Name | CmPossibility
Type | Class Diagram


Stereotype focus Report

Report: | General Info

UML Standard Profile
Stereotype focus

Specifies a class that defines the core logic or control flow for one or more auxiliary classes that support it. Support classes may be defined explicitly using Auxiliary classes or implicitly by dependency relationships. Focus classes are typically used together with one or more Auxiliary classes, and are particularly useful for specifying the core business logic or control flow of components during design. See also: «auxiliary».

General Info
Name | focus
Base Classes | Class
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram PartOfSpeech

PartOfSpeech MoInflClass InflectionClasses InflectionClasses DefaultInflectionClass DefaultInflectionClass MoReferralRule RulesOfReferral RulesOfReferral MoDerivAffMsa MoInflAffixSlot ReversalIndexEntry PartOfSpeech PartOfSpeech WfiAnalysis Category Category FsFeatStruc MoStemMsa PartOfSpeech PartOfSpeech FsFeatDefn BearableFeatures BearableFeatures InflectableFeats InflectableFeats MoStemName StemNames StemNames MoInflAffixTemplate MoAffixAllomorph MoDerivStepMsa CmPossibility <unnamed> <unnamed> CmPossibilityList LangProject PartsOfSpeech PartsOfSpeech EmptyParadigmCells EmptyParadigmCells FromPartOfSpeech FromPartOfSpeech PartOfSpeech PartOfSpeech AffixTemplates AffixTemplates ToPartOfSpeech ToPartOfSpeech MsEnvPartOfSpeech MsEnvPartOfSpeech AffixSlots AffixSlots InherFeatVal InherFeatVal ReferenceForms ReferenceForms DefaultFeatures DefaultFeatures FromPartsOfSpeech FromPartsOfSpeech

General Info
Name | PartOfSpeech
Type | Class Diagram


Package Component View index

Packages
Cellar
FeatSys
LangProj
Ling
Notebk
Scripture


PackageComponent View Report

Report: | General Info | Inner Elements

Package Component View

General Info
Name | Component View
Abstract | false
Leaf | false
Root | false

Inner Elements
Name | Type
Cellar | Package
FeatSys | Package
LangProj | Package
Ling | Package
Notebk | Package
Scripture | Package


Class Diagram

Report: | General Info

Class Diagram CmAgent

CmAgent MoMorphData AnalyzingAgents AnalyzingAgents LangProject AnalyzingAgents AnalyzingAgents StText Notes Notes WfiAnalysis WfiWordform CmAgentEvaluation <unnamed> <unnamed> <unnamed> <unnamed> CmObject Approves Approves Disproves Disproves Evaluations Evaluations

General Info
Name | CmAgent
Type | Class Diagram


Stereotype auxiliary Report

Report: | General Info

UML Standard Profile
Stereotype auxiliary

Specifies a class that supports another more central or fundamental class, typically by implementing secondary logic or control flow. The class that the auxiliary supports may be defined explicitly using a Focus class or implicitly by a dependency relationship. Auxiliary classes are typically used together with Focus classes, and are particularly useful for specifying the secondary business logic or control flow of components during design. See also: «focus».

General Info
Name | auxiliary
Base Classes | Class
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram Language Project

LangProject LexDb LexDb LexDb Texts Texts Text ResearchNotebook ResearchNotebook RnResearchNbk Styles Styles Next Next BasedOn BasedOn StStyle MorphologicalData MorphologicalData MoMorphData Filters Filters CmFilter <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> CmMajorObject <unnamed> <unnamed> CmProject <unnamed> <unnamed> Roles Roles Restrictions Restrictions UsageTypes UsageTypes AnthroList AnthroList PartsOfSpeech PartsOfSpeech SenseTypes SenseTypes ConfidenceLevels ConfidenceLevels MorphTypes MorphTypes RecTypes RecTypes DomainTypes DomainTypes Locations Locations AnalysisStatus AnalysisStatus People People Positions Positions AffixCategories AffixCategories Thesaurus Thesaurus TimeOfDay TimeOfDay Education Education TranslationTags TranslationTags CmPossibilityList Overlays Overlays PossList PossList CmOverlay PhonologicalData PhonologicalData PhPhonData Scripture <unnamed> <unnamed> PartsOfSpeech PartsOfSpeech ReversalIndex AnalyzingAgents AnalyzingAgents AnalyzingAgents AnalyzingAgents CmAgent WordformLookupLists WordformLookupLists <unnamed> <unnamed> WordformLookupList TranslatedScripture TranslatedScripture Pictures Pictures CmFolder SemanticDomainList SemanticDomainList AnnotationDefs AnnotationDefs CmRow Rows Rows CmCell Cells Cells UserAppFeatAct UserConfigAcct CmAnnotation UserAccounts UserAccounts CheckLists CheckLists Annotations Annotations ActivatedFeatures ActivatedFeatures GenreList GenreList FsFeatureSystem PhFeatureSystem PhFeatureSystem MsFeatureSystem MsFeatureSystem

General Info
Name | Language Project
Type | Class Diagram


Class Diagram

Report: | General Info

Class Diagram Wordform Inventory

LexEntry LexSense WfiAnalysis CmPossibility FsFeatStruc MoForm WfiWordSet WfiWordform WfiGloss PartOfSpeech MoMorphSynAnalysis MorphoSyntaxAnalyses MorphoSyntaxAnalyses Category Category MorphoSyntaxAnalysis MorphoSyntaxAnalysis Derivation Derivation InflectionalFeats InflectionalFeats MoDeriv Cases Cases SubPossibilities SubPossibilities UsageTypes UsageTypes SenseType SenseType ThesaurusItems ThesaurusItems DomainTypes DomainTypes Restrictions Restrictions Stems Stems Status Status Confidence Confidence Senses Senses AnthroCodes AnthroCodes CmAnthroItem ThesaurusItems ThesaurusItems AnthroCodes AnthroCodes WordFormLookup Meanings Meanings WfiMorphBundle MorphBundles MorphBundles Morph Morph Msa Msa Sense Sense MoCompoundRule ToProdRestrict ToProdRestrict CompoundRuleApps CompoundRuleApps MoInflAffixTemplate Region Region Analyses Analyses LexemeForm LexemeForm AlternateForms AlternateForms CmPossibility

General Info
Name | Wordform Inventory
Type | Class Diagram


Class Diagram

Report: | General Info

Class Diagram MorphologyOld

MoMorphData PhPhonData Environments Environments PhEnvironment Strata Strata MoStratum MoMorphAdhocProhib AdhocCoProhibitions AdhocCoProhibitions <unnamed> <unnamed> MoAdhocProhib <unnamed> <unnamed> MoAlloAdhocProhib CompoundRules CompoundRules Stratum Stratum MoCompoundRule MorphologicalData MorphologicalData PhonologicalData PhonologicalData LangProject MoEndoCompound MoExoCompound FsFeatStruc MsEnvFeatures MsEnvFeatures MoAffixAllomorph PartOfSpeech InflectionClasses InflectionClasses Subclasses Subclasses DefaultInflectionClass DefaultInflectionClass MoInflClass StemNames StemNames StemNames StemNames MoStemName RulesOfReferral RulesOfReferral RulesOfReferral RulesOfReferral MoReferralRule Stratum Stratum MoInflAffixTemplate PrefixSlots PrefixSlots Slots Slots SuffixSlots SuffixSlots MoInflAffixSlot Input Input ReferenceForms ReferenceForms Region Region Regions Regions Output Output FsFeatStruc DefaultStem DefaultStem Morphemes Morphemes MoMorphSynAnalysis DefaultAffix DefaultAffix FromInflectionClass FromInflectionClass Allomorphs Allomorphs MoForm <unnamed> <unnamed> <unnamed> <unnamed> InflectionClasses InflectionClasses MoAffixForm <unnamed> <unnamed> StemName StemName MoStemAllomorph <unnamed> <unnamed> MoAffixProcess MoDerivAffMsa MoMorphSynAnalysis MoInflAffMsa FsFeatStruc MoStemMsa FromMsFeatures FromMsFeatures <unnamed> <unnamed> ToMsFeatures ToMsFeatures PartOfSpeech <unnamed> <unnamed> <unnamed> <unnamed> PartOfSpeech PartOfSpeech ToInflectionClass ToInflectionClass InflectionClass InflectionClass LeftContext LeftContext RightContext RightContext PhPhonContext ToMsa ToMsa

General Info
Name | MorphologyOld
Type | Class Diagram


Stereotype profile Report

Report: | General Info | Extended Elements

UML Standard Profile
Stereotype profile

A profile is a stereotyped package that contains model elements that have been customized for a specific domain or purpose using extension mechanisms, such as stereotypes, tagged definitions, and constraints. A profile may also specify model libraries on which it depends and the metamodel subset that it extends. (The latter is specified via an applicableSubset tag definition.)

General Info
Name | profile
Base Classes | Package
Abstract | false
Leaf | false
Root | false

Extended Elements
Name | Type | Owner
UML Standard Profile | Package |


Stereotype table Report

Report: | General Info

UML Standard Profile
Stereotype table

General Info
Name | table
Base Classes | Class
Abstract | false
Leaf | false
Root | false


Stereotype stateInvariant Report

Report: | General Info

UML Standard Profile
Stereotype stateInvariant

Specifies a constraint that must be attached to a state vertex in a state machine that has a classifier for a context. The stereotype indicates that the constraint holds for instances of the classifier when an instance is in that state.

General Info
Name | stateInvariant
Base Classes | Constraint
Abstract | false
Leaf | false
Root | false


Package Data types index

Data Types
bigString
bigUnicode
binary
binary
boolean
float
genDate
guid
image
integer
multiBigString
multiBigUnicode
multiString
multiUnicode
numeric
string
textPropBinary
time
unicode
void
Tag Definitions


PackageData types Report

Report: | General Info | Inner Elements

Package Data types

General Info
Name | Data types
Abstract | false
Leaf | false
Root | false

Inner Elements
Name | Type
bigString | Data Type
bigUnicode | Data Type
binary | Data Type
binary | Data Type
boolean | Data Type
float | Data Type
genDate | Data Type
guid | Data Type
image | Data Type
integer | Data Type
multiBigString | Data Type
multiBigUnicode | Data Type
multiString | Data Type
multiUnicode | Data Type
numeric | Data Type
string | Data Type
textPropBinary | Data Type
time | Data Type
unicode | Data Type
void | Data Type
max | Tag Definition
min | Tag Definition


Stereotype database Report

Report: | General Info

UML Standard Profile
Stereotype database

General Info
Name | database
Base Classes | Package
Abstract | false
Leaf | false
Root | false


Stereotype executable Report

Report: | General Info

UML Standard Profile
Stereotype executable

Denotes a program file that can be executed on a computer system.Subclass of «file».

General Info
Name | executable
Base Classes | Artifact
Abstract | false
Leaf | false
Root | false


Stereotype modelLibrary Report

Report: | General Info

UML Standard Profile
Stereotype modelLibrary

A model library is a stereotyped package that contains model elements that are intended to be reused by other packages. A model library differs from a profile in that a model library does not extend the metamodel using stereotypes and tagged definitions. A model library is analogous to a class library in some programming languages.

General Info
Name | modelLibrary
Base Classes | Package
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram Lexical Database

LangProject CmMajorObject <unnamed> <unnamed> LexDb LexDb LexDb LexicalFormIndex LexicalFormIndex Entries Entries LexEntry Appendixes Appendixes LexAppendix Senses Senses Senses Senses Appendixes Appendixes LexSense Examples Examples LexExampleSentence Pictures Pictures LexPronunciation Contents Contents Introduction Introduction StText Translations Translations CmTranslation Subentries Subentries ReversalEntries ReversalEntries ReversalIndexEntry MoForm AllomorphIndex AllomorphIndex MoMorphSynAnalysis MorphoSyntaxAnalyses MorphoSyntaxAnalyses MorphoSyntaxAnalysis MorphoSyntaxAnalysis Components Components CmPossibilityList SenseTypes SenseTypes UsageTypes UsageTypes MorphTypes MorphTypes DomainTypes DomainTypes CmPossibility CmPossibility DomainTypes DomainTypes ThesaurusItems ThesaurusItems SenseType SenseType UsageTypes UsageTypes CmPossibility Type Type LexEtymology Etymology Etymology Status Status Status Status CmAnthroItem AnthroCodes AnthroCodes ReversalIndex PartsOfSpeech PartsOfSpeech Entries Entries PartOfSpeech PartOfSpeech PartOfSpeech CmSemanticDomain OcmRefs OcmRefs RelatedDomains RelatedDomains <unnamed> <unnamed> SemanticDomains SemanticDomains CmDomainQ Questions Questions StStyle BasedOn BasedOn Styles Styles Next Next <unnamed> <unnamed> CmMajorObject <unnamed> <unnamed> CmPossibility CmObject LexAppendix <unnamed> <unnamed> ReversalIndexes ReversalIndexes MainEntriesOrSenses MainEntriesOrSenses LexEntryType <unnamed> <unnamed> References References LexRefType <unnamed> <unnamed> LexReference Members Members CmObject Targets Targets LexemeForm LexemeForm AlternateForms AlternateForms CmPicture Pronunciations Pronunciations CmMedia CmFile MediaFile MediaFile CmFolder Media Media CmLocation Location Location MediaFiles MediaFiles CmFile PictureFile PictureFile CmResource Resources Resources LexEntryRef EntryRefs EntryRefs CmObject ComponentLexemes ComponentLexemes VariantEntryTypes VariantEntryTypes ComplexEntryTypes ComplexEntryTypes VariantEntryTypes VariantEntryTypes ComplexEntryTypes ComplexEntryTypes PrimaryLexemes PrimaryLexemes

General Info
Name | Lexical Database
Type | Class Diagram


Stereotype modelLibrary Report

Report: | General Info

UML Standard Profile
Stereotype modelLibrary

This dependency means that the supplier package is being used as a model library associated with a profile. The client is a package that is stereotyped as a profile and the supplier is a non-profile package that contains shared model elements, such as classes and data types.

General Info
Name | modelLibrary
Base Classes | Dependency
Abstract | false
Leaf | false
Root | false


Stereotype schema Report

Report: | General Info

UML Standard Profile
Stereotype schema

General Info
Name | schema
Base Classes | Package
Abstract | false
Leaf | false
Root | false


Stereotype appliedProfile Report

Report: | General Info

UML Standard Profile
Stereotype appliedProfile

This dependency is used to indicate which profiles are applicable to a package. Typically, the client is an ordinary package or a model (but could be any other kind of package), while the supplier is a profile package. This means that the profile applies transitively to the model elements contained in the client package, including the client package itself.

General Info
Name | appliedProfile
Base Classes | Dependency
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram CellarServer

SubFolders SubFolders CmFolder CmMajorObject <unnamed> <unnamed> CmPossibilityList SubPossibilities SubPossibilities Confidence Confidence CmPossibility Status Status Restrictions Restrictions CmFile Files Files CmPicture CmMedia MediaFile MediaFile PictureFile PictureFile

General Info
Name | CellarServer
Type | Class Diagram


Stereotype source Report

Report: | General Info

UML Standard Profile
Stereotype source

Denotes a source file that can be compiled into an executable file.Subclass of «file».

General Info
Name | source
Base Classes | Artifact
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram MorphoPhonology

PhSimpleContextBdry FsFeatStruc FeatureStructure FeatureStructure PhTerminalUnit <unnamed> <unnamed> PhBdryMarker FeatureStructure FeatureStructure PhSimpleContextSeg <unnamed> <unnamed> PhPhoneme BoundaryMarkers BoundaryMarkers Phonemes Phonemes PhPhonemeSet PhNaturalClass <unnamed> <unnamed> Features Features PhNCFeatures <unnamed> <unnamed> Segments Segments PhNCSegments LangProject NaturalClasses NaturalClasses PhonemeSets PhonemeSets PhonologicalData PhonologicalData PhPhonData PhSequenceContext Members Members <unnamed> <unnamed> PhPhonContext <unnamed> <unnamed> Member Member PhIterationContext <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> PhSimpleContext FeatureStructure FeatureStructure <unnamed> <unnamed> PhSimpleContextNC Contexts Contexts PhContextOrVar PhVariable MoInsertNC MoRuleMapping MoInsertPhones MoCopyFromInput MoModifyFromInput <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> Content Content Content Content Modification Modification MoAffixProcess Input Input Output Output Content Content Content Content PhEnvironment RightContext RightContext Environments Environments LeftContext LeftContext PhCode Codes Codes <unnamed> <unnamed> <unnamed> <unnamed> FsFeatureSystem PhFeatureSystem PhFeatureSystem PhFeatureConstraint FeatConstraints FeatConstraints CmPossibilityList PhonRuleFeats PhonRuleFeats Features Features PhPhonRuleFeat CmObject Item Item PhSegmentRule PhonRules PhonRules MoStratum InitialStratum InitialStratum FinalStratum FinalStratum PhSimpleContext PhSegRuleRHS PhPhonContext LeftContext LeftContext RightContext RightContext StrucChange StrucChange PartOfSpeech InputPOSes InputPOSes ExclRuleFeats ExclRuleFeats ReqRuleFeats ReqRuleFeats PhRegularRule PhMetathesisRule <unnamed> <unnamed> <unnamed> <unnamed> RightHandSides RightHandSides StrucDesc StrucDesc CmPossibility <unnamed> <unnamed>

General Info
Name | MorphoPhonology
Type | Class Diagram


Stereotype implementation Report

Report: | General Info

UML Standard Profile
Stereotype implementation

Specifies the implementation of a class in some programming language (for example, C++, Smalltalk, Java) in which an instance may not have more than one class. This is in contrast to Class, for which an instance may have multiple classes at one time and may gain or lose classes over time, and an object (a child of instance) may dynamically have multiple classes. An Implementation class is said to realize a Type if it provides all of the operations defined for the Type with the same behavior as specified for the Type’s operations. An Implementation Class may realize a number of different Types. Note that the physical attributes and associations of the Implementation class do not have to be the same as those of any Type it realizes and that the Implementation Class may provide methods for its operations in terms of its physical attributes and associations. See also: «type».

General Info
Name | implementation
Base Classes | Class
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram Scripture

Scripture ScrSection StText Paragraphs Paragraphs StPara ScrBookRef Heading Heading Content Content StStyle Styles Styles ImportSettings ImportSettings StFootnote <unnamed> <unnamed> ScrDraft ArchivedDrafts ArchivedDrafts ScrDifference RevParagraph RevParagraph Title Title Books Books Sections Sections ScriptureBooks ScriptureBooks Footnotes Footnotes ScrBook BookId BookId Diffs Diffs CmMajorObject <unnamed> <unnamed> ScrImportSet ScrMarkerMapping ScrImportSource ScrImportSFFiles ScrImportP6Project Style Style ScriptureSources ScriptureSources NoteSources NoteSources BackTransSources BackTransSources ScriptureMappings ScriptureMappings NoteMappings NoteMappings Files Files <unnamed> <unnamed> <unnamed> <unnamed> CmFile CmAnnotationDefn NoteType NoteType NoteType NoteType ScrScriptureNote StJournalText CmPossibility Categories Categories Quote Quote Recommendation Recommendation Resolution Resolution Discussion Discussion Responses Responses CmBaseAnnotation <unnamed> <unnamed> CmPossibilityList NoteCategories NoteCategories Notes Notes BookAnnotations BookAnnotations ScrBookAnnotations ScrRefSystem Books Books CmResource Resources Resources ScrCheckRun ChkHistRecs ChkHistRecs StTxtPara ScrTxtPara ScrFootnote <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed>

General Info
Name | Scripture
Type | Class Diagram


Association Template Report

Report: | General Info | Association Ends | Tagged Values

Association Template

refers to the MoInflAffixTemplate whose application this trace structure represents.

General Info
Name | Template
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflTemplateApp
End B | <unnamed> | 1 | MoInflAffixTemplate

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflTemplateApp
Association | Template
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixTemplate
Association | Template
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association UsageTypes Report

Report: | General Info | Association Ends | Tagged Values

Association UsageTypes

General Info
Name | UsageTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | UsageTypes
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | UsageTypes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Slots Report

Report: | General Info | Association Ends | Tagged Values

Association Slots

refers to an ordered seq of MoInflAffixSlot; during the course of a derivation, each Affix Slot is applied in sequence, beginning with the top-most slot. While in many (most?) languages the order of attachment of Inflectional affixes is irrelevant, it may occasionally be necessary to specify a derivational order to account for allomorphy. Since the left-to-right order is likely to be discovered earlier than the derivation order, it will probably be necessary to provide a default derivation order which can be computed from the order in the PrefixSlots and SuffixSlots attributes (below). Existing front-ends to AMPLE (such as CarlaMen) do something similar by allowing the user to choose to apply all prefixes before all suffixes, or vice versa, and something similar will probably suffice as a default here.

General Info
Name | Slots
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffixTemplate
End B | <unnamed> | 0..* | MoInflAffixSlot

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixTemplate
Association | Slots
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlot
Association | Slots
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoDerivTrace
Child Element | MoInflTemplateApp


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhNaturalClass
Child Element | PhNCFeatures


Association InflectionClasses Report

Report: | General Info | Association Ends | Tagged Values

Association InflectionClasses

refers to a collection of MoInflectionClass, giving the conjugation or declension classes to which this allomorph belongs. This supports the collapsing into allomorphs of affixes which differ only in their form and in their requirements for inflection class. The allomorph which is the default will not specify any inflection class, and will therefore be used for all inflection classes not specified by other allomorphs. An empty value of this attribute therefore does not mean that this allomorph is not used in any inflection classes. In theory, this attr should be atomic, at least for inflectional affixes. That is, an inflectional affix should either specify a single inflection class, or it should be the elsewhere case, in which case it does not specify any inflection class (Carstairs-McCarthy 1994). It is nonetheless defined here as a seq attr, (1) for stealth-to-wealth reasons, and (2) because this theoretical claim may be wrong. There should however be tools to help the analyst discover inflectional affixes which have more than one inflection class specified in this attr, and if possible correct the analysis.

General Info
Name | InflectionClasses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAffixForm
End B | <unnamed> | 0..* | MoInflClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |
Tag Name: Questions |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixForm
Association | InflectionClasses
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | InflectionClasses
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association SenseTypes Report

Report: | General Info | Association Ends | Tagged Values

Association SenseTypes

General Info
Name | SenseTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | SenseTypes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | SenseTypes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhNaturalClass


Association InflFeats Report

Report: | General Info | Association Ends | Tagged Values

Association InflFeats

Owns an FsFeatStruc, giving the morphosyntactic features which the word is to be inflected for at the end of the derivation. Changed from InflectionFeatures for the database port.

General Info
Name | InflFeats
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivStepMsa
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivStepMsa
Association | InflFeats
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | InflFeats
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AllomorphIndex Report

Report: | General Info | Association Ends | Tagged Values

Association AllomorphIndex

General Info
Name | AllomorphIndex
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 0..* | MoForm

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | AllomorphIndex
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoForm
Association | AllomorphIndex
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | LexAppendix


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhPhonData


Association StemForm Report

Report: | General Info | Association Ends | Tagged Values

Association StemForm

refers to an MoStemAllomorph, a stem found in the lexicon.

General Info
Name | StemForm
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDeriv
End B | <unnamed> | 1 | MoStemAllomorph

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDeriv
Association | StemForm
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemAllomorph
Association | StemForm
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Entries Report

Report: | General Info | Association Ends | Tagged Values

Association Entries

General Info
Name | Entries
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ReversalIndex
End B | <unnamed> | 0..* | ReversalIndexEntry

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ReversalIndex
Association | Entries
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ReversalIndexEntry
Association | Entries
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Environments Report

Report: | General Info | Association Ends | Tagged Values

Association Environments

General Info
Name | Environments
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonData
End B | <unnamed> | 0..* | PhEnvironment

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonData
Association | Environments
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhEnvironment
Association | Environments
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoAdhocProhib
Child Element | MoAlloAdhocProhib


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoDerivTrace
Child Element | MoInflAffixSlotApp


Association Regions Report

Report: | General Info | Association Ends | Tagged Values

Association Regions

owns a collection of FsFeatStrucs. Conceptually, this is analogous to MoInflectionalAffixMsa.InflectionalFeatures, defining the parts of the paradigm that use this stem. However, unlike an inflectional affix, it is possible for a stem to have more than one FsFeatStruc and therefore pertain to more than one contiguous region of a paradigm, i.e. a stem need have no particular (or at least no consistent) semantics over and above the semantics of the lexeme it belongs to. (Again, see Aronoff 1992.) An example is the '1sg/subj' stem which for many Spanish verbs is used for the past subjunctive and the 1sg present indicative, such as teng- 'have'. In addition to being relevant to one or more regions of a paradigm, a stem may be relevant to derivational morphology. This is indicated in the model by referencing the MoStemName from the MoDerivationalAffixMsa.

General Info
Name | Regions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemName
End B | <unnamed> | 0..* | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemName
Association | Regions
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | Regions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoRuleMapping
Child Element | MoInsertNC


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhSimpleContext
Child Element | PhSimpleContextBdry


Association PartsOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association PartsOfSpeech

General Info
Name | PartsOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ReversalIndex
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ReversalIndex
Association | PartsOfSpeech
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | PartsOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association FeatureStructure Report

Report: | General Info | Association Ends | Tagged Values

Association FeatureStructure

Allows the user to write phonological rules that are sensitive to a particular phoneme (as opposed to a class of phonemes).

General Info
Name | FeatureStructure
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSimpleContextSeg
End B | <unnamed> | 1 | PhPhoneme

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSimpleContextSeg
Association | FeatureStructure
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhoneme
Association | FeatureStructure
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoDerivTrace
Child Element | MoStratumApp


Association StemMsa Report

Report: | General Info | Association Ends | Tagged Values

Association StemMsa

refers to an MoStemMsa, a stem found in the lexicon. Note that this object and the allomorph pointed to by the StemForm must belong to the same LexEntry.

General Info
Name | StemMsa
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDeriv
End B | <unnamed> | 1 | MoStemMsa

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDeriv
Association | StemMsa
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | StemMsa
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Stratum Report

Report: | General Info | Association Ends | Tagged Values

Association Stratum

refers to an MoStratum, giving the stratum to which this rule belongs. The assumption behind the fact that this is an atomic attribute, is that a given compound rule (i.e. type of compound) can belong to only one stratum. If compounding happens in more than one stratum, then there must be more than one compounding rule. See also the discussion of MoStratum.vCompoundRules..

General Info
Name | Stratum
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoCompoundRule
End B | <unnamed> | 1 | MoStratum

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoCompoundRule
Association | Stratum
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratum
Association | Stratum
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoForm
Child Element | MoAffixForm


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | LexExampleSentence


Association FeatureStructure Report

Report: | General Info | Association Ends | Tagged Values

Association FeatureStructure

General Info
Name | FeatureStructure
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSimpleContextBdry
End B | <unnamed> | 1 | PhBdryMarker

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSimpleContextBdry
Association | FeatureStructure
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhBdryMarker
Association | FeatureStructure
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmTranslation


Association CompoundRuleApps Report

Report: | General Info | Association Ends | Tagged Values

Association CompoundRuleApps

owns an ordered seq of MoCompoundRuleApp, representing the application of compound rules belonging to this stratum. The order is the order of application in derivation (which may be the reverse of the order in parsing).

General Info
Name | CompoundRuleApps
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStratumApp
End B | <unnamed> | 0..* | MoCompoundRuleApp

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratumApp
Association | CompoundRuleApps
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoCompoundRuleApp
Association | CompoundRuleApps
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Package Component View::Ling index

Classes
ChkRef
ChkRendering
ChkSense
ChkTerm
ConstChartClauseMarker
ConstChartMovedTextMarker
ConstChartRow
ConstChartTag
ConstChartWordGroup
ConstituentChartCellPart
DsChart
DsConstChart
DsDiscourseData
LexAppendix
LexDb
LexEntry
LexEntryRef
LexEntryType
LexEtymology
LexExampleSentence
LexPronunciation
LexReference
LexRefType
LexSense
MoAdhocProhib
MoAdhocProhibGr
MoAffixAllomorph
MoAffixForm
MoAffixProcess
MoAlloAdhocProhib
MoBinaryCompoundRule
MoCompoundRule
MoCompoundRuleApp
MoCoordinateCompound
MoCopyFromInput
MoDeriv
MoDerivAffApp
MoDerivAffMsa
MoDerivStepMsa
MoDerivTrace
MoEndoCompound
MoExoCompound
MoForm
MoGlossItem
MoGlossSystem
MoInflAffixSlot
MoInflAffixSlotApp
MoInflAffixTemplate
MoInflAffMsa
MoInflClass
MoInflTemplateApp
MoInsertNC
MoInsertPhones
MoModifyFromInput
MoMorphAdhocProhib
MoMorphData
MoMorphSynAnalysis
MoMorphType
MoPhonolRuleApp
MoReferralRule
MoRuleMapping
MoStemAllomorph
MoStemMsa
MoStemName
MoStratum
MoStratumApp
MoUnclassifiedAffixMsa
PartOfSpeech
PhBdryMarker
PhCode
PhContextOrVar
PhEnvironment
PhFeatureConstraint
PhIterationContext
PhMetathesisRule
PhNaturalClass
PhNCFeatures
PhNCSegments
PhPhonContext
PhPhonData
PhPhoneme
PhPhonemeSet
PhPhonRuleFeat
PhRegularRule
PhSegmentRule
PhSegRuleRHS
PhSequenceContext
PhSimpleContext
PhSimpleContextBdry
PhSimpleContextNC
PhSimpleContextSeg
PhTerminalUnit
PhVariable
ReversalIndex
ReversalIndexEntry
Text
WfiAnalysis
WfiGloss
WfiMorphBundle
WfiWordform
WfiWordSet
WordFormLookup
WordformLookupList
Associations
AdhocCoProhibitions [MoMorphData - MoAdhocProhib]
AffixCategory [MoInflAffMsa - CmPossibility]
AffixCategory [MoDerivAffMsa - CmPossibility]
AffixForm [MoDerivAffApp - MoAffixAllomorph]
AffixForm [MoInflAffixSlotApp - MoAffixForm]
AffixMsa [MoDerivAffApp - MoDerivAffMsa]
AffixMsa [MoInflAffixSlotApp - MoInflAffMsa]
AffixSlots [PartOfSpeech - MoInflAffixSlot]
AffixTemplates [PartOfSpeech - MoInflAffixTemplate]
AllomorphIndex [LexDb - MoForm]
Allomorphs [MoAlloAdhocProhib - MoForm]
AlternateForms [LexEntry - MoForm]
Analyses [WfiWordform - WfiAnalysis]
AnalyzingAgents [MoMorphData - CmAgent]
AnthroCodes [WordFormLookup - CmAnthroItem]
AnthroCodes [LexSense - CmAnthroItem]
Appendixes [LexDb - LexAppendix]
Appendixes [LexSense - LexAppendix]
BearableFeatures [PartOfSpeech - FsFeatDefn]
BoundaryMarkers [PhPhonemeSet - PhBdryMarker]
Cases [WfiWordSet - WfiWordform]
Category [WfiAnalysis - PartOfSpeech]
Cells [ConstChartRow - ConstituentChartCellPart]
ChartMarkers [DsDiscourseData - CmPossibilityList]
Charts [DsDiscourseData - DsChart]
Codes [PhTerminalUnit - PhCode]
ComplexEntryTypes [LexEntryRef - LexEntryType]
Components [MoMorphSynAnalysis - MoMorphSynAnalysis]
CompoundRuleApps [MoStratumApp - MoCompoundRuleApp]
CompoundRuleApps [WfiAnalysis - MoCompoundRule]
CompoundRules [MoMorphData - MoCompoundRule]
ConstChartTempl [DsDiscourseData - CmPossibilityList]
Content [MoInsertNC - PhNaturalClass]
Content [MoCopyFromInput - PhContextOrVar]
Content [MoInsertPhones - PhTerminalUnit]
Content [MoModifyFromInput - PhContextOrVar]
Contents [LexAppendix - StText]
Contents [Text - StText]
Contexts [PhPhonData - PhContextOrVar]
DefaultAffix [MoStemName - MoInflAffMsa]
DefaultFeatures [PartOfSpeech - FsFeatStruc]
DefaultInflectionClass [PartOfSpeech - MoInflClass]
DefaultStem [MoStemName - MoStemName]
DependentClauses [ConstChartClauseMarker - ConstChartRow]
DerivAffApp [MoStratumApp - MoDerivAffApp]
Derivation [WfiAnalysis - MoDeriv]
Description [PhPhonContext - StText]
DomainTypes [LexSense - CmPossibility]
DomainTypes [LexDb - CmPossibilityList]
EmptyParadigmCells [PartOfSpeech - FsFeatStruc]
Entries [ReversalIndex - ReversalIndexEntry]
Entries [LexDb - LexEntry]
EntryRefs [LexEntry - LexEntryRef]
Environments [PhPhonData - PhEnvironment]
Etymology [LexEntry - LexEtymology]
Evaluations [CmAgentEvaluation - WfiAnalysis]
Examples [LexSense - LexExampleSentence]
ExclRuleFeats [PhSegRuleRHS - PhPhonRuleFeat]
FeatConstraints [PhPhonData - PhFeatureConstraint]
FeatStructFrag [MoGlossItem - FsFeatStruc]
Feature [PhFeatureConstraint - FsFeatDefn]
Features [PhNCFeatures - FsFeatStruc]
FeatureStructure [PhSimpleContextSeg - PhPhoneme]
FeatureStructure [PhSimpleContextBdry - PhBdryMarker]
FeatureStructure [PhSimpleContextNC - PhNaturalClass]
FinalStratum [PhSegmentRule - MoStratum]
FirstAllomorph [MoAlloAdhocProhib - MoForm]
FirstMorpheme [MoMorphAdhocProhib - MoMorphSynAnalysis]
FromInflectionClass [MoDerivAffMsa - MoInflClass]
FromMsFeatures [MoDerivAffMsa - FsFeatStruc]
FromPartOfSpeech [MoDerivAffMsa - PartOfSpeech]
FromPartsOfSpeech [MoStemMsa - PartOfSpeech]
FromProdRestrict [MoDerivAffMsa - CmPossibility]
FromProdRestrict [MoInflAffMsa - CmPossibility]
FromStemName [MoDerivAffMsa - MoStemName]
GlossBundle [MoMorphSynAnalysis - MoGlossItem]
Glosses [MoGlossSystem - MoGlossItem]
GlossItems [MoGlossItem - MoGlossItem]
GlossSystem [MoMorphData - MoGlossSystem]
InflectableFeats [PartOfSpeech - FsFeatDefn]
InflectionalFeats [MoDeriv - FsFeatStruc]
InflectionClass [MoStemMsa - MoInflClass]
InflectionClass [MoDerivStepMsa - MoInflClass]
InflectionClasses [MoAffixForm - MoInflClass]
InflectionClasses [PartOfSpeech - MoInflClass]
InflFeats [MoDerivStepMsa - FsFeatStruc]
InflFeats [MoInflAffMsa - FsFeatStruc]
InflTemplateApps [WfiAnalysis - MoInflAffixTemplate]
InherFeatVal [PartOfSpeech - FsFeatStruc]
InitialStratum [PhSegmentRule - MoStratum]
Input [MoReferralRule - FsFeatStruc]
Input [MoAffixProcess - PhContextOrVar]
InputPOSes [PhSegRuleRHS - PartOfSpeech]
Introduction [LexDb - StText]
LeftContext [PhEnvironment - PhPhonContext]
LeftContext [PhSegRuleRHS - PhPhonContext]
LeftForm [MoCompoundRuleApp - MoStemAllomorph]
LeftMsa [MoBinaryCompoundRule - MoStemMsa]
LexemeForm [LexEntry - MoForm]
LexicalFormIndex [LexDb - LexEntry]
Linker [MoBinaryCompoundRule - MoAffixForm]
Linker [MoCompoundRuleApp - MoAffixAllomorph]
Meaning [ChkRendering - WfiGloss]
Meanings [WfiAnalysis - WfiGloss]
MediaFiles [LexPronunciation - CmMedia]
Member [PhIterationContext - PhPhonContext]
Members [PhSequenceContext - PhPhonContext]
Members [MoAdhocProhibGr - MoAdhocProhib]
MinusConstr [PhSimpleContextNC - PhFeatureConstraint]
Modification [MoModifyFromInput - PhNCFeatures]
Morph [WfiMorphBundle - MoForm]
MorphBundles [WfiAnalysis - WfiMorphBundle]
Morphemes [MoMorphAdhocProhib - MoMorphSynAnalysis]
MorphoSyntaxAnalyses [LexEntry - MoMorphSynAnalysis]
MorphoSyntaxAnalysis [LexSense - MoMorphSynAnalysis]
MorphType [MoForm - MoMorphType]
MorphTypes [LexDb - CmPossibilityList]
Msa [WfiMorphBundle - MoMorphSynAnalysis]
MsEnvFeatures [MoAffixAllomorph - FsFeatStruc]
MsEnvPartOfSpeech [MoAffixAllomorph - PartOfSpeech]
MsFeatures [MoDerivStepMsa - FsFeatStruc]
MsFeatures [MoStemMsa - FsFeatStruc]
MsFeatures [WfiAnalysis - FsFeatStruc]
NaturalClasses [PhPhonData - PhNaturalClass]
Occurrences [ChkTerm - ChkRef]
Output [MoAffixProcess - MoRuleMapping]
Output [MoReferralRule - FsFeatStruc]
OutputMsa [MoDerivAffApp - MoDerivStepMsa]
OverridingMsa [MoEndoCompound - MoStemMsa]
PartOfSpeech [ReversalIndexEntry - PartOfSpeech]
PartOfSpeech [MoStemMsa - PartOfSpeech]
PartOfSpeech [MoDerivStepMsa - PartOfSpeech]
PartOfSpeech [MoUnclassifiedAffixMsa - PartOfSpeech]
PartOfSpeech [MoInflAffMsa - PartOfSpeech]
PartsOfSpeech [ReversalIndex - CmPossibilityList]
PhoneEnv [MoStemAllomorph - PhEnvironment]
PhoneEnv [MoAffixAllomorph - PhEnvironment]
Phonemes [PhPhonemeSet - PhPhoneme]
Phonemes [MoStratum - PhPhonemeSet]
PhonemeSets [PhPhonData - PhPhonemeSet]
PhonRules [PhPhonData - PhSegmentRule]
Pictures [LexSense - CmPicture]
PlusConstr [PhSimpleContextNC - PhFeatureConstraint]
Position [MoAffixAllomorph - PhEnvironment]
PrefixSlots [MoInflAffixTemplate - MoInflAffixSlot]
ProdRestrict [MoStemMsa - CmPossibility]
ProdRestrict [MoDerivStepMsa - CmPossibility]
Pronunciations [LexEntry - LexPronunciation]
PRuleApps [MoStratumApp - MoPhonolRuleApp]
ReferenceForms [MoInflClass - FsFeatStruc]
ReferenceForms [PartOfSpeech - FsFeatStruc]
References [LexDb - CmPossibilityList]
Region [MoInflAffixTemplate - FsFeatStruc]
Regions [MoStemName - FsFeatStruc]
Rendering [ChkRef - WfiWordform]
Renderings [ChkTerm - ChkRendering]
ReqRuleFeats [PhSegRuleRHS - PhPhonRuleFeat]
Resources [LexDb - CmResource]
RestOfAllos [MoAlloAdhocProhib - MoForm]
RestOfMorphs [MoMorphAdhocProhib - MoMorphSynAnalysis]
ReversalEntries [LexSense - ReversalIndexEntry]
ReversalIndexes [LexDb - ReversalIndex]
RightContext [PhEnvironment - PhPhonContext]
RightContext [PhSegRuleRHS - PhPhonContext]
RightForm [MoCompoundRuleApp - MoStemAllomorph]
RightHandSides [PhRegularRule - PhSegRuleRHS]
RightMsa [MoBinaryCompoundRule - MoStemMsa]
Rows [DsConstChart - ConstChartRow]
Rule [MoPhonolRuleApp - CmObject]
RulesOfReferral [PartOfSpeech - MoReferralRule]
RulesOfReferral [MoInflClass - MoReferralRule]
Segments [PhNCSegments - PhPhoneme]
SemanticDomains [LexSense - CmSemanticDomain]
Sense [WfiMorphBundle - LexSense]
Sense [ChkSense - LexSense]
Senses [LexSense - LexSense]
Senses [LexEntry - LexSense]
SenseType [LexSense - CmPossibility]
SenseTypes [LexDb - CmPossibilityList]
Slot [MoInflAffixSlotApp - MoInflAffixSlot]
SlotApps [MoInflTemplateApp - MoInflAffixSlotApp]
Slots [MoInflAffixTemplate - MoInflAffixSlot]
Slots [MoInflAffMsa - MoInflAffixSlot]
Status [LexDb - CmPossibilityList]
Status [LexSense - CmPossibility]
StemForm [MoDeriv - MoStemAllomorph]
StemMsa [MoDeriv - MoStemMsa]
StemName [MoStemAllomorph - MoStemName]
StemNames [PartOfSpeech - MoStemName]
StemNames [MoInflClass - MoStemName]
Stems [WfiAnalysis - LexEntry]
Strata [MoMorphData - MoStratum]
Stratum [MoCompoundRule - MoStratum]
Stratum [MoDerivAffMsa - MoStratum]
Stratum [MoStemMsa - MoStratum]
Stratum [MoStratumApp - MoStratum]
Stratum [MoInflAffixTemplate - MoStratum]
StratumApps [MoDeriv - MoStratumApp]
StrucChange [PhSegRuleRHS - PhSimpleContext]
StrucDesc [PhSegmentRule - PhSimpleContext]
Subclasses [MoInflClass - MoInflClass]
Subentries [ReversalIndexEntry - ReversalIndexEntry]
SuffixSlots [MoInflAffixTemplate - MoInflAffixSlot]
SurfaceForm [ChkRendering - WfiWordform]
Target [MoGlossItem - MoGlossItem]
Template [MoInflTemplateApp - MoInflAffixTemplate]
TemplateApp [MoStratumApp - MoInflTemplateApp]
TestSets [MoMorphData - WfiWordSet]
ThesaurusItems [LexSense - CmPossibility]
ThesaurusItems [WordFormLookup - CmPossibility]
ToInflectionClass [MoDerivAffMsa - MoInflClass]
ToMsa [MoExoCompound - MoStemMsa]
ToMsFeatures [MoDerivAffMsa - FsFeatStruc]
ToPartOfSpeech [MoDerivAffMsa - PartOfSpeech]
ToProdRestrict [MoDerivAffMsa - CmPossibility]
ToProdRestrict [MoCompoundRule - CmPossibility]
Translations [LexExampleSentence - CmTranslation]
Type [CmTranslation - CmPossibility]
UsageTypes [LexSense - CmPossibility]
UsageTypes [LexDb - CmPossibilityList]
VariantEntryTypes [LexEntryRef - LexEntryType]
Wordforms [WordformLookupList - WordFormLookup]
WordGroup [ConstChartMovedTextMarker - ConstChartWordGroup]
Generalizations
<unnamed> [PhNaturalClass - CmObject]
<unnamed> [LexAppendix - CmObject]
<unnamed> [PhPhonData - CmObject]
<unnamed> [MoAlloAdhocProhib - MoAdhocProhib]
<unnamed> [MoInflAffixSlotApp - MoDerivTrace]
<unnamed> [MoInsertNC - MoRuleMapping]
<unnamed> [PhSimpleContextBdry - PhSimpleContext]
<unnamed> [MoStratumApp - MoDerivTrace]
<unnamed> [MoAffixForm - MoForm]
<unnamed> [LexExampleSentence - CmObject]
<unnamed> [CmTranslation - CmObject]
<unnamed> [ReversalIndex - CmMajorObject]
<unnamed> [Text - CmMajorObject]
<unnamed> [MoInflAffixTemplate - CmObject]
<unnamed> [PhEnvironment - CmObject]
<unnamed> [MoInflTemplateApp - MoDerivTrace]
<unnamed> [MoBinaryCompoundRule - MoCompoundRule]
<unnamed> [LexDb - CmMajorObject]
<unnamed> [MoStemMsa - MoMorphSynAnalysis]
<unnamed> [MoReferralRule - CmObject]
<unnamed> [MoStemAllomorph - MoForm]
<unnamed> [MoInflAffMsa - MoMorphSynAnalysis]
<unnamed> [MoCompoundRule - CmObject]
<unnamed> [MoPhonolRuleApp - MoDerivTrace]
<unnamed> [PhNCFeatures - PhNaturalClass]
<unnamed> [LexSense - CmObject]
<unnamed> [MoStratum - CmObject]
<unnamed> [MoEndoCompound - MoBinaryCompoundRule]
<unnamed> [PhCode - CmObject]
<unnamed> [PhSequenceContext - PhPhonContext]
<unnamed> [MoDerivAffApp - MoDerivTrace]
<unnamed> [MoDerivTrace - CmObject]
<unnamed> [MoDerivStepMsa - MoMorphSynAnalysis]
<unnamed> [PhSimpleContextSeg - PhSimpleContext]
<unnamed> [MoMorphSynAnalysis - CmObject]
<unnamed> [MoStemName - CmObject]
<unnamed> [MoCopyFromInput - MoRuleMapping]
<unnamed> [ReversalIndexEntry - CmObject]
<unnamed> [PhPhoneme - PhTerminalUnit]
<unnamed> [MoMorphData - CmObject]
<unnamed> [LexPronunciation - CmObject]
<unnamed> [MoInsertPhones - MoRuleMapping]
<unnamed> [PhContextOrVar - CmObject]
<unnamed> [MoMorphType - CmPossibility]
<unnamed> [WordformLookupList - CmMajorObject]
<unnamed> [PhTerminalUnit - CmObject]
<unnamed> [MoModifyFromInput - MoRuleMapping]
<unnamed> [MoCoordinateCompound - MoBinaryCompoundRule]
<unnamed> [WordFormLookup - CmObject]
<unnamed> [PhNCSegments - PhNaturalClass]
<unnamed> [LexEntry - CmObject]
<unnamed> [PhBdryMarker - PhTerminalUnit]
<unnamed> [WfiWordform - CmObject]
<unnamed> [MoCompoundRuleApp - MoDerivTrace]
<unnamed> [WfiGloss - CmObject]
<unnamed> [MoDerivAffMsa - MoMorphSynAnalysis]
<unnamed> [PhIterationContext - PhPhonContext]
<unnamed> [MoInflClass - CmObject]
<unnamed> [WfiWordSet - CmObject]
<unnamed> [MoRuleMapping - CmObject]
<unnamed> [PhSimpleContext - PhPhonContext]
<unnamed> [MoAffixProcess - MoAffixForm]
<unnamed> [PartOfSpeech - CmPossibility]
<unnamed> [MoExoCompound - MoBinaryCompoundRule]
<unnamed> [PhFeatureConstraint - CmObject]
<unnamed> [PhSimpleContextNC - PhSimpleContext]
<unnamed> [MoAdhocProhib - CmObject]
<unnamed> [MoMorphAdhocProhib - MoAdhocProhib]
<unnamed> [MoForm - CmObject]
<unnamed> [MoAffixAllomorph - MoAffixForm]
<unnamed> [PhPhonemeSet - CmObject]
<unnamed> [MoAdhocProhibGr - MoAdhocProhib]
<unnamed> [PhPhonContext - PhContextOrVar]
<unnamed> [PhVariable - PhContextOrVar]
<unnamed> [ChkTerm - CmPossibility]
<unnamed> [ChkRef - CmObject]
<unnamed> [LexReference - CmObject]
<unnamed> [ChkSense - CmObject]
<unnamed> [ChkRendering - CmObject]
<unnamed> [PhSegmentRule - CmObject]
<unnamed> [PhSegRuleRHS - CmObject]
<unnamed> [PhPhonRuleFeat - CmPossibility]


PackageComponent View::Ling Report

View: | Hide Browser | Browser on the left | Browser on the right | Dictionary
Report: | General Info | Inner Elements | Inner Relations | Tagged Values

Package Component View::Ling

General Info
Name | Ling
Abstract | false
Leaf | false
Root | false
Owner | Component View

Inner Elements
Name | Type
ChkRef | Class
ChkRendering | Class
ChkSense | Class
ChkTerm | Class
ConstChartClauseMarker | Class
ConstChartMovedTextMarker | Class
ConstChartRow | Class
ConstChartTag | Class
ConstChartWordGroup | Class
ConstituentChartCellPart | Class
DsChart | Class
DsConstChart | Class
DsDiscourseData | Class
LexAppendix | Class
LexDb | Class
LexEntry | Class
LexEntryRef | Class
LexEntryType | Class
LexEtymology | Class
LexExampleSentence | Class
LexPronunciation | Class
LexReference | Class
LexRefType | Class
LexSense | Class
MoAdhocProhib | Class
MoAdhocProhibGr | Class
MoAffixAllomorph | Class
MoAffixForm | Class
MoAffixProcess | Class
MoAlloAdhocProhib | Class
MoBinaryCompoundRule | Class
MoCompoundRule | Class
MoCompoundRuleApp | Class
MoCoordinateCompound | Class
MoCopyFromInput | Class
MoDeriv | Class
MoDerivAffApp | Class
MoDerivAffMsa | Class
MoDerivStepMsa | Class
MoDerivTrace | Class
MoEndoCompound | Class
MoExoCompound | Class
MoForm | Class
MoGlossItem | Class
MoGlossSystem | Class
MoInflAffixSlot | Class
MoInflAffixSlotApp | Class
MoInflAffixTemplate | Class
MoInflAffMsa | Class
MoInflClass | Class
MoInflTemplateApp | Class
MoInsertNC | Class
MoInsertPhones | Class
MoModifyFromInput | Class
MoMorphAdhocProhib | Class
MoMorphData | Class
MoMorphSynAnalysis | Class
MoMorphType | Class
MoPhonolRuleApp | Class
MoReferralRule | Class
MoRuleMapping | Class
MoStemAllomorph | Class
MoStemMsa | Class
MoStemName | Class
MoStratum | Class
MoStratumApp | Class
MoUnclassifiedAffixMsa | Class
PartOfSpeech | Class
PhBdryMarker | Class
PhCode | Class
PhContextOrVar | Class
PhEnvironment | Class
PhFeatureConstraint | Class
PhIterationContext | Class
PhMetathesisRule | Class
PhNaturalClass | Class
PhNCFeatures | Class
PhNCSegments | Class
PhPhonContext | Class
PhPhonData | Class
PhPhoneme | Class
PhPhonemeSet | Class
PhPhonRuleFeat | Class
PhRegularRule | Class
PhSegmentRule | Class
PhSegRuleRHS | Class
PhSequenceContext | Class
PhSimpleContext | Class
PhSimpleContextBdry | Class
PhSimpleContextNC | Class
PhSimpleContextSeg | Class
PhTerminalUnit | Class
PhVariable | Class
ReversalIndex | Class
ReversalIndexEntry | Class
Text | Class
WfiAnalysis | Class
WfiGloss | Class
WfiMorphBundle | Class
WfiWordform | Class
WfiWordSet | Class
WordFormLookup | Class
WordformLookupList | Class

Inner Relations
Association AdhocCoProhibitions [MoMorphData - MoAdhocProhib]
Association AffixCategory [MoInflAffMsa - CmPossibility]
Association AffixCategory [MoDerivAffMsa - CmPossibility]
Association AffixForm [MoDerivAffApp - MoAffixAllomorph]
Association AffixForm [MoInflAffixSlotApp - MoAffixForm]
Association AffixMsa [MoDerivAffApp - MoDerivAffMsa]
Association AffixMsa [MoInflAffixSlotApp - MoInflAffMsa]
Association AffixSlots [PartOfSpeech - MoInflAffixSlot]
Association AffixTemplates [PartOfSpeech - MoInflAffixTemplate]
Association AllomorphIndex [LexDb - MoForm]
Association Allomorphs [MoAlloAdhocProhib - MoForm]
Association AlternateForms [LexEntry - MoForm]
Association Analyses [WfiWordform - WfiAnalysis]
Association AnalyzingAgents [MoMorphData - CmAgent]
Association AnthroCodes [WordFormLookup - CmAnthroItem]
Association AnthroCodes [LexSense - CmAnthroItem]
Association Appendixes [LexDb - LexAppendix]
Association Appendixes [LexSense - LexAppendix]
Association BearableFeatures [PartOfSpeech - FsFeatDefn]
Association BoundaryMarkers [PhPhonemeSet - PhBdryMarker]
Association Cases [WfiWordSet - WfiWordform]
Association Category [WfiAnalysis - PartOfSpeech]
Association Cells [ConstChartRow - ConstituentChartCellPart]
Association ChartMarkers [DsDiscourseData - CmPossibilityList]
Association Charts [DsDiscourseData - DsChart]
Association Codes [PhTerminalUnit - PhCode]
Association ComplexEntryTypes [LexEntryRef - LexEntryType]
Association Components [MoMorphSynAnalysis - MoMorphSynAnalysis]
Association CompoundRuleApps [MoStratumApp - MoCompoundRuleApp]
Association CompoundRuleApps [WfiAnalysis - MoCompoundRule]
Association CompoundRules [MoMorphData - MoCompoundRule]
Association ConstChartTempl [DsDiscourseData - CmPossibilityList]
Association Content [MoInsertNC - PhNaturalClass]
Association Content [MoCopyFromInput - PhContextOrVar]
Association Content [MoInsertPhones - PhTerminalUnit]
Association Content [MoModifyFromInput - PhContextOrVar]
Association Contents [LexAppendix - StText]
Association Contents [Text - StText]
Association Contexts [PhPhonData - PhContextOrVar]
Association DefaultAffix [MoStemName - MoInflAffMsa]
Association DefaultFeatures [PartOfSpeech - FsFeatStruc]
Association DefaultInflectionClass [PartOfSpeech - MoInflClass]
Association DefaultStem [MoStemName - MoStemName]
Association DependentClauses [ConstChartClauseMarker - ConstChartRow]
Association DerivAffApp [MoStratumApp - MoDerivAffApp]
Association Derivation [WfiAnalysis - MoDeriv]
Association Description [PhPhonContext - StText]
Association DomainTypes [LexSense - CmPossibility]
Association DomainTypes [LexDb - CmPossibilityList]
Association EmptyParadigmCells [PartOfSpeech - FsFeatStruc]
Association Entries [ReversalIndex - ReversalIndexEntry]
Association Entries [LexDb - LexEntry]
Association EntryRefs [LexEntry - LexEntryRef]
Association Environments [PhPhonData - PhEnvironment]
Association Etymology [LexEntry - LexEtymology]
Association Evaluations [CmAgentEvaluation - WfiAnalysis]
Association Examples [LexSense - LexExampleSentence]
Association ExclRuleFeats [PhSegRuleRHS - PhPhonRuleFeat]
Association FeatConstraints [PhPhonData - PhFeatureConstraint]
Association FeatStructFrag [MoGlossItem - FsFeatStruc]
Association Feature [PhFeatureConstraint - FsFeatDefn]
Association Features [PhNCFeatures - FsFeatStruc]
Association FeatureStructure [PhSimpleContextSeg - PhPhoneme]
Association FeatureStructure [PhSimpleContextBdry - PhBdryMarker]
Association FeatureStructure [PhSimpleContextNC - PhNaturalClass]
Association FinalStratum [PhSegmentRule - MoStratum]
Association FirstAllomorph [MoAlloAdhocProhib - MoForm]
Association FirstMorpheme [MoMorphAdhocProhib - MoMorphSynAnalysis]
Association FromInflectionClass [MoDerivAffMsa - MoInflClass]
Association FromMsFeatures [MoDerivAffMsa - FsFeatStruc]
Association FromPartOfSpeech [MoDerivAffMsa - PartOfSpeech]
Association FromPartsOfSpeech [MoStemMsa - PartOfSpeech]
Association FromProdRestrict [MoDerivAffMsa - CmPossibility]
Association FromProdRestrict [MoInflAffMsa - CmPossibility]
Association FromStemName [MoDerivAffMsa - MoStemName]
Association GlossBundle [MoMorphSynAnalysis - MoGlossItem]
Association Glosses [MoGlossSystem - MoGlossItem]
Association GlossItems [MoGlossItem - MoGlossItem]
Association GlossSystem [MoMorphData - MoGlossSystem]
Association InflectableFeats [PartOfSpeech - FsFeatDefn]
Association InflectionalFeats [MoDeriv - FsFeatStruc]
Association InflectionClass [MoStemMsa - MoInflClass]
Association InflectionClass [MoDerivStepMsa - MoInflClass]
Association InflectionClasses [MoAffixForm - MoInflClass]
Association InflectionClasses [PartOfSpeech - MoInflClass]
Association InflFeats [MoDerivStepMsa - FsFeatStruc]
Association InflFeats [MoInflAffMsa - FsFeatStruc]
Association InflTemplateApps [WfiAnalysis - MoInflAffixTemplate]
Association InherFeatVal [PartOfSpeech - FsFeatStruc]
Association InitialStratum [PhSegmentRule - MoStratum]
Association Input [MoReferralRule - FsFeatStruc]
Association Input [MoAffixProcess - PhContextOrVar]
Association InputPOSes [PhSegRuleRHS - PartOfSpeech]
Association Introduction [LexDb - StText]
Association LeftContext [PhEnvironment - PhPhonContext]
Association LeftContext [PhSegRuleRHS - PhPhonContext]
Association LeftForm [MoCompoundRuleApp - MoStemAllomorph]
Association LeftMsa [MoBinaryCompoundRule - MoStemMsa]
Association LexemeForm [LexEntry - MoForm]
Association LexicalFormIndex [LexDb - LexEntry]
Association Linker [MoBinaryCompoundRule - MoAffixForm]
Association Linker [MoCompoundRuleApp - MoAffixAllomorph]
Association Meaning [ChkRendering - WfiGloss]
Association Meanings [WfiAnalysis - WfiGloss]
Association MediaFiles [LexPronunciation - CmMedia]
Association Member [PhIterationContext - PhPhonContext]
Association Members [PhSequenceContext - PhPhonContext]
Association Members [MoAdhocProhibGr - MoAdhocProhib]
Association MinusConstr [PhSimpleContextNC - PhFeatureConstraint]
Association Modification [MoModifyFromInput - PhNCFeatures]
Association Morph [WfiMorphBundle - MoForm]
Association MorphBundles [WfiAnalysis - WfiMorphBundle]
Association Morphemes [MoMorphAdhocProhib - MoMorphSynAnalysis]
Association MorphoSyntaxAnalyses [LexEntry - MoMorphSynAnalysis]
Association MorphoSyntaxAnalysis [LexSense - MoMorphSynAnalysis]
Association MorphType [MoForm - MoMorphType]
Association MorphTypes [LexDb - CmPossibilityList]
Association Msa [WfiMorphBundle - MoMorphSynAnalysis]
Association MsEnvFeatures [MoAffixAllomorph - FsFeatStruc]
Association MsEnvPartOfSpeech [MoAffixAllomorph - PartOfSpeech]
Association MsFeatures [MoDerivStepMsa - FsFeatStruc]
Association MsFeatures [MoStemMsa - FsFeatStruc]
Association MsFeatures [WfiAnalysis - FsFeatStruc]
Association NaturalClasses [PhPhonData - PhNaturalClass]
Association Occurrences [ChkTerm - ChkRef]
Association Output [MoAffixProcess - MoRuleMapping]
Association Output [MoReferralRule - FsFeatStruc]
Association OutputMsa [MoDerivAffApp - MoDerivStepMsa]
Association OverridingMsa [MoEndoCompound - MoStemMsa]
Association PartOfSpeech [ReversalIndexEntry - PartOfSpeech]
Association PartOfSpeech [MoStemMsa - PartOfSpeech]
Association PartOfSpeech [MoDerivStepMsa - PartOfSpeech]
Association PartOfSpeech [MoUnclassifiedAffixMsa - PartOfSpeech]
Association PartOfSpeech [MoInflAffMsa - PartOfSpeech]
Association PartsOfSpeech [ReversalIndex - CmPossibilityList]
Association PhoneEnv [MoStemAllomorph - PhEnvironment]
Association PhoneEnv [MoAffixAllomorph - PhEnvironment]
Association Phonemes [PhPhonemeSet - PhPhoneme]
Association Phonemes [MoStratum - PhPhonemeSet]
Association PhonemeSets [PhPhonData - PhPhonemeSet]
Association PhonRules [PhPhonData - PhSegmentRule]
Association Pictures [LexSense - CmPicture]
Association PlusConstr [PhSimpleContextNC - PhFeatureConstraint]
Association Position [MoAffixAllomorph - PhEnvironment]
Association PrefixSlots [MoInflAffixTemplate - MoInflAffixSlot]
Association ProdRestrict [MoStemMsa - CmPossibility]
Association ProdRestrict [MoDerivStepMsa - CmPossibility]
Association Pronunciations [LexEntry - LexPronunciation]
Association PRuleApps [MoStratumApp - MoPhonolRuleApp]
Association ReferenceForms [MoInflClass - FsFeatStruc]
Association ReferenceForms [PartOfSpeech - FsFeatStruc]
Association References [LexDb - CmPossibilityList]
Association Region [MoInflAffixTemplate - FsFeatStruc]
Association Regions [MoStemName - FsFeatStruc]
Association Rendering [ChkRef - WfiWordform]
Association Renderings [ChkTerm - ChkRendering]
Association ReqRuleFeats [PhSegRuleRHS - PhPhonRuleFeat]
Association Resources [LexDb - CmResource]
Association RestOfAllos [MoAlloAdhocProhib - MoForm]
Association RestOfMorphs [MoMorphAdhocProhib - MoMorphSynAnalysis]
Association ReversalEntries [LexSense - ReversalIndexEntry]
Association ReversalIndexes [LexDb - ReversalIndex]
Association RightContext [PhEnvironment - PhPhonContext]
Association RightContext [PhSegRuleRHS - PhPhonContext]
Association RightForm [MoCompoundRuleApp - MoStemAllomorph]
Association RightHandSides [PhRegularRule - PhSegRuleRHS]
Association RightMsa [MoBinaryCompoundRule - MoStemMsa]
Association Rows [DsConstChart - ConstChartRow]
Association Rule [MoPhonolRuleApp - CmObject]
Association RulesOfReferral [PartOfSpeech - MoReferralRule]
Association RulesOfReferral [MoInflClass - MoReferralRule]
Association Segments [PhNCSegments - PhPhoneme]
Association SemanticDomains [LexSense - CmSemanticDomain]
Association Sense [WfiMorphBundle - LexSense]
Association Sense [ChkSense - LexSense]
Association Senses [LexSense - LexSense]
Association Senses [LexEntry - LexSense]
Association SenseType [LexSense - CmPossibility]
Association SenseTypes [LexDb - CmPossibilityList]
Association Slot [MoInflAffixSlotApp - MoInflAffixSlot]
Association SlotApps [MoInflTemplateApp - MoInflAffixSlotApp]
Association Slots [MoInflAffixTemplate - MoInflAffixSlot]
Association Slots [MoInflAffMsa - MoInflAffixSlot]
Association Status [LexDb - CmPossibilityList]
Association Status [LexSense - CmPossibility]
Association StemForm [MoDeriv - MoStemAllomorph]
Association StemMsa [MoDeriv - MoStemMsa]
Association StemName [MoStemAllomorph - MoStemName]
Association StemNames [PartOfSpeech - MoStemName]
Association StemNames [MoInflClass - MoStemName]
Association Stems [WfiAnalysis - LexEntry]
Association Strata [MoMorphData - MoStratum]
Association Stratum [MoCompoundRule - MoStratum]
Association Stratum [MoDerivAffMsa - MoStratum]
Association Stratum [MoStemMsa - MoStratum]
Association Stratum [MoStratumApp - MoStratum]
Association Stratum [MoInflAffixTemplate - MoStratum]
Association StratumApps [MoDeriv - MoStratumApp]
Association StrucChange [PhSegRuleRHS - PhSimpleContext]
Association StrucDesc [PhSegmentRule - PhSimpleContext]
Association Subclasses [MoInflClass - MoInflClass]
Association Subentries [ReversalIndexEntry - ReversalIndexEntry]
Association SuffixSlots [MoInflAffixTemplate - MoInflAffixSlot]
Association SurfaceForm [ChkRendering - WfiWordform]
Association Target [MoGlossItem - MoGlossItem]
Association Template [MoInflTemplateApp - MoInflAffixTemplate]
Association TemplateApp [MoStratumApp - MoInflTemplateApp]
Association TestSets [MoMorphData - WfiWordSet]
Association ThesaurusItems [LexSense - CmPossibility]
Association ThesaurusItems [WordFormLookup - CmPossibility]
Association ToInflectionClass [MoDerivAffMsa - MoInflClass]
Association ToMsa [MoExoCompound - MoStemMsa]
Association ToMsFeatures [MoDerivAffMsa - FsFeatStruc]
Association ToPartOfSpeech [MoDerivAffMsa - PartOfSpeech]
Association ToProdRestrict [MoDerivAffMsa - CmPossibility]
Association ToProdRestrict [MoCompoundRule - CmPossibility]
Association Translations [LexExampleSentence - CmTranslation]
Association Type [CmTranslation - CmPossibility]
Association UsageTypes [LexSense - CmPossibility]
Association UsageTypes [LexDb - CmPossibilityList]
Association VariantEntryTypes [LexEntryRef - LexEntryType]
Association Wordforms [WordformLookupList - WordFormLookup]
Association WordGroup [ConstChartMovedTextMarker - ConstChartWordGroup]
Generalization <unnamed> [PhNaturalClass - CmObject]
Generalization <unnamed> [LexAppendix - CmObject]
Generalization <unnamed> [PhPhonData - CmObject]
Generalization <unnamed> [MoAlloAdhocProhib - MoAdhocProhib]
Generalization <unnamed> [MoInflAffixSlotApp - MoDerivTrace]
Generalization <unnamed> [MoInsertNC - MoRuleMapping]
Generalization <unnamed> [PhSimpleContextBdry - PhSimpleContext]
Generalization <unnamed> [MoStratumApp - MoDerivTrace]
Generalization <unnamed> [MoAffixForm - MoForm]
Generalization <unnamed> [LexExampleSentence - CmObject]
Generalization <unnamed> [CmTranslation - CmObject]
Generalization <unnamed> [ReversalIndex - CmMajorObject]
Generalization <unnamed> [Text - CmMajorObject]
Generalization <unnamed> [MoInflAffixTemplate - CmObject]
Generalization <unnamed> [PhEnvironment - CmObject]
Generalization <unnamed> [MoInflTemplateApp - MoDerivTrace]
Generalization <unnamed> [MoBinaryCompoundRule - MoCompoundRule]
Generalization <unnamed> [LexDb - CmMajorObject]
Generalization <unnamed> [MoStemMsa - MoMorphSynAnalysis]
Generalization <unnamed> [MoReferralRule - CmObject]
Generalization <unnamed> [MoStemAllomorph - MoForm]
Generalization <unnamed> [MoInflAffMsa - MoMorphSynAnalysis]
Generalization <unnamed> [MoCompoundRule - CmObject]
Generalization <unnamed> [MoPhonolRuleApp - MoDerivTrace]
Generalization <unnamed> [PhNCFeatures - PhNaturalClass]
Generalization <unnamed> [LexSense - CmObject]
Generalization <unnamed> [MoStratum - CmObject]
Generalization <unnamed> [MoEndoCompound - MoBinaryCompoundRule]
Generalization <unnamed> [PhCode - CmObject]
Generalization <unnamed> [PhSequenceContext - PhPhonContext]
Generalization <unnamed> [MoDerivAffApp - MoDerivTrace]
Generalization <unnamed> [MoDerivTrace - CmObject]
Generalization <unnamed> [MoDerivStepMsa - MoMorphSynAnalysis]
Generalization <unnamed> [PhSimpleContextSeg - PhSimpleContext]
Generalization <unnamed> [MoMorphSynAnalysis - CmObject]
Generalization <unnamed> [MoStemName - CmObject]
Generalization <unnamed> [MoCopyFromInput - MoRuleMapping]
Generalization <unnamed> [ReversalIndexEntry - CmObject]
Generalization <unnamed> [PhPhoneme - PhTerminalUnit]
Generalization <unnamed> [MoMorphData - CmObject]
Generalization <unnamed> [LexPronunciation - CmObject]
Generalization <unnamed> [MoInsertPhones - MoRuleMapping]
Generalization <unnamed> [PhContextOrVar - CmObject]
Generalization <unnamed> [MoMorphType - CmPossibility]
Generalization <unnamed> [WordformLookupList - CmMajorObject]
Generalization <unnamed> [PhTerminalUnit - CmObject]
Generalization <unnamed> [MoModifyFromInput - MoRuleMapping]
Generalization <unnamed> [MoCoordinateCompound - MoBinaryCompoundRule]
Generalization <unnamed> [WordFormLookup - CmObject]
Generalization <unnamed> [PhNCSegments - PhNaturalClass]
Generalization <unnamed> [LexEntry - CmObject]
Generalization <unnamed> [PhBdryMarker - PhTerminalUnit]
Generalization <unnamed> [WfiWordform - CmObject]
Generalization <unnamed> [MoCompoundRuleApp - MoDerivTrace]
Generalization <unnamed> [WfiGloss - CmObject]
Generalization <unnamed> [MoDerivAffMsa - MoMorphSynAnalysis]
Generalization <unnamed> [PhIterationContext - PhPhonContext]
Generalization <unnamed> [MoInflClass - CmObject]
Generalization <unnamed> [WfiWordSet - CmObject]
Generalization <unnamed> [MoRuleMapping - CmObject]
Generalization <unnamed> [PhSimpleContext - PhPhonContext]
Generalization <unnamed> [MoAffixProcess - MoAffixForm]
Generalization <unnamed> [PartOfSpeech - CmPossibility]
Generalization <unnamed> [MoExoCompound - MoBinaryCompoundRule]
Generalization <unnamed> [PhFeatureConstraint - CmObject]
Generalization <unnamed> [PhSimpleContextNC - PhSimpleContext]
Generalization <unnamed> [MoAdhocProhib - CmObject]
Generalization <unnamed> [MoMorphAdhocProhib - MoAdhocProhib]
Generalization <unnamed> [MoForm - CmObject]
Generalization <unnamed> [MoAffixAllomorph - MoAffixForm]
Generalization <unnamed> [PhPhonemeSet - CmObject]
Generalization <unnamed> [MoAdhocProhibGr - MoAdhocProhib]
Generalization <unnamed> [PhPhonContext - PhContextOrVar]
Generalization <unnamed> [PhVariable - PhContextOrVar]
Generalization <unnamed> [ChkTerm - CmPossibility]
Generalization <unnamed> [ChkRef - CmObject]
Generalization <unnamed> [LexReference - CmObject]
Generalization <unnamed> [ChkSense - CmObject]
Generalization <unnamed> [ChkRendering - CmObject]
Generalization <unnamed> [PhSegmentRule - CmObject]
Generalization <unnamed> [PhSegRuleRHS - CmObject]
Generalization <unnamed> [PhPhonRuleFeat - CmPossibility]

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: ver |  |
Tag Name: verBack |  |


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmMajorObject
Child Element | ReversalIndex


Association ReversalEntries Report

Report: | General Info | Association Ends | Tagged Values

Association ReversalEntries

General Info
Name | ReversalEntries
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | ReversalIndexEntry

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | ReversalEntries
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ReversalIndexEntry
Association | ReversalEntries
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association DerivAffApp Report

Report: | General Info | Association Ends | Tagged Values

Association DerivAffApp

Owns an ordered seq of MoDerivationalAffixApp, representing the attachment of derivational affixes belonging to this stratum. The order is the order of application in derivation (which may be the reverse of the order in parsing). Changed from DerivationalAffixApps.

General Info
Name | DerivAffApp
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStratumApp
End B | <unnamed> | 0..* | MoDerivAffApp

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratumApp
Association | DerivAffApp
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffApp
Association | DerivAffApp
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association RightMsa Report

Report: | General Info | Association Ends | Tagged Values

Association RightMsa

owns an MoStemMsa, giving the morphosyntactic information about the right-hand member of this compound, in the same fashion as the LeftMsa attribute.

General Info
Name | RightMsa
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoBinaryCompoundRule
End B | <unnamed> | 1 | MoStemMsa

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoBinaryCompoundRule
Association | RightMsa
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | RightMsa
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmMajorObject
Child Element | Text


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoInflAffixTemplate


Package Component View::FeatSys index

Component View::FeatSys


PackageComponent View::FeatSys Report

Report: | General Info | Tagged Values

Package Component View::FeatSys

General Info
Name | FeatSys
Abstract | false
Leaf | false
Root | false
Owner | Component View

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: ver |  |
Tag Name: verBack |  |


Package Component View::Scripture index

Classes
ScrBook
ScrBookAnnotations
ScrBookRef
ScrCheckRun
ScrDifference
ScrDraft
ScrFootnote
ScrImportP6Project
ScrImportSet
ScrImportSFFiles
ScrImportSource
Scripture
ScrMarkerMapping
ScrRefSystem
ScrScriptureNote
ScrSection
ScrTxtPara
Associations
ArchivedDrafts [Scripture - ScrDraft]
BookId [ScrBook - ScrBookRef]
Books [ScrDraft - ScrBook]
Content [ScrSection - StText]
Diffs [ScrBook - ScrDifference]
Footnotes [ScrBook - StFootnote]
Heading [ScrSection - StText]
ImportSettings [Scripture - ScrImportSet]
Publications [CmMajorObject - Publication]
Resources [Scripture - CmResource]
RevParagraph [ScrDifference - StPara]
ScriptureBooks [Scripture - ScrBook]
Sections [ScrBook - ScrSection]
Styles [Scripture - StStyle]
Title [ScrBook - StText]
Generalizations


PackageComponent View::Scripture Report

View: | Hide Browser | Browser on the left | Browser on the right | Dictionary
Report: | General Info | Inner Elements | Inner Relations | Tagged Values

Package Component View::Scripture

General Info
Name | Scripture
Abstract | false
Leaf | false
Root | false
Owner | Component View

Inner Elements
Name | Type
ScrBook | Class
ScrBookAnnotations | Class
ScrBookRef | Class
ScrCheckRun | Class
ScrDifference | Class
ScrDraft | Class
ScrFootnote | Class
ScrImportP6Project | Class
ScrImportSet | Class
ScrImportSFFiles | Class
ScrImportSource | Class
Scripture | Class
ScrMarkerMapping | Class
ScrRefSystem | Class
ScrScriptureNote | Class
ScrSection | Class
ScrTxtPara | Class

Inner Relations
Association ArchivedDrafts [Scripture - ScrDraft]
Association BookId [ScrBook - ScrBookRef]
Association Books [ScrDraft - ScrBook]
Association Content [ScrSection - StText]
Association Diffs [ScrBook - ScrDifference]
Association Footnotes [ScrBook - StFootnote]
Association Heading [ScrSection - StText]
Association ImportSettings [Scripture - ScrImportSet]
Association Publications [CmMajorObject - Publication]
Association Resources [Scripture - CmResource]
Association RevParagraph [ScrDifference - StPara]
Association ScriptureBooks [Scripture - ScrBook]
Association Sections [ScrBook - ScrSection]
Association Styles [Scripture - StStyle]
Association Title [ScrBook - StText]
Generalization <unnamed> [ScrBookAnnotations - CmObject]

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: ver |  |
Tag Name: verBack |  |


Association InflectionClass Report

Report: | General Info | Association Ends | Tagged Values

Association InflectionClass

refers to an MoInflectionClass (i.e. a conjugation or declension class). If none is listed, PartOfSpeech.vDefaultInflectionClass is used. If there is no vDefaultInflectionClass, then there are presumably no inflection classes (since the default value for vDefaultInflectionClass is the first inflection class of the paradigm). The assumption here is that inflection class membership is essentially an arbitrary label, i.e. that the inflection class membership of a stem cannot and should not be defined by a set of stem allomorphs or lists of 'principal parts' (see discussion in Carstairs-McCarthy 1998b: 332-334).

General Info
Name | InflectionClass
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemMsa
End B | <unnamed> | 1 | MoInflClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | InflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | InflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Entries Report

Report: | General Info | Association Ends | Tagged Values

Association Entries

This is a list of all types of entries. It is sorted by citationForm, thus we no longer need the citationForm index.

General Info
Name | Entries
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 0..* | LexEntry

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | Entries
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | Entries
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhEnvironment


Package Component View::Cellar index

Classes
CmAgent
CmAgentEvaluation
CmAnnotation
CmAnnotationDefn
CmAnthroItem
CmBaseAnnotation
CmCell
CmCustomItem
CmDomainQ
CmFile
CmFilter
CmFolder
CmIndirectAnnotation
CmLocation
CmMajorObject
CmMedia
CmMediaAnnotation
CmObject
CmOverlay
CmPerson
CmPicture
CmPossibility
CmPossibilityList
CmProject
CmResource
CmRow
CmSemanticDomain
CmTranslation
CrossReference
FsAbstractStructure
FsClosedFeature
FsClosedValue
FsComplexFeature
FsComplexValue
FsDisjunctiveValue
FsFeatDefn
FsFeatStruc
FsFeatStrucDisj
FsFeatStrucType
FsFeatureSpecification
FsFeatureSystem
FsNegatedValue
FsOpenFeature
FsOpenValue
FsSharedValue
FsSymFeatVal
Note
PubDivision
PubHeader
PubHFSet
Publication
PubPageLayout
PunctuationForm
Segment
StFootnote
StJournalText
StPara
StStyle
StText
StTxtPara
TextTag
UserAppFeatAct
UserConfigAcct
UserView
UserViewField
UserViewRec
Associations
AnalyzedTextObjects [StTxtPara - CmObject]
AnnotationType [CmAnnotation - CmAnnotationDefn]
AppliesTo [CmIndirectAnnotation - CmAnnotation]
Approves [CmAgent - CmAgentEvaluation]
BasedOn [StStyle - StStyle]
BasedOn [DsConstChart - StText]
BeginObject [CmBaseAnnotation - CmObject]
BeginSegment [ConstChartWordGroup - Segment]
BeginSegment [TextTag - Segment]
Categories [ScrScriptureNote - CmPossibility]
Cells [CmRow - CmCell]
CheckLists [LangProject - CmPossibilityList]
Column [ConstituentChartCellPart - CmPossibility]
ComplexEntryTypes [LexDb - CmPossibilityList]
ComponentLexemes [LexEntryRef - CmObject]
Confidence [CmPossibility - CmPossibility]
Contents [FsFeatStrucDisj - FsFeatStruc]
Default [FsFeatDefn - FsFeatureSpecification]
DefaultFooter [PubHFSet - PubHeader]
DefaultHeader [PubHFSet - PubHeader]
Discussion [CmPossibility - StText]
Disproves [CmAgent - CmAgentEvaluation]
Divisions [Publication - PubDivision]
Education [CmPerson - CmPossibility]
EndObject [CmBaseAnnotation - CmObject]
EndSegment [ConstChartWordGroup - Segment]
EvenFooter [PubHFSet - PubHeader]
EvenHeader [PubHFSet - PubHeader]
Feature [FsFeatureSpecification - FsFeatDefn]
FeatureDisjunctions [FsFeatStruc - FsFeatStrucDisj]
Features [CmAnnotation - FsFeatStruc]
Features [FsFeatStrucType - FsFeatDefn]
Features [FsFeatureSystem - FsFeatDefn]
Features [PhPhoneme - FsFeatStruc]
FeatureSpecs [FsFeatStruc - FsFeatureSpecification]
Fields [UserViewRec - UserViewField]
Files [CmFolder - CmFile]
FirstFooter [PubHFSet - PubHeader]
FirstHeader [PubHFSet - PubHeader]
GenreList [LangProject - CmPossibilityList]
Genres [Text - CmPossibility]
HeaderFooterSets [CmMajorObject - PubHFSet]
HFSet [PubDivision - PubHFSet]
InstanceOf [CmAnnotation - CmObject]
Location [LexPronunciation - CmLocation]
Locations [RnGenericRec - CmLocation]
MainEntriesOrSenses [LexEntry - CmObject]
MediaFile [CmMedia - CmFile]
Next [StStyle - StStyle]
Notes [CmAgent - StText]
NoteType [ScrMarkerMapping - CmAnnotationDefn]
NoteType [ScrImportSource - CmAnnotationDefn]
ObjRefs [StTxtPara - CmObject]
OtherObjects [CmBaseAnnotation - CmObject]
PageLayout [PubDivision - PubPageLayout]
Paragraphs [StText - StPara]
Paragraphs [StText - StTxtPara]
PhFeatureSystem [LangProject - FsFeatureSystem]
PhonRuleFeats [PhPhonData - CmPossibilityList]
PictureFile [CmPicture - CmFile]
PlaceOfBirth [CmPerson - CmLocation]
PlacesOfResidence [CmPerson - CmLocation]
Positions [CmPerson - CmPossibility]
Possibilities [CmPossibilityList - CmPossibility]
PossItems [CmOverlay - CmPossibility]
PossList [UserViewField - CmPossibilityList]
PossList [CmOverlay - CmPossibilityList]
PrimaryLexemes [LexEntryRef - CmObject]
ProdRestrict [MoMorphData - CmPossibilityList]
Questions [CmSemanticDomain - CmDomainQ]
Records [UserView - UserViewRec]
Researchers [CmPossibility - CmPerson]
Restrictions [CmPossibility - CmPossibility]
Rows [CmFilter - CmRow]
Segments [StTxtPara - Segment]
Source [CmAnnotation - CmAgent]
Status [CmPossibility - CmPossibility]
SubfieldOf [UserViewField - UserViewField]
SubFolders [CmFolder - CmFolder]
SubPossibilities [CmPossibility - CmPossibility]
Tag [TextTag - CmPossibility]
Tag [ConstChartTag - CmPossibility]
Targets [LexReference - CmObject]
Template [DsChart - CmPossibility]
Text [CmAnnotation - StText]
TextMarkupTags [LangProject - CmPossibilityList]
TextObjects [StTxtPara - CmObject]
Translations [StTxtPara - CmTranslation]
Type [FsFeatStruc - FsFeatStrucType]
Type [FsComplexFeature - FsFeatStrucType]
Types [FsFeatureSystem - FsFeatStrucType]
UserConfigAcct [UserAppFeatAct - UserConfigAcct]
Value [FsClosedValue - FsSymFeatVal]
Value [FsNegatedValue - FsSymFeatVal]
Value [FsDisjunctiveValue - FsSymFeatVal]
Value [FsComplexValue - FsAbstractStructure]
Value [FsSharedValue - FsFeatureSpecification]
Values [FsClosedFeature - FsSymFeatVal]
VariantEntryTypes [LexDb - CmPossibilityList]
Generalizations
<unnamed> [WfiAnalysis - CmObject]
<unnamed> [MoDeriv - CmObject]
<unnamed> [FsFeatureSystem - CmObject]
<unnamed> [FsComplexFeature - FsFeatDefn]
<unnamed> [FsAbstractStructure - CmObject]
<unnamed> [FsOpenValue - FsFeatureSpecification]
<unnamed> [FsFeatStrucType - CmObject]
<unnamed> [FsComplexValue - FsFeatureSpecification]
<unnamed> [FsSharedValue - FsFeatureSpecification]
<unnamed> [FsOpenFeature - FsFeatDefn]
<unnamed> [FsClosedFeature - FsFeatDefn]
<unnamed> [FsFeatStruc - FsAbstractStructure]
<unnamed> [FsNegatedValue - FsFeatureSpecification]
<unnamed> [FsClosedValue - FsFeatureSpecification]
<unnamed> [FsSymFeatVal - CmObject]
<unnamed> [FsFeatStrucDisj - FsAbstractStructure]
<unnamed> [FsFeatureSpecification - CmObject]
<unnamed> [FsDisjunctiveValue - FsFeatureSpecification]
<unnamed> [ScrBook - CmObject]
<unnamed> [Scripture - CmMajorObject]
<unnamed> [ScrSection - CmObject]
<unnamed> [ScrBookRef - CmObject]
<unnamed> [CmCustomItem - CmPossibility]
<unnamed> [UserViewRec - CmObject]
<unnamed> [CmMajorObject - CmObject]
<unnamed> [StStyle - CmObject]
<unnamed> [CmOverlay - CmObject]
<unnamed> [UserView - CmObject]
<unnamed> [CmFilter - CmObject]
<unnamed> [StText - CmObject]
<unnamed> [UserViewField - CmObject]
<unnamed> [CmProject - CmObject]
<unnamed> [CrossReference - CmObject]
<unnamed> [StTxtPara - StPara]
<unnamed> [CmLocation - CmPossibility]
<unnamed> [CmPossibility - CmObject]
<unnamed> [CmPossibilityList - CmMajorObject]
<unnamed> [StPara - CmObject]
<unnamed> [CmCell - CmObject]
<unnamed> [CmAgent - CmObject]
<unnamed> [CmRow - CmObject]
<unnamed> [CmAgentEvaluation - CmObject]
<unnamed> [MoGlossItem - CmObject]
<unnamed> [MoGlossSystem - CmObject]
<unnamed> [CmIndirectAnnotation - CmAnnotation]
<unnamed> [CmBaseAnnotation - CmAnnotation]
<unnamed> [CmMediaAnnotation - CmAnnotation]
<unnamed> [CmAnnotation - CmObject]
<unnamed> [StFootnote - StText]
<unnamed> [ScrDraft - CmObject]
<unnamed> [ScrDifference - CmObject]
<unnamed> [WfiMorphBundle - CmObject]
<unnamed> [CmAnnotationDefn - CmPossibility]
<unnamed> [PubDivision - CmObject]
<unnamed> [PubPageLayout - CmObject]
<unnamed> [Publication - CmObject]
<unnamed> [PubHFSet - CmObject]
<unnamed> [PubHeader - CmObject]
<unnamed> [CmFile - CmObject]
<unnamed> [CmPicture - CmObject]
<unnamed> [LexEtymology - CmObject]
<unnamed> [UserConfigAcct - CmObject]
<unnamed> [CmPerson - CmPossibility]
<unnamed> [CmAnthroItem - CmPossibility]
<unnamed> [StJournalText - StText]
<unnamed> [CmResource - CmObject]
<unnamed> [CmPossibility - CmPossibilityList]


PackageComponent View::Cellar Report

View: | Hide Browser | Browser on the left | Browser on the right | Dictionary
Report: | General Info | Inner Elements | Inner Relations | Tagged Values

Package Component View::Cellar

General Info
Name | Cellar
Abstract | false
Leaf | false
Root | false
Owner | Component View

Inner Elements
Name | Type
CmAgent | Class
CmAgentEvaluation | Class
CmAnnotation | Class
CmAnnotationDefn | Class
CmAnthroItem | Class
CmBaseAnnotation | Class
CmCell | Class
CmCustomItem | Class
CmDomainQ | Class
CmFile | Class
CmFilter | Class
CmFolder | Class
CmIndirectAnnotation | Class
CmLocation | Class
CmMajorObject | Class
CmMedia | Class
CmMediaAnnotation | Class
CmObject | Class
CmOverlay | Class
CmPerson | Class
CmPicture | Class
CmPossibility | Class
CmPossibilityList | Class
CmProject | Class
CmResource | Class
CmRow | Class
CmSemanticDomain | Class
CmTranslation | Class
CrossReference | Class
FsAbstractStructure | Class
FsClosedFeature | Class
FsClosedValue | Class
FsComplexFeature | Class
FsComplexValue | Class
FsDisjunctiveValue | Class
FsFeatDefn | Class
FsFeatStruc | Class
FsFeatStrucDisj | Class
FsFeatStrucType | Class
FsFeatureSpecification | Class
FsFeatureSystem | Class
FsNegatedValue | Class
FsOpenFeature | Class
FsOpenValue | Class
FsSharedValue | Class
FsSymFeatVal | Class
Note | Class
PubDivision | Class
PubHeader | Class
PubHFSet | Class
Publication | Class
PubPageLayout | Class
PunctuationForm | Class
Segment | Class
StFootnote | Class
StJournalText | Class
StPara | Class
StStyle | Class
StText | Class
StTxtPara | Class
TextTag | Class
UserAppFeatAct | Class
UserConfigAcct | Class
UserView | Class
UserViewField | Class
UserViewRec | Class

Inner Relations
Association AnalyzedTextObjects [StTxtPara - CmObject]
Association AnnotationType [CmAnnotation - CmAnnotationDefn]
Association AppliesTo [CmIndirectAnnotation - CmAnnotation]
Association Approves [CmAgent - CmAgentEvaluation]
Association BasedOn [StStyle - StStyle]
Association BasedOn [DsConstChart - StText]
Association BeginObject [CmBaseAnnotation - CmObject]
Association BeginSegment [ConstChartWordGroup - Segment]
Association BeginSegment [TextTag - Segment]
Association Categories [ScrScriptureNote - CmPossibility]
Association Cells [CmRow - CmCell]
Association CheckLists [LangProject - CmPossibilityList]
Association Column [ConstituentChartCellPart - CmPossibility]
Association ComplexEntryTypes [LexDb - CmPossibilityList]
Association ComponentLexemes [LexEntryRef - CmObject]
Association Confidence [CmPossibility - CmPossibility]
Association Contents [FsFeatStrucDisj - FsFeatStruc]
Association Default [FsFeatDefn - FsFeatureSpecification]
Association DefaultFooter [PubHFSet - PubHeader]
Association DefaultHeader [PubHFSet - PubHeader]
Association Discussion [CmPossibility - StText]
Association Disproves [CmAgent - CmAgentEvaluation]
Association Divisions [Publication - PubDivision]
Association Education [CmPerson - CmPossibility]
Association EndObject [CmBaseAnnotation - CmObject]
Association EndSegment [ConstChartWordGroup - Segment]
Association EvenFooter [PubHFSet - PubHeader]
Association EvenHeader [PubHFSet - PubHeader]
Association Feature [FsFeatureSpecification - FsFeatDefn]
Association FeatureDisjunctions [FsFeatStruc - FsFeatStrucDisj]
Association Features [CmAnnotation - FsFeatStruc]
Association Features [FsFeatStrucType - FsFeatDefn]
Association Features [FsFeatureSystem - FsFeatDefn]
Association Features [PhPhoneme - FsFeatStruc]
Association FeatureSpecs [FsFeatStruc - FsFeatureSpecification]
Association Fields [UserViewRec - UserViewField]
Association Files [CmFolder - CmFile]
Association FirstFooter [PubHFSet - PubHeader]
Association FirstHeader [PubHFSet - PubHeader]
Association GenreList [LangProject - CmPossibilityList]
Association Genres [Text - CmPossibility]
Association HeaderFooterSets [CmMajorObject - PubHFSet]
Association HFSet [PubDivision - PubHFSet]
Association InstanceOf [CmAnnotation - CmObject]
Association Location [LexPronunciation - CmLocation]
Association Locations [RnGenericRec - CmLocation]
Association MainEntriesOrSenses [LexEntry - CmObject]
Association MediaFile [CmMedia - CmFile]
Association Next [StStyle - StStyle]
Association Notes [CmAgent - StText]
Association NoteType [ScrMarkerMapping - CmAnnotationDefn]
Association NoteType [ScrImportSource - CmAnnotationDefn]
Association ObjRefs [StTxtPara - CmObject]
Association OtherObjects [CmBaseAnnotation - CmObject]
Association PageLayout [PubDivision - PubPageLayout]
Association Paragraphs [StText - StPara]
Association Paragraphs [StText - StTxtPara]
Association PhFeatureSystem [LangProject - FsFeatureSystem]
Association PhonRuleFeats [PhPhonData - CmPossibilityList]
Association PictureFile [CmPicture - CmFile]
Association PlaceOfBirth [CmPerson - CmLocation]
Association PlacesOfResidence [CmPerson - CmLocation]
Association Positions [CmPerson - CmPossibility]
Association Possibilities [CmPossibilityList - CmPossibility]
Association PossItems [CmOverlay - CmPossibility]
Association PossList [UserViewField - CmPossibilityList]
Association PossList [CmOverlay - CmPossibilityList]
Association PrimaryLexemes [LexEntryRef - CmObject]
Association ProdRestrict [MoMorphData - CmPossibilityList]
Association Questions [CmSemanticDomain - CmDomainQ]
Association Records [UserView - UserViewRec]
Association Researchers [CmPossibility - CmPerson]
Association Restrictions [CmPossibility - CmPossibility]
Association Rows [CmFilter - CmRow]
Association Segments [StTxtPara - Segment]
Association Source [CmAnnotation - CmAgent]
Association Status [CmPossibility - CmPossibility]
Association SubfieldOf [UserViewField - UserViewField]
Association SubFolders [CmFolder - CmFolder]
Association SubPossibilities [CmPossibility - CmPossibility]
Association Tag [TextTag - CmPossibility]
Association Tag [ConstChartTag - CmPossibility]
Association Targets [LexReference - CmObject]
Association Template [DsChart - CmPossibility]
Association Text [CmAnnotation - StText]
Association TextMarkupTags [LangProject - CmPossibilityList]
Association TextObjects [StTxtPara - CmObject]
Association Translations [StTxtPara - CmTranslation]
Association Type [FsFeatStruc - FsFeatStrucType]
Association Type [FsComplexFeature - FsFeatStrucType]
Association Types [FsFeatureSystem - FsFeatStrucType]
Association UserConfigAcct [UserAppFeatAct - UserConfigAcct]
Association Value [FsClosedValue - FsSymFeatVal]
Association Value [FsNegatedValue - FsSymFeatVal]
Association Value [FsDisjunctiveValue - FsSymFeatVal]
Association Value [FsComplexValue - FsAbstractStructure]
Association Value [FsSharedValue - FsFeatureSpecification]
Association Values [FsClosedFeature - FsSymFeatVal]
Association VariantEntryTypes [LexDb - CmPossibilityList]
Generalization <unnamed> [WfiAnalysis - CmObject]
Generalization <unnamed> [MoDeriv - CmObject]
Generalization <unnamed> [FsFeatureSystem - CmObject]
Generalization <unnamed> [FsComplexFeature - FsFeatDefn]
Generalization <unnamed> [FsAbstractStructure - CmObject]
Generalization <unnamed> [FsOpenValue - FsFeatureSpecification]
Generalization <unnamed> [FsFeatStrucType - CmObject]
Generalization <unnamed> [FsComplexValue - FsFeatureSpecification]
Generalization <unnamed> [FsSharedValue - FsFeatureSpecification]
Generalization <unnamed> [FsOpenFeature - FsFeatDefn]
Generalization <unnamed> [FsClosedFeature - FsFeatDefn]
Generalization <unnamed> [FsFeatStruc - FsAbstractStructure]
Generalization <unnamed> [FsNegatedValue - FsFeatureSpecification]
Generalization <unnamed> [FsClosedValue - FsFeatureSpecification]
Generalization <unnamed> [FsSymFeatVal - CmObject]
Generalization <unnamed> [FsFeatStrucDisj - FsAbstractStructure]
Generalization <unnamed> [FsFeatureSpecification - CmObject]
Generalization <unnamed> [FsDisjunctiveValue - FsFeatureSpecification]
Generalization <unnamed> [ScrBook - CmObject]
Generalization <unnamed> [Scripture - CmMajorObject]
Generalization <unnamed> [ScrSection - CmObject]
Generalization <unnamed> [ScrBookRef - CmObject]
Generalization <unnamed> [CmCustomItem - CmPossibility]
Generalization <unnamed> [UserViewRec - CmObject]
Generalization <unnamed> [CmMajorObject - CmObject]
Generalization <unnamed> [StStyle - CmObject]
Generalization <unnamed> [CmOverlay - CmObject]
Generalization <unnamed> [UserView - CmObject]
Generalization <unnamed> [CmFilter - CmObject]
Generalization <unnamed> [StText - CmObject]
Generalization <unnamed> [UserViewField - CmObject]
Generalization <unnamed> [CmProject - CmObject]
Generalization <unnamed> [CrossReference - CmObject]
Generalization <unnamed> [StTxtPara - StPara]
Generalization <unnamed> [CmLocation - CmPossibility]
Generalization <unnamed> [CmPossibility - CmObject]
Generalization <unnamed> [CmPossibilityList - CmMajorObject]
Generalization <unnamed> [StPara - CmObject]
Generalization <unnamed> [CmCell - CmObject]
Generalization <unnamed> [CmAgent - CmObject]
Generalization <unnamed> [CmRow - CmObject]
Generalization <unnamed> [CmAgentEvaluation - CmObject]
Generalization <unnamed> [MoGlossItem - CmObject]
Generalization <unnamed> [MoGlossSystem - CmObject]
Generalization <unnamed> [CmIndirectAnnotation - CmAnnotation]
Generalization <unnamed> [CmBaseAnnotation - CmAnnotation]
Generalization <unnamed> [CmMediaAnnotation - CmAnnotation]
Generalization <unnamed> [CmAnnotation - CmObject]
Generalization <unnamed> [StFootnote - StText]
Generalization <unnamed> [ScrDraft - CmObject]
Generalization <unnamed> [ScrDifference - CmObject]
Generalization <unnamed> [WfiMorphBundle - CmObject]
Generalization <unnamed> [CmAnnotationDefn - CmPossibility]
Generalization <unnamed> [PubDivision - CmObject]
Generalization <unnamed> [PubPageLayout - CmObject]
Generalization <unnamed> [Publication - CmObject]
Generalization <unnamed> [PubHFSet - CmObject]
Generalization <unnamed> [PubHeader - CmObject]
Generalization <unnamed> [CmFile - CmObject]
Generalization <unnamed> [CmPicture - CmObject]
Generalization <unnamed> [LexEtymology - CmObject]
Generalization <unnamed> [UserConfigAcct - CmObject]
Generalization <unnamed> [CmPerson - CmPossibility]
Generalization <unnamed> [CmAnthroItem - CmPossibility]
Generalization <unnamed> [StJournalText - StText]
Generalization <unnamed> [CmResource - CmObject]
Generalization <unnamed> [CmPossibility - CmPossibilityList]

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: ver |  |
Tag Name: verBack |  |


Association ReferenceForms Report

Report: | General Info | Association Ends | Tagged Values

Association ReferenceForms

ReferenceForms: owns a collection of FsFeatStruc, each of which defines the cell whose inflection uniquely picks out an inflection class. (Cf. Carstairs-McCarthy 1991, particularly section 8). Usually, the reference forms belonging to a PartOfSpeech will suffice for all the MoInflectionClasses, i.e. a single "Primary Reference Form" (Carstairs-McCarthy's term). In some cases, however, it may prove necessary to provide a secondary reference form to distinguish among "mixed" classes (see again the discussion in Carstairs-McCarthy 1991.) This attr is then where the secondary reference form would be stored. The classes which need to be distinguished by ReferenceForms will presumably constitute the members of the Subclasses attr of some parent inflection class, together with that parent inflection class. The appropriate class to list the ReferenceForms will then be that parent class, and the daughter classes will inherit that property via their vAllReferenceForms (see below). Note that this attribute performs no particular function in any of the algorithms used for computing affixed forms. However, it may be useful in the context of a dictionary, e.g. for providing principal parts.

General Info
Name | ReferenceForms
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflClass
End B | <unnamed> | 0..* | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | ReferenceForms
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | ReferenceForms
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Stratum Report

Report: | General Info | Association Ends | Tagged Values

Association Stratum

Stratum: refers to the MoStratum to which this MoMorphoSyntaxAnalysis object belongs. In an earlier version of this document, this attr belonged to MoForm. But that implied that one allomorph might belong to one stratum, and another allomorph to another stratum, which seems wrong. It is here, rather than on the superclass, because MoInflectionalAffixMsas do not need to "know" their stratum (their stratum is specified by the MoInflAffixTemplate in which they appear). (The other subclass of MoMorphoSyntaxAnalysis which has this attr is MoStemMsa.)

General Info
Name | Stratum
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 1 | MoStratum

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | Stratum
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratum
Association | Stratum
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoCompoundRule
Child Element | MoBinaryCompoundRule


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmMajorObject
Child Element | LexDb


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoMorphSynAnalysis
Child Element | MoStemMsa


Association Strata Report

Report: | General Info | Association Ends | Tagged Values

Association Strata

owns a col of MoStratum objects, in order from shallowest to deepest.

General Info
Name | Strata
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphData
End B | <unnamed> | 0..* | MoStratum

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphData
Association | Strata
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratum
Association | Strata
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association AffixMsa Report

Report: | General Info | Association Ends | Tagged Values

Association AffixMsa

refers to an MoDerivationalAffixMsa, giving the morphosyntactic information about the affix.

General Info
Name | AffixMsa
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffApp
End B | <unnamed> | 1 | MoDerivAffMsa

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffApp
Association | AffixMsa
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | AffixMsa
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association StemNames Report

Report: | General Info | Association Ends | Tagged Values

Association StemNames

owns a collection seq of MoStemNames, which define any non-default inflectional stems of the category (but not the default stem). For example, Aronoff (1992) discusses what he calls the '3-stem' of Latin verbs, a form which exists in all verb conjugations, and which is used as the base in a variety of places of the paradigm (which places are not identifiable on semantic or other grounds without using 'or'). The MoStemNames are interpreted as a disjunctively ordered list, i.e. in selecting a Stem for a given word, the list of StemNames is searched linearly, stopping at the first one for which one of its cells unifies with the FsFeatStruc of the word to be derived (see Choosing a Stem Allomorph). The order of the MoStemNames in this attribute is therefore important.If this attribute is empty, it defaults to the value of the same attribute in its owner. This allows e.g. defining a set of stem names for all verbs, and inheriting those names for subcategories of verb. It should probably be possible to block such inheritance without specifying any stem names, so there needs to be some specified value for that ('nil', say). An example might be modal verbs in English, which are presumably a subclass of verbs, but which lack certain forms.

General Info
Name | StemNames
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 0..* | MoStemName

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | StemNames
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemName
Association | StemNames
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Package Component View::LangProj index

Classes
LangProject
Associations
ActivatedFeatures [LangProject - UserAppFeatAct]
AffixCategories [LangProject - CmPossibilityList]
AnalysisStatus [LangProject - CmPossibilityList]
AnalyzingAgents [LangProject - CmAgent]
AnnotationDefs [LangProject - CmPossibilityList]
Annotations [LangProject - CmAnnotation]
AnthroList [LangProject - CmPossibilityList]
ConfidenceLevels [LangProject - CmPossibilityList]
DiscourseData [LangProject - DsDiscourseData]
Education [LangProject - CmPossibilityList]
Filters [LangProject - CmFilter]
LexDb [LangProject - LexDb]
Locations [LangProject - CmPossibilityList]
Media [LangProject - CmFolder]
MorphologicalData [LangProject - MoMorphData]
MsFeatureSystem [LangProject - FsFeatureSystem]
Overlays [LangProject - CmOverlay]
PartsOfSpeech [LangProject - CmPossibilityList]
People [LangProject - CmPossibilityList]
PhonologicalData [LangProject - PhPhonData]
Pictures [LangProject - CmFolder]
Positions [LangProject - CmPossibilityList]
ResearchNotebook [LangProject - RnResearchNbk]
Restrictions [LangProject - CmPossibilityList]
Roles [LangProject - CmPossibilityList]
SemanticDomainList [LangProject - CmPossibilityList]
Styles [LangProject - StStyle]
Texts [LangProject - Text]
Thesaurus [LangProject - CmPossibilityList]
TimeOfDay [LangProject - CmPossibilityList]
TranslatedScripture [LangProject - Scripture]
TranslationTags [LangProject - CmPossibilityList]
UserAccounts [LangProject - UserConfigAcct]
WordformLookupLists [LangProject - WordformLookupList]
Generalizations


PackageComponent View::LangProj Report

View: | Hide Browser | Browser on the left | Browser on the right | Dictionary
Report: | General Info | Inner Elements | Inner Relations | Tagged Values

Package Component View::LangProj

General Info
Name | LangProj
Abstract | false
Leaf | false
Root | false
Owner | Component View

Inner Elements
Name | Type
LangProject | Class

Inner Relations
Association ActivatedFeatures [LangProject - UserAppFeatAct]
Association AffixCategories [LangProject - CmPossibilityList]
Association AnalysisStatus [LangProject - CmPossibilityList]
Association AnalyzingAgents [LangProject - CmAgent]
Association AnnotationDefs [LangProject - CmPossibilityList]
Association Annotations [LangProject - CmAnnotation]
Association AnthroList [LangProject - CmPossibilityList]
Association ConfidenceLevels [LangProject - CmPossibilityList]
Association DiscourseData [LangProject - DsDiscourseData]
Association Education [LangProject - CmPossibilityList]
Association Filters [LangProject - CmFilter]
Association LexDb [LangProject - LexDb]
Association Locations [LangProject - CmPossibilityList]
Association Media [LangProject - CmFolder]
Association MorphologicalData [LangProject - MoMorphData]
Association MsFeatureSystem [LangProject - FsFeatureSystem]
Association Overlays [LangProject - CmOverlay]
Association PartsOfSpeech [LangProject - CmPossibilityList]
Association People [LangProject - CmPossibilityList]
Association PhonologicalData [LangProject - PhPhonData]
Association Pictures [LangProject - CmFolder]
Association Positions [LangProject - CmPossibilityList]
Association ResearchNotebook [LangProject - RnResearchNbk]
Association Restrictions [LangProject - CmPossibilityList]
Association Roles [LangProject - CmPossibilityList]
Association SemanticDomainList [LangProject - CmPossibilityList]
Association Styles [LangProject - StStyle]
Association Texts [LangProject - Text]
Association Thesaurus [LangProject - CmPossibilityList]
Association TimeOfDay [LangProject - CmPossibilityList]
Association TranslatedScripture [LangProject - Scripture]
Association TranslationTags [LangProject - CmPossibilityList]
Association UserAccounts [LangProject - UserConfigAcct]
Association WordformLookupLists [LangProject - WordformLookupList]
Generalization <unnamed> [LangProject - CmProject]

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: ver |  |
Tag Name: verBack |  |


Association MsFeatures Report

Report: | General Info | Association Ends | Tagged Values

Association MsFeatures

owns an FsFeatStruc, giving the morphosyntactic features which result from percolation. N.B.: This does not include inflectional features which are to be realized by inflectional affixes (and which may be incompatible with the current part of speech, or contradict percolated features).

General Info
Name | MsFeatures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivStepMsa
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivStepMsa
Association | MsFeatures
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | MsFeatures
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association SenseType Report

Report: | General Info | Association Ends | Tagged Values

Association SenseType

General Info
Name | SenseType
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | SenseType
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | SenseType
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoReferralRule


Association AdhocCoProhibitions Report

Report: | General Info | Association Ends | Tagged Values

Association AdhocCoProhibitions

Used to hold the list of ad hoc cooccurrence restrictions. (Ideally, this is empty!)

General Info
Name | AdhocCoProhibitions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphData
End B | <unnamed> | 0..* | MoAdhocProhib

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphData
Association | AdhocCoProhibitions
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAdhocProhib
Association | AdhocCoProhibitions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoForm
Child Element | MoStemAllomorph


Association Morphemes Report

Report: | General Info | Association Ends | Tagged Values

Association Morphemes

refers to a collection seq of MoMorphoSyntaxAnalysis objects, the co-occurrence of which is ungrammatical. Usually, there will be exactly two such morphemes. If there are three or more morphemes, the intended meaning is that a word is ungrammatical in which all such morphemes appear (but the co-occurrence of only some of the morphemes is not prohibited). Having only one morpheme in this attribute should be flagged as a Warning, since such a restriction can do nothing. Note: we are assuming here that the user interface cannot simply prohibit constraints with a single morpheme, because they arise in the process of creating a constraint. (You cannot count to two until you've counted to one.)

General Info
Name | Morphemes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphAdhocProhib
End B | <unnamed> | 0..* | MoMorphSynAnalysis

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |
Tag Name: Questions |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphAdhocProhib
Association | Morphemes
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphSynAnalysis
Association | Morphemes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoMorphSynAnalysis
Child Element | MoInflAffMsa


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoCompoundRule


Association PartOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association PartOfSpeech

General Info
Name | PartOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ReversalIndexEntry
End B | <unnamed> | 1 | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ReversalIndexEntry
Association | PartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | PartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Senses Report

Report: | General Info | Association Ends | Tagged Values

Association Senses

General Info
Name | Senses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | LexSense

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | Senses
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | Senses
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoDerivTrace
Child Element | MoPhonolRuleApp


Association TestSets Report

Report: | General Info | Association Ends | Tagged Values

Association TestSets

WfiWordSets are a collection of words that the user might want to use to test his word grammar as he adjusts morphological rules and the lexicon.

General Info
Name | TestSets
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphData
End B | <unnamed> | 0..* | WfiWordSet

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphData
Association | TestSets
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiWordSet
Association | TestSets
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association InflectableFeats Report

Report: | General Info | Association Ends | Tagged Values

Association InflectableFeats

refers to a collection seq of FsFeatureDefn, each of which is a morphosyntactic feature which a word of this part of speech is inflected for. Note that MoInflectionalAffixMsas may be sensitive to other features as well. Changed from InflectableFeatures

General Info
Name | InflectableFeats
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 0..* | FsFeatDefn

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | InflectableFeats
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatDefn
Association | InflectableFeats
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Type Report

Report: | General Info | Association Ends | Tagged Values

Association Type

The type of translation: free, literal, back, front, etc.

General Info
Name | Type
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmTranslation
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmTranslation
Association | Type
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Type
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Cases Report

Report: | General Info | Association Ends | Tagged Values

Association Cases

General Info
Name | Cases
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiWordSet
End B | <unnamed> | 0..* | WfiWordform

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiWordSet
Association | Cases
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiWordform
Association | Cases
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association MorphTypes Report

Report: | General Info | Association Ends | Tagged Values

Association MorphTypes

General Info
Name | MorphTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | MorphTypes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | MorphTypes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Subclasses Report

Report: | General Info | Association Ends | Tagged Values

Association Subclasses

owns a collection of MoInflectionClasses, each of which is a specialization of this Inflection Class. Part of the S2W process is decreasing the number of inflection classes by pushing identical information in subclasses up into the parent inflection class, and by accounting for differences among subclasses in other ways (e.g. as phonologically predictable allomorphy, or by features such as gender that are not among the PartOfSpeech.InflectableFeatures attribute of the owner).

General Info
Name | Subclasses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflClass
End B | <unnamed> | 0..* | MoInflClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | Subclasses
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | Subclasses
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | LexSense


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoStratum


Association FromStemName Report

Report: | General Info | Association Ends | Tagged Values

Association FromStemName

FromStemName: refers to an MoStemName, telling the stem to which this affix attaches. If this attr is empty, this affix attaches to the default stem of an MoStemMsa, as given by the vDefaultStems attr. (The vDefaultStems attr is a seq attr, to allow for a choice based on phonological constraints; in the absence of phonologically conditioned stem selection, there should be only one default stem.)

General Info
Name | FromStemName
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 1 | MoStemName

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | FromStemName
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemName
Association | FromStemName
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoBinaryCompoundRule
Child Element | MoEndoCompound


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhCode


Association Translations Report

Report: | General Info | Association Ends | Tagged Values

Association Translations

General Info
Name | Translations
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexExampleSentence
End B | <unnamed> | 0..* | CmTranslation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexExampleSentence
Association | Translations
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmTranslation
Association | Translations
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Output Report

Report: | General Info | Association Ends | Tagged Values

Association Output

Owns an ordered seq of MoRuleMapping, describing the form output by attachment of this affix. Typically this consists of a copy of the Input plus some constant for the affix, but reduplication, infixation, simulfixes and suprafixes will be more complex. The left-to-right order of the MoRuleMapping objects in this attribute corresponds to the order of the pieces of the output word which will be constructed by the rule.

General Info
Name | Output
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAffixProcess
End B | <unnamed> | 0..* | MoRuleMapping

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixProcess
Association | Output
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoRuleMapping
Association | Output
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association MorphoSyntaxAnalysis Report

Report: | General Info | Association Ends | Tagged Values

Association MorphoSyntaxAnalysis

General Info
Name | MorphoSyntaxAnalysis
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 1 | MoMorphSynAnalysis

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | MorphoSyntaxAnalysis
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphSynAnalysis
Association | MorphoSyntaxAnalysis
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association NaturalClasses Report

Report: | General Info | Association Ends | Tagged Values

Association NaturalClasses

Change this here.

General Info
Name | NaturalClasses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonData
End B | <unnamed> | 0..* | PhNaturalClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonData
Association | NaturalClasses
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhNaturalClass
Association | NaturalClasses
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhPhonContext
Child Element | PhSequenceContext


Association LeftContext Report

Report: | General Info | Association Ends | Tagged Values

Association LeftContext

General Info
Name | LeftContext
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhEnvironment
End B | <unnamed> | 1 | PhPhonContext

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhEnvironment
Association | LeftContext
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonContext
Association | LeftContext
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Content Report

Report: | General Info | Association Ends | Tagged Values

Association Content

refers to a PhNaturalClass to be added into the output at this position.

General Info
Name | Content
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInsertNC
End B | <unnamed> | 1 | PhNaturalClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInsertNC
Association | Content
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhNaturalClass
Association | Content
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Linker Report

Report: | General Info | Association Ends | Tagged Values

Association Linker

owns an MoAffixForm in the encoding of the language, giving the phoneme(s) inserted between the two parts of the compound (cf. Linguist List 10.1477, http://linguistlist.org/10/10-1477.html). If this field is empty, nothing is inserted between the two parts. The linker is semantically meaningless (else it would be a morpheme).

General Info
Name | Linker
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoBinaryCompoundRule
End B | <unnamed> | 1 | MoAffixForm

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoBinaryCompoundRule
Association | Linker
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixForm
Association | Linker
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association InflectionClass Report

Report: | General Info | Association Ends | Tagged Values

Association InflectionClass

InflectionClass: refers to an MoInflectionClass. This gives the inflection class to which the word being derived belongs, at this stage in the derivation. The algorithm for computing this is rather complex (which is why I have not defined this as a virtual attr), but basically it is this: If the last MoDerivationalAffix attached specifies a ToInflectionClass, then this attr is that inflection class. If the last MoDerivationalAffix attached does not specify a ToInflectionClass, then we collect all the derivational affixes attached inside that one which have the same ToPartOfSpeech or a PartOfSpeech which is a subcategory or a supercategory of the last derivational affix's part of speech, stopping when we come to a part of speech which is not the same or a subcategory or a supercategory. The outermost of these affixes which specifies a ToInflectionClass is used for this stage's InflectionClass. If none of these affixes specifies a ToInflectionClass, and the MoStemMsa is accessible (meaning none of the affixes has a contrary ToPartOfSpeech), then we use the InflectionClass of that stem. If all of these possibilities fail, we use the vDefaultInflectionClass of the PartOfSpeech.

General Info
Name | InflectionClass
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivStepMsa
End B | <unnamed> | 1 | MoInflClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivStepMsa
Association | InflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | InflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Components Report

Report: | General Info | Association Ends | Tagged Values

Association Components

points to an ordered seq of other MoMorphoSyntaxAnalysis objects, which are interpreted as the morphemes or stems that make up this object. Additional Notes: Ordinarily, this would only be appropriate for stems which are not roots, hence it would be an attribute of MoStemMsa. I believe it is here on the superclass because under the stealth-to-wealth concept, the user may be in a state where he realizes something is composite, but has not yet worked out all the morphemes of which it is composed. This attribute could then be used to point to the parts that have already been discovered. Possibly when the user succeeds in completely decomposing the stem or composite affix, this object could go away, although it may be beneficial to retain it for future comparisons. Another possible use might be for a portmanteaux affix with a partial analysis, or for 'complex' affixes like the English ?ation (which under the Word Based Hypothesis, cannot be composed of the suffixes ?at and ?ion because of its appearance in words like recitation, since there is no word *recitate). I have defined this as an ordered seq on the assumption that the order of the components will match the left-to-right order of the morphemes. This is not unproblematic: some morphemes may be unanalyzed, and some morphemes may not appear in a strict left-to-right order (e.g. infixes). The former problem could be fixed by the use of placeholder (uninstantiated) Msas; the latter could be fixed either by defining a canonical order, or by using derivational order instead.

General Info
Name | Components
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphSynAnalysis
End B | <unnamed> | 0..* | MoMorphSynAnalysis

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphSynAnalysis
Association | Components
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphSynAnalysis
Association | Components
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Package Component View::Notebk index

Classes
Reminder
RnGenericRec
RnResearchNbk
RnRoledPartic
Associations
AnthroCodes [RnGenericRec - CmAnthroItem]
Conclusions [RnGenericRec - StText]
Confidence [RnGenericRec - CmPossibility]
CounterEvidence [RnGenericRec - RnGenericRec]
CrossReferences [RnResearchNbk - CrossReference]
CrossReferences [RnGenericRec - CrossReference]
Description [RnGenericRec - StText]
Discussion [RnGenericRec - StText]
ExternalMaterials [RnGenericRec - StText]
FurtherQuestions [RnGenericRec - StText]
Hypothesis [RnGenericRec - StText]
Participants [RnRoledPartic - CmPerson]
Participants [RnGenericRec - RnRoledPartic]
PersonalNotes [RnGenericRec - StText]
PhraseTags [RnGenericRec - CmPossibility]
Records [RnResearchNbk - RnGenericRec]
RecTypes [RnResearchNbk - CmPossibilityList]
Reminders [RnResearchNbk - Reminder]
Reminders [RnGenericRec - Reminder]
Researchers [RnGenericRec - CmPerson]
ResearchPlan [RnGenericRec - StText]
Restrictions [RnGenericRec - CmPossibility]
Role [RnRoledPartic - CmPossibility]
SeeAlso [RnGenericRec - RnGenericRec]
Sources [RnGenericRec - CmPerson]
Status [RnGenericRec - CmPossibility]
SubRecords [RnGenericRec - RnGenericRec]
SupersededBy [RnGenericRec - RnGenericRec]
SupportingEvidence [RnGenericRec - RnGenericRec]
TimeOfEvent [RnGenericRec - CmPossibility]
Type [RnGenericRec - CmPossibility]
VersionHistory [RnGenericRec - StText]
Generalizations
<unnamed> [RnResearchNbk - CmMajorObject]
<unnamed> [RnRoledPartic - CmObject]
<unnamed> [Reminder - CmObject]
<unnamed> [RnGenericRec - CmObject]


PackageComponent View::Notebk Report

View: | Hide Browser | Browser on the left | Browser on the right | Dictionary
Report: | General Info | Inner Elements | Inner Relations | Tagged Values

Package Component View::Notebk

General Info
Name | Notebk
Abstract | false
Leaf | false
Root | false
Owner | Component View

Inner Elements
Name | Type
Reminder | Class
RnGenericRec | Class
RnResearchNbk | Class
RnRoledPartic | Class

Inner Relations
Association AnthroCodes [RnGenericRec - CmAnthroItem]
Association Conclusions [RnGenericRec - StText]
Association Confidence [RnGenericRec - CmPossibility]
Association CounterEvidence [RnGenericRec - RnGenericRec]
Association CrossReferences [RnResearchNbk - CrossReference]
Association CrossReferences [RnGenericRec - CrossReference]
Association Description [RnGenericRec - StText]
Association Discussion [RnGenericRec - StText]
Association ExternalMaterials [RnGenericRec - StText]
Association FurtherQuestions [RnGenericRec - StText]
Association Hypothesis [RnGenericRec - StText]
Association Participants [RnRoledPartic - CmPerson]
Association Participants [RnGenericRec - RnRoledPartic]
Association PersonalNotes [RnGenericRec - StText]
Association PhraseTags [RnGenericRec - CmPossibility]
Association Records [RnResearchNbk - RnGenericRec]
Association RecTypes [RnResearchNbk - CmPossibilityList]
Association Reminders [RnResearchNbk - Reminder]
Association Reminders [RnGenericRec - Reminder]
Association Researchers [RnGenericRec - CmPerson]
Association ResearchPlan [RnGenericRec - StText]
Association Restrictions [RnGenericRec - CmPossibility]
Association Role [RnRoledPartic - CmPossibility]
Association SeeAlso [RnGenericRec - RnGenericRec]
Association Sources [RnGenericRec - CmPerson]
Association Status [RnGenericRec - CmPossibility]
Association SubRecords [RnGenericRec - RnGenericRec]
Association SupersededBy [RnGenericRec - RnGenericRec]
Association SupportingEvidence [RnGenericRec - RnGenericRec]
Association TimeOfEvent [RnGenericRec - CmPossibility]
Association Type [RnGenericRec - CmPossibility]
Association VersionHistory [RnGenericRec - StText]
Generalization <unnamed> [RnResearchNbk - CmMajorObject]
Generalization <unnamed> [RnRoledPartic - CmObject]
Generalization <unnamed> [Reminder - CmObject]
Generalization <unnamed> [RnGenericRec - CmObject]

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: ver |  |
Tag Name: verBack |  |


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoBinaryCompoundRule
Child Element | MoExoCompound


Association DefaultStem Report

Report: | General Info | Association Ends | Tagged Values

Association DefaultStem

refers to another MoStemName, which specifies the stem to be used (in conjunction with the DefaultAffix, if the latter is specified) if the stem's lexical entry does not list an MoStemAllomorph with this stem name. That is, if a lexeme does not have an irregular (listed) stem, this attribute specifies that some more regular stem will be used, either as a base (if there is a DefaultAffix) or by itself (if there is no DefaultAffix). If no DefaultStem is specified, then for any lexeme which does not explicitly list an (irregular) MoStemAllomorph with this stem name, the base for this MoStemName has the same form as the lexeme's (MoStemMsa's) DefaultStems. (The DefaultStems attr is a seq, allowing for phonological selection of one among several default stems; most often, the seq will contain a single stem.) Thus a regular stem for a given stem is constructed from the DefaultStem of that lexeme as specified by this MoStemName plus the DefaultAffix given by this MoStemName. This covers the common situation in which a relatively small subset of the words of a given paradigm have irregular forms, while the others have a stem based on the default stem with or without a stem-forming affix. Note that we can get into an infinite loop here, if any MoStemName calls for itself or (more likely) another MoStemName which (recursively) calls for the first MoStemName. This of course constitutes an error; fortunately, it should be easy to detect this situation. The possibilities for this attr are the StemNames of the PartOfSpeech which owns this MoStemName (not including this MoStemName).

General Info
Name | DefaultStem
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemName
End B | <unnamed> | 1 | MoStemName

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemName
Association | DefaultStem
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemName
Association | DefaultStem
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Contents Report

Report: | General Info | Association Ends | Tagged Values

Association Contents

General Info
Name | Contents
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexAppendix
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexAppendix
Association | Contents
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Contents
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhTerminalUnit
Child Element | PhBdryMarker


Association ToMsFeatures Report

Report: | General Info | Association Ends | Tagged Values

Association ToMsFeatures

ToMsFeatures: owns a FsFeatStruc, giving the morphosyntactic features which the word derived from this affix contains. In brief, the morphosyntactic features of the output word will contain all these feature values plus any nonconflicting feature values of the stem, provided the features are included in PartOfSpeech.BearableFeatures or PartOfSpeech.InflectableFeatures of the output word. (Or putting it differently, the ToMsFeatures override any conflicting features which would otherwise be percolated up from the stem.)

General Info
Name | ToMsFeatures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | ToMsFeatures
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | ToMsFeatures
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association DefaultInflectionClass Report

Report: | General Info | Association Ends | Tagged Values

Association DefaultInflectionClass

refers to one of the classes in vAllInflectionClasses; defaults to the first MoInflectionClasses in vAllInflectionClasses (which would be the first class defined for this part of speech; this choice makes sense, i.e. the default is likely to be the largest inflection class, not a subclass of some class.) According to Wurzel (as described in Carstairs-McCarthy 1998b), the default class is the Inflection Class to which newly coined lexemes are usually assigned, to which lexemes from other classes 'drift' in the process of historical change, and the class to which children tend to assign lexemes before they learn the correct class. For our purposes, however, it may be simpler just to think of the default class as being the largest class numerically, i.e. the class to which words in the lexical database are assigned as a first guess.

General Info
Name | DefaultInflectionClass
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 1 | MoInflClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | DefaultInflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | DefaultInflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AffixCategory Report

Report: | General Info | Association Ends | Tagged Values

Association AffixCategory

In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. This field is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a CmPossibility of "derv" (derivational affix).

General Info
Name | AffixCategory
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffMsa
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffMsa
Association | AffixCategory
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | AffixCategory
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association FeatureStructure Report

Report: | General Info | Association Ends | Tagged Values

Association FeatureStructure

General Info
Name | FeatureStructure
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSimpleContextNC
End B | <unnamed> | 1 | PhNaturalClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSimpleContextNC
Association | FeatureStructure
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhNaturalClass
Association | FeatureStructure
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Allomorphs Report

Report: | General Info | Association Ends | Tagged Values

Association Allomorphs

refers to a seq of MoForm objects, the co-occurrence of which is ungrammatical. Usually, there will be exactly two such allomorphs. If there are three or more allomorphs, the intended meaning is that a word is ungrammatical in which all such morphemes appear (but the co-occurrence of only some of the morphemes is not prohibited). Having only one morpheme in this attribute should be flagged as a Warning, since such a restriction can do nothing. When the Adjacency attribute is 'Anywhere', the fact that this attribute is a seq, rather than a collection, is unimportant. But the order of allomorphs becomes important when the Adjacency attribute has any other value. Specifically, the order of the allomorphs in this attribute is interpreted as a left-to-right order.

General Info
Name | Allomorphs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAlloAdhocProhib
End B | <unnamed> | 0..* | MoForm

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |
Tag Name: Questions |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAlloAdhocProhib
Association | Allomorphs
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoForm
Association | Allomorphs
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association FromInflectionClass Report

Report: | General Info | Association Ends | Tagged Values

Association FromInflectionClass

specifies the inflection (conjugation or declension) class which the stem to which this affix attaches must belong. In general, derivational affixes are arguably not marked for this property, so this attribute may be superfluous. However, it will certainly be necessary if non-Inflectional inflectional morphology is to be modeled using this class. (And it may turn out that some derivational affixes are sensitive to the inflectional class of their stem.) Under the realizational model of inflectional morphology, the inflection class to which an allomorph of an inflectional (realizational) affix belongs is indicated by MoAffixForm.InflectionClasses. That attribute is also available for allomorphs of derivational affixes (i.e. this class). That might be overkill, in that if a derivational affix attaches to stems of a single inflectional class, we could assign a single allomorph to that affix, and capture the restriction of the affix to the inflectional class as a restriction on that allomorph. However, the fromInflectionClass attribute here is parallel to the toInflectionClass attribute (defined below), which is independently needed. (Andy suggests that it may also be the case that a derivational affix would apply to a single inflection class, but have multiple allomorphs, in which case it would be convenient to have the attribute here, thereby avoiding the need to mark each allomorph for the same inflection class.)

General Info
Name | FromInflectionClass
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 1 | MoInflClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | FromInflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | FromInflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoDerivTrace
Child Element | MoDerivAffApp


Association Wordforms Report

Report: | General Info | Association Ends | Tagged Values

Association Wordforms

General Info
Name | Wordforms
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WordformLookupList
End B | <unnamed> | 0..* | WordFormLookup

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WordformLookupList
Association | Wordforms
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WordFormLookup
Association | Wordforms
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Content Report

Report: | General Info | Association Ends | Tagged Values

Association Content

refers to a PhContextOrVar in MoAffixProcess.Input of the owner of this object; the meaning is that the stretch of the input word matched by that PhContextOrVar is copied over without alteration to the output.

General Info
Name | Content
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoCopyFromInput
End B | <unnamed> | 1 | PhContextOrVar

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoCopyFromInput
Association | Content
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhContextOrVar
Association | Content
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association MorphoSyntaxAnalyses Report

Report: | General Info | Association Ends | Tagged Values

Association MorphoSyntaxAnalyses

General Info
Name | MorphoSyntaxAnalyses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntry
End B | <unnamed> | 0..* | MoMorphSynAnalysis

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | MorphoSyntaxAnalyses
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphSynAnalysis
Association | MorphoSyntaxAnalyses
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association DomainTypes Report

Report: | General Info | Association Ends | Tagged Values

Association DomainTypes

General Info
Name | DomainTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | DomainTypes
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | DomainTypes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoDerivTrace


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoMorphSynAnalysis
Child Element | MoDerivStepMsa


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhSimpleContext
Child Element | PhSimpleContextSeg


Association Stems Report

Report: | General Info | Association Ends | Tagged Values

Association Stems

In a thorough analysis this attribute will not be used. However, if the linguist wishes to only analyze stems this is an easy way to accomplish this.

General Info
Name | Stems
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiAnalysis
End B | <unnamed> | 0..* | LexEntry

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | Stems
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | Stems
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association DefaultAffix Report

Report: | General Info | Association Ends | Tagged Values

Association DefaultAffix

refers to an inflectional affix (MoInflectionalAffixMsa) that is attached to the stem selected by the DefaultStem to give this stem, if the stem's lexical entry does not have an MoStemAllomorph with this stem name. If this attribute is empty, the default shape of this kind of stem is the same as that of the default stem; effectively, the stem is then formed by null affixation. The situation in which this attribute is empty is common in languages where some lexemes have a suppletive stem, but where the majority of lexemes use a regular stem without any special affixation. In Spanish, for instance, some verbs have an irregular stem used in the first person singular present indicative and in the present subjunctive, but for most verbs, the stem used in these regions of the paradigm is the same as that used elsewhere. Note that in the course of doing S2W morphology, the user might initially assign Spanish stem-changing and non-stem-changing verbs to different paradigms. Later, noticing that the only difference between the two paradigms is the stem change, he could collapse the two paradigms (as advocated in Carstairs 1987, chapter 6), retaining the special '1s present indicative/present subjunctive' form for the irregular verbs, and leaving the '1s present indicative/present subjunctive' form empty for regular verbs. While it would be nice to limit the possibilities for this attr to less than all the affixes in the lexical database, it is not clear that there is any way to do so.

General Info
Name | DefaultAffix
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemName
End B | <unnamed> | 1 | MoInflAffMsa

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemName
Association | DefaultAffix
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffMsa
Association | DefaultAffix
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoMorphSynAnalysis


Association RightContext Report

Report: | General Info | Association Ends | Tagged Values

Association RightContext

General Info
Name | RightContext
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhEnvironment
End B | <unnamed> | 1 | PhPhonContext

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhEnvironment
Association | RightContext
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonContext
Association | RightContext
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoStemName


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoRuleMapping
Child Element | MoCopyFromInput


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ReversalIndexEntry


Association PRuleApps Report

Report: | General Info | Association Ends | Tagged Values

Association PRuleApps

owns an ordered seq of MoPhonolRuleApp, representing the application of the phonological rules of this stratum. Note that the fact that this attr belongs to the MoStratumApp precludes modeling cyclic application. That restriction could easily be lifted. The order is the order of application in derivation (which may be the reverse of the order in parsing).

General Info
Name | PRuleApps
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStratumApp
End B | <unnamed> | 0..* | MoPhonolRuleApp

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratumApp
Association | PRuleApps
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoPhonolRuleApp
Association | PRuleApps
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association PartOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association PartOfSpeech

Most users will be more familiar with the notion of PartOfSpeech or morphosyntactic category than the notion of the object MorphoSyntacticInformation. This attribute, PartOfSpeech, stores the reference to the PartOfSpeech.

General Info
Name | PartOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemMsa
End B | <unnamed> | 1 | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | PartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | PartOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AffixMsa Report

Report: | General Info | Association Ends | Tagged Values

Association AffixMsa

refers to an MoInflectonalAffixMsa, the inflectional affix which was attached. Note that this MSA does not result in any change to the MSA of the word. As with the AffixForm attr, if the application of this slot results in an implicit zero affix (because none of the MoInflectionalAffixMsas belonging to this MoInflAffixSlot matched the InflectionalFeatures of the owning MoDerivation), this AffixMsa attr will be none.

General Info
Name | AffixMsa
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffixSlotApp
End B | <unnamed> | 1 | MoInflAffMsa

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlotApp
Association | AffixMsa
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffMsa
Association | AffixMsa
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhTerminalUnit
Child Element | PhPhoneme


Association Slot Report

Report: | General Info | Association Ends | Tagged Values

Association Slot

refers to an MoInflAffixSlot in the MoInflAffixTemplate pointed to by the Template attr of my owner.

General Info
Name | Slot
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffixSlotApp
End B | <unnamed> | 1 | MoInflAffixSlot

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlotApp
Association | Slot
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlot
Association | Slot
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoMorphData


Association Stratum Report

Report: | General Info | Association Ends | Tagged Values

Association Stratum

refers to the MoStratum to which this MoMorphoSyntaxAnalysis object belongs. In an earlier version of this document, this attr belonged to MoForm. But that implied that one allomorph might belong to one stratum, and another allomorph to another stratum, which seems wrong. It is here, rather than on the superclass, because MoInflectionalAffixMsas do not need to "know" their stratum (their stratum is specified by the MoInflAffixTemplate in which they appear). (The other subclass of MoMorphoSyntaxAnalysis which has this attr is MoDerivationalAffixMsa.)

General Info
Name | Stratum
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemMsa
End B | <unnamed> | 1 | MoStratum

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | Stratum
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratum
Association | Stratum
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | LexPronunciation


Association Contexts Report

Report: | General Info | Association Ends | Tagged Values

Association Contexts

Change this here.

General Info
Name | Contexts
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonData
End B | <unnamed> | 0..* | PhContextOrVar

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonData
Association | Contexts
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhContextOrVar
Association | Contexts
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association AnthroCodes Report

Report: | General Info | Association Ends | Tagged Values

Association AnthroCodes

General Info
Name | AnthroCodes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WordFormLookup
End B | <unnamed> | 0..* | CmAnthroItem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WordFormLookup
Association | AnthroCodes
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnthroItem
Association | AnthroCodes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association PlusConstr Report

Report: | General Info | Association Ends | Tagged Values

Association PlusConstr

Refers to a collection seq of PhFeatureConstraint. The use of a plusConstraint only makes sense if there are two or more contexts in a rule that make use of the same constraint. If two such constraints occur in the environment of the rule (treating the input as part of the environment), then the feature referred to by the constraint is required to have the same value in every place where the word matches the pattern. For example, if a plusConstraint for the feature voiced appears on two adjacent consonant contexts in a rule, then the word being matched must have two adjacent consonants with identical voicing. If one of the constraints is in the environment and one in the output of the rule, then the effect is that of a rule of assimilation: in the form output by the rule, the phoneme affected by the rule will have the same value as the value on the phoneme matched by the environment.This attribute is not intended to be implemented immediately, but is included here for completeness (since it is apparently difficult to add new attributes once a COM interface has been defined).Note that although this attr is defined as a collection seq (not an ordered seq), the order is assumed to be stable. Otherwise the labels used in SPE-style rules would be subject to change. On the other hand, the use of a seq attr here may be overkill; from a linguistic standpoint, a single constraint (plus or minus) might be adequate. Renamed from PlusConstraints for the Firebird port.

General Info
Name | PlusConstr
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSimpleContextNC
End B | <unnamed> | 0..* | PhFeatureConstraint

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSimpleContextNC
Association | PlusConstr
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhFeatureConstraint
Association | PlusConstr
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Codes Report

Report: | General Info | Association Ends | Tagged Values

Association Codes

a collection of PhCodes (which amounts to a seq of strings), each in a single encoding (but not perhaps all in the same encoding). Each string is a representation of the phoneme or boundary marker in that encoding.

General Info
Name | Codes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhTerminalUnit
End B | <unnamed> | 0..* | PhCode

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |
Tag Name: Questions |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhTerminalUnit
Association | Codes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhCode
Association | Codes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Examples Report

Report: | General Info | Association Ends | Tagged Values

Association Examples

General Info
Name | Examples
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | LexExampleSentence

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | Examples
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexExampleSentence
Association | Examples
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association SlotApps Report

Report: | General Info | Association Ends | Tagged Values

Association SlotApps

owns an ordered seq of MoInflAffixSlotApps, representing the sequence of inflectional affix slots belonging to this template that were applied in the derivation. An alternative to having this attr and a separate class for slot applications, would be to have an attr here for inflectional affix applications themselves, bypassing the "middleman." The distinction between slot applications and the attachment of a particular affix belonging to a slot is that if no affix in a particular slot applies, the effect is that of an implicit zero affix. Under this alternative, there would thus be no indication that the slot in question had been tried. It seems better to have this attr record the slot applications, on the assumption that one wants to know if there was an implicit zero affix. I have defined this as an ordered seq, but it would be possible to derive the ordering from the order of the MoInflAffixSlots in the Slots attr of the MoInflAffixTemplate of this template application. However, this would not work if the user had changed the order of slots since this derivation was created.

General Info
Name | SlotApps
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflTemplateApp
End B | <unnamed> | 0..* | MoInflAffixSlotApp

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflTemplateApp
Association | SlotApps
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlotApp
Association | SlotApps
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association MorphType Report

Report: | General Info | Association Ends | Tagged Values

Association MorphType

refers to an MoMorphType which is an item on a possibilities list. Possibilities include at least: prefix, suffix, infix, circumfix, root, bound root, and probably proclitic and enclitic. Note that most of these are appropriate for one or the other subclass, but since there is only one possibilities list, the types must be limited by procedural code. Other kinds of affixation (circumfixes, simulfixes, suprafixes etc.) are probably beyond the capabilities of Item-and-Arrangement morphology, and may therefore need to be prevented from appearing (or grayed out) with the class MoAffixAllomorph. Additional Notes: It is of course possible to analyze reduplication as the attachment of a prosodic constituent, such as a syllable (see McCarthy and Prince 1990), provided there is some way of filling the melodic information into that skeleton. But the system described here does not provide a way of automatically copying such melodic information, so reduplication cannot be treated in that way at present. (And in many cases, reduplication under prosodic morphology requires the base to be parsed into two constituents, so that affixation still involves more than specifying the prosodic form of the affix.)

General Info
Name | MorphType
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoForm
End B | <unnamed> | 1 | MoMorphType

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoForm
Association | MorphType
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphType
Association | MorphType
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoRuleMapping
Child Element | MoInsertPhones


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhContextOrVar


Association StemNames Report

Report: | General Info | Association Ends | Tagged Values

Association StemNames

owns a collection of MoStemNames, which define any non-default inflectional stems of the inflection class (but not the default stem) in addition to those found in the PartOfSpeech. The MoStemNames are interpreted as a disjunctively ordered list, i.e. in selecting a Stem for a given word, the list of StemNames is searched linearly, stopping at the first one for which one of its cells unifies with the FsFeatStruc of the word to be derived (see Choosing a Stem Allomorph). The order of the MoStemNames in this attribute is therefore important. If this attribute is empty, it defaults to the value of the same attribute in its owner. This allows e.g. defining a set of stem names for all verbs, and inheriting those names for all inflection classes of verb (as well as for all subcategories of verb). It should probably be possible to block such inheritance without specifying any stem names, so there needs to be some specified value for that ('nil', say).

General Info
Name | StemNames
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflClass
End B | <unnamed> | 0..* | MoStemName

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | StemNames
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemName
Association | StemNames
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | MoMorphType


Association StratumApps Report

Report: | General Info | Association Ends | Tagged Values

Association StratumApps

owns an ordered seq of MoStratumApp structures, representing the sequence of applications of strata (i.e. of the affixes and phonological rules of those strata) to an underlying form. The order is from the deepest stratum to the shallowest.

General Info
Name | StratumApps
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDeriv
End B | <unnamed> | 0..* | MoStratumApp

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDeriv
Association | StratumApps
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratumApp
Association | StratumApps
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association ToMsa Report

Report: | General Info | Association Ends | Tagged Values

Association ToMsa

owns an MoStemMsa, giving the morphosyntactic information about the output of this compound. (Since the morphosyntactic properties of the daughters cannot be inherited in an exocentric compound, there is no question here of conflicts between the properties specified in this attribute and the properties of the daughters.) There is no provision for choosing a part of speech based on the argument properties of either element of the compound.

General Info
Name | ToMsa
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoExoCompound
End B | <unnamed> | 1 | MoStemMsa

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoExoCompound
Association | ToMsa
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | ToMsa
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association DomainTypes Report

Report: | General Info | Association Ends | Tagged Values

Association DomainTypes

General Info
Name | DomainTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | DomainTypes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | DomainTypes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association InflectionClasses Report

Report: | General Info | Association Ends | Tagged Values

Association InflectionClasses

owns a collection seq of MoInflectionClasses, each of which is an inflection class (conjugation or declension class) immediately owned by this part of speech. This does not include sub-inflection classes of those classes, for which see vAllSubInflectionClasses; nor does it include any inflection classes defined on more abstract parts of speech, for which see vAllSuperInflectionClasses. See also vAllInflectionClasses.

General Info
Name | InflectionClasses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 0..* | MoInflClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | InflectionClasses
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | InflectionClasses
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Phonemes Report

Report: | General Info | Association Ends | Tagged Values

Association Phonemes

collection seq of PhPhoneme.

General Info
Name | Phonemes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonemeSet
End B | <unnamed> | 0..* | PhPhoneme

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonemeSet
Association | Phonemes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhoneme
Association | Phonemes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association PrefixSlots Report

Report: | General Info | Association Ends | Tagged Values

Association PrefixSlots

refers to an ordered seq of MoInflAffixSlot, i.e. those slots which correspond (roughly) to prefixes. The order is from the innermost affix out, i.e. right-to-left. The reason for this attribute (and for the SuffixSlots attribute, below) is that the Slots attribute is a derivation order, i.e. the order in which the affixes are applied during a derivation; while the partition into prefix and suffix slots is for purposes of display, and to support the stealth-to-wealth concept (see discussion above, under slots). For most languages, the PrefixSlots and the SuffixSlots will partition the entire set of slots. Of course, this assumes that no affix slot contains both prefixes and suffixes (i.e. there is no discontinuous bleeding), and that affixes of reduplication, infixes, circumfixes, simulfixes etc. can be shoe-horned into one or the other of these attributes. There are almost certainly languages where this will not work, and for which the user may wish to ignore the prefix and suffix division. Accordingly, some alternative sort of display should be available for that situation. An example of such a language is Huave (Matthews 1972b), for which some slots contain both prefixes and suffixes; see also Stump's (1992) discussion of "ambifixal position classes."

General Info
Name | PrefixSlots
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffixTemplate
End B | <unnamed> | 0..* | MoInflAffixSlot

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixTemplate
Association | PrefixSlots
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlot
Association | PrefixSlots
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association MinusConstr Report

Report: | General Info | Association Ends | Tagged Values

Association MinusConstr

refers to a collection seq of PhFeatureConstraints; see discussion under the plusConstraints attr. A feature in question is required to have opposite value from a plusConstraint elsewhere in the rule, and thus makes sense only if a constraint with the same value appears elsewhere in the rule.See implementation comments under plusConstraints. Changed from MinusConstraints for the Firebird Port.

General Info
Name | MinusConstr
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSimpleContextNC
End B | <unnamed> | 0..* | PhFeatureConstraint

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSimpleContextNC
Association | MinusConstr
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhFeatureConstraint
Association | MinusConstr
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmMajorObject
Child Element | WordformLookupList


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhTerminalUnit


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoRuleMapping
Child Element | MoModifyFromInput


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoBinaryCompoundRule
Child Element | MoCoordinateCompound


Association Content Report

Report: | General Info | Association Ends | Tagged Values

Association Content

refers to an ordered seq of PhPhonemes and/or PhBdryMarkers (thus the signature is the superclass PhTerminalUnit).

General Info
Name | Content
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInsertPhones
End B | <unnamed> | 0..* | PhTerminalUnit

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInsertPhones
Association | Content
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhTerminalUnit
Association | Content
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association UsageTypes Report

Report: | General Info | Association Ends | Tagged Values

Association UsageTypes

General Info
Name | UsageTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | UsageTypes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | UsageTypes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Feature Report

Report: | General Info | Association Ends | Tagged Values

Association Feature

refers to an FsFeatureDefnPhFeatureNode, the feature with respect to which the constraint ensures agreement (or disagreement).The use of an atomic attr, rather than a seq attr, emulates to a certain extent the insight of autosegmental phonology and feature geometry that a rule can change (or refer to in the environment) only a single feature node. Note however that the fact that the feature can be a nonterminal feature (an FsComplexFeature), allows agreement with respect to a number of features dominated by a single node (e.g. a place of articulation feature, which might dominate the features labial, coronal, and back).

General Info
Name | Feature
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhFeatureConstraint
End B | <unnamed> | 1 | FsFeatDefn

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhFeatureConstraint
Association | Feature
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatDefn
Association | Feature
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Input Report

Report: | General Info | Association Ends | Tagged Values

Association Input

owns an FsFeatStruc, constituting the morphosyntactic feature values which must be present in a word in order for this Rule of Referral to apply. Often these features form an 'environment' which is not altered in the Output. However, this is true only if the input features are disjunctive with the output features. For instance, suppose in some language the nominative plural of nouns is syncretic with the nominative singular. Assuming singular and plural are the two possible values of 'number' in this language, this syncretism can be represented by a rule which has as input [case: nominative] and as output [number: singular]. But it is not always possible to make the input and output features disjunctive, particularly (but not only) where features are non-binary. For example, if the above syncretism held in a language which distinguished dual number, and the nominative dual was distinct from the singular (and plural) nominative forms, then it would be necessary to mention the 'number' feature both in the input and in the output, to prevent the rule from overapplying to the dual. It might be possible (and desirable) to have a view of rules of referral in which the input features which are unaffected in the output are distinguished (as a sort of environment) from the input features which are changed in the output. Additional notes: In Stump's (1993a, (11) page 457) format for a Rule of Referral, this corresponds to τ on the left-hand side.

General Info
Name | Input
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoReferralRule
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoReferralRule
Association | Input
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | Input
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | WordFormLookup


Association RulesOfReferral Report

Report: | General Info | Association Ends | Tagged Values

Association RulesOfReferral

owns an ordered seq of MoReferralRule; used for statements like "the accusative plural of nouns is identical to the nominative plural" or "the accusative plural of second declension nouns is identical to the nominative plural'. (Note that rules of referral which are owned by the PartOfSpeech hold for all lexemes of that part of speech, regardless of inflection class; whereas rules of referral owned by an MoInflectionClass hold only for lexemes of that class. In Stump's (1993a) notation, the latter case corresponds to indicating a 'CLASS' for the Referral Rule.)I (MM) have defined this as an ordered seq, because in rare cases one referral rule might override another such rule. See the discussion of the similar RulesOfReferral attr in MoInflectionClass.

General Info
Name | RulesOfReferral
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 0..* | MoReferralRule

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | RulesOfReferral
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoReferralRule
Association | RulesOfReferral
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Members Report

Report: | General Info | Association Ends | Tagged Values

Association Members

an ordered seq of PhPhonologicalContext (but not normally another PhSequenceContext)

General Info
Name | Members
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhSequenceContext
End B | <unnamed> | 0..* | PhPhonContext

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhSequenceContext
Association | Members
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonContext
Association | Members
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Data TypemultiString Report

Report: | General Info

Data types
Data Type multiString

General Info
Name | multiString
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhNaturalClass
Child Element | PhNCSegments


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | LexEntry


Association RulesOfReferral Report

Report: | General Info | Association Ends | Tagged Values

Association RulesOfReferral

owns a sequence of MoReferralRule. Like the attribute pRulesOfReferral in the class PartOfSpeech, except that rules of referral which are owned by the PartOfSpeech hold for all lexemes of that part of speech (regardless of inflection class), whereas rules of referral owned by this class hold only for lexemes of a particular class. (In Stump's (1993a) notation, the latter case corresponds to indicating a 'CLASS' for the Referral Rule.)

General Info
Name | RulesOfReferral
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflClass
End B | <unnamed> | 0..* | MoReferralRule

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | RulesOfReferral
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoReferralRule
Association | RulesOfReferral
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association ThesaurusItems Report

Report: | General Info | Association Ends | Tagged Values

Association ThesaurusItems

General Info
Name | ThesaurusItems
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | ThesaurusItems
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | ThesaurusItems
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Member Report

Report: | General Info | Association Ends | Tagged Values

Association Member

a PhPhonologicalContext (but not normally another PhIterationContext)

General Info
Name | Member
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhIterationContext
End B | <unnamed> | 1 | PhPhonContext

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhIterationContext
Association | Member
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonContext
Association | Member
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Introduction Report

Report: | General Info | Association Ends | Tagged Values

Association Introduction

General Info
Name | Introduction
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | Introduction
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Introduction
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | WfiWordform


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoDerivTrace
Child Element | MoCompoundRuleApp


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | WfiGloss


Association Description Report

Report: | General Info | Association Ends | Tagged Values

Association Description

General Info
Name | Description
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonContext
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonContext
Association | Description
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Description
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Segments Report

Report: | General Info | Association Ends | Tagged Values

Association Segments

refers to a collection seq of PhPhoneme, which are interpreted as the members of this class.

General Info
Name | Segments
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhNCSegments
End B | <unnamed> | 0..* | PhPhoneme

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhNCSegments
Association | Segments
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhoneme
Association | Segments
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoMorphSynAnalysis
Child Element | MoDerivAffMsa


Association Subentries Report

Report: | General Info | Association Ends | Tagged Values

Association Subentries

General Info
Name | Subentries
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ReversalIndexEntry
End B | <unnamed> | 0..* | ReversalIndexEntry

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ReversalIndexEntry
Association | Subentries
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ReversalIndexEntry
Association | Subentries
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ThesaurusItems Report

Report: | General Info | Association Ends | Tagged Values

Association ThesaurusItems

General Info
Name | ThesaurusItems
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WordFormLookup
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WordFormLookup
Association | ThesaurusItems
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | ThesaurusItems
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Senses Report

Report: | General Info | Association Ends | Tagged Values

Association Senses

I am not currently sure whether senses belong on minor entries or not but we did allow this in LinguaLinks so I will leave it here for now for compatibility's sake.

General Info
Name | Senses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntry
End B | <unnamed> | 0..* | LexSense

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | Senses
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | Senses
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association ToInflectionClass Report

Report: | General Info | Association Ends | Tagged Values

Association ToInflectionClass

specifies the inflection (conjugation or declension) class which the word derived from this affix attaches belongs. An example of the use of this attribute would be to mark the conjugation class resulting from the attachment of a verbalizer. Another example is the use of the noun (declension) class 3 in Swahili to mark dimunitives (Beard 1998: 62). Note that a PartOfSpeech has an attr defaultInflClass, to which a derived word will belong if no toInflClass is defined here.

General Info
Name | ToInflectionClass
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 1 | MoInflClass

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | ToInflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflClass
Association | ToInflectionClass
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AnthroCodes Report

Report: | General Info | Association Ends | Tagged Values

Association AnthroCodes

General Info
Name | AnthroCodes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | CmAnthroItem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | AnthroCodes
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnthroItem
Association | AnthroCodes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Stratum Report

Report: | General Info | Association Ends | Tagged Values

Association Stratum

refers to the MoStratum whose application this trace structure represents.

General Info
Name | Stratum
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStratumApp
End B | <unnamed> | 1 | MoStratum

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratumApp
Association | Stratum
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratum
Association | Stratum
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Rule Report

Report: | General Info | Association Ends | Tagged Values

Association Rule

refers to the phonological rule (class to be defined) whose application this trace structure represents

General Info
Name | Rule
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoPhonolRuleApp
End B | <unnamed> | 1 | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: Questions |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoPhonolRuleApp
Association | Rule
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | Rule
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhPhonContext
Child Element | PhIterationContext


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoInflClass


Association LeftForm Report

Report: | General Info | Association Ends | Tagged Values

Association LeftForm

LeftForm: refers to a form (Wordform? MoStemAllomorph?), that of the left-hand member of the compound.

General Info
Name | LeftForm
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoCompoundRuleApp
End B | <unnamed> | 1 | MoStemAllomorph

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoCompoundRuleApp
Association | LeftForm
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemAllomorph
Association | LeftForm
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | WfiWordSet


Association PhonemeSets Report

Report: | General Info | Association Ends | Tagged Values

Association PhonemeSets

owns a collection of PhPhonemeSets, describing the phonemic inventory of the language. The reason for allowing this to be a collection (rather than atomic) is to allow for phonological descriptions at multiple levels (strata),

General Info
Name | PhonemeSets
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonData
End B | <unnamed> | 0..* | PhPhonemeSet

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonData
Association | PhonemeSets
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonemeSet
Association | PhonemeSets
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Phonemes Report

Report: | General Info | Association Ends | Tagged Values

Association Phonemes

refers to a PhPhonemeSet which provides the phonemes and boundary markers relevant to this stratum. In Hermit Crab, there were two attributes similar to this on strata: an InputLevelOfRepresentation, and an OutputLevelOfRepresentation. It was not clear that this bought anything that having different levels of representation in successive strata would not have bought.

General Info
Name | Phonemes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStratum
End B | <unnamed> | 1 | PhPhonemeSet

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratum
Association | Phonemes
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonemeSet
Association | Phonemes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Linker Report

Report: | General Info | Association Ends | Tagged Values

Association Linker

refers to an MoAffixAllomorph, that of the linker between the two parts of the compound. If there is no linker, this attr is none.

General Info
Name | Linker
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoCompoundRuleApp
End B | <unnamed> | 1 | MoAffixAllomorph

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoCompoundRuleApp
Association | Linker
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixAllomorph
Association | Linker
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AffixForm Report

Report: | General Info | Association Ends | Tagged Values

Association AffixForm

refers to the MoAffixAllomorph, giving the phonetic form of the affix.

General Info
Name | AffixForm
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffApp
End B | <unnamed> | 1 | MoAffixAllomorph

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffApp
Association | AffixForm
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixAllomorph
Association | AffixForm
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoRuleMapping


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhPhonContext
Child Element | PhSimpleContext


Association AnalyzingAgents Report

Report: | General Info | Association Ends | Tagged Values

Association AnalyzingAgents

General Info
Name | AnalyzingAgents
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphData
End B | <unnamed> | 0..* | CmAgent

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphData
Association | AnalyzingAgents
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAgent
Association | AnalyzingAgents
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoAffixForm
Child Element | MoAffixProcess


Association OutputMsa Report

Report: | General Info | Association Ends | Tagged Values

Association OutputMsa

owns an MoDerivationalStepMsa, giving the morphosyntactic information resulting from attaching the derivational affix.

General Info
Name | OutputMsa
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffApp
End B | <unnamed> | 1 | MoDerivStepMsa

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffApp
Association | OutputMsa
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivStepMsa
Association | OutputMsa
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association BoundaryMarkers Report

Report: | General Info | Association Ends | Tagged Values

Association BoundaryMarkers

collection seq of PhBdryMarker

General Info
Name | BoundaryMarkers
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhPhonemeSet
End B | <unnamed> | 0..* | PhBdryMarker

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonemeSet
Association | BoundaryMarkers
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhBdryMarker
Association | BoundaryMarkers
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Features Report

Report: | General Info | Association Ends | Tagged Values

Association Features

owns an FsFeatStruc, specifying the feature values which characterize this natural class. The meaning is that any phoneme which includes (N.B.: not unifies with) the specified feature values matches this natural class.

General Info
Name | Features
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PhNCFeatures
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhNCFeatures
Association | Features
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | Features
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association CompoundRules Report

Report: | General Info | Association Ends | Tagged Values

Association CompoundRules

owns a seq of MoCompoundRules. (Alternatively, these could be owned in the stratum to which they belong - see MoStratum.vCompoundRules for discussion.) The order corresponds to the order in which the compounding rules apply in a derivation.

General Info
Name | CompoundRules
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphData
End B | <unnamed> | 0..* | MoCompoundRule

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |
Tag Name: Questions |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphData
Association | CompoundRules
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoCompoundRule
Association | CompoundRules
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Appendixes Report

Report: | General Info | Association Ends | Tagged Values

Association Appendixes

General Info
Name | Appendixes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 0..* | LexAppendix

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | Appendixes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexAppendix
Association | Appendixes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | PartOfSpeech


Association Content Report

Report: | General Info | Association Ends | Tagged Values

Association Content

refers to a PhContextOrVar from the input of the MoAffixProcess owning this object; the meaning is that the stretch of the input word matched by that PhContextOrVar is copied over to the output, but modified in accordance with the modification attribute. Typically, this will be a single phoneme, which is modified by the addition of one or two features (e.g. by being palatalized).

General Info
Name | Content
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoModifyFromInput
End B | <unnamed> | 1 | PhContextOrVar

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoModifyFromInput
Association | Content
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhContextOrVar
Association | Content
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhFeatureConstraint


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | PhSimpleContext
Child Element | PhSimpleContextNC


Association AffixForm Report

Report: | General Info | Association Ends | Tagged Values

Association AffixForm

refers to an MoAffixForm, the allomorph of the inflectional affix which was attached. If the application of this slot results in an implicit zero affix (because none of the MoInflectionalAffixMsas belonging to this MoInflAffixSlot matched the InflectionalFeatures of the owning MoDerivation), this AffixForm will be none.

General Info
Name | AffixForm
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffixSlotApp
End B | <unnamed> | 1 | MoAffixForm

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlotApp
Association | AffixForm
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixForm
Association | AffixForm
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Derivation Report

Report: | General Info | Association Ends | Tagged Values

Association Derivation

General Info
Name | Derivation
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiAnalysis
End B | <unnamed> | 1 | MoDeriv

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | Derivation
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDeriv
Association | Derivation
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Stratum Report

Report: | General Info | Association Ends | Tagged Values

Association Stratum

refers to the MoStratum to which this MoInflAffixTemplate belongs. Normally that would be the final stratum (or at least to the final stratum in which morphology takes place; if one is modeling post-lexical phonology, that would usually be in a stratum after the inflectional morphology). However, in languages where some derivational affixes attach outside of (some) inflection, that derivational morphology (and any subsequent inflectional morphology) will be in a stratum outside of a stratum containing the inflectional affix template. This definition assumes there are no cycles, i.e. that one does not get the same kind of inflectional affixes both inside and outside of derivational affixes. That's not obviously correct, e.g. one might have [[[[Noun_root] noun_template ] verbalizer ] verb_template] and [[[[Verb_root] verb_template ] nominalizer ] noun_template] where the two instances of noun_template and of verb_template are the same. This would be a counterexample (or would require duplicating the templates in the two strata, obviously a sign that something is wrong with the analysis).

General Info
Name | Stratum
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffixTemplate
End B | <unnamed> | 1 | MoStratum

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixTemplate
Association | Stratum
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratum
Association | Stratum
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Region Report

Report: | General Info | Association Ends | Tagged Values

Association Region

owns an FsFeatStruc defining the region of the paradigm for which this template is relevant. The idea here is that in some regions of the template (typically, things like participles or imperatives), there may be fewer affix slots than in other regions. While one could use the same template for all regions, with affixes in some of the slots restricted to appearing only with certain features (such as [?participle]), this is probably not the simplest analysis (since it requires all affixes in those slots to be so marked, including what would otherwise be default affixes). If this attr is empty, then this template pertains to the entire paradigm except for any regions covered by templates ordered before this one in the PartOfSpeech.AffixTemplates attr of the owner.

General Info
Name | Region
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffixTemplate
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |
Tag Name: Questions |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixTemplate
Association | Region
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | Region
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association LexicalFormIndex Report

Report: | General Info | Association Ends | Tagged Values

Association LexicalFormIndex

General Info
Name | LexicalFormIndex
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 0..* | LexEntry

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | LexicalFormIndex
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | LexicalFormIndex
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoAdhocProhib


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoAdhocProhib
Child Element | MoMorphAdhocProhib


Association Output Report

Report: | General Info | Association Ends | Tagged Values

Association Output

Constitutes the morphosyntactic feature values which the Rule of Referral outputs. Additional notes: In Stump's (1993a, (11) page 457) format for a Rule of Referral, this corresponds to [F1:v1...Fm:Vm]. Note that the input and output fields may refer to the same features, albeit with different values. This is particularly likely for non-binary features (see Stump's rules (20) and (28), for example), but may also be necessary with binary features (e.g. Stump's rule (54b)). Accordingly, it would be possible to split the input features into a set of features whose values will be changed in the output, and a set of features which effectively form the environment for the change. This could even be done in the 'view' of the rule.

General Info
Name | Output
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoReferralRule
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoReferralRule
Association | Output
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | Output
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association FromMsFeatures Report

Report: | General Info | Association Ends | Tagged Values

Association FromMsFeatures

specifies the morphosyntactic features which the stem to which this affix attaches must bear. See also the discussion of the FromPartOfSpeech attribute above.

General Info
Name | FromMsFeatures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDerivAffMsa
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDerivAffMsa
Association | FromMsFeatures
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | FromMsFeatures
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoForm


Association Category Report

Report: | General Info | Association Ends | Tagged Values

Association Category

General Info
Name | Category
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiAnalysis
End B | <unnamed> | 1 | PartOfSpeech

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | Category
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | Category
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association BearableFeatures Report

Report: | General Info | Association Ends | Tagged Values

Association BearableFeatures

refers to a collection seq of FsFeatureDefn, each of which is a morphosyntactic feature which a word of this part of speech can bear. This is primarily intended for features which may be important to the derivational morphology, although these features may also be relevant to inflectional morphology. For example, the English suffix -ess is added only to animate nouns: waitress, lioness, actress, but *tabless, *officess; ?ful attaches to abstract nouns: graceful, useful, helpful, but *personful, *buildingful, *actorful.The notion of features that a given part of speech can bear is generally implicit in works on morphology, but see Lieber 1992: 90-91.

General Info
Name | BearableFeatures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PartOfSpeech
End B | <unnamed> | 0..* | FsFeatDefn

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PartOfSpeech
Association | BearableFeatures
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatDefn
Association | BearableFeatures
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association StemName Report

Report: | General Info | Association Ends | Tagged Values

Association StemName

refers to a MoStemName. Ordinarily, only one allomorph of any given stem will bear a given stem name, but this may not be true if there are phonologically conditioned allomorphs as well. If this attribute is empty, this stem is used as the default stem for the paradigm.

General Info
Name | StemName
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStemAllomorph
End B | <unnamed> | 1 | MoStemName

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemAllomorph
Association | StemName
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemName
Association | StemName
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Modification Report

Report: | General Info | Association Ends | Tagged Values

Association Modification

refers to an PhNCFeatures object, specifying the features to be added to the phonemes matched by the content to give a portion of the output.

General Info
Name | Modification
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoModifyFromInput
End B | <unnamed> | 1 | PhNCFeatures

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoModifyFromInput
Association | Modification
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhNCFeatures
Association | Modification
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association TemplateApp Report

Report: | General Info | Association Ends | Tagged Values

Association TemplateApp

owns an MoInflAffixTemplateApp, representing the application of an MoInflAffixTemplate belonging to this stratum and matching the InflectionClass of the MoStemMsa at the point of application.

General Info
Name | TemplateApp
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoStratumApp
End B | <unnamed> | 1 | MoInflTemplateApp

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStratumApp
Association | TemplateApp
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflTemplateApp
Association | TemplateApp
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association RightForm Report

Report: | General Info | Association Ends | Tagged Values

Association RightForm

RightForm: refers to a form (Wordform? MoStemAllomorph?), that of the right-hand member of the compound.

General Info
Name | RightForm
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoCompoundRuleApp
End B | <unnamed> | 1 | MoStemAllomorph

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |
Tag Name: Questions |  |
Tag Name: Usage |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoCompoundRuleApp
Association | RightForm
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemAllomorph
Association | RightForm
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoAffixForm
Child Element | MoAffixAllomorph


Association MsEnvFeatures Report

Report: | General Info | Association Ends | Tagged Values

Association MsEnvFeatures

owns an FsFeatStruc, defining the morphosyntactic features which the stem to which this affix attaches must bear. See discussion of the MsEnvPartOfSpeech attribute above.

General Info
Name | MsEnvFeatures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAffixAllomorph
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixAllomorph
Association | MsEnvFeatures
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | MsEnvFeatures
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association LeftMsa Report

Report: | General Info | Association Ends | Tagged Values

Association LeftMsa

owns an MoStemMsa, giving the morphosyntactic information about the left-hand member of this compound. If this MoStemMsa specifies a PartOfSpeech, then the left-hand member of this compound must belong to that part of speech. If this MoStemMsa specifies an FsFeatStruc, then the left-hand member of this compound must have (not unify with!) the features of that feature structure. Since the parts of speech are contained in an inheritance hierarchy, a question arises: if this MSA points to an abstract part of speech (verb, say), does a word with a more specific part of speech (transitive verb, say) match? In the absence of any reason to think it does not, I would suggest that reference to an abstract part of speech entails that more specific parts of speech are included. Otherwise, it is hard to imagine how one could use this attribute - it would be necessary to allow a collection of parts of speech, or else to have separate compound rule for each specific part of speech.

General Info
Name | LeftMsa
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoBinaryCompoundRule
End B | <unnamed> | 1 | MoStemMsa

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoBinaryCompoundRule
Association | LeftMsa
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoStemMsa
Association | LeftMsa
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PhPhonemeSet


Association SuffixSlots Report

Report: | General Info | Association Ends | Tagged Values

Association SuffixSlots

refers to an ordered seq of MoInflAffixSlot, i.e. those slots which correspond (roughly) to suffixes. The order is from the innermost affix out, i.e. left-to-right. See discussion re PrefixSlots concerning other types of affixes.

General Info
Name | SuffixSlots
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoInflAffixTemplate
End B | <unnamed> | 0..* | MoInflAffixSlot

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixTemplate
Association | SuffixSlots
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoInflAffixSlot
Association | SuffixSlots
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Input Report

Report: | General Info | Association Ends | Tagged Values

Association Input

Owns an ordered seq of PhContextOrVar, describing the form of the stem to which the affix attaches. The left-to-right order of the PhContextOrVars in this attribute corresponds to the order of the portions of the input word which match. (N.B.: There could be ambiguity, for instance if the input had two adjacent PhVariables. The system should check for this, and warn the user.) Given that PhContextOrVar can itself own an PhSequenceContext, the use of a seq attribute here may seem like overkill. However, it is only the topmost members of this Input attribute that can be numbered (the numbering is part of the user interface, and allows the user to point back to particular pieces of the input for the output). Perhaps this numbering can be done differently, in which case the Input attribute won't need to be seq.

General Info
Name | Input
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAffixProcess
End B | <unnamed> | 0..* | PhContextOrVar

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAffixProcess
Association | Input
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhContextOrVar
Association | Input
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association InflectionalFeats Report

Report: | General Info | Association Ends | Tagged Values

Association InflectionalFeats

Owns (but see below) an FsFeatStruc giving the inflectional features (to be) realized in this derivation. It is not clear whether this should be an owning or virtual attr. If derivations are always owned by some higher object that could logically hold such a feature structure (e.g. a test case or a cell in a paradigm), then this attr should just return that feature structure. Changed from InflectionalFeatures.

General Info
Name | InflectionalFeats
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoDeriv
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: Notes |  |
Tag Name: num |  |
Tag Name: Questions |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoDeriv
Association | InflectionalFeats
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | InflectionalFeats
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Data TypemultiUnicode Report

Report: | General Info

Data types
Data Type multiUnicode

General Info
Name | multiUnicode
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | WfiAnalysis


Data Typeboolean Report

Report: | General Info

Data types
Data Type boolean

General Info
Name | boolean
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data Typeinteger Report

Report: | General Info

Data types
Data Type integer

General Info
Name | integer
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data Typeunicode Report

Report: | General Info

Data types
Data Type unicode

General Info
Name | unicode
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data Typeimage Report

Report: | General Info

Data types
Data Type image

General Info
Name | image
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data Typestring Report

Report: | General Info

Data types
Data Type string

General Info
Name | string
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data Typetime Report

Report: | General Info

Data types
Data Type time

General Info
Name | time
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoDeriv


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsFeatureSpecification
Child Element | FsComplexValue


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | FsSymFeatVal


Association Value Report

Report: | General Info | Association Ends | Tagged Values

Association Value

Every Fs*Value class has an attribute of "Value". The only one that has multiple items is FsDisjunctiveValue (after all, how can you have a disjunction with only one item?). In a sense, even for FsDisjunctiveValue, there is only one "value" associated with a disjunction: it's the first one that "works." For consistency within the entire Fs*Value set, the attribute for FsDisjunctiveValue is in the singular as "Value" rather than "Values" even though it is a collection.

General Info
Name | Value
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsDisjunctiveValue
End B | <unnamed> | 0..* | FsSymFeatVal

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsDisjunctiveValue
Association | Value
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsSymFeatVal
Association | Value
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Value Report

Report: | General Info | Association Ends | Tagged Values

Association Value

General Info
Name | Value
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsComplexValue
End B | <unnamed> | 1 | FsAbstractStructure

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsComplexValue
Association | Value
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsAbstractStructure
Association | Value
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Value Report

Report: | General Info | Association Ends | Tagged Values

Association Value

General Info
Name | Value
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsClosedValue
End B | <unnamed> | 1 | FsSymFeatVal

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsClosedValue
Association | Value
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsSymFeatVal
Association | Value
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Types Report

Report: | General Info | Association Ends | Tagged Values

Association Types

General Info
Name | Types
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsFeatureSystem
End B | <unnamed> | 0..* | FsFeatStrucType

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatureSystem
Association | Types
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStrucType
Association | Types
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association FeatureSpecs Report

Report: | General Info | Association Ends | Tagged Values

Association FeatureSpecs

General Info
Name | FeatureSpecs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsFeatStruc
End B | <unnamed> | 0..* | FsFeatureSpecification

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | FeatureSpecs
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatureSpecification
Association | FeatureSpecs
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | FsFeatureSystem


Association Contents Report

Report: | General Info | Association Ends | Tagged Values

Association Contents

General Info
Name | Contents
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsFeatStrucDisj
End B | <unnamed> | 0..* | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStrucDisj
Association | Contents
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | Contents
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsFeatDefn
Child Element | FsComplexFeature


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | FsAbstractStructure


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsFeatureSpecification
Child Element | FsOpenValue


Association Type Report

Report: | General Info | Association Ends | Tagged Values

Association Type

General Info
Name | Type
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsFeatStruc
End B | <unnamed> | 1 | FsFeatStrucType

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | Type
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStrucType
Association | Type
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | FsFeatStrucType


Association Values Report

Report: | General Info | Association Ends | Tagged Values

Association Values

General Info
Name | Values
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsClosedFeature
End B | <unnamed> | 0..* | FsSymFeatVal

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsClosedFeature
Association | Values
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsSymFeatVal
Association | Values
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association FeatureDisjunctions Report

Report: | General Info | Association Ends | Tagged Values

Association FeatureDisjunctions

General Info
Name | FeatureDisjunctions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsFeatStruc
End B | <unnamed> | 0..* | FsFeatStrucDisj

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | FeatureDisjunctions
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStrucDisj
Association | FeatureDisjunctions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsFeatureSpecification
Child Element | FsSharedValue


Association Default Report

Report: | General Info | Association Ends | Tagged Values

Association Default

Feature of number might have a default value of singular.

General Info
Name | Default
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsFeatDefn
End B | <unnamed> | 1 | FsFeatureSpecification

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatDefn
Association | Default
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatureSpecification
Association | Default
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Feature Report

Report: | General Info | Association Ends | Tagged Values

Association Feature

General Info
Name | Feature
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsFeatureSpecification
End B | <unnamed> | 1 | FsFeatDefn

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatureSpecification
Association | Feature
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatDefn
Association | Feature
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Value Report

Report: | General Info | Association Ends | Tagged Values

Association Value

General Info
Name | Value
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsNegatedValue
End B | <unnamed> | 1 | FsSymFeatVal

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsNegatedValue
Association | Value
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsSymFeatVal
Association | Value
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsFeatDefn
Child Element | FsOpenFeature


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsFeatDefn
Child Element | FsClosedFeature


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsAbstractStructure
Child Element | FsFeatStruc


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsFeatureSpecification
Child Element | FsNegatedValue


Association Type Report

Report: | General Info | Association Ends | Tagged Values

Association Type

General Info
Name | Type
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsComplexFeature
End B | <unnamed> | 1 | FsFeatStrucType

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsComplexFeature
Association | Type
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStrucType
Association | Type
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsFeatureSpecification
Child Element | FsClosedValue


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsAbstractStructure
Child Element | FsFeatStrucDisj


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | FsFeatureSpecification


Association Value Report

Report: | General Info | Association Ends | Tagged Values

Association Value

General Info
Name | Value
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | FsSharedValue
End B | <unnamed> | 1 | FsFeatureSpecification

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsSharedValue
Association | Value
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatureSpecification
Association | Value
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | FsFeatureSpecification
Child Element | FsDisjunctiveValue


Association Styles Report

Report: | General Info | Association Ends | Tagged Values

Association Styles

Scripture requires text style attributes that are uniquely different from styles for general documents in the project. This new style sheet (collection of styles) can be structured just like the style sheet in the Language Project, but is used for all texts authored in the Scripture Editor - Drafts, Back Translations, Notes, UNS Questions, etc. This allows us to: a. utilize styles that are specific for Scripture use; b. avoid conflicts with the LangProject style sheet if, for example, a Style named 'Paragraph' is desired for both general documents and Scripture

General Info
Name | Styles
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Scripture
End B | <unnamed> | 0..* | StStyle

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Scripture
Association | Styles
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StStyle
Association | Styles
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ScriptureBooks Report

Report: | General Info | Association Ends | Tagged Values

Association ScriptureBooks

The Scripture object is a container for an ordered collection of ScrBooks (Scripture Books).

General Info
Name | ScriptureBooks
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Scripture
End B | <unnamed> | 0..* | ScrBook

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Scripture
Association | ScriptureBooks
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBook
Association | ScriptureBooks
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association BookId Report

Report: | General Info | Association Ends | Tagged Values

Association BookId

A reference to a ScrBookRef. This association is for convenience. The correct item in ScrBookRef could also be found using ScrBook.CanonicalNum.

General Info
Name | BookId
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrBook
End B | <unnamed> | 1 | ScrBookRef

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBook
Association | BookId
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBookRef
Association | BookId
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Content Report

Report: | General Info | Association Ends | Tagged Values

Association Content

A ScrSection has Content - the actual verses themselves. Content has a signature of StText allowing us to have multiple paragraphs, paragraph styles and character styles all of which will be used extensively for verse material. Chapter and verse references are character styles found in the Contents of the StTxtPara.

General Info
Name | Content
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrSection
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrSection
Association | Content
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Content
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Title Report

Report: | General Info | Association Ends | Tagged Values

Association Title

The Title can be a sequence of paragraphs. We might thus have a paragraph style for Main Title and for SubTitles to support titles like: The Acts of the Apostles

General Info
Name | Title
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrBook
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBook
Association | Title
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Title
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Sections Report

Report: | General Info | Association Ends | Tagged Values

Association Sections

A ScrBook is made up of ScrSections. ScrSections represent short passages of Scripture. For example, Matthew 1:1-17 in the NIV is a ScrSection with a heading of "The Genealogy of Jesus."

General Info
Name | Sections
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrBook
End B | <unnamed> | 0..* | ScrSection

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBook
Association | Sections
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrSection
Association | Sections
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Heading Report

Report: | General Info | Association Ends | Tagged Values

Association Heading

Headings are extra-canonical material used to help the reader know what a particular passage is about. Example: "The Genealogy of Jesus" for the passage (ScrSection) of Matthew 1:1-17. Although these are normally just a short-line, they sometimes are multi-lined including Headings and Subheadings. Thus the signature here is a StText - allowing us to have multiple paragraphs, paragraph styles and character styles.

General Info
Name | Heading
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrSection
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrSection
Association | Heading
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Heading
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ScrBook


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmMajorObject
Child Element | Scripture


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ScrSection


Association Status Report

Report: | General Info | Association Ends | Tagged Values

Association Status

The status of this Possibility. This is a user-definable list but initial list will include: Confirmed, Disproved, Pending.

General Info
Name | Status
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPossibility
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Status
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Status
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmMajorObject
Child Element | CmPossibilityList


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmCell


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ScrBookRef


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | CmCustomItem


Association Positions Report

Report: | General Info | Association Ends | Tagged Values

Association Positions

General Info
Name | Positions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPerson
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | Positions
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Positions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | UserViewRec


Association BasedOn Report

Report: | General Info | Association Ends | Tagged Values

Association BasedOn

General Info
Name | BasedOn
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StStyle
End B | <unnamed> | 1 | StStyle

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StStyle
Association | BasedOn
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StStyle
Association | BasedOn
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association PossList Report

Report: | General Info | Association Ends | Tagged Values

Association PossList

General Info
Name | PossList
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | UserViewField
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserViewField
Association | PossList
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | PossList
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association PossItems Report

Report: | General Info | Association Ends | Tagged Values

Association PossItems

An Overlay can have a number of CmPossibilities associated with it for the purposes of tagging text. These CmPossibilities come from a particular CmPossibilityList (defined by PossList). For example, the user might have an overlay for OCM codes having to do with marriage and fishing. He might have another overlay with OCM codes that have to do with cooking.

General Info
Name | PossItems
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmOverlay
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmOverlay
Association | PossItems
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | PossItems
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Paragraphs Report

Report: | General Info | Association Ends | Tagged Values

Association Paragraphs

General Info
Name | Paragraphs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StText
End B | <unnamed> | 0..* | StPara

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Paragraphs
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StPara
Association | Paragraphs
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association PlacesOfResidence Report

Report: | General Info | Association Ends | Tagged Values

Association PlacesOfResidence

General Info
Name | PlacesOfResidence
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPerson
End B | <unnamed> | 0..* | CmLocation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | PlacesOfResidence
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmLocation
Association | PlacesOfResidence
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmMajorObject


Association SubfieldOf Report

Report: | General Info | Association Ends | Tagged Values

Association SubfieldOf

General Info
Name | SubfieldOf
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | UserViewField
End B | <unnamed> | 1 | UserViewField

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserViewField
Association | SubfieldOf
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserViewField
Association | SubfieldOf
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | StStyle


Association Notes Report

Report: | General Info | Association Ends | Tagged Values

Association Notes

General Info
Name | Notes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmAgent
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAgent
Association | Notes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Notes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmOverlay


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | UserView


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmFilter


Association AnalyzedTextObjects Report

Report: | General Info | Association Ends | Tagged Values

Association AnalyzedTextObjects

AnalyzedTextObjects is used when there are associated analyses with any objects in the text. It is primarily meant for morphological interlinear analysis of text. Reference pointers to TxtWordformInContext (one for every word, punctuation and reference in the text) are set in a sequence. Note: the name of the class will likely change to TxtObjInContext because it handles more than just words. Refer to the documentation on TxtWordformInContext for more information. This attribute is used only if the application requires it. It does not obviate the need for TextObjects

General Info
Name | AnalyzedTextObjects
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StTxtPara
End B | <unnamed> | 0..* | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StTxtPara
Association | AnalyzedTextObjects
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | AnalyzedTextObjects
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Discussion Report

Report: | General Info | Association Ends | Tagged Values

Association Discussion

Any pertinent discussion for this Possibility.

General Info
Name | Discussion
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPossibility
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Discussion
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Discussion
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Confidence Report

Report: | General Info | Association Ends | Tagged Values

Association Confidence

Indicates confidence in the data collected for this possibility item. This value comes from a user-defined list that is used by many different FieldWorks objects (Events, Analysis Records, Lexical Entries and their Senses, etc.) These values are user-definable and initially include: Low, Medium and High as possibilities.

General Info
Name | Confidence
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPossibility
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Confidence
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Confidence
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Records Report

Report: | General Info | Association Ends | Tagged Values

Association Records

General Info
Name | Records
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | UserView
End B | <unnamed> | 0..* | UserViewRec

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserView
Association | Records
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserViewRec
Association | Records
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | StText


Association Researchers Report

Report: | General Info | Association Ends | Tagged Values

Association Researchers

The person(s) who created/modified this Possibility record or any of its fields.

General Info
Name | Researchers
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPossibility
End B | <unnamed> | 0..* | CmPerson

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Researchers
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | Researchers
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association SubPossibilities Report

Report: | General Info | Association Ends | Tagged Values

Association SubPossibilities

General Info
Name | SubPossibilities
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPossibility
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | SubPossibilities
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | SubPossibilities
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | UserViewField


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmProject


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CrossReference


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | StPara
Child Element | StTxtPara


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | CmLocation


Association TextObjects Report

Report: | General Info | Association Ends | Tagged Values

Association TextObjects

The Contents of StTxtPara are parsed into TextObjects. The event that triggers parsing is yet to be determined but will probably be when the StTxtPara loses focus. Parsed objects include Wordforms, Punctuation, and References (including ScrRefs if the contents are translated Scripture). A sequence of references are set to each of these objects as they are found in their respective inventories (Wordform Inventory, Punctuation Inventory, and ReferenceScheme) This attribute exists in order to allow for a concordance by WfiWordform, (currently including punctuation), PunctuationForm and/or ScrRef. This attribute is a "lite" version of AnalyzedTextObjects. This attribute should only be used if a particular application of StTxtPara requires concordances.

General Info
Name | TextObjects
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StTxtPara
End B | <unnamed> | 0..* | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StTxtPara
Association | TextObjects
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | TextObjects
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Fields Report

Report: | General Info | Association Ends | Tagged Values

Association Fields

General Info
Name | Fields
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | UserViewRec
End B | <unnamed> | 0..* | UserViewField

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserViewRec
Association | Fields
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserViewField
Association | Fields
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Cells Report

Report: | General Info | Association Ends | Tagged Values

Association Cells

General Info
Name | Cells
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmRow
End B | <unnamed> | 0..* | CmCell

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmRow
Association | Cells
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmCell
Association | Cells
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Next Report

Report: | General Info | Association Ends | Tagged Values

Association Next

General Info
Name | Next
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StStyle
End B | <unnamed> | 1 | StStyle

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StStyle
Association | Next
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StStyle
Association | Next
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Rows Report

Report: | General Info | Association Ends | Tagged Values

Association Rows

General Info
Name | Rows
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmFilter
End B | <unnamed> | 0..* | CmRow

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFilter
Association | Rows
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmRow
Association | Rows
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association SubFolders Report

Report: | General Info | Association Ends | Tagged Values

Association SubFolders

General Info
Name | SubFolders
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmFolder
End B | <unnamed> | 0..* | CmFolder

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFolder
Association | SubFolders
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFolder
Association | SubFolders
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmPossibility


Association ObjRefs Report

Report: | General Info | Association Ends | Tagged Values

Association ObjRefs

For Scripture, by convention this refers to ScrRef objects (a subclass of CmObject). In other texts we might possibly have a use for referring to other targets--for example, ChoicesListItems like OCM codes, if we decided to go down to the paragraph level but didn't want to go all the way to tagging phrases. This could also foreseeably be used for referencing schemes for vernacular text (apart from a Scripture referencing system). It also avoids the philosophical problem of having a property unique to Scripture on a very general-purpose object.

General Info
Name | ObjRefs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StTxtPara
End B | <unnamed> | 0..* | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StTxtPara
Association | ObjRefs
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | ObjRefs
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Education Report

Report: | General Info | Association Ends | Tagged Values

Association Education

General Info
Name | Education
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPerson
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | Education
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Education
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association PossList Report

Report: | General Info | Association Ends | Tagged Values

Association PossList

The list that a CmOverlay gets its PossItems from.

General Info
Name | PossList
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmOverlay
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmOverlay
Association | PossList
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | PossList
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | StPara


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmAgent


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmRow


Association Restrictions Report

Report: | General Info | Association Ends | Tagged Values

Association Restrictions

Indicates whether the data for this possibility item has restrictions for presentation to certain audiences. This value comes from a user-defined list that is used by many different FieldWorks objects (Events, Analysis Records, Lexical Entries and their Senses, etc.) These values are user-definable and initially include: No restrictions, Do not publish, Case by case, Unknown

General Info
Name | Restrictions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPossibility
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Restrictions
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Restrictions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association PlaceOfBirth Report

Report: | General Info | Association Ends | Tagged Values

Association PlaceOfBirth

General Info
Name | PlaceOfBirth
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmPerson
End B | <unnamed> | 1 | CmLocation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | PlaceOfBirth
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmLocation
Association | PlaceOfBirth
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmMajorObject
Child Element | RnResearchNbk


Data TypemultiBigString Report

Report: | General Info

Data types
Data Type multiBigString

General Info
Name | multiBigString
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | RnRoledPartic


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | Reminder


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | RnGenericRec


Data Typeguid Report

Report: | General Info

Data types
Data Type guid

General Info
Name | guid
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data Typebinary Report

Report: | General Info

Data types
Data Type binary

General Info
Name | binary
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data TypegenDate Report

Report: | General Info

Data types
Data Type genDate

General Info
Name | genDate
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data TypebigUnicode Report

Report: | General Info

Data types
Data Type bigUnicode

General Info
Name | bigUnicode
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data TypebigString Report

Report: | General Info

Data types
Data Type bigString

General Info
Name | bigString
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Association MorphologicalData Report

Report: | General Info | Association Ends | Tagged Values

Association MorphologicalData

General Info
Name | MorphologicalData
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | MoMorphData

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | MorphologicalData
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphData
Association | MorphologicalData
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Overlays Report

Report: | General Info | Association Ends | Tagged Values

Association Overlays

General Info
Name | Overlays
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | CmOverlay

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Overlays
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmOverlay
Association | Overlays
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association AffixCategories Report

Report: | General Info | Association Ends | Tagged Values

Association AffixCategories

In traditional interlinearizing programs, the user is encouraged to provide a part-of-speech or category for all morphemes in a word. Inflectional affixes such as PAST, PRESENT and FUTURE might be labelled as tense. Derivational affixes often take labels very similar to their glosses - CAUSATIVE might be labelled as causative or causative marker or simply verb affix. The AffixCategoryList is provided here to allow the user to label affixes in this way for "stealth" purposes only. Inflectional affixes should ultimately be captured in inflectional templates and slot names used for interlinearizing. Derivational affixes should be default have a MoAffixCategory of "derv" (derivational affix). Refer to MoInflectionalAffixMsa and MoDerivationalAffixMsa for more information.

General Info
Name | AffixCategories
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | AffixCategories
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | AffixCategories
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association People Report

Report: | General Info | Association Ends | Tagged Values

Association People

General Info
Name | People
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | People
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | People
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association MsFeatureSystem Report

Report: | General Info | Association Ends | Tagged Values

Association MsFeatureSystem

General Info
Name | MsFeatureSystem
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | FsFeatureSystem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | MsFeatureSystem
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatureSystem
Association | MsFeatureSystem
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Locations Report

Report: | General Info | Association Ends | Tagged Values

Association Locations

General Info
Name | Locations
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Locations
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | Locations
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Styles Report

Report: | General Info | Association Ends | Tagged Values

Association Styles

General Info
Name | Styles
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | StStyle

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Styles
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StStyle
Association | Styles
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Roles Report

Report: | General Info | Association Ends | Tagged Values

Association Roles

General Info
Name | Roles
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Roles
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | Roles
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Texts Report

Report: | General Info | Association Ends | Tagged Values

Association Texts

General Info
Name | Texts
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | Text

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Texts
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Text
Association | Texts
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Filters Report

Report: | General Info | Association Ends | Tagged Values

Association Filters

General Info
Name | Filters
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | CmFilter

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Filters
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFilter
Association | Filters
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association TimeOfDay Report

Report: | General Info | Association Ends | Tagged Values

Association TimeOfDay

General Info
Name | TimeOfDay
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | TimeOfDay
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | TimeOfDay
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AnalysisStatus Report

Report: | General Info | Association Ends | Tagged Values

Association AnalysisStatus

General Info
Name | AnalysisStatus
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | AnalysisStatus
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | AnalysisStatus
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Restrictions Report

Report: | General Info | Association Ends | Tagged Values

Association Restrictions

General Info
Name | Restrictions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Restrictions
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | Restrictions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AnalyzingAgents Report

Report: | General Info | Association Ends | Tagged Values

Association AnalyzingAgents

At this point, in time (Jan, 2002) CmAnalyzingAgents are used only by MoMorphological data. Refer to CmAnalyzingAgent for more info.

General Info
Name | AnalyzingAgents
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | CmAgent

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | AnalyzingAgents
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAgent
Association | AnalyzingAgents
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association AnthroList Report

Report: | General Info | Association Ends | Tagged Values

Association AnthroList

General Info
Name | AnthroList
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | AnthroList
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | AnthroList
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association PartsOfSpeech Report

Report: | General Info | Association Ends | Tagged Values

Association PartsOfSpeech

General Info
Name | PartsOfSpeech
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | PartsOfSpeech
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | PartsOfSpeech
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ResearchNotebook Report

Report: | General Info | Association Ends | Tagged Values

Association ResearchNotebook

General Info
Name | ResearchNotebook
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | RnResearchNbk

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | ResearchNotebook
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnResearchNbk
Association | ResearchNotebook
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association TranslationTags Report

Report: | General Info | Association Ends | Tagged Values

Association TranslationTags

General Info
Name | TranslationTags
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | TranslationTags
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | TranslationTags
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmProject
Child Element | LangProject


Association Positions Report

Report: | General Info | Association Ends | Tagged Values

Association Positions

General Info
Name | Positions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Positions
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | Positions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Thesaurus Report

Report: | General Info | Association Ends | Tagged Values

Association Thesaurus

General Info
Name | Thesaurus
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Thesaurus
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | Thesaurus
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association LexDb Report

Report: | General Info | Association Ends | Tagged Values

Association LexDb

General Info
Name | LexDb
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | LexDb

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | LexDb
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | LexDb
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Education Report

Report: | General Info | Association Ends | Tagged Values

Association Education

General Info
Name | Education
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Education
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | Education
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association WordformLookupLists Report

Report: | General Info | Association Ends | Tagged Values

Association WordformLookupLists

General Info
Name | WordformLookupLists
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | WordformLookupList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | WordformLookupLists
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WordformLookupList
Association | WordformLookupLists
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ConfidenceLevels Report

Report: | General Info | Association Ends | Tagged Values

Association ConfidenceLevels

General Info
Name | ConfidenceLevels
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | ConfidenceLevels
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | ConfidenceLevels
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association PhonologicalData Report

Report: | General Info | Association Ends | Tagged Values

Association PhonologicalData

General Info
Name | PhonologicalData
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | PhPhonData

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | PhonologicalData
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PhPhonData
Association | PhonologicalData
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association ExternalMaterials Report

Report: | General Info | Association Ends | Tagged Values

Association ExternalMaterials

A listing of any external sources, such as tape or video records, pictures in a scrapbook, etc.

General Info
Name | ExternalMaterials
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | ExternalMaterials
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | ExternalMaterials
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Confidence Report

Report: | General Info | Association Ends | Tagged Values

Association Confidence

An indication of how confident the researcher is about the data in this record. Example values high, medium, low, uncertain.

General Info
Name | Confidence
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Confidence
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Confidence
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association SubRecords Report

Report: | General Info | Association Ends | Tagged Values

Association SubRecords

A collection of lower-level records. This permits a hierarchical grouping of records (e.g., all of the records dealing with Emilio and Maria's Wedding.) By placing this attribute at the RnGenericRecord level, we are making the claim that any type of record can have subrecords. Thus, for example, a Formal Interview might include some Observations that happened during the interview; a Performance Record might include several formal interviews about the performance; a Cartographic Record might include Reports on Conversations that helped in creating the map.

General Info
Name | SubRecords
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | RnGenericRec

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | SubRecords
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | SubRecords
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association AnthroCodes Report

Report: | General Info | Association Ends | Tagged Values

Association AnthroCodes

OcmCodes - User applies OCM tags to this particular record.April 5, 2001 - The following documentation needs to be updated.This is where the user applies tagging at the scope of the entire record. Tags will be to such lists as the FRAME (the modified Outline of Cultural Materials), a grammar outline, and numerous other outlines that will be included with the system. After doing this tagging, the user will be able to quickly find all records that pertain to a particular topic. (In the user interface, we will provide mechanisms to facilitate fast tagging, including choosing which outline to tag from.)

General Info
Name | AnthroCodes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | CmAnthroItem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | AnthroCodes
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnthroItem
Association | AnthroCodes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association FurtherQuestions Report

Report: | General Info | Association Ends | Tagged Values

Association FurtherQuestions

Questions that have arisen as a result of trying to prove a hypothesis or when examining an event record. These may be used later in elicitation sessions or become the bases of new hypotheses.

General Info
Name | FurtherQuestions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | FurtherQuestions
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | FurtherQuestions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Participants Report

Report: | General Info | Association Ends | Tagged Values

Association Participants

A list of people (or one person) involved in the event in the role specified below.

General Info
Name | Participants
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnRoledPartic
End B | <unnamed> | 0..* | CmPerson

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnRoledPartic
Association | Participants
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | Participants
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association RecTypes Report

Report: | General Info | Association Ends | Tagged Values

Association RecTypes

A list of event types that the user can modify. Types included by default are: Performance, Almanac, Conversation, Observation, LiteratureSummary.

General Info
Name | RecTypes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnResearchNbk
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnResearchNbk
Association | RecTypes
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | RecTypes
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association PhraseTags Report

Report: | General Info | Association Ends | Tagged Values

Association PhraseTags

The Tags attribute is used for explicit tagging by the end-user, where he indicates that a given tag applies to the entire record. The PhraseTags attribute by contrast is a behind-the-scenes tag. When the user tags a word or phrase within a description, the editing mechanism will add that tag to this attribute. The purpose is to provide a means for fast searching. The user can do a quick back-reference search to arrive at the appropriate records, and then do a text search to find the actual tagged phrase. In this manner we avoid having to do a sequential search through every record in the notebook.

General Info
Name | PhraseTags
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | PhraseTags
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | PhraseTags
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association SeeAlso Report

Report: | General Info | Association Ends | Tagged Values

Association SeeAlso

See Also cross-references for Events or Analyses

General Info
Name | SeeAlso
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | RnGenericRec

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | SeeAlso
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | SeeAlso
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association VersionHistory Report

Report: | General Info | Association Ends | Tagged Values

Association VersionHistory

A collection of versions that the record has gone through. This includes an archival of previous versions of the actual records.

General Info
Name | VersionHistory
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | VersionHistory
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | VersionHistory
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association CrossReferences Report

Report: | General Info | Association Ends | Tagged Values

Association CrossReferences

CrossReference objects that capture crossReferences between two RnGenericRecords are owned here by the ResearchNotebook.

General Info
Name | CrossReferences
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnResearchNbk
End B | <unnamed> | 0..* | CrossReference

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnResearchNbk
Association | CrossReferences
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CrossReference
Association | CrossReferences
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Records Report

Report: | General Info | Association Ends | Tagged Values

Association Records

A collection containing all of the top-level records in the notebook. (Keep in mind that records can contain records, so that this attribute only contains the top-level records.) This is the main content attribute of the notebook.

General Info
Name | Records
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnResearchNbk
End B | <unnamed> | 0..* | RnGenericRec

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnResearchNbk
Association | Records
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Records
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Researchers Report

Report: | General Info | Association Ends | Tagged Values

Association Researchers

Tthe persons who obtained, entered, or analyzed the data. If more than one person was involved, then all researchers can be cited here.

General Info
Name | Researchers
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | CmPerson

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Researchers
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPerson
Association | Researchers
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Restrictions Report

Report: | General Info | Association Ends | Tagged Values

Association Restrictions

Any restrictions that might exist for this data.

General Info
Name | Restrictions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Restrictions
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Restrictions
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Role Report

Report: | General Info | Association Ends | Tagged Values

Association Role

The role of the above participant(s). The role may be set to "unspecified."

General Info
Name | Role
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnRoledPartic
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnRoledPartic
Association | Role
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Role
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Reminders Report

Report: | General Info | Association Ends | Tagged Values

Association Reminders

At a global level, the user can use this attribute to view all of the reminders that have been made within the individual records. (The view will presumably permit ordering (and/or sorting) and filtering of these reminders, in support of creating printouts that can help guide further work or elicitation.)

General Info
Name | Reminders
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnResearchNbk
End B | <unnamed> | 0..* | Reminder

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnResearchNbk
Association | Reminders
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Reminder
Association | Reminders
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Reminders Report

Report: | General Info | Association Ends | Tagged Values

Association Reminders

A place where the user can record reminders for further research, such as further editing to do to the record, or additional types of data to seek, or whatever comes to mind.

General Info
Name | Reminders
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | Reminder

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | Reminders
Visibility | public
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Reminder
Association | Reminders
Visibility | public
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association CrossReferences Report

Report: | General Info | Association Ends | Tagged Values

Association CrossReferences

A RnGenericRecord can refer to one or more CrossReference objects. For version 1 of Research Notebook, CrossReference objects will have two backreferences representing a bi-directional cross-reference.

General Info
Name | CrossReferences
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | RnGenericRec
End B | <unnamed> | 0..* | CrossReference

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Name: num |  |

Association End <unnamed>

General Info
Name | <unnamed>
Element | RnGenericRec
Association | CrossReferences
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CrossReference
Association | CrossReferences
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Data Typevoid Report

Report: | General Info

Data types
Data Type void

General Info
Name | void
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data TypemultiBigUnicode Report

Report: | General Info

Data types
Data Type multiBigUnicode

General Info
Name | multiBigUnicode
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data Typenumeric Report

Report: | General Info

Data types
Data Type numeric

General Info
Name | numeric
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Data Typefloat Report

Report: | General Info

Data types
Data Type float

General Info
Name | float
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Tag Definition num Report

Report: | General Info | Typed Values

UML Standard Profile
Tag Definition num

24

General Info
Name | num
Multiplicity | 1
Type | String
Base Classes | Association

Typed Values
Value | Owner
9 | GlossItems
10 | Target
3 | GlossBundle
7 | GlossSystem
1 | Glosses
8 | FeatStructFrag
3 | Members
2 | FirstMorpheme
3 | RestOfMorphs
10 | Meanings
11 | MorphBundles
2 | Morph
3 | Msa
4 | Sense
8 | Contents
12 | CompoundRuleApps
2 | FirstAllomorph
3 | RestOfAllos
13 | Etymology
15 | Status
26 | Status
27 | SemanticDomains
13 | InflTemplateApps
1 | Occurrences
5 | Rendering
1 | PartOfSpeech
17 | ReversalIndexes
5 | PartOfSpeech
19 | References
7 | Slots
29 | LexemeForm
30 | AlternateForms
2 | OverridingMsa
31 | Pronunciations
4 | MediaFiles
7 | FromPartsOfSpeech
2 | Sense
21 | Resources
1 | ConstChartTempl
2 | Charts
3 | ChartMarkers
1 | SurfaceForm
2 | Meaning
3 | Renderings
34 | EntryRefs
1 | VariantEntryTypes
2 | ComplexEntryTypes
5 | FeatConstraints
7 | PhonRules
4 | InitialStratum
5 | FinalStratum
1 | LeftContext
2 | RightContext
3 | StrucChange
4 | InputPOSes
5 | ExclRuleFeats
6 | ReqRuleFeats
1 | RightHandSides
6 | StrucDesc
2 | Rows
1 | DependentClauses
1 | WordGroup
7 | Cells
14, | Evaluations
10 | Footnotes
9 | ArchivedDrafts
2 | Books
11 | Diffs
6 | RevParagraph
5 | Publications
7 | ImportSettings
33 | Resources
1 | AppliesTo
6 | EndObject
7 | OtherObjects
5 | BeginObject
6 | InstanceOf
4 | Source
3 | AnnotationType
7 | Text
1 | UserConfigAcct
8 | Features
6 | HeaderFooterSets
8 | Translations
4 | PageLayout
8 | Divisions
5 | HFSet
3 | DefaultHeader
4 | DefaultFooter
5 | FirstHeader
8 | EvenFooter
6 | FirstFooter
7 | EvenHeader
6 | Files
5 | Questions
50 | CheckLists
19 | MainEntriesOrSenses
4 | Features
3 | Features
2 | Targets
9 | ProdRestrict
11 | NoteType
2 | NoteType
2 | Categories
2 | MediaFile
3 | Location
2 | PictureFile
52 | GenreList
9 | Genres
1 | Template
1 | BasedOn
4 | ComponentLexemes
22 | VariantEntryTypes
23 | ComplexEntryTypes
3 | PrimaryLexemes
154 | PhFeatureSystem
6 | PhonRuleFeats
2 | Features
55 | TextMarkupTags
24 | Locations
1 | Paragraphs
5 | Tag
1 | Tag
1 | BeginSegment
2 | EndSegment
1 | Column
6 | Segments
1 | BeginSegment
7 | Approves
8 | Disproves
8 | Possibilities
44 | Annotations
45 | UserAccounts
46 | ActivatedFeatures
40 | TranslatedScripture
48 | Pictures
49 | SemanticDomainList
47 | AnnotationDefs
51 | Media
53 | DiscourseData
3 | OcmRefs
4 | RelatedDomains
3 | Members
3 | CreatedBy
4 | ModifiedBy
1 | Books
3 | ChkHistRecs
1 | Item
2 | EndSegment
3 | Tags
4 | Notes
5 | Analyses


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmAgentEvaluation


Tag Definition num Report

Report: | General Info | Typed Values

UML Standard Profile
Tag Definition num

139

General Info
Name | num
Multiplicity | 1
Type | String
Default Value | value
Base Classes | Class

Typed Values
Value | Owner
109 | MoGlossItem
108 | MoGlossSystem
110 | MoAdhocProhibGr
112 | WfiMorphBundle
113 | LexEtymology
125 | ChkTerm
116 | ChkRef
117 | MoUnclassifiedAffixMsa
118 | LexEntryType
120 | LexReference
119 | LexRefType
121 | ChkSense
122 | DsChart
123 | DsConstChart
124 | DsDiscourseData
126 | ChkRendering
127 | LexEntryRef
132 | PhPhonRuleFeat
128 | PhSegmentRule
131 | PhSegRuleRHS
130 | PhMetathesisRule
129 | PhRegularRule
9 | ConstChartClauseMarker
8 | ConstChartMovedTextMarker
3 | ConstChartRow
10 | ConstChartTag
7 | ConstChartWordGroup
6 | ConstituentChartCellPart
10 | ScrDraft
11 | ScrDifference
14 | ScrImportP6Project
1 | ParatextID
8 | ScrImportSet
1 | ImportType
2 | ImportSettings
3 | ImportProjToken
5 | Name
6 | Description
15 | ScrImportSFFiles
1 | FileFormat
13 | ScrImportSource
1 | ICULocale
16 | ScrMarkerMapping
1 | BeginMarker
2 | EndMarker
3 | Excluded
4 | Target
5 | Domain
6 | ICULocale
18 | ScrScriptureNote
1 | ResolutionStatus
17 | ScrBookAnnotations
19 | ScrCheckRun
20 | ScrFootnote
21 | ScrTxtPara
32 | CmAgentEvaluation
35 | CmAnnotationDefn
34 | CmAnnotation
37 | CmBaseAnnotation
36 | CmIndirectAnnotation
38 | CmMediaAnnotation
39 | StFootnote
40 | UserConfigAcct
41 | UserAppFeatAct
42 | Publication
43 | PubDivision
44 | PubPageLayout
45 | PubHFSet
46 | PubHeader
47 | CmFile
48 | CmPicture
66 | CmSemanticDomain
67 | CmDomainQ
68 | StJournalText
69 | CmMedia
70 | CmResource
3 | Note
11 | PunctuationForm
6 | Segment
22 | TextTag
11 | NoteMappings
10 | ScriptureMappings
8 | BackTransSources
9 | NoteSources
7 | ScriptureSources
10 | Style
2 | Files
5 | Recommendation
6 | Resolution
4 | Discussion
7 | Responses
3 | Quote
25 | NoteCategories
24 | BookAnnotations
2 | Notes


Tag Definition abbrev Report

Report: | General Info | Typed Values

UML Standard Profile
Tag Definition abbrev

General Info
Name | abbrev
Multiplicity | 1
Type | String
Base Classes | Class

Typed Values
Value | Owner
glit | MoGlossItem
glsys | MoGlossSystem
acpg | MoAdhocProhibGr
wmrb | WfiMorphBundle
ety | LexEtymology
chkt | ChkTerm
chkr | ChkRef
uamsa | MoUnclassifiedAffixMsa
let | LexEntryType
lref | LexReference
lrt | LexRefType
chks | ChkSense
dsc | DsChart
dscc | DsConstChart
dsdd | DsDiscourseData
chkg | ChkRendering
ler | LexEntryRef
pprf | PhPhonRuleFeat
segrule | PhSegmentRule
segrhs | PhSegRuleRHS
phmetar | PhMetathesisRule
phregrule | PhRegularRule
cccm | ConstChartClauseMarker
ccmtm | ConstChartMovedTextMarker
ccr | ConstChartRow
cct | ConstChartTag
ccwg | ConstChartWordGroup
cccp | ConstituentChartCellPart
sdrf | ScrDraft
sdif | ScrDifference
sipp | ScrImportP6Project
scis | ScrImportSet
sisf | ScrImportSFFiles
ssrc | ScrImportSource
scmm | ScrMarkerMapping
scsn | ScrScriptureNote
scba | ScrBookAnnotations
sccr | ScrCheckRun
scrF | ScrFootnote
ScTP | ScrTxtPara
caev | CmAgentEvaluation
annd | CmAnnotationDefn
anno | CmAnnotation
bann | CmBaseAnnotation
iann | CmIndirectAnnotation
mann | CmMediaAnnotation
stfn | StFootnote
ucac | UserConfigAcct
uafa | UserAppFeatAct
cmpb | Publication
cmpd | PubDivision
cmpl | PubPageLayout
cmps | PubHFSet
cmph | PubHeader
cmfl | CmFile
pic | CmPicture
dom | CmSemanticDomain
doq | CmDomainQ
stjt | StJournalText
med | CmMedia
rsrc | CmResource
nt | Note
pf | PunctuationForm
seg | Segment
tt | TextTag


Association GlossItems Report

Report: | General Info | Association Ends | Tagged Values

Association GlossItems

General Info
Name | GlossItems
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoGlossItem
End B | <unnamed> | 0..* | MoGlossItem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 9 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoGlossItem
Association | GlossItems
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoGlossItem
Association | GlossItems
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Target Report

Report: | General Info | Association Ends | Tagged Values

Association Target

Note also that this attribute has two different functions. 1. If a gloss item is a cross-reference, it needs a target attribute to point to a the preferred term in the master gloss list. A cross-reference item lists a term that the user would be looking for, but redirects the user to a standardized term elsewhere in the tree. 2. An additional status is added to indicate that a gloss item that has been copied into a subtree under a complex feature is a proxy for the original gloss item in the master gloss list. A proxy item uses the target attribute to point to its source item. No other attributes on a proxy item should be used since the values on the target item are its values. (The implementation might use term to store the "carried-down" suffix to the gloss string when carry is active.) visible The item is an original item that should be shown in the gloss chooser. hidden The item is an original item, but should not be shown in the gloss chooser. proxy The item should be shown in the gloss chooser, but it is a proxy standing in for an original item.

General Info
Name | Target
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoGlossItem
End B | <unnamed> | 1 | MoGlossItem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 10 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoGlossItem
Association | Target
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoGlossItem
Association | Target
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association GlossBundle Report

Report: | General Info | Association Ends | Tagged Values

Association GlossBundle

The functional gloss for this MSA is the ordered bundle of MoGlossItems that it points to. These are ordered as necessary to create the desired gloss string. When the user selects gloss items from the language-specific gloss system to form a composite gloss, this analysis is stored in the MSA as a gloss bundle (which an attribute on MSA that stores a set of references to all the selected gloss items). The language-specific feature structure for an MSA is automatically generated by computing the unification of all the feature structure fragments in the gloss bundle.

General Info
Name | GlossBundle
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphSynAnalysis
End B | <unnamed> | 0..* | MoGlossItem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphSynAnalysis
Association | GlossBundle
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoGlossItem
Association | GlossBundle
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association GlossSystem Report

Report: | General Info | Association Ends | Tagged Values

Association GlossSystem

General Info
Name | GlossSystem
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphData
End B | <unnamed> | 1 | MoGlossSystem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphData
Association | GlossSystem
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoGlossSystem
Association | GlossSystem
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Glosses Report

Report: | General Info | Association Ends | Tagged Values

Association Glosses

General Info
Name | Glosses
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoGlossSystem
End B | <unnamed> | 0..* | MoGlossItem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoGlossSystem
Association | Glosses
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoGlossItem
Association | Glosses
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association FeatStructFrag Report

Report: | General Info | Association Ends | Tagged Values

Association FeatStructFrag

A gloss item in the language-specific gloss system is formalized by a feature structure fragment. The feature structure for a glossed morpheme is thus the unification of all the feature structure fragments for its component gloss items. When the user selects gloss items from the language-specific gloss system to form a composite gloss, this analysis is stored in the MSA as a gloss bundle (which an attribute on MSA that stores a set of references to all the selected gloss items). The language-specific feature structure for an MSA is automatically generated by computing the unification of all the feature structure fragments in the gloss bundle. Changed from FeatureStructureFragment.

General Info
Name | FeatStructFrag
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoGlossItem
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 8 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoGlossItem
Association | FeatStructFrag
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | FeatStructFrag
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoGlossItem


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | MoGlossSystem


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | MoAdhocProhib
Child Element | MoAdhocProhibGr


Association Members Report

Report: | General Info | Association Ends | Tagged Values

Association Members

General Info
Name | Members
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAdhocProhibGr
End B | <unnamed> | 0..* | MoAdhocProhib

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAdhocProhibGr
Association | Members
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAdhocProhib
Association | Members
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Data TypetextPropBinary Report

Report: | General Info

Data types
Data Type textPropBinary

textPropertiesBinary - This is distinguished from binary so that FDO can make a distinction between the binary data that occurs as the properties of StText and regular binary. If they are both defined as binary, there is no way to distinguish the two in the SQLServer database. For more information contact Eberhard Beilharz.

General Info
Name | textPropBinary
Visibility | public
Abstract | false
Leaf | false
Root | false
Owner | Data types


Class Diagram

Report: | General Info

Class Diagram Annotations

CmIndirectAnnotation CmBaseAnnotation CmAnnotation CmAnnotationDefn AppliesTo AppliesTo <unnamed> <unnamed> <unnamed> <unnamed> InstanceOf InstanceOf Source Source AnnotationType AnnotationType BeginObject BeginObject EndObject EndObject OtherObjects OtherObjects CmObject CmObject CmAgent FsFeatStruc CmMediaAnnotation <unnamed> <unnamed> LangProject Annotations Annotations StText Text Text CmPossibility CmPossibilityList <unnamed> <unnamed> Features Features ScrScriptureNote StJournalText CmPossibility Resolution Resolution Recommendation Recommendation Quote Quote Responses Responses Discussion Discussion <unnamed> <unnamed> CreatedBy CreatedBy ModifiedBy ModifiedBy CmPerson <unnamed> <unnamed> StText <unnamed> <unnamed> Categories Categories TextMarkupTags TextMarkupTags

General Info
Name | Annotations
Type | Class Diagram


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmAnnotation
Child Element | CmIndirectAnnotation


Association AppliesTo Report

Report: | General Info | Association Ends | Tagged Values

Association AppliesTo

General Info
Name | AppliesTo
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmIndirectAnnotation
End B | <unnamed> | 1..* | CmAnnotation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmIndirectAnnotation
Association | AppliesTo
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotation
Association | AppliesTo
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association EndObject Report

Report: | General Info | Association Ends | Tagged Values

Association EndObject

General Info
Name | EndObject
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmBaseAnnotation
End B | <unnamed> | 1 | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmBaseAnnotation
Association | EndObject
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | EndObject
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmAnnotation
Child Element | CmBaseAnnotation


Association OtherObjects Report

Report: | General Info | Association Ends | Tagged Values

Association OtherObjects

General Info
Name | OtherObjects
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmBaseAnnotation
End B | <unnamed> | 0..* | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmBaseAnnotation
Association | OtherObjects
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | OtherObjects
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association BeginObject Report

Report: | General Info | Association Ends | Tagged Values

Association BeginObject

General Info
Name | BeginObject
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmBaseAnnotation
End B | <unnamed> | 1 | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmBaseAnnotation
Association | BeginObject
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | BeginObject
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AnnotationType Report

Report: | General Info | Association Ends | Tagged Values

Association AnnotationType

An annotation is of a particular type. The AnnotationDefn defines possible behaviors for an annotation.

General Info
Name | AnnotationType
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmAnnotation
End B | <unnamed> | 1 | CmAnnotationDefn

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotation
Association | AnnotationType
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotationDefn
Association | AnnotationType
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association InstanceOf Report

Report: | General Info | Association Ends | Tagged Values

Association InstanceOf

Annotations, in many cases, are tags from a predefined list of objects. We might want to mark up a text for OCM codes. A particular annotation in context may tag an instance of OCM code 152. WordformsInContext are tagged with Wordforms found in the WordformInventory.

General Info
Name | InstanceOf
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmAnnotation
End B | <unnamed> | 1 | CmObject

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotation
Association | InstanceOf
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmObject
Association | InstanceOf
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Tag Definition num2 Report

Report: | General Info

UML Standard Profile
Tag Definition num2

General Info
Name | num2
Multiplicity | 1
Type | String
Base Classes | Association


Tag Definition abbrev1 Report

Report: | General Info

UML Standard Profile
Tag Definition abbrev1

General Info
Name | abbrev1
Multiplicity | 1
Type | String
Base Classes | Class


Association Source Report

Report: | General Info | Association Ends | Tagged Values

Association Source

Who made this annotation. If a computer parser, the agent will be that parser.

General Info
Name | Source
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmAnnotation
End B | <unnamed> | 1 | CmAgent

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotation
Association | Source
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAgent
Association | Source
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Tag Definition num1 Report

Report: | General Info

UML Standard Profile
Tag Definition num1

General Info
Name | num1
Multiplicity | 1
Type | String
Base Classes | Class


Tag Definition num3 Report

Report: | General Info

UML Standard Profile
Tag Definition num3

General Info
Name | num3
Multiplicity | 1
Type | String
Base Classes | Attribute


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmAnnotation
Child Element | CmMediaAnnotation


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmAnnotation


Association Annotations Report

Report: | General Info | Association Ends | Tagged Values

Association Annotations

General Info
Name | Annotations
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | CmAnnotation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 44 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Annotations
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotation
Association | Annotations
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Text Report

Report: | General Info | Association Ends | Tagged Values

Association Text

To handle multiparagraph annotations.

General Info
Name | Text
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmAnnotation
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotation
Association | Text
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Text
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | StText
Child Element | StFootnote


Association Footnotes Report

Report: | General Info | Association Ends | Tagged Values

Association Footnotes

General Info
Name | Footnotes
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrBook
End B | <unnamed> | 0..* | StFootnote

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 10 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBook
Association | Footnotes
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StFootnote
Association | Footnotes
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Class Diagram

Report: | General Info

Class Diagram Interlinear Texts

LangProject Text Texts Texts StPara StText Paragraphs Paragraphs Contents Contents CmMajorObject <unnamed> <unnamed> StTxtPara <unnamed> <unnamed> CmAnnotation Annotations Annotations WfiGloss WfiAnalysis Meanings Meanings WfiWordform CmBaseAnnotation <unnamed> <unnamed> OtherObjects OtherObjects BeginObject BeginObject CmObject EndObject EndObject CmObject InstanceOf InstanceOf <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> <unnamed> CmPossibility Genres Genres

General Info
Name | Interlinear Texts
Type | Class Diagram


Association FirstMorpheme Report

Report: | General Info | Association Ends | Tagged Values

Association FirstMorpheme

General Info
Name | FirstMorpheme
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphAdhocProhib
End B | <unnamed> | 1 | MoMorphSynAnalysis

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphAdhocProhib
Association | FirstMorpheme
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphSynAnalysis
Association | FirstMorpheme
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association RestOfMorphs Report

Report: | General Info | Association Ends | Tagged Values

Association RestOfMorphs

Changed from RestOfMorphemes.

General Info
Name | RestOfMorphs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoMorphAdhocProhib
End B | <unnamed> | 0..* | MoMorphSynAnalysis

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphAdhocProhib
Association | RestOfMorphs
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphSynAnalysis
Association | RestOfMorphs
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association ArchivedDrafts Report

Report: | General Info | Association Ends | Tagged Values

Association ArchivedDrafts

General Info
Name | ArchivedDrafts
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Scripture
End B | <unnamed> | 0..* | ScrDraft

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 9 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Scripture
Association | ArchivedDrafts
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrDraft
Association | ArchivedDrafts
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ScrDraft


Association Books Report

Report: | General Info | Association Ends | Tagged Values

Association Books

General Info
Name | Books
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrDraft
End B | <unnamed> | 0..* | ScrBook

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrDraft
Association | Books
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBook
Association | Books
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Diffs Report

Report: | General Info | Association Ends | Tagged Values

Association Diffs

General Info
Name | Diffs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrBook
End B | <unnamed> | 0..* | ScrDifference

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 11 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrBook
Association | Diffs
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrDifference
Association | Diffs
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association RevParagraph Report

Report: | General Info | Association Ends | Tagged Values

Association RevParagraph

the paragraph in the revision that the difference is in.

General Info
Name | RevParagraph
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | ScrDifference
End B | <unnamed> | 1 | StPara

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | ScrDifference
Association | RevParagraph
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StPara
Association | RevParagraph
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | ScrDifference


Association Meanings Report

Report: | General Info | Association Ends | Tagged Values

Association Meanings

General Info
Name | Meanings
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiAnalysis
End B | <unnamed> | 0..* | WfiGloss

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 10 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | Meanings
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiGloss
Association | Meanings
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association MorphBundles Report

Report: | General Info | Association Ends | Tagged Values

Association MorphBundles

General Info
Name | MorphBundles
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiAnalysis
End B | <unnamed> | 0..* | WfiMorphBundle

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 11 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | MorphBundles
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiMorphBundle
Association | MorphBundles
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Morph Report

Report: | General Info | Association Ends | Tagged Values

Association Morph

General Info
Name | Morph
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiMorphBundle
End B | <unnamed> | 1 | MoForm

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiMorphBundle
Association | Morph
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoForm
Association | Morph
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Msa Report

Report: | General Info | Association Ends | Tagged Values

Association Msa

General Info
Name | Msa
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiMorphBundle
End B | <unnamed> | 1 | MoMorphSynAnalysis

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiMorphBundle
Association | Msa
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoMorphSynAnalysis
Association | Msa
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Sense Report

Report: | General Info | Association Ends | Tagged Values

Association Sense

General Info
Name | Sense
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiMorphBundle
End B | <unnamed> | 1 | LexSense

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiMorphBundle
Association | Sense
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | Sense
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | WfiMorphBundle


Class Diagram

Report: | General Info

Class Diagram User Configuations

UserConfigAcct LangProject UserAppFeatAct CmObject UserAccounts UserAccounts ActivatedFeatures ActivatedFeatures UserConfigAcct UserConfigAcct <unnamed> <unnamed>

General Info
Name | User Configuations
Type | Class Diagram


Association UserAccounts Report

Report: | General Info | Association Ends | Tagged Values

Association UserAccounts

General Info
Name | UserAccounts
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | UserConfigAcct

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 45 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | UserAccounts
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserConfigAcct
Association | UserAccounts
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association ActivatedFeatures Report

Report: | General Info | Association Ends | Tagged Values

Association ActivatedFeatures

General Info
Name | ActivatedFeatures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | UserAppFeatAct

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 46 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | ActivatedFeatures
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserAppFeatAct
Association | ActivatedFeatures
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association UserConfigAcct Report

Report: | General Info | Association Ends | Tagged Values

Association UserConfigAcct

General Info
Name | UserConfigAcct
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | UserAppFeatAct
End B | <unnamed> | 0..* | UserConfigAcct

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 1 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserAppFeatAct
Association | UserConfigAcct
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | UserConfigAcct
Association | UserConfigAcct
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | CmAnnotationDefn


Association Contents Report

Report: | General Info | Association Ends | Tagged Values

Association Contents

General Info
Name | Contents
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Text
End B | <unnamed> | 1 | StText

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 8 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Text
Association | Contents
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | StText
Association | Contents
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association CompoundRuleApps Report

Report: | General Info | Association Ends | Tagged Values

Association CompoundRuleApps

Allows Morph Sketch Generator to extract example wordforms where a compound rule applied.

General Info
Name | CompoundRuleApps
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | WfiAnalysis
End B | <unnamed> | 0..* | MoCompoundRule

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 12 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | WfiAnalysis
Association | CompoundRuleApps
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoCompoundRule
Association | CompoundRuleApps
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association Features Report

Report: | General Info | Association Ends | Tagged Values

Association Features

General Info
Name | Features
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmAnnotation
End B | <unnamed> | 1 | FsFeatStruc

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 8 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnnotation
Association | Features
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | FsFeatStruc
Association | Features
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association HeaderFooterSets Report

Report: | General Info | Association Ends | Tagged Values

Association HeaderFooterSets

Used to define preset header/footer layouts that can be selected and copied to a publication division. Reason: needed to implement TE-1468

General Info
Name | HeaderFooterSets
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmMajorObject
End B | <unnamed> | 0..* | PubHFSet

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmMajorObject
Association | HeaderFooterSets
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHFSet
Association | HeaderFooterSets
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Translations Report

Report: | General Info | Association Ends | Tagged Values

Association Translations

Refer to the documentation on LpTranslation.

General Info
Name | Translations
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | StTxtPara
End B | <unnamed> | 0..* | CmTranslation

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 8 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | StTxtPara
Association | Translations
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmTranslation
Association | Translations
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Stereotype create Report

Report: | General Info

UML Standard Profile
Stereotype create

Specifies that the designated feature creates an instance of the BehavioralFeature classifier to which the feature is attached. May be promoted to the Classifier containing the feature.

General Info
Name | create
Base Classes | BehavioralFeature
Abstract | false
Leaf | false
Root | false


Class Diagram

Report: | General Info

Class Diagram Publications

Publication PubDivision PubPageLayout PageLayout PageLayout Divisions Divisions Scripture Publications Publications CmMajorObject <unnamed> <unnamed> LangProject TranslatedScripture TranslatedScripture PubHFSet PubHeader HFSet HFSet DefaultHeader DefaultHeader DefaultFooter DefaultFooter FirstHeader FirstHeader EvenFooter EvenFooter FirstFooter FirstFooter EvenHeader EvenHeader HeaderFooterSets HeaderFooterSets

General Info
Name | Publications
Type | Class Diagram


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PubDivision


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PubPageLayout


Association PageLayout Report

Report: | General Info | Association Ends | Tagged Values

Association PageLayout

The page layout parameters for this division specifying page size, margins, header and footer positions, etc.

General Info
Name | PageLayout
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PubDivision
End B | <unnamed> | 1 | PubPageLayout

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubDivision
Association | PageLayout
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubPageLayout
Association | PageLayout
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Divisions Report

Report: | General Info | Association Ends | Tagged Values

Association Divisions

The content divisions (i.e. sections) that determine overall content of the publication.

General Info
Name | Divisions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | Publication
End B | <unnamed> | 0..* | PubDivision

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 8 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | Publication
Association | Divisions
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubDivision
Association | Divisions
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | Publication


Association TranslatedScripture Report

Report: | General Info | Association Ends | Tagged Values

Association TranslatedScripture

General Info
Name | TranslatedScripture
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | Scripture

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 40 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | TranslatedScripture
Visibility | public
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Scripture
Association | TranslatedScripture
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Class Diagram

Report: | General Info

Class Diagram Structured Text

WfiWordform CmObject StText StPara CmTranslation StTxtPara StFootnote CmPossibility <unnamed> <unnamed> <unnamed> <unnamed> Type Type <unnamed> <unnamed> Paragraphs Paragraphs ObjRefs ObjRefs AnalyzedTextObjects AnalyzedTextObjects TextObjects TextObjects StStyle <unnamed> <unnamed> BasedOn BasedOn Next Next LangProject Styles Styles Translations Translations Scripture Styles Styles StJournalText CmPerson CmPossibility ModifiedBy ModifiedBy CreatedBy CreatedBy <unnamed> <unnamed> <unnamed> <unnamed>

General Info
Name | Structured Text
Type | Class Diagram


Association Publications Report

Report: | General Info | Association Ends | Tagged Values

Association Publications

A collection of all of the publication layouts available for output from the translated scripture database.

General Info
Name | Publications
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmMajorObject
End B | <unnamed> | 0..* | Publication

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmMajorObject
Association | Publications
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | Publication
Association | Publications
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association FirstAllomorph Report

Report: | General Info | Association Ends | Tagged Values

Association FirstAllomorph

General Info
Name | FirstAllomorph
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAlloAdhocProhib
End B | <unnamed> | 1 | MoForm

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 2 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAlloAdhocProhib
Association | FirstAllomorph
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoForm
Association | FirstAllomorph
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association RestOfAllos Report

Report: | General Info | Association Ends | Tagged Values

Association RestOfAllos

Changed from RestOfAllomorphs.

General Info
Name | RestOfAllos
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | MoAlloAdhocProhib
End B | <unnamed> | 0..* | MoForm

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoAlloAdhocProhib
Association | RestOfAllos
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | MoForm
Association | RestOfAllos
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PubHFSet


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | PubHeader


Association HFSet Report

Report: | General Info | Association Ends | Tagged Values

Association HFSet

Changed from HeaderFooterSettings.

General Info
Name | HFSet
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PubDivision
End B | <unnamed> | 1 | PubHFSet

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubDivision
Association | HFSet
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHFSet
Association | HFSet
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association DefaultHeader Report

Report: | General Info | Association Ends | Tagged Values

Association DefaultHeader

The contents of the default header for pages of a publication division (odd pages use the default header).

General Info
Name | DefaultHeader
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PubHFSet
End B | <unnamed> | 1 | PubHeader

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHFSet
Association | DefaultHeader
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHeader
Association | DefaultHeader
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association DefaultFooter Report

Report: | General Info | Association Ends | Tagged Values

Association DefaultFooter

The contents of the default footer for pages of a publication division (odd pages use the default footer).

General Info
Name | DefaultFooter
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PubHFSet
End B | <unnamed> | 1 | PubHeader

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHFSet
Association | DefaultFooter
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHeader
Association | DefaultFooter
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association FirstHeader Report

Report: | General Info | Association Ends | Tagged Values

Association FirstHeader

The contents of the header for the first page of a publication division when different from the default.

General Info
Name | FirstHeader
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PubHFSet
End B | <unnamed> | 0..1 | PubHeader

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHFSet
Association | FirstHeader
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHeader
Association | FirstHeader
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..1
Changeability | changeable
Ordering | unordered
Scope | instance


Association EvenFooter Report

Report: | General Info | Association Ends | Tagged Values

Association EvenFooter

The contents of the footer for the even pages of a publication division when different from the default.

General Info
Name | EvenFooter
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PubHFSet
End B | <unnamed> | 0..1 | PubHeader

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 8 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHFSet
Association | EvenFooter
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHeader
Association | EvenFooter
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..1
Changeability | changeable
Ordering | unordered
Scope | instance


Association FirstFooter Report

Report: | General Info | Association Ends | Tagged Values

Association FirstFooter

The contents of the footer for the first page of a publication division when different from the default.

General Info
Name | FirstFooter
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PubHFSet
End B | <unnamed> | 0..1 | PubHeader

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHFSet
Association | FirstFooter
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHeader
Association | FirstFooter
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..1
Changeability | changeable
Ordering | unordered
Scope | instance


Association EvenHeader Report

Report: | General Info | Association Ends | Tagged Values

Association EvenHeader

The contents of the header for the even pages of a publication division when different from the default.

General Info
Name | EvenHeader
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | PubHFSet
End B | <unnamed> | 0..1 | PubHeader

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 7 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHFSet
Association | EvenHeader
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | PubHeader
Association | EvenHeader
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmFile


Association Files Report

Report: | General Info | Association Ends | Tagged Values

Association Files

General Info
Name | Files
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmFolder
End B | <unnamed> | 0..* | CmFile

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 6 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFolder
Association | Files
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFile
Association | Files
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association Pictures Report

Report: | General Info | Association Ends | Tagged Values

Association Pictures

General Info
Name | Pictures
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 0..* | CmFolder

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 48 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | Pictures
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmFolder
Association | Pictures
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmPicture


Association Etymology Report

Report: | General Info | Association Ends | Tagged Values

Association Etymology

Each entry can have one etymology specification.

General Info
Name | Etymology
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexEntry
End B | <unnamed> | 1 | LexEtymology

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 13 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEntry
Association | Etymology
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexEtymology
Association | Etymology
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Status Report

Report: | General Info | Association Ends | Tagged Values

Association Status

General Info
Name | Status
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexDb
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 15 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexDb
Association | Status
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | Status
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association Status Report

Report: | General Info | Association Ends | Tagged Values

Association Status

General Info
Name | Status
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 1 | CmPossibility

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 26 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | Status
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibility
Association | Status
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | LexEtymology


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmPossibility
Child Element | CmSemanticDomain


Association OcmRefs Report

Report: | General Info | Association Ends | Tagged Values

Association OcmRefs

For those that do have an OCM list, we will set links to the appropriate items. We anticipate our program establishing these links when the OCM list is added to the database.

General Info
Name | OcmRefs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmSemanticDomain
End B | <unnamed> | 0..* | CmAnthroItem

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 3 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmSemanticDomain
Association | OcmRefs
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmAnthroItem
Association | OcmRefs
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association RelatedDomains Report

Report: | General Info | Association Ends | Tagged Values

Association RelatedDomains

Example: (Ron Moe's Standard Format):\cf Weather; Cloud; Star We use this property to link related domains. Ideally this should be a bidirectional link, but so far we do not provide this capability in our conceptual model. So for now we'll live with unidirectional links.

General Info
Name | RelatedDomains
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmSemanticDomain
End B | <unnamed> | 0..* | CmSemanticDomain

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 4 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmSemanticDomain
Association | RelatedDomains
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmSemanticDomain
Association | RelatedDomains
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Dependency Report

Report: | General Info

Generalization <unnamed>

General Info
Name | <unnamed>
Parent Element | CmObject
Child Element | CmDomainQ


Association Questions Report

Report: | General Info | Association Ends | Tagged Values

Association Questions

Each domain has a list of questions used to elicit words. Each question has sample words and sentences, so we group these together into CmDomainQ. The domain then owns a sequence of these. They need to be ordered since important questions come first.

General Info
Name | Questions
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | CmSemanticDomain
End B | <unnamed> | 0..* | CmDomainQ

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 5 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmSemanticDomain
Association | Questions
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmDomainQ
Association | Questions
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | ordered
Scope | instance


Association SemanticDomains Report

Report: | General Info | Association Ends | Tagged Values

Association SemanticDomains

General Info
Name | SemanticDomains
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LexSense
End B | <unnamed> | 0..* | CmSemanticDomain

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 27 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LexSense
Association | SemanticDomains
Visibility | private
Aggregation Kind | none
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmSemanticDomain
Association | SemanticDomains
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 0..*
Changeability | changeable
Ordering | unordered
Scope | instance


Association SemanticDomainList Report

Report: | General Info | Association Ends | Tagged Values

Association SemanticDomainList

General Info
Name | SemanticDomainList
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 49 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | SemanticDomainList
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | SemanticDomainList
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Association AnnotationDefs Report

Report: | General Info | Association Ends | Tagged Values

Association AnnotationDefs

Changed from AnnotationDefinitions.

General Info
Name | AnnotationDefs
Abstract | false
Leaf | false
Root | false

Association Ends
 | Name | Multiplicity | Element
End A | <unnamed> |  | LangProject
End B | <unnamed> | 1 | CmPossibilityList

Tagged Values
Tag Definition/Tag Name | Value | Documentation
Tag Definition: num : String[1] | 47 |

Association End <unnamed>

General Info
Name | <unnamed>
Element | LangProject
Association | AnnotationDefs
Visibility | private
Aggregation Kind | composite
Navigable | true
Changeability | changeable
Ordering | unordered
Scope | instance

Association End <unnamed>

General Info
Name | <unnamed>
Element | CmPossibilityList
Association | AnnotationDefs
Visibility | private
Aggregation Kind | none
Navigable | true
Multiplicity | 1
Changeability | changeable
Ordering | unordered
Scope | instance


Stereotype balking Report

Report: | General Info

UML Standard Profile
Stereotype balking

message In the balking message case the sender abandons the message if the receiver is not ready.

General Info
Name | balking
Base Classes | Message
Abstract | false
Leaf | false
Root | false


Stereotype instantiate Report

Report: | General Info

UML Standard Profile
Stereotype instantiate

A stereotyped usage dependency among classifiers indicating that operations on the client create instances of the supplier.

General Info
Name | instantiate
Base Classes | Usage
Abstract | false
Leaf | false
Root | false


Stereotype stub Report

Report: | General Info

UML Standard Profile
Stereotype stub

A stub is a stereotyped package representing a package that is incompletely transferred; specifically, a stub provides the public parts of the package, but nothing more.

General Info
Name | stub
Base Classes | Package
Abstract | false
Leaf | false
Root | false


Stereotype become Report

Report: | General Info

UML Standard Profile
Stereotype become

Specifies a Flow relationship, source and target of which represent the same instance at different points in time, but each with potentially different values, state instance, and roles. A Become Dependency from A to B means that instance A becomes B with possibly new values, state instance, and roles at a different moment in time/space.

General Info
Name | become
Base Classes | Flow
Abstract | false
Leaf | false
Root | false


Stereotype topLevel Report

Report: | General Info

UML Standard Profile
Stereotype topLevel

TopLevel is a stereotype of package denoting the top-most package in a containment hierarchy. The topLevel stereotype defines the outer limit for looking up names, as namespaces see outwards. A topLevel subsystem represents the top of the subsystem containment hierarchy, i.e., it is the model element that represents the boundary of the entire physical system being modeled.

General Info
Name | topLevel
Base Classes | Package
Abstract | false
Leaf | false
Root | false


Stereotype association Report

Report: | General Info

UML Standard Profile
Stereotype association

Specifies a real association (default and redundant, but may be included AssociationEnd for emphasis).

General Info
Name | association
Base Classes | AssociationEnd
Abstract | false
Leaf | false
Root | false


Stereotype useCaseModel Report

Report: | General Info

UML Standard Profile
Stereotype useCaseModel

A use case model specifies the services a system provides to its users; that is, the different ways of using the system, and whose top-level package is a use case system.

General Info
Name | useCaseModel
Base Classes | Model
Abstract | false
Leaf | false
Root | false


Stereotype process Report

Report: | General Info

UML Standard Profile
Stereotype process

Specifies a classifier that represents a heavy-weight flow of control.

General Info
Name | process
Base Classes | Classifier
Abstract | false
Leaf | false
Root | false


Stereotype copy Report

Report: | General Info

UML Standard Profile
Stereotype copy

Specifies a Flow relationship, the source and target of which are different instances, but each with the same values, state instance, and roles (but a distinct identity). A Copy Dependency from A to B means that B is an exact copy of A. Future changes in A are not necessarily reflected in B.

General Info
Name | copy
Base Classes | Flow
Abstract | false
Leaf | false
Root | false


Stereotype precondition Report

Report: | General Info

UML Standard Profile
Stereotype precondition

Specifies a constraint that must be attached to an operation, and denotes that the conditions of the constraint must hold for the invocation of the operation.

General Info
Name | precondition
Base Classes | Constraint
Abstract | false
Leaf | false
Root | false


Stereotype powertype Report

Report: | General Info

UML Standard Profile
Stereotype powertype

Specifies that the classifier is a metaclass whose instances are siblings marked by the same discriminator. For example, the metaclass TreeSpecies might be a power type for the subclasses of Tree that represent different species, such as AppleTree, BananaTree, and CherryTree.

General Info
Name | powertype
Base Classes | Classifier
Abstract | false
Leaf | false
Root | false


Stereotype implementation Report

Report: | General Info

UML Standard Profile
Stereotype implementation

Specifies that the child inherits the implementation of the parent (its attributes, operations and methods) but does not make public the supplier s interfaces nor guarantee to support them, thereby violating substitutability. This is private inheritance and is usually used only for programming implementation purposes.

General Info
Name | implementation
Base Classes | Generalization
Abstract | false
Leaf | false
Root | false


Stereotype create Report

Report: | General Info

UML Standard Profile
Stereotype create

Create is a stereotyped call event denoting that the instance receiving that event has just been created. For state machines, it triggers the initial transition at the topmost level of the state machine (and is the only kind of trigger that may be applied to an initial transition).

General Info
Name | create
Base Classes | CallEvent
Abstract | false
Leaf | false
Root | false


Stereotype parameter Report

Report: | General Info

UML Standard Profile
Stereotype parameter

Specifies that the relationship represents a procedure parameter rather than AssociationEnd an actual association.

General Info
Name | parameter
Base Classes | AssociationEnd
Abstract | false
Leaf | false
Root | false


Stereotype local Report

Report: | General Info

UML Standard Profile
Stereotype local

Specifies that the relationship represents a local variable within a AssociationEnd procedure rather than an actual association.

General Info
Name | local
Base Classes | AssociationEnd
Abstract | false
Leaf | false
Root | false


Stereotype local Report

Report: | General Info

UML Standard Profile
Stereotype local

Local is a constraint applied to a link-end, specifying that the corresponding instance is visible because it is in a local scope relative to the link.

General Info
Name | local
Base Classes | LinkEnd
Abstract | false
Leaf | false
Root | false


Stereotype association Report

Report: | General Info

UML Standard Profile
Stereotype association

Association is a constraint applied to a link-end, specifying that the corresponding instance is visible via association.

General Info
Name | association
Base Classes | LinkEnd
Abstract | false
Leaf | false
Root | false


Stereotype import Report

Report: | General Info

UML Standard Profile
Stereotype import

Import is a stereotyped permission dependency between two namespaces, denoting that the public contents of the target package are added to the namespace of the source package.

General Info
Name | import
Base Classes | Permission
Abstract | false
Leaf | false
Root | false


Stereotype framework Report

Report: | General Info

UML Standard Profile
Stereotype framework

A framework is a stereotyped package consisting mainly of patterns, where patterns are defined as template collaborations.

General Info
Name | framework
Base Classes | Package
Abstract | false
Leaf | false
Root | false


Stereotype self Report

Report: | General Info

UML Standard Profile
Stereotype self

Specifies that the relationship represents a reference to the object that AssociationEnd owns an operation or action rather than an actual association.

General Info
Name | self
Base Classes | AssociationEnd
Abstract | false
Leaf | false
Root | false


Stereotype derive Report

Report: | General Info

UML Standard Profile
Stereotype derive

(Name for the stereotyped class is Derivation.) Specifies a derivation relationship among model elements that are usually, but not necessarily, of the same type. A derived dependency specifies that the client may be computed from the supplier. The mapping specifies the computation. The client may be implemented for design reasons, such as efficiency, even though it is logically redundant.

General Info
Name | derive
Base Classes | Abstraction
Abstract | false
Leaf | false
Root | false


Stereotype metamodel Report

Report: | General Info

UML Standard Profile
Stereotype metamodel

A metamodel is a stereotyped model denoting that the model is an abstraction of another model, i.e., it is a model of a model. Hence, if M2 is a model of the model M1, then M2 is a metamodel of M1. It follows then that classes in M1 are instances of metaclasses in M2. The stereotype can be recursively applied, as in the case of a 4-layer metamodel architecture.

General Info
Name | metamodel
Base Classes | Model
Abstract | false
Leaf | false
Root | false


Stereotype boundary Report

Report: | General Info

UML Standard Profile
Stereotype boundary

A boundary is a class that lies on the periphery of a system, but within it. It interacts with actors outside the system as well as with entity, control, and other boundary classes within the system.

General Info
Name | boundary
Base Classes | Class
Abstract | false
Leaf | false
Root | false


Stereotype access Report

Report: | General Info

UML Standard Profile
Stereotype access

Access is a stereotyped permission dependency between two namespaces, denoting that the public contents of the target namespace are accessible to the namespace of the source package.

General Info
Name | access
Base Classes | Permission
Abstract | false
Leaf | false
Root | false


Stereotype time-out Report

Report: | General Info

UML Standard Profile
Stereotype time-out

A time-out message the sender sends for a given period of time while waiting for acknowledgment by recipient. The sender is freed up if the acknowledgment does not occur within the duration specified in the description.

General Info
Name | time-out
Base Classes | Stimulus
Abstract | false
Leaf | false
Root | false


Stereotype type Report

Report: | General Info

UML Standard Profile
Stereotype type

Specifies a domain of objects together with the operations applicable to the objects, without defining the physical implementation of those objects. A type may not contain any methods, maintain its own thread of control, or be nested. However, it may have attributes and associations. The associations of a Type are defined solely for the purpose of specifying the behavior of the type's operations and do not represent the implementation of state data.

General Info
Name | type
Base Classes | Class
Abstract | false
Leaf | false
Root | false


Stereotype utility Report

Report: | General Info

UML Standard Profile
Stereotype utility

Specifies a classifier that has no instances, but rather denotes a named collection of non-member attributes and operations, all of which are class-scoped.

General Info
Name | utility
Base Classes | Classifier
Abstract | false
Leaf | false
Root | false


Stereotype requirement Report

Report: | General Info

UML Standard Profile
Stereotype requirement

Specifies a desired feature, property, or behavior of an element as part Comment of a system.

General Info
Name | requirement
Base Classes | Comment
Abstract | false
Leaf | false
Root | false


Stereotype realize Report

Report: | General Info

UML Standard Profile
Stereotype realize

(Name for the stereotyped class is Realization.) Specifies a realization relationship between a specification model element or elements (the supplier) and a model element or elements that implement it (the client). The implementation model element is required to support all of the operations or received signals that the specification model element declares. The implementation model element must make or inherit its own declarations of the operations and signal receptions. The mapping specifies the relationship between the two. The mapping may or may not be computable. Realization can be used to model stepwise refinement, optimizations, transformations, templates, model synthesis, framework composition, etc.

General Info
Name | realize
Base Classes | Abstraction
Abstract | false
Leaf | false
Root | false


Stereotype destroy Report

Report: | General Info

UML Standard Profile
Stereotype destroy

Destroy is a stereotyped call event denoting that the instance receiving the event is being destroyed.

General Info
Name | destroy
Base Classes | CallEvent
Abstract | false
Leaf | false
Root | false


Stereotype signalflow Report

Report: | General Info

UML Standard Profile
Stereotype signalflow

Signalflow is a stereotype of ObjectFlowState with a Signal as its type.

General Info
Name | signalflow
Base Classes | ObjectFlowState
Abstract | false
Leaf | false
Root | false


Stereotype create Report

Report: | General Info

UML Standard Profile
Stereotype create

Create is a stereotyped usage dependency denoting that the client classifier creates instances of the supplier classifier.

General Info
Name | create
Base Classes | Usage
Abstract | false
Leaf | false
Root | false


Stereotype implicit Report

Report: | General Info

UML Standard Profile
Stereotype implicit

The «implicit» stereotype is applied to an association, specifying that the association is not manifest, but rather is only conceptual.

General Info
Name | implicit
Base Classes | Association
Abstract | false
Leaf | false
Root | false


Stereotype postcondition Report

Report: | General Info

UML Standard Profile
Stereotype postcondition

Specifies a constraint that must be attached to an operation, and denotes that the conditions of the constraint must hold after the invocation of the operation.

General Info
Name | postcondition
Base Classes | Constraint
Abstract | false
Leaf | false
Root | false


Stereotype facade Report

Report: | General Info

UML Standard Profile
Stereotype facade

A facade is a stereotyped package containing only references to model elements owned by another package. It is used to provide a public view of some of the contents of a package. A facade does not contain any model elements of its own.

General Info
Name | facade
Base Classes | Package
Abstract | false
Leaf | false
Root | false


Stereotype trace Report

Report: | General Info

UML Standard Profile
Stereotype trace

(Name for the stereotyped class is Trace.) Specifies a trace relationship between model elements or sets of model elements that represent the same concept in different models. Traces are mainly used for tracking requirements and changes across models. Since model changes can occur in both directions, the directionality of the dependency can often be ignored. The mapping specifies the relationship between the two, but it is rarely computable and is usually informal.

General Info
Name | trace
Base Classes | Abstraction
Abstract | false
Leaf | false
Root | false


Stereotype balking Report

Report: | General Info

UML Standard Profile
Stereotype balking

message In the balking message case the sender abandons the message if the receiver is not ready.

General Info
Name | balking
Base Classes | Stimulus
Abstract | false
Leaf | false
Root | false


Stereotype systemModel Report

Report: | General Info

UML Standard Profile
Stereotype systemModel

A systemModel is a stereotyped model that contains a collection of models of the same physical system. A systemModel also contains all relationships and constraints between model elements contained in different models.

General Info
Name | systemModel
Base Classes | Model
Abstract | false
Leaf | false
Root | false


Stereotype refine Report

Report: | General Info

UML Standard Profile
Stereotype refine

General Info
Name | refine
Base Classes | Abstraction
Abstract | false
Leaf | false
Root | false


Stereotype invariant Report

Report: | General Info

UML Standard Profile
Stereotype invariant

Specifies a constraint that must be attached to a set of classifiers or relationships. It indicates that the conditions of the constraint must hold over time (for the time period of concern in the particular containing element) for the classifiers or relationships and their instances.

General Info
Name | invariant
Base Classes | Constraint
Abstract | false
Leaf | false
Root | false


Stereotype friend Report

Report: | General Info

UML Standard Profile
Stereotype friend

Friend is a stereotyped permission dependency whose source is a model element, such as an operation, class, or package, and whose target is a model element in a different package, such as an operation, class or package. A friend relationship grants the source access to the target regardless of the declared visibility. It extends the visibility of the supplier so that the client can see into the supplier.

General Info
Name | friend
Base Classes | Permission
Abstract | false
Leaf | false
Root | false


Stereotype destroy Report

Report: | General Info

UML Standard Profile
Stereotype destroy

Specifies that the designated feature destroys an instance of the BehavioralFeature classifier to which the feature is attached. May be promoted to the classifier containing the feature.

General Info
Name | destroy
Base Classes | BehavioralFeature
Abstract | false
Leaf | false
Root | false


Stereotype global Report

Report: | General Info

UML Standard Profile
Stereotype global

Specifies that the target is a global value that is known to all elements AssociationEnd rather than an actual association.

General Info
Name | global
Base Classes | AssociationEnd
Abstract | false
Leaf | false
Root | false


Stereotype parameter Report

Report: | General Info

UML Standard Profile
Stereotype parameter

Parameter is a constraint applied to a link-end, specifying that the corresponding instance is visible because it is in a parameter scope relative to the link.

General Info
Name | parameter
Base Classes | LinkEnd
Abstract | false
Leaf | false
Root | false


Stereotype entity Report

Report: | General Info

UML Standard Profile
Stereotype entity

An entity is a passive class; that is, its objects do not initiate interactions on their own. An entity object may participate in many different use case realizations and usually outlives any single interaction.

General Info
Name | entity
Base Classes | Class
Abstract | false
Leaf | false
Root | false


Stereotype call Report

Report: | General Info

UML Standard Profile
Stereotype call

Call is a stereotyped usage dependency whose source is an operation and whose target is an operation. The relationship may also be subsumed to the class containing an operation, with the meaning that there exists an operation in the class to which the dependency applies. A call dependency specifies that the source operation or an operation in the source class invokes the target operation or an operation in the target class. A call dependency may connect a source operation to any target operation that is within scope including, but not limited to, operations of the enclosing classifier and operations of other visible classifiers.

General Info
Name | call
Base Classes | Usage
Abstract | false
Leaf | false
Root | false


Stereotype time-out Report

Report: | General Info

UML Standard Profile
Stereotype time-out

A time-out message the sender sends for a given period of time while waiting for acknowledgment by recipient. The sender is freed up if the acknowledgment does not occur within the duration specified in the description.

General Info
Name | time-out
Base Classes | Message
Abstract | false
Leaf | false
Root | false


Stereotype responsibility Report

Report: | General Info

UML Standard Profile
Stereotype responsibility

Specifies a contract or an obligation of an element in its relationship Comment to other elements.

General Info
Name | responsibility
Base Classes | Comment
Abstract | false
Leaf | false
Root | false


Stereotype thread Report

Report: | General Info

UML Standard Profile
Stereotype thread

Classifier Specifies a classifier that represents a flow of control.

General Info
Name | thread
Base Classes | Classifier
Abstract | false
Leaf | false
Root | false


Stereotype self Report

Report: | General Info

UML Standard Profile
Stereotype self

Self is a constraint applied to a link-end, specifying that the corresponding instance is visible because it is the dispatcher of the request.

General Info
Name | self
Base Classes | LinkEnd
Abstract | false
Leaf | false
Root | false


Stereotype control Report

Report: | General Info

UML Standard Profile
Stereotype control

A control is a class whose objects manage interactions between collections of objects. A control class usually has behavior that is specific for one use case, and a control object usually does not outlive the use case realizations in which it participates.

General Info
Name | control
Base Classes | Class
Abstract | false
Leaf | false
Root | false


Stereotype global Report

Report: | General Info

UML Standard Profile
Stereotype global

Global is a constraint applied to a link-end, specifying that the corresponding instance is visible because it is in a global scope relative to the link.

General Info
Name | global
Base Classes | LinkEnd
Abstract | false
Leaf | false
Root | false


Stereotype send Report

Report: | General Info

UML Standard Profile
Stereotype send

«send» Usage Send is a stereotyped usage dependency whose source is an operation and whose target is a signal, specifying that the source sends the target signal.

General Info
Name | send
Base Classes | Usage
Abstract | false
Leaf | false
Root | false


Stereotype metaclass Report

Report: | General Info

UML Standard Profile
Stereotype metaclass

Specifies that the instances of the classifier are classes.

General Info
Name | metaclass
Base Classes | Classifier
Abstract | false
Leaf | false
Root | false


Stereotype document Report

Report: | General Info

UML Standard Profile
Stereotype document

Denotes a document.

General Info
Name | document
Base Classes | Component
Abstract | false
Leaf | false
Root | false


Stereotype executable Report

Report: | General Info

UML Standard Profile
Stereotype executable

Denotes a program that may be run on a node.

General Info
Name | executable
Base Classes | Component
Abstract | false
Leaf | false
Root | false


Stereotype file Report

Report: | General Info

UML Standard Profile
Stereotype file

Denotes a document containing source code or data.

General Info
Name | file
Base Classes | Component
Abstract | false
Leaf | false
Root | false


Stereotype library Report

Report: | General Info

UML Standard Profile
Stereotype library

Denotes a static or dynamic library.

General Info
Name | library
Base Classes | Component
Abstract | false
Leaf | false
Root | false


Stereotype implementationClass Report

Report: | General Info

UML Standard Profile
Stereotype implementationClass

Specifies the implementation of a class in some programming Class language in which an instance may not have more than one class. This is in contrast to a general UML Class, for which an instance may have multiple classes at one time and may gain or lose classes over time, and an object (a child of instance) may dynamically have multiple classes.

General Info
Name | implementationClass
Base Classes | Class
Abstract | false
Leaf | false
Root | false


Stereotype table Report

Report: | General Info

UML Standard Profile
Stereotype table

Denotes a data base table.

General Info
Name | table
Base Classes | Component
Abstract | false
Leaf | false
Root | false


Top Browser

Model Report

Classes/Interfaces
Diagrams

Dictionary

Models/Packages/Subsystems
Project: FieldWorks
Component View
Component View::Cellar
Component View::FeatSys
Component View::LangProj
Component View::Ling
Component View::Notebk
Component View::Scripture
Data types
UML Standard Profile